#configure terminal | Enter configure mode. |
(config)#interface lo | Enter interface mode. |
(config-if)#ip address 192.168.0.63/32 secondary | Set the IP address for the interface. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe2 | Enter interface mode. |
(config-if)#ip address 10.10.23.63/24 | Set the IP address for the interface. |
(config-if)#label-switching | Enable label switching on interface xe2. |
(config-if)#commit | Commit the transaction. |
(config)#router rsvp | Enter Configure Router mode. |
(config-router)#exit | Exit Router mode. |
(config)#interface xe2 | Enter interface mode. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#router ospf 100 | Configure the Routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process. |
(config-router)#router-id 192.168.0.63 | Configure OSPF router-ID same as loopback interface IP address |
(config-router)#network 10.10.23.0/24 area 0 | Define the network (10.10.23.0/24) on which OSPF runs and associate the area ID (0). |
(config-router)#network 192.168.0.63/32 area 0 | Set the IP address of the loopback interface to 192.168.0.63/32. |
(config-router)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#interface lo | Enter interface mode. |
(config-if)#ip address 192.168.0.60/32 secondary | Set the IP address for the interface. |
(config-if)#exit | Enable label switching on interface lo. |
(config)#interface xe2 | Enter interface mode. |
(config-if)#ip address 10.10.23.60/24 | Set the IP address for the interface. |
(config-if)#label-switching | Enable label switching on interface xe2. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe1 | Enter interface mode. |
(config-if)#ip address 10.10.21.60/24 | Set the IP address for the interface. |
(config-if)#label-switching | Enable label switching on interface xe1. |
(config-if)#commit | Commit the transaction. |
(config)#router rsvp | Enter Configure Router mode. |
(config-router)#exit | Exit Router mode. |
(config)#interface xe2 | Enter interface mode. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe1 | Enter interface mode. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#router ospf 100 | Configure the Routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process. |
(config-router)#router-id 192.168.0.60 | Configure OSPF router-ID same as loopback interface IP address |
(config-router)#network 10.10.23.0/24 area 0 | Define the first network (10.10.23.0/24) on which OSPF runs and associate the area ID (0). |
(config-router)#network 10.10.21.0/24 area 0 | Define the second network (10.10.21.0/24) on which OSPF runs and associate the area ID (0). |
(config-router)#network 192.168.0.60/32 area 0 | Set the IP address of the loopback interface to 192.168.0.63/32. |
(config-router)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#interface lo | Enter interface mode. |
(config-if)#ip address 192.168.0.90/32 secondary | Set the IP address for the interface. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe1 | Enter interface mode. |
(config-if)#ip address 10.10.21.90/24 | Set the IP address for the interface. |
(config-if)#label-switching | Enable label switching on interface xe2. |
(config-if)#commit | Commit the transaction. |
(config)#router rsvp | Enter Configure Router mode. |
(config-router)#exit | Exit Router mode. |
(config)#interface xe1 | Enter interface mode. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#router ospf 100 | Configure the Routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process. |
(config-router)#router-id 192.168.0.90 | Configure OSPF router-ID same as loopback interface IP address |
(config-router)#network 10.10.21.0/24 area 0 | Define the network (10.10.21.0/24) on which OSPF runs and associate the area ID (0). |
(config-router)#network 192.168.0.90/32 area 0 | Set the IP address of the loopback interface to 192.168.0.63/32. |
(config-router)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#rsvp-trunk T1 | Create an RSVP trunk T1 and enter the Trunk mode. |
(config-trunk)#no primary cspf | Specify no primary cspf since CSPF is enabled by default. |
(config-trunk)#to 192.168.0.90 | Specify the IPv4 egress (destination point) for the LSP. |
(config-trunk)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#rsvp-trunk T1 | Create an RSVP trunk T1 and enter the Trunk mode. |
(config-trunk)#to 192.168.0.90 | Specify the IPv4 egress (destination point) for the LSP. |
(config-trunk)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#router rsvp | Enable RSVP globally. |
(config-router)#rsvp-path PE2 | Configure RSVP path. |
(config-path)#rsvp-trunk T1 | Create an RSVP trunk T1 and enter the Trunk mode. |
(config-trunk)#map-route 90.90.90.0/24 | Specify the destination prefix that needs to mapped to this trunk. |
(config-trunk)#to 192.168.0.90 | Specify the IPv4 egress (destination point) for the LSP. |
(config-trunk)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#rsvp-path P1 | Create an RSVP Path P1 and enter the Path mode. |
(config-path)#10.10.23.60 strict | Configure this explicit route path as a strict hop. |
(config-path)#10.10.21.90 loose | Configure this explicit route path as a loose hop. |
(config-path)#exit | Exit Path mode. |
#configure terminal | Enter configure mode. |
(config)#rsvp-trunk T1 | Create an RSVP trunk T1 and enter the Trunk mode. |
(config-trunk)#no primary cspf | Since CSPF is enabled by default, specify no primary cspf if CSPF is not required. |
(config-trunk)#primary path P1 | Configure trunk T1 to use the defined path. |
(config-trunk)#to 192.168.0.90 | Specify the IPv4 egress (destination point) for the LSP. |
(config-trunk)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#rsvp-path myPath | Specify an RSVP path to be used. |
(config-path)#10.10.23.60 strict | Configure this explicit route path as a strict hop. |
(config-path)#exit | Exit Path mode. |
(config)#rsvp-path myPath2 | Specify an RSVP path to be used. |
(config-path)#10.10.23.60 loose | Configure this explicit route path as a loose hop. |
(config-path)#exit | Exit Path mode. |
(config)#rsvp-trunk T1 | Create an RSVP trunk T1 and enter the Trunk mode. |
(config-trunk)#no primary cspf | Since CSPF is enabled by default, specify no secondary cspf if CSPF is not required. |
(config-trunk)#primary path myPath | Specify an RSVP path to be used. |
(config-trunk)#no secondary cspf | Specify the no secondary cspf option for the Secondary LSP. |
(config-trunk)#secondary path myPath2 | Specify an RSVP path to be used. |
(config-trunk)#to 192.168.0.90 | Specify the IPv4 egress (destination point) for the LSP. |
(config-trunk)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#interface lo | Enter interface mode |
(config-if)#ip address 47.47.47.47/32 secondary | Set the secondary IP address for the lo interface |
(config-if)#exit | Exit interface mode. |
(config)#router rsvp | Enable RSVP globally. |
(config-router)#exit | Exit RSVP mode. |
(config)#interface vlan1.2 | Enter the interface mode. |
(config-if)#ip address 10.10.23.1/24 | Configure the IP Address |
(config-if)#mtu 1600 | Configure MTU size. |
(config-if)#label-switching | Enable MPLS. |
(config-if)#ip ospf network point-to-point | Enable OSPF point-to-point network type. |
(config-if)#enable-rsvp | Enable RSVP at the interface level. |
(config-if)#exit | Exit the interface mode. |
(config)#interface vlan1.3 | Enter the interface mode. |
(config-if)#ip address 10.10.24.1/24 | Configure the IP Address |
(config-if)#mtu 1600 | Configure MTU size. |
(config-if)#label-switching | Enable MPLS. |
(config-if)#ip ospf network point-to-point | Enable OSPF point-to-point network type. |
(config-if)#enable-rsvp | Enable RSVP at the interface level. |
(config-if)#exit | Exit the interface mode. |
(config)#interface vlan1.4 | Enter the interface mode. |
(config-if)#ip address 10.10.25.1/24 | Configure the IP Address |
(config-if)#mtu 1600 | Configure MTU size. |
(config-if)#label-switching | Enable MPLS. |
(config-if)#ip ospf network point-to-point | Enable OSPF point-to-point network type. |
(config-if)#enable-rsvp | Enable RSVP at the interface level. |
(config-if)#exit | Exit the interface mode. |
(config)#interface vlan1.5 | Enter the interface mode. |
(config-if)#ip address 10.10.26.1/24 | Configure the IP Address |
(config-if)#mtu 1600 | Configure MTU size. |
(config-if)#label-switching | Enable MPLS. |
(config-if)#ip ospf network point-to-point | Enable OSPF point-to-point network type. |
(config-if)#enable-rsvp | Enable RSVP at the interface level. |
(config-if)#exit | Exit the interface mode. |
(config)#interface vlan1.6 | Enter the interface mode. |
(config-if)#ip address 10.10.27.1/24 | Configure the IP Address |
(config-if)#mtu 1600 | Configure MTU size. |
(config-if)#label-switching | Enable MPLS. |
(config-if)#ip ospf network point-to-point | Enable OSPF point-to-point network type. |
(config-if)#enable-rsvp | Enable RSVP at the interface level. |
(config-if)#exit | Exit the interface mode. |
(config)#interface vlan1.7 | Enter the interface mode. |
(config-if)#ip address 10.10.28.1/24 | Configure the IP Address |
(config-if)#mtu 1600 | Configure MTU size. |
(config-if)#label-switching | Enable MPLS. |
(config-if)#ip ospf network point-to-point | Enable OSPF point-to-point network type. |
(config-if)#enable-rsvp | Enable RSVP at the interface level. |
(config-if)#exit | Exit the interface mode. |
(config)#interface xe2 | Enter the interface mode. |
(config-if)#switchport | Configure Switchport |
(config-if)#bridge-group 1 | Assign a Bridge ID to the port channel |
(config-if)#switchport mode trunk | Configure trunk |
(config-if)#switchport trunk allowed vlan add 2,501 | Configure allowed VLANs |
(config-if)#switchport trunk native vlan 501 | Configure native VLAN. |
(config-if)#load-interval 30 | Set load interval |
(config-if)#mtu 9192 | Configure the MTU Size. |
(config-if)#exit | Exit the interface mode. |
(config)#interface xe3 | Enter the interface mode. |
(config-if)#switchport | Configure Switchport |
(config-if)#bridge-group 1 | Assign a Bridge ID to the port channel |
(config-if)#switchport mode trunk | Configure trunk |
(config-if)#switchport trunk allowed vlan add 3,502 | Configure allowed VLANs |
(config-if)#switchport trunk native vlan 502 | Configure native VLAN. |
(config-if)#load-interval 30 | Set load interval |
(config-if)#mtu 9192 | Configure the MTU Size. |
(config-if)#exit | Exit the interface mode. |
(config)#interface xe4 | Enter the interface mode. |
(config-if)#switchport | Configure Switchport |
(config-if)#bridge-group 1 | Assign a Bridge ID to the port channel |
(config-if)#switchport mode trunk | Configure trunk |
(config-if)#switchport trunk allowed vlan add 4,503 | Configure allowed VLANs |
(config-if)#switchport trunk native vlan 503 | Configure native VLAN. |
(config-if)#load-interval 30 | Set load interval |
(config-if)#mtu 9192 | Configure the MTU Size. |
(config-if)#exit | Exit the interface mode. |
(config)#interface xe5 | Enter the interface mode. |
(config-if)#switchport | Configure Switchport |
(config-if)#bridge-group 1 | Assign a Bridge ID to the port channel |
(config-if)#switchport mode trunk | Configure trunk |
(config-if)#switchport trunk allowed vlan add 5,504 | Configure allowed VLANs |
(config-if)#switchport trunk native vlan 504 | Configure native VLAN. |
(config-if)#load-interval 30 | Set load interval |
(config-if)#mtu 9192 | Configure the MTU Size. |
(config-if)#exit | Exit the interface mode. |
(config)#interface xe6 | Enter the interface mode. |
(config-if)#switchport | Configure Switchport |
(config-if)#bridge-group 1 | Assign a Bridge ID to the port channel |
(config-if)#switchport mode trunk | Configure trunk |
(config-if)#switchport trunk allowed vlan add 6,505 | Configure allowed VLANs |
(config-if)#switchport trunk native vlan 505 | Configure native VLAN. |
(config-if)#load-interval 30 | Set load interval |
(config-if)#mtu 9192 | Configure the MTU Size. |
(config-if)#exit | Exit the interface mode. |
(config)#interface xe7 | Enter the interface mode. |
(config-if)#switchport | Configure Switchport |
(config-if)#bridge-group 1 | Assign a Bridge ID to the port channel |
(config-if)#switchport mode trunk | Configure trunk |
(config-if)#switchport trunk allowed vlan add 7,506 | Configure allowed VLANs |
(config-if)#switchport trunk native vlan 506 | Configure native VLAN. |
(config-if)#load-interval 30 | Set load interval |
(config-if)#mtu 9192 | Configure the MTU Size. |
(config-if)#exit | Exit the interface mode. |
(conf)#rsvp-path p1-r1-r3 mpls | Create RSVP path |
(conf-path)#10.10.23.2 strict | Configure nexthop |
(conf-path)#10.10.21.2 strict | Configure nexthop |
(conf)#rsvp-path sp1-r1-r3 mpls | Create RSVP path |
(conf-path)#10.10.24.2 strict | Configure nexthop |
(conf-path)#10.10.22.2 strict | Configure nexthop |
(conf)#rsvp-path sp2-r1-r3 mpls | Create RSVP path |
(conf-path)#10.10.25.2 strict | Configure nexthop |
(conf-path)#10.10.29.2 strict | Configure nexthop |
(conf)#rsvp-path sp3-r1-r3 mpls | Create RSVP path |
(conf-path)#10.10.26.2 strict | Configure nexthop |
(conf-path)#10.10.30.2 strict | Configure nexthop |
(conf)#rsvp-path sp4-r1-r3 mpls | Create RSVP path |
(conf-path)#10.10.27.2 strict | Configure nexthop |
(conf-path)#10.10.31.2 strict | Configure nexthop |
(conf)#rsvp-path sp5-r1-r3 mpls | Create RSVP path |
(conf-path)#10.10.28.2 strict | Configure nexthop |
(conf-path)#10.10.32.2 strict | Configure nexthop |
(conf)#rsvp-trunk 47-49-test ipv4 | Create a RSVP trunk link |
(conf-trunk)#primary path p1-r1-r3 | Configure primary path for trunk link |
(conf-trunk)#secondary-priority 1 path sp1-r1-r3 | Configure secondary link for trunk link |
(conf-trunk)#secondary-priority 2 path sp2-r1-r3 | Configure secondary link for trunk link |
(conf-trunk)#secondary-priority 3 path sp3-r1-r3 | Configure secondary link for trunk link |
(conf-trunk)#secondary-priority 4 path sp4-r1-r3 | Configure secondary link for trunk link |
(conf-trunk)#secondary-priority 5 path sp5-r1-r3 | Configure secondary link for trunk link |
(conf-trunk)#to 49.49.49.49 | Configure remote node for the LSP |
(config-trunk)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#router ospf 100 | Configure the Routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process. |
(config-router)#ospf router-id 47.47.47.47 | Configure OSPF router-ID same as loopback interface IP address |
(config-router)#network 10.10.23.0/24 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router)#network 10.10.24.0/24 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router)#network 10.10.25.0/24 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router)#network 10.10.26.0/24 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router)#network 10.10.27.0/24 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router)#network 10.10.28.0/24 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router)#network 47.47.47.47/32 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router) #commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#interface lo | Enter interface mode |
(config-if)#ip address 46.46.46.46/32 secondary | Set the secondary IP address for the lo interface |
(config-if)#exit | Exit interface mode. |
(config)#router rsvp | Enable RSVP globally. |
(config-router)#exit | Exit RSVP mode. |
(config)#interface vlan1.2 | Enter the interface mode. |
(config-if)#ip address 10.10.23.2/24 | Configure the IP Address |
(config-if)#mtu 1600 | Configure MTU size. |
(config-if)#label-switching | Enable MPLS. |
(config-if)#ip ospf network point-to-point | Enable OSPF point-to-point network type. |
(config-if)#enable-rsvp | Enable RSVP at the interface level. |
(config-if)#exit | Exit the interface mode. |
(config)#interface vlan1.3 | Enter the interface mode. |
(config-if)#ip address 10.10.24.2/24 | Configure the IP Address |
(config-if)#mtu 1600 | Configure MTU size. |
(config-if)#label-switching | Enable MPLS. |
(config-if)#ip ospf network point-to-point | Enable OSPF point-to-point network type. |
(config-if)#enable-rsvp | Enable RSVP at the interface level. |
(config-if)#exit | Exit the interface mode. |
(config)#interface vlan1.4 | Enter the interface mode. |
(config-if)#ip address 10.10.25.2/24 | Configure the IP Address |
(config-if)#mtu 1600 | Configure MTU size. |
(config-if)#label-switching | Enable MPLS. |
(config-if)#ip ospf network point-to-point | Enable OSPF point-to-point network type. |
(config-if)#enable-rsvp | Enable RSVP at the interface level. |
(config-if)#exit | Exit the interface mode. |
(config)#interface vlan1.5 | Enter the interface mode. |
(config-if)#ip address 10.10.26.2/24 | Configure the IP Address |
(config-if)#mtu 1600 | Configure MTU size. |
(config-if)#label-switching | Enable MPLS. |
(config-if)#ip ospf network point-to-point | Enable OSPF point-to-point network type. |
(config-if)#enable-rsvp | Enable RSVP at the interface level. |
(config-if)#exit | Exit the interface mode. |
(config)#interface vlan1.6 | Enter the interface mode. |
(config-if)#ip address 10.10.27.2/24 | Configure the IP Address |
(config-if)#mtu 1600 | Configure MTU size. |
(config-if)#label-switching | Enable MPLS. |
(config-if)#ip ospf network point-to-point | Enable OSPF point-to-point network type. |
(config-if)#enable-rsvp | Enable RSVP at the interface level. |
(config-if)#exit | Exit the interface mode. |
(config)#interface vlan1.7 | Enter the interface mode. |
(config-if)#ip address 10.10.28.2/24 | Configure the IP Address |
(config-if)#mtu 1600 | Configure MTU size. |
(config-if)#label-switching | Enable MPLS. |
(config-if)#ip ospf network point-to-point | Enable OSPF point-to-point network type. |
(config-if)#enable-rsvp | Enable RSVP at the interface level. |
(config-if)#exit | Exit the interface mode. |
(config)#interface vlan1.9 | Enter the interface mode. |
(config-if)#ip address 10.10.21.1/24 | Configure the IP Address |
(config-if)#mtu 1600 | Configure MTU size. |
(config-if)#label-switching | Enable MPLS. |
(config-if)#ip ospf network point-to-point | Enable OSPF point-to-point network type. |
(config-if)#enable-rsvp | Enable RSVP at the interface level. |
(config-if)#exit | Exit the interface mode. |
(config)#interface vlan1.10 | Enter the interface mode. |
(config-if)#ip address 10.10.22.1/24 | Configure the IP Address |
(config-if)#mtu 1600 | Configure MTU size. |
(config-if)#label-switching | Enable MPLS. |
(config-if)#ip ospf network point-to-point | Enable OSPF point-to-point network type. |
(config-if)#enable-rsvp | Enable RSVP at the interface level. |
(config-if)#exit | Exit the interface mode. |
(config)#interface vlan1.11 | Enter the interface mode. |
(config-if)#ip address 10.10.29.1/24 | Configure the IP Address |
(config-if)#mtu 1600 | Configure MTU size. |
(config-if)#label-switching | Enable MPLS. |
(config-if)#ip ospf network point-to-point | Enable OSPF point-to-point network type. |
(config-if)#enable-rsvp | Enable RSVP at the interface level. |
(config-if)#exit | Exit the interface mode. |
(config)#interface vlan1.12 | Enter the interface mode. |
(config-if)#ip address 10.10.30.1/24 | Configure the IP Address |
(config-if)#mtu 1600 | Configure MTU size. |
(config-if)#label-switching | Enable MPLS. |
(config-if)#ip ospf network point-to-point | Enable OSPF point-to-point network type. |
(config-if)#enable-rsvp | Enable RSVP at the interface level. |
(config-if)#exit | Exit the interface mode. |
(config)#interface vlan1.13 | Enter the interface mode. |
(config-if)#ip address 10.10.31.1/24 | Configure the IP Address |
(config-if)#mtu 1600 | Configure MTU size. |
(config-if)#label-switching | Enable MPLS. |
(config-if)#ip ospf network point-to-point | Enable OSPF point-to-point network type. |
(config-if)#enable-rsvp | Enable RSVP at the interface level. |
(config-if)#exit | Exit the interface mode. |
(config)#interface vlan1.14 | Enter the interface mode. |
(config-if)#ip address 10.10.32.1/24 | Configure the IP Address |
(config-if)#mtu 1600 | Configure MTU size. |
(config-if)#label-switching | Enable MPLS. |
(config-if)#ip ospf network point-to-point | Enable OSPF point-to-point network type. |
(config-if)#enable-rsvp | Enable RSVP at the interface level. |
(config-if)#exit | Exit the interface mode. |
(config)#interface xe2 | Enter the interface mode. |
(config-if)#switchport | Configure Switchport |
(config-if)#bridge-group 1 | Assign a Bridge ID to the port channel |
(config-if)#switchport mode trunk | Configure trunk |
(config-if)#switchport trunk allowed vlan add 2,507 | Configure allowed VLANs |
(config-if)#switchport trunk native vlan 507 | Configure native VLAN. |
(config-if)#load-interval 30 | Set load interval |
(config-if)#mtu 9192 | Configure the MTU Size. |
(config-if)#exit | Exit the interface mode. |
(config)#interface xe3 | Enter the interface mode. |
(config-if)#switchport | Configure Switchport |
(config-if)#bridge-group 1 | Assign a Bridge ID to the port channel |
(config-if)#switchport mode trunk | Configure trunk |
(config-if)#switchport trunk allowed vlan add 3,508 | Configure allowed VLANs |
(config-if)#switchport trunk native vlan 508 | Configure native VLAN. |
(config-if)#load-interval 30 | Set load interval |
(config-if)#mtu 9192 | Configure the MTU Size. |
(config-if)#exit | Exit the interface mode. |
(config)#interface xe4 | Enter the interface mode. |
(config-if)#switchport | Configure Switchport |
(config-if)#bridge-group 1 | Assign a Bridge ID to the port channel |
(config-if)#switchport mode trunk | Configure trunk |
(config-if)#switchport trunk allowed vlan add 4,509 | Configure allowed VLANs |
(config-if)#switchport trunk native vlan 509 | Configure native VLAN. |
(config-if)#load-interval 30 | Set load interval |
(config-if)#mtu 9192 | Configure the MTU Size. |
(config-if)#exit | Exit the interface mode. |
(config)#interface xe5 | Enter the interface mode. |
(config-if)#switchport | Configure Switchport |
(config-if)#bridge-group 1 | Assign a Bridge ID to the port channel |
(config-if)#switchport mode trunk | Configure trunk |
(config-if)#switchport trunk allowed vlan add 5,510 | Configure allowed VLANs |
(config-if)#switchport trunk native vlan 510 | Configure native VLAN. |
(config-if)#load-interval 30 | Set load interval |
(config-if)#mtu 9192 | Configure the MTU Size. |
(config-if)#exit | Exit the interface mode. |
(config)#interface xe6 | Enter the interface mode. |
(config-if)#switchport | Configure Switchport |
(config-if)#bridge-group 1 | Assign a Bridge ID to the port channel |
(config-if)#switchport mode trunk | Configure trunk |
(config-if)#switchport trunk allowed vlan add 6,511 | Configure allowed VLANs |
(config-if)#switchport trunk native vlan 511 | Configure native VLAN. |
(config-if)#load-interval 30 | Set load interval |
(config-if)#mtu 9192 | Configure the MTU Size. |
(config-if)#exit | Exit the interface mode. |
(config)#interface xe7 | Enter the interface mode. |
(config-if)#switchport | Configure Switchport |
(config-if)#bridge-group 1 | Assign a Bridge ID to the port channel |
(config-if)#switchport mode trunk | Configure trunk |
(config-if)#switchport trunk allowed vlan add 7,512 | Configure allowed VLANs |
(config-if)#switchport trunk native vlan 512 | Configure native VLAN. |
(config-if)#load-interval 30 | Set load interval |
(config-if)#mtu 9192 | Configure the MTU Size. |
(config-if)#exit | Exit the interface mode. |
(config)#interface xe9 | Enter the interface mode. |
(config-if)#switchport | Configure Switchport |
(config-if)#bridge-group 1 | Assign a Bridge ID to the port channel |
(config-if)#switchport mode trunk | Configure trunk |
(config-if)#switchport trunk allowed vlan add 9,513 | Configure allowed VLANs |
(config-if)#switchport trunk native vlan 513 | Configure native VLAN. |
(config-if)#load-interval 30 | Set load interval |
(config-if)#mtu 9192 | Configure the MTU Size. |
(config-if)#exit | Exit the interface mode. |
(config)#interface xe10 | Enter the interface mode. |
(config-if)#switchport | Configure Switchport |
(config-if)#bridge-group 1 | Assign a Bridge ID to the port channel |
(config-if)#switchport mode trunk | Configure trunk |
(config-if)#switchport trunk allowed vlan add 10,514 | Configure allowed VLANs |
(config-if)#switchport trunk native vlan 514 | Configure native VLAN. |
(config-if)#load-interval 30 | Set load interval |
(config-if)#mtu 9192 | Configure the MTU Size. |
(config-if)#exit | Exit the interface mode. |
(config)#interface xe11 | Enter the interface mode. |
(config-if)#switchport | Configure Switchport |
(config-if)#bridge-group 1 | Assign a Bridge ID to the port channel |
(config-if)#switchport mode trunk | Configure trunk |
(config-if)#switchport trunk allowed vlan add 11,515 | Configure allowed VLANs |
(config-if)#switchport trunk native vlan 515 | Configure native VLAN. |
(config-if)#load-interval 30 | Set load interval |
(config-if)#mtu 9192 | Configure the MTU Size. |
(config-if)#exit | Exit the interface mode. |
(config)#interface xe12 | Enter the interface mode. |
(config-if)#switchport | Configure Switchport |
(config-if)#bridge-group 1 | Assign a Bridge ID to the port channel |
(config-if)#switchport mode trunk | Configure trunk |
(config-if)#switchport trunk allowed vlan add 12,516 | Configure allowed VLANs |
(config-if)#switchport trunk native vlan 516 | Configure native VLAN. |
(config-if)#load-interval 30 | Set load interval |
(config-if)#mtu 9192 | Configure the MTU Size. |
(config-if)#exit | Exit the interface mode. |
(config)#interface xe13 | Enter the interface mode. |
(config-if)#switchport | Configure Switchport |
(config-if)#bridge-group 1 | Assign a Bridge ID to the port channel |
(config-if)#switchport mode trunk | Configure trunk |
(config-if)#switchport trunk allowed vlan add 13,517 | Configure allowed VLANs |
(config-if)#switchport trunk native vlan 517 | Configure native VLAN. |
(config-if)#load-interval 30 | Set load interval |
(config-if)#mtu 9192 | Configure the MTU Size. |
(config-if)#exit | Exit the interface mode. |
(config)#interface xe14 | Enter the interface mode. |
(config-if)#switchport | Configure Switchport |
(config-if)#bridge-group 1 | Assign a Bridge ID to the port channel |
(config-if)#switchport mode trunk | Configure trunk |
(config-if)#switchport trunk allowed vlan add 14,518 | Configure allowed VLANs |
(config-if)#switchport trunk native vlan 518 | Configure native VLAN. |
(config-if)#load-interval 30 | Set load interval |
(config-if)#mtu 9192 | Configure the MTU Size. |
(config-if)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#router ospf 100 | Configure the Routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process. |
(config-router)#ospf router-id 46.46.46.46 | Configure OSPF router-ID same as loopback interface IP address |
(config-router)#network 10.10.21.0/24 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router)#network 10.10.22.0/24 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router)#network 10.10.23.0/24 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router)#network 10.10.24.0/24 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router)#network 10.10.25.0/24 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router)#network 10.10.26.0/24 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router)#network 10.10.27.0/24 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router)#network 10.10.28.0/24 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router)#network 10.10.29.0/24 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router)#network 10.10.30.0/24 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router)#network 10.10.31.0/24 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router)#network 10.10.32.0/24 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router)#network 46.46.46.46/32 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router) #commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#interface lo | Enter interface mode |
(config-if)#ip address 49.49.49.49/32 secondary | Set the secondary IP address for the lo interface |
(config-if)#exit | Exit interface mode. |
(config)#router rsvp | Enable RSVP globally. |
(config-router)#exit | Exit RSVP mode. |
(config)#interface vlan1.9 | Enter the interface mode. |
(config-if)#ip address 10.10.21.2/24 | Configure the IP Address |
(config-if)#mtu 1600 | Configure MTU size. |
(config-if)#label-switching | Enable MPLS. |
(config-if)#ip ospf network point-to-point | Enable OSPF point-to-point network type. |
(config-if)#enable-rsvp | Enable RSVP at the interface level. |
(config-if)#exit | Exit the interface mode. |
(config)#interface vlan1.10 | Enter the interface mode. |
(config-if)#ip address 10.10.22.2/24 | Configure the IP Address |
(config-if)#mtu 1600 | Configure MTU size. |
(config-if)#label-switching | Enable MPLS. |
(config-if)#ip ospf network point-to-point | Enable OSPF point-to-point network type. |
(config-if)#enable-rsvp | Enable RSVP at the interface level. |
(config-if)#exit | Exit the interface mode. |
(config)#interface vlan1.11 | Enter the interface mode. |
(config-if)#ip address 10.10.29.2/24 | Configure the IP Address |
(config-if)#mtu 1600 | Configure MTU size. |
(config-if)#label-switching | Enable MPLS. |
(config-if)#ip ospf network point-to-point | Enable OSPF point-to-point network type. |
(config-if)#enable-rsvp | Enable RSVP at the interface level. |
(config-if)#exit | Exit the interface mode. |
(config)#interface vlan1.12 | Enter the interface mode. |
(config-if)#ip address 10.10.30.2/24 | Configure the IP Address |
(config-if)#mtu 1600 | Configure MTU size. |
(config-if)#label-switching | Enable MPLS. |
(config-if)#ip ospf network point-to-point | Enable OSPF point-to-point network type. |
(config-if)#enable-rsvp | Enable RSVP at the interface level. |
(config-if)#exit | Exit the interface mode. |
(config)#interface vlan1.13 | Enter the interface mode. |
(config-if)#ip address 10.10.31.2/24 | Configure the IP Address |
(config-if)#mtu 1600 | Configure MTU size. |
(config-if)#label-switching | Enable MPLS. |
(config-if)#ip ospf network point-to-point | Enable OSPF point-to-point network type. |
(config-if)#enable-rsvp | Enable RSVP at the interface level. |
(config-if)#exit | Exit the interface mode. |
(config)#interface vlan1.14 | Enter the interface mode. |
(config-if)#ip address 10.10.32.2/24 | Configure the IP Address |
(config-if)#mtu 1600 | Configure MTU size. |
(config-if)#label-switching | Enable MPLS. |
(config-if)#ip ospf network point-to-point | Enable OSPF point-to-point network type. |
(config-if)#enable-rsvp | Enable RSVP at the interface level. |
(config-if)#exit | Exit the interface mode. |
(config)#interface xe9 | Enter the interface mode. |
(config-if)#switchport | Configure Switchport |
(config-if)#bridge-group 1 | Assign a Bridge ID to the port channel |
(config-if)#switchport mode trunk | Configure trunk |
(config-if)#switchport trunk allowed vlan add 9,519 | Configure allowed VLANs |
(config-if)#switchport trunk native vlan 519 | Configure native VLAN. |
(config-if)#load-interval 30 | Set load interval |
(config-if)#mtu 9192 | Configure the MTU Size. |
(config-if)#exit | Exit the interface mode. |
(config)#interface xe10 | Enter the interface mode. |
(config-if)#switchport | Configure Switchport |
(config-if)#bridge-group 1 | Assign a Bridge ID to the port channel |
(config-if)#switchport mode trunk | Configure trunk |
(config-if)#switchport trunk allowed vlan add 10,520 | Configure allowed VLANs |
(config-if)#switchport trunk native vlan 520 | Configure native VLAN. |
(config-if)#load-interval 30 | Set load interval |
(config-if)#mtu 9192 | Configure the MTU Size. |
(config-if)#exit | Exit the interface mode. |
(config)#interface xe11 | Enter the interface mode. |
(config-if)#switchport | Configure Switchport |
(config-if)#bridge-group 1 | Assign a Bridge ID to the port channel |
(config-if)#switchport mode trunk | Configure trunk |
(config-if)#switchport trunk allowed vlan add 11,521 | Configure allowed VLANs |
(config-if)#switchport trunk native vlan 521 | Configure native VLAN. |
(config-if)#load-interval 30 | Set load interval |
(config-if)#mtu 9192 | Configure the MTU Size. |
(config-if)#exit | Exit the interface mode. |
(config)#interface xe12 | Enter the interface mode. |
(config-if)#switchport | Configure Switchport |
(config-if)#bridge-group 1 | Assign a Bridge ID to the port channel |
(config-if)#switchport mode trunk | Configure trunk |
(config-if)#switchport trunk allowed vlan add 12,522 | Configure allowed VLANs |
(config-if)#switchport trunk native vlan 522 | Configure native VLAN. |
(config-if)#load-interval 30 | Set load interval |
(config-if)#mtu 9192 | Configure the MTU Size. |
(config-if)#exit | Exit the interface mode. |
(config)#interface xe13 | Enter the interface mode. |
(config-if)#switchport | Configure Switchport |
(config-if)#bridge-group 1 | Assign a Bridge ID to the port channel |
(config-if)#switchport mode trunk | Configure trunk |
(config-if)#switchport trunk allowed vlan add 13,523 | Configure allowed VLANs |
(config-if)#switchport trunk native vlan 523 | Configure native VLAN. |
(config-if)#load-interval 30 | Set load interval |
(config-if)#mtu 9192 | Configure the MTU Size. |
(config-if)#exit | Exit the interface mode. |
(config)#interface xe14 | Enter the interface mode. |
(config-if)#switchport | Configure Switchport |
(config-if)#bridge-group 1 | Assign a Bridge ID to the port channel |
(config-if)#switchport mode trunk | Configure trunk |
(config-if)#switchport trunk allowed vlan add 14,524 | Configure allowed VLANs |
(config-if)#switchport trunk native vlan 524 | Configure native VLAN. |
(config-if)#load-interval 30 | Set load interval |
(config-if)#mtu 9192 | Configure the MTU Size. |
(config-if)#exit | Exit the interface mode. |
(conf)#rsvp-path sp1-r3-r1 mpls | Create RSVP path |
(conf-path)#10.10.21.1 strict | Configure nexthop |
(conf-path)#10.10.23.1 strict | Configure nexthop |
(conf)#rsvp-path sp2-r3-r1 mpls | Create RSVP path |
(conf-path)#10.10.22.1 strict | Configure nexthop |
(conf-path)#10.10.24.1 strict | Configure nexthop |
(conf)#rsvp-path sp2-r3-r1 mpls | Create RSVP path |
(conf-path)#10.10.29.2 strict | Configure nexthop |
(conf-path)#10.10.25.1 strict | Configure nexthop |
(conf)#rsvp-path sp3-r3-r1 mpls | Create RSVP path |
(conf-path)#10.10.30.1 strict | Configure nexthop |
(conf-path)#10.10.26.1 strict | Configure nexthop |
(conf)#rsvp-path sp4-r3-r1 mpls | Create RSVP path |
(conf-path)#10.10.31.1 strict | Configure nexthop |
(conf-path)#10.10.27.1 strict | Configure nexthop |
(conf)#rsvp-path sp5-r3-r1 mpls | Create RSVP path |
(conf-path)#10.10.32.1 strict | Configure nexthop |
(conf-path)#10.10.28.1 strict | Configure nexthop |
(conf)#rsvp-trunk 49-47-test ipv4 | Create a RSVP trunk link |
(conf-trunk)#primary path p1-r3-r1 | Configure primary path for trunk link |
(conf-trunk)#secondary-priority 1 path sp1-r3-r1 | Configure secondary link for trunk link |
(conf-trunk)#secondary-priority 2 path sp2-r3-r1 | Configure secondary link for trunk link |
(conf-trunk)#secondary-priority 3 path sp3-r3-r1 | Configure secondary link for trunk link |
(conf-trunk)#secondary-priority 4 path sp4-r3-r1 | Configure secondary link for trunk link |
(conf-trunk)#secondary-priority 5 path sp5-r3-r1 | Configure secondary link for trunk link |
(conf-trunk)#to 47.47.47.47 | Configure remote node for the LSP |
(conf-trunk)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#router ospf 100 | Configure the Routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process. |
(config-router)#ospf router-id 49.49.49.49 | Configure OSPF router-ID same as loopback interface IP address |
(config-router)#network 10.10.21.0/24 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router)#network 10.10.22.0/24 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router)#network 10.10.29.0/24 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router)#network 10.10.30.0/24 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router)#network 10.10.31.0/24 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router)#network 10.10.32.0/24 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router)#network 49.49.49.49/32 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router) #commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#admin-group A 0 | Add new administrative groups, specify their names and assign bit values to them. |
(config)#admin-group B 1 | |
(config)#admin-group C 2 | |
(config)#admin-group D 3 | |
(config)#admin-group E 4 | |
(config)#interface xe0 | Enter interface mode. |
(config-if)#admin-group A | Add administrative groups to the links. When used in the interface mode, this command adds a link between an interface and a group. The name is the name of the group previously configured. You can have multiple groups per interface. |
(config-if)#admin-group B | |
(config-if)#admin-group C | |
(config-if)#exit | Exit interface mode. |
(config)#interface xe2 | Enter interface mode. |
(config-if)#admin-group E | Add administrative groups to the links. When used in the interface mode, this command adds a link between an interface and a group. The name is the name of the group previously configured. You can have multiple groups per interface. |
(config-if)#admin-group D | |
(config-if)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#admin-group A 0 | Add new administrative groups and specify their names and assign bit values to them. |
(config)#admin-group C 2 | |
(config)#interface xe2 | Enter interface mode |
(config-if)#admin-group A | Add administrative groups to the links. When used in the interface mode, this command adds a link between an interface and a group. The name is the name of the group previously configured. You can have multiple groups per interface. |
(config-if)#admin-group C | |
(config-if)#commit | Commit the transaction. |
(config)#router rsvp | Enter the router mode for RSVP. |
(config-router)#rsvp-path P1 | Configure RSVP path. |
#configure terminal | Enter configure mode. |
(config)#rsvp-trunk T1 | Create an RSVP trunk T1 and enter the Trunk mode. |
(config-trunk)#no primary cspf | Since CSPF is enabled by default, specify no primary cspf if CSPF is not required. |
(config-trunk)#primary path P1 | Specify an RSVP primary path to be used. |
(config-trunk)#no primary cspf | Specify the no primary cspf option for the LSP. |
(config-trunk)#primary include-any A | Set up the LSP with admin group constraint A. |
(config-trunk)#primary include-any C | Set up the LSP with admin group constraint C. |
(config-trunk)#to 192.168.0.90 | Specify the IPv4 egress (destination point) for the LSP. |
(config-trunk)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#router rsvp | Enter the router mode for RSVP. |
(config-router)#hello-interval 10 | Set the hello-interval (in seconds) between hello packets. |
(config-router)#hello-timeout 35 | Set the hello-timeout value. If an LSR has not received a Hello message from a peer within this period, all sessions shared with this peer are reset. |
(config-router)#neighbor 10.10.23.60 | Explicitly specify the neighbor to exchange Hello messages with. |
(config-router)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#router rsvp | Enter the router mode for RSVP. |
(config-router)#hello-interval 10 | Set the hello-interval (in seconds) between hello packets. |
(config-router)#hello-timeout 35 | Set the hello-timeout value. If an LSR has not received a Hello message from a peer within this period, all sessions shared with this peer are reset. |
(config-router)#neighbor 10.10.23.63 | Explicitly specify the neighbor to exchange Hello messages with. |
(config-router)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#interface lo | Enter interface mode. |
(config-if)#ip address 29.29.29.29/32 secondary | Set a secondary IP address of the interface |
(config-if)#no shutdown | Administratively bring the interface up. |
(config-if)#exit | Exit interface mode. |
(config)#router-id 29.29.29.29 | Configure the router ID. |
(config)#router rsvp | Enter to router rsvp mode. |
(config-router)#exit | Exit the router mode |
(config)#router ldp | Enter to router LDP mode. |
(config-router)#targeted-peer ipv4 30.30.30.30 | Configure targeted peer. |
(config-router-targeted-peer)#exit-targeted-peer-mode | Exit-targeted-peer-mode |
(config-router)#exit | Exit router mode |
(config)#interface xe21 | Enter interface mode. |
(config-if)#label-switching | Enable label switching on interface. |
(config-if)#ip address 21.21.21.29/24 | Set an IP address of the interface. |
(config-if)#no shutdown | Administratively no shutdown the interface. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#enable-ldp ipv4 | Enable LDP on this interface |
(config-if)#exit | Exit interface mode. |
(config)#interface xe22 | Enter interface mode. |
(config-if)#label-switching | Enable label switching on interface |
(config-if)#enable-ldp ipv4 | Enable LDP on this interface |
(config-if)#ip address 22.22.22.29/24 | Set an IP address of the interface. |
(config-if)#no shutdown | Administratively no shutdown the interface. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#router ospf | Enter the router configure mode for OSPF. |
(config-router)#router-id 29.29.29.29 | Configure OSPF router-ID same as loopback interface IP address |
(config-router)#network 21.21.21.0/24 area 0 (config-router)#network 22.22.22.0/24 area 0 (config-router)#network 29.29.29.29/32 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router)#exit | Exit the router configure mode. |
(config)#rsvp-path p21 | Enter the path mode for RSVP pt1. |
(config-path)#21.21.21.43 strict | Configure this explicit route path as a strict hop. |
(config-path)#38.38.38.42 strict | Configure this explicit route path as a strict hop. |
(config-path)#69.69.69.30 strict | Configure this explicit route path as a strict hop. |
(config)#exit | Exit the path mode. |
(config)#rsvp-trunk to_30 ipv4 | Enter the trunk mode for RSVP. |
(config-trunk)#primary fast-reroute protection one-to-one | Configure primary fast-reroute protection facility for a trunk. |
(config-trunk)#primary fast-reroute node-protection | Configure primary fast-reroute node protection for the trunk |
(config-trunk)#primary path p21 | Configure trunk to 30 to use the defined path. |
(config-trunk)#to 30.30.30.30 | Specify the IPv4 egress (destination point) for the LSP. |
(config-trunk)#exit | Exit from trunk mode. |
(config)#ip vrf vrf1 | Configure VRF instance |
(config-vrf)#rd 100:1 | Configure Router Distinguisher value |
(config-vrf)#route-target both 100:1 | Configure route-target as both |
(config-vrf)#exit | Exit the path mode. |
(config)#interface xe43 | Enter to the interface mode |
(config-if)#ip vrf forwarding vrf1 | Bind the VRF instance to the interface |
(config-if)#ip address 43.43.43.29/24 | Configure IP address |
(config-if)#exit | Exit interface mode. |
(config)#router bgp 100 | Configure BGP router instance |
(config-router)#neighbor 30.30.30.30 remote-as 100 | Configure neighbor with remote-as |
(config-router)#neighbor 30.30.30.30 update-source 29.29.29.29 | Configure update source as loopback address |
(config-router)#address-family vpnv4 unicast | Configure VPNv4 address family |
(config-router-af)#neighbor 30.30.30.30 activate | Activate the VPN neighbor |
(config-router-af)#exit-address-family | Exit the VPN address family |
(config-router)#address-family ipv4 vrf vrf1 | Configure VRF address family |
(config-router-af)redistribute connected | Redistribute connected route |
(config-router-af)exit-address-family | Exit VRF address family |
(config-router)#exit | Exit router mode |
(config)#mpls l2-circuit vlan10 10 30.30.30.30 | Configure Virtual circuit. |
(config-pseudowire)#exit | Exit pseudowire config mode. |
(config)#service-template st1 | Template configuration |
(config-svc)#match outer-vlan 10 | Match criteria under template configuration |
(config-svc)#exit | Exit service template mode |
(config)#service-template st2 | Template configuration |
(config-svc)#match outer-vlan 30 | Match criteria under template configuration |
(config-svc)#exit | Exit service template mode |
(config)#interface xe44 | Enter interface configuration mode |
(config-if)#switchport | Configure interface as switch port |
(config-if)#mpls-l2-circuit t1 service-template st1 | Bind the interface to the VC with service template |
(config-if)#exit | Exit interface configuration mode |
(config)#mpls vpls vpls30 30 | Configure VPLS instance |
(config-vpls)#signaling ldp | Configure VPLS signaling as LDP |
(config-vpls-sig)#vpls-type vlan | Configure VPLS type as VLAN encapsulation |
(config-vpls-sig)#vpls-peer 30.30.30.30 | Configure VPLS peer |
(config-vpls-sig)#exit-signaling | Exit VPLS configuration mode |
(config)#interface xe45 | Enter interface configuration mode |
(config-if)#switchport | Configure interface as switch port |
(config-if)#mpls-vpls vpls30 service-template st2 | Bind the VPLS instance to the interface |
(config-if-vpls)#split-horizon group access1 | Configure split-horizon group on VPLS |
(config-if-vpls)#exit | Exit VPLS attachment-circuit mode |
(config-if)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#interface lo | Enter interface mode. |
(config-if)#ip address 43.43.43.43/32 secondary | Set a secondary IP address of the interface |
(config-if)#no shutdown | Administratively shutdown the interface. |
(config-if)#exit | Exit interface mode. |
(config)#router-id 43.43.43.43 | Configure the router ID. |
(config)#router rsvp | Enter to router RSVP mode. |
(config-router)#exit | Exit the router mode |
(config)#interface xe5/1 | Enter interface mode. |
(config-if)#label-switching | Enable label switching on interface. |
(config-if)#ip address 11.11.11.43/24 | Set an IP address of the interface. |
(config-if)#no shutdown | Administratively no shutdown the interface. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe9/1 | Enter interface mode. |
(config-if)#label-switching | Enable label switching on interface |
(config-if)#ip address 21.21.21.43/24 | Set an IP address of the interface. |
(config-if)#no shutdown | Administratively no shutdown the interface. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe9/2 | Enter interface mode. |
(config-if)#label-switching | Enable label switching on interface. |
(config-if)#ip address 22.22.22.43/24 | Set an IP address of the interface. |
(config-if)#no shutdown | Administratively no shutdown the interface. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe13/2 | Enter interface mode. |
(config-if)#label-switching | Enable label switching on interface |
(config-if)#ip address 38.38.38.43/24 | Set an IP address of the interface. |
(config-if)#no shutdown | Administratively no shutdown the interface. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#router ospf | Enter the router configure mode for OSPF. |
(config-router)#router-id 43.43.43.43 | Configure OSPF router-ID same as loopback interface IP address |
(config-router)#network 11.11.11.0/24 area 0 (config-router)#network 22.22.22.0/24 area 0 (config-router)#network 21.21.21.0/24 area 0 (config-router)#network 38.38.38.0/24 area 0 (config-router)#network 43.43.43.43/32 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router)#commit | Commit the transaction. |
(config)#interface lo | Enter interface mode. |
(config-if)#ip address 42.42.42.42/32 secondary | Set a secondary IP address of the interface |
(config-if)#no shutdown | Administratively shutdown the interface. |
(config-if)#exit | Exit interface mode. |
(config)#router-id 42.42.42.42 | Configure the router ID. |
(config)#router rsvp | Enter to router RSVP mode. |
(config-router)#exit | Exit the router mode |
(config)#interface xe2 | Enter interface mode. |
(config-if)#label-switching | Enable label switching on interface. |
(config-if)#ip address 5.5.5.42/24 | Set an IP address of the interface. |
(config-if)#no shutdown | Administratively no shutdown the interface. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe10/1 | Enter interface mode. |
(config-if)#label-switching | Enable label switching on interface |
(config-if)#ip address 25.25.25.42/24 | Set an IP address of the interface. |
(config-if)#no shutdown | Administratively no shutdown the interface. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe3 | Enter interface mode. |
(config-if)#label-switching | Enable label switching on interface. |
(config-if)#ip address 38.38.38.42/24 | Set an IP address of the interface. |
(config-if)#no shutdown | Administratively no shutdown the interface. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe4 | Enter interface mode |
(config-if)#label-switching | Enable label switching on interface |
(config-if)#ip address 69.69.69.42/24 | Specify an IP address for the interface |
(config-if)#no shutdown | Administratively no shutdown the interface |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface |
(config-if)#exit | Exit interface mode |
(config)#router ospf | Enter the router configure mode for OSPF. |
(config-router)#router-id 42.42.42.42 | Configure OSPF router-ID same as loopback interface IP address |
(config-router)#network 5.5.5.0/24 area 0 (config-router)#network 25.25.25.0/24 area 0 (config-router)#network 69.69.69.0/24 area 0 (config-router)#network 38.38.38.0/24 area 0 (config-router)#network 42.42.42.42/32 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router)#commit | Commit the transaction |
(config)#interface lo | Enter interface mode. |
(config-if)#ip address 44.44.44.44/32 secondary | Set a secondary IP address of the interface |
(config-if)#no shutdown | Administratively no shutdown the interface. |
(config-if)#exit | Exit interface mode. |
(config)#router-id 44.44.44.44 | Configure the router ID. |
(config)#router rsvp | Enter to router RSVP mode. |
(config-router)#exit | Exit the router mode |
(config)#interface xe1/1 | Enter interface mode. |
(config-if)#label-switching | Enable label switching on interface. |
(config-if)#ip address 1.1.1.41/24 | Set an IP address of the interface. |
(config-if)#no shutdown | Administratively no shutdown the interface. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe2 | Enter interface mode. |
(config-if)#label-switching | Enable label switching on interface |
(config-if)#ip address 5.5.5.41/24 | Set an IP address of the interface. |
(config-if)#no shutdown | Administratively no shutdown the interface. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe5/1 | Enter interface mode. |
(config-if)#label-switching | Enable label switching on interface. |
(config-if)#ip address 11.11.11.41/24 | Set an IP address of the interface. |
(config-if)#no shutdown | Administratively no shutdown the interface. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#router ospf | Enter the router configure mode for OSPF. |
(config-router)#router-id 44.44.44.44 | Configure OSPF router-ID same as loopback interface IP address |
(config-router)#network 5.5.5.0/24 area 0 (config-router)#network 1.1.1.0/24 area 0 (config-router)#network 11.11.11.0/24 area 0 (config-router)#network 44.44.44.44/32 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router)#commit | Commit the transaction. |
(config)#interface lo | Enter interface mode. |
(config-if)#ip address 31.31.31.31/32 secondary | Set a secondary IP address of the interface |
(config-if)#no shutdown | Administratively shutdown the interface. |
(config-if)#exit | Exit interface mode. |
(config)#router-id 31.31.31.31 | Configure the router ID. |
(config)#router rsvp | Enter to router RSVP mode. |
(config-router)#exit | Exit the router mode |
(config)#interface xe1 | Enter interface mode. |
(config-if)#label-switching | Enable label switching on interface. |
(config-if)#ip address 1.1.1.31/24 | Set an IP address of the interface. |
(config-if)#no shutdown | Administratively no shutdown the interface. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe25 | Enter interface mode. |
(config-if)#label-switching | Enable label switching on interface |
(config-if)#ip address 25.25.25.31/24 | Set an IP address of the interface. |
(config-if)#no shutdown | Administratively no shutdown the interface. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe41 | Enter interface mode. |
(config-if)#label-switching | Enable label switching on interface. |
(config-if)#ip address 41.41.41.31/24 | Set an IP address of the interface. |
(config-if)#no shutdown | Administratively no shutdown the interface. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#router ospf | Enter the router configure mode for OSPF. |
(config-router)#router-id 31.31.31.31 | Configure OSPF router-ID same as loopback interface IP address |
(config-router)#network 1.1.1.0/24 area 0 (config-router)#network 25.25.25.0/24 area 0 (config-router)#network 41.41.41.0/24 area 0 (config-router)#network 31.31.31.31/32 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router)#commit | Commit the transaction. |
(config)#interface lo | Enter interface mode. |
(config-if)#ip address 30.30.30.30/32 secondary | Set a secondary IP address of the interface |
(config-if)#no shutdown | Administratively shutdown the interface. |
(config-if)#exit | Exit interface mode. |
(config)#router-id 30.30.30.30 | Configure the router ID. |
(config)#router rsvp | Enter to router RSVP mode. |
(config-router)#exit | Exit the router mode |
(config)#router ldp | Enter to router LDP mode. |
(config-router)#targeted-peer ipv4 29.29.29.29 | Configure targeted peer. |
(config-router-targeted-peer)#exit-targeted-peer-mode | Exit-targeted-peer-mode |
(config-router)#exit | Exit router mode |
(config)#interface xe41 | Enter interface mode. |
(config-if)#label-switching | Enable label switching on interface. |
(config-if)#ip address 41.41.41.30/24 | Set an IP address of the interface. |
(config-if)#no shutdown | Administratively no shutdown the interface. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#enable-ldp ipv4 | Enable LDP on this interface |
(config-if)#exit | Exit interface mode. |
(config)#interface xe54/1 | Enter interface mode. |
(config-if)#label-switching | Enable label switching on interface |
(config-if)#enable-ldp ipv4 | Enable LDP on this interface |
(config-if)#ip address 69.69.69.30/24 | Set an IP address of the interface. |
(config-if)#no shutdown | Administratively no shutdown the interface. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#router ospf | Enter the router configure mode for OSPF. |
(config-router)#router-id 30.30.30.30 | Configure OSPF router-ID same as loopback interface IP address |
(config-router)#network 41.41.41.0/24 area 0 (config-router)#network 69.69.69.0/24 area 0 (config-router)#network 30.30.30.30/32 area 0 | Define the network on which OSPF runs and associate the area ID |
(config-router)#commit | Commit the transaction. |
(config)#rsvp-path p41 | Enter the path mode for RSVP pt1. |
(config-path)#41.41.41.31 strict | Configure this explicit route path as a strict hop. |
(config-path)#1.1.1.41 strict | Configure this explicit route path as a strict hop. |
(config-path)#11.11.11.43 strict | Configure this explicit route path as a strict hop. |
(config)#exit | Exit the path mode. |
(config)#rsvp-trunk to_29 ipv4 | Enter the trunk mode for rsvp. |
(config-trunk)#primary fast-reroute protection one-to-one | Configure primary fast-reroute protection facility for a trunk. |
(config-trunk)#primary fast-reroute node-protection | Configure primary fast-reroute node protection for the trunk |
(config-trunk)#primary path p41 | Configure trunk to_29 to use the defined path. |
(config-trunk)#to 29.29.29.29 | Specify the IPv4 egress (destination point) for the LSP. |
(config-trunk)#exit | Exit from trunk mode. |
(config)#ip vrf vrf1 | Configure VRF instance |
(config-vrf)#rd 100:1 | Configure Router Distinguisher value |
(config-vrf)#route-target both 100:1 | Configure route-target as both |
(config-vrf)#exit | Exit the path mode. |
(config)#interface xe23 | Enter to the interface mode |
(config-if)#ip vrf forwarding vrf1 | Bind the VRF instance to the interface |
(config-if)#ip address 23.23.23.29/24 | Configure IP address |
(config-if)#exit | Exit interface mode. |
(config)#router bgp 100 | Configure BGP router instance |
(config-router)#neighbor 29.29.29.29 remote-as 100 | Configure neighbor with remote-as |
(config-router)#neighbor 29.29.29.29 update-source 30.30.30.30 | Configure update source as loopback address |
(config-router)#address-family vpnv4 unicast | Configure VPNv4 address family |
(config-router-af)#neighbor 29.29.29.29 activate | Activate the VPN neighbor |
(config-router-af)#exit-address-family | Exit the VPN address family |
(config-router)#address-family ipv4 vrf vrf1 | Configure VRF address family |
(config-router-af)redistribute connected | Redistribute connected route |
(config-router-af)exit-address-family | Exit VRF address family |
(config-router)#exit | Exit router mode |
(config)#mpls l2-circuit vlan10 10 29.29.29.29 | Configure Virtual circuit. |
(config-pseudowire)#exit | Exit pseudowire config mode. |
(config)#service-template st1 | Template configuration |
(config-svc)#match outer-vlan 10 | Match criteria under template configuration |
(config-svc)#exit | Exit service template mode |
(config)#service-template st2 | Template configuration |
(config-svc)#match outer-vlan 30 | Match criteria under template configuration |
(config-svc)#exit | Exit service template mode |
(config)#interface xe24 | Enter interface configuration mode |
(config-if)#switchport | Configure interface as switch port |
(config-if)#mpls-l2-circuit vlan10 service-template st1 | Bind the interface to the VC with service template |
(config-if)#exit | Exit interface configuration mode |
(config)#mpls vpls vpls30 30 | Configure VPLS instance |
(config-vpls)#signaling ldp | Configure VPLS signaling as LDP |
(config-vpls-sig)#vpls-type vlan | Configure VPLS type as VLAN encapsulation |
(config-vpls-sig)#vpls-peer 29.29.29.29 | Configure VPLS peer |
(config-vpls-sig)#exit-signaling | Exit VPLS configuration mode |
(config)#interface xe25 | Enter interface configuration mode |
(config-if)#switchport | Configure interface as switch port |
(config-if)#mpls-vpls vpls30 service-template st2 | Bind the VPLS instance to the interface |
(config-if-vpls)#split-horizon group access1 | Configure split-horizon group on VPLS |
(config-if-vpls)#exit | Exit VPLS attachment-circuit mode |
(config-if)#commit | Commit the transaction. |
#configure terminal | Enter configure mode. |
(config)#rsvp-trunk T1 | Create an RSVP trunk T1 and enter the Trunk mode. |
(config-trunk)#reoptimize | Enable re-optimization of the session. |
#configure terminal | Enter configure mode. |
(config)#router rsvp | Enter RSVP mode |
(config-router)#lsp-reoptimization-timer 5 | Sets the re-optimization timer for the session. |
(config)#rsvp-trunk t1 force-reoptimize | Re-optimize the LSP forcefully |