OcNOS-SP : Layer 3 Guide : Intermediate System to Intermediate System Command Reference : IS-IS Commands
IS-IS Commands
This chapter describes the IS-IS commands:
ispf
key-id
net
accept-lifetime
Use this command to specify the time period during which the authentication on a key chain is received as valid.
Use the no parameter with this command to negate this command.
Command Syntax
accept-lifetime HH:MM:SS MONTH <01-31> <1993-2035> HH:MM:SS MONTH <01-31> <1993-2035>
accept-lifetime HH:MM:SS MONTH <01-31> <1993-2035> infinite
accept-lifetime HH:MM:SS MONTH <01-31> <1993-2035> duration <1-2147483646>
no accept-lifetime
Parameters
HH:MM:SS
Specify the start time of accept-lifetime in hours, minutes and seconds.
<01-31>
Specify the day of the month to start. If the day is a single-digit, the leading 0 must be added, example: 01, 02, 03, etc.
MONTH
Specify the month of the year to start as the first three letters of the month with first letter in upper case, for example, Jan. (case sensitive).
<1993-2035>
Specify the year to start.
HH:MM:SS
Specify the end time of accept-lifetime in hours, minutes and seconds.
<01-31>
Specify the day of the month to end. If the day is a single-digit, the leading 0 must be added, example: 01, 02, 03, etc.
MONTH
Specify the month of the year to end as the first three letters of the month with first letter in caps, for example, Jan. (case sensitive).
<1993-2035>
Specify the year to end.
duration
Indicate the duration parameter.
<1-2147483646>
 
Specify the actual end time duration of a key in seconds.
infinite
Specify the end time to never expire.
Default
By default, accept-lifetime command is disabled
Command Mode
Keychain-key mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
The following example shows the setting of accept-lifetime for key-id 1 on the key chain named mychain.
#configure terminal
(config)#key chain mychain
(config-keychain)#key-id 1
(config-keychain-key)#accept-lifetime 03:03:01 Dec 03 2004 04:04:02 Oct 06 2006
 
address-family ipv6
Use this command to enter 'address-family ipv6' mode, where users can configure IPv6 routing specific configuration.
Use the no parameter with this command to remove all configuration under 'address-family ipv6'.
Command Syntax
address-family ipv6 (unicast|)
no address-family ipv6 (unicast|)
Parameters
unicast
Specify unicast routing for IPv6.
Default
Unicast routing is not configured.
Command Mode
Router mode
Example
#configure terminal
(config)#router isis bb
(config-router)#address-family ipv6 unicast
 
adjacency-check
Use this command to check ISIS neighbor protocol support.
Use the no parameter with this command to uncheck ISIS neighbor protocol support.
Command Syntax
adjacency-check
no adjacency-check
Parameters
None
Default
By default, adjacency-check command is disabled
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
(config)#router isis bb
(config-router)#adjacency-check
 
(config-router)#no adjacency-check
area-password
Use this command to set the authentication password for the Level-1 area and to set authentication on Level-1 sequence number PDUs. This command enables authentication when receiving and sending link-state and sequence number PDUs in Level-1 areas. The password must be the same for all the ISIS routers in the same area.
Use the no parameter with this command to clear the area password.
Command Syntax
area-password WORD
area-password WORD authenticate snp (send-only|validate)
no area-password
Parameters
WORD
Password string.
authenticate
Insert the password into Level-1 SNP PDUs.
snp
Sequence number PDUs.
send-only
Only insert the password into the Level-1 sequence number PDUs, but not check the password in sequence number PDUs that it receives. Use this keyword during a software upgrade to ease the transition.
validate
Insert the password into Level-1 sequence number PDUs and check the password in sequence number PDUs that it receives.
Default
By default, the area password is not configured
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
(config)#router isis bb
(config-router)#area-password mypasswd
 
(config)#router isis bb
(config-router)#area-password myPass authenticate snp send-only
 
(config)#router isis bb
(config-router)#no area-password
authentication key-chain
Use this command to set the key chain to be used for authentication at the instance level. Authentication mode must be set to md5 to configure the key chain. If no key chain is configured with the key-chain command, no key-chain authentication is performed.
Only one authentication key-chain is applied to an ISIS interface at a time. That is, issuing a second isis authentication key-chain command overrides the first isis authentication key-chain command. If neither the level-1 nor the level-2 keyword is configured, the chain applies to both levels. Authentication can be specified for an individual ISIS interface using the isis authentication key-chain command.
Use the no parameter with this command to unset the key chain used for authentication.
Command Syntax
authentication key-chain WORD (level-1|level-2|)
no authentication key-chain (level-1|level-2|)
Parameters
WORD
Specify the chain name (valid authentication keys).
level-1
Specify an authentication key-chain for level-1 PDUs.
level-2
Specify an authentication key-chain for level-2 PDUs.
Default
The key chain applies to the level(s) on which authentication mode is configured as MD5 if no level is specified.
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
#configure terminal
(config)#router isis 1
(config-router)#authentication key-chain myKey level-1
authentication mode
Use this command to set the authentication mode at the instance level.
If clear-text authentication was configured using the area-password or domain-password commands, the authentication mode command overrides both of those commands (based on the level at which MD5 is configured). If the authentication mode command was used first, and subsequently an attempt is made to use the area-password or domain-password commands, the attempt fails. To configure clear-text authentication using the area-password or domain-password commands, first use the no authentication mode command.
The type of authentication and the level to which it applies can be specified for a single ISIS interface, rather than per ISIS instance, using the isis authentication mode command.
Use the no parameter with this command to unset the authentication mode.
Command Syntax
authentication mode {md5|text} (level-1|level-2|)
no authentication mode {md5|text} (level-1|level-2|)
Parameters
md5
Keyed message digest
text
Text mode
level-1
Specify an authentication key-chain for level-1 PDUs.
level-2
Specify an authentication key-chain for level-2 PDUs.
Default
The authentication mode is set to MD5 for both levels if no level is specified.
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#configure terminal
(config)#router isis 1
(config-router)#authentication mode md5 level-1
 
(config-router)#no authentication mode md5 level-1
authentication send-only
Use this command to set the send-only option at the instance level.
Use this command before configuring the authentication mode and authentication key-chain, so that the implementation of authentication goes smoothly. That is, the routers will have more time for the keys to be configured on each router if authentication is inserted only on the packets being sent, not checked on packets being received. After all routers that must communicate are configured with this command, enable the authentication mode and key chain on each router. Then, specify the no authentication send-only command to disable the send-only feature.
If the level-1-2 keyword is configured, the send-only feature applies to both levels.
Use the no parameter with this command to unset the send-only option.
Command Syntax
authentication send-only (level-1-only|level-2-only|level-1-2)
no authentication send-only
Parameters
level-1-only
Set send-only option for level-1 only.
level-2-only
Set send-only option for level-2 only.
level-1-2
Set send-only option for level-1-2 only.
Default
By default, authentication send only is disabled
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#configure terminal
(config)#router isis 1
(config-router)#authentication send-only level-1-only
 
(config-router)#no authentication send-only
bfd all-interfaces
Use this command to enable the Bidirectional Forwarding Detection (BFD) feature on the interfaces enabled with this ISIS instance.
This command sets BFD fall-over check for all the neighbors under specified process. To disable BFD checking on particular interface use isis bfd disable command at interface mode.
Use the no parameter with this command to disable BFD functionality for an ISIS instance.
Command Syntax
bfd all-interfaces
no bfd all-interfaces
Parameters
None
Default
By default, the BFD feature is disabled.
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
(config)#router isis aa
(config-router)#bfd all-interfaces
 
(config-router)#no bfd all-interfaces
capability cspf
Use this command to enable the constrained shortest path first (CSPF) feature in the ISIS module. CSPF calculates optimum explicit route (ER), using Traffic Engineering Database and (TED) and pre-existing Label Switched Path (LSP). The resulting ER is used by a signaling protocol (RSVP-TE) to set up LSPs. Use the no parameter with this command to disable CSPF functionality for an ISIS instance.
Command Syntax
capability cspf
no capability cspf
Parameters
None
Default
If this command is not used, the CSPF feature is disabled.
Command Mode
Router mode
Example
(config)#router isis aa
(config-router)#capability cspf
 
clear clns neighbors
Use this command to clear CLNS neighbor adjacencies.
Command Syntax
clear clns neighbors
Parameters
None
Command Mode
Exec mode and Privileged Exec mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
>ena
#clear clns neighbors
 
clear clns is-neighbors
Use this command to clear IS neighbor adjacencies.
Command Syntax
clear clns is-neighbors System-ID
Parameters
System-ID
Neighbor system ID in XXXX.XXXX.XXXX format.
Command Mode
Exec mode and Privileged Exec mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
>enable
#clear clns is-neighbors 1111.1111.1111.1111
clear ip isis route
Use this command to clear IPv4 routes.
Command Syntax
clear ip isis (WORD|) route (redistribution|all)
Parameters
WORD
Name that identifies the IS-IS area.
redistribution
Clear IS-IS local redistribution routes.
all
Clear all of the IS-IS routing tables.
Command Mode
Exec mode and Privileged Exec mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
>ena
#clear ip isis route redistribution
 
clear isis adjacency
This command is used to remove the entries from the IS-IS adjacency database. Clears all adjacencies for the specified routing instance or specified interface or particular system ID.
Command Syntax
clear isis adjacency (*|IFNAME|system-id XXXX.XXXX.XXXX|) (vrf VRFNAME|)
Parameters
*
Clear all neighbors.
IFNAME
Interface name.
XXXX.XXXX.XXXX
 
Neighbor System-ID.
VRFNAME
VRF name.
Command Mode
Exec mode and Privileged Exec mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
#clear isis adjacency *
 
clear isis counter
Use this command to clear system-wide IS-IS counters (IsisSystemCounterEntry in RFC 4444).
Command Syntax
clear isis counter
Parameters
None
Command Mode
Exec mode and Privileged Exec mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
#clear isis counter
 
clear isis interface counter
Use this command to clear interface counters. If you do not specify a parameter, then counters for all interfaces are cleared.
Command Syntax
clear isis interface counter (IFNAME|)
Parameters
IFNAME
Interface name.
Command Mode
Exec mode and Privileged Exec mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
#clear isis interface counter
 
clear isis process
Use this command to restart ISIS processes. If you do not specify a parameter, then all ISIS processes are restarted.
Command Syntax
clear isis (WORD|) process
Parameters
WORD
Name that identifies the IS-IS area.
Command Mode
Exec mode and Privileged Exec mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
#clear isis process
 
debug isis
Use this command to turn on debugging for specified criteria. Debug commands enable to show some debugging information about specified criteria into file or terminal.
Use the no parameter to turn off debugging for specified criteria.
Command syntax
debug isis (all|)
debug isis (authentication|bfd|checksum|events|hello|mpls (interface IFNAME | System-ID|)|cspf (events | hexdump|)|ifsm|local-updates|lsp|nfsm|nsm |pdu|protocol-errors|rib|spf)
no debug isis (all|)
no debug all
no debug all isis
undebug all
undebug isis (all|)
undebug all isis
no debug isis (authentication|bfd|checksum|events|hello|mpls (interface IFNAME | System-ID|)|cspf (events | hexdump|)|ifsm|local-updates|lsp|nfsm|nsm |pdu|protocol-errors|rib|spf)
undebug isis (authentication|bfd|checksum|events|hello|mpls (interface IFNAME | System-ID|)|cspf (events | hexdump|)|ifsm|local-updates|lsp|nfsm|nsm |pdu|protocol-errors|rib|spf)
Parameters
all
Enables all debugging.
authentication
Debugging for authentication.
checksum
Debugging for checksums.
bfd
Debugging for bidirectional forwarding detection.
events
Debugging for internal events.
hello
Debugging for hello processing.
mpls
Debugging for MPLS.
IFNAME
Interface name.
System-ID
System identifier.
cspf
Debugging for CSPF.
events
Events.
hexdump
Hexdump.
ifsm
Debugging for interface finite state machine.
local-updates
Debugging for local updates.
lsp
Debugging for link-state packet.
nfsm
Debugging for neighbor finite state machine.
nsm
Debugging for NSM messages.
pdu
Debugging for protocol data unit.
protocol-errors
 
Debugging for protocol errors.
rib
Debugging for RIB information.
spf
Debugging for shortest path first route calculation.
Command Mode
Privileged Exec mode and Configure mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#configure terminal
(config)#debug isis pdu
 
#configure terminal
(config)#debug isis nsm
default-information originate
Use this command to originate reachability information to a default route into link-state packets.
There is no default information in a Level-2 domain by default, while a Level-1 router calculates a default to L1L2 route during SPF calculation. This command originates a default route into a Level-2 domain.
Use the no parameter with this command to withdraw reachability information to a default route from link-state packets.
Command Syntax
default-information originate (always| level-1|) (route-map WORD|)
no default-information originate (always| level-1|)
Parameters
originate
Specify to distribute a default route
always
The default route is advertised even if there is no default route in the router’s routing table.
level-1
Distribute in level-1.
route-map
Identifies other filtering options via a route map.
Default
There is no default information in Level-2 domain by default, while Level-1 router calculates default to L1L2 route during SPF calculation. This command enables to originate default route into Level-2 domain. As an added option, if the user wants to originate the default route in L1 LSP, the “level-1” parameter can be used as follows:
default-information originate level-1
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#configure terminal
(config)#router isis bb
(config-router)#default-information originate
(config-router)#exit
(config)#exit
 
distance (IPv4)
Use this command in router mode to set the administrative distance for all IPv4 routes or routes from a specific source.
Use the no parameter with this command to remove an administrative distance.
Command Syntax
distance <1-255> (System-ID (WORD|)|)
no distance (System-ID|)
Parameters
<1-255>
Distance range.
System-ID
Source ID in XXXX.XXXX.XXXX format.
WORD
Access-list name.
Default
By default, all options are turned off.
Command Mode
Router mode
Examples
The following example shows setting the administrative distance for all routes.
#configure terminal
(config)#router isis
(config-router)#distance 10
The following example shows setting the administrative distance for a specific route source.
#configure terminal
(config)#router isis
(config-router)#distance 40 0000.0000.0001
 
distance (IPv6)
Use this command in router mode to set the administrative distance for all IPv6 routes.
Use the no parameter with this command to remove an administrative distance.
Command Syntax
distance <1-255>
no distance
Parameters
<1-255>
Distance range.
Default
By default, all options are turned off.
Command Mode
Address-family ipv6 mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
The following example shows setting the administrative distance for all routes.
#configure terminal
(config)#router isis
(config-router)#address-family ipv6
(config-router-af)#distance 14
 
domain-password
Use this command to set the authentication password for the Level-2 domain, and optionally, the authentication password on Level-2 sequence number PDUs.
Configuring this command to enable authentication when receiving and sending link state and sequence number PDUs in Level-2 domain. The domain password must be the same in the Level-2 domain.
Use the no parameter with this command to clear the domain password.
Command Syntax
domain-password WORD
domain-password WORD authenticate snp (send-only|validate)
no domain-password
Parameters
WORD
Password string.
authenticate
Inserts th password into Level-1 sequence number PDUs.
snp
sequence number PDUs.
send-only
Only inserts the password into the Level-1 sequence number PDUs, but does not check the password in sequence number PDUs that it receives. Use this keyword during a software upgrade to ease the transition.
validate
Inserts the password into the Level-1 sequence number PDUs and checks the password in sequence number PDUs received.
Default
By default, there is no domain password .
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#configure terminal
(config)#router isis bb
(config-router)#domain-password mypasswd
 
(config)#router isis bb
(config-router)#domain-password myPass authenticate snp send-only
 
(config)#router isis bb
(config-router)#no domain-password
 
dynamic-hostname
Use this command to configure the hostname to advertise for an ISIS instance using the dynamic hostname exchange mechanism (RFC 2763) and system-ID-to-hostname translation. This command configures a hostname to use for the Dynamic Hostname Exchange Mechanism and System-ID to hostname translation. This is required to get accurate results when using the show isis database and a few other commands.
Use the no parameter to disable the Hostname configured.
 
Command Syntax
dynamic-hostname
hostname dynamic
dynamic-hostname area-tag
no dynamic-hostname
no hostname dynamic
Parameters
area-tag
Use the routing area tag as the hostname, not the router's global hostname.
Default
By default, the Dynamic Hostname Exchange Mechanism is disabled.
Command Mode
Router mode
Example
#configure terminal
(config)#router isis bb
(config-router)#dynamic-hostname area-tag
 
 
 
 
fast-reroute per-prefix
Use this command to enable Loop Free Alternate Fast Reroute (LFA FRR) for all prefixes or only those prefixes in a route map.
Use the no form of this command to disable LFA FRR.
Command Syntax
fast-reroute per-prefix (level-1|level-2) proto (ipv4) (all|route-map WORD)
no fast-reroute per-prefix (level-1|level-2) proto (ipv4)
Parameters
level-1
Level 1 only.
level-2
Level 2 only.
ipv4
IPv4 address family only.
all
All prefixes.
route-map
Prefixes from a route map.
WORD
Route map name.
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 3.0.
Examples
#configure terminal
(config)#router isis 100
(config-router)#fast-reroute per-prefix level-2 proto ipv4 all
(config-router)#fast-reroute per-prefix level-1 proto ipv4 route-map rmap1 (config-router)#no fast-reroute per-prefix level-2 proto ipv4
 
fast-reroute per-prefix remote-lfa
Use this command to configure remote loop-free alternate fast reroute configuration for a particular level of an IS-IS instance.
Use the no parameter to remove remote loop-free alternate fast reroute configuration.
Command Syntax
fast-reroute per-prefix remote-lfa (level-1|level-2) proto ipv4 tunnel mpls-ldp
no fast-reroute per-prefix remote-lfa (level-1|level-2) proto ipv4
Parameters
level-1
Level 1 only.
level-2
Level 2 only.
Default
By default, fast-reroute per-prefix remote-lfa is not enabled.
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 5.1.
Examples
#configure terminal
(config)#router isis 1
(config-router)#fast-reroute per-prefix remote-lfa level-1 proto ipv4 tunnel mpls-ldp
(config-router)#
 
 
fast-reroute terminate-hold-on interval
Use this command to set the Loop Free Alternate Fast Reroute (LFA FRR) termination hold-on timer.
Use the no form of this command to set the termination hold-on timer to its default value (1000 milliseconds).
Command Syntax
fast-reroute terminate-hold-on interval <100-100000>
no fast-reroute terminate-hold-on interval
Parameters
<100-100000>
LFA FRR termination hold-on timer interval in milliseconds.
Default
1000 milliseconds
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 3.0.
Examples
#configure terminal
(config)#router isis 100
(config-router)#fast-reroute terminate-hold-on interval 7000
(config-router)#no fast-reroute terminate-hold-on interval
 
fast-reroute tie-break
Use this command to set the tie-breaking policy for selecting a fast reroute repair path. You assign a priority to each type of repair path. The tie-breaker value is used to select an LFA FRR route when multiple LFA FRR routes are available for the same primary route.
Use the no form of this command to set the tie-break preference value for a protection type to its default value.
To set all types of repair paths to their default priorities, do not specify a repair path with the no form of this command.
Command Syntax
fast-reroute tie-break (level-1|level-2) proto (ipv4) (primary-path|interface- disjoint|node-protecting|broadcast-interface-disjoint|secondary-path|downstream- path) index <1-255>
no fast-reroute tie-break (level-1|level-2) proto (ipv4) (primary- path|interface-disjoint|node-protecting|broadcast-interface-disjoint|secondary- path|downstream-path)
Parameters
level-1
Level 1 only.
level-2
Level 2 only.
ipv4
IPv4 address family only.
primary-path
Use a path from the Equal-Cost Multipath Path (ECMP) set. An ECMP found during the primary shortest path first (SPF) repair might not be desirable in networks where traffic exceeds the capacity of any single link.
interface-disjoint
 
Link protecting: prefer a backup path that uses a different interface than the interface used to reach destination via the primary path.
node-protecting
Bypass the primary-path gateway router which might not protect the router that is the next hop in the primary path. This ensures complete traffic protection even if the primary next-hop router fails.
broadcast-interface-disjoint
 
Do not use the interface if connected to a broadcast network. Repair paths protect links when a repair path and a protected primary path use different next-hop interfaces. However, on broadcast interfaces, if the repair path is computed via the same interface as the primary path, but their next-hop gateways are different, the router is protected but the link might not be.
secondary-path
Prefer a non-ECMP backup path.
downstream-path
Prefer a backup path to the destination which satisfies the downstream condition where the path cost to reach the destination from the LFA next hop is less than the path cost to the destination from the self node via primary next hop:
Distance_opt(N, D) < Distance_opt(S, D)
This might result in lost traffic, but prevents looping.
index
Tie breaking index. A lower value has higher preference.
<1-255>
Tie breaking index value.
Defaults
 
primary-path
20
interface-disjoint
60
node-protecting
30
broadcast-interface-disjoint
70
secondary-path
255
downstream-path
90
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 3.0.
Examples
#configure terminal
(config)#router isis 100
(config-router)#fast-reroute tie-break level-2 proto ipv4 node-protecting index 127
(config-router)#no fast-reroute tie-break level-1 proto ipv4 broadcastinterface-disjoint
 
ignore-lsp-errors
Use this command to ignore link-state packets (LSPs) with checksum errors. By default, ISIS validates the checksum for LSP and if the checksum has an error, the LSP is dropped. Giving this command says to ignore the LSP checksum error and treat it as if checksum is passed.
Use the no parameter to turn off this function.
Command Syntax
ignore-lsp-errors
no ignore-lsp-errors
Parameters
None
Default
By default, the LSP checksum is checked on receipt.
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
In this sample, rtr1 does not drop LSP packets with bad checksum.
#configure terminal
(config)#router isis bb
(config-router)#ignore-lsp-errors
ip router isis
Use this command to enable ISIS IPv4 routing on the interface. This command is mandatory to ISIS configuration.
After giving this command, the router sends ISIS Hello with IP address TLV on this interface and IP reachability information TLV in link-state packets are updated.
Use the no parameter with this command to disable ISIS IPv4 routing on the interface. This action does not clear the ISIS database. To clear the database, unconfigure the ISIS routing instance.
Command Syntax
ip router isis WORD
no ip router isis WORD
Parameters
WORD
Name that identifies the IS-IS area. Specify an existing area name or a new area name.
Default
By default, IPv4 routing is disabled on the router.
Command Mode
Interface mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
#configure terminal
(config)#interface eth0
(config-if)#ip router isis bb
 
ipv6 router isis
Use this command to enable ISIS IPv6 routing on the interface. This command is mandatory to IPv6 ISIS configuration. Match the ISIS instance tag to one of existing instance's tags, or a new instance with the tag name should be initiated, otherwise routing will not run on this interface.
Configuring this command, the router sends ISIS Hello with IPv6 address TLV on this interface, and IPv6 reachability information TLV in the LSP will be updated.
Use the no parameter with this command to disable ISIS IPv6 routing on the interface.
Command Syntax
ipv6 router isis WORD
no ipv6 router isis WORD
Parameters
WORD
ISIS instance name.
Default
By default, IPv6 routing is disabled on the router.
Command Mode
Interface mode
Example
#configure terminal
(config)#interface eth0
(config-if)#ipv6 router isis bb
 
isis authentication key-chain
Use this command to set the key chain to be used for authentication on the interface-related packets.
Authentication mode must be set to md5 to configure the key chain. If no key chain is configured with the key-chain command, no key-chain authentication is performed. Only one authentication key-chain is applied to an ISIS interface at a time. That is, issuing a second isis authentication key-chain command overrides the first isis authentication key-chain command.
If neither the level-1 nor level-2 keyword is configured, the key chain applies to the level(s) on which the authentication mode is configured as md5. Authentication can be specified for an entire instance of ISIS, instead of at the interface level, by using the authentication key-chain command.
Use the no parameter with this command to unset the key chain used for authentication on the interface-related packets.
Command Syntax
isis authentication key-chain WORD (level-1|level-2|)
no isis authentication key-chain (level-1|level-2|)
Parameters
WORD
Chain name - valid authentication keys.
level-1
Specify an authentication key-chain for level-1 PDUs.
level-2
Specify an authentication key-chain for level-2 PDUs.
Default
By default, this option is disabled. The key chain applies to the level(s) on which authentication mode is configured as MD5 if no level is specified.
Command Mode
Interface mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
#configure terminal
(config)#interface eth1
(config-if)#isis authentication key-chain myKey level-1
isis authentication mode md5
Use this command to set the MD5 authentication mode. If the isis password command was used, then subsequently an attempt is made to use the isis authentication mode command, the attempt fails. To configure isis authentication mode command, first use the no isis password command. If the isis authentication mode command was used, then subsequently an attempt is made to use the isis password command, the attempt fails.
To configure clear text authentication using the isis password command, first use the no isis authentication mode command. The type of authentication and the level to which it applies can be specified for the entire ISIS instance, rather than per interface, using the authentication mode command.
Use the no parameter with this command to unset the MD5 authentication mode.
Command Syntax
isis authentication mode {md5|text} (level-1|level-2|)
no isis authentication mode {md5|text} (level-1|level-2|)
Parameters
md5
Keyed message digest
text
Text mode
level-1
Specify an authentication key-chain for level-1 PDUs.
level-2
Specify an authentication key-chain for level-2 PDUs.
Default
By default, this option is disabled. The authentication mode will be set to MD5 for both levels if no level is specified.
Command Mode
Interface mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
#configure terminal
(config)#interface eth1
(config-if)#isis authentication mode md5 level-1
isis authentication send-only
Use this command to set the send-only option to the interface-related packets.
Use this command before configuring the ISIS authentication mode and ISIS authentication key-chain, so that the implementation of authentication goes smoothly. That is, the routers will have more time for the keys to be configured on each router if authentication is inserted only on the packets being sent, not checked on packets being received. After all routers that must communicate are configured with this command, enable the authentication mode and key chain on each router.
Use the no parameter with this command to unset the send-only option to the interface-related packets.
Command Syntax
isis authentication send-only (level-1-only|level-2-only|level-1-2)
no isis authentication send-only
Parameters
level-1-only
Set send-only option for level-1 only.
level-2-only
Set send-only option for level-2 only.
level-1-2
Set send-only option for level-1-2 only.
Default
By default, this option is disabled. The send-only option applies to both levels if no level is specified.
Command Mode
Interface mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
#configure terminal
(config)#interface eth1
(config-if)#isis authentication send-only level-1-only
isis bfd
Use this command to enable/disable the BFD check on interface.
The isis bfd command allows a user to enable BFD on an interface. The isis bfd disable command disables BFD checking on an interface. However, the no isis bfd and no isis bfd disable commands both remove the enable/disable configuration, but do not disable/enable BFD.
The bfd all-interfaces command enables BFD on all interfaces attached to an instance then configuring. This command disables BFD configuration on a particular interface.
Command Syntax
isis bfd (disable|)
no isis bfd (disable|)
Parameters
disable
Specify to disable BFD.
Default
By default, bfd feature enable/disable is not configured.
Command Mode
Interface mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
#configure terminal
(config)#interface eth0
(config-if)#isis bfd disable
 
isis circuit-type
Use this command to set the circuit type for the interface.
If level-1 or level-2-only is specified in this command, ISIS sends only the specified level of PDUs. On the point-to-point interface, there is only one type of Hello packet, so in this case ISIS Hello will be sent regardless of circuit-type. If is-type is configured as level-1 or level-2 only, routing for this instance is performed for only the specified level. In this manner, only the particular level of PDU is sent on the interface.
Use the no parameter to reset circuit type to the default.
Command Syntax
isis circuit-type (level-1|level-1-2|level-2-only)
no isis circuit-type
Parameters
level-1
Specify that only Level-1 adjacencies are formed.
level-1-2
Specify that Level-1-2 adjacencies are formed.
level-2-only
Specify that only Level-2 adjacencies are formed.
Default
By default, the default circuit-type is level-1-2.
Command Mode
Interface mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
#configure terminal
(config)#interface eth0
(config-if)#isis circuit-type level-2-only
isis csnp-interval
Use this command to set CSNP (Complete sequence number PDU) interval in seconds.
Configuring this command changes the interval between two consecutive CSNP transmission. By default, CSNP is sent every 10 seconds only by LAN DIS. This parameter is only valid on broadcast interface, since periodic CSNP is only sent on broadcast interface, while CSNP on Point-to-Point interface is sent only when adjacency is initiated.
Use the no parameter with this command to reset CSNP interval to the default value.
Command Syntax
isis csnp-interval <1-65535> (level-1|level-2|)
no isis csnp-interval (level-1|level-2|)
Parameters
<1-65535>
Specify the CSNP interval in seconds.
level-1
Specify Level-1 CSNP.
level-2
Specify Level-2 CSNP.
Default
By default, ISIS uses 10 seconds for the interval and the interval is applied to both level-1 and level-2.
Command Mode
Interface mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
#configure terminal
(config)#interface eth0
(config-if)#isis csnp-interval 20
isis fast-reroute per-prefix candidate disable
Use this command to prevent an interface from becoming an Loop Free Alternate Fast Reroute (LFA FRR) for a primary route.
Use the no form of this command to enable an interface to become an LFA FRR for a primary route.
Command Syntax
isis fast-reroute per-prefix candidate disable (level-1|level-2)
no isis fast-reroute per-prefix candidate disable (level-1|level-2)
Parameters
level-1
Level-1 only
level-2
Level-2 only
Command Mode
Interface mode
Applicability
This command was introduced before OcNOS version 3.0.
Example
#configure terminal
(config)#interface eth0
(config-if)#isis fast-reroute per-prefix candidate disable level-2
(config-if)#no isis fast-reroute per-prefix candidate disable level-2
isis hello-interval
Use this command to set the Hello interval in seconds. The Hello-interval is set with the hello-multiplier (see isis hello-multiplier command).
Configuring this command changes the time interval between two consecutive Hello transmissions. If a device receives its own LSP with a maximum sequence number, then it suspends ISIS for the hold interval. DIS sends Hello transmissions at three times the rate than non-DIS. If ISIS is elected as DIS on this interface, ISIS sends Hello every 3.3 seconds.
If minimal keyword is specified, Holding timer in Hello PDU is set to 1 second and Hello interval is calculated by dividing by the hello-multiplier. For example, if the hello-multiplier is configured as 4 and hello-interval minimal is the command used, an Hello PDU is sent every 250 milliseconds.
Use the no parameter to set the Hello interval to the default.
Command Syntax
isis hello-interval <1-65535> (level-1|level-2|)
isis hello-interval minimal (level-1-only|level-2-only|level-1-2)
no isis hello-interval (level-1|level-2|)
no isis hello-interval minimal
Parameters
<1-65535>
Specify the hello interval in seconds.
minimal
Specify the holding-time as 1 second.
level-1
Specify Level-1 CSNP.
level-2
Specify Level-2 CSNP.
level-1-only
Specify only Level-1 CSNP.
level-2-only
Specify only Level-2 CSNP.
level-1-2
Specify only Level-1-2 CSNP.
Default
By default, ISIS uses 10 seconds for the interval and the interval is applied to both level-1 and level-2.
Command Mode
Interface mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#configure terminal
(config)#interface eth0
(config-if)#isis hello-interval 5 level-1
 
(config-if)#isis hello-interval minimal level-1-only
isis hello-multiplier
Use this command to set multiplier for Hello holding time.
Changes Holding Timer in Hello PDU. Holding timer is calculated by “Hello-Interval” multiplied by this value. If minimal keyword is specified with the Hello-Interval, the holding timer is set to 1 second and the hello-interval is calculated by dividing 1 by this value.
Use the no parameter with this command to set multiplier to the default.
Command Syntax
isis hello-multiplier <2-100> (level-1|level-2|)
no isis hello-multiplier (level-1|level-2|)
Parameters
<2-100>
Specify a hello multiplier value.
level-1
Specify Level-1 hello.
level-2
Specify Level-2 hello.
Default
By default, ISIS uses 3 seconds for the multiplier value and the multiplier is applied to both level-1 and level-2.
Command Mode
Interface mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
#configure terminal
(config)#interface eth0
(config-if)#isis hello-multiplier 4
isis hello padding
Use this command to enable IS-IS hello padding at the interface level.
Intermediate System-to-Intermediate System (IS-IS) hellos are padded to the full maximum transmission unit (MTU) size. The benefit of padding IS-IS hellos to the full MTU is that it allows for early detection of errors that result from transmission problems with large frames or errors that result from mismatched MTUs on adjacent interfaces.
Use the no parameter with this command to disable IS-IS hello padding.
Command Syntax
isis hello padding
no isis hello padding
Parameters
None
Default
By default, ISIS hello padding is enabled
Command Mode
Interface mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#configure terminal
(config)#interface eth1
(config-if)#isis hello padding
 
(config-if)#no isis hello padding
isis lsp-interval
Use this command to set the link-state packet (LSP) transmission interval.
Giving this command changes the minimum interval between two consecutive LSP transmission. When flooding or some other event triggers LSP transmission, the LSP is put in the interface queue and scheduled to send according to this interval. Two consecutive LSP transmissions are scheduled to have at least this interval.
Use the no parameter with this command to set LSP transmission interval to the default.
Command Syntax
isis lsp-interval <1-4294967295>
no isis lsp-interval
Parameters
<1-4294967295>
LSP transmission interval in milliseconds.
Default
By default, ISIS uses 33 milliseconds for the interval.
Command Mode
Interface mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#configure terminal
(config)#interface eth0
(config-if)#isis lsp-interval 100
 
(config-if)#no isis lsp-interval
isis mesh-group
Use this command to set Mesh Group ID on the current interface.
Use the no parameter to unset mesh group on the current interface.
Command Syntax
isis mesh-group <1-4294967295>
no isis mesh-group
Parameters
<1-4294967295>
Specify a mesh group number
Default
By default, mesh groups are not enabled on this interface.
Command Mode
Interface mode
Examples
(config)#interface eth0
(config-if)#isis mesh-group 20
 
(config)#interface eth2
(config-if)#no isis mesh-group
isis metric
Use this command to set the default metric for the interface. The interface default metric is put into IP reachability information TLVs and in IS reachability information TLVs in link-state packets. The value is used for SPF calculation, and is applied when the metric-style is configured as “narrow”.
Use the no parameter with this command to set default metric to the default.
Command Syntax
isis metric <1-63> (level-1|level-2|)
no isis metric (level-1|level-2|)
Parameters
<1-63>
Default metric.
level-1
Default metric for level-1 circuit.
level-2
Default metric for level-2 circuit.
Default
By default, ISIS uses 10 for the metric value and the value is applied to both level-1 and level-2.
Command Mode
Interface mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
#configure terminal
(config)#interface eth0
(config-if)#isis metric 20
isis network
Use this command to change a broadcast interface network type to a point-to-point network type.
Use the no parameter with this command to revert to the default setting of a broadcast interface network type.
Command Syntax
isis network (broadcast|point-to-point)
no isis network
Parameters
broadcast
Specify ISIS a broadcast multi-access network.
point-to-point
Specify ISIS a point-to-point network.
Default
By default, the network is set to a broadcast multi-access network type.
Command Mode
Interface mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
#configure terminal
(config)#interface eth0
(config-if)#isis network point-to-point
isis password
Use this command to set the authentication password of Hello PDU on the interface.
If the isis authentication mode command was used, then subsequently an attempt is made to use the isis password command, the attempt fails. To configure clear text authentication using the isis password command, first use the no isis authentication mode command.
Use the no parameter to clear the password.
Command Syntax
isis password WORD (level-1|level-2|)
no isis password (level-1|level-2|)
Parameters
WORD
Specify a password string.
level-1
Specify a password for Level-1 hello PDUs.
level-2
Specify a password for Level-2 hello PDUs.
Default
By default, no password is configured; this applies to both level-1 and level-2.
Command Mode
Interface mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
#configure terminal
(config)#interface eth0
(config-if)#isis password mypassword level-1
isis priority
Use this command to set the priority for LAN DIS election. This command changes the priority value in LAN ISIS Hello PDUs. A lower priority value is less preferred in DIS election, and a higher priority value is more preferred.
Note: This command is not valid for Point-to-Point interface.
Use the no parameter to set priority to the default.
Command Syntax
isis priority <0-127> (level-1|level-2|)
no isis priority (level-1|level-2|)
Parameters
<0-127>
Priority value
level-1
Specify a password for Level-1 hello PDUs.
level-2
Specify a password for Level-2 hello PDUs.
Default
By default, ISIS uses 64 for the priority value, and the priority is applied to both level-1 and level-2.
Command Mode
Interface mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
#configure terminal
(config)#interface eth0
(config-if)#isis priority 127
isis retransmit-interval
Use this command to set the link-state packet (LSP) retransmission interval.
Use the no parameter to set the interval to the default.
Command Syntax
isis retransmit-interval <1-65535>
no isis retransmit-interval
Parameters
<1-65535>
Interval for retransmission of the same LSP in seconds.
Default
By default, ISIS uses an interval of 5 seconds.
Command Mode
Interface mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#configure terminal
(config)#interface eth0
(config-if)#isis retransmit-interval 10
 
(config-if)#no isis retransmit-interval
 
ispf
Use this command to enable incremental SPF for a routing process.
Use the no parameter to disable incremental SPF from a routing process.
Command Syntax
ispf (level-1|level-2-only|)
no ispf
Parameters
level-1
Act as level-1 only IS.
level-2-only
Act as level-2 only IS.
Default
By default, all levels are turned off.
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#configure terminal
(config)#router isis bb
(config-router)#ispf level-1
 
(config)#router isis bb
(config-router)#no ispf
isis wait-timer
Use the isis wait-timer seconds command to configure the number of seconds the router will wait for adjacency information
Use the no parameter to set the wait-timer to the default.
Command Syntax
isis wait-timer <1-65535> (level-1|level-2|)
no isis wait-timer (level-1|level-2|)
Parameters
level-1
Act as level-1 only IS.
level-2
Act as level-2 only IS.
Default
By default, wait-timer will be 20 seconds (2 times the hello timer).
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#configure terminal
(config)#router isis bb
(config-router)#isis wait-timer 30
 
(config)#router isis bb
(config-router)#no isis wait-timer
 
isis wide-metric
Use this command to set wide metric for the interface.
Interface wide-metric is put into Extended IP reachability TLVs. Extended IS reachability TLVs and IPv6 rechability TLVs in LSPs. The value is used for SPF calculation. The value is applied when metric-style is configured as 'wide'.
Use the no parameter to set wide metric to the default.
Command Syntax
isis wide-metric <1-16777214> (level-1|level-2|)
no isis wide-metric (level-1|level-2|)
Parameters
<1-16777214>
 
Specify a wide metric.
level-1
 
Specify the wide metric for Level-1 circuit.
level-2
 
Specify the wide metric for Level-2 circuit.
Default
By default, ISIS uses 10 for the metric value and the metric is applied to both level-1 and level-2.
Command Mode
Interface mode
Applicability
None.
Examples
#configure terminal
(config)#interface eth0
(config-router)#isis wide-metric 100
 
(config)#interface eth0
(config-router)#no isis wide-metric
isis tag
Use this command to sets the tag for link-state packets (LSPs) sent out advertising routes for networks directly connected to an interface.
If you do not specify a parameter, then the tag value is set for level-1-2 boundary.
Use the no parameter to unset the tag.
Command Syntax
isis tag <1-4294967295> (level-1|level-2|)
no isis tag (level-1|level-2|)
Parameters
<1-4294967295>
Tag value.
level-1
Specify the tag value for the level-1 boundary.
level-2
Specify the tag value for the level-2 boundary.
Command Mode
Interface mode
Examples
>ena
#con term
Enter configuration commands, one per line. End with CNTL/Z.
(config)#interface eth0
(config-if)#isis tag 500 level-1
isis te-metric
Use this command to set TE metric for the interface. Interface te-metric is put into Extended IS reachability TLV. The value is used for CSPF calculation. The value is applied when metric-style is configured as wide.
Use the no parameter to unset the TE metric.
Command Syntax
isis te-metric <1-16777214> (level-1|level-2|)
no isis te-metric (level-1|level-2|)
Parameters
<1-16777214>
Specify a TE metric.
level-1
Specify the TE metric for level-1 circuit.
level-2
Specify the TE metric for level-2 circuit.
Default
By default, it will take ISIS wide metric value.
Command Mode
Interface mode
Applicability
This command was introduced in OcNOS version 5.0
Examples
#configure terminal
(config)#interface eth1
(config-router)#isis te-metric 100
(config)#interface eth1
(config-router)#no isis te-metric
is-type
Use this command to set the IS to the specified level of routing.
Changing is-type brings down, then brings up a particular level of routing. There is a limitation: Only one ISIS instance can run Level-2 routing (either Level-2 only IS, or Level-1-2 IS).
Use the no parameter to set the IS to the default.
Command Syntax
is-type (level-1|level-1-2|level-2-only)
no is-type
Parameters
level-1
Act as level-1 only IS.
level-1-2
Act as level-1-2 IS.
level-2-only
Act as level-2 only IS.
Default
By default, ISIS uses level-1-2 if there is no Level-2 instance nor a Level-1-2 instance. Otherwise, it uses level-1.
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#configure terminal
(config)#router isis bb
(config-router)#is-type level-1
 
(config)#router isis bb
(config-router)#no is-type
key chain
Use this command to enter the key chain management mode and to configure a key chain with a key chain name. This command allows you to enter the keychain mode to specify keys on this key chain.
Command Syntax
key chain WORD
no key chain WORD
Parameters
WORD
Specify the name of the key chain to manage.
Default
By default, keychain mode is disabled.
Command Mode
Configure mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
The following example shows the creation of a key chain named mychain and the change to keychain mode:
#configure terminal
(config)#key chain mychain
(config-keychain)#
 
key-id
Use this command to manage, add or delete authentication keys in a key-chain. This command allows you to enter the keychain-key mode to set a password for the key.
Command Syntax
key-id <0-2147483647>
no key-id <0-2147483647>
Parameters
<0-2147483647>
Specify a key identifier.
Default
By default, ISIS uses level-1-2 if there is no Level-2 instance nor a Level-1-2 instance. Otherwise, it uses level-1.
Command Mode
Keychain mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
The following example configures a key number 1 and shows the change to keychain-key command mode.
#configure terminal
(config)#key chain mychain
(config-keychain)#key-id 1
(config-keychain-key)#
 
key-string
Use this command to define a password in plain-text to be used by a key.
The password is stored as encrypted, and is displayed in encrypted text when show running-config command is executed.
Use the no parameter with this command to disable this feature.
Command Syntax
key-string WORD
no key-string
Parameters
WORD
Specify a string of characters to be used as a password by the key. The length of the string should be between 1-80 characters.
Default
By default, password is not configured.
Command Mode
Keychain mode and Keychain-key mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
In the following example, the password for key 1 in the key chain named mychain is set to prime:
#configure terminal
(config)#key chain mychain
(config-keychain)#key-id 1
(config-keychain-key)#key-string prime
 
(config-keychain)#key-id 1
(config-keychain-key)#no key-string
 
key-string encrypted
Use this command to define a password in its encrypted format to be used by a key.
Use the no parameter with this command to disable this feature
Command Syntax
key-string encrypted WORD
no key-string encrypted
Parameters
WORD
Specify the encrypted string of characters to be used as a password by the key. The length of this string should be between 18-162 characters.
Default
By default, password is not configured.
Command Mode
Keychain mode and Keychain-key mode.
Applicability
This command was introduced in OcNOS version 4.1.
Examples:
In the following example, the encrypted password for key-id 1 in the key chain named mykeychain is set to 0xd6c50b442de47f70 (equivalent to "mychain" in plain-text):
#configure terminal
(config)#key chain mykeychain
(config-keychain)#key-id 1
(config-keychain-key)#key-string encrypted 0xd6c50b442de47f70
(config-keychain)#key-id 1
(config-keychain-key)#no key-string
 
lsp-gen-interval
Use this command to set the minimum interval before regenerating the same link-state packet (LSP). The smaller the interval, the faster the convergence. However, this setting might cause more frequent flooding.
Use the no parameter with this command to set the interval to the default.
Command Syntax
lsp-gen-interval <1-120>
lsp-gen-interval (level-1|level-2) <1-120>
no lsp-gen-interval (level-1|level-2|)
Parameters
<1-120>
Minimum interval in seconds.
level-1
Interval for Level-1 IS.
level-2
Interval for Level-2 IS.
Default
By default, ISIS uses 5 seconds for the interval and the interval is applied to both level-1 and level-2.
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
#configure terminal
(config)#router isis bb
(config-router)#lsp-gen-interval 10
lsp-mtu
Use this command to set maximum transfer unit for link-state packets (LSPs).
Use the no parameter with this command to set the interval to the default.
Command Syntax
lsp-mtu (level-1|level-2|) <512-4352>
no lsp-mtu (level-1|level-2|)
Parameters
<512-4352>
MTU size
level-1
Size for Level-1 IS.
level-2
Size for Level-2 IS.
Default
By default, the MTU is 1492 bytes.
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
#configure terminal
(config)#router isis bb
(config-router)#lsp-mtu 555
lsp-refresh-interval
Use this command to set the link-state packet (LSP) refresh interval.
IP Infusion Inc. recommends making the lsp-refresh-interval smaller than the max-lsp-lifetime value.
Use the no parameter to set the interval to the default value.
Command Syntax
lsp-refresh-interval <1-65535>
no lsp-refresh-interval
Parameters
<1-65535>
Refresh interval in seconds.
Default
By default, the interval is 900 seconds.
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#configure terminal
(config)#router isis bb
(config-router)#lsp-refresh-interval 600
 
(config)#router isis bb
(config-router)#no lsp-refresh-interval
max-area-address
Use this command to set the maximum number of ISIS areas that can be configured on this router with the net command. By default, ISIS permits a maximum of three areas that can be defined on a router.
Use the no parameter with this command to set the maximum number of ISIS areas to its default (3).
Command Syntax
max-area-address <3-254>
no max-area-address
Parameters
<3-254>
The maximum number of areas in the network.
Default
By default, the maximum number of areas is 3.
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
(config)#router isis net2
(config-router)#max-area-address 5
(config-router)#net 71.0001.0000.0000.0001.00
(config-router)#net 72.0001.0000.0000.0001.00
(config-router)#net 73.0001.0000.0000.0001.00
(config-router)#net 74.0001.0000.0000.0001.00
(config-router)#net 75.0001.0000.0000.0001.00
max-lsp-lifetime
Use this command to set the maximum link-state packet (LSP) lifetime. You must set max-lsp-lifetime greater than the lsp-refresh-interval interval.
Use the no parameter to set the lifetime to the default.
Command Syntax
max-lsp-lifetime <350-65535>
no max-lsp-lifetime
Parameters
<350-65535>
Maximum LSP lifetime in seconds.
Default
By default, max-lsp-lifetime is set to 1200 seconds.
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#configure terminal
(config)#router isis bb
(config-router)#max-lsp-lifetime 1500
 
(config)#router isis bb
(config-router)#no max-lsp-lifetime
metric-style
Use this command to configure the ISIS metric style. Use the following table when changing the method of how TLV encodes and SPF calculates a decision:
 
 
Metric-style Command
Wide SPF
Wide TLV
Narrow SPF
Narrow TLV
narrow (default)
OFF
OFF
ON
OFF
narrow transition
ON
OFF
ON
ON
wide
ON
ON
OFF
OFF
wide transition
ON
ON
ON
OFF
transition
ON
ON
ON
ON
Where:
Wide SPF: Uses wide TLVs for SPF calculation.
Wide TLV: Encodes wide TLVs in the LSP.
Narrow SPF: Uses narrow TLVs for SPF calculation.
Narrow TLV: Encodes narrow TLVs in the LSP.
Use the no parameter to set the style to the default style, narrow.
Command Syntax
metric-style (narrow|wide|transition) (level-1|level-2|)
metric-style (narrow|wide) transition (level-1|level-2|)
no metric-style
Parameters
narrow
Specify the old style of TLVs with narrow metric.
wide
Specify the new style of TLVs to carry wider metric.
transition
Specify to send and accept both styles of TLVs during transition.
level-1
Specify the level-1 metric style.
level-2
Specify the level-2 metric style.
transition
Accept both styles of TLVs during transition
Default
By default, ISIS uses narrow metric style for level 1 and 2.
Command Mode
Router mode
Examples
(config)#router isis bb
(config-router)#metric-style narrow transition
 
mpls traffic-eng
Use this command to configure MPLS Traffic Engineering feature for ISIS.
Use the no parameter to turn off the feature.
Note: Metric-style wide must be enabled before using this CLI.
Command Syntax
mpls traffic-eng (level-1|level-2)
no mpls traffic-eng (level-1|level-2)
Parameters
level-1
Specify the level-1 MPLS Traffic Engineering feature.
level-2
Specify the level-2 MPLS Traffic Engineering feature.
Default
If this command is not used, ISIS does not encode traffic engineering TLVs and Sub-TLVs.
Command Mode
Router mode
Examples
(config)#router isis bb
(config-router)#metric-style wide
(config-router)#mpls traffic-eng level-1
 
(config)#router isis bb
(config-router)#no mpls traffic-eng level-1
mpls traffic-eng router-id
Use this command to configure the traffic engineering stable IP address for a system.
Use the no parameter to turn off the feature.
Command Syntax
mpls traffic-eng router-id A.B.C.D
no mpls traffic-eng router-id
Parameters
A.B.C.D
Specify the ISIS router-ID in an IP address format.
Default
If this command is not used, and traffic engineering is enabled, ISIS will use global router-id..
Command Mode
Router mode
Examples
(config)#router isis bb
(config-router)#mpls traffic-eng router-id 10.10.0.23
 
(config)#router isis bb
(config-router)#no mpls traffic-eng router-id
 
net
Use this command to add a Network Entity Title (NET) for the instance.
On a router running ISIS, a NET can be 8 to 20 bytes in length. The last byte is always the n-selector, and must be zero. The n-selector indicates no transport entity, and means that the packet is for the routing software of the system. The six bytes directly preceding the n-selector are the system ID. The system ID length is a fixed size and cannot be changed. The system ID must be unique throughout each area (Level 1) and throughout the backbone (Level 2).
The bytes preceding the system ID are the area ID, which can be from 1 - 13 bytes in length. By default, a maximum of three NETs per router are allowed with a different area ID but the system ID should be the same for all NETs. You can increase the number of area IDs per system ID with the max-area-address command.
Use the no parameter to remove the NET.
Command Syntax
net NET
no net NET
Parameters
NET
Specify a network entity title (NET) in 1 to 13 octets (that is, XX.XXXX. ... .XXXX.XX).
Default
By default, ISIS does not configure a NET and routing is not enabled for the interface.
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
#configure terminal
(config)#router isis bb
(config-router)#net 49.0000.0001.0002.0003.00
 
passive-interface
Use this command to suppress routing updates on all interfaces or on a specified interface, which puts the interfaces into passive mode.
To advertise passive prefixes in LSP, an interface must be configured with ip router isis when using "passive-interface" command. If interface is not configured with isis instance "passive-interface IFNAME" command must be used to add that interface as passive. Enabling passive interface on an ISIS enabled interface disables ISIS routing updates on the interface and makes the interface passive.
Use the no parameter with this command to remove interfaces from passive mode.
Note: The command passive-interface IFNAME disable is used to make a particular interface active after the passive-interface command (with no parameters) has set all interfaces as passive.
Command Syntax
passive-interface
passive-interface IFNAME
passive-interface IFNAME disable
 
no passive-interface
no passive-interface IFNAME
no passive-interface IFNAME disable
Parameters
IFNAME
Interface name. If this parameter is omitted, then all interfaces become passive or active.
disable
Disable passive interface.
Command Mode
Router mode
Examples
The following suppresses routing updates on a specified interface.
#configure terminal
(config)#router isis 100
(config-router)#passive-interface
(config-router)#passive-interface eth0 disable
 
prc-interval-exp
Use this command to configure exponential back-off delay between PRC calculations.
Use the no parameter to disable any set exponential back-off delay between PRC calculations.
Command Syntax
prc-interval-exp
prc-interval-exp <0-2147483647> <0-2147483647>
no prc-interval-exp
Parameters
<0-2147483647>
Set the minimum delay between receiving a change to PRC calculation in milliseconds.
<0-2147483647>
Set the maximum delay between receiving a change to PRC calculation in milliseconds.
Default
By default, minimum delay is 500 milliseconds and maximum delay is 50 seconds.
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
(config)#router isis
(config-router)#prc-interval-exp 100 10000
 
(config)#router isis
(config-router)#no prc-interval-exp
redistribute
Use this command to redistribute routes from another protocol into the ISIS routing table.
Use the no form of this command to disable redistribution.
Command Syntax
redistribute (kernel|connected|static|rip|ospf|bgp) {metric <0-16777215>| metric-type (internal|external)|level-1|level-2|level-1-2|route-map WORD}
no redistribute (kernel|connected|static|rip|ospf|bgp) {metric <0-16777215>| metric-type (internal|external)|level-1|level-2|level-1-2|route-map WORD}
Parameters
kernel
Redistribute kernel routes.
connected
Redistribute connected routes.
static
Redistribute static routes.
rip
Redistribute RIP routes.
ospf
Redistribute OSPF routes.
bgp
Redistribute BGP routes.
metric
Metric for redistributed routes.
<0-16777215>
 
IS-IS default metric.
metric-type
IS-IS exterior metric type for redistributed routes:
internal
IS-IS internal metric type.
external
IS-IS external metric type.
level-1
Redistribute routes into level 1 only.
level-2
Redistribute routes into level 2 only (default).
level-1-2
Redistribute routes into both levels.
route-map
Route map reference.
WORD
Route map name.
Default
By default, redistribution is disabled.
If no level parameter is specified, by default redistributed routes will be added in level-2 LSP. If is-type of an IS-IS instance is level-1, the level parameter must be set to level-1 for redistribute command to take effect and redistribute routes in L1 LSP.
Command Mode
For IPv4: Router mode
For IPv6: address-family ipv6 mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
(config)#router isis A
(config-router)#redistribute bgp metric 12
redistribute isis
Use this command to redistribute reachability information from one level to the other level. If an distribute-list name is given with this command for an access list that does not exist, the routes are still redistributed.
Use the no form of this command to disable redistribution.
Command Syntax
redistribute isis level-1 into level-2
redistribute isis level-2 into level-1
redistribute isis level-1 into level-2 distribute-list WORD
redistribute isis level-2 into level-1 distribute-list WORD
no redistribute isis level-1 into level-2
no redistribute isis level-2 into level-1
Parameters
level-1
Specify an inter-area route from level-1.
level-2
Specify an inter-area routes from level-2.
into
Specify a level from level-n into level-m.
level-1
Specify an inter-area route into level-1.
level-2
Specify an inter-area routes into level-2.
distribute-list
 
Indicate the distributed-list parameter.
WORD
Specify the actual selected route.
Default
By default, ISIS redistributes selected L1 routes into L2.
Command Mode
For Ipv4: Router mode
For Ipv6: address-family ipv6 mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#configure terminal
(config)#router isis bb
(config-router)#redistribute isis level-2 into level-1
 
(config)#router isis bb
(config-router)#redistribute isis level-2 into level-1 distribute-list new
 
(config)#router isis bb
(config-router)#no redistribute isis level-2 into level-1
redistribute isis WORD
Use this command to redistribute reachability information from one isis instance into another instance. Only one isis instance can be redistributed.
Use the no parameter with this command to stop redistribution.
Note: This command is not supported for address family IPv6.
Command Syntax
redistribute isis WORD {metric <0-16777215>| metric-type (internal | external ) |level-1|level-2|level-1-2|route-map WORD}
no redistribute isis WORD {metric <0-16777215>| metric-type (internal|external) |level-1|level-2|level-1-2|route-map WORD}
Parameters
WORD
Specify an isis instance name or tag
metric
 
Specify the metric for redistributed routes.
<0-16777215>
 
Specify the IS-IS default metric.
metric-type
 
Specify the IS-IS exterior metric type for redistributed routes:
internal
 
Set IS-IS internal metric type.
external
 
Set IS-IS external metric type.
level-1
 
IS-IS Level-1 routes.
level-2
 
IS-IS Level-2 routes.
level-1-2
 
IS-IS Level-1 and Level-2 routes.
route-map
 
Specify a Route map reference.
WORD
 
Specify name of the route-map.
Default
By default, redistribute command is disabled.
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
(config)#router isis A
(config-router)#redistribute isis B metric 12
 
router isis
Use this command to initiate an ISIS routing instance. This command starts the ISIS routing instance and enters router configuration mode. Configure at least one NET to start routing. Also, enable a particular interface with the ip router isis command.
Use the no parameter with this command to remove an ISIS routing instance.
Command Syntax
router isis WORD
no router isis WORD
Parameters
WORD
Name that specifies an ISO routing instance tag.
Default
By default, ISIS routing instance is not configured.
Command Mode
Configure mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
#configure terminal
(config)#router isis New
(config-router)#
send-lifetime
Use this command to specify the time period during which the authentication key on a key chain can be sent.
Use the no parameter with this command to negate this command.
Command Syntax
send-lifetime HH:MM:SS MONTH <01-31> <1993-2035> HH:MM:SS MONTH <01-31> <1993-2035>
send-lifetime HH:MM:SS MONTH <01-31> <1993-2035> infinite
send-lifetime HH:MM:SS MONTH <01-31> <1993-2035> duration <1-2147483646>
no send-lifetime
Parameters
HH:MM:SS
Specify the start time of send-lifetime in hours, minutes and seconds.
<01-31>
Specify the day of the month to start. If the day is a single-digit, the leading 0 must be added, example: 01, 02, 03, etc.
MONTH
Specify the month of the year to start as the first three letters of the month with first letter in caps, for example, Jan. (case sensitive)
<1993-2035>
Specify the year to start.
HH:MM:SS
Specify the end time of send-lifetime in hours, minutes and seconds.
<01-31>
Specify the day of the month to end. If the day is a single-digit, the leading 0 must be added, example: 01, 02, 03, etc.
MONTH
Specify the month of the year to end as the first three letters of the month with first letter in caps, for example, Jan. (case sensitive)
<1993-2035>
Specify the year to end.
duration
Indicate the duration parameter.
<1-2147483646>
 
Specify the actual end time duration of a key in seconds.
infinite
Specify the end time to never expire.
Applicability
No default value is specified
Command Mode
Keychain-key mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
The following example shows the setting of send-lifetime for key-id 1 on the key chain named mychain:
#configure terminal
(config)#key chain mychain
(config-keychain)#key-id 1
(config-keychain-key)#send-lifetime 03:03:01 Jan 03 2004 04:04:02 Dec 06 2006
set-overload-bit
Use this command to set the overload-bit in self link-state packets (LSPs), preventing the router from being used as a transit router during SPF calculation. The router will still receive LSPs even when the overload bit is set.
Use the no parameter to clear the overload-bit from self-LSPs.
Command Syntax
set-overload-bit ({suppress (external|interlevel|external interlevel|interlevel external)|on-startup (<5-86400>|wait-for-bgp)}|)
no set-overload-bit
Parameters
 
Default
The overload-bit is not set by default.
Command Mode
Router mode
Applicability
This command was introduced in OcNOS version 6.4.2.
Example
This example configures the router to set the overload bit at startup, does not allow the unset of the overload bit until BGP converges, suppresses redistribution between levels, and suppresses redistribution from external routing protocols while the overload bit is set.
OcNOS(config)#router isis bb
OcNOS(config-router)#set-overload-bit on-startup wait-for-bgp suppress interlevel external
 
snmp context
Use this command to configure the SNMP context name that is mapped to each isis instance.
When context name is configured isis OID is registered with SNMP to that context.
Use no form of the command to un-map the SNMP context name from isis instance and unregister isis OID from SNMP.
Command Syntax
snmp context-name WORD
no snmp context-name
Parameters
WORD
SNMP context name (Maximum 32 alphanumeric characters)
Default
Option is disabled.
Command Mode
Router mode
Applicability
This command was introduced in OcNOS version 6.4.1.
Examples
OcNOS#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
OcNOS(config)#router isis 1
OcNOS(config-router)#snmp context-name context1
 
snmp restart isis
Use this command to restart SNMP in Intermediate System to Intermediate System (IS-IS)
Command Syntax
snmp restart isis
Parameters
None
Default
By default, snmp restart is not configured.
Command Mode
Configure mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#snmp restart isis
spf-interval-exp
Use this command to set the minimum and maximum hold intervals between Shortest Path First (SPF) calculations.
The spf-interval-exp command configures the minimum and maximum interval time between the receipt of a topology change and the calculation of the SPF.
Use the no parameter with this command to set the minimum and maximum hold intervals to the default.
Command Syntax
spf-interval-exp <0-2147483647> <0-2147483647>
spf-interval-exp (level-1|level-2) <0-2147483647> <0-2147483647>
no spf-interval-exp ((level-1|level-2)|)
Parameters
<0-2147483647>
Specify the minimum delay between receiving a change to the SPF calculation in milliseconds. The default SPF minimum hold-time interval value is 500 milliseconds.
<0-2147483647>
Specify the maximum delay between receiving a change to the SPF calculation in milliseconds. The default SPF maximum hold-time interval value is 50 seconds.
level-1
Specify an interval for Level-1 IS.
level-2
Specify an interval for Level-2 IS.
Default
By default, ISIS uses 500 milliseconds and 50,000 milliseconds for the minimum and maximum hold intervals, respectively. The values are applied to both level-1 and level-2 if the level parameter is omitted.
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#configure terminal
(config)#router isis bb
(config-router)#spf-interval-exp level-1 600 60000
 
(config)#router isis bb
(config-router)#no spf-interval-exp level-1
summary-address
Use this command to configure Summary Address to summarize IPv4 reachability information.
Use the no parameter with this command to unconfigure the summary.
Command Syntax
summary-address A.B.C.D/M (level-1 |level-1-2 |level-2) (metric <1-63>|)
no summary-address A.B.C.D/M
Parameters
A.B.C.D/M
Specify the IPv4 prefix to be announced.
level-1
Specify the reachability information only for Level-1.
level-1-2
Specify the reachability information for both Level-1 and Level-2.
level-2
Specify the reachability information only for Level-2.
metric
Specify the metric for the summarized address.
<1-63>
Specify the metric. The default is 0.
Default
By default, ISIS does not configure the summary-address. Level must be configured along with summary-address. Metric is optional.
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#configure terminal
(config)#router isis bb
(config-router)#summary-address 10.10.0.0/16 level-1-2 metric 3
 
(config)#router isis bb
(config-router)#no summary-address 10.10.0.0/16
summary-prefix
Use this command to configure Summary Prefix to summarize IPv6 reachability information.
Use the no parameter with this command to unconfigure the summary.
Command Syntax
summary-prefix X:X::X:X/M (level-1 |level-1-2 |level-2) (metric <1-63>|)
no summary-prefix X:X::X:X/M
Parameters
X:X::X:X/M
Specify the IPv6 prefix to be announced.
level-1
Specify the reachability information only for Level-1.
level-1-2
Specify the reachability information for both Level-1 and Level-2.
level-2
Specify the reachability information only for Level-2.
metric
Specify the metric for the summarized address.
<1-63>
Specify the metric. The default is 0.
Default
By default, ISIS does not configure the summary-prefix. Level must be configured along with summary-prefix. Metric is optional.
Command Mode
Address Family IPv6 mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#configure terminal
(config)#router isis 1
(config-router)#address-family ipv6
(config-router-af)#summary-prefix 2356::1/64 level-1 metric 30