OcNOS-SP : Layer 2 Guide : Layer 2 Configuration Guide : PW Redundancy with MLAG Configuration
PW Redundancy with MLAG Configuration
This chapter contains configuration for Pseudowire Redundancy with MLAG (Active and Standby). It also provides an overview of Pseudowire concepts.
In a single-segment pseudowire (SS-PW) application, the Packet Switched Network (PSN) layer usually provides protection for the PW. One way is by using an RSVP LSP with Fast Reroute (FRR) backup; another way is an end-to-end backup LSP. However, there are some applications where the backup PW terminates on a different target PE node, so PSN protection methods cannot protect against failure of either the target Provider Edge (PE) node or a remote Access Circuit (AC). It is also important for an operator that a particular PW is preferred. For example, the one with the least latency.
PW redundancy supports Label Distribution Protocol (LDP) PW. In the case of PW applications, the PSN layer can provide the protection for PW. Occasionally, a TE LSP signaled by RSVP-TE can be used as a PSN tunnel for a PW. In this scenario, TE can provide FRR to protect the end-to-end LSP in the PSN layer.
FRR-based protection schemes cannot protect against failure of PE nodes and access circuits. However, PW redundancy can protect against these failures.
MLAG expands the concept of link aggregation so that it provides node-level redundancy by allowing two nodes to share a common LAG endpoint. This gives PE redundancy for CE node.
CE devices can be connected to two PE nodes for PE-node-level redundancy using MLAG.
End-to-End traffic flow decision will take by MLAG Active node not by PW-Redundancy node.
Topology
In the below example PE1 and PE2 forms a MLAG domain.
As shown in Figure 14-32, PE1 and PE2 are a single logical switches to P3 and P4. Even if either PE1 or PE2 is down, there exists a path to reach other destinations.
 
MLAG Topology
Uplink Interface and OSPF Configuration
PE1
 
#configure terminal
Enter configure mode.
(config)#interface lo
Configure the Loopback interface.
(config-if)# ip address 35.35.35.35/32 secondary
Set the IP address of the loopback interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe5
Enter interface mode.
(config-if)# ip address 10.35.48.1/30
Set the IP address of the interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe9
Enter interface mode.
(config-if)# ip address 10.35.33.1/30
Set the IP address of the interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe10
Enter interface mode.
(config-if)# ip address 10.35.49.1/30
Set the IP address of the interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf 100
Enter the Router mode for OSPF.
(config-router)#ospf router-id 35.35.35.35
Configure OSPF router ID.
(config-router)# bfd all-interfaces
Configure BFD on OSPF.
(config-router)#network 10.35.48.0/30 area 0.0.0.0
Define the Network on which OSPF runs and associate the
area ID (area 0) with the interface.
 
 
(config-router)#network 10.35.49.0/30 area 0.0.0.0
Define the Network on which OSPF runs and associate the
area ID (area 0) with the interface.
(config-router)#network 10.35.33.0/30 area 0.0.0.0
Define the Network on which OSPF runs and associate the
area ID (area 0) with the interface.
 
(config-router)#exit
Exit router mode.
PE2
 
#configure terminal
Enter configure mode.
(config)#interface lo
Configure the Loopback interface.
(config-if)# ip address 33.33.33.33/32 secondary
Set the IP address of the loopback interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe5
Enter interface mode.
(config-if)# ip address 10.33.49.1/30
Set the IP address of the interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe9
Enter interface mode.
(config-if)# ip address 10.35.33.2/30
Set the IP address of the interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe11
Enter interface mode.
(config-if)# ip address 10.33.48.1/30
Set the IP address of the interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf 100
Enter the Router mode for OSPF.
(config-router)#ospf router-id 33.33.33.33
Configure OSPF router ID.
(config-router)# bfd all-interfaces
Configure BFD on OSPF.
(config-router)#network 10.33.48.0/30 area 0.0.0.0
Define the Network on which OSPF runs and associate the
area ID (area 0) with the interface.
 
(config-router)#network 10.33.49.0/30 area 0.0.0.0
Define the Network on which OSPF runs and associate the
area ID (area 0) with the interface.
 
(config-router)#network 10.35.33.0/30 area 0.0.0.0
Define the Network on which OSPF runs and associate the
area ID (area 0) with the interface.
(config-router)#exit
Exit router mode
 
P3
 
#configure terminal
Enter configure mode.
(config)#interface lo
Configure the Loopback interface.
(config-if)# ip address 48.48.48.48/32 secondary
Set the IP address of the loopback interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe5
Enter interface mode.
(config-if)# ip address 10.35.48.2/30
Set the IP address of the interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe6
Enter interface mode.
(config-if)# ip address 10.48.32.1/30
Set the IP address of the interface
(config-if)#exit
Exit interface mode.
(config)# interface xe7
Enter interface mode.
(config-if)# ip address 10.48.49.1/30
Set the IP address of the interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe11
Enter interface mode.
(config-if)# ip address 10.33.48.2/30
Set the IP address of the interface
(config-if)#exit
Exit interface mode.
(config)#router ospf 100
Enter the Router mode for OSPF.
(config-router)#ospf router-id 48.48.48.48
Configure OSPF router ID.
(config-router)# bfd all-interfaces
Configure BFD on OSPF.
(config-router)#network 10.35.48.0/30 area 0.0.0.0
Define the Network on which OSPF runs and associate the
area ID (area 0) with the interface.
 
(config-router)#network 10.48.49.0/30 area 0.0.0.0
Define the Network on which OSPF runs and associate the
area ID (area 0) with the interface.
 
(config-router)#network 10.48.32.0/30 area 0.0.0.0
Define the Network on which OSPF runs and associate the
area ID (area 0) with the interface.
(config-router)#network 10.33.48.0/30 area 0.0.0.0
Define the Network on which OSPF runs and associate the
area ID (area 0) with the interface.
(config-router)#exit
Exit router mode
 
P4
 
#configure terminal
Enter configure mode.
(config)#interface lo
Configure the Loopback interface.
(config-if)# ip address 49.49.49.49/32 secondary
Set the IP address of the loopback interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe5
Enter interface mode.
(config-if)# ip address 10.33.49.2/30
Set the IP address of the interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe6
Enter interface mode.
(config-if)# ip address 10.49.32.1/30
Set the IP address of the interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe7
Enter interface mode.
(config-if)# ip address 10.48.49.2/30
Set the IP address of the interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe10
Enter interface mode.
(config-if)# ip address 10.35.49.2/30
Set the IP address of the interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf 100
Enter the Router mode for OSPF.
(config-router)#ospf router-id 49.49.49.49
Configure OSPF router ID.
(config-router)# bfd all-interfaces
Configure BFD on OSPF.
(config-router)#network 10.35.49.0/30 area 0.0.0.0
Define the Network on which OSPF runs and associate the
area ID (area 0) with the interface.
 
(config-router)#network 10.48.49.0/30 area 0.0.0.0
Define the Network on which OSPF runs and associate the
area ID (area 0) with the interface.
 
(config-router)#network 10.49.32.0/30 area 0.0.0.0
Define the Network on which OSPF runs and associate the
area ID (area 0) with the interface.
(config-router)#network 10.33.49.0/30 area 0.0.0.0
Define the Network on which OSPF runs and associate the
area ID (area 0) with the interface.
(config-if)#exit
Exit interface mode.
 
P5
 
#configure terminal
Enter configure mode.
(config)#interface lo
Configure the Loopback interface.
(config-if)# ip address 32.32.32.32/32 secondary
Set the IP address of the loopback interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe6
Enter interface mode.
(config-if)# ip address 10.48.32.2/30
Set the IP address of the interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe7
Enter interface mode.
(config-if)# ip address 10.49.32.1/30
Set the IP address of the interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf 100
Enter the Router mode for OSPF.
(config-router)#ospf router-id 32.32.32.32
Configure OSPF router ID.
(config-router)# bfd all-interfaces
Configure BFD on OSPF.
(config-router)#network 10.48.32.0/30 area 0.0.0.0
Define the Network on which OSPF runs and associate the
area ID (area 0) with the interface.
 
(config-router)#network 10.49.32.0/30 area 0.0.0.0
Define the Network on which OSPF runs and associate the
area ID (area 0) with the interface.
 
(config-if)#exit
Exit interface mode.
 
RSVP Global Configuration
PE1
 
#configure terminal
Enter configure mode.
(config)#router rsvp
Enter the router mode for RSVP.
(config-router)# no php
Configure no PHP
(config-router)#exit
Exit router mode.
(config)# interface xe5
Enter interface mode.
(config-if)# label-switching
Enable label switching on the interface
(config-if)# enable-rsvp
Enable RSVP on the interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe9
Enter interface mode.
(config-if)# label-switching
Enable label switching on the interface
(config-if)# enable-rsvp
Enable RSVP on the interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe10
Enter interface mode.
(config-if)# label-switching
Enable label switching on the interface
(config-if)# enable-rsvp
Enable RSVP on the interface.
(config-if)#exit
Exit interface mode.
PE2
 
#configure terminal
Enter configure mode.
(config)#router rsvp
Enter the Router mode for RSVP.
(config-router)# no php
Configure no PHP
(config-router)#exit
Exit router mode.
(config)# interface xe5
Enter interface mode.
(config-if)# label-switching
Enable label switching on the interface
(config-if)# enable-rsvp
Enable RSVP on the interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe9
Enter interface mode.
(config-if)# label-switching
Enable label switching on the interface.
(config-if)# enable-rsvp
Enable RSVP on the interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe11
Enter interface mode.
(config-if)# label-switching
Enable label switching on the interface
(config-if)# enable-rsvp
Enable RSVP on the interface.
(config-if)#exit
Exit interface mode.
 
P3
 
#configure terminal
Enter configure mode.
(config)#router rsvp
Enter the Router mode for RSVP.
(config-router)# no php
Configure no PHP
(config-router)#exit
Exit router mode.
(config)# interface xe5
Enter interface mode.
(config-if)# label-switching
Enable label switching on the interface
(config-if)# enable-rsvp
Enable RSVP on the interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe6
Enter interface mode.
(config-if)# label-switching
Enable label switching on the interface
(config-if)# enable-rsvp
Enable RSVP on the interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe7
Enter interface mode.
(config-if)# label-switching
Enable label switching on the interface
(config-if)# enable-rsvp
Enable RSVP on the interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe11
Enter interface mode.
(config-if)# label-switching
Enable label switching on the interface
(config-if)# enable-rsvp
Enable RSVP on the interface.
(config-if)#exit
Exit interface mode.
 
P4
 
#configure terminal
Enter configure mode.
(config)#router rsvp
Enter the Router mode for RSVP.
(config-router)# no php
Configure no PHP
(config-router)#exit
Exit router mode.
(config)# interface xe5
Enter interface mode.
(config-if)# label-switching
Enable label switching on the interface
(config-if)# enable-rsvp
Enable RSVP on the interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe6
Enter interface mode.
(config-if)# label-switching
Enable label switching on the interface
(config-if)# enable-rsvp
Enable RSVP on the interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe7
Enter interface mode.
(config-if)# label-switching
Enable label switching on the interface
(config-if)# enable-rsvp
Enable RSVP on the interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe10
Enter interface mode.
(config-if)# label-switching
Enable label switching on the interface
(config-if)# enable-rsvp
Enable RSVP on the interface.
(config-if)#exit
Exit interface mode.
 
P5
 
#configure terminal
Enter configure mode.
(config)#router rsvp
Enter the Router mode for RSVP.
(config-router)# no php
Configure no PHP
(config-router)#exit
Exit router mode.
(config)# interface xe6
Enter interface mode.
(config-if)# label-switching
Enable label switching on the interface
(config-if)# enable-rsvp
Enable RSVP on the interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe7
Enter interface mode.
(config-if)# label-switching
Enable label switching on the interface
(config-if)# enable-rsvp
Enable RSVP on the interface.
(config-if)#exit
Exit interface mode.
 
RSVP-LSP Configuration
PE1
 
#configure terminal
Enter configure mode.
(config)# rsvp-path 35-to-32 mpls
Configure RSVP-Path PE5
(config-path)# 10.35.48.2 strict
Configure Strict hop
(config-path)# 10.48.32.2 strict
Configure Strict hop
(config-path)#exit
Exit RSVP-Path mode
(config)#rsvp-trunk 35-to-32
Configure RSVP-Trunk to PE5
(config-trunk)# primary fast-reroute protection one-to-one
Set FRR one-to-one mode.
(config-trunk)# primary fast-reroute node-protection
Set FRR node protection
(config-trunk)# primary path 35-to-32
Set RSVP path.
(config-trunk)# to 32.32.32.32
Configure RSVP-LSP destination IP address
(config-trunk)#exit
Exit RSVP-Trunk mode
PE2
 
#configure terminal
Enter configure mode.
(config)# rsvp-path 33-to-32 mpls
Configure RSVP-Path to PE5
(config-path)# 10.33.49.2 strict
Configure Strict hop
(config-path)# 10.49.32.2 strict
Configure Strict hop
(config-path)#exit
Exit RSVP path mode
(config)#rsvp-trunk 33-to-32
Configure RSVP trunk to PE5.
(config-trunk)# primary fast-reroute protection one-to-one
Set FRR one-to-one mode.
(config-trunk)# primary fast-reroute node-protection
Set FRR node protection
(config-trunk)# primary path 33-to-32
Set RSVP path.
(config-trunk)# to 32.32.32.32
Configure RSVP LSP destination IP address.
(config-trunk)#exit
Exit RSVP-Trunk mode
 
PE5
 
#configure terminal
Enter configure mode.
(config)# rsvp-path 32-to-35 mpls
Configure RSVP path to PE1
(config-path)# 10.48.32.1 strict
Configure Strict hop
(config-path)# 10.35.48.1 strict
Configure Strict hop
(config-path)#exit
Exit RSVP path mode
(config)# rsvp-path 32-to-33 mpls
Configure RSVP path to PE2
(config-path)# 10.49.32.1 strict
Configure Strict hop
(config-path)# 10.33.49.1 strict
Configure Strict hop
(config-path)#exit
Exit RSVP path mode
(config)#rsvp-trunk 32-to-35
Configure RSVP trunk.to PE1.
(config-trunk)# primary fast-reroute protection one-to-one
Set FRR one-to-one mode.
(config-trunk)# primary fast-reroute node-protection
Set FRR node protection
(config-trunk)# primary path 32-to-35
Set RSVP path
(config-trunk)# to 33.33.33.33
Configure RSVP-LSP destination IP address.
(config-trunk)#exit
Exit RSVP trunk mode
 
T-LDP Configuration
PE1
 
#configure terminal
Enter configure mode.
(config)#router ldp
Enter the router mode for LDP.
(config-router)# router-id 35.35.35.35
Configure LDP router ID.
(config-router)# pw-status-tlv
Set PW status TLV
(config-router)# no multicast-hellos
Disable Multicast hellos
(config-router)# targeted-peer ipv4 32.32.32.32
Configure LDP targeted peer to PE5
(config-router-targeted-peer)# exit-targeted-peer-mode
Exit targeted peer mode.
(config-router)#exit
Exit router mode
(config)# interface xe5
Enter interface mode.
(config-if)# enable-ldp ipv4
Enable IPv4 LDP on the interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe9
Enter interface mode.
(config-if)# enable-ldp ipv4
Enable IPv4 LDP on the interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe10
Enter interface mode.
(config-if)# enable-ldp ipv4
Enable IPv4 LDP on the interface.
(config-if)#exit
Exit interface mode.
PE2
 
#configure terminal
Enter configure mode.
(config)#router ldp
Enter the router mode for LDP.
(config-router)# router-id 33.33.33.33
Configure LDP router ID
(config-router)# pw-status-tlv
Set PW status TLV.
(config-router)# no multicast-hellos
Disable multicast hellos
(config-router)# targeted-peer ipv4 32.32.32.32
Configure LDP targeted peer to PE5
(config-router-targeted-peer)# exit-targeted-peer-mode
Exit targeted peer mode.
(config-router)#exit
Exit router mode
(config)# interface xe5
Enter interface mode.
(config-if)# enable-ldp ipv4
Enable IPv4 LDP on the interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe9
Enter interface mode.
(config-if)# enable-ldp ipv4
Enable IPv4 LDP on the interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe11
Enter interface mode.
(config-if)# enable-ldp ipv4
Enable IPv4 LDP on the interface.
(config-if)#exit
Exit interface mode.
 
PE5
 
#configure terminal
Enter configure mode.
(config)#router ldp
Enter the router mode for LDP.
(config-router)# router-id 32.32.32.32
Configure LDP router ID
(config-router)# pw-status-tlv
Set PW status TLV
(config-router)# no multicast-hellos
Disable multicast hellos
(config-router)# targeted-peer ipv4 35.35.35.35
Configure LDP targeted peer to PE5
(config-router-targeted-peer)# exit-targeted-peer-mode
Exit targeted peer mode.
(config-router)# targeted-peer ipv4 33.33.33.33
Configure LDP targeted peer to PE5
(config-router-targeted-peer)# exit-targeted-peer-mode
Exit targeted peer mode.
(config-router)#exit
Exit router mode
(config)# interface xe6
Enter interface mode.
(config-if)# enable-ldp ipv4
Enable IPv4 LDP on the interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe7
Enter interface mode.
(config-if)# enable-ldp ipv4
Enable IPv4 LDP on the interface.
(config-if)#exit
Exit interface mode.
 
MLAG Configuration
CE1
 
#configure terminal
Enter configure mode.
(config)#interface po1
Configure the LAG interface
(config-if)#switchport
Configure the interface as Layer 2
(config-if)#exit
Exit interface mode.
(config)#interface xe1
Enter interface mode.
(config-if)#channel-group 1 mode active
Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#channel-group 1 mode active
Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by
 
the local system
(config-if)#exit
Exit interface mode.
(config)#interface xe3
Enter interface mode.
(config-if)#channel-group 1 mode active
Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system
(config-if)#exit
Exit interface mode.
(config)#interface xe4
Enter interface mode.
(config-if)#channel-group 1 mode active
Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system
(config-if)#exit
Exit interface mode.
PE1
 
#configure terminal
Enter configure mode.
(config)#mcec domain configuration
Configure MLAG global.
(config-mcec-domain)# domain-address 1111.2222.3333
Configure the domain address.
(config-mcec-domain)# domain-system-number 1
Configure Domain System number.
(config-mcec-domain)# intra-domain-link xe6
Configure IDL link.
(config-mcec-domain)#exit
Exit MLAG global mode.
(config)#interface po1
Configure the LAG interface
(config-if)#switchport
Configure the interface as Layer 2
(config-if)#exit
Exit interface mode.
(config)#interface xe1
Enter interface mode.
(config-if)#channel-group 1 mode active
Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#channel-group 1 mode active
Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system
(config-if)#exit
Exit interface mode.
(config)#interface po1
Configure the LAG interface
(config-if)# mlag 1
Configure MLAG domain to LAG interface
(config-if)#exit
Exit interface mode.
 
PE2
 
#configure terminal
Enter configure mode.
(config)#mcec domain configuration
Configure MLAG global
(config-mcec-domain)# domain-address 1111.2222.3333
Configure the Domain address
(config-mcec-domain)# domain-system-number 2
Configure Domain System number.
(config-mcec-domain)# intra-domain-link xe6
Configure IDL link.
(config-mcec-domain)#exit
Exit MLAG global mode.
(config)#interface po1
Configure the LAG interface
(config-if)#switchport
Configure the interface as Layer 2
(config-if)#exit
Exit interface mode.
(config)#interface xe3
Enter interface mode.
(config-if)#channel-group 1 mode active
Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system
(config-if)#exit
Exit interface mode.
(config)#interface xe4
Enter interface mode.
(config-if)#channel-group 1 mode active
Add this interface to channel group 1 and enable link aggregation so that it can be selected for aggregation by the local system
(config-if)#exit
Exit interface mode.
(config)#interface po1
Configure the LAG interface
(config-if)# mlag 1
Configure MLAG domain to LAG interface
(config-if)#exit
Exit interface mode.
 
VPWS PW Redundancy Configuration
PE1
 
#configure terminal
Enter configure mode.
(config)#service-template S-00-00-10
Configure service template (translate)
(config-svc)# match outer-vlan 10
Configure match
(config-svc)# rewrite ingress translate 20 outgoing-tpid dot1.q
Configure rewrite action
(config-svc)#exit
Exit service template
(config)# mpls l2-circuit VC1 1001 32.32.32.32
Configure VPWS to PE5
(config-pseudowire)#exit
Exit pseudowire config mode.
(config)#int po1
Enter interface mode
(config-if)#mpls-l2-circuit VC1 service-template S-00-00-10
Attach VPWS to AC interface.
(config-if)#exit
Exit interface
PE2
 
#configure terminal
Enter configure mode.
(config)#service-template S-00-00-10
Configure service template (translate)
(config-svc)# match outer-vlan 10
Configure match
(config-svc)# rewrite ingress translate 20 outgoing-tpid dot1.q
Configure rewrite action
(config-svc)#exit
Exit service template
(config)# mpls l2-circuit VC2 1002 32.32.32.32
Configure VPWS to PE5
(config-pseudowire)#exit
Exit pseudowire config mode.
(config)#int po1
Enter interface mode
(config-if)#mpls-l2-circuit VC2 service-template S-00-00-10
Attach VPWS to AC interface.
(config-if)#exit
Exit interface
 
PE5
 
#configure terminal
Enter configure mode.
(config)#service-template S-00-00-10
Configure service template (translate)
(config-svc)# match outer-vlan 10
Configure match
(config-svc)# rewrite ingress translate 20 outgoing-tpid dot1.q
Configure rewrite action
(config-svc)#exit
Exit service template
(config)# mpls l2-circuit VC1 1001 35.35.35.35
Configure VPWS to PE1
(config-pseudowire)#exit
Exit pseudowire config mode.
(config)# mpls l2-circuit VC2 1002 33.33.33.33
Configure VPWS to PE2
(config-pseudowire)#exit
Exit pseudowire config mode.
(config)#int xe8
Enter interface mode
(config-if)# switchport
Switch to Layer 2 mode.
(config-if)#mpls-l2-circuit VC1 service-template S-00-00-10
Attach Primary VPWS to AC interface.
(config-if)# mpls-l2-circuit VC2 service-template S-00-00-10 secondary
Attach Secondary VPWS to AC interface.
(config-if)#exit
Exit interface
 
Validation
To see detail information about the MLAG, use the following command:
MLAG Active node:
PE1#show mlag domain details
 
------------------------------------
Domain Configuration
------------------------------------
 
Domain System Number : 1
Domain Address : 1111.2222.3333
Domain Priority : 32768
Intra Domain Interface : xe12
 
Hello RCV State : Current
Hello Periodic Timer State : Slow Periodic
Domain Sync : IN_SYNC
Neigh Domain Sync : IN_SYNC
Domain Adjacency : UP
 
------------------------------------
MLAG Configuration
------------------------------------
 
MLAG-1
Mapped Aggregator : po1
Admin Key : 16385
Oper Key : 16385
Physical properties Digest : 89 25 47 22 f1 47 6d 92 b8 71 9c ca 61 fb db 3a
 
Neigh Admin Key : 32769
Neigh Physical Digest : 89 25 47 22 f1 47 6d 92 b8 71 9c ca 61 fb db 3a
Info RCV State : Current
Info Periodic Time State : Standby
Mlag Sync : IN_SYNC
Mode : Active-Standby
Current Mlag state : Active
 
 
MLAG Standby node:
 
PE2#show mlag domain details
 
------------------------------------
Domain Configuration
------------------------------------
 
Domain System Number : 2
Domain Address : 1111.2222.3333
Domain Priority : 32768
Intra Domain Interface : xe12
 
Hello RCV State : Current
Hello Periodic Timer State : Slow Periodic
Domain Sync : IN_SYNC
Neigh Domain Sync : IN_SYNC
Domain Adjacency : UP
 
------------------------------------
MLAG Configuration
------------------------------------
 
MLAG-1
Mapped Aggregator : po1
Admin Key : 32769
Oper Key : 32769
Physical properties Digest : 89 25 47 22 f1 47 6d 92 b8 71 9c ca 61 fb db 3a
 
Neigh Admin Key : 16385
Neigh Physical Digest : 89 25 47 22 f1 47 6d 92 b8 71 9c ca 61 fb db 3a
Info RCV State : Current
Info Periodic Time State : Standby
Mlag Sync : IN_SYNC
Mode : Active-Standby
Current Mlag state : Standby
 
To see summary information about the MLAG, use the following command:
MLAG active node:
PE1#show mlag domain summary
 
------------------------------------
Domain Configuration
------------------------------------
 
Domain System Number : 2
Domain Address : 1111.2222.3333
Domain Priority : 32768
Intra Domain Interface : xe12
Domain Adjacency : UP
Domain Sync via : Intra-domain-interface
------------------------------------
MLAG Configuration
------------------------------------
 
MLAG-1
Mapped Aggregator : po1
Physical properties Digest : 89 25 47 22 f1 47 6d 92 b8 71 9c ca 61 fb db 3a
Total Bandwidth : 20g
Mlag Sync : IN_SYNC
Mode : Active-Standby
Current Mlag state : Active
 
MLAG Standby node:
PE2#show mlag domain summary
 
------------------------------------
Domain Configuration
------------------------------------
 
Domain System Number : 1
Domain Address : 1111.2222.3333
Domain Priority : 32768
Intra Domain Interface : xe12
Domain Adjacency : UP
Domain Sync via : Intra-domain-interface
------------------------------------
MLAG Configuration
------------------------------------
 
MLAG-1
Mapped Aggregator : po1
Physical properties Digest : 89 25 47 22 f1 47 6d 92 b8 71 9c ca 61 fb db 3a
Total Bandwidth : 20g
Mlag Sync : IN_SYNC
Mode : Active-Standby
Current Mlag state : Standby
 
To see summary information about the Virtual Circuits, use the following command:
#show mpls vc-table
The samples below show summary information about the just-configured four virtual circuits.
PE1#show mpls vc-table
VC-ID Vlan-ID Inner-Vlan-ID Access-Intf Network-Intf Out Label Tunnel-Label Nexthop Status
1001 N/A N/A po1 xe14 24960 24324 32.32.32.32 Active
PE1#
 
PE2#show mpls vc-table
VC-ID Vlan-ID Inner-Vlan-ID Access-Intf Network-Intf Out Label Tunnel-Label Nexthop Status
1002 N/A N/A po1 xe14 24961 24323 32.32.32.32 Inactive
PE2#
 
PE5#show mpls vc-table
VC-ID Vlan-ID Inner-Vlan-ID Access-Intf Network-Intf Out Label Tunnel-Label Nexthop Status
1001 N/A N/A xe23 xe12 24986 24322 35.35.35.35 Active
1002 N/A N/A xe23 xe12 24968 24320 33.33.33.33 Inactive
PE5#
 
 
To view detailed configuration information about the L2 Virtual Circuits, including LDP PW status, use the following
command:
PE1#show ldp mpls-l2-circuit 1001 detail
vcid: 1001 type: vlan, local groupid: 0, remote groupid: 0 (vc is up)
destination: 32.32.32.32, Peer LDP Ident: 32.32.32.32
Local label: 24986, remote label: 24960
Access IF: po1, Network IF: xe13
Local MTU: 9100, Remote MTU: 9100
Local Control Word: disabled Remote Control Word: Not-Applicable Current use: disabled
Local PW Status Capability : enabled
Remote PW Status Capability : enabled
Current PW Status TLV : enabled
Local PW Status :
Forwarding
Active
Remote PW Status :
Forwarding
Active
 
PE2#show ldp mpls-l2-circuit 1002 detail
vcid: 1002 type: vlan, local groupid: 0, remote groupid: 0 (vc is up)
destination: 32.32.32.32, Peer LDP Ident: 32.32.32.32
Local label: 24968, remote label: 24961
Access IF: po1, Network IF: xe14
Local MTU: 9100, Remote MTU: 9100
Local Control Word: disabled Remote Control Word: Not-Applicable Current use: disabled
Local PW Status Capability : enabled
Remote PW Status Capability : enabled
Current PW Status TLV : enabled
Local PW Status :
Not Forwarding
Ingress AC Receive Fault
Egress AC Transmit Fault
Remote PW Status :
Not Forwarding
Standby
 
PE5#show ldp mpls-l2-circuit 1001 detail
vcid: 1001 type: vlan, local groupid: 0, remote groupid: 0 (vc is up)
destination: 35.35.35.35, Peer LDP Ident: 35.35.35.35
Local label: 24960, remote label: 24986
Access IF: xe23, Network IF: xe14
Local MTU: 9100, Remote MTU: 9100
Local Control Word: disabled Remote Control Word: Not-Applicable Current use: disabled
Local PW Status Capability : enabled
Remote PW Status Capability : enabled
Current PW Status TLV : enabled
Local PW Status :
Forwarding
Active
Remote PW Status :
Forwarding
Active
 
PE5#show ldp mpls-l2-circuit 1002 detail
vcid: 1002 type: vlan, local groupid: 0, remote groupid: 0 (vc is up)
destination: 33.33.33.33, Peer LDP Ident: 33.33.33.33
Local label: 24961, remote label: 24968
Access IF: xe23, Network IF: xe12
Local MTU: 9100, Remote MTU: 9100
Local Control Word: disabled Remote Control Word: Not-Applicable Current use: disabled
Local PW Status Capability : enabled
Remote PW Status Capability : enabled
Current PW Status TLV : enabled
Local PW Status :
Not Forwarding
Standby
Remote PW Status :
Not Forwarding
Ingress AC Receive Fault
Egress AC Transmit Fault