OcNOS-SP : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : 6PE Configuration
6PE Configuration
This chapter explains about IPv6 islands over IPv4 MPLS using IPv6 Provider Edge Routers (6PE). With this technique, IPv6 islands are connected to each other across an IPv4 backbone enabled with MPLS label stacking while MP-BGP is used to announce the IPv6 routes across these MPLS tunnels. This feature can be implemented with label- switched paths (LSPs) using the Label Distribution Protocol (LDP) or Resource Reservation Protocol (RSVP).
This feature offers the following options to the service providers:
Connect to other IPv6 networks accessible across the MPLS core.
Provide access to IPv6 services and resources that service provider provides.
Provide IPv6 VPN services without going for complete overhaul of existing MPLS/IPv4 core.
The 6PE uses the existing IPv4 MPLS core infrastructure for IPv6 transport. It enables IPv6 sites to communicate with each other over an IPv4 MPLS core network using MPLS label switched paths (LSPs). This feature relies heavily on multiprotocol Border Gateway Protocol (BGP) extensions in the IPv4 network configuration on the provider edge (PE) router to exchange IPv6 reachability information (in addition to an MPLS label) for each IPv6 address prefix. Edge routers are configured as dual-stack, running both IPv4 and IPv6, and use the IPv4 mapped IPv6 address for IPv6 prefix reachability exchange.
Benefits of 6PE
6PE offers the following benefits to service providers:
Minimal operational cost and risk - No impact on existing IPv4 and MPLS services.
Only provider edge routers require upgrade - A 6PE router can be an existing PE router or a new one dedicated to IPv6 traffic.
No impact on IPv6 customer edge (CE) routers - The ISP can connect to any CE router running Static, IGP or EGP.
Production services ready - An ISP can delegate IPv6 prefixes.
IPv6 introduction into an existing MPLS service - 6PE routers can be added at any time.
IPv6 on Provider Edge Routers
The 6PE is a technique that provides global IPv6 reachability over IPv4 MPLS. It allows one shared routing table for all other devices. 6PE allows IPv6 domains to communicate with one another over the IPv4 without an explicit tunnel setup, requiring only one IPv4 address per IPv6 domain. While implementing 6PE, the provider edge routers are upgraded to support 6PE, while the rest of the core network is not touched (IPv6 unaware).
This implementation requires no re-configuration of core routers because forwarding is based on labels rather than on the IP header itself. This provides a cost-effective strategy for deploying IPv6.The IPv6 reachability information is exchanged by PE routers using multi-protocol Border Gateway Protocol (mp-iBGP) extensions. 6PE relies on mp-iBGP extensions in the IPv4 network configuration on the PE router to exchange IPv6 reachability information in addition to an MPLS label for each IPv6 address prefix to be advertised. PE routers are configured as dual stacks, running both IPv4 and IPv6, and use the IPv4 mapped IPv6 address for IPv6 prefix reachability exchange. The next hop advertised by the PE router for 6PE prefixes is still the IPv4 address that is used for IPv4 L3 VPN routes.
The following figure illustrates the 6PE topology.
Topology
As shown in Figure 4-5:
CE1 and CE2 are customer edge routers
6PE1 and 6PE2 are IPv6 Provider Edge routers
P is the router at the core of the IPv4 MPLS provider network
6PE Configuration
Configuration
CE1
 
#configure terminal
Enter configure mode
(config)#interface lo
Enter interface mode
(config-if)#ip address 44.44.44.44/32 secondary
Assign the IPv4 address
(config-if)#exit
Exit interface mode
(config)#interface xe1
Enter interface mode.
(config-if)#ipv6 address 2001::2/64
Assign the IPv6 address.
(config-if)#exit
Exit interface mode.
(config)#router bgp 200
Enter router BGP mode.
(config-router)#bgp router-id 44.44.44.44
Assign router ID
(config-router)#neighbor 2001::1 remote-as 100
Configure 6PE1 as an eBGP4+ neighbor.
(config-router)#address-family ipv6 unicast
Enter Address-Family IPv6 unicast mode
(config-router-af)#redistribute static
Redistribute static routes
(config-router-af)#neighbor 2001::1 activate
Activate the neighbor in the IPv6 address family
(config-router-af)#exit
Exit address family
(config-router)#ipv6 route 2ffe::/64 xe1
Configure IPV6 static route
(config-router)#commit
Commit the transaction
CE2
 
#configure terminal
Enter configure mode
(config)#interface lo
Enter interface mode
(config-if)#ip address 66.66.66.66/32 secondary
Assign the IPv4 address
(config-if)#exit
Exit interface mode
(config)#interface xe1
Enter Interface mode
(config-if)#ipv6 address 3002::2/64
Assign IPv6 address
(config-if)#exit
Exit interface mode
(config)#router bgp 300
Enter BGP configure mode
(config-router)#bgp router-id 66.66.66.66
Assign router ID
(config-router)#neighbor 3002::1 remote-as 100
Configure 6PE2 as an eBGP4+ neighbor.
(config-router)#address-family ipv6 unicast
Enter Address-Family IPv6 unicast mode
(config-router-af)#redistribute static
Redistribute static routes
(config-router-af)#neighbor 3002::1 activate
Activate the neighbor in the IPv6 address family.
(config-router-af)#exit
Exit address family
(config-router)#ipv6 route 3ffe::/64 xe1
Configure IPV6 static route
(config-router)#commit
Commit the transaction
PE1
 
#configure terminal
Enter configure mode
(config)#interface xe1
Enter Interface mode
(config-if)#ipv6 address 2001::1/64
Assign IPv6 address
(config-if)#exit
Exit interface mode
(config)#interface lo
Enter Interface mode
(config-if)#ip address 1.1.1.1/32 secondary
Assign the IP address to loopback interface
(config-if)#exit
Exit interface mode.
(config)#router ldp
Enter router ldp mode.
(config-router)#router-id 1.1.1.1
Configure router-id
(config-router)#explicit-null
Configure explicit-null.
(config-router)#router-id 1.1.1.1
Configure router-id
(config-router)#transport-address ipv4 1.1.1.1
Configure transport address as loopback address
(config-router)#targeted-peer ipv4 3.3.3.3
Configure targeted peer
config-router-targeted-peer)#exit
Exit router targeted mode
(config-router)#exit
Exit LDP mode
(config)#interface xe2
Enter Interface mode
(config-if)#ip address 20.1.1.1/24
Assign IPv4 address
(config-if)#label-switching
Enable label switching in interface.
(config-if)#enable-ldp ipv4
Enable ldp in interface.
(config-if)#exit
Exit interface mode
(config)#router ospf
Enter router ospf mode.
(config-router)#ospf router-id 1.1.1.1
Configure ospf router id same as loopback ip address.
(config-router)#network 1.1.1.1/32 area 0
(config-router)#network 20.1.1.0/24 area 0
Define the network on which OSPF runs and associate area id.
(config-router)#exit
Exit from router ospf mode.
(config)#mpls label mode 6pe per-prefix
Change label mode to per-prefix, default is per VRF
(config)#router bgp 100
Enter BGP Configure mode.
(config-router)#bgp router-id 1.1.1.1
Configure BGP router-id
(config-router)#neighbor 3.3.3.3 remote-as 100
Configure 6PE2 as an iBGP peer.
(config-router)#neighbor 3.3.3.3 update-source lo
Update the source as loopback for iBGP peering with the remote 6PE router.
(config-router)#neighbor 2001::2 remote-as 200
Configure CE1 as eBGP peer
(config-router)#address-family ipv4 unicast
Enter address family mode
(config-router-af)#neighbor 3.3.3.3 activate
Activate neighbor
(config-router-af)#exit
Exit address family mode
(config-router)#address-family ipv6 labeled- unicast
Enter IPv6 labeled-unicast Address Family mode.
(config-router-af)#neighbor 3.3.3.3 activate
Activate the 6PE neighbor
(config-router-af)#exit-address-family
Exit IPv6 LU Address Family mode.
(config-router)#address-family ipv6 unicast
Enter the IPv6 address family
(config-router-af)#neighbor 2001::2 activate
Activate CE inside IPv6 address family
(config-router-af)#redistribute connected
Redistribute the connected routes
(config-router-af)#exit
Exit IPv6 Address Family mode.
(config-router)#commit
Commit the transaction.
P1
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode
(config-if)#ip address 2.2.2.2/32 secondary
Assign the IP address to loopback interface
(config-if)#exit
Exit interface mode
(config)#router ldp
Enter router ldp mode.
(config-router)#router-id 2.2.2.2
Configure router-id
(config-router)#transport-address ipv4 2.2.2.2
Configure transport address as loopback address
(config-router)#exit
Exit router ldp mode.
(config)#router ospf
Enter router ospf mode.
(config-router)#ospf router-id 2.2.2.2
Configure ospf router id same as loopback ip address.
(config-router)#network 2.2.2.2/32 area 0
(config-router)#network 20.1.1.2/24 area 0
(config-router)#network 30.1.1.1/24 area 0
Define the network on which OSPF runs and associate area id.
(config-router)#exit
Exit from router ospf mode.
(config)#interface xe2
Enter Interface mode
(config-if)#ip address 30.1.1.1/24
Assign IPv4 address
(config-if)#label-switching
Enable label switching in interface.
(config-if)#enable-ldp ipv4
Enable ldp in interface.
(config-if)#exit
Exit interface mode
(config)#interface xe1
Enter Interface mode
(config-if)#ip address 20.1.1.2/24
Assign IPv4 address
(config-if)#label-switching
Enable label switching in interface.
(config-if)#enable-ldp ipv4
Enable ldp in interface.
(config-if)#commit
Commit the transaction.
PE2
 
#configure terminal
Enter configure mode
(config)#interface xe2
Enter Interface mode
(config-if)#ipv6 address 3002::1/64
Assign IPv6 address
(config-if)#exit
Exit interface mode
(config)#interface lo
Enter Interface mode
(config-if)#ip address 3.3.3.3/32 secondary
Assign the IP address to loopback interface
(config-if)#exit
Exit interface mode.
(config)#router ldp
Enter router ldp mode.
(config-router)#router-id 3.3.3.3
Configure router-id
(config-router)#transport-address ipv4 3.3.3.3
Configure transport address as loopback address
(config-router)#targeted-peer ipv4 1.1.1.1
Configure targeted peer
(config-router-targeted-peer)#exit
Exit-targeted-peer-mode
(config-router)#explicit-null
Configure explicit-null.
(config-router)#exit
Exit LDP mode
(config)#interface xe1
Enter Interface mode
(config-if)#ip address 30.1.1.2/24
Assign IPv4 address
(config-if)#label-switching
Enable label switching in interface.
(config-if)#enable-ldp ipv4
Enable ldp in interface.
(config-if)#exit
Exit interface mode
(config)#mpls label mode 6pe per-prefix
Change label mode to per-prefix, default is per VRF
(config)#router bgp 100
Enter router BGP mode.
(config-router)#bgp router-id 3.3.3.3
Configure BGP router id
(config-router)#neighbor 1.1.1.1 remote-as 100
Configure 6VPE2 as an iBGP peer.
(config-router)#neighbor 1.1.1.1 update-source lo
Update the source as loopback for iBGP peering with the remote 6VPE router.
(config-router)#address-family ipv4 unicast
Enter address family mode
(config-router-af)#neighbor 1.1.1.1 activate
Activate neighbor
(config-router-af)#exit
Exit address family mode
(config-router)#neighbor 3002::2 remote-as 300
Configure CE1 as eBGP peer
(config-router)#address-family ipv6 labeled- unicast
Enter IPv6 labeled-unicast Address Family mode.
(config-router-af)#neighbor 1.1.1.1 activate
Activate the 6PE neighbor
(config-router-af)#exit-address-family
Exit IPv6 LU Address Family mode.
(config-router)#address-family ipv6 unicast
Enter the IPv6 address family
(config-router-af)#neighbor 3002::2 activate
Activate CE inside IPv6 address family
(config-router-af)#redistribute connected
Redistribute the connected routes
(config-router-af)#exit-address-family
Exit IPv6 Address Family mode.
(config-router)#exit
Exit Router mode.
(config)#router ospf
Enter OSPF router mode
(config-router)#network 3.3.3.3/32 area 0
Enable OSPF with specified area ID on interfaces with IP address that matches the specified network address
(config-router)#network 30.1.1.0/24 area 0
Enable OSPF with specified area ID on interfaces with IP address that matches the specified network address
(config-router)#commit
Commit the transaction
Validation
CE1
CE1#show ipv6 route
IPv6 Routing Table
Codes: K - kernel route, C - connected, S - static, D- DHCP, R - RIP,
O - OSPF, IA - OSPF inter area, E1 - OSPF external type 1,
E2 - OSPF external type 2, E - EVPN N1 - OSPF NSSA external type 1,
N2 - OSPF NSSA external type 2, i - IS-IS, B - BGP,
v - vrf leaked
Timers: Uptime
 
IP Route Table for VRF "default"
C ::1/128 via ::, lo, 01:10:32
C 2001::/64 via ::, xe1, 00:46:49
S 2ffe::/64 [1/0] via ::, xe1, 00:35:20
B 3002::/64 [20/0] via fe80::5054:ff:fe29:189d, xe1, 00:02:12
B 3ffe::/64 [20/0] via fe80::5054:ff:fe29:189d, xe1, 00:02:36
C fe80::/64 via ::, xe3, 01:10:32
#
 
CE1#show ipv6 bgp summary
BGP router identifier 44.44.44.44, local AS number 200
BGP table version is 8
3 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
2001::1 4 100 80 83 8 0 0 00:01:45 3
 
Total number of neighbors 1
 
Total number of Established sessions 1
PE1
PE1#show ipv6 route
IPv6 Routing Table
Codes: K - kernel route, C - connected, S - static, D- DHCP, R - RIP,
O - OSPF, IA - OSPF inter area, E1 - OSPF external type 1,
E2 - OSPF external type 2, E - EVPN N1 - OSPF NSSA external type 1,
N2 - OSPF NSSA external type 2, i - IS-IS, B - BGP,
v - vrf leaked
Timers: Uptime
 
IP Route Table for VRF "default"
C ::1/128 via ::, lo, 01:17:11
C 2001::/64 via ::, xe1, 00:40:22
B 2ffe::/64 [20/0] via fe80::5054:ff:fe60:f4e5, xe1, 00:02:37
B 3002::/64 [200/0] via ::ffff:3.3.3.3, 00:03:10
B 3ffe::/64 [200/0] via ::ffff:3.3.3.3, 00:01:07
C fe80::/64 via ::, xe2, 01:17:11
 
PE1#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
2.2.2.2 xe2 Passive OPERATIONAL 30 00:06:59
 
PE1#show bgp ipv6
BGP table version is 5, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
*> l 2001::/64 :: 0 100 32768 ?
*> l 2ffe::/64 2001::2(fe80::5054:ff:fe60:f4e5)
0 100 0 200 ?
*>i 3002::/64 ::ffff:3.3.3.3 0 100 0 ?
*>i 3ffe::/64 ::ffff:3.3.3.3 0 100 0 300 ?
 
Total number of prefixes 4
 
PE1#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 2.2.2.2/32 3 3 - - LSP_DEFAULT 3 xe2 No 20.1.1.2
L> 3.3.3.3/32 4 4 - - LSP_DEFAULT 24321 xe2 No 20.1.1.2
L> 30.1.1.0/24 5 3 - - LSP_DEFAULT 3 xe2 No 20.1.1.2
B> 3002::/64 2 2 0 Yes LSP_DEFAULT 24960 - No 3.3.3.3
B> 3ffe::/64 1 1 0 Yes LSP_DEFAULT 24961 - No 3.3.3.3
 
PE1#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
2.2.2.2 xe2 Passive OPERATIONAL 30 00:06:59
 
PE1#show mpls ftn-table
Primary FTN entry with FEC: 2.2.2.2/32, id: 3, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 4, in intf: - in label: 0 out-segment ix: 3
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 3, owner: N/A, Stale: NO, out intf: xe2, out label: 3
Nexthop addr: 20.1.1.2 cross connect ix: 4, op code: Push
 
 
Primary FTN entry with FEC: 3.3.3.3/32, id: 4, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 5, in intf: - in label: 0 out-segment ix: 4
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 4, owner: LDP, Stale: NO, out intf: xe2, out label: 24321
Nexthop addr: 20.1.1.2 cross connect ix: 5, op code: Push
 
 
Primary FTN entry with FEC: 30.1.1.0/24, id: 5, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 4, in intf: - in label: 0 out-segment ix: 3
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 3, owner: N/A, Stale: NO, out intf: xe2, out label: 3
Nexthop addr: 20.1.1.2 cross connect ix: 4, op code: Push
 
 
Primary FTN entry with FEC: 3002::/64, id: 2, row status: Active, Tunnel-Policy: N/A
Owner: BGP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Transport Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 2, in intf: - in label: 0 out-segment ix: 2
Owner: BGP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 2, owner: BGP, Stale: NO, BGP out intf: xe2, transport out intf: xe2, out label: 24960
Nexthop addr: 3.3.3.3 cross connect ix: 2, op code: Push and Lookup
 
 
Primary FTN entry with FEC: 3ffe::/64, id: 1, row status: Active, Tunnel-Policy: N/A
Owner: BGP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Transport Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 1, in intf: - in label: 0 out-segment ix: 1
Owner: BGP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 1, owner: BGP, Stale: NO, BGP out intf: xe2, transport out intf: xe2, out label: 24961
Nexthop addr: 3.3.3.3 cross connect ix: 1, op code: Push and Lookup
 
PE1#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop LSP-Type
B> 2001::/64 3 24960 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
B> 2ffe::/64 4 24961 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
#
 
PE1#show ip bgp summary
BGP router identifier 1.1.1.1, local AS number 100
BGP table version is 1
3 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
3.3.3.3 4 100 42 43 1 0 0 00:08:40 0
 
Total number of neighbors 1
 
Total number of Established sessions 1
 
PE1#show ipv6 bgp summary
BGP router identifier 1.1.1.1, local AS number 100
BGP table version is 5
3 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
2001::2 4 200 93 98 5 0 0 00:08:33 1
 
Total number of neighbors 1
 
Total number of Established sessions 1
 
PE1#show ip bgp neighbors
BGP neighbor is 3.3.3.3, remote AS 100, local AS 100, internal link
BGP version 4, local router ID 1.1.1.1, remote router ID 3.3.3.3
BGP state = Established, up for 00:08:55
Last read 00:00:21, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv4 Unicast: advertised and received
Address family IPv6 Labeled Unicast: advertised and received
Received 42 messages, 0 notifications, 0 in queue
Sent 43 messages, 1 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 5 seconds
Update source is lo
For address family: IPv4 Unicast
BGP table version 1, neighbor version 1
Index 1, Offset 0, Mask 0x2
Community attribute sent to this neighbor (both)
0 accepted prefixes
0 announced prefixes
 
For address family: IPv6 Labeled-Unicast
BGP table version 6, neighbor version 6
Index 1, Offset 0, Mask 0x2
Community attribute sent to this neighbor (both)
2 accepted prefixes
2 announced prefixes
 
Connections established 2; dropped 1
Local host: 1.1.1.1, Local port: 34293
Foreign host: 3.3.3.3, Foreign port: 179
Nexthop: 1.1.1.1
Nexthop global: ::
Nexthop local: ::
BGP connection: non shared network
Last Reset: 00:09:51, due to Administratively Reset (Cease Notification sent)
Notification Error Message: (Cease/Administratively Reset.)
 
BGP neighbor is 2001::2, remote AS 200, local AS 100, external link
BGP version 4, local router ID 1.1.1.1, remote router ID 44.44.44.44
BGP state = Established, up for 00:08:45
Last read 00:00:16, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv6 Unicast: advertised and received
Received 92 messages, 1 notifications, 0 in queue
Sent 97 messages, 1 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 30 seconds
For address family: IPv6 Unicast
BGP table version 5, neighbor version 5
Index 1, Offset 0, Mask 0x2
Community attribute sent to this neighbor (both)
1 accepted prefixes
3 announced prefixes
 
Connections established 3; dropped 2
Local host: 2001::1, Local port: 179
Foreign host: 2001::2, Foreign port: 40980
Nexthop: 1.1.1.1
Nexthop global: 2001::1
Nexthop local: fe80::5054:ff:fe29:189d
BGP connection: shared network
Last Reset: 00:08:50, due to BGP Notification received
Notification Error Message: (Cease/Other Configuration Change.)
P1
P1#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
3.3.3.3 xe1 Passive OPERATIONAL 30 00:10:11
1.1.1.1 xe2 Active OPERATIONAL 30 00:09:21
 
P1#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 1.1.1.1/32 2 2 - - LSP_DEFAULT 0 xe2 No 20.1.1.1
L> 3.3.3.3/32 1 1 - - LSP_DEFAULT 0 xe1 No 30.1.1.2
 
P1#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop LSP-Type
L> 3.3.3.3/32 2 24321 0 N/A xe1 30.1.1.2 LSP_DEFAULT
L> 1.1.1.1/32 1 24320 0 N/A xe2 20.1.1.1 LSP_DEFAULT
PE2
PE2#show ipv6 route
IPv6 Routing Table
Codes: K - kernel route, C - connected, S - static, D- DHCP, R - RIP,
O - OSPF, IA - OSPF inter area, E1 - OSPF external type 1,
E2 - OSPF external type 2, E - EVPN N1 - OSPF NSSA external type 1,
N2 - OSPF NSSA external type 2, i - IS-IS, B - BGP,
v - vrf leaked
Timers: Uptime
 
IP Route Table for VRF "default"
C ::1/128 via ::, lo, 01:24:48
B 2001::/64 [200/0] via ::ffff:1.1.1.1, 00:11:08
B 2ffe::/64 [200/0] via ::ffff:1.1.1.1, 00:10:34
C 3002::/64 via ::, xe2, 00:24:41
B 3ffe::/64 [20/0] via fe80::5054:ff:fef6:c35d, xe2, 00:09:07
C fe80::/64 via ::, xe3, 01:24:48
 
PE2#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop LSP-Type
B> 3002::/64 3 24960 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
B> 3ffe::/64 4 24961 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
 
PE2#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 1.1.1.1/32 3 2 - - LSP_DEFAULT 24320 xe1 No 30.1.1.1
L> 2.2.2.2/32 1 1 - - LSP_DEFAULT 3 xe1 No 30.1.1.1
L> 20.1.1.0/24 2 1 - - LSP_DEFAULT 3 xe1 No 30.1.1.1
B> 2001::/64 4 3 0 Yes LSP_DEFAULT 24960 - No 1.1.1.1
B> 2ffe::/64 5 4 0 Yes LSP_DEFAULT 24961 - No 1.1.1.1
 
PE2#show mpls ftn-table
Primary FTN entry with FEC: 1.1.1.1/32, id: 3, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 3, in intf: - in label: 0 out-segment ix: 2
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 2, owner: LDP, Stale: NO, out intf: xe1, out label: 24320
Nexthop addr: 30.1.1.1 cross connect ix: 3, op code: Push
 
 
Primary FTN entry with FEC: 2.2.2.2/32, id: 1, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 2, in intf: - in label: 0 out-segment ix: 1
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 1, owner: N/A, Stale: NO, out intf: xe1, out label: 3
Nexthop addr: 30.1.1.1 cross connect ix: 2, op code: Push
 
 
Primary FTN entry with FEC: 20.1.1.0/24, id: 2, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 2, in intf: - in label: 0 out-segment ix: 1
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 1, owner: N/A, Stale: NO, out intf: xe1, out label: 3
Nexthop addr: 30.1.1.1 cross connect ix: 2, op code: Push
 
 
Primary FTN entry with FEC: 2001::/64, id: 4, row status: Active, Tunnel-Policy: N/A
Owner: BGP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Transport Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 4, in intf: - in label: 0 out-segment ix: 3
Owner: BGP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 3, owner: BGP, Stale: NO, BGP out intf: xe1, transport out intf: xe1, out label: 24960
Nexthop addr: 1.1.1.1 cross connect ix: 4, op code: Push and Lookup
 
 
Primary FTN entry with FEC: 2ffe::/64, id: 5, row status: Active, Tunnel-Policy: N/A
Owner: BGP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Transport Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 5, in intf: - in label: 0 out-segment ix: 4
Owner: BGP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 4, owner: BGP, Stale: NO, BGP out intf: xe1, transport out intf: xe1, out label: 24961
Nexthop addr: 1.1.1.1 cross connect ix: 5, op code: Push and Lookup
 
PE2#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
2.2.2.2 xe1 Active OPERATIONAL 30 00:12:01
 
PE2#show bgp ipv6
BGP table version is 5, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
*>i 2001::/64 ::ffff:1.1.1.1 0 100 0 ?
*>i 2ffe::/64 ::ffff:1.1.1.1 0 100 0 200 ?
*> l 3002::/64 :: 0 100 32768 ?
*> l 3ffe::/64 3002::2(fe80::5054:ff:fef6:c35d)
0 100 0 300 ?
 
Total number of prefixes 4
 
PE2#show ip bgp neighbors
BGP neighbor is 1.1.1.1, remote AS 100, local AS 100, internal link
BGP version 4, local router ID 3.3.3.3, remote router ID 1.1.1.1
BGP state = Established, up for 00:11:54
Last read 00:00:06, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv4 Unicast: advertised and received
Address family IPv6 Labeled Unicast: advertised and received
Received 50 messages, 0 notifications, 0 in queue
Sent 50 messages, 1 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 5 seconds
Update source is lo
For address family: IPv4 Unicast
BGP table version 1, neighbor version 1
Index 1, Offset 0, Mask 0x2
Community attribute sent to this neighbor (both)
0 accepted prefixes
0 announced prefixes
 
For address family: IPv6 Labeled-Unicast
BGP table version 5, neighbor version 5
Index 1, Offset 0, Mask 0x2
Community attribute sent to this neighbor (both)
2 accepted prefixes
2 announced prefixes
 
Connections established 2; dropped 1
Local host: 3.3.3.3, Local port: 179
Foreign host: 1.1.1.1, Foreign port: 34293
Nexthop: 3.3.3.3
Nexthop global: ::
Nexthop local: ::
BGP connection: non shared network
Last Reset: 00:12:28, due to Administratively Reset (Cease Notification sent)
Notification Error Message: (Cease/Administratively Reset.)
 
BGP neighbor is 3002::2, remote AS 300, local AS 100, external link
BGP version 4, local router ID 3.3.3.3, remote router ID 66.66.66.66
BGP state = Established, up for 00:10:17
Last read 00:00:25, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv6 Unicast: advertised and received
Received 61 messages, 2 notifications, 0 in queue
Sent 68 messages, 2 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 30 seconds
For address family: IPv6 Unicast
BGP table version 5, neighbor version 5
Index 1, Offset 0, Mask 0x2
Community attribute sent to this neighbor (both)
1 accepted prefixes
3 announced prefixes
 
Connections established 3; dropped 2
Local host: 3002::1, Local port: 52758
Foreign host: 3002::2, Foreign port: 179
Nexthop: 3.3.3.3
Nexthop global: 3002::1
Nexthop local: fe80::5054:ff:fe2b:8d4f
BGP connection: shared network
Last Reset: 00:10:22, due to BGP Notification received
Notification Error Message: (Cease/Other Configuration Change.)
 
PE2#show ip bgp summary
BGP router identifier 3.3.3.3, local AS number 100
BGP table version is 1
3 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
1.1.1.1 4 100 50 52 1 0 0 00:12:06 0
 
Total number of neighbors 1
 
Total number of Established sessions 1
 
PE2#show ipv6 bgp summary
BGP router identifier 3.3.3.3, local AS number 100
BGP table version is 5
3 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
3002::2 4 300 64 70 5 0 0 00:10:31 1
 
Total number of neighbors 1
 
Total number of Established sessions 1
CE2
CE2#show ipv6 bgp summary
BGP router identifier 66.66.66.66, local AS number 300
BGP table version is 9
3 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
3002::1 4 100 70 67 9 0 0 00:11:35 3
 
Total number of neighbors 1
 
Total number of Established sessions 1
 
CE2#show ipv6 route
IPv6 Routing Table
Codes: K - kernel route, C - connected, S - static, D- DHCP, R - RIP,
O - OSPF, IA - OSPF inter area, E1 - OSPF external type 1,
E2 - OSPF external type 2, E - EVPN N1 - OSPF NSSA external type 1,
N2 - OSPF NSSA external type 2, i - IS-IS, B - BGP,
v - vrf leaked
Timers: Uptime
 
IP Route Table for VRF "default"
C ::1/128 via ::, lo, 01:26:48
B 2001::/64 [20/0] via fe80::5054:ff:fe2b:8d4f, xe2, 00:11:43
B 2ffe::/64 [20/0] via fe80::5054:ff:fe2b:8d4f, xe2, 00:11:43
C 3002::/64 via ::, xe2, 00:24:47
S 3ffe::/64 [1/0] via ::, xe2, 00:24:05
C fe80::/64 via ::, xe2, 01:26:48