OcNOS-SP : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : 6VPE Configuration
6VPE Configuration
This chapter explains how 6VPE (IPv6 on VPN Provider Edge Routers) can interconnect IPv6 islands over an MPLS- enabled IPv4 cloud. 6VPE enables IPv6 sites to communicate with each other over an MPLS/IPv4 core network using MPLS LSPs. The 6VPE routers exchange IPv6 reachability information over the core using Multi-Protocol Border Gateway Protocol (MP-BGP) over IPv4.
Topology
As shown in Figure 5-6:
CE1 and CE2 are customer edge routers
6VPE1 and 6VPE2 are IPv6 Provider Edge routers
P is the router at the core of the IPv4 MPLS provider network.
6VPE Configuration
Configuration
CE1
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode
(config-if)#ip address 44.44.44.44/32 secondary
Assign the IPv4 address
(config-if)#exit
Exit interface mode
(config)#interface xe1
Enter interface mode.
(config-if)#ipv6 address 2001::2/64
Assign the IPv6 address.
(config-if)#exit
Exit interface mode.
(config)#ipv6 route 2ffe::/64 xe1
Advertise IPv6 static route.
(config)#router bgp 200
Enter BGP router mode.
(config-router)#bgp router-id 44.44.44.44
Configure bgp router-id
(config-router)#neighbor 2001::1 remote-as 100
Configure 6VPE1 as an eBGP4+ neighbor.
(config-router)#address-family ipv6 unicast
Enter address-family IPv6 unicast mode.
(config-router-af)#neighbor 2001::1 activate
Activate the neighbor in the IPv6 address family.
(config-router-af)#redistribute connected
Redistribute the connected route under address family IPv6 unicast.
(config-router-af)#redistribute static
Redistribute static routes.
(config-router-af)#commit
Commit the transaction.
CE2
 
#configure terminal
Enter configure mode
(config)#interface lo
Enter interface mode
(config-if)#ip address 66.66.66.66/32 secondary
Assign the IPv4 address
(config-if)#exit
Exit interface mode
(config)#interface xe1
Enter interface mode.
(config-if)#ipv6 address 3001::2/64
Assign the IPv6 address.
(config-if)#exit
Exit interface mode.
(config)#ipv6 route 3ffe::/64 xe1
Configure IPV6 static route
(config)#router bgp 300
Enter BGP router mode.
(config-router)#bgp router-id 66.66.66.66
Configure BGP router-id
(config-router)#neighbor 3001::1 remote-as 100
Configure 6VPE1 as an eBGP4+ neighbor.
(config-router)#address-family ipv6 unicast
Enter address-family IPv6 unicast mode.
(config-router-af)#neighbor 3001::1 activate
Activate the neighbor in the IPv6 address family.
(config-router-af)#redistribute connected
Redistribute the connected route under address family IPv6 unicast.
(config-router-af)#redistribute static
Redistribute static routes.
(config-router-af)#commit
Commit the transaction.
PE1
 
#configure terminal
Enter configure mode.
(config)#ip vrf IPI
Create a new VRF named IPI.
(config-vrf)#rd 1:100
Assign the route distinguisher (RD) value as 1:100.
(config-vrf)#route-target both 100:200
Import routes between route target (RT) ext-communities 100 and 200.
(config-vrf)#router-id 77.77.77.77
Configure router-id for VRF
(config-vrf)#exit
Exit VRF mode.
(config)#interface xe1
Enter interface mode.
(config-if)#ip vrf forwarding IPI
Bind the interface connected to the CE router with VRF IPI.
(config-if)#ipv6 address 2001::1/64
Assign the IPv6 address.
(config-if)#exit
Exit interface mode.
(config)#router bgp 100
Enter BGP router mode.
(config-router)#bgp router-id 1.1.1.1
Configure BGP router-id
(config-router)#neighbor 3.3.3.3 remote-as 100
Configure 6VPE2 as an iBGP peer.
(config-router)#neighbor 3.3.3.3 update-source lo
Update the source as loopback for iBGP peering with the remote 6VPE router.
(config-router)#address-family ipv4 unicast
Enter address family mode
(config-router-af)#neighbor 3.3.3.3 activate
Activate the neighbor
(config-router-af)#exit-address-family
Exit address family mode
(config-router)#address-family vpnv6 unicast
Enter VPNv6 address family mode.
(config-router-af)#neighbor 3.3.3.3 activate
Activate the 6VPE neighbor so that it can accept VPN IPv6 routes.
(config-router-af)#exit-address-family
Exit VPNv6 address family mode.
(config-router)#address-family ipv6 vrf IPI
Enter the IPv6 address family for VRF IPI.
(config-router-af)#neighbor 2001::2 remote-as 200
Activate CE inside IPv6 address family for vrf IPI.
(config-router-af)#neighbor 2001::2 activate
Activate the 6VPE neighbor so that it can accept VPN IPv6 routes.
(config-router-af)#redistribute connected
Redistribute the connected route under address family IPv6 for VRF IPI.
(config-router-af)#exit-address-family
Exit IPv6 Address Family mode.
(config-router)#exit
Exit router mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 1.1.1.1/32 secondary
Assign the IP address to loopback interface.
(config-if)#exit
Exit interface mode.
(config)#router ldp
Enter router LDP mode.
(config-router)#router-id 1.1.1.1
Set the router ID to IP address 1.1.1.1
(config-router)#transport-address ipv4 1.1.1.1
Configure transport address as loopback address.
(config-router)#targeted-peer ipv4 3.3.3.3
Configure targeted peer.
(config-router-targeted-peer)#exit
Exit-targeted-peer-mode
(config-router)#exit
Exit router LDP mode.
(config)#router rsvp
Enter RSVP router mode.
(config-router)#exit
Exit router mode.
(config)#interface xe2
Enter interface mode.
(config-if)#label-switching
Enable label switching in interface.
(config-if)#enable-rsvp
Enable RSVP in interface.
(config-if)#enable-ldp ipv4
Enable LDP in interface.
(config-if)#ip address 20.10.10.1/24
Assign IP address to interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf 100
Enter OSPF router mode.
(config-router)#ospf router-id 1.1.1.1
Configure OSPF router id same as loopback ip address.
(config-router)#network 1.1.1.1/32 area 0 (config-router)#network 20.10.10.1/24 area 0
Define the network on which OSPF runs and associate area id.
(config-router)#exit
Exit OSPF router mode.
(config)#rsvp-trunk toPE2
Enter the trunk mode for RSVP.
(config-trunk)#to 3.3.3.3
Specify IPv4 Egress for the LSP.
(config-trunk)#commit
Commit the transaction.
P1
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 2.2.2.2/32 secondary
Assign the IP address to loopback interface.
(config-if)#exit
Exit interface mode.
(config)#router ldp
Enter router LDP mode.
(config-router)#router-id 2.2.2.2
Set the router ID to IP address 2.2.2.2
(config-router)#transport-address ipv4 2.2.2.2
Configure transport address as loopback address.
(config-router)#exit
Exit router mode.
(config)#router rsvp
Enter RSVP router mode.
(config-router)#exit
Exit router mode.
(config)#interface xe1
Enter interface mode.
(config-if)#label-switching
Enable label switching in interface.
(config-if)#enable-rsvp
Enable RSVP in interface.
(config-if)#enable-ldp ipv4
Enable LDP in interface.
(config-if)#ip address 20.10.10.2/24
Assign IP address to interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#label-switching
Enable label switching in interface.
(config-if)#enable-rsvp
Enable RSVP in interface.
(config-if)#enable-ldp ipv4
Enable ldp in interface.
(config-if)#ip address 20.10.20.1/24
Assign IP address to interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf 100
Enter OSPF router mode.
(config-router)#ospf router-id 2.2.2.2
Configure OSPF router id same as loopback ip address.
(config-router)#network 2.2.2.2/32 area 0 (config-router)#network 20.10.20.1/24 area 0 (config-router)#network 20.10.10.2/24 area 0
Define the network on which OSPF runs and associate area id.
(config-router)#commit
Commit the transaction.
PE2
 
#configure terminal
Enter configure mode.
(config)#ip vrf IPI
Create a new VRF named IPI.
(config-vrf)#rd 1:101
Assign the route distinguisher (RD) value as 1:101.
(config-vrf)#route-target both 100:200
Import routes between route target (RT) ext-communities 100 and 200.
(config-vrf)#router-id 55.55.55.55
Configure Router-id for VRF
(config-vrf)#exit
Exit VRF mode.
(config)#interface xe2
Enter interface mode.
(config-if)#ip vrf forwarding IPI
Bind the interface connected to the CE router with VRF IPI.
(config-if)#ipv6 address 3001::1/64
Assign the IPv6 address.
(config-if)#exit
Exit interface mode.
(config)#router bgp 100
Enter BGP router mode.
(config-router)#bgp router-id 3.3.3.3
Configure BGP router-id
(config-router)#neighbor 1.1.1.1 remote-as 100
Configure 6VPE2 as an iBGP peer.
(config-router)#neighbor 1.1.1.1 update-source lo
Update the source as loopback for iBGP peering with the remote 6VPE router.
(config-router)#address-family ipv4 unicast
Enter address family mode
(config-router-af)#neighbor 1.1.1.1 activate
Activate the neighbor
(config-router-af)#exit-address-family
Exit address family mode
(config-router)#address-family vpnv6 unicast
Enter VPNv6 address family mode.
(config-router-af)#neighbor 1.1.1.1 activate
Activate the 6VPE neighbor so that it can accept VPN IPv6 routes.
(config-router-af)#exit-address-family
Exit VPNv6 address family mode.
(config-router)#address-family ipv6 vrf IPI
Enter the IPv6 address family for VRF IPI.
(config-router-af)#neighbor 3001::2 remote-as 300
Activate CE inside IPv6 address family for vrf IPI.
(config-router-af)#neighbor 3001::2 activate
Activate the neighbor
(config-router-af)#redistribute connected
Redistribute the connected route under address family IPv6 for VRF IPI.
(config-router-af)#exit-address-family
Exit IPv6 Address Family mode.
(config-router)#exit
Exit router mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 3.3.3.3/32 secondary
Assign the IP address to loopback interface.
(config-if)#exit
Exit interface mode.
(config)#router ldp
Enter router LDP mode.
(config-router)#router-id 3.3.3.3
Set the router ID to IP address 3.3.3.3
(config-router)#transport-address ipv4 3.3.3.3
Configure transport address as loopback address.
(config-router)#targeted-peer ipv4 1.1.1.1
Configure targeted peer.
(config-router-targeted-peer)#exit
Exit-targeted-peer-mode
(config-router)#exit
Exit router mode
(config)#router rsvp
Enter RSVP router mode.
(config-router)#exit
Exit router mode.
(config)#interface xe1
Enter interface mode.
(config-if)#label-switching
Enable label switching in interface
(config-if)#enable-rsvp
Enable RSVP in interface.
(config-if)#enable-ldp ipv4
Enable LDP in interface.
(config-if)#ip address 20.10.20.2/24
Assign IP address to interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf 100
Enter OSPF router mode.
(config-router)#ospf router-id 3.3.3.3
Configure OSPF router id same as loopback ip address.
(config-router)#network 3.3.3.3/32 area 0 (config-router)#network 20.10.20.2/24 area 0
Define the network on which OSPF runs and associate area id.
(config-router)#exit
Exit OSPF router mode.
(config)#rsvp-trunk toPE1
Enter the trunk mode for RSVP.
(config-trunk)#to 1.1.1.1
Specify IPv4 Egress for the LSP.
(config-trunk)#commit
Commit the transaction.
Validation
CE1
CE1#show ipv6 route
IPv6 Routing Table
Codes: K - kernel route, C - connected, S - static, D- DHCP, R - RIP,
O - OSPF, IA - OSPF inter area, E1 - OSPF external type 1,
E2 - OSPF external type 2, E - EVPN N1 - OSPF NSSA external type 1,
N2 - OSPF NSSA external type 2, i - IS-IS, B - BGP,
v - vrf leaked
Timers: Uptime
 
IP Route Table for VRF "default"
C ::1/128 via ::, lo, 01:38:28
C 2001::/64 via ::, xe1, 01:20:30
S 2ffe::/64 [1/0] via ::, xe1, 00:01:27
B 3001::/64 [20/0] via fe80::5054:ff:fe29:189d, xe1, 00:06:40
B 3ffe::/64 [20/0] via fe80::5054:ff:fe29:189d, xe1, 00:02:24
C fe80::/64 via ::, xe3, 01:38:28
 
CE1#show ipv6 bgp summary vrf all
BGP router identifier 44.44.44.44, local AS number 200
BGP table version is 4
3 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
2001::1 4 100 1167 1522 4 0 0 00:13:23 3
 
Total number of neighbors 1
 
Total number of Established sessions 1
PE1
PE1#show ipv6 route vrf IPI
IPv6 Routing Table
Codes: K - kernel route, C - connected, S - static, D- DHCP, R - RIP,
O - OSPF, IA - OSPF inter area, E1 - OSPF external type 1,
E2 - OSPF external type 2, E - EVPN N1 - OSPF NSSA external type 1,
N2 - OSPF NSSA external type 2, i - IS-IS, B - BGP,
v - vrf leaked
Timers: Uptime
 
IP Route Table for VRF "IPI"
C 2001::/64 via ::, xe1, 01:12:03
B 2ffe::/64 [20/0] via fe80::5054:ff:fe60:f4e5, xe1, 00:02:05
B 3001::/64 [200/0] via ::ffff:3.3.3.3, 00:08:02
B 3ffe::/64 [200/0] via ::ffff:3.3.3.3, 00:03:33
C fe80::/64 via ::, xe1, 01:12:32
 
PE1#show ip bgp summary vrf all
BGP router identifier 3.3.3.3, local AS number 100
BGP table version is 1
3 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
1.1.1.1 4 100 78 84 1 0 0 00:32:15 0
 
Total number of neighbors 1
 
Total number of Established sessions 1
 
PE1#show ipv6 bgp summary vrf all
BGP router identifier 55.55.55.55, local AS number 100
BGP VRF IPI Route Distinguisher: 1:101
BGP table version is 1
3 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
3001::2 4 200 79 81 1 0 0 00:32:15 2
 
Total number of neighbors 1
 
Total number of Established sessions 1
 
PE1#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 2.2.2.2/32 1 1 - - LSP_DEFAULT 3 xe2 No 20.10.10.2
R(t)> 3.3.3.3/32 4 4 5001 Yes LSP_DEFAULT 24320 xe2 No 20.10.10.2
L 3.3.3.3/32 3 2 - - LSP_DEFAULT 24960 xe2 No 20.10.10.2
L> 20.10.20.0/24 2 1 - - LSP_DEFAULT 3 xe2 No 20.10.10.2
 
PE1#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
 
Ingress RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
3.3.3.3 1.1.1.1 PRI toPE2-Primary UP 00:08:44 1 1 SE - 24320 DEFAULT
Total 1 displayed, Up 1, Down 0.
 
Egress RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
1.1.1.1 3.3.3.3 PRI toPE1-Primary UP 00:08:39 1 1 SE 24960 - ELSP_CON
Total 1 displayed, Up 1, Down 0.
 
PE1#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop LSP-Type
B> IPI 2 25600 Nolabel N/A IPI N/A LSP_DEFAULT
LT
R> 3.3.3.3/32 2 24320 Nolabel N/A N/A 127.0.0.1 ELSP_CONF
IG
 
PE1#show mpls vrf-table
Output for IPv6 VRF table with id: 2
Primary FTN entry with FEC: 3001::/64, id: 1, row status: Active, Tunnel-Policy: N/A
Owner: BGP, distance: 0, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Transport Tunnel id: 5001, Protected LSP id: 2201, QoS Resource id: 0, Description: N/A, Color: 0
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 5, in intf: - in label: 0 out-segment ix: 5
Owner: BGP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 5, owner: BGP, Stale: NO, BGP out intf: xe2, transport out intf: xe2, out label: 24320
Nexthop addr: 3.3.3.3 cross connect ix: 5, op code: Push and Lookup
 
 
Primary FTN entry with FEC: 3ffe::/64, id: 2, row status: Active, Tunnel-Policy: N/A
Owner: BGP, distance: 0, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Transport Tunnel id: 5001, Protected LSP id: 2201, QoS Resource id: 0, Description: N/A, Color: 0
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 5, in intf: - in label: 0 out-segment ix: 5
Owner: BGP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 5, owner: BGP, Stale: NO, BGP out intf: xe2, transport out intf: xe2, out label: 24320
Nexthop addr: 3.3.3.3 cross connect ix: 5, op code: Push and Lookup
 
PE1#show mpls ftn-table
Primary FTN entry with FEC: 2.2.2.2/32, id: 1, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 1, in intf: - in label: 0 out-segment ix: 1
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 1, owner: N/A, Stale: NO, out intf: xe2, out label: 3
Nexthop addr: 20.10.10.2 cross connect ix: 1, op code: Push
 
 
Primary FTN entry with FEC: 3.3.3.3/32, id: 4, row status: Active, Tunnel-Policy: N/A
Owner: RSVP, distance: 0, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 5001, Protected LSP id: 2201, QoS Resource id: 2, Description: toPE2, Color: 0
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 4, in intf: - in label: 0 out-segment ix: 4
Owner: RSVP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 4, owner: RSVP, Stale: NO, out intf: xe2, out label: 24320
Nexthop addr: 20.10.10.2 cross connect ix: 4, op code: Push
 
 
Primary FTN entry with FEC: 3.3.3.3/32, id: 3, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 2, in intf: - in label: 0 out-segment ix: 2
Owner: LDP, Persistent: No, Admin Status: Down, Oper Status: Down
Out-segment with ix: 2, owner: LDP, Stale: NO, out intf: xe2, out label: 24960
Nexthop addr: 20.10.10.2 cross connect ix: 2, op code: Push
 
 
Primary FTN entry with FEC: 20.10.20.0/24, id: 2, row status: Active, Tunnel-Policy: N/A
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, Color: 0
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 1, in intf: - in label: 0 out-segment ix: 1
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 1, owner: N/A, Stale: NO, out intf: xe2, out label: 3
Nexthop addr: 20.10.10.2 cross connect ix: 1, op code: Push
 
 
PE1#show ip bgp vpnv6 all
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal, l - labeled
S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 1:100 (Default for VRF IPI)
*> l 2001::/64 :: 0 100 32768 ?
* 2001::/64 2001::2(fe80::5054:ff:fe60:f4e5)
0 100 0 200 ?
*> l 2ffe::/64 2001::2(fe80::5054:ff:fe60:f4e5)
0 100 0 200 ?
*>i 3001::/64 ::ffff:3.3.3.3 0 100 0 ?
*>i 3ffe::/64 ::ffff:3.3.3.3 0 100 0 300 ?
Announced routes count = 3
Accepted routes count = 2
Route Distinguisher: 1:101
*>i 3001::/64 ::ffff:3.3.3.3 0 100 0 ?
*>i 3ffe::/64 ::ffff:3.3.3.3 0 100 0 300 ?
Announced routes count = 0
Accepted routes count = 2
 
PE1#show ip bgp neighbors
BGP neighbor is 3.3.3.3, remote AS 100, local AS 100, internal link
BGP version 4, local router ID 1.1.1.1, remote router ID 3.3.3.3
BGP state = Established, up for 00:09:55
Last read 00:00:21, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv4 Unicast: advertised and received
Address family VPNv6 Unicast: advertised and received
Received 27 messages, 0 notifications, 0 in queue
Sent 27 messages, 0 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 5 seconds
Update source is lo
For address family: IPv4 Unicast
BGP table version 1, neighbor version 1
Index 1, Offset 0, Mask 0x2
Community attribute sent to this neighbor (both)
0 accepted prefixes
0 announced prefixes
 
For address family: VPNv6 Unicast
BGP table version 3, neighbor version 3
Index 1, Offset 0, Mask 0x2
Community attribute sent to this neighbor (both)
2 accepted prefixes
2 announced prefixes
 
Connections established 1; dropped 0
Local host: 1.1.1.1, Local port: 33537
Foreign host: 3.3.3.3, Foreign port: 179
Nexthop: 1.1.1.1
Nexthop global: ::
Nexthop local: ::
BGP connection: non shared network
 
BGP neighbor is 2001::2, vrf IPI, remote AS 200, local AS 100, external link
BGP version 4, local router ID 77.77.77.77, remote router ID 44.44.44.44
BGP state = Established, up for 00:16:19
Last read 00:00:10, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv6 Unicast: advertised and received
Received 42 messages, 0 notifications, 0 in queue
Sent 42 messages, 0 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 30 seconds
For address family: IPv6 Unicast
BGP table version 1, neighbor version 1
Index 0, Offset 0, Mask 0x1
Community attribute sent to this neighbor (standard)
2 accepted prefixes
3 announced prefixes
 
Connections established 1; dropped 0
Local host: 2001::1, Local port: 34776
Foreign host: 2001::2, Foreign port: 179
Nexthop: 77.77.77.77
Nexthop global: 2001::1
Nexthop local: fe80::5054:ff:fe29:189d
BGP connection: shared network
 
P1
P1#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf Nexthop
L> 1.1.1.1/32 1 0 Yes LSP_DEFAULT 3 xe2 20.10.10.1
L> 3.3.3.3/32 2 0 Yes LSP_DEFAULT 3 xe1 20.10.20.2
 
P1#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, S - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
U - unknown
 
Code FEC/VRF ILM-ID In-Label Out-Label In-Intf Out-Intf Nexthop LSP-Type
R> 1.1.1.1/32 2 24321 24960 N/A xe1 20.10.10.1 ELSP_CONFIG
R> 3.3.3.3/32 1 24320 24960 N/A xe2 20.10.20.2 ELSP_CONFIG
L> 1.1.1.1/32 4 24961 3 N/A xe1 20.10.10.1 LSP_DEFAULT
L> 3.3.3.3/32 5 24960 3 N/A xe2 20.10.20.2 LSP_DEFAULT
 
P1#show ip ospf neighbor
 
Total number of full neighbors: 2
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
1.1.1.1 1 Full/Backup 00:00:31 20.10.10.1 xe1 0
3.3.3.3 1 Full/DR 00:00:32 20.10.20.2 xe2 0
PE2
PE2#show ipv6 route vrf IPI
IPv6 Routing Table
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
IA - OSPF inter area, E1 - OSPF external type 1,
E2 - OSPF external type 2, E - EVPN N1 - OSPF NSSA external type 1,
N2 - OSPF NSSA external type 2, I - IS-IS, B - BGP
Timers: Uptime
 
IP Route Table for VRF "IPI"
C ::1/128 via ::, lo.IPI, 00:24:23
C 3001::/64 via ::, xe1, 00:24:22
B 3ffe::/64 [20/0] via fe80::3617:ebff:fe0e:1201, xe1, 00:05:28
C fe80::/64 via ::, xe1, 00:24:22
 
PE2#show ip bgp summary vrf all
BGP router identifier 55.55.55.55, local AS number 100
BGP VRF IPI Route Distinguisher: 1:100
BGP table version is 1
3 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
3001::2 4 300 116 181 1 0 0 00:22:05 0
 
Total number of neighbors 1
 
Total number of Established sessions 1
BGP router identifier 3.3.3.3, local AS number 100
BGP table version is 1
3 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
1.1.1.1 4 100 65 66 1 0 0 00:26:21 0
 
Total number of neighbors 1
 
Total number of Established sessions 1
 
PE2#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf Nexthop
R(t)> 1.1.1.1/32 1 5001 Yes LSP_DEFAULT 24321 xe2 20.10.20.1
L 1.1.1.1/32 2 0 Yes LSP_DEFAULT 24961 xe2 20.10.20.1
L> 2.2.2.2/32 3 0 Yes LSP_DEFAULT 3 xe2 20.10.20.1
L> 20.10.10.0/24 4 0 Yes LSP_DEFAULT 3 xe2 20.10.20.1
 
PE2#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
 
Ingress RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
1.1.1.1 3.3.3.3 PRI toPE1-Primary UP 00:23:21 1 1 SE - 24321 DEFAULT
Total 1 displayed, Up 1, Down 0.
 
Egress RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
3.3.3.3 1.1.1.1 PRI toPE2-Primary UP 00:23:33 1 1 SE 24960 - ELSP_CON
Total 1 displayed, Up 1, Down 0.
 
PE2#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, S - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
U - unknown
 
Code FEC/VRF ILM-ID In-Label Out-Label In-Intf Out-Intf Nexthop LSP-Type
B> 3ffe::/64 3 24321 N/A N/A xe1 fe80::3617:ebff:fe0e:1201 LSP_DEFAULT
B> 3001::/64 2 24320 N/A N/A xe1 :: LSP_DEFAULT
R> 3.3.3.3/32 1 24960 N/A N/A N/A 127.0.0.1 ELSP_CONFIG
 
PE2#show ip bgp neighbors
BGP neighbor is 1.1.1.1, remote AS 100, local AS 100, internal link
BGP version 4, local router ID 3.3.3.3, remote router ID 1.1.1.1
BGP state = Established, up for 00:23:39
Last read 00:00:27, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv4 Unicast: advertised and received
Address family VPNv6 Unicast: advertised and received
Received 58 messages, 0 notifications, 0 in queue
Sent 60 messages, 0 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 5 seconds
Update source is lo
For address family: IPv4 Unicast
BGP table version 1, neighbor version 1
Index 1, Offset 0, Mask 0x2
Community attribute sent to this neighbor (both)
0 accepted prefixes
0 announced prefixes
 
For address family: VPNv6 Unicast
BGP table version 4, neighbor version 4
Index 1, Offset 0, Mask 0x2
Community attribute sent to this neighbor (both)
2 accepted prefixes
2 announced prefixes
 
Connections established 1; dropped 0
Local host: 3.3.3.3, Local port: 37145
Foreign host: 1.1.1.1, Foreign port: 179
Nexthop: 3.3.3.3
Nexthop global: ::
Nexthop local: ::
BGP connection: non shared network
 
BGP neighbor is 3001::2, vrf IPI, remote AS 300, local AS 100, external link
BGP version 4, local router ID 55.55.55.55, remote router ID 66.66.66.66
BGP state = Established, up for 00:19:23
Last read 00:00:05, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv4 Unicast: advertised and received
Address family IPv6 Unicast: advertised and received
Received 110 messages, 0 notifications, 0 in queue
Sent 113 messages, 62 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 30 seconds
For address family: IPv4 Unicast
BGP table version 1, neighbor version 1
Index 1, Offset 0, Mask 0x2
Community attribute sent to this neighbor (standard)
0 accepted prefixes
0 announced prefixes
 
For address family: IPv6 Unicast
BGP table version 1, neighbor version 1
Index 1, Offset 0, Mask 0x2
Community attribute sent to this neighbor (standard)
2 accepted prefixes
3 announced prefixes
 
Connections established 1; dropped 0
Local host: 3001::1, Local port: 179
Foreign host: 3001::2, Foreign port: 58741
Nexthop: 55.55.55.55
Nexthop global: 3001::1
Nexthop local: fe80::da9e:f3ff:fec9:65a1
BGP connection: shared network
Last Reset: 00:19:28, due to OPEN Message Error (Notification sent)
Notification Error Message: (OPEN Message Error/Bad BGP Identifier.)
 
PE2#show ip bgp vpnv6 all
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, l - labeled
S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 1:100 (Default for VRF IPI)
*>i 2001::/64 ::ffff:101:101 0 100 0 ?
*>i 2ffe::/64 ::ffff:101:101 0 100 0 200 ?
*> l 3001::/64 :: 0 100 32768 ?
* 3001::/64 3001::2(fe80::3617:ebff:fe0e:1201)
0 100 0 300 ?
*> l 3ffe::/64 3001::2(fe80::3617:ebff:fe0e:1201)
0 100 0 300 ?
Announced routes count = 3
Accepted routes count = 2
Route Distinguisher: 1:100
*>i 2001::/64 ::ffff:101:101 0 100 0 ?
*>i 2ffe::/64 ::ffff:101:101 0 100 0 200 ?
Announced routes count = 0
Accepted routes count = 2
 
PE2#show mpls ftn-table
Primary FTN entry with FEC: 1.1.1.1/32, id: 1, row status: Active
Owner: RSVP, distance: 0, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 5001, Protected LSP id: 2201, QoS Resource id: 2, Description: toPE1
Cross connect ix: 4, in intf: - in label: 0 out-segment ix: 3
Owner: RSVP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 3, owner: RSVP, out intf: xe1, out label: 24321
Nexthop addr: 20.10.20.1 cross connect ix: 4, op code: Push
 
 
Primary FTN entry with FEC: 1.1.1.1/32, id: 2, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 5, in intf: - in label: 0 out-segment ix: 4
Owner: LDP, Persistent: No, Admin Status: Down, Oper Status: Down
Out-segment with ix: 4, owner: LDP, out intf: xe1, out label: 24961
Nexthop addr: 20.10.20.1 cross connect ix: 5, op code: Push
 
 
Primary FTN entry with FEC: 2.2.2.2/32, id: 3, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 6, in intf: - in label: 0 out-segment ix: 5
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 5, owner: LDP, out intf: xe1, out label: 3
Nexthop addr: 20.10.20.1 cross connect ix: 6, op code: Push
 
 
Primary FTN entry with FEC: 20.10.10.0/24, id: 4, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 6, in intf: - in label: 0 out-segment ix: 5
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 5, owner: LDP, out intf: xe1, out label: 3
Nexthop addr: 20.10.20.1 cross connect ix: 6, op code: Push
 
 
PE2#show mpls vrf-table
Output for IPv6 VRF table with id: 2
Primary FTN entry with FEC: 2001::/64, id: 1, row status: Active
Owner: BGP, distance: 0, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 5001, Protected LSP id: 2201, QoS Resource id: 0, Description: N/A
Cross connect ix: 3, in intf: - in label: 0 out-segment ix: 2
Owner: BGP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 2, owner: BGP, out intf: N/A, out label: 24320
Nexthop addr: 1.1.1.1 cross connect ix: 3, op code: Push and Lookup
 
 
Primary FTN entry with FEC: 2ffe::/64, id: 2, row status: Active
Owner: BGP, distance: 0, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 5001, Protected LSP id: 2201, QoS Resource id: 0, Description: N/A
Cross connect ix: 7, in intf: - in label: 0 out-segment ix: 6
Owner: BGP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 6, owner: BGP, out intf: N/A, out label: 24321
Nexthop addr: 1.1.1.1 cross connect ix: 7, op code: Push and Lookup
CE2
CE2#show ipv6 route
IPv6 Routing Table
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
IA - OSPF inter area, E1 - OSPF external type 1,
E2 - OSPF external type 2, E - EVPN N1 - OSPF NSSA external type 1,
N2 - OSPF NSSA external type 2, I - IS-IS, B - BGP
Timers: Uptime
 
IP Route Table for VRF "default"
C ::1/128 via ::, lo, 00:37:26
B 2001::/64 [20/0] via fe80::da9e:f3ff:fec9:65a1, xe2, 00:20:44
B 2ffe::/64 [20/0] via fe80::da9e:f3ff:fec9:65a1, xe2, 00:09:52
C 3001::/64 via ::, xe2, 00:27:07
S 3ffe::/64 [1/0] via ::, xe2, 00:07:31
C fe80::/64 via ::, xe2, 00:37:26
 
CE2#show ip bgp summary vrf all
BGP router identifier 66.66.66.66, local AS number 300
BGP table version is 1
3 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
3001::1 4 100 178 176 1 0 0 00:20:51 0
 
Total number of neighbors 1
 
Total number of Established sessions 1