OcNOS-SP : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : LDP Inter-Area Configuration
LDP Inter-Area Configuration
This chapter contains LDP inter-area configuration examples.
Overview
Provider-based MPLS (Multiprotocol Label Switching) networks are expanding with the success of Layer 3 Virtual Private Networks and the new deployments of Layer 2 VPNs. Service providers MPLS backbones are significantly growing both in terms of density with the addition of Provider Edge (PE) routers to connect new customers and in terms of footprint as traditional Layer 2 aggregation networks may be replaced by IP/MPLS networks. As a consequence, many providers need to introduce IGP areas. Inter-area LSPs (that is, LSPs that traverse at least two IGP areas) are required to ensure MPLS connectivity between PEs located in distinct IGP areas.
On a large MPLS networks, multiple IGP areas need to be configured for flexible network deployment and fast route convergence. When advertising routes between IGP areas, to prevent a large number of routes from consuming too many resources, an Area Border Router (ABR) needs to aggregate the routes in the area and advertises the aggregated route to the neighboring IGP areas. By default, when establishing LSPs, LDP searches the routing table for the route that exactly matches the FEC in the received Label Mapping message.
The LDP inter-area feature provides a longest-match label mapping procedure where a label is used if the Forwarding Equivalence Class (FEC) matches an entry in the Routing Information Base (RIB). Matching is defined by an IP longest-match search and does not mandate an exact match.
Configure LDP Inter-Area
The LDP Inter-Area configuration process can be divided into the following tasks:
1. Enable label-switching on the interface in NSM.
2. Enable LDP on an interface in LDP.
3. Run an IGP (Internal Gateway Protocol) such as OSPF or ISIS to distribute reachability information within the MPLS cloud.
4. Give the inter-area-lsp command in LDP router mode to enable creation of inter-area LSPs.
To configure a summary route on an ABR, configure two networks such R4 and R5 in Figure 12-1, so that two prefixes are summarized. For example, 4.4.4.0/24 is a summary route for the networks 4.4.4.1/32 and 4.4.4.2/32.
Give the area-range command on the routers to summarize the networks. For example: area 2 range 4.4.4.0/24.
Note: LDP Downstream-On-Demand not supported with inter-area configuration. LDP Inter-Area Graceful Restart (GR) is not supported in this release.
Topology
LDP inter-area topology
PE1
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter loopback interface mode.
(config-if)#ip address 1.1.1.1/32 secondary
Set the IP address of the loopback interface to 1.1.1.1/32.
(config-if)#exit
Exit interface mode.
(config)#router ldp
Enter router mode for LDP.
(config-router)#router-id 1.1.1.1
Set the router ID to IP address 1.1.1.1
(config-router)#transport-address ipv4 1.1.1.1
Configure the transport address for IPv4 (for IPv6 use ipv6) to be used for a TCP session over which LDP will run.
Note: It is preferable to use the loopback address as the transport address.
(config-router)#targeted-peer ipv4 4.4.4.1
Configure targeted peer.
(config-router-targeted-peer)#targeted-peer ipv4 4.4.4.2
Configure targeted peer.
(config-router-targeted-peer)#exit
Exit-targeted-peer-mode
(config-router)#exit
Exit router mode.
(config)#interface xe2
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface xe2.
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#ip address 10.1.1.1/24
Set the IP address of the interface to 10.1.1.1/24
(config)#router ospf 1
Configure the routing process and specify the Process ID (1).
(config-router)#network 1.1.1.1/32 area 0
(config-router)#network 10.1.1.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config)#interface xe2
Enter interface mode.
(config-if)#enable-ldp ipv4
Enable LDP on xe2.
(config-if)#exit
Exit interface mode.
(config)#router ldp
Enter LDP router mode.
(config-router)#inter-area-lsp
Enable the inter-area-LSP command.
(config-router)#commit
Commit the transaction.
P1
 
#configure terminal
Enter configure mode.
(config)#router ldp
Enter router mode for LDP.
(config-router)#router-id 2.2.2.1
Set the router ID to IP address 2.2.2.1
(config-router)#transport-address ipv4 2.2.2.1
Configure the transport address for IPv4 (for IPv6 use ipv6) to be used for a TCP session over which LDP will run.
Note: It is preferable to use the loopback address as the transport address.
(config-router)#exit
Exit router mode.
(config)#interface xe2
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface xe2.
(config-if)#exit
Exit interface mode.
(config)#interface lo
Enter loopback interface mode.
(config-if)#ip address 2.2.2.1/32
Set the IP address of the loopback interface to 2.2.2.1/32.
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#ip address 10.1.1.2/24
Set the IP address of the interface to 10.1.1.2/24
(config-if)#label-switching
Enable label switching on interface xe1.
(config-if)#exit
Exit interface mode.
(config)#interface xe1
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface xe1.
(config-if)#ip address 20.1.1.1/24
Set the IP address of the interface to 20.1.1.1/24
(config-if)#exit
Exit interface mode.
(config)#router ospf 1
Configure the routing process and specify the Process ID (1).
(config-router)#network 2.2.2.1/32 area 0
(config-router)#network 10.1.1.0/24 area 0
(config-router)#network 20.1.1.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config)#interface xe2
Enter interface mode.
(config-if)#enable-ldp ipv4
Enable LDP on xe2.
(config-if)#exit
Exit interface mode.
(config)#interface xe1
Enter interface mode.
(config-if)#enable-ldp ipv4
Enable LDP on xe1.
(config-if)#exit
Exit interface mode.
(config)#router ldp
Enter LDP router mode.
(config-router)#inter-area-lsp
Enable the inter-area-LSP command.
(config-router)#commit
Commit the transaction.
P2
 
#configure terminal
Enter configure mode.
(config)#interface xe1
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface xe1.
(config-if)#exit
Exit interface mode.
(config)#interface lo
Enter loopback interface mode.
(config-if)#ip address 3.3.3.1/32 secondary
Set the IP address of the loopback interface to 3.3.3.1/32.
(config-if)#exit
Exit interface mode.
(config)#interface xe1
Enter interface mode.
(config-if)#ip address 20.1.1.2/24
Set the IP address of the interface to 20.1.1.2/24
(config-if)#label-switching
Enable label switching on interface xe1.
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface xe1.
(config-if)#ip address 30.1.1.1/24
Set the IP address of the interface to 30.1.1.1/24
(config-if)#exit
Exit interface mode.
(config)#interface xe3
Specify the interface (xe3) to be configured.
(config-if)#label-switching
Enable label switching on interface xe1.
(config-if)#enable-ldp ipv4
Enable LDP on xe1.
(config-if)#ip address 30.1.2.1/24
Set the IP address of the interface to 30.1.2.1/24
(config-if)#exit
Exit interface mode.
(config)#router ospf 1
Configure the routing process and specify the Process ID (1).
(config-router)#network 3.3.3.1/32 area 0
(config-router)#network 20.1.1.0/24 area 0
(config-router)#network 30.1.1.0/24 area 2
(config-router)#network 30.1.2.0/24 area 2
Define the interface on which OSPF runs and associate the area ID (0 and 2) respectively with the interface.
(config)#router ldp
Enter LDP router mode.
(config-router)#transport-address ipv4 3.3.3.1
Configure the transport address for IPv4 (for IPv6 use ipv6) to be used for a TCP session over which LDP will run.
Note: It is preferable to use the loopback address as the transport address.
(config-router)#router-id 3.3.3.1
Set the router ID to IP address 3.3.3.1
(config-router)#exit
Exit router mode.
(config)#interface xe1
Enter interface mode.
(config-if)#enable-ldp ipv4
Enable LDP on xe1.
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#enable-ldp ipv4
Enable LDP on xe2.
(config-if)#exit
Exit interface mode.
(config)#interface xe3
Enter interface mode.
(config-if)#enable-ldp ipv4
Enable LDP on xe3.
(config-if)#exit
Exit interface mode.
(config)#router ospf 1
Configure the routing process and specify the Process ID (1).
(config-router)#area 2 range 4.4.4.0/24
Configure the summary route with range command.
(config-router)#commit
Commit the transaction.
PE2
 
#configure terminal
Enter configure mode.
(config)#interface xe2
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface xe2.
(config-if)#exit
Exit interface mode.
(config)#interface lo
Enter loopback interface mode.
(config-if)#ip address 4.4.4.1/32 secondary
Set the IP address of the loopback interface to 4.4.4.1/32.
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#ip address 30.1.1.2/24
Set the IP address of the interface to 30.1.1.2/24
(config)#router ospf 1
Configure the routing process and specify the Process ID (1).
(config-router)#network 4.4.4.1/32 area 2
(config-router)#network 30.1.1.0/24 area 2
Define the interface on which OSPF runs and associate the area ID (2) with the interface.
(config)#router ldp
Enter LDP router mode.
(config-router)#router-id 4.4.4.1
Set the router ID to IP address to 4.4.4.1
(config-router)#transport-address ipv4 4.4.4.1
Configure the transport address for IPv4 (for IPv6 use ipv6) to be used for a TCP session over which LDP will run.
Note: It is preferable to use the loopback address as the transport address.
(config-router)#exit
Exit router mode.
(config)#interface xe2
Enter interface mode.
(config-if)#enable-ldp ipv4
Enable LDP on xe2.
(config-if)#commit
Commit the transaction.
PE3
 
#configure terminal
Enter configure mode.
(config)#interface xe3
Specify the interface(xe3) to be configured.
(config-if)#label-switching
Enable label switching on interface xe2.
(config-if)#exit
Exit interface mode.
(config)#interface lo
Enter loopback interface mode.
(config-if)#ip address 4.4.4.2/32 secondary
Set the IP address of the loopback interface to 4.4.4.2/32.
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#ip address 30.1.2.2/24
Set the IP address of the interface to 30.1.2.2/24
(config)#router ospf 1
Configure the routing process and specify the Process ID (1).
(config-router)#network 4.4.4.2/32 area 2
(config-router)#network 30.1.2.0/24 area 2
Define the interface on which OSPF runs and associate the area ID (2) with the interface.
(config)#router ldp
Enter LDP router mode.
(config-router)#router-id 4.4.4.2
Set the router ID to IP address to 4.4.4.2
(config-router)#transport-address ipv4 1.1.1.1
Configure the transport address for IPv4 (for IPv6 use ipv6) to be used for a TCP session over which LDP will run.
Note: It is preferable to use the loopback address as the transport address.
(config-router)#exit
Exit router mode.
(config)#interface xe3
Enter interface mode.
(config-if)#enable-ldp ipv4
Enable LDP on xe3.
(config-if)#commit
Commit the transaction.
Validation
PE1
PE1#show ip route
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
ia - IS-IS inter area, E - EVPN,
v - vrf leaked
* - candidate default
 
IP Route Table for VRF "default"
Gateway of last resort is 10.12.49.1 to network 0.0.0.0
 
K* 0.0.0.0/0 [0/0] via 10.12.49.1, xe0
C 1.1.1.1/32 is directly connected, lo, 00:30:03
O 2.2.2.1/32 [110/2] via 10.1.1.2, xe2, 00:19:09
O 3.3.3.1/32 [110/3] via 10.1.1.2, xe2, 00:12:28
O IA 4.4.4.0/24 [110/4] via 10.1.1.2, xe2, 00:08:42
C 10.1.1.0/24 is directly connected, xe2, 00:29:06
C 10.12.49.0/24 is directly connected, xe0, 01:32:26
O 20.1.1.0/24 [110/2] via 10.1.1.2, xe2, 00:19:09
O IA 30.1.1.0/24 [110/3] via 10.1.1.2, xe2, 00:12:28
O IA 30.1.2.0/24 [110/3] via 10.1.1.2, xe2, 00:12:28
C 127.0.0.0/8 is directly connected, lo, 01:33:35
PE1#show ldp inter-area-fecs
LSR codes : E/N - LSR is egress/non-egress for this FEC,
L - LSR received a label for this FEC,
> - LSR will use this route for the FEC
FEC Code Session Out Label ELC Nexthop Addr
Matching RIB prefix - 4.4.4.0/24
4.4.4.1/32 NL> 2.2.2.1 25605 No 10.1.1.2
4.4.4.2/32 NL> 2.2.2.1 25606 No 10.1.1.2
 
PE1#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN, ! - using backup
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 2.2.2.1/32 1 2 - Yes LSP_DEFAULT 3 xe2 No 10.1.1.2
L> 3.3.3.1/32 3 3 - Yes LSP_DEFAULT 25600 xe2 No 10.1.1.2
L> 4.4.4.0/24 6 6 - Yes LSP_DEFAULT 25604 xe2 No 10.1.1.2
L> 4.4.4.1/32 7 7 - Yes LSP_DEFAULT 25605 xe2 No 10.1.1.2
L> 4.4.4.2/32 8 1 - Yes LSP_DEFAULT 25606 xe2 No 10.1.1.2
L> 20.1.1.0/24 2 2 - Yes LSP_DEFAULT 3 xe2 No 10.1.1.2
L> 30.1.1.0/24 4 4 - Yes LSP_DEFAULT 25601 xe2 No 10.1.1.2
L> 30.1.2.0/24 5 5 - Yes LSP_DEFAULT 25602 xe2 No 10.1.1.2
 
PE1#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
2.2.2.1 xe2 Passive OPERATIONAL 30 00:19:02
P1
P1#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
1.1.1.1 xe2 Active OPERATIONAL 30 00:22:11
3.3.3.1 xe1 Passive OPERATIONAL 30 00:16:34
 
P1#show ldp inter-area-fecs
LSR codes : E/N - LSR is egress/non-egress for this FEC,
L - LSR received a label for this FEC,
> - LSR will use this route for the FEC
FEC Code Session Out Label ELC Nexthop Addr
Matching RIB prefix - 4.4.4.0/24
4.4.4.1/32 NL> 3.3.3.1 25600 No 20.1.1.2
4.4.4.2/32 NL> 3.3.3.1 25604 No 20.1.1.2
 
P1#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN, ! - using backup
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 1.1.1.1/32 1 2 - Yes LSP_DEFAULT 3 xe1 No 10.1.1.1
L> 3.3.3.1/32 2 3 - Yes LSP_DEFAULT 3 xe1 No 20.1.1.2
L> 4.4.4.0/24 6 3 - Yes LSP_DEFAULT 3 xe1 No 20.1.1.2
L> 4.4.4.1/32 5 4 - Yes LSP_DEFAULT 25600 xe1 No 20.1.1.2
L> 4.4.4.2/32 7 1 - Yes LSP_DEFAULT 25604 xe1 No 20.1.1.2
L> 30.1.1.0/24 3 3 - Yes LSP_DEFAULT 3 xe1 No 20.1.1.2
L> 30.1.2.0/24 4 3 - Yes LSP_DEFAULT 3 xe1 No 20.1.1.2
 
P1#show ip route
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
ia - IS-IS inter area, E - EVPN,
v - vrf leaked
* - candidate default
 
IP Route Table for VRF "default"
Gateway of last resort is 10.12.49.1 to network 0.0.0.0
 
K* 0.0.0.0/0 [0/0] via 10.12.49.1, xe0
O 1.1.1.1/32 [110/2] via 10.1.1.1, xe2, 00:28:05
C 2.2.2.1/32 is directly connected, lo, 00:29:56
O 3.3.3.1/32 [110/2] via 20.1.1.2, xe1, 00:21:28
O IA 4.4.4.0/24 [110/3] via 20.1.1.2, xe1, 00:17:41
C 10.1.1.0/24 is directly connected, xe2, 00:29:29
C 10.12.49.0/24 is directly connected, xe0, 01:26:43
C 20.1.1.0/24 is directly connected, xe1, 00:29:06
O IA 30.1.1.0/24 [110/2] via 20.1.1.2, xe1, 00:21:28
O IA 30.1.2.0/24 [110/2] via 20.1.1.2, xe1, 00:21:28
C 127.0.0.0/8 is directly connected, lo, 01:30:20
P2
P2#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
2.2.2.1 xe1 Active OPERATIONAL 30 00:18:30
4.4.4.1 xe2 Passive OPERATIONAL 30 00:13:42
4.4.4.2 xe3 Passive OPERATIONAL 30 00:08:51
 
P2#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN, ! - using backup
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 1.1.1.1/32 1 1 - Yes LSP_DEFAULT 25603 xe1 No 20.1.1.1
L> 2.2.2.1/32 2 2 - Yes LSP_DEFAULT 3 xe1 No 20.1.1.1
L> 4.4.4.1/32 4 3 - Yes LSP_DEFAULT 3 xe2 No 30.1.1.2
L> 4.4.4.2/32 5 4 - Yes LSP_DEFAULT 3 xe3 No 30.1.2.2
L> 10.1.1.0/24 3 2 - Yes LSP_DEFAULT 3 xe1 No 20.1.1.1
 
P2#show ip route
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
ia - IS-IS inter area, E - EVPN,
v - vrf leaked
* - candidate default
 
IP Route Table for VRF "default"
Gateway of last resort is 10.12.49.1 to network 0.0.0.0
 
K* 0.0.0.0/0 [0/0] via 10.12.49.1, xe0
O 1.1.1.1/32 [110/3] via 20.1.1.1, xe1, 00:20:52
O 2.2.2.1/32 [110/2] via 20.1.1.1, xe1, 00:20:52
C 3.3.3.1/32 is directly connected, lo, 00:23:04
O 4.4.4.0/24 [110/0] is a summary, Null, 00:17:09
O 4.4.4.1/32 [110/2] via 30.1.1.2, xe2, 00:17:09
O 4.4.4.2/32 [110/2] via 30.1.2.2, xe3, 00:10:38
O 10.1.1.0/24 [110/2] via 20.1.1.1, xe1, 00:20:52
C 10.12.49.0/24 is directly connected, xe0, 01:33:43
C 20.1.1.0/24 is directly connected, xe1, 00:22:46
C 30.1.1.0/24 is directly connected, xe2, 00:22:15
C 30.1.2.0/24 is directly connected, xe3, 00:21:48
C 127.0.0.0/8 is directly connected, lo, 01:35:10
PE2
PE2#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
3.3.3.1 xe2 Active OPERATIONAL 30 00:14:56
 
PE2#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN, ! - using backup
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intfh ELC Nexthop
L> 1.1.1.1/32 1 1 - Yes LSP_DEFAULT 25601 xe2 No 30.1.1.1
L> 2.2.2.1/32 2 2 - Yes LSP_DEFAULT 25602 xe2 No 30.1.1.1
L> 3.3.3.1/32 3 3 - Yes LSP_DEFAULT 3 xe2 No 30.1.1.1
L> 4.4.4.2/32 7 5 - Yes LSP_DEFAULT 25605 xe2 No 30.1.1.1
L> 10.1.1.0/24 4 4 - Yes LSP_DEFAULT 25603 xe2 No 30.1.1.1
L> 20.1.1.0/24 5 3 - Yes LSP_DEFAULT 3 xe2 No 30.1.1.1
L> 30.1.2.0/24 6 3 - Yes LSP_DEFAULT 3 xe2 No 30.1.1.1
 
PE2#show ip route
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
ia - IS-IS inter area, E - EVPN,
v - vrf leaked
* - candidate default
 
IP Route Table for VRF "default"
Gateway of last resort is 10.12.49.1 to network 0.0.0.0
 
K* 0.0.0.0/0 [0/0] via 10.12.49.1, xe0
O IA 1.1.1.1/32 [110/4] via 30.1.1.1, xe2, 00:16:46
O IA 2.2.2.1/32 [110/3] via 30.1.1.1, xe2, 00:16:46
O IA 3.3.3.1/32 [110/2] via 30.1.1.1, xe2, 00:16:46
C 4.4.4.1/32 is directly connected, lo, 00:17:38
O 4.4.4.2/32 [110/3] via 30.1.1.1, xe2, 00:10:22
O IA 10.1.1.0/24 [110/3] via 30.1.1.1, xe2, 00:16:46
C 10.12.49.0/24 is directly connected, xe0, 01:24:27
O IA 20.1.1.0/24 [110/2] via 30.1.1.1, xe2, 00:16:46
C 30.1.1.0/24 is directly connected, xe2, 00:17:22
O 30.1.2.0/24 [110/2] via 30.1.1.1, xe2, 00:16:46
C 127.0.0.0/8 is directly connected, lo, 01:26:08
PE3
PE3#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
3.3.3.1 xe3 Active OPERATIONAL 30 00:12:50
 
PE3#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN, ! - using backup
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 1.1.1.1/32 1 1 - Yes LSP_DEFAULT 25606 xe3 No 30.1.2.1
L> 2.2.2.1/32 2 2 - Yes LSP_DEFAULT 25607 xe3 No 30.1.2.1
L> 3.3.3.1/32 3 3 - Yes LSP_DEFAULT 3 xe3 No 30.1.2.1
L> 4.4.4.1/32 4 4 - Yes LSP_DEFAULT 25608 xe3 No 30.1.2.1
L> 10.1.1.0/24 5 5 - Yes LSP_DEFAULT 25609 xe3 No 30.1.2.1
L> 20.1.1.0/24 6 3 - Yes LSP_DEFAULT 3 xe3 No 30.1.2.1
L> 30.1.1.0/24 7 3 - Yes LSP_DEFAULT 3 xe3 No 30.1.2.1
 
PE3#show ip route
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
ia - IS-IS inter area, E - EVPN,
v - vrf leaked
* - candidate default
 
IP Route Table for VRF "default"
Gateway of last resort is 10.12.49.1 to network 0.0.0.0
 
K* 0.0.0.0/0 [0/0] via 10.12.49.1, xe0
O IA 1.1.1.1/32 [110/4] via 30.1.2.1, xe3, 00:13:04
O IA 2.2.2.1/32 [110/3] via 30.1.2.1, xe3, 00:13:04
O IA 3.3.3.1/32 [110/2] via 30.1.2.1, xe3, 00:13:04
O 4.4.4.1/32 [110/3] via 30.1.2.1, xe3, 00:13:04
C 4.4.4.2/32 is directly connected, lo, 00:16:39
O IA 10.1.1.0/24 [110/3] via 30.1.2.1, xe3, 00:13:04
C 10.12.49.0/24 is directly connected, xe0, 00:57:36
O IA 20.1.1.0/24 [110/2] via 30.1.2.1, xe3, 00:13:04
O 30.1.1.0/24 [110/2] via 30.1.2.1, xe3, 00:13:04
C 30.1.2.0/24 is directly connected, xe3, 00:13:22
C 127.0.0.0/8 is directly connected, lo, 00:59:09