OcNOS-SP : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : MPLS BFD Configuration
MPLS BFD Configuration
This chapter shows how to configure MPLS-LSP-BFD and PW-VCCV-BFD
BFD can be used to track the liveliness of MPLS LSP and also can be used as one of the CV mechanisms in VCCV for PW fault detection and status signaling.
Topology
Figure 43-12 shows the configuration required to enable MPLS LSP BFD.
MPLS LSP BFD Topology
Configuring MPLS BFD LSP over LDP
PE1
 
#configure terminal
Enter configure mode.
(config)#interface lo
Specify the loopback (lo) interface to be configured.
(config-if)#ip address 1.1.1.1/32 secondary
Set the IP address of the loopback interface to 1.1.1.1/32.
(conf)#interface eth1
Enter interface mode
(conf-if)#ip address 10.10.10.1/24
Assign IP address to eth1 interface
(config-if)#label-switching
Enable label switching on interface eth1.
(config-if)#enable-ldp ipv4
Enable LDP on eth1.
(confi-if)#exit
Exit interface mode
(config)#router ldp
Enter Router mode for LDP.
(config-router)#router-id 1.1.1.1
Set the router ID to IP address 1.1.1.1
(config-router)#transport-address ipv4 1.1.1.1
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface. Note: It is preferable to use the loopback address as transport address. In addition, use the parameter "ipv6" if you are configuring an IPv6 interface.
(config-router)#exit
Exit the Router mode and return to the Configure mode.
(config)#router ospf 100
Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#network 10.10.10.0/24 area 0
Advertise the eth1 interface in OSPF area 0.
(config-router)#network 1.1.1.1/32 area 0
Advertise the lo interface in OSPF area 0.
(config-router)#exit
Exit router mode
(config)#mpls bfd ldp all
Configure mpls bfd for ldp
(config-mpls-bfd)#exit
Exit mpls bfd mode
(config)#commit
Commit the candidate configuration to the running configuration
(config)#end
Exit out of configuration terminal mode
P
 
#configure terminal
Enter configure mode.
(config)#interface lo
Specify the loopback (lo) interface to be configured.
(config-if)#ip address 2.2.2.2/32 secondary
Set the IP address of the loopback interface to 2.2.2.2/32.
(config-if)#exit
Exit interface mode.
(config)#interface eth1
Specify the interface (eth1) to be configured.
(conf-if)#ip address 10.10.10.2/24
Assign IP address to eth1 interface
(config-if)#label-switching
Enable label switching on interface eth1.
(config-if)#enable-ldp ipv4
Enable LDP on a specified interface (eth1).
(config-if)#exit
Exit interface mode.
(config)#interface eth2
Specify the interface (eth2) to be configured.
(conf-if)#ip address 20.20.20.1/24
Assign IP address to eth2 interface
(config-if)#label-switching
Enable label switching on interface eth2.
(config-if)#enable-ldp ipv4
Enable LDP on a specified interface (eth2).
(config-if)#exit
Exit interface mode.
(config)#router ldp
Enter Router mode.
(config-router)#router-id 2.2.2.2
Set the router ID to IP address 2.2.2.2.
(config-router)#transport-address ipv4 2.2.2.2
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface.
(config-router)#exit
Exit Router mode and return to Configure mode.
(config)#router ospf 100
Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#network 10.10.10.0/24 area 0
Define the interfaces on which OSPF runs and associate the area ID (0) with them.
(config-router)#network 20.20.20.0/24 area 0
Define the interfaces on which OSPF runs and associate the area ID (0) with them.
(config-router)#network 2.2.2.2/32 area 0
Define the interfaces on which OSPF runs and associate the area ID (0) with them.
(config)#mpls bfd ldp all
Configure mpls bfd for ldp
(config-mpls-bfd)#exit
Exit mpls bfd mode
(config)#commit
Commit the candidate configuration to the running configuration
(config)#end
Exit out of configuration terminal mode
PE2
 
#configure terminal
Enter configure mode.
(config)#interface lo
Specify the loopback (lo) interface to be configured.
(config-if)#ip address 3.3.3.3/32 secondary
Set the IP address of the loopback interface to 3.3.3.3/32.
(config-if)#exit
Exit interface mode.
(config)#interface eth2
Specify the interface (eth2) to be configured.
(conf-if)#ip address 20.20.20.2/24
Assign IP address to eth2 interface
(config-if)#label-switching
Enable label switching on interface eth2.
(config-if)#enable-ldp ipv4
Enable LDP on a specified interface (eth2).
(config-if)#commit
Commit the transaction.
(config-if)#exit
Exit Interface mode
(config)#router ldp
Enter Router mode.
(config-router)#router-id 3.3.3.3
Set the router ID for IP address 3.3.3.3.
(config-router)#transport-address ipv4 3.3.3.3
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface. Note: It is preferable to use the loopback address as transport address. In addition, use the parameter "ipv6" if you are configuring an IPv6 interface.
(config-router)#exit
Exit the Router mode and return to the Configure mode.
(config)#router ospf 100
Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#network 20.20.20.0/24 area 0
Define the interfaces on which OSPF runs and associate the area ID (0) with them.
(config-router)#network 3.3.3.3/32 area 0
Define the interfaces on which OSPF runs and associate the area ID (0) with them.
(config-router)#commit
Commit the transaction.
(config)#mpls bfd ldp all
Configure mpls bfd for ldp
(config-mpls-bfd)#exit
Exit mpls bfd mode
(config)#commit
Commit the candidate configuration to the running configuration
(config)#end
Exit out of configuration terminal mode
Validation
Validation 1
Verify OSPF neighbor adjacency between all 5 routers.
PE1#show ip ospf neighbor
 
Total number of full neighbors: 1
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
2.2.2.2 1 Full/DR 00:00:32 10.10.10.2 eth1 0
 
P#show ip ospf neighbor
 
Total number of full neighbors: 2
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
1.1.1.1 1 Full/Backup 00:00:35 10.10.10.1 eth1 0
3.3.3.3 1 Full/Backup 00:00:32 20.20.20.2 eth2 0
 
PE2#show ip ospf neighbor
 
Total number of full neighbors: 1
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
2.2.2.2 1 Full/DR 00:00:31 20.20.20.1 eth1 0
Validation 2
Verify that ldp session on all 3 nodes have come up.
PE1#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
2.2.2.2 eth1 Passive OPERATIONAL 30 01:30:57
 
P#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
1.1.1.1 eth1 Active OPERATIONAL 30 01:48:34
3.3.3.3 eth2 Passive OPERATIONAL 30 03:01:14
 
PE2#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
2.2.2.2 eth2 Active OPERATIONAL 30 03:01:14
Validation 3
The command output below displays the LSP sessions with LDP as signaling protocol.
PE1# #show bfd mpls lsp sessions
Peer Addr Path Tunnel-name State Local Local Min Min Encap Last
Disc Multi Tx Rx Dn-Time
2.2.2.2 LDP LSP Up 1281 3 10000 10000 IP/UDP 00:00:00
3.3.3.3 LDP LSP Up 1282 3 10000 10000 IP/UDP 00:00:00
0.0.0.0 LDP LSP Up 1283 3 3000 3000 IP/UDP 00:00:00
0.0.0.0 LDP LSP Up 1284 3 3000 3000 IP/UDP 00:00:00
 
P #show bfd mpls lsp sessions
Peer Addr Path Tunnel-name State Local Local Min Min Encap Last
Disc Multi Tx Rx Dn-Time
3.3.3.3 LDP LSP Up 1283 3 10000 10000 IP/UDP 00:00:00
0.0.0.0 LDP LSP Up 1281 3 3000 3000 IP/UDP 00:00:00
1.1.1.1 LDP LSP Up 1282 3 10000 10000 IP/UDP 00:00:00
0.0.0.0 LDP LSP Up 1284 3 3000 3000 IP/UDP 00:00:00
 
PE1 #show bfd mpls lsp sessions
Peer Addr Path Tunnel-name State Local Local Min Min Encap Last
Disc Multi Tx Rx Dn-Time
2.2.2.2 LDP LSP Up 1282 3 10000 10000 IP/UDP 00:00:00
0.0.0.0 LDP LSP Up 1283 3 3000 3000 IP/UDP 00:00:00
1.1.1.1 LDP LSP Up 1281 3 10000 10000 IP/UDP 00:00:00
0.0.0.0 LDP LSP Up 1284 3 3000 3000 IP/UDP 00:00:00
 
Configuring MPLS BFD LSP over RSVP
This section shows how to configure RSVP session between PE1 and PE2 and MPLS BFD.
Note: For OSPF configurations, please refer 'Configuring MPLS BFD LSP over LDP' section.
PE1
 
(config)#router rsvp
Enter Router mode for RSVP.
(config-router)#exit
Exit RSVP router mode
(conf)#interface eth1
Enter interface mode
(config-if)#label-switching
Enable label switching on interface eth1.
(config-if)#enable-rsvp
Enable RSVP on eth1.
(confi-if)#exit
Exit interface mode
(config)#rsvp-trunk T1 ipv4
Configure Trunk for RSVP
(config-trunk)# from 1.1.1.1
Specify tunnel ingress for RSVP
(config-trunk)# to 3.3.3.3
Specify tunnel egress for RSVP
(config-trunk)#exit
Exit RSVP trunk configuration mode
(config)#mpls bfd rsvp all
Configure mpls bfd for RSVP
(config-mpls-bfd)#exit
Exit mpls bfd mode
(config)#commit
Commit the candidate configuration to the running configuration
(config)#end
Exit out of configuration terminal mode
 
P
 
(config)#router rsvp
Enter Router mode for RSVP.
(config-router)#exit
Exit RSVP router mode
(conf)#interface eth1
Enter interface mode
(config-if)#label-switching
Enable label switching on interface eth1.
(config-if)#enable-rsvp
Enable RSVP on eth1.
(confi-if)#exit
Exit interface mode
(conf)#interface eth2
Enter interface mode
(config-if)#label-switching
Enable label switching on interface eth2.
(config-if)#enable-rsvp
Enable RSVP on eth2.
(confi-if)#exit
Exit interface mode
(config)#mpls bfd rsvp all
Configure mpls bfd for RSVP
(config-mpls-bfd)#exit
Exit mpls bfd mode
(config)#commit
Commit the candidate configuration to the running configuration
(config)#end
Exit out of configuration terminal mode
PE2
 
(config)#router rsvp
Enter Router mode for RSVP.
(config-router)#exit
Exit RSVP router mode
(conf)#interface eth2
Enter interface mode
(config-if)#label-switching
Enable label switching on interface eth2.
(config-if)#enable-rsvp
Enable RSVP on eth2.
(confi-if)#exit
Exit interface mode
(config)#rsvp-trunk T1 ipv4
Configure Trunk for RSVP
(config-trunk)# from 3.3.3.3
Specify tunnel ingress for RSVP
(config-trunk)# to 1.1.1.1
Specify tunnel egress for RSVP
(config-trunk)#exit
Exit RSVP trunk configuration mode
(config)#mpls bfd rsvp all
Configure mpls bfd for RSVP
(config-mpls-bfd)#exit
Exit mpls bfd mode
(config)#commit
Commit the candidate configuration to the running configuration
(config)#end
Exit out of configuration terminal mode
Validation
Validation 1
Verify RSVP session is up and running between PE nodes.
PE1#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
 
Ingress RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
3.3.3.3 1.1.1.1 PRI T1-Primary UP 00:35:38 1 1 SE - 24321 DEFAULT
Total 1 displayed, Up 1, Down 0.
 
Egress RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
1.1.1.1 3.3.3.3 PRI T1-Primary UP 00:35:51 1 1 SE 24320 - ELSP_CON
Total 1 displayed, Up 1, Down 0.
 
PE2#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
 
Ingress RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
1.1.1.1 3.3.3.3 PRI T1-Primary UP 00:37:51 1 1 SE - 24320 DEFAULT
Total 1 displayed, Up 1, Down 0.
 
Egress RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
3.3.3.3 1.1.1.1 PRI T1-Primary UP 00:37:38 1 1 SE 24320 - ELSP_CON
 
Validation 2
The command output below displays the LSP sessions with RSVP.
PE1#show bfd mpls lsp sessions
Peer Addr Path Tunnel-name State Local Local Min Min Encap Last
Disc Multi Tx Rx Dn-Time
3.3.3.3 RSVP LSP T1 Up 1282 3 10000 10000 IP/UDP 00:00:00
PE2#show bfd mpls lsp sessions
Peer Addr Path Tunnel-name State Local Local Min Min Encap Last
Disc Multi Tx Rx Dn-Time
1.1.1.1 RSVP LSP T1 Up 1281 3 10000 10000 IP/UDP 00:00:00
 
Configuring Static MPLS BFD
This section shows how to configure MPLS BFD statically.
Note: For OSPF configurations, please refer 'Configuring MPLS BFD LSP over LDP' section.
PE1
 
(config)#interface eth1
Enter interface mode
(config-if)#label-switching
Enable label switching on interface eth1.
(config-if)#exit
Exit interface mode
(conf)#mpls ftn-entry 3.3.3.3/32 102 10.10.10.2 eth1
Configure MPLS FTN entry for the creation of a static LSP to
PE-2.
 
(config)#mpls ilm-entry 401 pop
Configure ILM entry
(config)#mpls bfd static all
Configure mpls bfd for static MPLS
(config-mpls-bfd)#exit
Exit mpls bfd mode
(config)#commit
Commit the candidate configuration to the running configuration
(config)#end
Exit out of configuration terminal mode
P
 
(config)#interface eth1
Enter interface mode
(config-if)#label-switching
Enable label switching on interface eth1.
(confi-if)#exit
Exit interface mode
(conf)#interface eth2
Enter interface mode
(config-if)#label-switching
Enable label switching on interface eth2.
(config-if)#exit
Exit interface mode
mpls ilm-entry 201 swap 401 eth1 10.10.10.1 1.1.1.1/32
Swap the incoming label
mpls ilm-entry 102 swap 301 eth2 mpls ftn-entry 1.1.1.1/32 201 20.20.20.1 eth2 20.20.20.2 3.3.3.3/32
Swap the incoming label
(config)#mpls bfd static all
Configure mpls bfd for static MPLS
(config-mpls-bfd)#exit
Exit mpls bfd mode
(config)#commit
Commit the candidate configuration to the running configuration
(config)#end
Exit out of configuration terminal mode
PE2
 
(conf)#interface eth2
Enter interface mode
(config-if)#label-switching
Enable label switching on interface eth2.
(config-if)#exit
Exit interface mode
(config)#mpls ftn-entry 1.1.1.1/32 201 20.20.20.1 eth2
Configure MPLS FTN entry for the creation of a static LSP to
PE-1
 
(config)#mpls bfd static all
Configure mpls bfd for static MPLS
(config-mpls-bfd)#exit
Exit mpls bfd mode
(config)#commit
Commit the candidate configuration to the running configuration
(config)#end
Exit out of configuration terminal mode
Validations
Validation 1
Verify static MPLS BFD session is up and running between PE nodes.
PE1#show bfd mpls lsp sessions
Peer Addr Path Tunnel-name State Local Local Min Min Encap Last
Disc Multi Tx Rx Dn-Time
3.3.3.3 Static LSP Up 1281 3 10000 10000 IP/UDP 00:00:00
 
PE2#show bfd mpls lsp sessions
Peer Addr Path Tunnel-name State Local Local Min Min Encap Last
Disc Multi Tx Rx Dn-Time
1.1.1.1 Static LSP Up 1281 3 10000 10000 IP/UDP 00:00:00
Configuring PW VCCV BFD
This section shows how to configure PW VCCV BFD.
Note: For OSPF configurations, please refer 'Configuring MPLS BFD LSP over LDP' section.
PE1
 
#configure terminal
Enter configure mode.
(config)#interface lo
Specify the loopback (lo) interface to be configured.
(config-if)#ip address 1.1.1.1/32 secondary
Set the IP address of the loopback interface to 1.1.1.1/32.
(conf)#interface eth1
Enter interface mode
(conf-if)#ip address 10.10.10.1/24
Assign IP address to eth1 interface
(config-if)#label-switching
Enable label switching on interface eth1.
(config-if)#enable-ldp ipv4
Enable LDP on eth1.
(confi-if)#exit
Exit interface mode
(config)#router ldp
Enter Router mode for LDP.
(config-router)#router-id 1.1.1.1
Set the router ID to IP address 1.1.1.1
(config-router)#transport-address ipv4 1.1.1.1
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface. Note: It is preferable to use the loopback address as transport address. In addition, use the parameter "ipv6" if you are configuring an IPv6 interface.
(config-router)#exit
Exit the Router mode and return to the Configure mode.
(config)#service-template st1
Service template configuration
(config-svc)#exit
Exit service-template configuration mode
(config)#mpls l2-circuit pw1 3.3.3.3
Configure the VC for PE2
(config-pseudowire)#control-word
Configure control-word
(config-pseudowire)#vccv cc-type type-1
Configure cc-type type-1
(config-pseudowire)#vccv cv-type type-3
Configure cv-type type-3
(confi- pseudowire)#exit
Exit pw configuration mode
(config)#commit
Commit the candidate configuration to the running configuration
P
 
#configure terminal
Enter configure mode.
(config)#interface lo
Specify the loopback (lo) interface to be configured.
(config-if)#ip address 2.2.2.2/32 secondary
Set the IP address of the loopback interface to 2.2.2.2/32.
(config-if)#exit
Exit interface mode.
(config)#interface eth1
Specify the interface (eth1) to be configured.
(conf-if)#ip address 10.10.10.2/24
Assign IP address to eth1 interface
(config-if)#label-switching
Enable label switching on interface eth1.
(config-if)#enable-ldp ipv4
Enable LDP on a specified interface (eth1).
(config-if)#exit
Exit interface mode.
(config)#interface eth2
Specify the interface (eth2) to be configured.
(conf-if)#ip address 20.20.20.1/24
Assign IP address to eth2 interface
(config-if)#label-switching
Enable label switching on interface eth2.
(config-if)#enable-ldp ipv4
Enable LDP on a specified interface (eth2).
(config-if)#exit
Exit interface mode.
(config)#router ldp
Enter Router mode.
(config-router)#router-id 2.2.2.2
Set the router ID to IP address 2.2.2.2.
(config-router)#transport-address ipv4 2.2.2.2
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface.
(config-router)#pw-status-tlv
Configure PW Status TLV to signal the pseudowire status
(config-router)#exit
Exit Router mode and return to Configure mode.
(config)#commit
Commit the candidate configuration to the running configuration
PE2
 
#configure terminal
Enter configure mode.
(config)#interface lo
Specify the loopback (lo) interface to be configured.
(config-if)#ip address 3.3.3.3/32 secondary
Set the IP address of the loopback interface to 3.3.3.3/32.
(config-if)#exit
Exit interface mode.
(config)#interface eth1
Specify the interface (eth1) to be configured.
(conf-if)#ip address 20.20.20.2/24
Assign IP address to eth1 interface
(config-if)#label-switching
Enable label switching on interface eth2.
(config-if)#enable-ldp ipv4
Enable LDP on a specified interface (eth2).
(config-if)#commit
Commit the transaction.
(config-if)#exit
Exit Interface mode
(config)#router ldp
Enter Router mode.
(config-router)#router-id 3.3.3.3
Set the router ID for IP address 3.3.3.3.
(config-router)#transport-address ipv4 3.3.3.3
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface. Note: It is preferable to use the loopback address as transport address. In addition, use the parameter "ipv6" if you are configuring an IPv6 interface.
(config-router)#exit
Exit the Router mode and return to the Configure mode.
(config)#service-template st1
Service template configuration
(config-svc)#exit
Exit service-template configuration mode
(config)#mpls l2-circuit pw1 1.1.1.1
Configure the VC for PE1
(config-pseudowire)#control-word
Configure control-word
(config-pseudowire)#vccv cc-type type-1
Configure cc-type type-1
(config-pseudowire)#vccv cv-type type-3
Configure cv-type type-3
(confi- pseudowire)#exit
Exit pw configuration mode
Validation
Validation 1
Verify PW VCCV BFD sessions are up between PE nodes.
PE1#show bfd mpls pw-vccv sessions
VC-ID Peer Addr State Local Local Min Min Encap Last
Disc Multi Tx Rx Dn-Time
1 3.3.3.3 Up 1281 3 3000 3000 PW-ACH 00:00:00
 
PE2#show bfd mpls pw-vccv sessions
VC-ID Peer Addr State Local Local Min Min Encap Last
Disc Multi Tx Rx Dn-Time
1 1.1.1.1 Up 1281 3 3000 3000 PW-ACH 00:00:00