OcNOS-SP : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : RSVP-TE Configuration
RSVP-TE Configuration
This chapter contains configurations for Resource Reservation Protocol - Traffic Engineering (RSVP-TE).
RSVP-TE Overview
RSVP-TE is a signaling protocol that supports explicit routing capabilities, To do this, an Explicit Route (ER) object is incorporated into RSVP PATH messages. This object encapsulates a sequence of hops that constitute the explicitly-routed path. Using the ER object, the paths taken by label-switched RSVP-MPLS flows can be pre-determined without conventional IP routing. An ER path can be administratively specified or computed based on CSPF and any policy requirements dictated by the operator through the trunk node, taking the current network state into consideration. A useful application of explicit routing is Traffic Engineering (TE). Using explicitly-routed LSPs, an ingress node can control the path through which traffic flows from itself, through the MPLS network, to the egress node. Explicit routing is therefore useful for the optimization of network resources and an increase in the quality of traffic-oriented performance.
Basic RSVP-TE Topology
RSVP-TE Architecture
RSVP-TE is a signaling protocol that supports explicit routing capabilities to establish LSPs in a MPLS network. OcNOS RSVP-TE:
Creates explicitly-routed paths, which might not agree with the route suggested by the IGP (OSPF, RIP) being used. Explicitly-routed LSPs, by definition, do not follow the paths suggested by IGPs.
Queries CSPF for a complete, end-to-end, explicit route based on constraints specified by the operator using RSVP commands.
Performs make-before-break type re-routing of tunnels. (Make-before-break is the creation of a new LSP before the old one is torn down).
Exchanges Hello messages to make node failures easier to detect. This means when there is no hello exchange between routers, then other node is assumed dead or offline (except in the case when the peer is known to not support Hellos).
Provides statistical information of RSVP messages exchanged.
In addition, OcNOS RSVP-TE may be used in unison with BGP to generate MPLS/BGP VPNs, and in unison with LDP to generate Layer-2 Virtual Circuits.
Configure RSVP-TE
Note: The following configuration for establishing a trunk is required on all routers participating in label-switching. Based on the assumption that minimal configurations exist on all participating routers, other examples do not repeat this configuration.
Enable Label Switching - Minimal Configuration
To establish a trunk on a system:
1. Enable label-switching and RSVP-TE on all participating interfaces.
2. Configure a trunk on the ingress router to use the best available IGP path.
In this example, the Label Switched Path (LSP) is configured using minimal configuration and is setup using the best IP nexthop available. Each router along the path is chosen by the previous router by looking up the best nexthop available in its IP routing table.
Topology for Minimal Configuration
PE1 - NSM
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 192.168.0.63/32 secondary
Set the IP address for the interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#ip address 10.10.23.63/24
Set the IP address for the interface.
(config-if)#label-switching
Enable label switching on interface xe2.
(config-if)#commit
Commit the transaction.
PE1 - RSVP-TE
 
(config)#router rsvp
Enter Configure Router mode.
(config-router)#exit
Exit Router mode.
(config)#interface xe2
Enter interface mode.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#commit
Commit the transaction.
PE1 - OSPF
 
#configure terminal
Enter configure mode.
(config)#router ospf 100
Configure the Routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#router-id 192.168.0.63
Configure OSPF router-ID same as loopback interface IP address
(config-router)#network 10.10.23.0/24 area 0
Define the network (10.10.23.0/24) on which OSPF runs and associate the area ID (0).
(config-router)#network 192.168.0.63/32 area 0
Set the IP address of the loopback interface to 192.168.0.63/32.
(config-router)#commit
Commit the transaction.
P - NSM
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 192.168.0.60/32 secondary
Set the IP address for the interface.
(config-if)#exit
Enable label switching on interface lo.
(config)#interface xe2
Enter interface mode.
(config-if)#ip address 10.10.23.60/24
Set the IP address for the interface.
(config-if)#label-switching
Enable label switching on interface xe2.
(config-if)#exit
Exit interface mode.
(config)#interface xe1
Enter interface mode.
(config-if)#ip address 10.10.21.60/24
Set the IP address for the interface.
(config-if)#label-switching
Enable label switching on interface xe1.
(config-if)#commit
Commit the transaction.
P - RSVP-TE
 
(config)#router rsvp
Enter Configure Router mode.
(config-router)#exit
Exit Router mode.
(config)#interface xe2
Enter interface mode.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe1
Enter interface mode.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#commit
Commit the transaction.
P - OSPF
 
#configure terminal
Enter configure mode.
(config)#router ospf 100
Configure the Routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#router-id 192.168.0.60
Configure OSPF router-ID same as loopback interface IP address
(config-router)#network 10.10.23.0/24 area 0
Define the first network (10.10.23.0/24) on which OSPF runs and associate the area ID (0).
(config-router)#network 10.10.21.0/24 area 0
Define the second network (10.10.21.0/24) on which OSPF runs and associate the area ID (0).
(config-router)#network 192.168.0.60/32 area 0
Set the IP address of the loopback interface to 192.168.0.63/32.
(config-router)#commit
Commit the transaction.
PE2 - NSM
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 192.168.0.90/32 secondary
Set the IP address for the interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe1
Enter interface mode.
(config-if)#ip address 10.10.21.90/24
Set the IP address for the interface.
(config-if)#label-switching
Enable label switching on interface xe2.
(config-if)#commit
Commit the transaction.
PE2 - RSVP-TE
 
(config)#router rsvp
Enter Configure Router mode.
(config-router)#exit
Exit Router mode.
(config)#interface xe1
Enter interface mode.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#commit
Commit the transaction.
PE2 - OSPF
 
#configure terminal
Enter configure mode.
(config)#router ospf 100
Configure the Routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#router-id 192.168.0.90
Configure OSPF router-ID same as loopback interface IP address
(config-router)#network 10.10.21.0/24 area 0
Define the network (10.10.21.0/24) on which OSPF runs and associate the area ID (0).
(config-router)#network 192.168.0.90/32 area 0
Set the IP address of the loopback interface to 192.168.0.63/32.
(config-router)#commit
Commit the transaction.
Establish a Trunk with CSPF Disabled
OcNOS, Constrained Shortest Path First (CSPF) calculation is enabled by default.Typically, CSPF is disabled when all of the participating nodes do not support the required traffic engineering extensions and LSPs are configured manually to use an explicit path. In this case, an LSP is established only along the path specified by the operator.
Note: This example is based on the assumption that a minimal configuration exists on all participating routers as described in Enable Label Switching - Minimal Configuration.
Topology
Basic Topology
PE1 - RSVP-TE
 
#configure terminal
Enter configure mode.
(config)#rsvp-trunk T1
Create an RSVP trunk T1 and enter the Trunk mode.
(config-trunk)#no primary cspf
Specify no primary cspf since CSPF is enabled by default.
(config-trunk)#to 192.168.0.90
Specify the IPv4 egress (destination point) for the LSP.
(config-trunk)#commit
Commit the transaction.
Establish a Trunk Using CSPF
The RSVP trunk can be configured using CSPF (Constraint-based Shortest Path First). In this case, the RSVP daemon (rsvpd) sends a request to the CSPF server to compute a path through the network to reach the destination. CSPF returns a hop-by-hop path called the Explicit Route to the RSVP daemon to be used in the Explicit Route Object (ERO). Each router along the path sends a Path message only to the nexthop specified in the ERO. In the OcNOS implementation, CSPF is enabled by default and if no cspf is not specified, the trunk is CSPF enabled automatically.
Note: This example is based on the assumption that a minimal configuration exists on all participating routers as described in Enable Label Switching - Minimal Configuration.
PE1 (RSVP Daemon)
 
#configure terminal
Enter configure mode.
(config)#rsvp-trunk T1
Create an RSVP trunk T1 and enter the Trunk mode.
(config-trunk)#to 192.168.0.90
Specify the IPv4 egress (destination point) for the LSP.
(config-trunk)#commit
Commit the transaction.
Mapping a Route to a Trunk
In the OcNOS implementation, a network can be mapped to a particular trunk using map-route configuration.
Note: This example is based on the assumption that a minimal configuration exists on all participating routers. For configuration details, refer to the “Establishing a Trunk - Minimal Configuration” section.
Topology
Topology for route mapping
PE1 - RSVP-TE
 
#configure terminal
Enter configure mode.
(config)#router rsvp
Enable RSVP globally.
(config-router)#rsvp-path PE2
Configure RSVP path.
(config-path)#rsvp-trunk T1
Create an RSVP trunk T1 and enter the Trunk mode.
(config-trunk)#map-route 90.90.90.0/24
Specify the destination prefix that needs to mapped to this trunk.
(config-trunk)#to 192.168.0.90
Specify the IPv4 egress (destination point) for the LSP.
(config-trunk)#commit
Commit the transaction.
Establish a Trunk Using Explicitly-Defined Path
Explicit Route hops can be configured manually in the trunk configuration. In this case, the RSVP daemon uses the configured hops as Explicit Route Objects (ERO). It sets up the LSP using specified hops only.
An ERO is composed of IP addresses called hops. An ERO hop can be defined as loose or strict. A loose hop can be reached by any available route. A strict hop must be reached via a direct link and cannot be routed over any alternate routers in between. In this example, since PE3 is defined as loose hop, P can use P2 as an intermediate hop to reach PE2. However, if it was a strict hop, then P would have to use interface xe1 to reach PE3 directly.
Note: This example is based on the assumption that a minimal configuration exists on all participating routers as described in Enable Label Switching - Minimal Configuration.
Topology
Topology for Explicitly Defined Path
PE1 - RSVP-Path
 
#configure terminal
Enter configure mode.
(config)#rsvp-path P1
Create an RSVP Path P1 and enter the Path mode.
(config-path)#10.10.23.60 strict
Configure this explicit route path as a strict hop.
(config-path)#10.10.21.90 loose
Configure this explicit route path as a loose hop.
(config-path)#exit
Exit Path mode.
#configure terminal
Enter configure mode.
(config)#rsvp-trunk T1
Create an RSVP trunk T1 and enter the Trunk mode.
(config-trunk)#no primary cspf
Since CSPF is enabled by default, specify no primary cspf if CSPF is not required.
(config-trunk)#primary path P1
Configure trunk T1 to use the defined path.
(config-trunk)#to 192.168.0.90
Specify the IPv4 egress (destination point) for the LSP.
(config-trunk)#commit
Commit the transaction.
Validation
PE1#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
 
Ingress RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
192.168.0.90 192.168.0.63 PRI T1-Primary UP 00:00:16 1 1 SE - 24320 DEFAULT
Total 1 displayed, Up 1, Down 0.
 
PE2#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to
ondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
 
Egress RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
192.168.0.90 192.168.0.63 PRI T1-Primary UP 00:00:33 1 1 SE 25600 - ELSP_CON
Total 1 displayed, Up 1, Down 0. PE1#show ip ospf neighbor
Total number of full neighbors: 1 OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
192.168.0.60 1 Full/Backup 00:00:30 10.10.23.60 xe2 0
 
P1#show ip ospf neighbor
 
Total number of full neighbors: 2 OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
192.168.0.90 1 Full/Backup 00:00:35 10.10.21.90 xe8 0
192.168.0.63 1 Full/DR 00:00:36 10.10.23.63 xe2 0
 
PE2#show ip ospf neighbor
 
Total number of full neighbors: 1 OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
192.168.0.60 1 Full/DR 00:00:32 10.10.21.60 xe8 0
Add a Secondary LSP to the Trunk
Although the attributes of a Secondary LSP are independent of the Primary LSP, a Secondary LSP cannot be configured without first configuring a Primary LSP. In addition to information on how to configure a secondary LSP, this example illustrates how to define a non-default setup and the hold priority for an LSP. Setup and hold priorities are used to determine which LSP should be given a preference when competing for resources. Specifically, the setup priority of an un-established LSP is compared to the hold priorities of established LSPs, and the numerically lower one is given a preference. However, once the LSP is established, its setup priority is never used until it is pre-empted or reset and is being brought up again.
Note: This example is based on the assumption that a minimal configuration exists on all participating routers as described in Enable Label Switching - Minimal Configuration.
Note: If user provides the RSVP path option for secondary, the primary path exclusion logic gets disabled. User needs to keep primary and secondary path mutually exclusive. Else, RSVP-Primary LSP and RSVP-Secondary LSP may select the same next hop, when RSVP is configured with "loose". Hence RSVP-Path first next-hop should be "strict".
PE1 - RSVP-TE
 
#configure terminal
Enter configure mode.
(config)#rsvp-path myPath
Specify an RSVP path to be used.
(config-path)#10.10.23.60 strict
Configure this explicit route path as a strict hop.
(config-path)#exit
Exit Path mode.
(config)#rsvp-path myPath2
Specify an RSVP path to be used.
(config-path)#10.10.23.60 loose
Configure this explicit route path as a loose hop.
(config-path)#exit
Exit Path mode.
(config)#rsvp-trunk T1
Create an RSVP trunk T1 and enter the Trunk mode.
(config-trunk)#no primary cspf
Since CSPF is enabled by default, specify no secondary cspf if CSPF is not required.
(config-trunk)#primary path myPath
Specify an RSVP path to be used.
(config-trunk)#no secondary cspf
Specify the no secondary cspf option for the Secondary LSP.
(config-trunk)#secondary path myPath2
Specify an RSVP path to be used.
(config-trunk)#to 192.168.0.90
Specify the IPv4 egress (destination point) for the LSP.
(config-trunk)#commit
Commit the transaction.
Validation
This example shows the number of configured RSVP sessions in a router.
PE1
#show rsvp session count
Total configured: 1, Up 1, Down 0
 
Total ingress sessions: 1, Up 1, Down 0
Total transit sessions: 0, Up 0, Down 0
Total egress sessions: 0, Up 0, Down 0
PE2
#show rsvp session count
Total configured: 1, Up 1, Down 0
 
Total ingress sessions: 0, Up 0, Down 0
Total transit sessions: 0, Up 0, Down 0
Total egress sessions: 1, Up 1, Down 0
Add Multiple Secondary LSP to the trunk
RSVP Multiple Secondary feature tries to provide continuous protection when multiple failures happen. In majority scenarios, feature tries to provide seamless protection. This is a proprietary feature where user can configure multiple secondary sessions in a rsvp-trunk. Each secondary will be associated with a priority. Priority secondary sessions must be programmed with a predefined path. User can configure a maximum of five priority levels. Lowest priority number corresponds to highest priority. Highest priority session will be signaled to be programmed as secondary session. If highest priority session cannot come up, then next available secondary will be selected based on polling. During primary session fail-over, programmed secondary priority session will protect the primary and then goes for an MBB update to act as the primary session until primary comes up. Once the highest priority session comes up as acting primary session, next available secondary priority session will be programmed to signal and come up secondary. Re-optimization timer executed once in every 5 minutes to ensure the best priority session serves as secondary. Configuration updates on secondary priority configurations doesn't trigger MBB and session will be restarted. This example illustrates how to create SVI, enable IGP protocols and RSVP on SVI.
Note: Ensure that the VLAN is configured before creating SVI.
Topology
Topology for Multiple Secondary Protection
Bridge Configuration
bridge 1 protocol ieee vlan-bridge
no bridge 1 spanning-tree enable bridge-forward
VLAN creation
vlan database
vlan 2-7 bridge 1 state enable
vlan 501-506 bridge 1 state enable
PE1
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode
(config-if)#ip address 47.47.47.47/32 secondary
Set the secondary IP address for the lo interface
(config-if)#exit
Exit interface mode.
(config)#router rsvp
Enable RSVP globally.
(config-router)#exit
Exit RSVP mode.
(config)#interface vlan1.2
Enter the interface mode.
(config-if)#ip address 10.10.23.1/24
Configure the IP Address
(config-if)#mtu 1600
Configure MTU size.
(config-if)#label-switching
Enable MPLS.
(config-if)#ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#enable-rsvp
Enable RSVP at the interface level.
(config-if)#exit
Exit the interface mode.
(config)#interface vlan1.3
Enter the interface mode.
(config-if)#ip address 10.10.24.1/24
Configure the IP Address
(config-if)#mtu 1600
Configure MTU size.
(config-if)#label-switching
Enable MPLS.
(config-if)#ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#enable-rsvp
Enable RSVP at the interface level.
(config-if)#exit
Exit the interface mode.
(config)#interface vlan1.4
Enter the interface mode.
(config-if)#ip address 10.10.25.1/24
Configure the IP Address
(config-if)#mtu 1600
Configure MTU size.
(config-if)#label-switching
Enable MPLS.
(config-if)#ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#enable-rsvp
Enable RSVP at the interface level.
(config-if)#exit
Exit the interface mode.
(config)#interface vlan1.5
Enter the interface mode.
(config-if)#ip address 10.10.26.1/24
Configure the IP Address
(config-if)#mtu 1600
Configure MTU size.
(config-if)#label-switching
Enable MPLS.
(config-if)#ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#enable-rsvp
Enable RSVP at the interface level.
(config-if)#exit
Exit the interface mode.
(config)#interface vlan1.6
Enter the interface mode.
(config-if)#ip address 10.10.27.1/24
Configure the IP Address
(config-if)#mtu 1600
Configure MTU size.
(config-if)#label-switching
Enable MPLS.
(config-if)#ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#enable-rsvp
Enable RSVP at the interface level.
(config-if)#exit
Exit the interface mode.
(config)#interface vlan1.7
Enter the interface mode.
(config-if)#ip address 10.10.28.1/24
Configure the IP Address
(config-if)#mtu 1600
Configure MTU size.
(config-if)#label-switching
Enable MPLS.
(config-if)#ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#enable-rsvp
Enable RSVP at the interface level.
(config-if)#exit
Exit the interface mode.
(config)#interface xe2
Enter the interface mode.
(config-if)#switchport
Configure Switchport
(config-if)#bridge-group 1
Assign a Bridge ID to the port channel
(config-if)#switchport mode trunk
Configure trunk
(config-if)#switchport trunk allowed vlan add 2,501
Configure allowed VLANs
(config-if)#switchport trunk native vlan 501
Configure native VLAN.
(config-if)#load-interval 30
Set load interval
(config-if)#mtu 9192
Configure the MTU Size.
(config-if)#exit
Exit the interface mode.
(config)#interface xe3
Enter the interface mode.
(config-if)#switchport
Configure Switchport
(config-if)#bridge-group 1
Assign a Bridge ID to the port channel
(config-if)#switchport mode trunk
Configure trunk
(config-if)#switchport trunk allowed vlan add 3,502
Configure allowed VLANs
(config-if)#switchport trunk native vlan 502
Configure native VLAN.
(config-if)#load-interval 30
Set load interval
(config-if)#mtu 9192
Configure the MTU Size.
(config-if)#exit
Exit the interface mode.
(config)#interface xe4
Enter the interface mode.
(config-if)#switchport
Configure Switchport
(config-if)#bridge-group 1
Assign a Bridge ID to the port channel
(config-if)#switchport mode trunk
Configure trunk
(config-if)#switchport trunk allowed vlan add 4,503
Configure allowed VLANs
(config-if)#switchport trunk native vlan 503
Configure native VLAN.
(config-if)#load-interval 30
Set load interval
(config-if)#mtu 9192
Configure the MTU Size.
(config-if)#exit
Exit the interface mode.
(config)#interface xe5
Enter the interface mode.
(config-if)#switchport
Configure Switchport
(config-if)#bridge-group 1
Assign a Bridge ID to the port channel
(config-if)#switchport mode trunk
Configure trunk
(config-if)#switchport trunk allowed vlan add 5,504
Configure allowed VLANs
(config-if)#switchport trunk native vlan 504
Configure native VLAN.
(config-if)#load-interval 30
Set load interval
(config-if)#mtu 9192
Configure the MTU Size.
(config-if)#exit
Exit the interface mode.
(config)#interface xe6
Enter the interface mode.
(config-if)#switchport
Configure Switchport
(config-if)#bridge-group 1
Assign a Bridge ID to the port channel
(config-if)#switchport mode trunk
Configure trunk
(config-if)#switchport trunk allowed vlan add 6,505
Configure allowed VLANs
(config-if)#switchport trunk native vlan 505
Configure native VLAN.
(config-if)#load-interval 30
Set load interval
(config-if)#mtu 9192
Configure the MTU Size.
(config-if)#exit
Exit the interface mode.
(config)#interface xe7
Enter the interface mode.
(config-if)#switchport
Configure Switchport
(config-if)#bridge-group 1
Assign a Bridge ID to the port channel
(config-if)#switchport mode trunk
Configure trunk
(config-if)#switchport trunk allowed vlan add 7,506
Configure allowed VLANs
(config-if)#switchport trunk native vlan 506
Configure native VLAN.
(config-if)#load-interval 30
Set load interval
(config-if)#mtu 9192
Configure the MTU Size.
(config-if)#exit
Exit the interface mode.
(conf)#rsvp-path p1-r1-r3 mpls
Create RSVP path
(conf-path)#10.10.23.2 strict
Configure nexthop
(conf-path)#10.10.21.2 strict
Configure nexthop
(conf)#rsvp-path sp1-r1-r3 mpls
Create RSVP path
(conf-path)#10.10.24.2 strict
Configure nexthop
(conf-path)#10.10.22.2 strict
Configure nexthop
(conf)#rsvp-path sp2-r1-r3 mpls
Create RSVP path
(conf-path)#10.10.25.2 strict
Configure nexthop
(conf-path)#10.10.29.2 strict
Configure nexthop
(conf)#rsvp-path sp3-r1-r3 mpls
Create RSVP path
(conf-path)#10.10.26.2 strict
Configure nexthop
(conf-path)#10.10.30.2 strict
Configure nexthop
(conf)#rsvp-path sp4-r1-r3 mpls
Create RSVP path
(conf-path)#10.10.27.2 strict
Configure nexthop
(conf-path)#10.10.31.2 strict
Configure nexthop
(conf)#rsvp-path sp5-r1-r3 mpls
Create RSVP path
(conf-path)#10.10.28.2 strict
Configure nexthop
(conf-path)#10.10.32.2 strict
Configure nexthop
(conf)#rsvp-trunk 47-49-test ipv4
Create a RSVP trunk link
(conf-trunk)#primary path p1-r1-r3
Configure primary path for trunk link
(conf-trunk)#secondary-priority 1 path sp1-r1-r3
Configure secondary link for trunk link
(conf-trunk)#secondary-priority 2 path sp2-r1-r3
Configure secondary link for trunk link
(conf-trunk)#secondary-priority 3 path sp3-r1-r3
Configure secondary link for trunk link
(conf-trunk)#secondary-priority 4 path sp4-r1-r3
Configure secondary link for trunk link
(conf-trunk)#secondary-priority 5 path sp5-r1-r3
Configure secondary link for trunk link
(conf-trunk)#to 49.49.49.49
Configure remote node for the LSP
(config-trunk)#commit
Commit the transaction.
OSPF configurations
 
#configure terminal
Enter configure mode.
(config)#router ospf 100
Configure the Routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#ospf router-id 47.47.47.47
Configure OSPF router-ID same as loopback interface IP address
(config-router)#network 10.10.23.0/24 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#network 10.10.24.0/24 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#network 10.10.25.0/24 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#network 10.10.26.0/24 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#network 10.10.27.0/24 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#network 10.10.28.0/24 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#network 47.47.47.47/32 area 0
Define the network on which OSPF runs and associate the area ID
(config-router) #commit
Commit the transaction.
 
Validation
This example shows the number of configured RSVP sessions in a router.
PE1
#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
 
Ingress RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
49.49.49.49 47.47.47.47 PRI 47-49-test-Primary UP 00:32:35 1 1 SE - 24961 DEFAULT
49.49.49.49 47.47.47.47 SEC 47-49-test-Secondary-Priority-1 UP 00:32:35 1 1 SE - 24962 DEFAULT
Total 2 displayed, Up 2, Down 0.
 
Egress RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
47.47.47.47 49.49.49.49 PRI 49-47-test-Primary UP 00:32:53 1 1 SE 24964 - ELSP_CON
47.47.47.47 49.49.49.49 PRI 49-47-test-Secondary-Priority-1 UP 00:32:47 1 1 SE 24962 - ELSP_CON
Total 2 displayed, Up 2, Down 0.
 
#show rsvp trunk multi-sec-detail
Ingress (Secondary-Priority1)
49.49.49.49
From: 47.47.47.47, LSPstate: Up, LSPname: 47-49-test-Secondary-Priority-1
Ingress FSM state: Operational
Establishment Time: 0s 253ms
Setup priority: 7, Hold priority: 0
CSPF usage: Enabled, CSPF Retry Count: 0, CSPF Retry Interval: 30 seconds
LSP Re-Optimization: Disabled, Re-Optimization Timer: NA, Cspf Client: OSPF
IGP-Shortcut: Disabled, LSP metric: 3
LSP Protection: None
Label in: -, Label out: 24962,
Tspec rate: 0, Fspec rate: 0
Policer: Not Configured
Tunnel Id: 5001, LSP Id: 2219, Ext-Tunnel Id: 47.47.47.47
Downstream: 47.46.3.2, vlan1.1003
Path refresh: 30 seconds (RR enabled) (due in 27970 seconds)
Resv lifetime: 157 seconds (due in 138 seconds)
Retry count: 0, intrvl: 30 seconds
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: none
Configured Path: SP1-47-49 (in use)
Configured Explicit Route Detail :
47.46.3.2/32 strict
46.45.9.2/32 strict
45.49.24.2/32 strict
Session Explicit Route Detail :
47.46.3.2/32 strict
46.45.9.2/32 strict
45.49.24.2/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
<self>
47.46.3.2
46.45.9.2
45.49.24.2
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 9216
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls
Ingress (Secondary-Priority2)
49.49.49.49
From: 47.47.47.47, LSPstate: Dn, LSPname: 47-49-test-Secondary-Priority-2
Ingress FSM state: Idle
Setup priority: 7, Hold priority: 0
CSPF usage: Enabled, CSPF Retry Count: 0, CSPF Retry Interval: 30 seconds
LSP Re-Optimization: Disabled, Re-Optimization Timer: NA, Cspf Client: NA
IGP-Shortcut: Disabled, LSP metric: 3
LSP Protection: None
Label in: -, Label out: -,
Tspec rate: 0, Fspec rate: 0
Policer: Not Configured
Tunnel Id: 5001, LSP Id: 2223, Ext-Tunnel Id: 47.47.47.47
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls
Ingress (Secondary-Priority3)
49.49.49.49
From: 47.47.47.47, LSPstate: Dn, LSPname: 47-49-test-Secondary-Priority-3
Ingress FSM state: Idle
Setup priority: 7, Hold priority: 0
CSPF usage: Enabled, CSPF Retry Count: 0, CSPF Retry Interval: 30 seconds
LSP Re-Optimization: Disabled, Re-Optimization Timer: NA, Cspf Client: NA
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: None
Label in: -, Label out: -,
Tspec rate: 0, Fspec rate: 0
Policer: Not Configured
Tunnel Id: 5001, LSP Id: 2219, Ext-Tunnel Id: 47.47.47.47
Last Recorded Error Code: Routing Problem (24)
Last Recorded Error Value: No route available toward destination (5)
Node where Last Recorded Error originated: None
Trunk Type: mpls
Ingress (Secondary-Priority4)
49.49.49.49
From: 47.47.47.47, LSPstate: Dn, LSPname: 47-49-test-Secondary-Priority-4
Ingress FSM state: Idle
Setup priority: 7, Hold priority: 0
CSPF usage: Enabled, CSPF Retry Count: 0, CSPF Retry Interval: 30 seconds
LSP Re-Optimization: Disabled, Re-Optimization Timer: NA, Cspf Client: NA
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: None
Label in: -, Label out: -,
Tspec rate: 0, Fspec rate: 0
Policer: Not Configured
Tunnel Id: 5001, LSP Id: 2219, Ext-Tunnel Id: 47.47.47.47
Last Recorded Error Code: Routing Problem (24)
Last Recorded Error Value: No route available toward destination (5)
Node where Last Recorded Error originated: None
Trunk Type: mpls
Ingress (Secondary-Priority5)
49.49.49.49
From: 47.47.47.47, LSPstate: Dn, LSPname: 47-49-test-Secondary-Priority-5
Ingress FSM state: Idle
Setup priority: 7, Hold priority: 0
CSPF usage: Enabled, CSPF Retry Count: 0, CSPF Retry Interval: 30 seconds
LSP Re-Optimization: Disabled, Re-Optimization Timer: NA, Cspf Client: NA
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: None
Label in: -, Label out: -,
Tspec rate: 0, Fspec rate: 0
Policer: Not Configured
Tunnel Id: 5001, LSP Id: 2219, Ext-Tunnel Id: 47.47.47.47
Last Recorded Error Code: Routing Problem (24)
Last Recorded Error Value: No route available toward destination (5)
Node where Last Recorded Error originated: None
Trunk Type: mpls
P Bridge Configuration
bridge 1 protocol ieee vlan-bridge
no bridge 1 spanning-tree enable bridge-forward
VLAN creation (Peer configuration for PE1)
vlan database
vlan 2-7 bridge 1 state enable
vlan 507-512 bridge 1 state enable
VLAN creation (Peer configuration for PE2)
vlan database
vlan 9-14 bridge 1 state enable
vlan 513-518 bridge 1 state enable
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode
(config-if)#ip address 46.46.46.46/32 secondary
Set the secondary IP address for the lo interface
(config-if)#exit
Exit interface mode.
(config)#router rsvp
Enable RSVP globally.
(config-router)#exit
Exit RSVP mode.
(config)#interface vlan1.2
Enter the interface mode.
(config-if)#ip address 10.10.23.2/24
Configure the IP Address
(config-if)#mtu 1600
Configure MTU size.
(config-if)#label-switching
Enable MPLS.
(config-if)#ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#enable-rsvp
Enable RSVP at the interface level.
(config-if)#exit
Exit the interface mode.
(config)#interface vlan1.3
Enter the interface mode.
(config-if)#ip address 10.10.24.2/24
Configure the IP Address
(config-if)#mtu 1600
Configure MTU size.
(config-if)#label-switching
Enable MPLS.
(config-if)#ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#enable-rsvp
Enable RSVP at the interface level.
(config-if)#exit
Exit the interface mode.
(config)#interface vlan1.4
Enter the interface mode.
(config-if)#ip address 10.10.25.2/24
Configure the IP Address
(config-if)#mtu 1600
Configure MTU size.
(config-if)#label-switching
Enable MPLS.
(config-if)#ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#enable-rsvp
Enable RSVP at the interface level.
(config-if)#exit
Exit the interface mode.
(config)#interface vlan1.5
Enter the interface mode.
(config-if)#ip address 10.10.26.2/24
Configure the IP Address
(config-if)#mtu 1600
Configure MTU size.
(config-if)#label-switching
Enable MPLS.
(config-if)#ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#enable-rsvp
Enable RSVP at the interface level.
(config-if)#exit
Exit the interface mode.
(config)#interface vlan1.6
Enter the interface mode.
(config-if)#ip address 10.10.27.2/24
Configure the IP Address
(config-if)#mtu 1600
Configure MTU size.
(config-if)#label-switching
Enable MPLS.
(config-if)#ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#enable-rsvp
Enable RSVP at the interface level.
(config-if)#exit
Exit the interface mode.
(config)#interface vlan1.7
Enter the interface mode.
(config-if)#ip address 10.10.28.2/24
Configure the IP Address
(config-if)#mtu 1600
Configure MTU size.
(config-if)#label-switching
Enable MPLS.
(config-if)#ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#enable-rsvp
Enable RSVP at the interface level.
(config-if)#exit
Exit the interface mode.
(config)#interface vlan1.9
Enter the interface mode.
(config-if)#ip address 10.10.21.1/24
Configure the IP Address
(config-if)#mtu 1600
Configure MTU size.
(config-if)#label-switching
Enable MPLS.
(config-if)#ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#enable-rsvp
Enable RSVP at the interface level.
(config-if)#exit
Exit the interface mode.
(config)#interface vlan1.10
Enter the interface mode.
(config-if)#ip address 10.10.22.1/24
Configure the IP Address
(config-if)#mtu 1600
Configure MTU size.
(config-if)#label-switching
Enable MPLS.
(config-if)#ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#enable-rsvp
Enable RSVP at the interface level.
(config-if)#exit
Exit the interface mode.
(config)#interface vlan1.11
Enter the interface mode.
(config-if)#ip address 10.10.29.1/24
Configure the IP Address
(config-if)#mtu 1600
Configure MTU size.
(config-if)#label-switching
Enable MPLS.
(config-if)#ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#enable-rsvp
Enable RSVP at the interface level.
(config-if)#exit
Exit the interface mode.
(config)#interface vlan1.12
Enter the interface mode.
(config-if)#ip address 10.10.30.1/24
Configure the IP Address
(config-if)#mtu 1600
Configure MTU size.
(config-if)#label-switching
Enable MPLS.
(config-if)#ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#enable-rsvp
Enable RSVP at the interface level.
(config-if)#exit
Exit the interface mode.
(config)#interface vlan1.13
Enter the interface mode.
(config-if)#ip address 10.10.31.1/24
Configure the IP Address
(config-if)#mtu 1600
Configure MTU size.
(config-if)#label-switching
Enable MPLS.
(config-if)#ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#enable-rsvp
Enable RSVP at the interface level.
(config-if)#exit
Exit the interface mode.
(config)#interface vlan1.14
Enter the interface mode.
(config-if)#ip address 10.10.32.1/24
Configure the IP Address
(config-if)#mtu 1600
Configure MTU size.
(config-if)#label-switching
Enable MPLS.
(config-if)#ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#enable-rsvp
Enable RSVP at the interface level.
(config-if)#exit
Exit the interface mode.
(config)#interface xe2
Enter the interface mode.
(config-if)#switchport
Configure Switchport
(config-if)#bridge-group 1
Assign a Bridge ID to the port channel
(config-if)#switchport mode trunk
Configure trunk
(config-if)#switchport trunk allowed vlan add 2,507
Configure allowed VLANs
(config-if)#switchport trunk native vlan 507
Configure native VLAN.
(config-if)#load-interval 30
Set load interval
(config-if)#mtu 9192
Configure the MTU Size.
(config-if)#exit
Exit the interface mode.
(config)#interface xe3
Enter the interface mode.
(config-if)#switchport
Configure Switchport
(config-if)#bridge-group 1
Assign a Bridge ID to the port channel
(config-if)#switchport mode trunk
Configure trunk
(config-if)#switchport trunk allowed vlan add 3,508
Configure allowed VLANs
(config-if)#switchport trunk native vlan 508
Configure native VLAN.
(config-if)#load-interval 30
Set load interval
(config-if)#mtu 9192
Configure the MTU Size.
(config-if)#exit
Exit the interface mode.
(config)#interface xe4
Enter the interface mode.
(config-if)#switchport
Configure Switchport
(config-if)#bridge-group 1
Assign a Bridge ID to the port channel
(config-if)#switchport mode trunk
Configure trunk
(config-if)#switchport trunk allowed vlan add 4,509
Configure allowed VLANs
(config-if)#switchport trunk native vlan 509
Configure native VLAN.
(config-if)#load-interval 30
Set load interval
(config-if)#mtu 9192
Configure the MTU Size.
(config-if)#exit
Exit the interface mode.
(config)#interface xe5
Enter the interface mode.
(config-if)#switchport
Configure Switchport
(config-if)#bridge-group 1
Assign a Bridge ID to the port channel
(config-if)#switchport mode trunk
Configure trunk
(config-if)#switchport trunk allowed vlan add 5,510
Configure allowed VLANs
(config-if)#switchport trunk native vlan 510
Configure native VLAN.
(config-if)#load-interval 30
Set load interval
(config-if)#mtu 9192
Configure the MTU Size.
(config-if)#exit
Exit the interface mode.
(config)#interface xe6
Enter the interface mode.
(config-if)#switchport
Configure Switchport
(config-if)#bridge-group 1
Assign a Bridge ID to the port channel
(config-if)#switchport mode trunk
Configure trunk
(config-if)#switchport trunk allowed vlan add 6,511
Configure allowed VLANs
(config-if)#switchport trunk native vlan 511
Configure native VLAN.
(config-if)#load-interval 30
Set load interval
(config-if)#mtu 9192
Configure the MTU Size.
(config-if)#exit
Exit the interface mode.
(config)#interface xe7
Enter the interface mode.
(config-if)#switchport
Configure Switchport
(config-if)#bridge-group 1
Assign a Bridge ID to the port channel
(config-if)#switchport mode trunk
Configure trunk
(config-if)#switchport trunk allowed vlan add 7,512
Configure allowed VLANs
(config-if)#switchport trunk native vlan 512
Configure native VLAN.
(config-if)#load-interval 30
Set load interval
(config-if)#mtu 9192
Configure the MTU Size.
(config-if)#exit
Exit the interface mode.
(config)#interface xe9
Enter the interface mode.
(config-if)#switchport
Configure Switchport
(config-if)#bridge-group 1
Assign a Bridge ID to the port channel
(config-if)#switchport mode trunk
Configure trunk
(config-if)#switchport trunk allowed vlan add 9,513
Configure allowed VLANs
(config-if)#switchport trunk native vlan 513
Configure native VLAN.
(config-if)#load-interval 30
Set load interval
(config-if)#mtu 9192
Configure the MTU Size.
(config-if)#exit
Exit the interface mode.
(config)#interface xe10
Enter the interface mode.
(config-if)#switchport
Configure Switchport
(config-if)#bridge-group 1
Assign a Bridge ID to the port channel
(config-if)#switchport mode trunk
Configure trunk
(config-if)#switchport trunk allowed vlan add 10,514
Configure allowed VLANs
(config-if)#switchport trunk native vlan 514
Configure native VLAN.
(config-if)#load-interval 30
Set load interval
(config-if)#mtu 9192
Configure the MTU Size.
(config-if)#exit
Exit the interface mode.
(config)#interface xe11
Enter the interface mode.
(config-if)#switchport
Configure Switchport
(config-if)#bridge-group 1
Assign a Bridge ID to the port channel
(config-if)#switchport mode trunk
Configure trunk
(config-if)#switchport trunk allowed vlan add 11,515
Configure allowed VLANs
(config-if)#switchport trunk native vlan 515
Configure native VLAN.
(config-if)#load-interval 30
Set load interval
(config-if)#mtu 9192
Configure the MTU Size.
(config-if)#exit
Exit the interface mode.
(config)#interface xe12
Enter the interface mode.
(config-if)#switchport
Configure Switchport
(config-if)#bridge-group 1
Assign a Bridge ID to the port channel
(config-if)#switchport mode trunk
Configure trunk
(config-if)#switchport trunk allowed vlan add 12,516
Configure allowed VLANs
(config-if)#switchport trunk native vlan 516
Configure native VLAN.
(config-if)#load-interval 30
Set load interval
(config-if)#mtu 9192
Configure the MTU Size.
(config-if)#exit
Exit the interface mode.
(config)#interface xe13
Enter the interface mode.
(config-if)#switchport
Configure Switchport
(config-if)#bridge-group 1
Assign a Bridge ID to the port channel
(config-if)#switchport mode trunk
Configure trunk
(config-if)#switchport trunk allowed vlan add 13,517
Configure allowed VLANs
(config-if)#switchport trunk native vlan 517
Configure native VLAN.
(config-if)#load-interval 30
Set load interval
(config-if)#mtu 9192
Configure the MTU Size.
(config-if)#exit
Exit the interface mode.
(config)#interface xe14
Enter the interface mode.
(config-if)#switchport
Configure Switchport
(config-if)#bridge-group 1
Assign a Bridge ID to the port channel
(config-if)#switchport mode trunk
Configure trunk
(config-if)#switchport trunk allowed vlan add 14,518
Configure allowed VLANs
(config-if)#switchport trunk native vlan 518
Configure native VLAN.
(config-if)#load-interval 30
Set load interval
(config-if)#mtu 9192
Configure the MTU Size.
(config-if)#commit
Commit the transaction.
OSPF configurations
 
#configure terminal
Enter configure mode.
(config)#router ospf 100
Configure the Routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#ospf router-id 46.46.46.46
Configure OSPF router-ID same as loopback interface IP address
(config-router)#network 10.10.21.0/24 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#network 10.10.22.0/24 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#network 10.10.23.0/24 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#network 10.10.24.0/24 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#network 10.10.25.0/24 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#network 10.10.26.0/24 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#network 10.10.27.0/24 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#network 10.10.28.0/24 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#network 10.10.29.0/24 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#network 10.10.30.0/24 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#network 10.10.31.0/24 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#network 10.10.32.0/24 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#network 46.46.46.46/32 area 0
Define the network on which OSPF runs and associate the area ID
(config-router) #commit
Commit the transaction.
PE2 Bridge Configuration
bridge 1 protocol ieee vlan-bridge
no bridge 1 spanning-tree enable bridge-forward
PE2 VLAN Creation
vlan database
vlan 9-14 bridge 1 state enable
vlan 519-524 bridge 1 state enable
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode
(config-if)#ip address 49.49.49.49/32 secondary
Set the secondary IP address for the lo interface
(config-if)#exit
Exit interface mode.
(config)#router rsvp
Enable RSVP globally.
(config-router)#exit
Exit RSVP mode.
(config)#interface vlan1.9
Enter the interface mode.
(config-if)#ip address 10.10.21.2/24
Configure the IP Address
(config-if)#mtu 1600
Configure MTU size.
(config-if)#label-switching
Enable MPLS.
(config-if)#ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#enable-rsvp
Enable RSVP at the interface level.
(config-if)#exit
Exit the interface mode.
(config)#interface vlan1.10
Enter the interface mode.
(config-if)#ip address 10.10.22.2/24
Configure the IP Address
(config-if)#mtu 1600
Configure MTU size.
(config-if)#label-switching
Enable MPLS.
(config-if)#ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#enable-rsvp
Enable RSVP at the interface level.
(config-if)#exit
Exit the interface mode.
(config)#interface vlan1.11
Enter the interface mode.
(config-if)#ip address 10.10.29.2/24
Configure the IP Address
(config-if)#mtu 1600
Configure MTU size.
(config-if)#label-switching
Enable MPLS.
(config-if)#ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#enable-rsvp
Enable RSVP at the interface level.
(config-if)#exit
Exit the interface mode.
(config)#interface vlan1.12
Enter the interface mode.
(config-if)#ip address 10.10.30.2/24
Configure the IP Address
(config-if)#mtu 1600
Configure MTU size.
(config-if)#label-switching
Enable MPLS.
(config-if)#ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#enable-rsvp
Enable RSVP at the interface level.
(config-if)#exit
Exit the interface mode.
(config)#interface vlan1.13
Enter the interface mode.
(config-if)#ip address 10.10.31.2/24
Configure the IP Address
(config-if)#mtu 1600
Configure MTU size.
(config-if)#label-switching
Enable MPLS.
(config-if)#ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#enable-rsvp
Enable RSVP at the interface level.
(config-if)#exit
Exit the interface mode.
(config)#interface vlan1.14
Enter the interface mode.
(config-if)#ip address 10.10.32.2/24
Configure the IP Address
(config-if)#mtu 1600
Configure MTU size.
(config-if)#label-switching
Enable MPLS.
(config-if)#ip ospf network point-to-point
Enable OSPF point-to-point network type.
(config-if)#enable-rsvp
Enable RSVP at the interface level.
(config-if)#exit
Exit the interface mode.
(config)#interface xe9
Enter the interface mode.
(config-if)#switchport
Configure Switchport
(config-if)#bridge-group 1
Assign a Bridge ID to the port channel
(config-if)#switchport mode trunk
Configure trunk
(config-if)#switchport trunk allowed vlan add 9,519
Configure allowed VLANs
(config-if)#switchport trunk native vlan 519
Configure native VLAN.
(config-if)#load-interval 30
Set load interval
(config-if)#mtu 9192
Configure the MTU Size.
(config-if)#exit
Exit the interface mode.
(config)#interface xe10
Enter the interface mode.
(config-if)#switchport
Configure Switchport
(config-if)#bridge-group 1
Assign a Bridge ID to the port channel
(config-if)#switchport mode trunk
Configure trunk
(config-if)#switchport trunk allowed vlan add 10,520
Configure allowed VLANs
(config-if)#switchport trunk native vlan 520
Configure native VLAN.
(config-if)#load-interval 30
Set load interval
(config-if)#mtu 9192
Configure the MTU Size.
(config-if)#exit
Exit the interface mode.
(config)#interface xe11
Enter the interface mode.
(config-if)#switchport
Configure Switchport
(config-if)#bridge-group 1
Assign a Bridge ID to the port channel
(config-if)#switchport mode trunk
Configure trunk
(config-if)#switchport trunk allowed vlan add 11,521
Configure allowed VLANs
(config-if)#switchport trunk native vlan 521
Configure native VLAN.
(config-if)#load-interval 30
Set load interval
(config-if)#mtu 9192
Configure the MTU Size.
(config-if)#exit
Exit the interface mode.
(config)#interface xe12
Enter the interface mode.
(config-if)#switchport
Configure Switchport
(config-if)#bridge-group 1
Assign a Bridge ID to the port channel
(config-if)#switchport mode trunk
Configure trunk
(config-if)#switchport trunk allowed vlan add 12,522
Configure allowed VLANs
(config-if)#switchport trunk native vlan 522
Configure native VLAN.
(config-if)#load-interval 30
Set load interval
(config-if)#mtu 9192
Configure the MTU Size.
(config-if)#exit
Exit the interface mode.
(config)#interface xe13
Enter the interface mode.
(config-if)#switchport
Configure Switchport
(config-if)#bridge-group 1
Assign a Bridge ID to the port channel
(config-if)#switchport mode trunk
Configure trunk
(config-if)#switchport trunk allowed vlan add 13,523
Configure allowed VLANs
(config-if)#switchport trunk native vlan 523
Configure native VLAN.
(config-if)#load-interval 30
Set load interval
(config-if)#mtu 9192
Configure the MTU Size.
(config-if)#exit
Exit the interface mode.
(config)#interface xe14
Enter the interface mode.
(config-if)#switchport
Configure Switchport
(config-if)#bridge-group 1
Assign a Bridge ID to the port channel
(config-if)#switchport mode trunk
Configure trunk
(config-if)#switchport trunk allowed vlan add 14,524
Configure allowed VLANs
(config-if)#switchport trunk native vlan 524
Configure native VLAN.
(config-if)#load-interval 30
Set load interval
(config-if)#mtu 9192
Configure the MTU Size.
(config-if)#exit
Exit the interface mode.
(conf)#rsvp-path sp1-r3-r1 mpls
Create RSVP path
(conf-path)#10.10.21.1 strict
Configure nexthop
(conf-path)#10.10.23.1 strict
Configure nexthop
(conf)#rsvp-path sp2-r3-r1 mpls
Create RSVP path
(conf-path)#10.10.22.1 strict
Configure nexthop
(conf-path)#10.10.24.1 strict
Configure nexthop
(conf)#rsvp-path sp2-r3-r1 mpls
Create RSVP path
(conf-path)#10.10.29.2 strict
Configure nexthop
(conf-path)#10.10.25.1 strict
Configure nexthop
(conf)#rsvp-path sp3-r3-r1 mpls
Create RSVP path
(conf-path)#10.10.30.1 strict
Configure nexthop
(conf-path)#10.10.26.1 strict
Configure nexthop
(conf)#rsvp-path sp4-r3-r1 mpls
Create RSVP path
(conf-path)#10.10.31.1 strict
Configure nexthop
(conf-path)#10.10.27.1 strict
Configure nexthop
(conf)#rsvp-path sp5-r3-r1 mpls
Create RSVP path
(conf-path)#10.10.32.1 strict
Configure nexthop
(conf-path)#10.10.28.1 strict
Configure nexthop
(conf)#rsvp-trunk 49-47-test ipv4
Create a RSVP trunk link
(conf-trunk)#primary path p1-r3-r1
Configure primary path for trunk link
(conf-trunk)#secondary-priority 1 path sp1-r3-r1
Configure secondary link for trunk link
(conf-trunk)#secondary-priority 2 path sp2-r3-r1
Configure secondary link for trunk link
(conf-trunk)#secondary-priority 3 path sp3-r3-r1
Configure secondary link for trunk link
(conf-trunk)#secondary-priority 4 path sp4-r3-r1
Configure secondary link for trunk link
(conf-trunk)#secondary-priority 5 path sp5-r3-r1
Configure secondary link for trunk link
(conf-trunk)#to 47.47.47.47
Configure remote node for the LSP
(conf-trunk)#commit
Commit the transaction.
OSPF configurations
 
#configure terminal
Enter configure mode.
(config)#router ospf 100
Configure the Routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
(config-router)#ospf router-id 49.49.49.49
Configure OSPF router-ID same as loopback interface IP address
(config-router)#network 10.10.21.0/24 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#network 10.10.22.0/24 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#network 10.10.29.0/24 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#network 10.10.30.0/24 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#network 10.10.31.0/24 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#network 10.10.32.0/24 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#network 49.49.49.49/32 area 0
Define the network on which OSPF runs and associate the area ID
(config-router) #commit
Commit the transaction.
Validation
This example shows the number of configured RSVP sessions in a router.
PE2
#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
 
Ingress RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
47.47.47.47 49.49.49.49 PRI 49-47-test-Primary UP 00:34:57 1 1 SE - 24970 DEFAULT
47.47.47.47 49.49.49.49 SEC 49-47-test-Secondary-Priority-1 UP 00:34:56 1 1 SE - 24968 DEFAULT
Total 2 displayed, Up 2, Down 0.
 
Egress RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
49.49.49.49 47.47.47.47 PRI 47-49-test-Primary UP 00:34:45 1 1 SE 31364 - ELSP_CON
49.49.49.49 47.47.47.47 PRI 47-49-test-Secondary-Priority-1 UP 00:34:44 1 1 SE 31360 - ELSP_CON
Total 2 displayed, Up 2, Down 0.
 
#show rsvp trunk multi-sec-detail
Ingress (Secondary-Priority1)
47.47.47.47
From: 49.49.49.49, LSPstate: Up, LSPname: 49-47-test-Secondary-Priority-1
Ingress FSM state: Operational
Establishment Time: 1s 71ms
Setup priority: 7, Hold priority: 0
CSPF usage: Enabled, CSPF Retry Count: 0, CSPF Retry Interval: 30 seconds
LSP Re-Optimization: Disabled, Re-Optimization Timer: NA, Cspf Client: OSPF
IGP-Shortcut: Disabled, LSP metric: 3
LSP Protection: None
Label in: -, Label out: 24968,
Tspec rate: 0, Fspec rate: 0
Policer: Not Configured
Tunnel Id: 5001, LSP Id: 2214, Ext-Tunnel Id: 49.49.49.49
Downstream: 45.49.24.1, vlan1.1024
Path refresh: 30 seconds (RR enabled) (due in 27829 seconds)
Resv lifetime: 157 seconds (due in 145 seconds)
Retry count: 0, intrvl: 30 seconds
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: none
Configured Path: SP1-49-47 (in use)
Configured Explicit Route Detail :
45.49.24.1/32 strict
46.45.9.1/32 strict
47.46.3.1/32 strict
Session Explicit Route Detail :
45.49.24.1/32 strict
46.45.9.1/32 strict
47.46.3.1/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
<self>
45.49.24.1
46.45.9.1
47.46.3.1
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 9216
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls
Ingress (Secondary-Priority2)
47.47.47.47
From: 49.49.49.49, LSPstate: Dn, LSPname: 49-47-test-Secondary-Priority-2
Ingress FSM state: Idle
Setup priority: 7, Hold priority: 0
CSPF usage: Enabled, CSPF Retry Count: 0, CSPF Retry Interval: 30 seconds
LSP Re-Optimization: Disabled, Re-Optimization Timer: NA, Cspf Client: NA
IGP-Shortcut: Disabled, LSP metric: 3
LSP Protection: None
Label in: -, Label out: -,
Tspec rate: 0, Fspec rate: 0
Policer: Not Configured
Tunnel Id: 5001, LSP Id: 2215, Ext-Tunnel Id: 49.49.49.49
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls
Ingress (Secondary-Priority3)
47.47.47.47
From: 49.49.49.49, LSPstate: Dn, LSPname: 49-47-test-Secondary-Priority-3
Ingress FSM state: Idle
Setup priority: 7, Hold priority: 0
CSPF usage: Enabled, CSPF Retry Count: 0, CSPF Retry Interval: 30 seconds
LSP Re-Optimization: Disabled, Re-Optimization Timer: NA, Cspf Client: NA
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: None
Label in: -, Label out: -,
Tspec rate: 0, Fspec rate: 0
Policer: Not Configured
Tunnel Id: 5001, LSP Id: 2213, Ext-Tunnel Id: 49.49.49.49
Last Recorded Error Code: Routing Problem (24)
Last Recorded Error Value: No route available toward destination (5)
Node where Last Recorded Error originated: None
Trunk Type: mpls
Ingress (Secondary-Priority4)
47.47.47.47
From: 49.49.49.49, LSPstate: Dn, LSPname: 49-47-test-Secondary-Priority-4
Ingress FSM state: Idle
Setup priority: 7, Hold priority: 0
CSPF usage: Enabled, CSPF Retry Count: 0, CSPF Retry Interval: 30 seconds
LSP Re-Optimization: Disabled, Re-Optimization Timer: NA, Cspf Client: NA
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: None
Label in: -, Label out: -,
Tspec rate: 0, Fspec rate: 0
Policer: Not Configured
Tunnel Id: 5001, LSP Id: 2213, Ext-Tunnel Id: 49.49.49.49
Last Recorded Error Code: Routing Problem (24)
Last Recorded Error Value: No route available toward destination (5)
Node where Last Recorded Error originated: None
Trunk Type: mpls
Ingress (Secondary-Priority5)
47.47.47.47
From: 49.49.49.49, LSPstate: Dn, LSPname: 49-47-test-Secondary-Priority-5
Ingress FSM state: Idle
Setup priority: 7, Hold priority: 0
CSPF usage: Enabled, CSPF Retry Count: 0, CSPF Retry Interval: 30 seconds
LSP Re-Optimization: Disabled, Re-Optimization Timer: NA, Cspf Client: NA
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: None
Label in: -, Label out: -,
Tspec rate: 0, Fspec rate: 0
Policer: Not Configured
Tunnel Id: 5001, LSP Id: 2213, Ext-Tunnel Id: 49.49.49.49
Last Recorded Error Code: Routing Problem (24)
Last Recorded Error Value: No route available toward destination (5)
Node where Last Recorded Error originated: None
Trunk Type: mpls
Add Administrative Group Constraints to an LSP
To add administrative group constraints (also known as color constraints) to an LSP:
Configure support for required administrative groups in NSM on all participating routers
Configure required administrative groups on all participating interfaces
The configuration in this example forces the primary LSP to be setup through links that belong either to administrative group A or C. A link that does not belong to either of these administrative groups will not be used for setting up the LSP.
Note: This example is based on the assumption that a minimal configuration exists on all participating routers as described in Enable Label Switching - Minimal Configuration.
PE1 - NSM
 
#configure terminal
Enter configure mode.
(config)#admin-group A 0
Add new administrative groups, specify their names and assign bit values to them.
(config)#admin-group B 1
(config)#admin-group C 2
(config)#admin-group D 3
(config)#admin-group E 4
(config)#interface xe0
Enter interface mode.
(config-if)#admin-group A
Add administrative groups to the links. When used in the interface mode, this command adds a link between an interface and a group. The name is the name of the group previously configured. You can have multiple groups per interface.
(config-if)#admin-group B
(config-if)#admin-group C
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#admin-group E
Add administrative groups to the links. When used in the interface mode, this command adds a link between an interface and a group. The name is the name of the group previously configured. You can have multiple groups per interface.
(config-if)#admin-group D
(config-if)#commit
Commit the transaction.
P - NSM
 
#configure terminal
Enter configure mode.
(config)#admin-group A 0
Add new administrative groups and specify their names and assign bit values to them.
(config)#admin-group C 2
(config)#interface xe2
Enter interface mode
(config-if)#admin-group A
Add administrative groups to the links. When used in the interface mode, this command adds a link between an interface and a group. The name is the name of the group previously configured. You can have multiple groups per interface.
(config-if)#admin-group C
(config-if)#commit
Commit the transaction.
PE1 - RSVP-TE
 
(config)#router rsvp
Enter the router mode for RSVP.
(config-router)#rsvp-path P1
Configure RSVP path.
#configure terminal
Enter configure mode.
(config)#rsvp-trunk T1
Create an RSVP trunk T1 and enter the Trunk mode.
(config-trunk)#no primary cspf
Since CSPF is enabled by default, specify no primary cspf if CSPF is not required.
(config-trunk)#primary path P1
Specify an RSVP primary path to be used.
(config-trunk)#no primary cspf
Specify the no primary cspf option for the LSP.
(config-trunk)#primary include-any A
Set up the LSP with admin group constraint A.
(config-trunk)#primary include-any C
Set up the LSP with admin group constraint C.
(config-trunk)#to 192.168.0.90
Specify the IPv4 egress (destination point) for the LSP.
(config-trunk)#commit
Commit the transaction.
Configure Global Parameters
Some common parameters can be configured in the Router mode on the RSVP-TE daemon. These parameters are global and affect all LSPs. In the following example the interval between two consecutive hello messages is set. The neighbor is defined by the neighbor command. Hello exchanges are enabled only between explicitly configured neighbors (configure this router as a neighbor on P (IP address 10.10.23.60).
Note: This example is based on the assumption that a minimal configuration exists on all participating routers as described in Enable Label Switching - Minimal Configuration.
PE1 - RSVP-TE
 
#configure terminal
Enter configure mode.
(config)#router rsvp
Enter the router mode for RSVP.
(config-router)#hello-interval 10
Set the hello-interval (in seconds) between hello packets.
(config-router)#hello-timeout 35
Set the hello-timeout value. If an LSR has not received a Hello message from a peer within this period, all sessions shared with this peer are reset.
(config-router)#neighbor 10.10.23.60
Explicitly specify the neighbor to exchange Hello messages with.
(config-router)#commit
Commit the transaction.
P - RSVP-TE
 
#configure terminal
Enter configure mode.
(config)#router rsvp
Enter the router mode for RSVP.
(config-router)#hello-interval 10
Set the hello-interval (in seconds) between hello packets.
(config-router)#hello-timeout 35
Set the hello-timeout value. If an LSR has not received a Hello message from a peer within this period, all sessions shared with this peer are reset.
(config-router)#neighbor 10.10.23.63
Explicitly specify the neighbor to exchange Hello messages with.
(config-router)#commit
Commit the transaction.
Fast Reroute Configuration (one-to-one method)
The Fast Reroute (FRR) configuration is a MPLS resiliency technology that provides fast traffic recovery when there is a link or router failure on mission critical services. These mechanisms enable the re-direction of traffic onto backup LSP tunnels in tens of milliseconds, in the event of a failure. The one-to-one backup method creates detour LSPs for each protected LSP at each potential point of local repair. This method is used to protect links and nodes during network failure.
In the below configurations each FRR trunk is mapped to VPWS,VPLS, and L3 VPN services.So it includes configurations of VPWS,VPLS and L3 VPN also.
Figure 6-13 is a simple topology example for FRR:
Topology Example for Fast Reroute
RTR-29
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 29.29.29.29/32 secondary
Set a secondary IP address of the interface
(config-if)#no shutdown
Administratively bring the interface up.
(config-if)#exit
Exit interface mode.
(config)#router-id 29.29.29.29
Configure the router ID.
(config)#router rsvp
Enter to router rsvp mode.
(config-router)#exit
Exit the router mode
(config)#router ldp
Enter to router LDP mode.
(config-router)#targeted-peer ipv4 30.30.30.30
Configure targeted peer.
(config-router-targeted-peer)#exit-targeted-peer-mode
Exit-targeted-peer-mode
(config-router)#exit
Exit router mode
(config)#interface xe21
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface.
(config-if)#ip address 21.21.21.29/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#enable-ldp ipv4
Enable LDP on this interface
(config-if)#exit
Exit interface mode.
(config)#interface xe22
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface
(config-if)#enable-ldp ipv4
Enable LDP on this interface
(config-if)#ip address 22.22.22.29/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf
Enter the router configure mode for OSPF.
(config-router)#router-id 29.29.29.29
Configure OSPF router-ID same as loopback interface IP address
(config-router)#network 21.21.21.0/24 area 0
(config-router)#network 22.22.22.0/24 area 0
(config-router)#network 29.29.29.29/32 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#exit
Exit the router configure mode.
(config)#rsvp-path p21
Enter the path mode for RSVP pt1.
(config-path)#21.21.21.43 strict
Configure this explicit route path as a strict hop.
(config-path)#38.38.38.42 strict
Configure this explicit route path as a strict hop.
(config-path)#69.69.69.30 strict
Configure this explicit route path as a strict hop.
(config)#exit
Exit the path mode.
(config)#rsvp-trunk to_30 ipv4
Enter the trunk mode for RSVP.
(config-trunk)#primary fast-reroute protection one-to-one
Configure primary fast-reroute protection facility for a trunk.
(config-trunk)#primary fast-reroute node-protection
Configure primary fast-reroute node protection for the trunk
(config-trunk)#primary path p21
Configure trunk to 30 to use the defined path.
(config-trunk)#to 30.30.30.30
Specify the IPv4 egress (destination point) for the LSP.
(config-trunk)#exit
Exit from trunk mode.
(config)#ip vrf vrf1
Configure VRF instance
(config-vrf)#rd 100:1
Configure Router Distinguisher value
(config-vrf)#route-target both 100:1
Configure route-target as both
(config-vrf)#exit
Exit the path mode.
(config)#interface xe43
Enter to the interface mode
(config-if)#ip vrf forwarding vrf1
Bind the VRF instance to the interface
(config-if)#ip address 43.43.43.29/24
Configure IP address
(config-if)#exit
Exit interface mode.
(config)#router bgp 100
Configure BGP router instance
(config-router)#neighbor 30.30.30.30 remote-as 100
Configure neighbor with remote-as
(config-router)#neighbor 30.30.30.30 update-source 29.29.29.29
Configure update source as loopback address
(config-router)#address-family vpnv4 unicast
Configure VPNv4 address family
(config-router-af)#neighbor 30.30.30.30 activate
Activate the VPN neighbor
(config-router-af)#exit-address-family
Exit the VPN address family
(config-router)#address-family ipv4 vrf vrf1
Configure VRF address family
(config-router-af)redistribute connected
Redistribute connected route
(config-router-af)exit-address-family
Exit VRF address family
(config-router)#exit
Exit router mode
(config)#mpls l2-circuit vlan10 10 30.30.30.30
Configure Virtual circuit.
(config-pseudowire)#exit
Exit pseudowire config mode.
(config)#service-template st1
Template configuration
(config-svc)#match outer-vlan 10
Match criteria under template configuration
(config-svc)#exit
Exit service template mode
(config)#service-template st2
Template configuration
(config-svc)#match outer-vlan 30
Match criteria under template configuration
(config-svc)#exit
Exit service template mode
(config)#interface xe44
Enter interface configuration mode
(config-if)#switchport
Configure interface as switch port
(config-if)#mpls-l2-circuit t1 service-template st1
Bind the interface to the VC with service template
(config-if)#exit
Exit interface configuration mode
(config)#mpls vpls vpls30 30
Configure VPLS instance
(config-vpls)#signaling ldp
Configure VPLS signaling as LDP
(config-vpls-sig)#vpls-type vlan
Configure VPLS type as VLAN encapsulation
(config-vpls-sig)#vpls-peer 30.30.30.30
Configure VPLS peer
(config-vpls-sig)#exit-signaling
Exit VPLS configuration mode
(config)#interface xe45
Enter interface configuration mode
(config-if)#switchport
Configure interface as switch port
(config-if)#mpls-vpls vpls30 service-template st2
Bind the VPLS instance to the interface
(config-if-vpls)#split-horizon group access1
Configure split-horizon group on VPLS
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#commit
Commit the transaction.
RTR-43
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 43.43.43.43/32 secondary
Set a secondary IP address of the interface
(config-if)#no shutdown
Administratively shutdown the interface.
(config-if)#exit
Exit interface mode.
(config)#router-id 43.43.43.43
Configure the router ID.
(config)#router rsvp
Enter to router RSVP mode.
(config-router)#exit
Exit the router mode
(config)#interface xe5/1
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface.
(config-if)#ip address 11.11.11.43/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe9/1
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface
(config-if)#ip address 21.21.21.43/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe9/2
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface.
(config-if)#ip address 22.22.22.43/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe13/2
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface
(config-if)#ip address 38.38.38.43/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf
Enter the router configure mode for OSPF.
(config-router)#router-id 43.43.43.43
Configure OSPF router-ID same as loopback interface IP address
(config-router)#network 11.11.11.0/24 area 0
(config-router)#network 22.22.22.0/24 area 0
(config-router)#network 21.21.21.0/24 area 0
(config-router)#network 38.38.38.0/24 area 0
(config-router)#network 43.43.43.43/32 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#commit
Commit the transaction.
RTR-42
 
(config)#interface lo
Enter interface mode.
(config-if)#ip address 42.42.42.42/32 secondary
Set a secondary IP address of the interface
(config-if)#no shutdown
Administratively shutdown the interface.
(config-if)#exit
Exit interface mode.
(config)#router-id 42.42.42.42
Configure the router ID.
(config)#router rsvp
Enter to router RSVP mode.
(config-router)#exit
Exit the router mode
(config)#interface xe2
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface.
(config-if)#ip address 5.5.5.42/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe10/1
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface
(config-if)#ip address 25.25.25.42/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe3
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface.
(config-if)#ip address 38.38.38.42/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe4
Enter interface mode
(config-if)#label-switching
Enable label switching on interface
(config-if)#ip address 69.69.69.42/24
Specify an IP address for the interface
(config-if)#no shutdown
Administratively no shutdown the interface
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface
(config-if)#exit
Exit interface mode
(config)#router ospf
Enter the router configure mode for OSPF.
(config-router)#router-id 42.42.42.42
Configure OSPF router-ID same as loopback interface IP address
(config-router)#network 5.5.5.0/24 area 0
(config-router)#network 25.25.25.0/24 area 0
(config-router)#network 69.69.69.0/24 area 0
(config-router)#network 38.38.38.0/24 area 0
(config-router)#network 42.42.42.42/32 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#commit
Commit the transaction
RTR-41
 
(config)#interface lo
Enter interface mode.
(config-if)#ip address 44.44.44.44/32 secondary
Set a secondary IP address of the interface
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#exit
Exit interface mode.
(config)#router-id 44.44.44.44
Configure the router ID.
(config)#router rsvp
Enter to router RSVP mode.
(config-router)#exit
Exit the router mode
(config)#interface xe1/1
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface.
(config-if)#ip address 1.1.1.41/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface
(config-if)#ip address 5.5.5.41/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe5/1
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface.
(config-if)#ip address 11.11.11.41/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf
Enter the router configure mode for OSPF.
(config-router)#router-id 44.44.44.44
Configure OSPF router-ID same as loopback interface IP address
(config-router)#network 5.5.5.0/24 area 0
(config-router)#network 1.1.1.0/24 area 0
(config-router)#network 11.11.11.0/24 area 0
(config-router)#network 44.44.44.44/32 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#commit
Commit the transaction.
RTR-31
 
(config)#interface lo
Enter interface mode.
(config-if)#ip address 31.31.31.31/32 secondary
Set a secondary IP address of the interface
(config-if)#no shutdown
Administratively shutdown the interface.
(config-if)#exit
Exit interface mode.
(config)#router-id 31.31.31.31
Configure the router ID.
(config)#router rsvp
Enter to router RSVP mode.
(config-router)#exit
Exit the router mode
(config)#interface xe1
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface.
(config-if)#ip address 1.1.1.31/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe25
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface
(config-if)#ip address 25.25.25.31/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe41
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface.
(config-if)#ip address 41.41.41.31/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf
Enter the router configure mode for OSPF.
(config-router)#router-id 31.31.31.31
Configure OSPF router-ID same as loopback interface IP address
(config-router)#network 1.1.1.0/24 area 0
(config-router)#network 25.25.25.0/24 area 0
(config-router)#network 41.41.41.0/24 area 0
(config-router)#network 31.31.31.31/32 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#commit
Commit the transaction.
RTR-30
 
(config)#interface lo
Enter interface mode.
(config-if)#ip address 30.30.30.30/32 secondary
Set a secondary IP address of the interface
(config-if)#no shutdown
Administratively shutdown the interface.
(config-if)#exit
Exit interface mode.
(config)#router-id 30.30.30.30
Configure the router ID.
(config)#router rsvp
Enter to router RSVP mode.
(config-router)#exit
Exit the router mode
(config)#router ldp
Enter to router LDP mode.
(config-router)#targeted-peer ipv4 29.29.29.29
Configure targeted peer.
(config-router-targeted-peer)#exit-targeted-peer-mode
Exit-targeted-peer-mode
(config-router)#exit
Exit router mode
(config)#interface xe41
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface.
(config-if)#ip address 41.41.41.30/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#enable-ldp ipv4
Enable LDP on this interface
(config-if)#exit
Exit interface mode.
(config)#interface xe54/1
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface
(config-if)#enable-ldp ipv4
Enable LDP on this interface
(config-if)#ip address 69.69.69.30/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf
Enter the router configure mode for OSPF.
(config-router)#router-id 30.30.30.30
Configure OSPF router-ID same as loopback interface IP address
(config-router)#network 41.41.41.0/24 area 0
(config-router)#network 69.69.69.0/24 area 0
(config-router)#network 30.30.30.30/32 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#commit
Commit the transaction.
(config)#rsvp-path p41
Enter the path mode for RSVP pt1.
(config-path)#41.41.41.31 strict
Configure this explicit route path as a strict hop.
(config-path)#1.1.1.41 strict
Configure this explicit route path as a strict hop.
(config-path)#11.11.11.43 strict
Configure this explicit route path as a strict hop.
(config)#exit
Exit the path mode.
(config)#rsvp-trunk to_29 ipv4
Enter the trunk mode for rsvp.
(config-trunk)#primary fast-reroute protection one-to-one
Configure primary fast-reroute protection facility for a trunk.
(config-trunk)#primary fast-reroute node-protection
Configure primary fast-reroute node protection for the trunk
(config-trunk)#primary path p41
Configure trunk to_29 to use the defined path.
(config-trunk)#to 29.29.29.29
Specify the IPv4 egress (destination point) for the LSP.
(config-trunk)#exit
Exit from trunk mode.
(config)#ip vrf vrf1
Configure VRF instance
(config-vrf)#rd 100:1
Configure Router Distinguisher value
(config-vrf)#route-target both 100:1
Configure route-target as both
(config-vrf)#exit
Exit the path mode.
(config)#interface xe23
Enter to the interface mode
(config-if)#ip vrf forwarding vrf1
Bind the VRF instance to the interface
(config-if)#ip address 23.23.23.29/24
Configure IP address
(config-if)#exit
Exit interface mode.
(config)#router bgp 100
Configure BGP router instance
(config-router)#neighbor 29.29.29.29 remote-as 100
Configure neighbor with remote-as
(config-router)#neighbor 29.29.29.29 update-source 30.30.30.30
Configure update source as loopback address
(config-router)#address-family vpnv4 unicast
Configure VPNv4 address family
(config-router-af)#neighbor 29.29.29.29 activate
Activate the VPN neighbor
(config-router-af)#exit-address-family
Exit the VPN address family
(config-router)#address-family ipv4 vrf vrf1
Configure VRF address family
(config-router-af)redistribute connected
Redistribute connected route
(config-router-af)exit-address-family
Exit VRF address family
(config-router)#exit
Exit router mode
(config)#mpls l2-circuit vlan10 10 29.29.29.29
Configure Virtual circuit.
(config-pseudowire)#exit
Exit pseudowire config mode.
(config)#service-template st1
Template configuration
(config-svc)#match outer-vlan 10
Match criteria under template configuration
(config-svc)#exit
Exit service template mode
(config)#service-template st2
Template configuration
(config-svc)#match outer-vlan 30
Match criteria under template configuration
(config-svc)#exit
Exit service template mode
(config)#interface xe24
Enter interface configuration mode
(config-if)#switchport
Configure interface as switch port
(config-if)#mpls-l2-circuit vlan10 service-template st1
Bind the interface to the VC with service template
(config-if)#exit
Exit interface configuration mode
(config)#mpls vpls vpls30 30
Configure VPLS instance
(config-vpls)#signaling ldp
Configure VPLS signaling as LDP
(config-vpls-sig)#vpls-type vlan
Configure VPLS type as VLAN encapsulation
(config-vpls-sig)#vpls-peer 29.29.29.29
Configure VPLS peer
(config-vpls-sig)#exit-signaling
Exit VPLS configuration mode
(config)#interface xe25
Enter interface configuration mode
(config-if)#switchport
Configure interface as switch port
(config-if)#mpls-vpls vpls30 service-template st2
Bind the VPLS instance to the interface
(config-if-vpls)#split-horizon group access1
Configure split-horizon group on VPLS
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#commit
Commit the transaction.
Validation
RTR-30#show rsvp session
Ingress RSVP:
To From State Pri Rt Style Labelin Labelout LSPName Uptime Est.time D
SType
29.29.29.29 30.30.30.30 Up Yes 1 1 SE - 24322 to_29-Primary 00:07:53 0s 118ms D
EFAULT
29.29.29.29 69.69.69.30 Up No 1 1 SE - 24322 to_29-Detour 00:07:53 0s 4ms DEF
AULT
Total 2 displayed, Up 2, Down 0.
 
Egress RSVP:
To From State Pri Rt Style Labelin Labelout LSPName Uptime Est.time D
SType
30.30.30.30 29.29.29.29 Up Yes 1 1 SE 24960 - to_30-Primary 00:07:57 N/A ELSP
_CON
30.30.30.30 25.25.25.42 Up Yes 1 1 SE 24961 - to_30-Detour 00:07:57 N/A ELSP
_CON
Total 2 displayed, Up 2, Down 0.
 
 
RTR-30#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf Nexthop
R(t)> 29.29.29.29/32 1 5001 Yes LSP_DEFAULT 24322 xe2 41.41.41.31
R(t)> 29.29.29.29/32 2 5001 No LSP_DEFAULT 24322 xe1 69.69.69.42
RTR-30#
 
RTR-30#show mpls vrf-table
Output for IPv4 VRF table with id: 2
Primary FTN entry with FEC: 43.43.43.0/24, id: 1, row status: Active
Owner: BGP, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 5001, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 7, in intf: - in label: 0 out-segment ix: 6
Owner: BGP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 6, owner: BGP, out intf: xe1, out label: 25602
Nexthop addr: 29.29.29.29 cross connect ix: 7, op code: Push and Lookup
 
 
Link 41.41.41.0/24 Goes down. Interface xe41 on router 30 is admistratively disabled with the "shutdown command".
 
RTR-30#
 
RTR-30#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
RTR-30(config)#int xe41
RTR-30(config-if)#shutdown
RTR-30(config-if)#
 
 
RTR-30#show rsvp session
Ingress RSVP:
To From State Pri Rt Style Labelin Labelout LSPName Uptime Est.time D
SType
29.29.29.29 30.30.30.30 Using Backup Yes 0 0 SE - - to_29-Primary N/A DEFAULT
29.29.29.29 30.30.30.30 Dn Yes 0 0 SE - - to_29-Primary N/A DEFAULT
29.29.29.29 69.69.69.30 Up No 1 1 SE - 24322 to_29-Detour 00:10:53 0s 4ms DEF
AULT
Total 3 displayed, Up 1, Down 2.
 
Egress RSVP:
To From State Pri Rt Style Labelin Labelout LSPName Uptime Est.time D
SType
30.30.30.30 29.29.29.29 Up Yes 1 1 SE 24960 - to_30-Primary 00:10:57 N/A ELSP
_CON
Total 1 displayed, Up 1, Down 0.
 
 
RTR-30#show mpls vc-table
VC-ID Vlan-ID Inner-Vlan-ID Access-Intf Network-Intf Out Label Tunnel-Label Nexthop Status
10 N/A N/A xe4 xe1 24321 24322 29.29.29.29 Active
RTR-30#
 
 
RTR-30#show mpls vpls mesh
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status
30 29.29.29.29 24322 24320 xe41 24320 2/Up 2 LDP Active
 
 
 
Link 41.41.41.0/24 is reestablished. Interfce xe41 is administrativly re-enabled.
 
 
RTR-30#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
RTR-30(config)#int xe41
RTR-30(config-if)#no shutdown
RTR-30(config-if)#
RTR-30#
 
 
RTR-30#show rsvp session
Ingress RSVP:
To From State Pri Rt Style Labelin Labelout LSPName Uptime Est.time D
SType
29.29.29.29 30.30.30.30 Up Yes 1 1 SE - 24322 to_29-Primary 00:00:01 0s 8ms DEF
AULT
29.29.29.29 69.69.69.30 Up No 1 1 SE - 24322 to_29-Detour 00:00:01 0s 8ms DEF
AULT
Total 2 displayed, Up 2, Down 0.
 
Egress RSVP:
To From State Pri Rt Style Labelin Labelout LSPName Uptime Est.time D
SType
30.30.30.30 29.29.29.29 Up Yes 1 1 SE 24960 - to_30-Primary 00:13:22 N/A ELSP
_CON
30.30.30.30 25.25.25.42 Up Yes 1 1 SE 24961 - to_30-Detour 00:00:08 N/A ELSP
_CON
Total 2 displayed, Up 2, Down 0.
 
 
RTR-30#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf Nexthop
R(t)> 29.29.29.29/32 1 5001 Yes LSP_DEFAULT 24322 xe41 41.41.41.31
R(t)> 29.29.29.29/32 2 5001 No LSP_DEFAULT 24322 xe54/1 69.69.69.42
 
Note: The primary LSP, which is in using backup state shall continue to use backup path in case where secondary is provisioned after the LSP state is changed to switch to backup.
MPLS RSVP PING and TRACEROUTE
This example shows MPLS ping and trace route for RSVP
#ping mpls rsvp tunnel-name to_30 detail
Sending 5 MPLS Echos to  to_30 , timeout is 5 seconds
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
Type 'Ctrl+C' to abort
! seq_num = 1 30.30.30.30 0.28 ms
! seq_num = 2 30.30.30.30 0.24 ms
! seq_num = 3 30.30.30.30 0.22 ms
! seq_num = 4 30.30.30.30 0.22 ms
! seq_num = 5 30.30.30.30 0.22 ms
 
Success Rate is 100.00 percent (5/5)
round-trip min/avg/max = 0.22/0.25/0.28
 
 
RTR-29#trace mpls rsvp tunnel-name to_30 detail
Tracing MPLS Label Switched Path to to_30 , timeout is 5 seconds
 
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
 
Type 'Ctrl+C' to abort
 
0 21.21.21.29 [Labels: 24320]
R 1 43.43.43.43 [Labels: 24320] 123.22 ms
R 2 42.42.42.42 [Labels: 24960] 1.60 ms
! 3 30.30.30.30 1.62 ms
MPLS RSVP Entropy Label Capabilities
To share the load across multiple members of a LAG port in the core of an MPLS network we can use entropy labels
An Entropy Label is always preceded by an Entropy level indicator which is a special Label with value seven, and indicates the next label present is an Entropy label. The trade off is the MPLS stack depth increases by two and it reduces overhead on transit routers.
Note: Load balancing is enabled by default for all the parameters. If you enable load balancing manually, then all the parameters enabled by default are reset and you need to enable the parameters based on which traffic should be load balanced.
Entropy labels will only be added when the remote edge node advertises its capability for Entropy.
The examples below show how entropy can be enabled on a provider edge node as per the setup we need to enable on RTR29 and RTR30 to have entropy enabled in both directions:
(config)#router rsvp
(config-router)#entropy-label-capability
 
This enables ELC signaling for RSVP.
For validation, use:
#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN, B - BGP FTN, K - CLI FTN, t - tunnel
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
Code FEC FTN-ID Tunnel-id Pri LSP-Type Out- Label ELC Out-Intf Nexthop
R(t)> 2 9.29.29.29/32 1 5001 Yes LSP_DEFAULT 24322 yes
xe2 1.41.41.31
R(t)> 29.29.29.29/32 2 5001 No LSP_DEFAULT 4322 yes
xe1 69.69.69.42
 
 
#show rsvp session ingress detail
Ingress (Primary)
41.41.41.31
From: 29.29.29.29, LSPstate: Up, LSPname: t1-Primary
Ingress FSM state: Operational
Establishment Time: 0s 3ms
Setup priority: 7, Hold priority: 0
CSPF usage: Enabled, CSPF Retry Count: 0, CSPF Retry Interval: 30 seconds
IGP-Shortcut: Disabled, LSP metric: 1
LSP Protection: None
Label in: -, Label out: 24320, ELC
MPLS RSVP LSP Re-optimization
Follow these steps to configure RSVP LSP Re-optimization.
 
#configure terminal
Enter configure mode.
(config)#rsvp-trunk T1
Create an RSVP trunk T1 and enter the Trunk mode.
(config-trunk)#reoptimize
Enable re-optimization of the session.
 
#configure terminal
Enter configure mode.
(config)#router rsvp
Enter RSVP mode
(config-router)#lsp-reoptimization-timer 5
Sets the re-optimization timer for the session.
 
Follow these steps to force the LSP to be re-optimized.
 
(config)#rsvp-trunk t1 force-reoptimize
Re-optimize the LSP forcefully