OcNOS-SP : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : RSVP-TE Facility Backup (Facility Bypass)
RSVP-TE Facility Backup (Facility Bypass)
RSVP supports multiple path protection mechanisms and facility backup is one of them. With facility backup protection, N number of LSPs sharing the common path can be protected using one bypass tunnel which leads to resource utilization.
Note: Do not configure a facility backup trunk with the same transit node as that of the primary trunk.
Topology
As shown in Figure 7-14, we have four routers R1, R2, R3, and R4.
RSVP facility backup
Configuration
PE1
 
#configure terminal
Enter configuration mode
(config)#interface lo
Specify interface loopback for configuration
(config-if)#ip address 1.1.1.1/32 secondary
Configure ip address of loopback
(config-if)#exit
Exit interface configuration mode
(config)#interface xe1
Specify interface xe1 for configuration
(config-if)#ip address 10.1.2.12/24
Configure ip address of interface
(config)#exit
Exit interface configuration mode
(config-if)#int xe5
Specify interface xe1 for configuration
(config-if)#ip address 10.1.4.14/24
Configure ip address of loopback
(config-if)#exit
Exit configuration mode
(config)#router ospf 1
Configure the router OSPF with process id
(config-router)#router-id 1.1.1.1
Configure OSPF router-id
(config-router)#network 1.1.1.1/32 area 1
Define the network of the interface with area 0
(config-router)#network 10.1.2.0/24 area 1
Define the network of the interface with area 0
(config-router)#network 10.1.4.0/24 area 1
Define the network of the interface with area 0
(config-router)#exit
Exit the configure mode
(config)#bfd interval 3 minrx 3 multiplier 3
Configure BFD interval
(config)#exit
Exit the configure mode
(config)#router ospf 1
Enter router OSPF mode with process id
(config-router)#bfd all-interfaces
Enable the OSPF enabled interfaces with bfd
(config-router)#exit
Exit the router mode
(config)#router rsvp
Enter router RSVP
(config-router)#exit
Exit the router configuration mode
(config)#interface xe1
Enter the interface mode
(config-if)#enable-rsvp
Enable RSVP
(config-if)#label-switching
Enable label-switching
(config-if)#exit
Exit the interface configuration mode
(config)#interface xe5
Enter the interface mode
(config-if)#enable-rsvp
Enable RSVP
(config-if)#label-switching
Enable label-switching
(config-if)#commit
Commit the transaction.
P1
 
(config)#interface lo
Specify the interface (lo)
(config-if)#ip address 2.2.2.2/32 secondary
Enter the loopback ip address as secondary
(config-if)#exit
Exit the interface configure mode
(config-if)#int xe1
Specify the interface(xe1)
(config-if)#ip address 10.1.2.21/24
Configure the IP address for the interface
(config-if)#exit
Exit the interface mode
(config-if)#int xe10
Specify the interface(xe1)
(config-if)#ip address 10.2.3.23/24
Configure the IP address for the interface
(config-if)#exit
Exit the configuration mode
(config)#router ospf 1
Configure OSPF router-id
(config-router)#router-id 2.2.2.2
Configure the router id
(config-router)#network 2.2.2.2/32 area 1
Define the network of the interface with area 0
(config-router)#network 10.1.2.0/24 area 1
Define the network of the interface with area 0
(config-router)#network 10.2.3.0/24 area 1
Define the network of the interface with area 0
(config-router)#exit
Exit the configure mode
(config)#bfd interval 3 minrx 3 multiplier 3
Configure BFD interval
(config)#exit
Exit the configure mode
(config)#router ospf 1
Enter router OSPF mode with process id
(config-router)#bfd all-interfaces
Enable the OSPF enabled interfaces with bfd
(config-router)#exit
Exit the router mode
(config)#router rsvp
Enter router RSVP
(config-router)#exit
Exit the router configuration mode
(config)#interface xe1
Enter the interface mode
(config-if)#enable-rsvp
Enable RSVP
(config-if)#label-switching
Enable label-switching
(config-if)#exit
Exit the interface configuration mode
(config)#interface xe10
Enter the interface mode
(config-if)#enable-rsvp
Enable RSVP
(config-if)#label-switching
Enable label-switching
(config-if)#commit
Commit the transaction.
P2
 
(config)#interface lo
Specify the interface (lo)
(config-if)#ip address 3.3.3.3/32 secondary
Enter the loopback ip address as secondary
(config-if)#exit
Exit the interface configuration mode
(config-if)#int xe10
Specify the interface(xe1)
(config-if)#ip address 10.2.3.32/24
Configure the IP address for the interface
(config-if)#exit
Exit the interface mode
(config-if)#interface xe5
Specify the interface(xe1)
(config-if)#ip address 10.3.4.34/24
Configure the IP address for the interface
(config-if)#exit
Exit the configuration mode
(config)#router ospf 1
Configure OSPF router-id
(config-router)#router-id 3.3.3.3
Configure the router id
(config-router)#network 3.3.3.3/32 area 1
Define the network of the interface with area 0
(config-router)#network 10.3.4.0/24 area 1
Define the network of the interface with area 0
(config-router)#network 10.2.3.0/24 area 1
Define the network of the interface with area 0
(config-router)#exit
Exit the configure mode
(config)#bfd interval 3 minrx 3 multiplier 3
Configure BFD interval
(config)#exit
Exit the configure mode
(config)#router ospf 1
Enter router OSPF mode with process id
(config-router)#bfd all-interfaces
Enable the OSPF enabled interfaces with bfd
(config-router)#exit
Exit the router mode
(config)#router rsvp
Enter router RSVP
(config-router)#exit
Exit the router configuration mode
(config)#interface xe10
Enter the interface mode
(config-if)#enable-rsvp
Enable RSVP
(config-if)#label-switching
Enable label-switching
(config-if)#exit
Exit the interface configuration mode
(config)#interface xe5
Enter the interface mode
(config-if)#enable-rsvp
Enable RSVP
(config-if)#label-switching
Enable label-switching
(config-if)#commit
Commit the transaction.
PE2
 
(config)#interface lo
Specify the interface (lo)
(config-if)#ip address 4.4.4.4/32 secondary
Enter the loopback IP address as secondary
(config-if)#exit
Exit the interface configuration mode
(config-if)#interface xe2
Specify the interface(xe1)
(config-if)#ip address 10.1.4.41/24
Configure the ip address for the interface
(config-if)#exit
Exit the interface mode
(config-if)#int xe5
Specify the interface(xe1)
(config-if)#ip address 10.3.4.43/24
Configure the ip address for the interface
(config-if)#exit
Exit the configuration mode
(config)#router ospf 1
Configure ospf router-id
(config-router)#router-id 4.4.4.4
Configure the router id
(config-router)#network 4.4.4.4/32 area 1
Define the network of the interface with area 0
(config-router)#network 10.1.4.0/24 area 1
Define the network of the interface with area 0
(config-router)#network 10.3.4.0/24 area 1
Define the network of the interface with area 0
(config-router)#exit
Exit the configure mode
(config)#bfd interval 3 minrx 3 multiplier 3
Configure BFD interval
(config)#exit
Exit the configuration mode
(config)#router ospf 1
Exit the router OSPF mode with process id
(config-router)#bfd all-interfaces
Enable the OSPF enabled interfaces with bfd
(config-router)#exit
Exit the router mode
(config)#router rsvp
Enter router RSVP
(config-router)#exit
Exit the router configuration mode
(config)#interface xe1
Enter the interface mode
(config-if)#enable-rsvp
Enable RSVP
(config-if)#label-switching
Enable label-switching
(config-if)#exit
Exit the interface configuration mode
(config)#interface xe5
Enter the interface mode
(config-if)#enable-rsvp
Enable RSVP
(config-if)#label-switching
Enable label-switching
(config-if)#commit
Commit the transaction.
RSVP Path on PE1
 
(config)#rsvp-path primary_1
Enter the rsvp-path configuration mode with name
(config-path)#10.1.2.21 strict
Specify the first next-hop ip address
(config-path)#10.2.3.32 strict
Specify the second next-hop ip address
(config-path)#exit
Exit the rsvp-path configuration mode
#configure terminal
Enter the configuration mode
(config)#rsvp-path bypass_1
Enter the rsvp-path configuration mode with name
(config-path)#10.1.4.41 strict
Specify the first next-hop ip address
(config-path)#10.3.4.34 strict
Specify the second next-hop ip address
(config-path)#exit
Exit the rsvp-path configuration mode
#configure terminal
Enter the configuration mode
(config)#rsvp-trunk R1-R3
Enter the rsvp trunk to be created with name
(config-trunk)#primary path primary_1
Configure primary path for the trunk
(config-trunk)#to 3.3.3.3
Enter the destination ip
(config-trunk)#primary fast-reroute protection facility
Configure facility backup protection for the trunk
(config-trunk)#exit
Exit the configuration mode
(config)#rsvp-bypass B1-B8
Enter the rsvp bypass to be created with name
(config-trunk)#path bypass_1
Configure primary path for the trunk
(config-trunk)#to 3.3.3.3
Enter the destination IP
(config-if)#commit
Commit the transaction.
Validation
OSPF Neighborship
PE1
#show ip ospf neighbor
 
Total number of full neighbors: 2
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
2.2.2.2 1 Full/Backup 00:00:38 10.1.2.21 xe1 0
4.4.4.4 1 Full/DR 00:00:33 10.1.4.41 xe5 0
P1
#show ip ospf neighbor
 
Total number of full neighbors: 2
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
1.1.1.1 1 Full/DR 00:00:35 10.1.2.12 xe1 0
3.3.3.3 1 Full/Backup 00:00:34 10.2.3.32 xe10 0
P2
#show ip ospf neighbor
 
Total number of full neighbors: 2
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
2.2.2.2 1 Full/DR 00:00:37 10.2.3.23 xe10 0
4.4.4.4 1 Full/Backup 00:00:39 10.3.4.43 xe5 0
PE2
#show ip ospf neighbor
 
Total number of full neighbors: 2
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
1.1.1.1 1 Full/Backup 00:00:38 10.1.4.14 xe2 0
3.3.3.3 1 Full/DR 00:00:36 10.3.4.34 xe5 0
RSVP Session
PE1
#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
 
Ingress RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
3.3.3.3 1.1.1.1 PRI R1-R3-Primary UP 00:54:48 1 1 SE - 24321 DEFAULT
3.3.3.3 1.1.1.1 BPS B1-B4-Bypass UP 01:08:32 1 1 SE - 24321 DEFAULT
Total 2 displayed, Up 2, Down 0.
#show rsvp bypass
Ingress RSVP:
To From LSPName State Uptime Rt Style Labelin Labelout DSType
3.3.3.3 1.1.1.1 B1-B4-Bypass UP 01:09:17 1 1 SE - 24321 DEFAULT
 
 
#show rsvp bypass protected-lsp-list
Bypass trunk: B1-B4
Bypass trunk bandwidth type: best-effort
List of LSP's Protected:
Tunnel-id Lsp Id Lsp Name Role Ext_tnl_id Ingress Egress
5001 2202 R1-R3-Primary Ingress 1.1.1.1 1.1.1.1 3.3.3.3
Total LSP protected : 1
Bandwidth in use : 0
 
 
#show rsvp bypass B1-B4 protected-lsp-list
Bypass trunk: B1-B4
Bypass trunk bandwidth type: best-effort
List of LSP's Protected:
Tunnel-id Lsp Id Lsp Name Role Ext_tnl_id Ingress Egress
5001 2202 R1-R3-Primary Ingress 1.1.1.1 1.1.1.1 3.3.3.3
Total LSP protected : 1
Bandwidth in use : 0
 
 
#show rsvp session detail
Ingress (Primary)
3.3.3.3
From: 1.1.1.1, LSPstate: Up, LSPname: R1-R3-Primary
Ingress FSM state: Operational
Establishment Time: 0s 8ms
Setup priority: 7, Hold priority: 0
CSPF usage: Enabled, CSPF Retry Count: 0, CSPF Retry Interval: 30 seconds
IGP-Shortcut: Disabled, LSP metric: 2
LSP Protection: facility
Fast-Reroute bandwidth : 0
Protection type desired: Link
Fast-Reroute Setup priority: 7, Hold priority: 0
Bypass trunk: B1-B4, Merge Point: 10.2.3.32, MP Label: 3
Bypass OutLabel: 24321, OutIntf: xe5
Protection provided -> Type: Link, BW: Best-effort
Label in: -, Label out: 24321
Tspec rate: 0, Fspec rate: 0
Policer: Not Configured
Tunnel Id: 5001, LSP Id: 2202, Ext-Tunnel Id: 1.1.1.1
Downstream: 10.1.2.21, xe1
Path refresh: 30 seconds (RR enabled) (due in 26564 seconds)
Resv refresh: 0 seconds (due in 0 seconds)
Resv lifetime: 157 seconds (due in 150 seconds)
Retry count: 0, intrvl: 30 seconds
RRO re-use as ERO: Disabled
Label Recording: Enabled
Admin Groups: none
Configured Path: primary_1 (in use)
Configured Explicit Route Detail :
10.1.2.21/32 strict
10.2.3.32/32 strict
Session Explicit Route Detail :
10.1.2.21/32 strict
10.2.3.32/32 strict
Record route:
LP = 1 -> PLR's Downstream link is protected PU = 1 -> Protection is in use on PLR
NP = 1 -> PLR's Downstream neighbor is protected BP = 1 -> BW protection available at PLR
-------------------------------------------------------------
IP Address Label (LP, PU, NP, BP)
-------------------------------------------------------------
<self>
10.1.2.21 24321 ( 0, 0, 0, 0)
10.2.3.32 3 ( 0, 0, 0, 0)
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls
Ingress (Bypass)
3.3.3.3
From: 1.1.1.1, LSPstate: Up, LSPname: B1-B4-Bypass
Ingress FSM state: Operational
Establishment Time: 0s 14ms
Setup priority: 7, Hold priority: 0
CSPF usage: Enabled, CSPF Retry Count: 0, CSPF Retry Interval: 30 seconds
IGP-Shortcut: Disabled, LSP metric: 2
LSP Protection: None
Bypass trunk bandwidth type: Best-effort
Label in: -, Label out: 24321
Tspec rate: 0, Fspec rate: 0
Policer: Not Configured
Tunnel Id: 5002, LSP Id: 2203, Ext-Tunnel Id: 1.1.1.1
Downstream: 10.1.4.41, xe5
Path refresh: 30 seconds (RR enabled) (due in 25747 seconds)
Resv lifetime: 157 seconds (due in 139 seconds)
Retry count: 0, intrvl: 30 seconds
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: none
Configured Path: bypass_1 (in use)
Configured Explicit Route Detail :
10.1.4.41/32 strict
10.3.4.34/32 strict
Session Explicit Route Detail :
10.1.4.41/32 strict
10.3.4.34/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
<self>
10.1.4.41
10.3.4.34
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls
Total LSP protected : 1, Bandwidth in use : 0
P1
#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
 
Transit RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
3.3.3.3 1.1.1.1 PRI R1-R3-Primary UP 00:57:44 1 1 SE 24321 3 ELSP_CON
Total 1 displayed, Up 1, Down 0.
 
#show rsvp session de
Transit
3.3.3.3
From: 1.1.1.1, LSPstate: Up, LSPname: R1-R3-Primary
Transit upstream state: Operational, downstream state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: facility
Fast-Reroute bandwidth : 0
Protection type desired: Link
Fast-Reroute Setup priority: 7, Hold priority: 0
Label in: 24321, Label out: 3
Tspec rate: 0, Fspec rate: 0
Tunnel Id: 5001, LSP Id: 2202, Ext-Tunnel Id: 1.1.1.1
Downstream: 10.2.3.32, xe10 Upstream: 10.1.2.12, xe1
Path refresh: 30 seconds (RR enabled) (due in 26500 seconds)
Path lifetime: 157 seconds (due in 126 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 20926 seconds)
Resv lifetime: 157 seconds (due in 151 seconds)
RRO re-use as ERO: Disabled
Label Recording: Enabled
Admin Groups: Received Explicit Route Detail :
10.1.2.21/32 strict
10.2.3.32/32 strict
Session Explicit Route Detail :
10.2.3.32/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
10.1.2.12 24321
<self>
10.2.3.32 3
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls
P2
#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
 
Egress RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
3.3.3.3 1.1.1.1 PRI R1-R3-Primary UP 00:58:47 1 1 SE 3 - ELSP_CON
3.3.3.3 1.1.1.1 PRI B1-B4-Bypass UP 01:12:30 1 1 SE 3 - ELSP_CON
Total 2 displayed, Up 2, Down 0
 
#show rsvp session detail
Egress
3.3.3.3
From: 1.1.1.1, LSPstate: Up, LSPname: R1-R3-Primary
Egress FSM state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: facility
Fast-Reroute bandwidth : 0
Protection type desired: Link
Fast-Reroute Setup priority: 7, Hold priority: 0
Label in: 3, Label out: -
Tspec rate: 0, Fspec rate: 0
Tunnel Id: 5001, LSP Id: 2202, Ext-Tunnel Id: 1.1.1.1
Upstream: 10.2.3.23, xe10
Path lifetime: 157 seconds (due in 140 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 37780 seconds)
RRO re-use as ERO: Disabled
Label Recording: Enabled
Admin Groups: Received Explicit Route Detail :
10.2.3.32/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
10.1.2.12 24321
10.2.3.23 3
<self>
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls
Egress
3.3.3.3
From: 1.1.1.1, LSPstate: Up, LSPname: B1-B4-Bypass
Egress FSM state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: None
Label in: 3, Label out: -
Tspec rate: 0, Fspec rate: 0
Tunnel Id: 5002, LSP Id: 2203, Ext-Tunnel Id: 1.1.1.1
Upstream: 10.3.4.43, xe5
Path lifetime: 157 seconds (due in 134 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 29222 seconds)
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: Received Explicit Route Detail :
10.3.4.34/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
10.1.4.14
10.3.4.43
<self>
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls.
PE2
#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
 
Transit RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
3.3.3.3 1.1.1.1 PRI B1-B4-Bypass UP 01:14:12 1 1 SE 24321 3 ELSP_CON
Total 1 displayed, Up 1, Down 0.
 
 
#show rsvp session detail
Transit
3.3.3.3
From: 1.1.1.1, LSPstate: Up, LSPname: B1-B4-Bypass
Transit upstream state: Operational, downstream state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: None
Label in: 24321, Label out: 3
Tspec rate: 0, Fspec rate: 0
Tunnel Id: 5002, LSP Id: 2203, Ext-Tunnel Id: 1.1.1.1
Downstream: 10.3.4.34, xe5 Upstream: 10.1.4.14, xe2
Path refresh: 30 seconds (RR enabled) (due in 25543 seconds)
Path lifetime: 157 seconds (due in 146 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 17729 seconds)
Resv lifetime: 157 seconds (due in 135 seconds)
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: Received Explicit Route Detail :
10.1.4.41/32 strict
10.3.4.34/32 strict
Session Explicit Route Detail :
10.3.4.34/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
10.1.4.14
<self>
10.3.4.34
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls
 
Limitations
Dedicated Bypass Bandwidth
Refer the topology defined above.
Suppose we have two primary tunnels P1 (100mbps) and P2(20mbps) ingressing from R1 and egressing at R3 (path R1->R2>R3) and asking for BW protection and we have two Bypass tunnels bp1 (120mbps) and bp2( 80mbps) type dedicated with same ingress and egress router taking Path R1->R4->R3. Below are the two cases defined in which we can observe different kinds of behavior.
1. Let the primary P1 and P2 come up.
CASE 1:
i) If the bypass bp1 (120mbps) comes up first it will give protection to both the primaries P1 and P2. bp2 should remain idle and will not give protection if there are no other primary tunnels asking for it.
CASE 2:
i) If the bypass bp2 (80mbps) comes up first it will give protection to only the primary P2 (20mbps) that will have satisfied protection which will not be changed until the bypass will go down.
ii) After that if bp1 (120mbps) comes it will provide protection to primary P1 (100mbps).
So in the CASE 1 after the protection has been provided to both the primary tunnels P1 and P2 by bypass bp1 if new primary tunnel P3 comes up with BW protection of 80mbps it would be given by bp2 (80mbps).
But in the CASE 2 as bp2 has only 60mbps left (20mbps is being used by P2) and it would not give protection to P3 tunnel and it will remain unprotected. To get the protection new tunnel has to have setup and hold priorities higher than other tunnels which are already been served with the bypass protection.
Secondary Tunnel
Suppose we have primary tunnel P1 (100mbps) ingressing from R1 and egressing at R3 (path R1->R2>R3) and asking for BW protection and we have Bypass tunnel bp1 (120mbps) type dedicated with same ingress and egress router taking Path R1->R4->R3. Then Bypass will start providing protection to primary P1.
If the primary went down it will start using the local protection.
After that if the secondary tunnel is provisioned, primary LSP, which is in using backup state shall continue to use backup path and will not shift over to secondary path.
Facility Bypass with Ring Topology Configuration
This section contains a complete Facility Bypass with Ring Topology configuration.
During facility bypass integration to OcNOS SP, few issues were reported when upstream and downstream interfaces of a session happens to be same (i.e. protection path is same as upstream path) and also CSPF most likely had some issues where LSP path used to formed by crossing the head node of the path.
Considering the information available in RSVP to impose restriction, bypass tunnel path crossing primary LSP node anywhere in between merge point were not considered for mapping.
Below assumption point was added in ERD and documents were updated on the line.
If protection is requested by primary session, then initial bypass matching criteria will be to ensure egress (merge point) node of bypass will be one of the nodes of primary LSP and bypass never intersect any node of primary LSP until the merge point.
The facility bypass method takes advantage of the MPLS label stack. Instead of creating a separate LSP for every backed-up LSP, a single LSP is created that serves to back up a set of LSPs. We call such an LSP tunnel a bypass tunnel. The bypass tunnel must intersect the path of the original LSP(s) somewhere downstream of the PLR. Naturally, this constrains the set of LSPs being backed up via that bypass tunnel to those that pass through some common downstream node. All LSPs that pass through the point of local repair and through this common node that do not also use the facilities involved in the bypass tunnel are candidates for this set of LSPs.
By multiple facility bypass tunnels, we mean that multiple facility bypass tunnels can be created to the same egress/MP. For a protected LSP there could be multiple candidates available. The mapping of the LSP to one of the backup tunnels has to be efficiently done so that we can extract the maximum benefit out of those backup tunnels available
Topology
Figure 7-15 displays a sample Facility Bypass with Ring topology.
Facility Bypass with Ring Topology
Configurations
All configuration commands in the table below should be followed for each router.
R1
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 1.1.1.1/32 secondary
Configure IP address for the loopback interface.
(config-if)#ip router isis ISIS-IGP
Enable IS-IS routing on an interface
(config-if)#exit
Exit interface mode.
(config)#bfd interval 3 minrx 3 multiplier
Configure BFD interval
(config)#router-id 1.1.1.1
Assigning router-id
(config)#router rsvp
Enter router mode for RSVP.
(config-router)#exit
Exit router configuration mode.
(config)#interface xe8
Specify the Interface to be configured.
(config-if)#ip address 10.1.1.1/24
Configure IP address for the interface.
(config-if)#no shutdown
Administratively bringing up the interface.
(config-if)#label-switching
Enable label switching on the interface
(config-if)#isis network point-to-point
Configure the ISIS interface network type as point to point
(config-if)#ip router isis ISIS-IGP
Enable IS-IS routing on an interface
(config-if)#enable-rsvp
Enable rsvp configuration on interface
(config-if)#exit
Exit interface mode.
(config)#interface xe20
Specify the Interface to be configured
(config-if)#ip address 12.1.1.1/24
Configure IP address for the interface.
(config-if)#no shutdown
Administratively bringing up the interface.
(config-if)#label-switching
Enable label switching on the interface
(config-if)#isis network point-to-point
Configure the ISIS interface network type as point to point
(config-if)#ip router isis ISIS-IGP
Enable IS-IS routing on an interface
(config-if)#enable-rsvp
Enable rsvp configuration on interface
(config-if)#exit
Exit interface mode.
(config)#router isis ISIS-IGP
Create an IS-IS routing instance
(config-router)#is-type level-1
Configure instance as level-1only routing.
(config-router)#metric-style wide
Configure the new style of metric type as wide.
(config-router)#mpls traffic-eng router-id 1.1.1.1
Configure MPLS-TE unique router-id TLV.
(config-router)#mpls traffic-eng level-1
Enable MPLS-TE in is-type Level-1
(config-router)#capability cspf
Enable CSPF feature for ISIS instance.
(config-router)#dynamic-hostname
Configure the hostname to be advertised for an ISIS instance
(config-router)#bfd all-interfaces
Enable BFD for all neighbors.
(config-router)#net 49.0000.0000.0001.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#exit
Exit router mode.
(config)#rsvp-path R1-R5-PRI-001
Create a rsvp path
(config-path)#10.1.1.2 strict
Configure this explicit router path as a strict hop
(config-path)#14.1.1.3 strict
Configure this explicit router path as a strict hop
(config-path)#17.1.1.3 strict
Configure this explicit router path as a strict hop
(config-path)#exit
Exit the rsvp-path mode
(config)#rsvp-path R1-R5-BPS-001
Create a rsvp path
(config-path)#12.1.1.2 strict
Configure this explicit router path as a strict hop
(config-path)#15.1.1.3 strict
Configure this explicit router path as a strict hop
(config-path)#exit
Exit the rsvp-path mode
(config)#rsvp-trunk R1-R5-PRI-001
Enter the trunk mode for RSVP
(config-trunk)#primary fast-reroute protection facility
Configure primary fast-reroute protection facility for a trunk.
(config-trunk)#primary fast-reroute node-protection
Configure primary fast-reroute node protection for a trunk.
(config-trunk)#primary path R1-R5-PRI-001
Configure trunk to use the defined path.
(config-trunk)#to 5.5.5.5
Specify the IPv4 egress (destination point) for the LSP
(config-path)#exit
Exit the rsvp-trunk mode
(config)#rsvp-bypass R1-R5-BPS-001
Enter the bypass mode for RSVP
(config-trunk)#path R1-R5-BPS-001
Configure path for bypass tunnel
(config-trunk)#to 5.5.5.5
Specify the IPv4 egress (destination point) for the LSP
(config-path)#exit
Exit the rsvp-bypass mode
(config)#commit
Commit the transaction.
R2
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 2.2.2.2/32 secondary
Configure IP address for the loopback interface.
(config-if)#ip router isis ISIS-IGP
Enable IS-IS routing on an interface
(config-if)#exit
Exit interface mode.
(config)#router-id 2.2.2.2
Assigning router-id
(config)#bfd interval 3 minrx 3 multiplier
Configure BFD interval
(config)#router rsvp
Enter router mode for RSVP.
(config-router)#exit
Exit router configuration mode.
(config)#interface xe29
Specify the Interface to be configured.
(config-if)#ip address 10.1.1.2/24
Configure IP address for the interface.
(config-if)#no shutdown
Administratively bringing up the interface.
(config-if)#label-switching
Enable label switching on the interface
(config-if)#isis network point-to-point
Configure the ISIS interface network type as point to point
(config-if)#ip router isis ISIS-IGP
Enable IS-IS routing on an interface
(config-if)#enable-rsvp
Enable rsvp configuration on interface
(config-if)#exit
Exit interface mode.
(config)#interface xe5
Specify the Interface to be configured
(config-if)#ip address 14.1.1.2/24
Configure IP address for the interface.
(config-if)#no shutdown
Administratively bringing up the interface.
(config-if)#label-switching
Enable label switching on the interface
(config-if)#isis network point-to-point
Configure the ISIS interface network type as point to point
(config-if)#ip router isis ISIS-IGP
Enable IS-IS routing on an interface
(config-if)#enable-rsvp
Enable rsvp configuration on interface
(config-if)#exit
Exit interface mode.
(config)#router isis ISIS-IGP
Create an IS-IS routing instance
(config-router)#is-type level-1
Configure instance as level-1only routing.
(config-router)#metric-style wide
Configure the new style of metric type as wide.
(config-router)#mpls traffic-eng router-id 2.2.2.2
Configure MPLS-TE unique router-id TLV.
(config-router)#mpls traffic-eng level-1
Enable MPLS-TE in is-type Level-1
(config-router)#capability cspf
Enable CSPF feature for ISIS instance.
(config-router)#dynamic-hostname
Configure the hostname to be advertised for an ISIS instance
(config-router)#bfd all-interfaces
Enable BFD for all neighbors.
(config-router)#net 49.0000.0000.0002.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#exit
Exit router mode.
(config)#commit
Commit the transaction.
R3
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 3.3.3.3/32 secondary
Configure IP address for the loopback interface.
(config-if)#ip router isis ISIS-IGP
Enable IS-IS routing on an interface
(config-if)#exit
Exit interface mode.
(config)#router-id 3.3.3.3
Assigning router-id
(config)#bfd interval 3 minrx 3 multiplier
Configure BFD interval
(config)#router rsvp
Enter router mode for RSVP.
(config-router)#exit
Exit router configuration mode.
(config)#interface xe7
Specify the Interface to be configured.
(config-if)#ip address 12.1.1.2/24
Configure IP address for the interface.
(config-if)#no shutdown
Administratively bringing up the interface.
(config-if)#label-switching
Enable label switching on the interface
(config-if)#isis network point-to-point
Configure the ISIS interface network type as point to point
(config-if)#ip router isis ISIS-IGP
Enable IS-IS routing on an interface
(config-if)#enable-rsvp
Enable rsvp configuration on interface
(config-if)#exit
Exit interface mode.
(config)#interface xe6
Specify the Interface to be configured
(config-if)#ip address 15.1.1.2/24
Configure IP address for the interface.
(config-if)#no shutdown
Administratively bringing up the interface.
(config-if)#label-switching
Enable label switching on the interface
(config-if)#isis network point-to-point
Configure the ISIS interface network type as point to point
(config-if)#ip router isis ISIS-IGP
Enable IS-IS routing on an interface
(config-if)#enable-rsvp
Enable rsvp configuration on interface
(config-if)#exit
Exit interface mode.
(config)#router isis ISIS-IGP
Create an IS-IS routing instance
(config-router)#is-type level-1
Configure instance as level-1only routing.
(config-router)#metric-style wide
Configure the new style of metric type as wide.
(config-router)#mpls traffic-eng router-id 3.3.3.3
Configure MPLS-TE unique router-id TLV.
(config-router)#mpls traffic-eng level-1
Enable MPLS-TE in is-type Level-1
(config-router)#capability cspf
Enable CSPF feature for ISIS instance.
(config-router)#dynamic-hostname
Configure the hostname to be advertised for an ISIS instance
(config-router)#bfd all-interfaces
Enable BFD for all neighbors.
(config-router)#net 49.0000.0000.0003.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#exit
Exit router mode.
(config)#commit
Commit the transaction.
R4
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 4.4.4.4/32 secondary
Configure IP address for the loopback interface.
(config-if)#ip router isis ISIS-IGP
Enable IS-IS routing on an interface
(config-if)#exit
Exit interface mode.
(config)#router-id 4.4.4.4
Assigning router-id
(config)#bfd interval 3 minrx 3 multiplier
Configure BFD interval
(config)#router rsvp
Enter router mode for RSVP.
(config-router)#exit
Exit router configuration mode.
(config)#interface xe4
Specify the Interface to be configured.
(config-if)#ip address 17.1.1.2/24
Configure IP address for the interface.
(config-if)#no shutdown
Administratively bringing up the interface.
(config-if)#label-switching
Enable label switching on the interface
(config-if)#isis network point-to-point
Configure the ISIS interface network type as point to point
(config-if)#ip router isis ISIS-IGP
Enable IS-IS routing on an interface
(config-if)#enable-rsvp
Enable rsvp configuration on interface
(config-if)#exit
Exit interface mode.
(config)#interface xe6
Specify the Interface to be configured
(config-if)#ip address 14.1.1.3/24
Configure IP address for the interface.
(config-if)#no shutdown
Administratively bringing up the interface.
(config-if)#label-switching
Enable label switching on the interface
(config-if)#isis network point-to-point
Configure the ISIS interface network type as point to point
(config-if)#ip router isis ISIS-IGP
Enable IS-IS routing on an interface
(config-if)#enable-rsvp
Enable rsvp configuration on interface
(config-if)#exit
Exit interface mode.
(config)#router isis ISIS-IGP
Create an IS-IS routing instance
(config-router)#is-type level-1
Configure instance as level-1only routing.
(config-router)#metric-style wide
Configure the new style of metric type as wide.
(config-router)#mpls traffic-eng router-id 4.4.4.4
Configure MPLS-TE unique router-id TLV.
(config-router)#mpls traffic-eng level-1
Enable MPLS-TE in is-type Level-1
(config-router)#capability cspf
Enable CSPF feature for ISIS instance.
(config-router)#dynamic-hostname
Configure the hostname to be advertised for an ISIS instance
(config-router)#bfd all-interfaces
Enable BFD for all neighbors.
(config-router)#net 49.0000.0000.0004.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#exit
Exit router mode.
(config)#commit
Commit the transaction.
R5
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 5.5.5.5/32 secondary
Configure IP address for the loopback interface.
(config-if)#ip router isis ISIS-IGP
Enable IS-IS routing on an interface
(config-if)#exit
Exit interface mode.
(config)#router-id 5.5.5.5
Assigning router-id
(config)#bfd interval 3 minrx 3 multiplier
Configure BFD interval
(config)#router rsvp
Enter router mode for RSVP.
(config-router)#exit
Exit router configuration mode.
(config)#interface xe12
Specify the Interface to be configured.
(config-if)#ip address 17.1.1.3/24
Configure IP address for the interface.
(config-if)#no shutdown
Administratively bringing up the interface.
(config-if)#label-switching
Enable label switching on the interface
(config-if)#isis network point-to-point
Configure the ISIS interface network type as point to point
(config-if)#ip router isis ISIS-IGP
Enable IS-IS routing on an interface
(config-if)#enable-rsvp
Enable rsvp configuration on interface
(config-if)#exit
Exit interface mode.
(config)#interface xe1
Specify the Interface to be configured
(config-if)#ip address 15.1.1.3/24
Configure IP address for the interface.
(config-if)#no shutdown
Administratively bringing up the interface.
(config-if)#label-switching
Enable label switching on the interface
(config-if)#isis network point-to-point
Configure the ISIS interface network type as point to point
(config-if)#ip router isis ISIS-IGP
Enable IS-IS routing on an interface
(config-if)#enable-rsvp
Enable rsvp configuration on interface
(config-if)#exit
Exit interface mode.
(config)#router isis ISIS-IGP
Create an IS-IS routing instance
(config-router)#is-type level-1
Configure instance as level-1only routing.
(config-router)#metric-style wide
Configure the new style of metric type as wide.
(config-router)#mpls traffic-eng router-id 5.5.5.5
Configure MPLS-TE unique router-id TLV.
(config-router)#mpls traffic-eng level-1
Enable MPLS-TE in is-type Level-1
(config-router)#capability cspf
Enable CSPF feature for ISIS instance.
(config-router)#dynamic-hostname
Configure the hostname to be advertised for an ISIS instance
(config-router)#bfd all-interfaces
Enable BFD for all neighbors.
(config-router)#net 49.0000.0000.0005.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#exit
Exit router mode.
(config)#commit
Commit the transaction.
Validation
RSVP Session
Validate that the RSVP Session is up.
R1:
R1#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
 
Ingress RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
5.5.5.5 1.1.1.1 PRI R1-R5-PRI-001-Primary UP 00:49:18 1 1 SE - 52480 DEFAULT
5.5.5.5 1.1.1.1 BPS R1-R5-BPS-001-Bypass UP 05:24:23 1 1 SE - 25600 DEFAULT
Total 2 displayed, Up 2, Down 0.
 
R1#show rsvp session detail
Ingress (Primary)
5.5.5.5
From: 1.1.1.1, LSPstate: Up, LSPname: R1-R5-PRI-001-Primary
Ingress FSM state: Operational
Establishment Time: 322s 925ms
Setup priority: 7, Hold priority: 0
CSPF usage: Enabled, CSPF Retry Count: 0, CSPF Retry Interval: 30 seconds
LSP Re-Optimization: Disabled, Re-Optimization Timer: NA, Cspf Client: ISIS
IGP-Shortcut: Disabled, LSP metric: 30
LSP Protection: facility
Fast-Reroute bandwidth : 0
Protection type desired: Node
Fast-Reroute Hop limit: 255
Fast-Reroute Setup priority: 7, Hold priority: 0
Bypass trunk: R1-R5-BPS-001, Merge Point: 17.1.1.3, MP Label: 25600
Bypass OutLabel: 25600, OutIntf: xe20
Protection provided -> Type: Node, BW: Best-effort
Label in: -, Label out: 52480,
Tspec rate: 0, Fspec rate: 0
Policer: Not Configured
Tunnel Id: 5001, LSP Id: 2201, Ext-Tunnel Id: 1.1.1.1
Bind value: 0, Oper state: NA, Alloc mode: NA
Downstream: 10.1.1.2, xe8
Path refresh: 30 seconds (RR enabled) (due in 27023 seconds)
Resv refresh: 0 seconds (due in 0 seconds)
Resv lifetime: 157 seconds (due in 128 seconds)
Retry count: 0, intrvl: 30 seconds
RRO re-use as ERO: Disabled
Label Recording: Enabled
Admin Groups: none
Configured Path: R1-R5-PRI-001 (in use)
Configured Explicit Route Detail :
10.1.1.2/32 strict
14.1.1.3/32 strict
17.1.1.3/32 strict
Session Explicit Route Detail :
10.1.1.2/32 strict
14.1.1.3/32 strict
17.1.1.3/32 strict
Record route:
LP = 1 -> PLR's Downstream link is protected PU = 1 -> Protection is in use on PLR
NP = 1 -> PLR's Downstream neighbor is protected BP = 1 -> BW protection available at PLR
-------------------------------------------------------------
IP Address Label (LP, PU, NP, BP)
-------------------------------------------------------------
<self>
10.1.1.2 52480 ( 0, 0, 0, 0)
14.1.1.3 52480 ( 0, 0, 0, 0)
17.1.1.3 25600 ( 0, 0, 0, 0)
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 9216
Recorded Time : N/A
Current Error:
Code : None, Value : None
Originated Node : None, Recorded Time : N/A
Last Signaled Error:
Code : None, Value : None
Originated Node : None, Recorded Time : N/A
Trunk Type: mpls
Ingress (Bypass)
5.5.5.5
From: 1.1.1.1, LSPstate: Up, LSPname: R1-R5-BPS-001-Bypass
Ingress FSM state: Operational
Establishment Time: 0s 4ms
Setup priority: 7, Hold priority: 0
CSPF usage: Enabled, CSPF Retry Count: 0, CSPF Retry Interval: 30 seconds
LSP Re-Optimization: Disabled, Re-Optimization Timer: NA, Cspf Client: ISIS
IGP-Shortcut: Disabled, LSP metric: 20
LSP Protection: None
Bypass trunk bandwidth type: Best-effort
Label in: -, Label out: 25600,
Tspec rate: 0, Fspec rate: 0
Policer: Not Configured
Tunnel Id: 5002, LSP Id: 2205, Ext-Tunnel Id: 1.1.1.1
Bind value: 0, Oper state: NA, Alloc mode: NA
Downstream: 12.1.1.2, xe20
Path refresh: 30 seconds (RR enabled) (due in 10514 seconds)
Resv lifetime: 157 seconds (due in 141 seconds)
Retry count: 0, intrvl: 30 seconds
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: none
Configured Path: R1-R5-BPS-001 (in use)
Configured Explicit Route Detail :
12.1.1.2/32 strict
15.1.1.3/32 strict
Session Explicit Route Detail :
12.1.1.2/32 strict
15.1.1.3/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
<self>
12.1.1.2
15.1.1.3
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 9216
Recorded Time : N/A
Current Error:
Code : None, Value : None
Originated Node : None, Recorded Time : N/A
Last Signaled Error:
Code : RSVP System error (23), Value : N/A (0)
Originated Node : 15.1.1.3, Recorded Time : 2023 May 16 08:52:51
Trunk Type: mpls
Total LSP protected : 1, Bandwidth in use : 0
R2:
R2#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
 
Transit RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
5.5.5.5 1.1.1.1 PRI R1-R5-PRI-001-Primary UP 00:49:59 1 1 SE 52480 52480 ELSP_CON
Total 1 displayed, Up 1, Down 0.
 
R2#show rsvp session detail
Transit
5.5.5.5
From: 1.1.1.1, LSPstate: Up, LSPname: R1-R5-PRI-001-Primary
Transit upstream state: Operational, downstream state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: facility
Fast-Reroute bandwidth : 0
Protection type desired: Node
Fast-Reroute Hop limit: 255
Fast-Reroute Setup priority: 7, Hold priority: 0
Label in: 52480, Label out: 52480,
Tspec rate: 0, Fspec rate: 0
Tunnel Id: 5001, LSP Id: 2201, Ext-Tunnel Id: 1.1.1.1
Bind value: 0, Oper state: NA, Alloc mode: NA
Downstream: 14.1.1.3, xe5 Upstream: 10.1.1.1, xe29
Path refresh: 30 seconds (RR enabled) (due in 27004 seconds)
Path lifetime: 157 seconds (due in 130 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 19943 seconds)
Resv lifetime: 157 seconds (due in 141 seconds)
RRO re-use as ERO: Disabled
Label Recording: Enabled
Admin Groups: Received Explicit Route Detail :
10.1.1.2/32 strict
14.1.1.3/32 strict
17.1.1.3/32 strict
Session Explicit Route Detail :
14.1.1.3/32 strict
17.1.1.3/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
10.1.1.1 52480
<self>
14.1.1.3 52480
17.1.1.3 25600
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 9216
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Current Error:
Code : None, Value : None
Originated Node : None, Recorded Time : N/A
Trunk Type: mpls
R3:
R3#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
 
Transit RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
5.5.5.5 1.1.1.1 PRI R1-R5-BPS-001-Bypass UP 05:25:48 1 1 SE 25600 3 ELSP_CON
Total 1 displayed, Up 1, Down 0.
 
R3#show rsvp session detail
Transit
5.5.5.5
From: 1.1.1.1, LSPstate: Up, LSPname: R1-R5-BPS-001-Bypass
Transit upstream state: Operational, downstream state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: None
Label in: 25600, Label out: 3,
Tspec rate: 0, Fspec rate: 0
Tunnel Id: 5002, LSP Id: 2205, Ext-Tunnel Id: 1.1.1.1
Bind value: 0, Oper state: NA, Alloc mode: NA
Downstream: 15.1.1.3, xe6 Upstream: 12.1.1.1, xe7
Path refresh: 30 seconds (RR enabled) (due in 10445 seconds)
Path lifetime: 157 seconds (due in 155 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 24008 seconds)
Resv lifetime: 157 seconds (due in 140 seconds)
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: Received Explicit Route Detail :
12.1.1.2/32 strict
15.1.1.3/32 strict
Session Explicit Route Detail :
15.1.1.3/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
12.1.1.1
<self>
15.1.1.3
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 9216
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Recorded Time : N/A
Current Error:
Code : None, Value : None
Originated Node : None, Recorded Time : N/A
Trunk Type: mpls
R3#
R4:
R4#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
 
Transit RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
5.5.5.5 1.1.1.1 PRI R1-R5-PRI-001-Primary UP 00:51:13 1 1 SE 52480 25600 ELSP_CON
Total 1 displayed, Up 1, Down 0.
 
R4#show rsvp session detail
Transit
5.5.5.5
From: 1.1.1.1, LSPstate: Up, LSPname: R1-R5-PRI-001-Primary
Transit upstream state: Operational, downstream state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: facility
Fast-Reroute bandwidth : 0
Protection type desired: Node
Fast-Reroute Hop limit: 255
Fast-Reroute Setup priority: 7, Hold priority: 0
Label in: 52480, Label out: 25600,
Tspec rate: 0, Fspec rate: 0
Tunnel Id: 5001, LSP Id: 2201, Ext-Tunnel Id: 1.1.1.1
Bind value: 0, Oper state: NA, Alloc mode: NA
Downstream: 17.1.1.3, xe4 Upstream: 14.1.1.2, xe6
Path refresh: 30 seconds (RR enabled) (due in 26908 seconds)
Path lifetime: 157 seconds (due in 148 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 37164 seconds)
Resv lifetime: 157 seconds (due in 144 seconds)
RRO re-use as ERO: Disabled
Label Recording: Enabled
Admin Groups: Received Explicit Route Detail :
14.1.1.3/32 strict
17.1.1.3/32 strict
Session Explicit Route Detail :
17.1.1.3/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
10.1.1.1 52480
14.1.1.2 52480
<self>
17.1.1.3 25600
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 9216
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Current Error:
Code : None, Value : None
Originated Node : None, Recorded Time : N/A
Trunk Type: mpls
R5:
R5#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
 
Egress RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
5.5.5.5 1.1.1.1 PRI R1-R5-PRI-001-Primary UP 00:51:45 1 1 SE 25600 - ELSP_CON
5.5.5.5 1.1.1.1 PRI R1-R5-BPS-001-Bypass UP 05:26:50 1 1 SE 3 - ELSP_CON
Total 2 displayed, Up 2, Down 0.
 
R5#show rsvp session detail
Egress
5.5.5.5
From: 1.1.1.1, LSPstate: Up, LSPname: R1-R5-PRI-001-Primary
Egress FSM state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: facility
Fast-Reroute bandwidth : 0
Protection type desired: Node
Fast-Reroute Hop limit: 255
Fast-Reroute Setup priority: 7, Hold priority: 0
Label in: 25600, Label out: -,
Tspec rate: 0, Fspec rate: 0
Tunnel Id: 5001, LSP Id: 2201, Ext-Tunnel Id: 1.1.1.1
Bind value: 0, Oper state: NA, Alloc mode: NA
Upstream: 17.1.1.2, xe12
Path lifetime: 157 seconds (due in 126 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 28434 seconds)
RRO re-use as ERO: Disabled
Label Recording: Enabled
Admin Groups: Received Explicit Route Detail :
17.1.1.3/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
10.1.1.1 52480
14.1.1.2 52480
17.1.1.2 25600
<self>
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 9216
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Recorded Time : N/A
Current Error:
Code : None, Value : None
Originated Node : None, Recorded Time : N/A
Trunk Type: mpls
Egress
5.5.5.5
From: 1.1.1.1, LSPstate: Up, LSPname: R1-R5-BPS-001-Bypass
Egress FSM state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: None
Label in: 3, Label out: -,
Tspec rate: 0, Fspec rate: 0
Tunnel Id: 5002, LSP Id: 2205, Ext-Tunnel Id: 1.1.1.1
Bind value: 0, Oper state: NA, Alloc mode: NA
Upstream: 15.1.1.2, xe1
Path lifetime: 157 seconds (due in 141 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 927 seconds)
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: Received Explicit Route Detail :
15.1.1.3/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
12.1.1.1
15.1.1.2
<self>
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 9216
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Recorded Time : N/A
Current Error:
Code : None, Value : None
Originated Node : None, Recorded Time : N/A
Trunk Type: mpls
RSVP Bypass
Validate that the RSVP bypass session is up.
R1:
R1#show rsvp bypass
Ingress RSVP:
To From LSPName State Uptime Rt Style Labelin Labelout DSType
5.5.5.5 1.1.1.1 R1-R5-BPS-001-Bypass UP 05:27:41 1 1 SE - 25600 DEFAULT
To validate RSVP bypass session details:
R1#show rsvp bypass detail
Ingress (Bypass)
5.5.5.5
From: 1.1.1.1, LSPstate: Up, LSPname: R1-R5-BPS-001-Bypass
Ingress FSM state: Operational
Establishment Time: 0s 4ms
Setup priority: 7, Hold priority: 0
CSPF usage: Enabled, CSPF Retry Count: 0, CSPF Retry Interval: 30 seconds
LSP Re-Optimization: Disabled, Re-Optimization Timer: NA, Cspf Client: ISIS
IGP-Shortcut: Disabled, LSP metric: 20
LSP Protection: None
Bypass trunk bandwidth type: Best-effort
Label in: -, Label out: 25600,
Tspec rate: 0, Fspec rate: 0
Policer: Not Configured
Tunnel Id: 5002, LSP Id: 2205, Ext-Tunnel Id: 1.1.1.1
Bind value: 0, Oper state: NA, Alloc mode: NA
Downstream: 12.1.1.2, xe20
Path refresh: 30 seconds (RR enabled) (due in 10319 seconds)
Resv lifetime: 157 seconds (due in 126 seconds)
Retry count: 0, intrvl: 30 seconds
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: none
Configured Path: R1-R5-BPS-001 (in use)
Configured Explicit Route Detail :
12.1.1.2/32 strict
15.1.1.3/32 strict
Session Explicit Route Detail :
12.1.1.2/32 strict
15.1.1.3/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
<self>
12.1.1.2
15.1.1.3
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 9216
Recorded Time : N/A
Current Error:
Code : None, Value : None
Originated Node : None, Recorded Time : N/A
Last Signaled Error:
Code : RSVP System error (23), Value : N/A (0)
Originated Node : 15.1.1.3, Recorded Time : 2023 May 16 08:52:51
Trunk Type: mpls
Total LSP protected : 1, Bandwidth in use : 0
To validate RSVP bypass Protected-lsp-list:
R1#show rsvp bypass protected-lsp-list
Bypass trunk: R1-R5-BPS-001
Bypass trunk bandwidth type: best-effort
List of LSP's Protected:
Tunnel-id Lsp Id Lsp Name Role Ext_tnl_id Ingress Egress
5001 2201 R1-R5-PRI-001-Primary Ingress 1.1.1.1 1.1.1.1 5.5.5.5
Total LSP protected : 1
Bandwidth in use : 0