OcNOS-SP : Segment Routing Guide : Path Computation Element Communication Protocol Configuration Guide : BGP Link State with ISIS Segment Routing
BGP Link State with ISIS Segment Routing
This chapter shows configuration of BGP link state with ISIS segment routing.
Overview
Segment Routing (SR) allows a head end node to steer a packet flow along any path. Intermediate per-flow states are eliminated due to source routing. The head end node is said to steer a flow into a Segment Routing Policy (SR Policy). The header of a packet steered in an SR Policy is augmented with the ordered list of segments associated with that SR Policy. This feature is supported for MPLS instantiations.
BGP-LS describes a mechanism by which Link-State (LS) and Traffic Engineering (TE) information from IGPs can be collected from networks and shared with external components using the BGP. This is achieved using a new BGP Network Layer Reachability Information (NLRI) encoding format. The mechanism is applicable to physical and virtual links. Applications of this technique include Path Computation Elements (PCEs). These components, while external to the network, require network state information on a real time basis. Specifically, they require link-state database information of each IGP node from the entire network. BGP protocol is used to collect the necessary information and to share with the external components and this is achieved using a NLRI encoding format.
An NLRI is defined to advertise SR Policy to the headend of that policy. New sub-TLVs for the Tunnel Encapsulation Attribute are defined to carry SR related information.
Note: We recommended using prefix-sid index, when have different SRGB configured on different routers there is very high chance that absolute value may lie outside SRGB and MPLS entries may not get installed, so we should use "prefix-sid index".
Topology
Figure 2-4 shows 6 routers and 1 controller. R1, R2, R3, and R4 belong to AS-100 and R5 and R6 belongs to AS-200, Controller belongs to AS-300 R1 and R2 has an iBGP (BGP-LS) session with R3. R3 and R5 have an eBGP session with the controller with BGP-LS.
ISIS segment routing with BGP link state
Configuration
R1: Interface
 
R1#configure terminal
Enter configure mode
R1(config)#hostname R1
Configure hostname
R1(config)#interface lo
Enter interface mode for loopback interface.
R1(config-if)#ip address 1.1.1.1/32 secondary
Configure IPv4 address.
R1(config-if)#ip router isis 1
Configure Router-isis.
R1(config-if)#prefix-sid index 100
Configure Prefix-sid
R1(config-if)#exit
Exit interface mode
R1(config)#interface xe2
Enter interface mode for xe2 interface.
R1(config-if)#ip address 10.1.1.1/24
Configure IPv4 address.
R1(config-if)# label-switching
Enable label switching
R1(config-if)#ip router isis 1
Configure Router-isis.
R1(config-if)#exit
Exit interface mode
R1: ISIS
 
R1(config)#router isis 1
Enter ISIS router mode
R1(config-router)#is-type level-1
Configure IS-type.
R1(config-router)#metric-style wide
Configure Metric-style.
R1(config-router)#mpls traffic-eng router-id 1.1.1.1
Configure MPLS TE router-id.
R1(config-router)#mpls traffic-eng level-1
Configure MPLS TE Level-1.
R1(config-router)#isis segment-routing global block 18000 20999
Configure SRGB range.
R1(config-router)#segment-routing mpls
Enabling Segment-Routing.
R1(config-router)#net 49.0000.0000.0000.0001.00
Configure net-id.
R1(config-router)#distribute bgp-ls
Distributing BGP-LS.
R1(config-router)#exit
Exit ISIS router mode
R1: BGP
 
R1(config)#router bgp 100
Enter BGP router mode
R1(config)#bgp router-id 1.1.1.1
Configure BGP router-id
R1(config-router)#neighbor 3.3.3.3 remote-as 100
Configure neighbor with remote-as.
R1(config-router)#neighbor 3.3.3.3 update-source lo
Configure neighbor with update-source.
R1(config-router)#address-family link-state link-state
Entering link-state link-state address family.
R1(config-router-af)#neighbor 3.3.3.3 activate
Activating Neighbor in link-state link-state address family.
R1(config-router)#exit
Exit BGP router mode
R2: Interface
 
R2#configure terminal
Enter configure mode
R2(config)#hostname R2
Configure hostname
R2(config)#interface lo
Enter interface mode for loopback interface.
R2(config-if)#ip address 2.2.2.2/32 secondary
Configure IPv4 address.
R2(config-if)#ip router isis 1
Configure Router-isis.
R2(config-if)#prefix-sid index 400
Configure Prefix-sid
R2(config-if)#exit
Exit interface mode
R2(config)#interface xe7
Enter interface mode for xe7 interface.
R2(config-if)#ip address 20.1.1.1/24
Configure IPv4 address.
R2(config-if)#label-switching
Enable lable switching
R2(config-if)#ip router isis 1
Configure Router-isis.
R2(config-if)#exit
Exit interface mode
R2: ISIS
 
R2(config)#router isis 1
Enter ISIS router mode
R2(config-router)#is-type level-2
Configure IS-type.
R2(config-router)#metric-style wide
Configure Metric-style.
R2(config-router)#mpls traffic-eng router-id 2.2.2.2
Configure MPLS TE router-id.
R2(config-router)#mpls traffic-eng level-2
Configure MPLS TE Level-2.
R2(config-router)#isis segment-routing global block 19000 21999
Configure SRGB range
R2(config-router)#segment-routing mpls
Enabling Segment-Routing.
R2(config-router)#net 49.0001.0000.0000.0002.00
Configure net-id.
R2(config-router)#distribute bgp-ls
Distributing BGP-LS.
R2(config-router)#exit
Exit ISIS router mode
R2: BGP
 
R2(config)#router bgp 100
Enter BGP router mode
R2(config)#bgp router-id 2.2.2.2
Configure BGP router-id
R2(config-router)#neighbor 3.3.3.3 remote-as 100
Configure neighbor with remote-as.
R2(config-router)#neighbor 3.3.3.3 update-source lo
Configure neighbor with update-source.
R2(config-router)#address-family link-state link-state
Entering link-state link-state address family.
R2(config-router-af)#neighbor 3.3.3.3 activate
Activating Neighbor in link-state link-state address family.
R2(config-router)#exit
Exit BGP router mode
R3: Interface
 
R3#configure terminal
Enter configure mode
R3(config)#hostname R3
Configure hostname
R3(config)#interface lo
Enter interface mode for loopback interface.
R3(config-if)#ip address 3.3.3.3/32 secondary
Configure IPv4 address.
R3(config-if)#ip router isis 1
Configure Router-isis.
R3(config-if)#prefix-sid index 300
Configure Prefix-sid
R3(config-if)#exit
Exit interface mode
R3(config)#interface xe2
Enter interface mode for xe2 interface.
R3(config-if)#ip address 10.1.1.2/24
Configure IPv4 address.
R3(config-if)#ip router isis 1
Configure Router-isis.
R3(config-if)# label-switching
Enable label switching
R3(config-if)#exit
Exit interface mode
R3(config)#interface xe7
Enter interface mode for xe7 interface.
R3(config-if)#ip address 20.1.1.2/24
Configure IPv4 address.
R3(config-if)#ip router isis 1
Configure Router-isis.
R3(config-if)# label-switching
Enable label switching
R3(config-if)#exit
Exit interface mode
R3(config)#interface xe12
Enter interface mode for xe12 interface.
R3(config-if)#ip address 30.1.1.1/24
Configure IPv4 address.
R3(config-if)# label-switching
Enable label switching
R3(config-if)#ip router isis 1
Configure Router-isis.
R3(config-if)#exit
Exit interface mode
R3(config)#interface xe4
Enter interface mode for xe4 interface.
R3(config-if)#ip address 40.1.1.1/24
Configure IPv4 address.
R3(config-if)# label-switching
Enable label switching
R3(config-if)#exit
Exit interface mode
R3: ISIS
 
R3(config)#router isis 1
Enter ISIS router mode
R3(config-router)#is-type level-1-2
Configure IS-type.
R3(config-router)#metric-style wide
Configure Metric-style.
R3(config-router)#mpls traffic-eng router-id 3.3.3.3
Configure MPLS TE router-id.
R3(config-router)#mpls traffic-eng level-1
Configure MPLS TE Level-1.
R3(config-router)#mpls traffic-eng level-2
Configure MPLS TE Level-2.
R3(config-router)#isis segment-routing global block 17500 22300
Configure SRGB range.
R3(config-router)#segment-routing mpls
Enabling Segment-Routing.
R3(config-router)#net 49.0000.0000.0000.0003.00
Configure net-id.
R3(config-router)#distribute bgp-ls
Distributing BGP-LS.
R3(config-router)#exit
Exit from router isis mode.
R3: BGP
 
R3(config)#router bgp 100
Enter BGP router mode
R3(config)#bgp router-id 3.3.3.3
Configure BGP router-id
R3(config-router)#neighbor 1.1.1.1 remote-as 100
Configure neighbor with remote-as.
R3(config-router)#neighbor 1.1.1.1 update-source lo
Configure neighbor with update-source.
R3(config-router)#neighbor 2.2.2.2 remote-as 100
Configure neighbor with remote-as.
R3(config-router)#neighbor 2.2.2.2 update-source lo
Configure neighbor with update-source.
R3(config-router)#address-family link-state link-state
Entering link-state link-state address family.
R3(config-router-af)#neighbor 1.1.1.1 activate
Activating Neighbor in link-state link-state address family.
R3(config-router-af)#neighbor 2.2.2.2 activate
Activating Neighbor in link-state link-state address family.
R3(config-router-af)#exit
Exit from BGP address family mode
R3(config-router#exit
Exit from bgp router mode
R3(config)#router bgp 100
Enter BGP router mode
R3(config-router)#neighbor 40.1.1.2 remote-as 300
Configure neighbor with remote-as.
R3(config-router)#address-family link-state link-state
Entering link-state link-state address family.
R3(config-router-af)#neighbor 40.1.1.2 activate
Activating Neighbor in link-state link-state address family.
R3(config-router-af)#exit
Exit from BGP address family mode
R3(config-router#exit
Exit from router bgp mode
R4: Interface
 
R4#configure terminal
Enter configure mode
R4(config)#hostname R4
Configure hostname
R4(config)#interface lo
Enter interface mode for loopback interface.
R4(config-if)#ip address 4.4.4.4/32 secondary
Configure IPv4 address.
R4(config-if)#ip router isis 1
Configure Router-isis.
R4(config-if)#prefix-sid index 500
Configure Prefix-sid
R4(config-if)#exit
Exit interface mode
R4(config)#interface xe12
Enter interface mode for xe12 interface.
R4(config-if)#ip address 30.1.1.2/24
Configure IPv4 address.
R4(config-if)#label-switching
Enable label switching
R4(config-if)#ip router isis 1
Configure Router-isis.
R4(config-if)#exit
Exit interface mode
R4: ISIS
 
R4(config)#router isis 1
Enter ISIS router mode
R4(config-router)#is-type level-1
Configure IS-type.
R4(config-router)#metric-style wide
Configure Metric-style.
R4(config-router)#mpls traffic-eng router-id 4.4.4.4
Configure MPLS TE router-id.
R4(config-router)#mpls traffic-eng level-1
Configure MPLS TE Level-1.
R4(config-router)#isis segment-routing global block 16500 23800
Configure SRGB range (default: 16-23999).
R4(config-router)#segment-routing mpls
Enabling Segment-Routing.
R4(config-router)#net 49.0000.0000.0000.0004.00
Configure net-id.
R4(config-router)#exit
Exit from router isis mode.
R5: Interface
 
R5#configure terminal
Enter configure mode
R5(config)#hostname R5
Configure hostname
R5(config)#interface lo
Enter interface mode for loopback interface.
R5(config-if)#ip address 5.5.5.5/32 secondary
Configure IPv4 address.
R5(config-if)#ip router isis 1
Configure Router-isis.
R5(config-if)#label-switching
Enable label switching
R5(config-if)#prefix-sid index 700
Configure Prefix-sid
R5(config-if)#exit
Exit interface mode
R5(config)#interface xe21
Enter interface mode for xe21 interface.
R5(config-if)#ip address 60.1.1.1/24
Configure IPv4 address.
R5(config-if)#ip router isis 1
Configure Router-isis.
R5(config-if)#exit
Exit interface mode
R5(config)#interface xe8
Enter interface mode for xe8 interface.
R5(config-if)#ip address 50.1.1.1/24
Configure IPv4 address.
R5(config-if)# label-switching
Enable label switching
R5(config-if)#exit
Exit interface mode
R5: ISIS
 
R5(config)#router isis 1
Enter ISIS router mode
R5(config-router)#is-type level-1-2
Configure IS-type.
R5(config-router)#metric-style wide
Configure Metric-style.
R5(config-router)#mpls traffic-eng router-id 5.5.5.5
Configure MPLS TE router-id.
R5(config-router)#mpls traffic-eng level-1
Configure MPLS TE Level-1.
R5(config-router)#mpls traffic-eng level-2
Configure MPLS TE Level-2.
R5(config-router)#isis segment-routing global block 19100 23800
Configure SRGB range (default: 16-23999).
R5(config-router)#segment-routing mpls
Enabling Segment-Routing.
R5(config-router)#net 49.0000.0000.0000.0005.00
Configure net-id.
R5(config-router)#distribute bgp-ls
Distributing BGP-LS.
R5(config-router)#exit
Exit from router isis mode.
R5: BGP
 
R5(config)#router bgp 200
Enter BGP router mode
R5(config)#bgp router-id 5.5.5.5
Configure BGP router-id
R5(config-router)#neighbor 50.1.1.2 remote-as 300
Configure neighbor with remote-as.
R5(config-router)#neighbor 50.1.1.2 update-source lo
Configure neighbor with update-source.
R5(config-router)#address-family link-state link-state
Entering link-state link-state address family.
R5(config-router-af)#neighbor 50.1.1.2 activate
Activating Neighbor in link-state link-state address family.
R5(config-router-af)#exit
Exit from BGP address family mode
R5(config-router#exit
Exit from bgp router mode
R6: Interface
 
R6#configure terminal
Enter configure mode
R6(config)#hostname R6
Configure hostname
R6(config)#interface lo
Enter interface mode for loopback interface.
R6(config-if)#ip address 6.6.6.6/32 secondary
Configure IPv4 address.
R6(config-if)#ip router isis 1
Configure Router-isis.
R6(config-if)#prefix-sid index 600
Configure Prefix-sid
R6(config-if)#exit
Exit interface mode
R6(config)#interface xe21
Enter interface mode for xe21 interface.
R6(config-if)#ip address 60.1.1.2/24
Configure IPv4 address.
R6(config-if)#label-switching
Enable label switching
R6(config-if)#ip router isis 1
Configure Router-isis.
R6(config-if)#exit
Exit interface mode
ISIS
 
R6(config)#router isis 1
Enter ISIS router mode
R6(config-router)#is-type level-1
Configure IS-type.
R6(config-router)#metric-style wide
Configure Metric-style.
R6(config-router)#mpls traffic-eng router-id 6.6.6.6
Configure MPLS TE router-id.
R6(config-router)#mpls traffic-eng level-1
Configure MPLS TE Level-1.
R6(config-router)#isis segment-routing global block 16100 23990
Configure SRGB range (default: 16-23999).
R6(config-router)#segment-routing mpls
Enabling Segment-Routing.
R6(config-router)#net 49.0000.0000.0000.0006.00
Configure net-id.
R6(config-router)#exit
Exit ISIS router mode
R7 (Controller): Interface
 
R7#configure terminal
Enter configure mode
R7(config)#hostname R7
Configure hostname
R7(config)#in xe4
Entering to interface xe4.
R7(config-if)#ip address 40.1.1.2/24
Configure IPv4 address.
R7(config-if)#in xe8
Entering to interface xe8.
R7(config-if)#ip address 50.1.1.2/24
Configure IPv4 address.
R7(config-if)#exit
Exit interface mode
R7: BGP
 
R7(config-if)#router bgp 300
Entering to router bgp mode.
R7(config-router)#neighbor 40.1.1.1 remote-as 100
Configure neighbor with remote-as.
R7(config-router)#neighbor 40.1.1.1 update-source xe4
Configure neighbor with update-source.
R7(config-router)#neighbor 50.1.1.1 remote-as 200
Configure neighbor with remote-as.
R7(config-router)#neighbor 50.1.1.1 update-source xe8
Configure neighbor with update-source.
R7(config-router)#address-family link-state link-state
Entering link-state link-state address family.
R7(config-router-af)#neighbor 50.1.1.1 activate
Activating Neighbor in link-state link-state address family.
R7(config-router-af)#neighbor 40.1.1.1 activate
Activating Neighbor in link-state link-state address family.
R7(config-router-af)#exit
Exit from BGP address family mode
R7(config-router#exit
Exit from bgp router mode
Validation on R3
ISIS Neighborship
R3#show clns neighbors
 
Total number of L1 adjacencies: 2
Total number of L2 adjacencies: 1
Total number of adjacencies: 3
Tag 1: VRF : default
System Id Interface SNPA State Holdtime Type Protocol
0000.0000.0001 xe2 e8c5.7a90.cc70 Up 6 L1 IS-IS
0000.0000.0002 xe7 e8c5.7ac5.c2b1 Up 6 L2 IS-IS
0000.0000.0004 xe12 e8c5.7a79.572a Up 6 L1 IS-IS
 
ISIS Database-Verbose
R3#show isis database verbose
Tag 1: VRF : default
IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
0000.0000.0001.00-00 0x0000000C 0x5342 858 0/0/0
Area Address: 49.0000
NLPID: 0xCC
IP Address: 1.1.1.1
Router ID: 1.1.1.1
Router Cap: 1.1.1.1
SRGB Range: 3000 SRGB Base SID: 18000 I:1 V:0
SR-Algorithm:
Algorithm: 0
Metric: 10 IS-Extended 0000.0000.0001.03
IPv4 Interface Address: 10.1.1.1
Neighbor IP Address: 10.1.1.1
Maximum Link Bandwidth: 10g
Reservable Bandwidth: 10g
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 10g
Unreserved Bandwidth at priority 1: 10g
Unreserved Bandwidth at priority 2: 10g
Unreserved Bandwidth at priority 3: 10g
Unreserved Bandwidth at priority 4: 10g
Unreserved Bandwidth at priority 5: 10g
Unreserved Bandwidth at priority 6: 10g
Unreserved Bandwidth at priority 7: 10g
TE-Default Metric: 10
System-ID: 0000.0000.0003 LAN Adjacency SID: 24960 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IP-Extended 1.1.1.1/32
Prefix-SID: index 100 R:0 N:1 P:0 E:0 V:0 L:0
Metric: 10 IP-Extended 10.11.2.0/30
Metric: 10 IP-Extended 10.1.1.0/24
0000.0000.0001.03-00 0x00000002 0x9335 854 0/0/0
Metric: 0 IS-Extended 0000.0000.0001.00
Metric: 0 IS-Extended 0000.0000.0003.00
0000.0000.0003.00-00* 0x0000000A 0x3E9A 1012 1/0/0
Area Address: 49.0000
NLPID: 0xCC
IP Address: 3.3.3.3
Router ID: 3.3.3.3
Router Cap: 3.3.3.3
SRGB Range: 4801 SRGB Base SID: 17500 I:1 V:0
SR-Algorithm:
Algorithm: 0
Metric: 10 IS-Extended 0000.0000.0004.02
IPv4 Interface Address: 30.1.1.1
Neighbor IP Address: 30.1.1.2
Maximum Link Bandwidth: 10g
Reservable Bandwidth: 10g
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 10g
Unreserved Bandwidth at priority 1: 10g
Unreserved Bandwidth at priority 2: 10g
Unreserved Bandwidth at priority 3: 10g
Unreserved Bandwidth at priority 4: 10g
Unreserved Bandwidth at priority 5: 10g
Unreserved Bandwidth at priority 6: 10g
Unreserved Bandwidth at priority 7: 10g
TE-Default Metric: 10
System-ID: 0000.0000.0004 LAN Adjacency SID: 24320 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IS-Extended 0000.0000.0001.03
IPv4 Interface Address: 10.1.1.2
Neighbor IP Address: 10.1.1.1
Maximum Link Bandwidth: 10g
Reservable Bandwidth: 10g
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 10g
Unreserved Bandwidth at priority 1: 10g
Unreserved Bandwidth at priority 2: 10g
Unreserved Bandwidth at priority 3: 10g
Unreserved Bandwidth at priority 4: 10g
Unreserved Bandwidth at priority 5: 10g
Unreserved Bandwidth at priority 6: 10g
Unreserved Bandwidth at priority 7: 10g
TE-Default Metric: 10
System-ID: 0000.0000.0001 LAN Adjacency SID: 24321 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IP-Extended 3.3.3.3/32
Prefix-SID: index 300 R:0 N:1 P:0 E:0 V:0 L:0
Metric: 10 IP-Extended 10.1.1.0/24
Metric: 10 IP-Extended 20.1.1.0/24
Metric: 10 IP-Extended 30.1.1.0/24
0000.0000.0004.00-00 0x0000000D 0xF8E2 1145 0/0/0
Area Address: 49.0000
NLPID: 0xCC
IP Address: 4.4.4.4
Router ID: 4.4.4.4
Router Cap: 4.4.4.4
SRGB Range: 7301 SRGB Base SID: 16500 I:1 V:0
SR-Algorithm:
Algorithm: 0
Metric: 10 IS-Extended 0000.0000.0004.02
IPv4 Interface Address: 30.1.1.2
Neighbor IP Address: 30.1.1.2
Maximum Link Bandwidth: 10g
Reservable Bandwidth: 10g
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 10g
Unreserved Bandwidth at priority 1: 10g
Unreserved Bandwidth at priority 2: 10g
Unreserved Bandwidth at priority 3: 10g
Unreserved Bandwidth at priority 4: 10g
Unreserved Bandwidth at priority 5: 10g
Unreserved Bandwidth at priority 6: 10g
Unreserved Bandwidth at priority 7: 10g
TE-Default Metric: 10
System-ID: 0000.0000.0003 LAN Adjacency SID: 24960 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IP-Extended 4.4.4.4/32
Prefix-SID: index 500 R:0 N:1 P:0 E:0 V:0 L:0
Metric: 10 IP-Extended 30.1.1.0/24
0000.0000.0004.02-00 0x00000005 0x9729 854 0/0/0
Metric: 0 IS-Extended 0000.0000.0004.00
Metric: 0 IS-Extended 0000.0000.0003.00
 
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
0000.0000.0002.00-00 0x00000009 0xB85F 929 0/0/0
Area Address: 49.0001
NLPID: 0xCC
IP Address: 2.2.2.2
Router ID: 2.2.2.2
Router Cap: 2.2.2.2
SRGB Range: 3000 SRGB Base SID: 19000 I:1 V:0
SR-Algorithm:
Algorithm: 0
Metric: 10 IS-Extended 0000.0000.0002.02
IPv4 Interface Address: 20.1.1.1
Neighbor IP Address: 20.1.1.1
Maximum Link Bandwidth: 10g
Reservable Bandwidth: 10g
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 10g
Unreserved Bandwidth at priority 1: 10g
Unreserved Bandwidth at priority 2: 10g
Unreserved Bandwidth at priority 3: 10g
Unreserved Bandwidth at priority 4: 10g
Unreserved Bandwidth at priority 5: 10g
Unreserved Bandwidth at priority 6: 10g
Unreserved Bandwidth at priority 7: 10g
TE-Default Metric: 10
System-ID: 0000.0000.0003 LAN Adjacency SID: 24320 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IP-Extended 2.2.2.2/32
Prefix-SID: index 400 R:0 N:1 P:0 E:0 V:0 L:0
Metric: 10 IP-Extended 20.1.1.0/24
0000.0000.0002.02-00 0x00000002 0x9D28 855 0/0/0
Metric: 0 IS-Extended 0000.0000.0002.00
Metric: 0 IS-Extended 0000.0000.0003.00
0000.0000.0003.00-00* 0x0000000A 0xEBDD 1146 0/0/0
Area Address: 49.0000
NLPID: 0xCC
IP Address: 3.3.3.3
Router ID: 3.3.3.3
Router Cap: 3.3.3.3
SRGB Range: 4801 SRGB Base SID: 17500 I:1 V:0
SR-Algorithm:
Algorithm: 0
Metric: 10 IS-Extended 0000.0000.0002.02
IPv4 Interface Address: 20.1.1.2
Neighbor IP Address: 20.1.1.1
Maximum Link Bandwidth: 10g
Reservable Bandwidth: 10g
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 10g
Unreserved Bandwidth at priority 1: 10g
Unreserved Bandwidth at priority 2: 10g
Unreserved Bandwidth at priority 3: 10g
Unreserved Bandwidth at priority 4: 10g
Unreserved Bandwidth at priority 5: 10g
Unreserved Bandwidth at priority 6: 10g
Unreserved Bandwidth at priority 7: 10g
TE-Default Metric: 10
System-ID: 0000.0000.0002 LAN Adjacency SID: 24322 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IP-Extended 3.3.3.3/32
Prefix-SID: index 300 R:0 N:1 P:0 E:0 V:0 L:0
Metric: 10 IP-Extended 10.1.1.0/24
Metric: 10 IP-Extended 20.1.1.0/24
Metric: 10 IP-Extended 30.1.1.0/24
Metric: 20 IP-Extended 4.4.4.4/32
Prefix-SID: index 500 R:1 N:0 P:0 E:0 V:0 L:0
Metric: 20 IP-Extended 1.1.1.1/32
Prefix-SID: index 100 R:1 N:0 P:0 E:0 V:0 L:0
Metric: 20 IP-Extended 10.11.2.0/30
BGP Neighborship
R3#show bgp neighbors
BGP neighbor is 1.1.1.1, remote AS 100, local AS 100, internal link
BGP version 4, local router ID 3.3.3.3, remote router ID 1.1.1.1
BGP state = Established, up for 00:26:06
Last read 00:00:28, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv4 Unicast: advertised and received
Address family Link-State Link-State: advertised and received
Received 77 messages, 0 notifications, 0 in queue
Sent 113 messages, 0 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 5 seconds
Update source is lo
For address family: IPv4 Unicast
BGP table version 1, neighbor version 1
Index 1, Offset 0, Mask 0x2
Community attribute sent to this neighbor (both)
0 accepted prefixes
0 announced prefixes
 
For address family: Link-State Link-State
BGP table version 21, neighbor version 21
Index 1, Offset 0, Mask 0x2
Community attribute sent to this neighbor (both)
11 accepted prefixes
33 announced prefixes
 
Connections established 1; dropped 0
Local host: 3.3.3.3, Local port: 44225
Foreign host: 1.1.1.1, Foreign port: 179
Nexthop: 3.3.3.3
Nexthop global: ::
Nexthop local: ::
BGP connection: non shared network
 
BGP neighbor is 2.2.2.2, remote AS 100, local AS 100, internal link
BGP version 4, local router ID 3.3.3.3, remote router ID 2.2.2.2
BGP state = Established, up for 00:30:37
Last read 00:00:14, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv4 Unicast: advertised and received
Address family Link-State Link-State: advertised and received
Received 115 messages, 0 notifications, 0 in queue
Sent 138 messages, 5 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 5 seconds
Update source is lo
For address family: IPv4 Unicast
BGP table version 1, neighbor version 1
Index 2, Offset 0, Mask 0x4
Community attribute sent to this neighbor (both)
0 accepted prefixes
0 announced prefixes
 
For address family: Link-State Link-State
BGP table version 21, neighbor version 21
Index 2, Offset 0, Mask 0x4
Community attribute sent to this neighbor (both)
20 accepted prefixes
33 announced prefixes
 
Connections established 3; dropped 2
Local host: 3.3.3.3, Local port: 37071
Foreign host: 2.2.2.2, Foreign port: 179
Nexthop: 3.3.3.3
Nexthop global: ::
Nexthop local: ::
BGP connection: non shared network
Last Reset: 00:30:42, due to Configuration Change (Cease Notification sent)
Notification Error Message: (Cease/Other Configuration Change.)
 
BGP neighbor is 40.1.1.2, remote AS 300, local AS 100, external link
BGP version 4, local router ID 3.3.3.3, remote router ID 40.1.1.2
BGP state = Established, up for 00:03:31
Last read 00:00:16, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv4 Unicast: advertised and received
Address family Link-State Link-State: advertised and received
Received 21 messages, 1 notifications, 0 in queue
Sent 51 messages, 1 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 30 seconds
For address family: IPv4 Unicast
BGP table version 1, neighbor version 1
Index 0, Offset 0, Mask 0x1
Community attribute sent to this neighbor (both)
0 accepted prefixes
0 announced prefixes
 
For address family: Link-State Link-State
BGP table version 21, neighbor version 21
Index 0, Offset 0, Mask 0x1
Community attribute sent to this neighbor (both)
11 accepted prefixes
53 announced prefixes
 
Connections established 2; dropped 1
Local host: 40.1.1.1, Local port: 179
Foreign host: 40.1.1.2, Foreign port: 47766
Nexthop: 40.1.1.1
Nexthop global: ::
Nexthop local: ::
BGP connection: non shared network
Last Reset: 00:03:31, due to Administratively Reset (Cease Notification sent)
Notification Error Message: (Cease/Administratively Reset.)
Validation of BGP-LS NLRIs
R3#show bgp link-state link-state
BGP router identifier 3.3.3.3, local AS number 100
Origin codes: i - IGP, e - EGP
Prefix codes: E link, V node, T IP reacheable route, I Identifier
N local node, R remote node, L link, P prefix
L1/L2 ISIS level-1/level-2, O OSPF, a area-ID,
c confed-ID/ASN, b bgp-identifier, r router-ID,
i if-address, n nbr-address, o OSPF Route-type,
p IP-prefix, d designated router address, s ISO-ID
i [V][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0001.00]]/208
i [V][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0003.00]]/208
i [V][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0003.02]]/208
[V][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0001.00]]/208
[V][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]]/208
[V][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.02]]/208
e [V][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]]/208
e [V][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0006.00]]/208
e [V][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0006.02]]/208
i [V][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0002.00]]/208
i [V][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0002.02]]/208
i [V][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.00]]/208
i [V][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.04]]/208
i [V][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0004.00]]/208
[V][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0002.00]]/208
[V][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]]/208
[V][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.04]]/208
[V][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0004.00]]/208
e [V][L2][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]]/208
i [E][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0001.00]][R[c100][b1.1.1.1][s0000.0000.0003.02]][L[i10.1.1.1][n10.1.1.2]]/328
i [E][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0003.00]][R[c100][b1.1.1.1][s0000.0000.0003.02]][L[i10.1.1.2][n10.1.1.2]]/328
i [E][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0003.02]][R[c100][b1.1.1.1][s0000.0000.0001.00]]/264
i [E][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0003.02]][R[c100][b1.1.1.1][s0000.0000.0003.00]]/264
[E][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0001.00]][R[c100][b3.3.3.3][s0000.0000.0003.02]][L[i10.1.1.1][n10.1.1.2]]/328
[E][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][R[c100][b3.3.3.3][s0000.0000.0003.02]][L[i10.1.1.2][n10.1.1.2]]/328
[E][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.02]][R[c100][b3.3.3.3][s0000.0000.0001.00]]/264
[E][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.02]][R[c100][b3.3.3.3][s0000.0000.0003.00]]/264
e [E][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][R[c200][b5.5.5.5][s0000.0000.0006.02]][L[i60.1.1.1][n60.1.1.2]]/328
e [E][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0006.00]][R[c200][b5.5.5.5][s0000.0000.0006.02]][L[i60.1.1.2][n60.1.1.2]]/328
e [E][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0006.02]][R[c200][b5.5.5.5][s0000.0000.0005.00]]/264
e [E][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0006.02]][R[c200][b5.5.5.5][s0000.0000.0006.00]]/264
i [E][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0002.00]][R[c100][b2.2.2.2][s0000.0000.0002.02]][L[i20.1.1.1][n20.1.1.1]]/328
i [E][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0002.02]][R[c100][b2.2.2.2][s0000.0000.0002.00]]/264
i [E][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0002.02]][R[c100][b2.2.2.2][s0000.0000.0003.00]]/264
i [E][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.00]][R[c100][b2.2.2.2][s0000.0000.0002.02]][L[i20.1.1.2][n20.1.1.1]]/328
i [E][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.00]][R[c100][b2.2.2.2][s0000.0000.0003.04]][L[i30.1.1.1][n30.1.1.1]]/328
i [E][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.04]][R[c100][b2.2.2.2][s0000.0000.0003.00]]/264
i [E][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.04]][R[c100][b2.2.2.2][s0000.0000.0004.00]]/264
i [E][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0004.00]][R[c100][b2.2.2.2][s0000.0000.0003.04]][L[i30.1.1.2][n30.1.1.1]]/328
[E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0002.00]][R[c100][b3.3.3.3][s0000.0000.0002.02]][L[i20.1.1.1][n20.1.1.1]]/328
[E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0002.02]][R[c100][b3.3.3.3][s0000.0000.0002.00]]/264
[E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0002.02]][R[c100][b3.3.3.3][s0000.0000.0003.00]]/264
[E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][R[c100][b3.3.3.3][s0000.0000.0002.02]][L[i20.1.1.2][n20.1.1.1]]/328
[E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][R[c100][b3.3.3.3][s0000.0000.0003.04]][L[i30.1.1.1][n30.1.1.1]]/328
[E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.04]][R[c100][b3.3.3.3][s0000.0000.0003.00]]/264
[E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.04]][R[c100][b3.3.3.3][s0000.0000.0004.00]]/264
[E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0004.00]][R[c100][b3.3.3.3][s0000.0000.0003.04]][L[i30.1.1.2][n30.1.1.1]]/328
i [T][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0001.00]][P[p10.1.1.0/24]]/240
i [T][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0001.00]][P[p1.1.1.1/32]]/248
i [T][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0003.00]][P[p10.1.1.0/24]]/240
i [T][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0003.00]][P[p20.1.1.0/24]]/240
i [T][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0003.00]][P[p30.1.1.0/24]]/240
i [T][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0003.00]][P[p3.3.3.3/32]]/248
[T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0001.00]][P[p10.1.1.0/24]]/240
[T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0001.00]][P[p1.1.1.1/32]]/248
[T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p10.1.1.0/24]]/240
[T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p20.1.1.0/24]]/240
[T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p30.1.1.0/24]]/240
[T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p3.3.3.3/32]]/248
e [T][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][P[p60.1.1.0/24]]/240
e [T][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][P[p5.5.5.5/32]]/248
e [T][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0006.00]][P[p60.1.1.0/24]]/240
e [T][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0006.00]][P[p6.6.6.6/32]]/248
i [T][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0002.00]][P[p20.1.1.0/24]]/240
i [T][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0002.00]][P[p2.2.2.2/32]]/248
i [T][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.00]][P[p10.1.1.0/24]]/240
i [T][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.00]][P[p20.1.1.0/24]]/240
i [T][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.00]][P[p30.1.1.0/24]]/240
i [T][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.00]][P[p1.1.1.1/32]]/248
i [T][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.00]][P[p3.3.3.3/32]]/248
i [T][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0004.00]][P[p30.1.1.0/24]]/240
i [T][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0004.00]][P[p4.4.4.4/32]]/248
[T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0002.00]][P[p20.1.1.0/24]]/240
[T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0002.00]][P[p2.2.2.2/32]]/248
[T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p10.1.1.0/24]]/240
[T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p20.1.1.0/24]]/240
[T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p30.1.1.0/24]]/240
[T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p1.1.1.1/32]]/248
[T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p3.3.3.3/32]]/248
[T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0004.00]][P[p30.1.1.0/24]]/240
[T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0004.00]][P[p4.4.4.4/32]]/248
e [T][L2][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][P[p60.1.1.0/24]]/240
e [T][L2][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][P[p5.5.5.5/32]]/248
e [T][L2][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][P[p6.6.6.6/32]]/248
NLRIs, Total: 84, Node: 19, Link: 28, Prefix: 37
Note: Count of NLRIs may be different sometimes.
Validation for NLRI count
R3#show bgp link-state link-state count
-------------------------------------------
Total NLRIs : 84
Node NLRIs : 19
Link NLRIs : 28
Prefix NLRIs : 37
-------------------------------------------
Note: Count of NLRIs may be different sometimes.
R3#show bgp link-state link-state self-originate
BGP router identifier 3.3.3.3, local AS number 100
Origin codes: i - IGP, e - EGP
Prefix codes: E link, V node, T IP reacheable route, I Identifier
N local node, R remote node, L link, P prefix
L1/L2 ISIS level-1/level-2, O OSPF, a area-ID,
c confed-ID/ASN, b bgp-identifier, r router-ID,
i if-address, n nbr-address, o OSPF Route-type,
p IP-prefix, d designated router address, s ISO-ID
[V][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0001.00]]/208
[V][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]]/208
[V][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.02]]/208
[V][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0002.00]]/208
[V][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]]/208
[V][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.04]]/208
[V][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0004.00]]/208
[E][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0001.00]][R[c100][b3.3.3.3][s0000.0000.0003.02]][L[i10.1.1.1][n10.1.1.2]]/328
[E][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][R[c100][b3.3.3.3][s0000.0000.0003.02]][L[i10.1.1.2][n10.1.1.2]]/328
[E][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.02]][R[c100][b3.3.3.3][s0000.0000.0001.00]]/264
[E][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.02]][R[c100][b3.3.3.3][s0000.0000.0003.00]]/264
[E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0002.00]][R[c100][b3.3.3.3][s0000.0000.0002.02]][L[i20.1.1.1][n20.1.1.1]]/328
[E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0002.02]][R[c100][b3.3.3.3][s0000.0000.0002.00]]/264
[E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0002.02]][R[c100][b3.3.3.3][s0000.0000.0003.00]]/264
[E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][R[c100][b3.3.3.3][s0000.0000.0002.02]][L[i20.1.1.2][n20.1.1.1]]/328
[E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][R[c100][b3.3.3.3][s0000.0000.0003.04]][L[i30.1.1.1][n30.1.1.1]]/328
[E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.04]][R[c100][b3.3.3.3][s0000.0000.0003.00]]/264
[E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.04]][R[c100][b3.3.3.3][s0000.0000.0004.00]]/264
[E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0004.00]][R[c100][b3.3.3.3][s0000.0000.0003.04]][L[i30.1.1.2][n30.1.1.1]]/328
[T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0001.00]][P[p10.1.1.0/24]]/240
[T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0001.00]][P[p1.1.1.1/32]]/248
[T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p10.1.1.0/24]]/240
[T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p20.1.1.0/24]]/240
[T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p30.1.1.0/24]]/240
[T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p3.3.3.3/32]]/248
[T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0002.00]][P[p20.1.1.0/24]]/240
[T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0002.00]][P[p2.2.2.2/32]]/248
[T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p10.1.1.0/24]]/240
[T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p20.1.1.0/24]]/240
[T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p30.1.1.0/24]]/240
[T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p1.1.1.1/32]]/248
[T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p3.3.3.3/32]]/248
[T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0004.00]][P[p30.1.1.0/24]]/240
[T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0004.00]][P[p4.4.4.4/32]]/248
NLRIs, Total: 34, Node: 7, Link: 12, Prefix: 15
Note: Count of NLRIs may be different sometimes.
Validation for Node-NLRI
R3#show bgp link-state link-state [V][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]]/208
BGP routing table entry for [V][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]]/208
Local
Received from 40.1.1.2
Link State:
Aux Router ID: 5.5.5.5
ISIS area address:49.0000
Range Size: 4701 Base SID: 19100 SR Algorithm: 0 SR Flags: I:1 V:0
Node flag bits: O:0 T:0 B:0 E:0
Validation for Link-NLRI
R3#show bgp link-state link-state [E][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][R[c200][b5.5.5.5][s0000.0000.0006.02]][L[i60.1.1.1][n60.1.1.2]]/328
BGP routing table entry for [E][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][R[c200][b5.5.5.5][s0000.0000.0006.02]][L[i60.1.1.1][n60.1.1.2]]/328
Local
Received from 40.1.1.2
Link State:
Local Router ID: 5.5.5.5, Admin-group: Max link bw: 3124999936.00 ,Max reservable link bw: 3124999936.00
Max unreserved link bw:3124999936.00 3124999936.00 3124999936.00 3124999936.00 3124999936.00 3124999936.00 3124999936.00 3124999936.00
TE metric 10 , IGP metric 10
SR Flags: F:0 B:0 V:1 L:1 S:0 P:0
MT-ID: 0 Neighbor ID: 0000.0000.0006 LAN Adjacency SID: 24320
Validation for Prefix-NLRI
R3#show bgp link-state link-state [T][L2][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][P[p5.5.5.5/32]]/248
BGP routing table entry for [T][L2][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][P[p5.5.5.5/32]]/248
Local
Received from 40.1.1.2
Link State:
Metric: 10 SID: 19300 SR Flags: R:0 N:1 P:0 E:0 V:1 L:0
Validation on R5
ISIS Neighbor ship
R5#show clns neighbors
 
Total number of L1 adjacencies: 1
Total number of L2 adjacencies: 0
Total number of adjacencies: 1
Tag 1: VRF : default
System Id Interface SNPA State Holdtime Type Protocol
0000.0000.0006 xe21 e8c5.7ad2.5ec3 Up 7 L1 IS-IS
ISIS Database Verbose
R5#show isis database verbose
Tag 1: VRF : default
IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
0000.0000.0005.00-00* 0x00000005 0x9107 1003 0/0/0
Area Address: 49.0000
NLPID: 0xCC
IP Address: 60.1.1.1
Router ID: 5.5.5.5
Router Cap: 5.5.5.5
SRGB Range: 4701 SRGB Base SID: 19100 I:1 V:0
SR-Algorithm:
Algorithm: 0
Metric: 10 IS-Extended 0000.0000.0006.01
IPv4 Interface Address: 60.1.1.1
Neighbor IP Address: 60.1.1.2
Maximum Link Bandwidth: 10g
Reservable Bandwidth: 10g
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 10g
Unreserved Bandwidth at priority 1: 10g
Unreserved Bandwidth at priority 2: 10g
Unreserved Bandwidth at priority 3: 10g
Unreserved Bandwidth at priority 4: 10g
Unreserved Bandwidth at priority 5: 10g
Unreserved Bandwidth at priority 6: 10g
Unreserved Bandwidth at priority 7: 10g
TE-Default Metric: 10
System-ID: 0000.0000.0006 LAN Adjacency SID: 26880 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IP-Extended 60.1.1.0/24
Metric: 10 IP-Extended 5.5.5.5/32
Prefix-SID: index 700 R:0 N:1 P:0 E:0 V:0 L:0
Metric: 10 IP-Extended 10.0.1.33/32
0000.0000.0006.00-00 0x00000002 0xE6B7 938 0/0/0
Area Address: 49.0000
NLPID: 0xCC
IP Address: 60.1.1.2
Router ID: 6.6.6.6
Router Cap: 6.6.6.6
SRGB Range: 7891 SRGB Base SID: 16100 I:1 V:0
SR-Algorithm:
Algorithm: 0
Metric: 10 IS-Extended 0000.0000.0006.01
IPv4 Interface Address: 60.1.1.2
Neighbor IP Address: 60.1.1.2
Maximum Link Bandwidth: 10g
Reservable Bandwidth: 10g
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 10g
Unreserved Bandwidth at priority 1: 10g
Unreserved Bandwidth at priority 2: 10g
Unreserved Bandwidth at priority 3: 10g
Unreserved Bandwidth at priority 4: 10g
Unreserved Bandwidth at priority 5: 10g
Unreserved Bandwidth at priority 6: 10g
Unreserved Bandwidth at priority 7: 10g
TE-Default Metric: 10
System-ID: 0000.0000.0005 LAN Adjacency SID: 24320 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IP-Extended 60.1.1.0/24
Metric: 10 IP-Extended 6.6.6.6/32
Prefix-SID: index 600 R:0 N:1 P:0 E:0 V:0 L:0
0000.0000.0006.01-00 0x00000001 0xD0EE 934 0/0/0
Metric: 0 IS-Extended 0000.0000.0006.00
Metric: 0 IS-Extended 0000.0000.0005.00
 
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
0000.0000.0005.00-00* 0x00000006 0xB9A2 1003 0/0/0
Area Address: 49.0000
NLPID: 0xCC
IP Address: 60.1.1.1
Router ID: 5.5.5.5
Router Cap: 5.5.5.5
SRGB Range: 4701 SRGB Base SID: 19100 I:1 V:0
SR-Algorithm:
Algorithm: 0
Metric: 10 IP-Extended 60.1.1.0/24
Metric: 10 IP-Extended 5.5.5.5/32
Prefix-SID: index 700 R:0 N:1 P:0 E:0 V:0 L:0
Metric: 10 IP-Extended 10.0.1.33/32
Metric: 20 IP-Extended 6.6.6.6/32
Prefix-SID: index 600 R:1 N:0 P:0 E:0 V:0 L:0
Validation of BGP-LS NLRIs
R5#sho bgp link-state link-state
BGP router identifier 5.5.5.5, local AS number 200
Origin codes: i - IGP, e - EGP
Prefix codes: E link, V node, T IP reacheable route, I Identifier
N local node, R remote node, L link, P prefix
L1/L2 ISIS level-1/level-2, O OSPF, a area-ID,
c confed-ID/ASN, b bgp-identifier, r router-ID,
i if-address, n nbr-address, o OSPF Route-type,
p IP-prefix, d designated router address, s ISO-ID
e [V][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0001.00]]/208
e [V][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0003.00]]/208
e [V][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0003.02]]/208
e [V][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0001.00]]/208
e [V][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]]/208
e [V][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.02]]/208
[V][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]]/208
[V][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0006.00]]/208
[V][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0006.02]]/208
e [V][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0002.00]]/208
e [V][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0002.02]]/208
e [V][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.00]]/208
e [V][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.04]]/208
e [V][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0004.00]]/208
e [V][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0002.00]]/208
e [V][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]]/208
e [V][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.04]]/208
e [V][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0004.00]]/208
[V][L2][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]]/208
e [E][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0001.00]][R[c100][b1.1.1.1][s0000.0000.0003.02]][L[i10.1.1.1][n10.1.1.2]]/328
e [E][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0003.00]][R[c100][b1.1.1.1][s0000.0000.0003.02]][L[i10.1.1.2][n10.1.1.2]]/328
e [E][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0003.02]][R[c100][b1.1.1.1][s0000.0000.0001.00]]/264
e [E][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0003.02]][R[c100][b1.1.1.1][s0000.0000.0003.00]]/264
e [E][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0001.00]][R[c100][b3.3.3.3][s0000.0000.0003.02]][L[i10.1.1.1][n10.1.1.2]]/328
e [E][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][R[c100][b3.3.3.3][s0000.0000.0003.02]][L[i10.1.1.2][n10.1.1.2]]/328
e [E][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.02]][R[c100][b3.3.3.3][s0000.0000.0001.00]]/264
e [E][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.02]][R[c100][b3.3.3.3][s0000.0000.0003.00]]/264
[E][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][R[c200][b5.5.5.5][s0000.0000.0006.02]][L[i60.1.1.1][n60.1.1.2]]/328
[E][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0006.00]][R[c200][b5.5.5.5][s0000.0000.0006.02]][L[i60.1.1.2][n60.1.1.2]]/328
[E][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0006.02]][R[c200][b5.5.5.5][s0000.0000.0005.00]]/264
[E][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0006.02]][R[c200][b5.5.5.5][s0000.0000.0006.00]]/264
e [E][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0002.00]][R[c100][b2.2.2.2][s0000.0000.0002.02]][L[i20.1.1.1][n20.1.1.1]]/328
e [E][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0002.02]][R[c100][b2.2.2.2][s0000.0000.0002.00]]/264
e [E][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0002.02]][R[c100][b2.2.2.2][s0000.0000.0003.00]]/264
e [E][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.00]][R[c100][b2.2.2.2][s0000.0000.0002.02]][L[i20.1.1.2][n20.1.1.1]]/328
e [E][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.00]][R[c100][b2.2.2.2][s0000.0000.0003.04]][L[i30.1.1.1][n30.1.1.1]]/328
e [E][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.04]][R[c100][b2.2.2.2][s0000.0000.0003.00]]/264
e [E][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.04]][R[c100][b2.2.2.2][s0000.0000.0004.00]]/264
e [E][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0004.00]][R[c100][b2.2.2.2][s0000.0000.0003.04]][L[i30.1.1.2][n30.1.1.1]]/328
e [E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0002.00]][R[c100][b3.3.3.3][s0000.0000.0002.02]][L[i20.1.1.1][n20.1.1.1]]/328
e [E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0002.02]][R[c100][b3.3.3.3][s0000.0000.0002.00]]/264
e [E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0002.02]][R[c100][b3.3.3.3][s0000.0000.0003.00]]/264
e [E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][R[c100][b3.3.3.3][s0000.0000.0002.02]][L[i20.1.1.2][n20.1.1.1]]/328
e [E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][R[c100][b3.3.3.3][s0000.0000.0003.04]][L[i30.1.1.1][n30.1.1.1]]/328
e [E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.04]][R[c100][b3.3.3.3][s0000.0000.0003.00]]/264
e [E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.04]][R[c100][b3.3.3.3][s0000.0000.0004.00]]/264
e [E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0004.00]][R[c100][b3.3.3.3][s0000.0000.0003.04]][L[i30.1.1.2][n30.1.1.1]]/328
e [T][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0001.00]][P[p10.1.1.0/24]]/240
e [T][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0001.00]][P[p1.1.1.1/32]]/248
e [T][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0003.00]][P[p10.1.1.0/24]]/240
e [T][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0003.00]][P[p20.1.1.0/24]]/240
e [T][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0003.00]][P[p30.1.1.0/24]]/240
e [T][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0003.00]][P[p3.3.3.3/32]]/248
e [T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0001.00]][P[p10.1.1.0/24]]/240
e [T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0001.00]][P[p1.1.1.1/32]]/248
e [T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p10.1.1.0/24]]/240
e [T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p20.1.1.0/24]]/240
e [T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p30.1.1.0/24]]/240
e [T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p3.3.3.3/32]]/248
[T][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][P[p60.1.1.0/24]]/240
[T][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][P[p5.5.5.5/32]]/248
[T][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0006.00]][P[p60.1.1.0/24]]/240
[T][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0006.00]][P[p6.6.6.6/32]]/248
e [T][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0002.00]][P[p20.1.1.0/24]]/240
e [T][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0002.00]][P[p2.2.2.2/32]]/248
e [T][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.00]][P[p10.1.1.0/24]]/240
e [T][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.00]][P[p20.1.1.0/24]]/240
e [T][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.00]][P[p30.1.1.0/24]]/240
e [T][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.00]][P[p1.1.1.1/32]]/248
e [T][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.00]][P[p3.3.3.3/32]]/248
e [T][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0004.00]][P[p30.1.1.0/24]]/240
e [T][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0004.00]][P[p4.4.4.4/32]]/248
e [T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0002.00]][P[p20.1.1.0/24]]/240
e [T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0002.00]][P[p2.2.2.2/32]]/248
e [T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p10.1.1.0/24]]/240
e [T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p20.1.1.0/24]]/240
e [T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p30.1.1.0/24]]/240
e [T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p1.1.1.1/32]]/248
e [T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p3.3.3.3/32]]/248
e [T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0004.00]][P[p30.1.1.0/24]]/240
e [T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0004.00]][P[p4.4.4.4/32]]/248
[T][L2][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][P[p60.1.1.0/24]]/240
[T][L2][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][P[p5.5.5.5/32]]/248
[T][L2][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][P[p6.6.6.6/32]]/248
NLRIs, Total: 84, Node: 19, Link: 28, Prefix: 37
Note: Count of NLRIs may be different sometimes.
Validation for NLRI Count
R5#sho bgp link-state link-state count
-------------------------------------------
Total NLRIs : 100
Node NLRIs : 24
Link NLRIs : 32
Prefix NLRIs : 44
-------------------------------------------
Note: Count of NLRIs may be different sometimes.
R5#show bgp link-state link-state self-originate
BGP router identifier 5.5.5.5, local AS number 200
Origin codes: i - IGP, e - EGP
Prefix codes: E link, V node, T IP reacheable route, I Identifier
N local node, R remote node, L link, P prefix
L1/L2 ISIS level-1/level-2, O OSPF, a area-ID,
c confed-ID/ASN, b bgp-identifier, r router-ID,
i if-address, n nbr-address, o OSPF Route-type,
p IP-prefix, d designated router address, s ISO-ID
[V][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]]/208
[V][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0006.00]]/208
[V][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0006.02]]/208
[V][L2][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]]/208
[E][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][R[c200][b5.5.5.5][s0000.0000.0006.02]][L[i60.1.1.1][n60.1.1.2]]/328
[E][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0006.00]][R[c200][b5.5.5.5][s0000.0000.0006.02]][L[i60.1.1.2][n60.1.1.2]]/328
[E][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0006.02]][R[c200][b5.5.5.5][s0000.0000.0005.00]]/264
[E][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0006.02]][R[c200][b5.5.5.5][s0000.0000.0006.00]]/264
[T][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][P[p60.1.1.0/24]]/240
[T][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][P[p5.5.5.5/32]]/248
[T][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0006.00]][P[p60.1.1.0/24]]/240
[T][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0006.00]][P[p6.6.6.6/32]]/248
[T][L2][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][P[p60.1.1.0/24]]/240
[T][L2][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][P[p5.5.5.5/32]]/248
[T][L2][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][P[p6.6.6.6/32]]/248
NLRIs, Total: 15, Node: 4, Link: 4, Prefix: 7
Note: Count of NLRIs may be different sometimes.
Validation for Node-NLRI
R5#show bgp link-state link-state [V][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0001.00]]/208
BGP routing table entry for [V][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0001.00]]/208
Local
Received from 50.1.1.2
Link State:
Aux Router ID: 1.1.1.1
ISIS area address:49.0002
Range Size: 8000 Base SID: 16000 SR Algorithm: 0 SR Flags: I:1 V:0
Node flag bits: O:0 T:0 B:0 E:0
Validation for Link-NLRI
R5#show bgp link-state link-state [E][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0001.00]][R[c100][b1.1.1.1][s0000.0000.0003.02]][L[i10.1.1.1][n10.1.1.2]]/328
BGP routing table entry for [E][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0001.00]][R[c100][b1.1.1.1][s0000.0000.0003.02]][L[i10.1.1.1][n10.1.1.2]]/328
Local
Received from 50.1.1.2
Link State:
Local Router ID: 1.1.1.1, Admin-group: Max link bw: 1250000000.00 ,Max reservable link bw: 1250000000.00
Max unreserved link bw:1250000000.00 1250000000.00 1250000000.00 1250000000.00 1250000000.00 1250000000.00 1250000000.00 1250000000.00
TE metric 10 , IGP metric 10
SR Flags: F:0 B:0 V:1 L:1 S:0 P:0
MT-ID: 0 Neighbor ID: 0000.0000.0003 LAN Adjacency SID: 24320
Validation for Prefix-NLRI
R5#show bgp link-state link-state [T][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0001.00]][P[p1.1.1.1/32]]/248
BGP routing table entry for [T][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0001.00]][P[p1.1.1.1/32]]/248
Local
Received from 50.1.1.2
Link State:
Metric: 10 SID: 16100 SR Flags: R:0 N:1 P:0 E:0 V:1 L:0
Validation on Controller
BGP Neighborship
Controller#show bgp neighbors
BGP neighbor is 40.1.1.1, remote AS 100, local AS 300, external link
BGP version 4, local router ID 40.1.1.2, remote router ID 3.3.3.3
BGP state = Established, up for 00:21:40
Last read 00:00:07, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv4 Unicast: advertised and received
Address family Link-State Link-State: advertised and received
Received 124 messages, 0 notifications, 0 in queue
Sent 71 messages, 1 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 30 seconds
For address family: IPv4 Unicast
BGP table version 1, neighbor version 1
Index 1, Offset 0, Mask 0x2
Community attribute sent to this neighbor (both)
0 accepted prefixes
0 announced prefixes
 
For address family: Link-State Link-State
BGP table version 7, neighbor version 7
Index 1, Offset 0, Mask 0x2
Community attribute sent to this neighbor (both)
69 accepted prefixes
15 announced prefixes
 
Connections established 2; dropped 1
Local host: 40.1.1.2, Local port: 47766
Foreign host: 40.1.1.1, Foreign port: 179
Nexthop: 40.1.1.2
Nexthop global: ::
Nexthop local: ::
BGP connection: non shared network
Last Reset: 00:21:45, due to Configuration Change (Cease Notification sent)
Notification Error Message: (Cease/Other Configuration Change.)
 
BGP neighbor is 50.1.1.1, remote AS 200, local AS 300, external link
BGP version 4, local router ID 40.1.1.2, remote router ID 5.5.5.5
BGP state = Established, up for 00:21:35
Last read 00:00:21, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv4 Unicast: advertised and received
Address family Link-State Link-State: advertised and received
Received 79 messages, 0 notifications, 0 in queue
Sent 94 messages, 1 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 30 seconds
For address family: IPv4 Unicast
BGP table version 1, neighbor version 1
Index 2, Offset 0, Mask 0x4
Community attribute sent to this neighbor (both)
0 accepted prefixes
0 announced prefixes
 
For address family: Link-State Link-State
BGP table version 7, neighbor version 7
Index 0, Offset 0, Mask 0x1
Community attribute sent to this neighbor (both)
15 accepted prefixes
69 announced prefixes
 
Connections established 2; dropped 1
Local host: 50.1.1.2, Local port: 179
Foreign host: 50.1.1.1, Foreign port: 43896
Nexthop: 50.1.1.2
Nexthop global: ::
Nexthop local: ::
BGP connection: non shared network
Last Reset: 00:21:40, due to Configuration Change (Cease Notification sent)
Notification Error Message: (Cease/Other Configuration Change.)
Validation of BGP-LS NLRIs
Controller#show bgp link-state link-state
BGP router identifier 40.1.1.2, local AS number 300
Origin codes: i - IGP, e - EGP
Prefix codes: E link, V node, T IP reacheable route, I Identifier
N local node, R remote node, L link, P prefix
L1/L2 ISIS level-1/level-2, O OSPF, a area-ID,
c confed-ID/ASN, b bgp-identifier, r router-ID,
i if-address, n nbr-address, o OSPF Route-type,
p IP-prefix, d designated router address, s ISO-ID
e [V][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0001.00]]/208
e [V][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0003.00]]/208
e [V][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0003.02]]/208
e [V][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0001.00]]/208
e [V][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]]/208
e [V][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.02]]/208
e [V][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]]/208
e [V][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0006.00]]/208
e [V][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0006.02]]/208
e [V][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0002.00]]/208
e [V][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0002.02]]/208
e [V][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.00]]/208
e [V][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.04]]/208
e [V][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0004.00]]/208
e [V][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0002.00]]/208
e [V][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]]/208
e [V][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.04]]/208
e [V][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0004.00]]/208
e [V][L2][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]]/208
e [E][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0001.00]][R[c100][b1.1.1.1][s0000.0000.0003.02]][L[i10.1.1.1][n10.1.1.2]]/328
e [E][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0003.00]][R[c100][b1.1.1.1][s0000.0000.0003.02]][L[i10.1.1.2][n10.1.1.2]]/328
e [E][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0003.02]][R[c100][b1.1.1.1][s0000.0000.0001.00]]/264
e [E][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0003.02]][R[c100][b1.1.1.1][s0000.0000.0003.00]]/264
e [E][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0001.00]][R[c100][b3.3.3.3][s0000.0000.0003.02]][L[i10.1.1.1][n10.1.1.2]]/328
e [E][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][R[c100][b3.3.3.3][s0000.0000.0003.02]][L[i10.1.1.2][n10.1.1.2]]/328
e [E][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.02]][R[c100][b3.3.3.3][s0000.0000.0001.00]]/264
e [E][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.02]][R[c100][b3.3.3.3][s0000.0000.0003.00]]/264
e [E][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][R[c200][b5.5.5.5][s0000.0000.0006.02]][L[i60.1.1.1][n60.1.1.2]]/328
e [E][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0006.00]][R[c200][b5.5.5.5][s0000.0000.0006.02]][L[i60.1.1.2][n60.1.1.2]]/328
e [E][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0006.02]][R[c200][b5.5.5.5][s0000.0000.0005.00]]/264
e [E][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0006.02]][R[c200][b5.5.5.5][s0000.0000.0006.00]]/264
e [E][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0002.00]][R[c100][b2.2.2.2][s0000.0000.0002.02]][L[i20.1.1.1][n20.1.1.1]]/328
e [E][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0002.02]][R[c100][b2.2.2.2][s0000.0000.0002.00]]/264
e [E][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0002.02]][R[c100][b2.2.2.2][s0000.0000.0003.00]]/264
e [E][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.00]][R[c100][b2.2.2.2][s0000.0000.0002.02]][L[i20.1.1.2][n20.1.1.1]]/328
e [E][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.00]][R[c100][b2.2.2.2][s0000.0000.0003.04]][L[i30.1.1.1][n30.1.1.1]]/328
e [E][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.04]][R[c100][b2.2.2.2][s0000.0000.0003.00]]/264
e [E][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.04]][R[c100][b2.2.2.2][s0000.0000.0004.00]]/264
e [E][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0004.00]][R[c100][b2.2.2.2][s0000.0000.0003.04]][L[i30.1.1.2][n30.1.1.1]]/328
e [E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0002.00]][R[c100][b3.3.3.3][s0000.0000.0002.02]][L[i20.1.1.1][n20.1.1.1]]/328
e [E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0002.02]][R[c100][b3.3.3.3][s0000.0000.0002.00]]/264
e [E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0002.02]][R[c100][b3.3.3.3][s0000.0000.0003.00]]/264
e [E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][R[c100][b3.3.3.3][s0000.0000.0002.02]][L[i20.1.1.2][n20.1.1.1]]/328
e [E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][R[c100][b3.3.3.3][s0000.0000.0003.04]][L[i30.1.1.1][n30.1.1.1]]/328
e [E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.04]][R[c100][b3.3.3.3][s0000.0000.0003.00]]/264
e [E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.04]][R[c100][b3.3.3.3][s0000.0000.0004.00]]/264
e [E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0004.00]][R[c100][b3.3.3.3][s0000.0000.0003.04]][L[i30.1.1.2][n30.1.1.1]]/328
e [T][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0001.00]][P[p10.1.1.0/24]]/240
e [T][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0001.00]][P[p1.1.1.1/32]]/248
e [T][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0003.00]][P[p10.1.1.0/24]]/240
e [T][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0003.00]][P[p20.1.1.0/24]]/240
e [T][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0003.00]][P[p30.1.1.0/24]]/240
e [T][L1][I0x1][N[c100][b1.1.1.1][s0000.0000.0003.00]][P[p3.3.3.3/32]]/248
e [T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0001.00]][P[p10.1.1.0/24]]/240
e [T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0001.00]][P[p1.1.1.1/32]]/248
e [T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p10.1.1.0/24]]/240
e [T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p20.1.1.0/24]]/240
e [T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p30.1.1.0/24]]/240
e [T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p3.3.3.3/32]]/248
e [T][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][P[p60.1.1.0/24]]/240
e [T][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][P[p5.5.5.5/32]]/248
e [T][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0006.00]][P[p60.1.1.0/24]]/240
e [T][L1][I0x1][N[c200][b5.5.5.5][s0000.0000.0006.00]][P[p6.6.6.6/32]]/248
e [T][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0002.00]][P[p20.1.1.0/24]]/240
e [T][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0002.00]][P[p2.2.2.2/32]]/248
e [T][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.00]][P[p10.1.1.0/24]]/240
e [T][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.00]][P[p20.1.1.0/24]]/240
e [T][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.00]][P[p30.1.1.0/24]]/240
e [T][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.00]][P[p1.1.1.1/32]]/248
e [T][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0003.00]][P[p3.3.3.3/32]]/248
e [T][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0004.00]][P[p30.1.1.0/24]]/240
e [T][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0004.00]][P[p4.4.4.4/32]]/248
e [T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0002.00]][P[p20.1.1.0/24]]/240
e [T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0002.00]][P[p2.2.2.2/32]]/248
e [T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p10.1.1.0/24]]/240
e [T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p20.1.1.0/24]]/240
e [T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p30.1.1.0/24]]/240
e [T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p1.1.1.1/32]]/248
e [T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p3.3.3.3/32]]/248
e [T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0004.00]][P[p30.1.1.0/24]]/240
e [T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0004.00]][P[p4.4.4.4/32]]/248
e [T][L2][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][P[p60.1.1.0/24]]/240
e [T][L2][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][P[p5.5.5.5/32]]/248
e [T][L2][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][P[p6.6.6.6/32]]/248
NLRIs, Total: 84, Node: 19, Link: 28, Prefix: 37
Note: Count of NLRIs may be different sometimes.
Validation for Particular NLRI
Controller#show bgp link-state link-state [V][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0002.00]]/208
BGP routing table entry for [V][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0002.00]]/208
Local
Received from 40.1.1.1
Link State:
Aux Router ID: 2.2.2.2
ISIS area address:49.0001
Range Size: 8000 Base SID: 16000 SR Algorithm: 0 SR Flags: I:1 V:0
Node flag bits: O:0 T:0 B:0 E:0
 
Controller#show bgp link-state link-state [E][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0004.00]][R[c100][b2.2.2.2][s0000.0000.0003.04]][L[i30.1.1.2][n30.1.1.1]]/328
BGP routing table entry for [E][L2][I0x1][N[c100][b2.2.2.2][s0000.0000.0004.00]][R[c100][b2.2.2.2][s0000.0000.0003.04]][L[i30.1.1.2][n30.1.1.1]]/328
Local
Received from 40.1.1.1
Link State:
Local Router ID: 4.4.4.4, Admin-group: Max link bw: 1250000000.00 ,Max reservable link bw: 1250000000.00
Max unreserved link bw:1250000000.00 1250000000.00 1250000000.00 1250000000.00 1250000000.00 1250000000.00 1250000000.00 1250000000.00
TE metric 10 , IGP metric 10
SR Flags: F:0 B:0 V:1 L:1 S:0 P:0
MT-ID: 0 Neighbor ID: 0000.0000.0003 LAN Adjacency SID: 24320
 
Controller#show bgp link-state link-state [T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0004.00]][P[p4.4.4.4/32]]/248
BGP routing table entry for [T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0004.00]][P[p4.4.4.4/32]]/248
Local
Received from 40.1.1.1
Link State:
Metric: 10 SID: 16700 SR Flags: R:0 N:1 P:0 E:0 V:1 L:0
SRMS Configuration
R5
 
R5(config)#segment-routing
Entering to SRMS.
R5(config-sr)#mapping-server
Entering to Mapping Server
R5(config-sr-ms)#prefix-sid-map address-family ipv4
Entering to prefix-to sid mapping.
R5(config-sr-ms-map-af4)#21.21.21.21/32 4545 attached
Configure SID for prefix.
R5(config-sr-ms-map-af4)#31.31.31.31/32 3535 attached
Configure SID for prefix.
R5(config-sr-ms-map-af4)#end
Exit from SRMS.
R5#configure terminal
Entering to Config mode.
R5(config)#router isis 1
Entering to router isis mode.
R5(config-router)#segment-routing prefix-sid-map advertise-local
Configure advertise-local for prefix-sid mapping.
R5(config-router)#exit
Exit from router isis mode
R3
 
R3(config)#segment-routing
Entering to SRMS.
R3(config-sr)#mapping-server
Entering to Mapping Server
R3(config-sr-ms)#prefix-sid-map address-family ipv4
Entering to prefix-to sid mapping.
R3(config-sr-ms-map-af4)#11.11.11.11/32 1111 range 3
Configure SID for prefix.
R3(config-sr-ms-map-af4)#12.12.12.12/32 6767 range 1
Configure SID for prefix.
R3(config-sr-ms-map-af4)#end
Exit from SRMS.
R3#configure terminal
Entering to Config mode.
R3(config)#router isis 1
Entering to router isis mode.
R3(config-router)#segment-routing prefix-sid-map advertise-local
Configure advertise-local for prefix-sid mapping.
R3(config-router)#exit
Exit from router isis mode
Validation on R3
ISIS Database Verbose
R3#show isis database verbose
Tag 1: VRF : default
IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R1.00-00 0x00000018 0xBFF4 1071 0/0/0
Area Address: 49.0000
NLPID: 0xCC
Hostname: R1
IP Address: 10.1.1.1
Router ID: 1.1.1.1
Router Cap: 1.1.1.1
SRGB Range: 3000 SRGB Base SID: 18000 I:1 V:0
SR-Algorithm:
Algorithm: 0
Metric: 10 IS-Extended R1.01
IPv4 Interface Address: 10.1.1.1
Neighbor IP Address: 10.1.1.1
Maximum Link Bandwidth: 10g
Reservable Bandwidth: 10g
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 10g
Unreserved Bandwidth at priority 1: 10g
Unreserved Bandwidth at priority 2: 10g
Unreserved Bandwidth at priority 3: 10g
Unreserved Bandwidth at priority 4: 10g
Unreserved Bandwidth at priority 5: 10g
Unreserved Bandwidth at priority 6: 10g
Unreserved Bandwidth at priority 7: 10g
TE-Default Metric: 10
System-ID: 0000.0000.0003 LAN Adjacency SID: 24960 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IP-Extended 10.1.1.0/30
Metric: 10 IP-Extended 1.1.1.1/32
Prefix-SID: index 100 R:0 N:1 P:0 E:0 V:0 L:0
R1.01-00 0x00000002 0xA129 1083 0/0/0
Metric: 0 IS-Extended R1.00
Metric: 0 IS-Extended R3.00
R1.02-00 0x00000012 0xC623 0 (328) 0/0/0
R3.00-00 * 0x00000116 0x5AAC 1194 1/0/0
Area Address: 49.0000
NLPID: 0xCC
Hostname: R3
IP Address: 10.1.1.2
Router ID: 3.3.3.3
Router Cap: 3.3.3.3
SRGB Range: 4801 SRGB Base SID: 17500 I:1 V:0
SR-Algorithm:
Algorithm: 0
SRMS-Preference: 128
Metric: 10 IS-Extended R1.01
IPv4 Interface Address: 10.1.1.2
Neighbor IP Address: 10.1.1.1
Maximum Link Bandwidth: 10g
Reservable Bandwidth: 10g
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 10g
Unreserved Bandwidth at priority 1: 10g
Unreserved Bandwidth at priority 2: 10g
Unreserved Bandwidth at priority 3: 10g
Unreserved Bandwidth at priority 4: 10g
Unreserved Bandwidth at priority 5: 10g
Unreserved Bandwidth at priority 6: 10g
Unreserved Bandwidth at priority 7: 10g
TE-Default Metric: 10
System-ID: 0000.0000.0001 LAN Adjacency SID: 24320 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IS-Extended 0000.0000.0004.01
IPv4 Interface Address: 30.1.1.1
Neighbor IP Address: 30.1.1.2
Maximum Link Bandwidth: 10g
Reservable Bandwidth: 10g
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 10g
Unreserved Bandwidth at priority 1: 10g
Unreserved Bandwidth at priority 2: 10g
Unreserved Bandwidth at priority 3: 10g
Unreserved Bandwidth at priority 4: 10g
Unreserved Bandwidth at priority 5: 10g
Unreserved Bandwidth at priority 6: 10g
Unreserved Bandwidth at priority 7: 10g
TE-Default Metric: 10
System-ID: 0000.0000.0004 LAN Adjacency SID: 24322 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IP-Extended 10.1.1.0/24
Metric: 10 IP-Extended 20.1.1.0/24
Metric: 10 IP-Extended 30.1.1.0/24
Metric: 10 IP-Extended 3.3.3.3/32
Prefix-SID: index 300 R:0 N:1 P:0 E:0 V:0 L:0
Metric: 20 IP-Extended 2.2.2.2/32
Prefix-SID: index 400 R:1 N:0 P:0 E:0 V:0 L:0
SID Binding: 11.11.11.11/32 F:0 M:0 S:0 D:0 A:0 Range:3
SID: Start:1111 Algorithm:0 R:0 N:0 P:0 E:0 V:0 L:0
SID Binding: 12.12.12.12/32 F:0 M:0 S:0 D:0 A:0 Range:1
SID: Start:6767 Algorithm:0 R:0 N:0 P:0 E:0 V:0 L:0
0000.0000.0004.00-00 0x00000016 0xAA99 1071 0/0/0
Area Address: 49.0000
NLPID: 0xCC
IP Address: 30.1.1.2
Router ID: 4.4.4.4
Router Cap: 4.4.4.4
SRGB Range: 7301 SRGB Base SID: 16500 I:1 V:0
SR-Algorithm:
Algorithm: 0
Metric: 10 IS-Extended 0000.0000.0004.01
IPv4 Interface Address: 30.1.1.2
Neighbor IP Address: 30.1.1.2
Maximum Link Bandwidth: 10g
Reservable Bandwidth: 10g
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 10g
Unreserved Bandwidth at priority 1: 10g
Unreserved Bandwidth at priority 2: 10g
Unreserved Bandwidth at priority 3: 10g
Unreserved Bandwidth at priority 4: 10g
Unreserved Bandwidth at priority 5: 10g
Unreserved Bandwidth at priority 6: 10g
Unreserved Bandwidth at priority 7: 10g
TE-Default Metric: 10
System-ID: 0000.0000.0003 LAN Adjacency SID: 24320 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IP-Extended 30.1.1.0/24
Metric: 10 IP-Extended 4.4.4.4/32
Prefix-SID: index 500 R:0 N:1 P:0 E:0 V:0 L:0
0000.0000.0004.01-00 0x00000001 0xA61F 395 0/0/0
Metric: 0 IS-Extended 0000.0000.0004.00
Metric: 0 IS-Extended R3.00
0000.0000.0004.02-00 0x00000010 0xB236 0 (365) 0/0/0
 
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
0000.0000.0002.00-00 0x0000001A 0xD622 1071 0/0/0
Area Address: 49.0001
NLPID: 0xCC
IP Address: 20.1.1.1
Router ID: 2.2.2.2
Router Cap: 2.2.2.2
SRGB Range: 3000 SRGB Base SID: 19000 I:1 V:0
SR-Algorithm:
Algorithm: 0
Metric: 10 IS-Extended 0000.0000.0002.01
IPv4 Interface Address: 20.1.1.1
Neighbor IP Address: 20.1.1.1
Maximum Link Bandwidth: 10g
Reservable Bandwidth: 10g
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 10g
Unreserved Bandwidth at priority 1: 10g
Unreserved Bandwidth at priority 2: 10g
Unreserved Bandwidth at priority 3: 10g
Unreserved Bandwidth at priority 4: 10g
Unreserved Bandwidth at priority 5: 10g
Unreserved Bandwidth at priority 6: 10g
Unreserved Bandwidth at priority 7: 10g
TE-Default Metric: 10
System-ID: 0000.0000.0003 LAN Adjacency SID: 24320 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IP-Extended 20.1.1.0/24
Metric: 10 IP-Extended 2.2.2.2/32
Prefix-SID: index 400 R:0 N:1 P:0 E:0 V:0 L:0
0000.0000.0002.01-00 0x00000002 0xA422 1191 0/0/0
Metric: 0 IS-Extended 0000.0000.0002.00
Metric: 0 IS-Extended R3.00
0000.0000.0002.03-00 0x00000013 0xB72D 0 (256) 0/0/0
R3.00-00 * 0x00000127 0x0123 1185 0/0/0
Area Address: 49.0000
NLPID: 0xCC
Hostname: R3
IP Address: 10.1.1.2
Router ID: 3.3.3.3
Router Cap: 3.3.3.3
SRGB Range: 4801 SRGB Base SID: 17500 I:1 V:0
SR-Algorithm:
Algorithm: 0
SRMS-Preference: 128
Metric: 10 IS-Extended 0000.0000.0002.01
IPv4 Interface Address: 20.1.1.2
Neighbor IP Address: 20.1.1.1
Maximum Link Bandwidth: 10g
Reservable Bandwidth: 10g
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 10g
Unreserved Bandwidth at priority 1: 10g
Unreserved Bandwidth at priority 2: 10g
Unreserved Bandwidth at priority 3: 10g
Unreserved Bandwidth at priority 4: 10g
Unreserved Bandwidth at priority 5: 10g
Unreserved Bandwidth at priority 6: 10g
Unreserved Bandwidth at priority 7: 10g
TE-Default Metric: 10
System-ID: 0000.0000.0002 LAN Adjacency SID: 24321 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IP-Extended 10.1.1.0/24
Metric: 10 IP-Extended 20.1.1.0/24
Metric: 20 IP-Extended 10.1.1.0/30
Metric: 10 IP-Extended 30.1.1.0/24
Metric: 10 IP-Extended 3.3.3.3/32
Prefix-SID: index 300 R:0 N:1 P:0 E:0 V:0 L:0
Metric: 20 IP-Extended 1.1.1.1/32
Prefix-SID: index 100 R:1 N:0 P:0 E:0 V:0 L:0
Metric: 20 IP-Extended 4.4.4.4/32
Prefix-SID: index 500 R:1 N:0 P:0 E:0 V:0 L:0
SID Binding: 11.11.11.11/32 F:0 M:0 S:0 D:0 A:0 Range:3
SID: Start:1111 Algorithm:0 R:0 N:0 P:0 E:0 V:0 L:0
SID Binding: 12.12.12.12/32 F:0 M:0 S:0 D:0 A:0 Range:1
SID: Start:6767 Algorithm:0 R:0 N:0 P:0 E:0 V:0 L:0
Validation for NLRI count
R3#sho bgp link-state link-state count
-------------------------------------------
Total NLRIs : 96
Node NLRIs : 19
Link NLRIs : 28
Prefix NLRIs : 49
-------------------------------------------
Note: Count of NLRIs may be different sometimes.
R3#sho bgp link-state link-state self-originate
BGP router identifier 3.3.3.3, local AS number 100
Origin codes: i - IGP, e - EGP
Prefix codes: E link, V node, T IP reacheable route, I Identifier
N local node, R remote node, L link, P prefix
L1/L2 ISIS level-1/level-2, O OSPF, a area-ID,
c confed-ID/ASN, b bgp-identifier, r router-ID,
i if-address, n nbr-address, o OSPF Route-type,
p IP-prefix, d designated router address, s ISO-ID
[V][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0001.00]]/208
[V][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]]/208
[V][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.02]]/208
[V][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0002.00]]/208
[V][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]]/208
[V][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.04]]/208
[V][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0004.00]]/208
[E][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0001.00]][R[c100][b3.3.3.3][s0000.0000.0003.02]][L[i10.1.1.1][n10.1.1.2]]/328
[E][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][R[c100][b3.3.3.3][s0000.0000.0003.02]][L[i10.1.1.2][n10.1.1.2]]/328
[E][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.02]][R[c100][b3.3.3.3][s0000.0000.0001.00]]/264
[E][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.02]][R[c100][b3.3.3.3][s0000.0000.0003.00]]/264
[E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0002.00]][R[c100][b3.3.3.3][s0000.0000.0002.02]][L[i20.1.1.1][n20.1.1.1]]/328
[E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0002.02]][R[c100][b3.3.3.3][s0000.0000.0002.00]]/264
[E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0002.02]][R[c100][b3.3.3.3][s0000.0000.0003.00]]/264
[E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][R[c100][b3.3.3.3][s0000.0000.0002.02]][L[i20.1.1.2][n20.1.1.1]]/328
[E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][R[c100][b3.3.3.3][s0000.0000.0003.04]][L[i30.1.1.1][n30.1.1.1]]/328
[E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.04]][R[c100][b3.3.3.3][s0000.0000.0003.00]]/264
[E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.04]][R[c100][b3.3.3.3][s0000.0000.0004.00]]/264
[E][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0004.00]][R[c100][b3.3.3.3][s0000.0000.0003.04]][L[i30.1.1.2][n30.1.1.1]]/328
[T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0001.00]][P[p10.1.1.0/24]]/240
[T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0001.00]][P[p1.1.1.1/32]]/248
[T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p10.1.1.0/24]]/240
[T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p20.1.1.0/24]]/240
[T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p30.1.1.0/24]]/240
[T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p3.3.3.3/32]]/248
[T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p11.11.11.11/32]]/248
[T][L1][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p12.12.12.12/32]]/248
[T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0002.00]][P[p20.1.1.0/24]]/240
[T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0002.00]][P[p2.2.2.2/32]]/248
[T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p10.1.1.0/24]]/240
[T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p20.1.1.0/24]]/240
[T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p30.1.1.0/24]]/240
[T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p1.1.1.1/32]]/248
[T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p3.3.3.3/32]]/248
[T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p11.11.11.11/32]]/248
[T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p12.12.12.12/32]]/248
[T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0004.00]][P[p30.1.1.0/24]]/240
[T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0004.00]][P[p4.4.4.4/32]]/248
NLRIs, Total: 38, Node: 7, Link: 12, Prefix: 19
Note: Count of NLRIs may be different sometimes.
Note: Here the total number of NLRI increases because of prefixes configured in SRMS.
Validation for Particular NLRI
Here we verify the prefix-NLRIs for prefixes configured in SRMS.
R3#show bgp link-state link-state [T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p11.11.11.11/32]]/248
BGP routing table entry for [T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p11.11.11.11/32]]/248
Local
Received from IGP
Link State:
SRMS SID: Start: 1111 Range: 3 Algorithm: 0 SR Flags: F:0 M:0 S:0 D:0 A:0
SR Flags: R:0 N:0 P:0 E:0 V:0 L:0
 
R3#show bgp li li [T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p12.12.12.12/32]]/248
BGP routing table entry for [T][L2][I0x1][N[c100][b3.3.3.3][s0000.0000.0003.00]][P[p12.12.12.12/32]]/248
Local
Received from IGP
Link State:
SRMS SID: Start: 6767 Range: 1 Algorithm: 0 SR Flags: F:0 M:0 S:0 D:0 A:0
SR Flags: R:0 N:0 P:0 E:0 V:0 L:0
 
R3#show bgp link-state link-state [T][L2][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][P[p21.21.21.21/32]]/248
BGP routing table entry for [T][L2][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][P[p21.21.21.21/32]]/248
Local
Received from 40.1.1.2
Link State:
SRMS SID: Start: 4545 Range: 1 Algorithm: 0 SR Flags: F:0 M:0 S:0 D:0 A:1
SR Flags: R:0 N:0 P:0 E:0 V:0 L:0
 
R3#show bgp link-state link-state [T][L2][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][P[p31.31.31.31/32]]/248
BGP routing table entry for [T][L2][I0x1][N[c200][b5.5.5.5][s0000.0000.0005.00]][P[p31.31.31.31/32]]/248
Local
Received from 40.1.1.2
Link State:
SRMS SID: Start: 3535 Range: 1 Algorithm: 0 SR Flags: F:0 M:0 S:0 D:0 A:1
SR Flags: R:0 N:0 P:0 E:0 V:0 L:0