OcNOS-SP : Layer 3 Guide : Routing Information Protocol Command Reference : Routing Information Protocol Commands
Routing Information Protocol Commands
This chapter provides an alphabetized reference for each of the Routing Information Protocol (RIP) commands, which support IPv4. It includes the following commands:
key-id
route
accept-lifetime
Use this command to specify the time period during which the authentication key on a key chain is received as valid.
Use the no option with this command to disable it.
See Appendix 4, Routing Information Protocol Authentication for information on how this command is related to the other authentication commands.
Command Syntax
accept-lifetime HH:MM:SS MONTH <01-31> <1993-2035> HH:MM:SS MONTH <01-31> <1993-2035>
accept-lifetime HH:MM:SS MONTH <01-31> <1993-2035> infinite
accept-lifetime HH:MM:SS MONTH <01-31> <1993-2035> duration <1-2147483646>
no accept-lifetime
Parameters
HH:MM:SS
Specify the start time of accept-lifetime in hours, minutes and seconds.
<01-31>
Specify the day of the month to start. If the day is a single-digit, the leading 0 must be added, example: 01, 02, 03, etc.
MONTH
Specify the month of the year to start as the first three letters of the month with first letter in upper case, for example, Jan. (case sensitive).
<1993-2035>
Specify the year to start.
HH:MM:SS
Specify the time when accept-lifetime expires in hours, minutes and seconds.
<01-31>
Specify the day of the month to end. If the day is a single-digit, the leading 0 must be added, example: 01, 02, 03, etc.
MONTH
Specify the month of the year to end as the first three letters of the month with first letter in caps, for example, Jan. (case sensitive).
<1993-2035>
Specify the year to expire.
duration
Specify the duration of the key in seconds <1-2147483646>.
infinite
Specify the end time to never expire.
Default
None
Command Mode
Keychain-key mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
The following example shows the setting of accept-lifetime for key-id 1 on the key chain named mychain.
#configure terminal
(config)#key chain mychain
(config-keychain)#key-id 1
(config-keychain-key)#accept-lifetime 03:03:01 Dec 30 2004 04:04:02 Oct 06 2006
 
(config)#key chain mychain
(config-keychain)#key-id 1
(config-keychain-key)#no accept-lifetime
 
 
cisco-metric-behavior
Use this command to enable the metric update consistent with Cisco.
Use either the no or disable parameter with this command to disable this feature.
Command Syntax
cisco-metric-behavior (enable|disable)
no cisco-metric-behavior
Parameters
enable
Enable updating the metric consistent with Cisco.
disable
Disable updating the metric consistent with Cisco.
Default
By default, the Cisco metric-behavior is disabled.
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
This example shows how to enable the metric update behavior to be consistent with Cisco in the Router mode.
#configure terminal
(config)#router rip
(config-router)#cisco-metric-behavior enable
 
clear ip rip route
Use this command to clear specific data from the RIP routing tables.
Using this command with the all parameter, clears the RIP table of all the routes. If you do not want that your RIP network to be deleted, use the redistribute connected command and make the RIP network a connected route. To delete the RIP routes learned from neighbor and also keep the RIP network intact, use the rip (clear ip rip route rip) parameter with this command.
Command Syntax
clear ip rip route (A.B.C.D/M|rip|kernel|connected|static|ospf|isis|bgp|all)
Parameters
A.B.C.D/M
Removes entries which exactly match this destination address from RIP routing table.
bgp
Removes only BGP routes from the RIP routing table.
connected
Removes entries for connected routes from the RIP routing table.
isis
Removes only IS-IS routes from the RIP routing table
kernel
Removes kernel entries from the RIP routing table.
ospf
Removes only OSPF routes from the RIP routing table.
rip
Removes only RIP routes from the RIP routing table.
static
Removes static entries from the RIP routing table.
all
Removes the entire RIP routing table.
Default
None
Command Mode
Privileged Exec mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#clear ip rip route 10.0.0.0/8
#clear ip rip route ospf
clear ip rip route vrf NAME
Use this command to clear all IPv4 RIP VRF route or any specific prefix RIP VRF route of any particular VRF name.
Command Syntax
clear ip rip route vrf NAME (*|A.B.C.D/M)
Parameters
A.B.C.D/M
Removes entries with the prefix specified.
*
Removes all routes
NAME
VPN Routing or Forwarding instance name
Default
None
Command Mode
Privileged Exec mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#clear ip rip route vrf myVRF *
clear ip rip statistics
Use this command to clear an IPv4 RIP statistics.
Command Syntax
clear ip rip statistics (IFNAME |)
Parameters
IFNAME
Removes entries from the interface.
Default
None
Command Mode
Privileged Exec mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#clear ip rip statistics
 
debug rip
Use this command to specify the options for the displayed debugging information for RIP events, RIP packets and RIP NSM.
Use the no parameter with this command to disable all debugging. The undebug alias command can also be used.
Command Syntax
debug rip (all|events|packet (recv|send|)|packet detail|nsm|rib|bfd|)
no debug rip (all|events|packet (recv|send|)|packet detail|nsm|rib|bfd|)
undebug rip (all|)
undebug rip bfd
undebug rip events
undebug rip nsm
undebug rip packet (recv|send|) (detail|)
undebug rip rib
Parameters
all
Debug all RIP information.
bfd
Debug all RIP and BFD information.
events
Debug RIP events.
nsm
Debug RIP and NSM communications.
packet
Debug RIP packets, only
recv
Debug received packets.
rib
Debug RIP and RIB communications.
send
Debug sent packets.
detail
Display detailed information for the sent or received packet.
Default
Disabled
Command Mode
Privileged Exec mode and Configure mode
Applicability
This command was introduced before OcNOS version 1.3 and modified in OcNOS version 6.1.0.
Examples
The following example specifies the options for the displayed debugging information in Configure mode prompt.
#configure terminal
(config)#debug rip events
(config)#debug rip packet send detail
(config)#debug rip nsm
 
The following example shows to disable all debugging in Privileged Exec mode prompt.
#undebug rip events
#undebug rip packet send detail
#undebug rip nsm
default-information originate
Use this command to add default routes to the RIP updates.
Use the no parameter with this command to disable this feature.
Command Syntax
default-information originate (always|) (route-map WORD|)
no default-information originate
Parameters
always
Always advertise default route
route map
Route map reference
WORD
Pointer to route-map entries
Default
Disabled
Command Mode*
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#configure terminal
(config)#router rip
(config-router)#default-information originate route-map pmap
 
default-metric
Use this command to specify the metrics to be assigned to redistributed routers.
This command is used in conjunction with the redistribute command to make the routing protocol use the specified metric value for all redistributed routes. A default metric is useful in redistributing routes with incompatible metrics. Every protocol has different metrics and can not be compared directly. Default metric provides the standard to compare. All routes that are redistributed will use the default metric.
Use the no parameter with this command to disable this feature.
Command Syntax
default-metric <1-15>
no default-metric
Parameter
<1-15>
Specify the default metric.
Default
By default, the metric value is set to 1.
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
This example assigns the cost of 10 to the OSPF routes which are redistributed into RIP.
#configure terminal
(config)#router rip
(config-router)#redistribute ospf
(config-router)#default-metric 10
 
distance
Use this command to set the administrative distance. The administrative distance is a feature used by the routers to select the path when there are two or more different routes to the same destination from two different routing protocols. A smaller administrative distance indicating a more reliable protocol.
Use the no parameter with this command to disable this function.
Command Syntax
distance <1-255>
distance <1-255> A.B.C.D/M (WORD|)
no distance
no distance A.B.C.D/M
Parameters
<1-255>
Specify the administrative distance value.
A.B.C.D./M
Specify the network prefix and length
WORD
Specify the access list name.
Default
By default, the administrative distance is 120.
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3 and modified in OcNOS version 6.1.0.
Examples
#configure terminal
(config)#router rip
(config-router)#distance 8 10.0.0.0/8 mylist
 
distribute-list
Use this command to filter incoming or outgoing route updates using an access list or a prefix list. You can filter out incoming or outgoing route updates using an access list or a prefix list. If you do not specify the name of the interface, the filter will be applied to all the interfaces.
Use the no parameter with this command to disable this feature.
Command Syntax
distribute-list WORD (in|out) (IFNAME|)
distribute-list prefix WORD (in|out) (IFNAME|)
no distribute-list (in|out) (IFNAME|)
no distribute-list prefix (in|out) (IFNAME|)
Parameters
WORD
Specify the IPv4 access-list number or name to use.
prefix
Filter prefixes in routing updates.
WORD
Specify the name of the IPv4 prefix-list to use.
in
Filter incoming routing updates.
out
Filter outgoing routing updates.
IFNAME
Specify the name of the interface on which distribute-list applies.
Default
Disabled
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3 and modified in OcNOS version 6.1.0.
Example
#configure terminal
(config)#router rip
(config-router)#distribute-list prefix myfilter in eth0
 
 
ip rip authentication key-chain
Use this command to enable RIPv2 authentication on an interface and specify the name of the key chain to be used. If you do not configure a key chain results in no authentication.
Use the no parameter with this command to disable this function.
See Appendix 4, Routing Information Protocol Authentication for information on how this command is related to the other authentication commands.
Command Syntax
ip rip authentication key-chain LINE
no ip rip authentication key-chain (LINE|)
Parameters
LINE
Specify the name of the key chain.
Default
If you do not configure a key chain, authentication is not used.
Command Mode
Interface mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
In the following example, interface eth0 is configured key-chain authentication and the name is specified as mykey. This name is used to enter the key-chain mode to specify the password. See the key command.
#configure terminal
(config)#interface eth0
(config-if)#ip rip authentication key-chain mykey
ip rip authentication mode
Use this command to specify the type of authentication mode used for RIP v2 packets.
Use the no parameter with this command to restore clear text authentication.
See Appendix 4, Routing Information Protocol Authentication for information on how this command is related to the other authentication commands.
Command Syntax
ip rip authentication mode md5
ip rip authentication mode text
no ip rip authentication mode
Parameters
md5
Uses the keyed MD5 authentication algorithm.
text
Specify the clear text or simple password authentication.
Default
No authentication mode is enabled by default. But, when any authentication key (string or key-chain) is configured, text authentication mode is enabled by default.
Command Mode
Interface mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
The following example shows md5 authentication configured on the eth1 interface, ensuring authentication of RIP packets received.
#configure terminal
(config)#interface eth1
(config-if)#ip rip authentication mode md5
ip rip authentication string
Use this command to specify the authentication string or password used by a key.
You can configure authentication for a single key or multiple keys at different times. Use this command to specify password for a single key on an interface.
Use the no parameter with this command to disable this feature.
See Appendix 4, Routing Information Protocol Authentication for how this command is related to the other authentication commands.
Command Syntax
ip rip authentication string LINE
no ip rip authentication string
Parameters
LINE
Specify the authentication string or password used by a key.
Default
None
Command Mode
Interface mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
In the following example, the interface eth1 is configured to have an authentication string as guest, any receiving RIP packet in that interface should have the same string as password.
#configure terminal
(config)#interface eth1
(config-if)#ip rip authentication string guest
ip rip receive-packet
Use this command to configure the interface to enable the reception of RIP packets.
Use the no parameter with this command to disable this feature.
Command Syntax
ip rip receive-packet
no ip rip receive-packet
Parameters
None
Default
Receive-packet is enabled
Command Mode
Interface mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
This example shows packet receiving being turned on for interface eth0.
#configure terminal
(config)#interface eth0
(config-if)#ip rip receive-packet
ip rip receive version
Use this command to receive specified version of RIP packets on an interface basis using version control, and override the setting of the version command.
Use the no form of this command to use the setting established by the version command.
Command Syntax
ip rip receive version (1|2)
ip rip receive version 1 2
no ip rip receive version
Parameters
1
Specify acceptance of RIP version 1 packets on the interface.
2
Specify acceptance of RIP version 2 packets on the interface.
1 2
Specify acceptance of RIP version 1 and version 2 packets on the interface.
Default
Version 2
Command Mode
Interface mode
Applicability
This command was introduced before OcNOS version 1.3 and modified in OcNOS version 6.1.0.
Examples
In the following example, interface eth1 in configured to receive both RIP version 1 and 2 packets.
#configure terminal
(config)#interface eth1
(config-if)#ip rip receive version 1 2
ip rip send-packet
Use this command to enable sending RIP packets through the current interface.
Use the no parameter with this command to disable this feature.
Command Syntax
ip rip send-packet
no ip rip send-packet
Parameters
None
Default
Send packet is enabled.
Command Mode
Interface mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
This example shows packet sending being turned on for interface eth0.
#configure terminal
(config)#interface eth0
(config-if)#ip rip send-packet
ip rip send version
Use this command to send RIP packets on an interface using version control. In addition to version 1 and version 2, compatible version packets can be specified. With the parameter 1-compatible, a version 2 RIP interface will broadcast the packets instead of multicasting them.
This command applies to a specific interface and overrides any the version specified by the version command.
Use the no parameter with this command to use the global RIP version control rules.
Command Syntax
ip rip send version (1|2|1-compatible)
ip rip send version 1 2
ino ip rip send version
Parameters
1
Specify sending RIP version 1 packets out of an interface.
2
Specify sending RIP version 2 packets out of an interface.
1 2
Specify acceptance of RIP version 1 and version 2 packets on the interface.
1-compatible
Specify sending RIP version 1 compatible packets from a version 2 RIP interface.
Default
Version 2
Command Mode
Interface mode
Applicability
This command was introduced before OcNOS version 1.3 and modified in OcNOS version 6.1.0.
Examples
In the following example, interface eth1 is configured to send both RIP version 1 and 2 packets.
#configure terminal
(config)#interface eth1
(config-if)#ip rip send version 1 2
 
ip rip split-horizon
Use this command to perform the split-horizon action on the interface
This command helps avoid including routes in updates sent to the same gateway from which they were learned. Using the split horizon command omits routes learned from one neighbor, in updates sent to that neighbor. Using the poisoned parameter with this command includes such routes in updates, but sets their metrics to infinity. Thus, advertising that these routes are not reachable.
Use the no parameter with this command to disable this function.
Command Syntax
ip rip split-horizon
ip rip split-horizon poisoned
no ip rip split-horizon
Parameter
poisoned
Performs split-horizon with poisoned reverse.
Default
Split horizon poisoned
Command Mode
Interface mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#configure terminal
(config)#interface eth0
(config-if)#ip rip split-horizon poisoned
key-id
Use this command to manage, add or delete authentication keys in a key-chain. This command allows you to enter the Keychain-key mode to set a password for the key.
Use the no option with this command to disable this feature.
See Appendix 4, Routing Information Protocol Authentication for information on how this command is related to the other authentication commands.
Command Syntax
key-id <0-2147483647>
no key-id <0-2147483647>
Parameters
<0-2147483647>
Specify a key identifier.
Default
By default, RIP uses level-1-2 if there is no Level-2 instance nor a Level-1-2 instance. Otherwise, it uses level-1.
Command Mode
Keychain mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
In the following example, the password for key-id 1 in the key chain named mychain is set to prime:
#configure terminal
(config)#key chain mychain
(config-keychain)#key-id 1
(config-keychain-key)#key-string prime
 
(config-keychain)#key-id 1
(config-keychain-key)#no key-string
 
key chain
Use this command to enter the key chain management mode and to configure a key chain with a key chain name. This command allows you to enter the keychain mode to specify keys on this key chain.
Use the no option with this command to disable this feature.
See Appendix 4, Routing Information Protocol Authentication for information on how this command is related to the other authentication commands.
Command Syntax
key chain WORD
no key chain WORD
Parameter
WORD
Specify the name of the key chain to manage.
Default
None
Command Mode
Configure mode and Keychain mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
The following example shows the creation of a key chain named mychain and the change into keychain mode prompt.
#configure terminal
(config)#key chain mychain
(config-keychain)#
 
The following example shows the creation of a key chain named mykeychain3 in the keychain mode and the addition of an authentication key key-id 10 in the same mode.
(config-keychain)#key chain mykeychain3
(config-keychain)#key-id 10
(config-keychain-key)#
key-string
Use this command to define a password in plain-text to be used by a key.
The password is stored as encrypted, and is displayed in encrypted text when show running-config command is executed.
Use the no parameter with this command to disable this feature.
See Appendix 4, Routing Information Protocol Authentication for information on how this command is related to the other authentication commands.
Command Syntax
key-string WORD
no key-string
Parameters
WORD
Specify a string of characters to be used as a password by the key.
Default
Disabled
Command Mode
Keychain-key mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
In the following example, the password for key-id 1 in the key chain named mychain is set to prime:
#configure terminal
(config)#key chain mychain
(config-keychain)#key-id 1
(config-keychain-key)#key-string prime
 
(config-keychain)#key-id 1
(config-keychain-key)#no key-string
key-string encrypted
Use this command to define a password in its encrypted format to be used by a key.
Use the no parameter with this command to disable this feature
Command Syntax
key-string encrypted WORD
no key-string encrypted
Parameters
WORD
Specify the encrypted string of characters to be used as a password by the key. The length of this string should be between 18-162 characters.
Default
By default, password is not configured.
Command Mode
Keychain mode and Keychain-key mode.
Applicability
This command was introduced in OcNOS version 4.1.
Examples:
In the following example, the encrypted password for key-id 1 in the key chain named mykeychain is set to 0xd6c50b442de47f70 (equivalent to "mychain" in plain-text):
#configure terminal
(config)#key chain mykeychain
(config-keychain)#key-id 1
(config-keychain-key)#key-string encrypted 0xd6c50b442de47f70
(config-keychain)#key-id 1
(config-keychain-key)#no key-string
maximum-prefix
Use this command to configure the maximum prefix.
Use the no parameter with this command to disable the limiting of the number of RIP routes in the routing table.
Command Syntax
maximum-prefix <1-65535> (<1-100>|)
no maximum-prefix
Parameters
<1-65535>
The maximum number of RIP routes allowed.
<1-100>
Percentage of maximum routes to generate a warning. The default threshold is 75%.
Default
The default maximum-prefix threshold is 75%.
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#configure terminal
(config)#router rip
(config-router)#maximum-prefix 150
neighbor
Use this command to specify a neighbor router. It is used for each connected point-to-point link. This command to exchanges non-broadcast routing information. It can be used multiple times for additional neighbors.
Passive-interface command disables sending routing updates on an interface. Use the neighbor command in conjunction with the passive-interface command to send routing updates to specific neighbors.
Use the no parameter with this command to disable the specific router.
Command Syntax
neighbor A.B.C.D
no neighbor A.B.C.D
Parameter
A.B.C.D
An IP address of a neighboring router with which the routing information will be exchanged.
Default
Disabled
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#configure terminal
(config)#router rip
(config-router)#neighbor 10.7.1.12
 
network
Use this command to specify a network as one that runs RIP. This command specifies the networks to which routing updates will be sent and received. If a network is not specified, the interfaces in that network will not be advertised in any RIP update.
Use the no parameter with this command to remove the specified network as one that runs RIP.
Command Syntax
network A.B.C.D/M
network IFNAME
no network A.B.C.D/M
no network IFNAME
Parameters
A.B.C.D/M
The IP address prefix and length of this IP network.
IFNAME
Alphanumeric string that defines the interface name.
Default
Disabled
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#configure terminal
(config)#router rip
(config-router)#network 10.0.0.0/8
(config-router)#network eth0
 
 
offset-list
Use this command to add an offset to in and out metrics to routes learned through RIP. This command specifies the offset value that is added to the routing metric. When the networks match the access list the offset is applied to the metrics. No change occurs if the offset value is zero.
Use the no parameter with this command to remove the offset list.
Command Syntax
offset-list WORD (in|out) (IFNAME|)
no offset-list WORD (in|out) (IFNAME|)
Parameters
WORD
Specify the access-list number or names to apply.
in
Indicates the access list will be used for metrics of incoming advertised routes.
out
Indicates the access list will be used for metrics of outgoing advertised routes.
IFNAME
An alphanumeric string that specifies the interface to match.
Default
The default offset value is the interface metric value which is defined by the operating system.
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3 and modified in OcNOS version 6.1.0.
Examples
In this example the router examines the RIP updates being sent out from interface eth0 and adds 16 hops to the routes matching the ip addresses specified in the access list accesslist1.
#configure terminal
(config)#router rip
(config-router)#offset-list accesslist1 in eth0
 
 
passive-interface
Use this command to block RIP broadcast on the interface.
Use the no parameter with this command to disable this function.
Command Syntax
passive-interface IFNAME
no passive-interface IFNAME
Parameters
IFNAME
Specify the interface name.
Default
Disabled
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#configure terminal
(config)#router rip
(config-router)#passive-interface eth0
 
recv-buffer-size
Use this command to run-time configure the RIP UDP receive-buffer size.
Use the no parameter with this command to return to the default value.
Command Syntax
recv-buffer-size <8192-2147483647>
no recv-buffer-size
Parameters
<8192-2147483647>
 
Specify the RIP UDP receive buffer size value.
Default
The default value of the RIP UDP receive-buffer size is 32768.
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#configure terminal
(config)#router rip
(config-router)#recv-buffer-size 150000
 
redistribute
Use this command to redistribute information from other routing protocols.
Use the no parameter with this command to disable this function.
Command Syntax
redistribute (kernel|connected|static|ospf|isis|bgp)
redistribute (kernel|connected|static|ospf|isis|bgp) metric <0-16>
redistribute (kernel|connected|static|ospf|isis|bgp) route-map WORD
redistribute (kernel|connected|static|ospf|isis|bgp) metric <0-16> route-map WORD
no redistribute (kernel|connected|static|ospf|isis|bgp)
no redistribute (kernel|connected|static|ospf|isis|bgp) metric <0-16>
no redistribute (kernel|connected|static|ospf|isis|bgp) route-map WORD
no redistribute (kernel|connected|static|ospf|isis|bgp) metric <0-16> route-map WORD
Parameters
bgp
Redistribute from BGP routes
connected
Redistribute from connected routes
isis
Redistribute from ISO IS-IS routes
kernel
Redistribute from kernel routes
ospf
Redistribute from OSPFv3 routes
static
Redistribute from static routes
metric
Metric value
<0–16>
Specify a metric value
route-map
Route map reference
WORD
Specify name of the route-map
Default
Disabled
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#configure terminal
(config)#router rip
(config-router)#redistribute kernel
 
 
#configure terminal
(config)#router rip
(config-router)#redistribute kernel route-map myroutemap
route
Use this command to configure static RIP routes.
Use the no parameter with this command to disable this function.
Command Syntax
route A.B.C.D/M
no route A.B.C.D/M
Parameter
A.B.C.D/M
Specify the IP address prefix and length.
Default
No route is added.
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
Use this command to add a static RIP route. This command is used most often for debugging purposes and does not show up in the kernel routing table. After adding the RIP route, it can be checked in the RIP routing table.
#configure terminal
(config)#router rip
(config-router)#version 1
(config-router)#network 10.10.10.0/24
(config-router)#network 10.10.11.0/24
(config-router)#neighbor 10.10.10.10
(config-router)#route 10.10.10.0/24
 
(config-router)#version 1
(config-router)#network 10.10.10.0/24
(config-router)#network 10.10.11.0/24
(config-router)#no route 10.10.10.0/24
 
router rip
Use this global command to enable a RIP routing process.
Use the no parameter with this command to disable RIP routing.
Command Syntax
router rip
no router rip
Parameter
None
Default
Disabled
Command Mode
Configure mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
This command is used to begin the RIP routing process.
#configure terminal
(config)#router rip
(config-router)#version 1
(config-router)#network 10.10.10.0/24
(config-router)#network 10.10.11.0/24
(config-router)#neighbor 10.10.10.10
send-lifetime
Use this command to specify the time period during which the authentication key on a key chain can be sent.
Use the no parameter with this command to negate this command.
Command Syntax
send-lifetime HH:MM:SS MONTH <01-31> <1993-2035> HH:MM:SS MONTH <01-31> <1993-2035>
send-lifetime HH:MM:SS MONTH <01-31> <1993-2035> infinite
send-lifetime HH:MM:SS MONTH <01-31> <1993-2035> duration <1-2147483646>
no send-lifetime
Parameters
HH:MM:SS
Specify the start time of send-lifetime in hours, minutes and seconds.
<01-31>
Specify the day of the month to start. If the day is a single-digit, the leading 0 must be added, example: 01, 02, 03, etc.
MONTH
Specify the month of the year to start as the first three letters of the month with first letter in upper case, for example, Jan. (case sensitive)
<1993-2035>
Specify the year to start.
HH:MM:SS
Specify the time when send-lifetime expires in hours, minutes and seconds.
<01-31>
Specify the day of the month to end. If the day is a single-digit, the leading 0 must be added, example: 01, 02, 03, etc.
MONTH
Specify the month of the year to end as the first three letters of the month with first letter in caps, for example, Jan. (case sensitive)
<1993-2035>
Specify the year to expire.
duration
Specify the duration of the key in seconds <1-2147483646>.
infinite
Specify the end time to never expire.
Default
Disabled
Command Mode
Keychain-key mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
The following example shows the setting of send-lifetime for key-id 1 on the key chain named mychain:
#configure terminal
(config)#key chain mychain
(config-keychain)#key-id 1
(config-keychain-key)#send-lifetime 03:03:01 Jan 03 2004 04:04:02 Dec 06 2006
show debugging rip
Use this command to display the RIP debugging status for these debugging options: nsm debugging, RIP event debugging, RIP packet debugging and RIP nsm debugging.
Command Syntax
show debugging rip
Parameters
None
Default
None
Command Mode
Exec mode and Privileged Exec mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
#show debugging rip
R2#show debugging rip
RIP debugging status:
RIP event debugging is on
RIP packet detail debugging is on
RIP RIB debugging is on
RIP NSM debugging is on
RIP BFD debugging is on
 
R2#
show ip protocols rip
Use this command to display RIP process parameters and statistics.
Command Syntax
show ip protocols
show ip protocols rip
Parameters
None
Default
None
Command Mode
Exec mode and Privileged Exec mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
This is an example of the output from the show ip protocols rip command:
#show ip protocols rip
Routing Protocol is "rip"
Sending updates every 30 seconds with +/-50%, next due in 12 seconds
Timeout after 180 seconds, garbage collect after 120 seconds
Outgoing update filter list for all interface is not set
Incoming update filter list for all interface is not set
Default redistribution metric is 1
Redistributing: connected static
Default version control: send version 2, receive version 2
Interface Send Recv Key-chain
eth0 2 2
Routing for Networks:
10.10.0.0/24
Routing Information Sources:
Gateway BadPackets BadRoutes Distance Last Update
Distance: (default is 120)
#
 
Figure 1-74 Explains the show command output details.
Table 1-74: Show ip protocols output details
Field
Description
Routing Protocol is "rip"
Specifies the routing protocol used.
Sending updates every 30 seconds
Specifies the time between sending updates.
Next due in 12 seconds
Precisely when the next update is due to be sent.
Timeout after 180 seconds
Specifies the value of the timeout parameter.
Redistributing
Lists the protocol that is being redistributed.
Routing for Networks
Specifies the networks for which the routing process is currently injecting routes.
Routing Information Sources
Lists all the routing sources the IP Infusion software is using to build its routing table.
 
show ip rip
Use this command to show RIP routes.
Command Syntax
show ip rip (database|)
Parameters
database
Specify to display information about the IP RIP database.
Default
None
Command Mode
Exec mode and Privileged Exec mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
The following output displays the RIP routing table with the destination network, nexthop and metric to reach it.
#show ip rip
Codes: R - RIP, K - Kernel, C - Connected, S - Static, O - OSPF, I - IS-IS,
B - BGP
Network Next Hop Metric From If Time
K 0.0.0.0/0 10.0.1.1 16 eth1 01:58
C 10.0.1.0/24 1 eth1
S 10.10.10.0/24 1 eth0
C 10.10.11.0/24 1 eth0
S 192.168.101.0/24 1 eth0
R 192.192.192.0/24 1 --
 
Table 1-75 shows the status codes displayed at the start of a route entry.
Table 1-75: Status codes
Status Code
Meaning
Description
R
RIP
RIP prevents routing loops by implementing a limit on the number of hops allowed in a path from source to destination.
K
Kernel
Kernel is central component of operating system.
C
Connected
Redistribute from locally connected networks.
S
Static
Connections in a static network are fixed links, while connections in a dynamic network are established on the fly as needed.
O
OSPF
Open Shortest Path First (OSPF) is a routing protocol for Internet Protocol (IP) networks.
I
IS-IS
Intermediate System to Intermediate System (IS-IS) is a routing protocol designed to move information efficiently within a host network.
B
BGP
BGP makes routing decisions based on paths, rules or network policies configured by a network administrator.
 
 
show ip rip interface
Use this command to display information about RIP interfaces. You can specify an interface name to display information about a specific interface.
Command Syntax
show ip rip interface (IFNAME|)
Parameters
IFNAME
Name of the interface for which information is to be displayed.
Default
None
Command Mode
Exec mode and Privileged Exec mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
The following output displays the RIP routing table with the destination network, nexthop and metric to reach it.
#show ip rip interface
lo is up, line protocol is up
RIP is not enabled on this interface
eth0 is up, line protocol is up
RIP is not enabled on this interface
eth1 is down, line protocol is down
RIP is not enabled on this interface
eth2 is up, line protocol is up
Routing Protocol: RIP
Receive RIP packets
Send RIPv1 Compatible
Passive interface: Disabled
Split horizon: Enabled with Poisoned Reversed
IP interface address:
10.10.1.1/24
10.10.2.1/24
 
Figure 1-76 Explains the show command output details.
Table 1-76: Show ip rip interface output details
Field
Description
Network
IP address of a network entity.
Nexthop
IP address of the next system that is used when forwarding a packet to the destination network.
Metric
If shown, the value of the inter-autonomous system metric.
Routing Protocol
Specifies the routing protocol used.
Passive Interface
Used in all routing protocols to disable sending updates out from a specific interface.
Split horizon
the routing switch does not advertise a route on the same interface as the one on which the routing switch learned the route.
IP Interface address
IP address of the RIP peer neighbor.
 
 
show ip rip statistics
Use this command to display information about RIP statistics. You can specify an interface name to display information about a specific interface.
Command Syntax
show ip rip statistics (IFNAME|)
Parameters
IFNAME
Name of the interface for which information is to be displayed.
Default
None
Command Mode
Exec mode and Privileged Exec mode
Applicability
This command was introduced before OcNOS version 1.3.
Example
The following output displays the RIP routing table with the destination network, nexthop and metric to reach it.
#show ip rip statistics eth1
Interface Name : eth1
Sent Multicast Updates : 3
Sent Multicast Requests : 1
Sent Unicast Updates : 0
Sent Unicast Requests : 0
Recv Multicast Updates : 3
Recv Multicast Requests : 0
Recv Unicast Updates : 1
Recv Unicast Requests : 0
Recv Bad Packets : 0
Recv Bad Routes : 0
 
Figure 1-77 Explains the show command output details.
Table 1-77: Show ip rip statistics output details
Field
Description
Network
IP address of a network entity.
Nexthop
IP address of the next system that is used when forwarding a packet to the destination network.
Metric
If shown, the value of the inter autonomous system metric.
Sent updates
Number of RIP routing updates that have been sent on Multicast/Unicast interface.
Sent Request
Number of RIP routing request that have been sent on Multicast/Unicast interface.
Recv updates
Number of RIP routing updates that have been received on Multicast/Unicast interface.
Recv Request
Number of RIP routing request that have been received on Multicast/Unicast interface.
Recv Bad Packets
Number of packets that were received on this interface and were not processed for any reason.
Recv Bad Routes
Number of route entries that were received on this interface and were not processed for any reason.
 
snmp restart rip
Use this command to restart SNMP in Routing Information Protocol (RIP)
Command Syntax
snmp restart rip
Parameters
None
Default
By default, snmp restart is disabled.
Command Mode
Configure mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#configure terminal
(config)#snmp restart rip
 
timers basic
Use this command to adjust routing network timers.
This command adjusts the RIP timing parameters. Every 30 seconds, an update is sent out containing the complete routing table to every neighboring router. When the time specified by the timeout parameter expires, the route is no longer valid. However, it is retained in the routing table for a short time so that neighbors are notified that the route has been dropped. When the time specified by the garbage parameter expires, the route is finally removed from the routing table. Until the garbage time expires, the route is included in all updates sent by the router.
All routers in the network must have the same timers to allow RIP to execute a distributed and asynchronous routing algorithms. The timers should not be synchronized as it might lead to unnecessary collisions on the network.
Use the no parameter with this command to restore the default routing network timers.
Command Syntax
timers basic <5-2147483647> <5-2147483647> <5-2147483647>
no timers basic
Parameters
<5-2147483647>
Specify the routing table update timer in seconds. The default is 30 seconds.
<5-2147483647>
Specify the routing information timeout timer in seconds. The default is 180 seconds. After this interval has elapsed and no updates for a route are received, the route is declared invalid.
<5-2147483647>
Specify the routing garbage collection timer in seconds. The default is 120 seconds.
Default
The default routing table update time is 30 seconds.
The default routing information timeout time is 180 seconds.
The default routing garbage collection time is 120 seconds.
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#configure terminal
(config)#router rip
(config-router)#timers basic 30 180 120
 
(config)#router rip
(config-router)#no timers basic
version
Use this command to specify a RIP version used globally by the router. RIP can be run in version 1 as well as version 2 mode. Version 2 has more features than version 1 including authentication. Once the rip version is set, rip packets of that version will be received and sent on all the rip-enabled interfaces.
Use the no parameter with this command to restore the default version.
Note: The ip rip receive version command and the ip rip send version command override the value set by the version command.
Command Syntax
version <1-2>
no version
Parameters
<1-2>
Specify the version of RIP processing.
Default
Version 2
Command Mode
Router mode
Applicability
This command was introduced before OcNOS version 1.3.
Examples
#configure terminal
(config)#router rip
(config-router)#version 1
(config-router)#network 10.10.10.0/24
(config-router)#network 10.10.11.0/24