OcNOS-SP : Segment Routing Guide : Segment Routing Configuration Guide : Configuring OSPF SR Mapping Server with LDP
Configuring OSPF SR Mapping Server with LDP
This chapter shows how to configure OSPF segment routing mapping server to work with LDP.
A segment routing mapping server allocates Segment Identifiers (SIDs) for prefixes and ranges of prefixes in an OSPF segment routing domain.
LDP can advertise SIDs for destinations in the LDP part of the network that does not support segment routing. These segments are converted to MPLS labels and installed in the FTN/ILM and forwarding tables.
OSPF uses OSPF TLVs to advertise any additional attributes associated with a prefix by adding new TLVs or sub-TLVs to the existing OSPF TLVs.
Note: Configure PE1 and PE2 router as a OSPF Segment routing, P1 and P2 router as a segment routing mapping server and PE3 and PE4 as a OSPF with LDP.
Topology
ISIS Segment routing with mapping server and LDP
PE1 and PE2 are in a OSPF segment routing domain.
P1 and P2 configured as mapping servers.
PE3 and PE4 are in OSPF with LDP domain.
PE1
 
PE1#configure terminal
Enter configure mode.
PE1(config)#interface lo
Enter interface mode.
PE1(config-if)#ip address 10.0.1.11/32 secondary
Configure the IP address of the interface
 
PE1(config-if)#prefix-sid index 500 no-php
Configure prefix SID absolute value.
PE1(config-if)#exit
Exit interface mode.
PE1(config)#interface xe2
Enter interface mode.
PE1(config-if)#ip address 10.11.1.1/30
Configure the IP address of the interface.
PE1(config-if)#label-switching
Enable label switching.
PE1(config-if)#exit
Exit interface mode.
PE1(config)#interface xe4
Enter interface mode.
PE1(config-if)#ip address 10.11.2.1/30
Configure the IP address of the interface.
PE1(config-if)#label-switching
Enable label switching.
PE1(config-if)#exit
Exit interface mode.
PE1(config)#interface xe6
Enter interface mode.
PE1(config-if)#ip address 10.11.22.1/30
Configure the IP address of the interface.
PE1(config-if)#label-switching
Enable label switching.
PE1(config-if)#exit
Exit interface mode.
PE1(config)#router ospf 1
Enter OSPF router mode for process ID 1.
PE1(config-router)#router-id 10.0.1.11
Set the router id.
PE1(config-router)# network 10.0.1.11/32 area 0.0.0.0
Advertise the lo interface in OSPF area 0..
PE1(config-router)# network 10.11.1.0/30 area 0.0.0.0
Advertise the lo interface in OSPF area 0.
PE1(config-router)# network 10.11.2.0/30 area 0.0.0.0
Advertise the xe4 interface in OSPF area 0.
PE1(config-router)# network 10.11.22.0/30 area 0.0.0.0
Advertise the xe6 interface in OSPF area 0.
PE1(config-router)# ospf segment-routing global block 16000 23999
Advertise the segment routing global block range (16000-23999)
PE1(config-router)#segment-routing mpls
Enable segment routing under router process.
PE1(config-router)#exit
Exit router mode.
PE1(config)#commit
Commit the candidate configuration to the running configuration.
PE2
 
PE2#configure terminal
Enter configure mode.
PE2(config)#interface lo
Enter interface mode.
PE2(config-if)#ip address 10.0.1.22/32 secondary
Configure the IP address of the interface.
PE2(config-if)#prefix-sid index 1000 no-php
Configure prefix SID absolute value.
PE2(config-if)#exit
Exit interface mode.
PE2(config)#interface xe6
Enter interface mode.
PE2(config-if)#ip address 10.11.22.2/30
Configure the IP address of the interface.
PE2(config-if)#label-switching
Enable label switching.
PE2(config-if)#exit
Exit interface mode.
PE2(config)#interface xe7
Enter interface mode.
PE2(config-if)#ip address 10.22.1.1/30
Configure the IP address of the interface.
PE2(config-if)#label-switching
Enable label switching.
PE2(config-if)#exit
Exit interface mode.
PE2(config)#interface xe10
Enter interface mode.
PE2(config-if)#ip address 10.22.2.1/30
Configure the IP address of the interface.
PE2(config-if)#label-switching
Enable label switching.
PE2(config-if)#exit
Exit interface mode.
PE2(config)#router ospf 1
Enter OSPF router mode for process ID 1.
PE2(config-router)# router-id 10.0.1.22
Advertise the router-id.
PE2(config-router)# network 10.0.1.22/32 area 0.0.0.0
Advertise the lo interface in OSPF area 0
PE2(config-router)#network 10.11.22.0/30 area 0.0.0.0
Advertise the xe6 interface in OSPF area 0
PE2(config-router)# network 10.22.1.0/30 area 0.0.0.0
Advertise the xe7 interface in OSPF area 0
PE2(config-router)# network 10.22.2.0/30 area 0.0.0.0
Advertise the xe10 interface in OSPF area 0
PE2(config-router)# ospf segment-routing global block 16000 23999
Advertise segment routing global block range(16000-23999).
PE2(config-router)#segment-routing mpls
Enable segment routing under router process.
PE2(config-router)#exit
Exit router mode.
PE2(config)#commit
Commit the candidate configuration to the running configuration.
P1
 
P1#configure terminal
Enter configure mode.
P1(config)#interface lo
Enter interface mode.
P1(config-if)#ip address 10.0.1.1/32 secondary
Configure the IP address of the interface.
P1(config-if)#prefix-sid index 2000 no-php
Configure prefix SID absolute value.
P1(config-if)#exit
Exit interface mode.
P1(config)#interface xe2
Enter interface mode.
P1(config-if)#ip address 10.11.1.2/30
Configure the IP address of the interface.
P1(config-if)#label-switching
Enable label switching.
P1(config-if)#exit
Exit interface mode.
P1(config)#interface xe7
Enter interface mode.
P1(config-if)#ip address 10.22.1.2/30
Configure the IP address of the interface.
P1(config-if)#label-switching
Enable label switching.
P1(config-if)#exit
Exit interface mode.
P1(config)#interface xe11
Enter interface mode.
P1(config-if)#ip address 10.1.1.1/30
Configure the IP address of the interface.
P1(config-if)#label-switching
Enable label switching.
P1(config-if)#exit
Exit interface mode.
P1(config)#interface xe17
Enter interface mode.
P1(config-if)#ip address 10.33.1.2/30
Configure the IP address of the interface.
P1(config-if)#label-switching
Enable label switching.
P1(config-if)#enable-ldp ipv4
 
P1(config-if)#exit
Exit interface mode.
P1(config)#router ospf 1
Set the routing process ID
P1(config-router)# router-id 10.0.1.1
Advertise the router-id
P1(config-router)# network 10.0.1.1/32 area 0.0.0.0
Advertise the lo interface in OSPF area 0
P1(config-router)# network 10.1.1.0/30 area 0.0.0.0
Advertise the xe12 interface in OSPF area 0
P1(config-router)# network 10.11.1.0/30 area 0.0.0.0
Advertise the xe2 interface in OSPF area 0
P1(config-router)# network 10.22.1.0/30 area 0.0.0.0
Advertise the xe7 interface in OSPF area 0
P1(config-router)# network 10.33.1.0/30 area 0.0.0.0
Advertise the xe17 interface in OSPF area 0
P1(config-router)# ospf segment-routing global block 16000 23999
Advertise the segment routing global block range(16000-23999).
P1(config-router)#segment-routing mpls
Enable segment routing under router process.
P1(config-router)#segment-routing prefix-sid-map advertise-local
Enable segment routing prefix-sid-map advertise-local under router process.
P1(config-router)#exit
Exit router mode.
P1(config)#segment-routing
Enter segment routing configuration mode
P1(config-sr)# mapping-server
Enter mapping server mode.
P1(config-sr-ms)#srms preference 200
Configure segment routing mapping server preference value.
P1(config-sr-ms)#prefix-sid-map address-family ipv4
Enter prefix-SID mapping configuration mode.
P1(config-sr-ms-map-af4)# 10.0.1.33/32 4000 range 1
Configure mapping server entry for assigning s-ids to prefixes.
P1(config-sr-ms-map-af4)# 10.0.1.44/32 5000 range 1
Configure mapping server entry for assigning s-ids to prefixes.
P1(config-sr-ms-map-af4)#end
Exit to privileged mode.
P1#configure terminal
Enter configure mode.
P1(config)#router ldp
Enter router ldp mode.
P1(config-router)#exit
Exit router mode.
P1#configure terminal
Enter configure mode.
P1(config)# mpls lsp-stitching
Enable mpls lsp stitching on global mode.
P1(config-router)#exit
Exit router mode.
P1(config)#commit
Commit the candidate configuration to the running configuration.
P2
 
P2#configure terminal
Enter configure mode.
P2(config)#router ldp
Enter router ldp mode.
P2(config-router)#exit
Exit router mode.
P2#configure terminal
Enter configure mode.
P2(config)# mpls lsp-stitching
Enable mpls lsp stitching on global mode.
P2(config-router)#exit
Exit router mode.
P2(config)#interface lo
Enter interface mode.
P2(config-if)#ip address 10.0.1.2/32 secondary
Configure the IP address of the interface.
P2(config-if)# prefix-sid index 3000 no-php
Configure Prefix SID value.
P2(config-if)#exit
Exit interface mode.
P2(config)#interface xe4
Enter interface mode.
P2(config-if)#ip address 10.11.2.2/30
Configure the IP address of the interface.
P2(config-if)#label-switching
Enable label switching.
P2(config-if)#exit
Exit interface mode.
P2(config)#interface xe10
Enter interface mode.
P2(config-if)#ip address 10.22.2.2/30
Configure the IP address of the interface.
P2(config-if)#label-switching
Enable label switching.
R4(config-if)#exit
Exit interface mode.
P2(config)#interface xe11
Enter interface mode.
P2(config-if)#ip address 10.1.1.2/30
Configure the IP address of the interface.
P2(config-if)#label-switching
Enable label switching.
P2(config-if)#exit
Exit interface mode.
P2(config)#interface xe13
Enter interface mode.
P2(config-if)#ip address 10.44.2.2/30
Configure the IP address of the interface.
P2(config-if)#label-switching
Enable label switching.
P2(config-if)# enable-ldp ipv4
Enable ldp ipv4 under interface.
P2(config-if)#exit
Exit interface mode.
P2(config)#router ospf 1
Set the routing process ID .
P2(config-router)# router-id 10.0.1.2
Advertise the router-id.
P2(config-router)# network 10.0.1.2/32 area 0.0.0.0
Advertise the xe17 interface in OSPF area 0.
P2(config-router)# network 10.1.1.0/30 area 0.0.0.0
Advertise the xe11 interface in OSPF area 0.
P2(config-router)# network 10.11.2.0/30 area 0.0.0.0
Advertise the xe4 interface in OSPF area 0.
P2(config-router)# network 10.22.2.0/30 area 0.0.0.0
Advertise the xe10 interface in OSPF area 0.
P2(config-router)# network 10.44.2.0/30 area 0.0.0.0
Advertise the xe13 interface in OSPF area 0.
P2(config-router)# ospf segment-routing global block 16000 23999
Advertise the segment routing global block range(16000-23999).
P2(config-router)#segment-routing mpls
Enable segment routing under router process.
P2(config-router)# segment-routing prefix-sid-map advertise-local
Enable segment routing prefix-sid-map advertise-local under router process.
P2(config-router)#exit
Exit router mode.
P2(config)#segment-routing
Enter segment routing configuration mode
P2(config-sr)# mapping-server
Enter mapping server mode.
P2(config-sr-ms)#srms preference 100
Configure segment routing mapping server preference value.
P2(config-sr-ms)#prefix-sid-map address-family ipv4
Enter prefix-SID mapping configuration mode.
P2(config-sr-ms-map-af4)# 10.0.1.33/32 1111 range 1
Configure mapping server entry for assigning s-ids to prefixes.
P2(config-sr-ms-map-af4)# 10.0.1.44/32 2222 range 1
Configure mapping server entry for assigning s-ids to prefixes.
P2(config-sr-ms-map-af4)#end
Exit to privileged mode.
P2#configure terminal
Enter configure mode
P2(config)#router ldp
Enter router ldp mode.
P2(config-router)#exit
Exit router mode.
P2#configure terminal
Enter configure mode.
P2(config)# mpls lsp-stitching
Enable mpls lsp stitching on global mode.
P2(config-router)#exit
Exit router mode
P2(config)#commit
Commit the candidate configuration to the running configuration.
PE3
 
PE3#configure terminal
Enter configure mode.
PE3(config)#interface lo
Enter interface mode.
PE3(config-if)#ip address 10.0.1.33/32 secondary
Configure the IP address of the interface.
PE3(config-if)#exit
Exit interface mode.
PE3(config)#router ldp
Enter router ldp mode.
PE3(config-router)#exit
Exit router mode.
PE3(config)#interface xe15
Enter interface mode.
PE3(config-if)#ip address 10.33.44.1/30
Configure the IP address of the interface.
PE3(config-if)#label-switching
Enable label switching.
PE3(config-if)#enable-ldp ipv4
Enable LDP ipv4 in interface.
PE3(config-if)#exit
Exit interface mode.
PE3(config)#interface xe17
Enter interface mode.
PE3(config-if)#ip address 10.33.1.1/30
Configure the IP address of the interface.
PE3(config-if)#label-switching
Enable label switching.
PE3(config-if)#enable-ldp ipv4
Enable LDP ipv4 in interface.
PE3(config-if)#exit
Exit interface mode.
PE3(config)#router ospf 1
Set the routing process ID
PE3(config-router)#router-id 10.0.1.33
Advertise the router-id
PE3(config-router)#network 10.0.1.33/32 area 0.0.0.0
Advertise the lo interface in OSPF area 0.
PE3(config-router)#network 10.33.1.0/30 area 0.0.0.0
Advertise the xe10 interface in OSPF area 0.
PE3(config-router)# network 10.33.44.0/30 area 0.0.0.0
Advertise the xe15 interface in OSPF area 0.
PE3(config-router)#exit
Exit router mode.
PE3(config)#commit
Commit the candidate configuration to the running configuration.
PE4
 
PE4#configure terminal
Enter configure mode.
PE4(config)#interface lo
Enter interface mode.
PE4(config-if)#ip address 10.0.1.44/32 secondary
Configure the IP address of the interface.
PE4(config-if)#exit
Exit interface mode.
PE4(config)#router ldp
Enter router ldp mode.
PE4(config-if)#exit
Exit interface mode.
PE4(config)#interface xe13
Enter interface mode.
PE4(config-if)#ip address 10.44.2.1/30
Configure the IP address of the interface.
PE4(config-if)#label-switching
Enable label switching.
PE4(config-if)#enable-ldp ipv4
Enable LDP ipv4 in interface
PE4(config-if)#exit
Exit interface mode.
PE4(config)#interface xe15
Enter interface mode.
PE4(config-if)#ip address 10.33.44.2/30
Configure the IP address of the interface.
PE4(config-if)#label-switching
Enable label switching.
PE4(config-if)#enable-ldp ipv4
Enable LDP ipv4 in interface
PE4(config-if)#exit
Exit interface mode.
PE4(config)#router ospf 1
Set the routing process ID
PE4(config-router)#router-id 10.0.1.44
Advertise the router-id
PE4(config-router)#network 10.0.1.44/32 area 0.0.0.0
Advertise the lo interface in OSPF area 0.
PE4(config-router)#network 10.33.44.0/30 area 0.0.0.0
Advertise the xe15 interface in OSPF area 0.
PE4(config-router)# network 10.44.2.0/30 area 0.0.0.0
Advertise the xe13 interface in OSPF area 0.
PE4(config-router)#exit
Exit router mode.
PE4(config)#commit
Commit the candidate configuration to the running configuration.
Validation 1
Verify OSPF neighbor adjacency between routers.
PE1#show ip ospf neighbor
 
Total number of full neighbors: 3
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
10.0.1.1 1 Full/Backup 00:00:33 10.11.1.2 xe2 0
10.0.1.2 1 Full/Backup 00:00:29 10.11.2.2 xe4 0
10.0.1.22 1 Full/Backup 00:00:35 10.11.22.2 xe6 0
 
 
 
PE2#show ip ospf neighbor
 
Total number of full neighbors: 3
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
10.0.1.11 1 Full/DR 00:00:31 10.11.22.1 xe6 0
10.0.1.1 1 Full/Backup 00:00:37 10.22.1.2 xe7 0
10.0.1.2 1 Full/Backup 00:00:32 10.22.2.2 xe10 0
 
P1#show ip ospf neighbor
 
Total number of full neighbors: 4
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
10.0.1.2 1 Full/Backup 00:00:33 10.1.1.2 xe11 0
10.0.1.11 1 Full/DR 00:00:31 10.11.1.1 xe2 0
10.0.1.22 1 Full/DR 00:00:40 10.22.1.1 xe7 0
10.0.1.33 1 Full/Backup 00:00:35 10.33.1.1 xe17 0
 
P2#show ip ospf neighbor
 
Total number of full neighbors: 4
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
10.0.1.1 1 Full/DR 00:00:34 10.1.1.1 xe11 0
10.0.1.11 1 Full/DR 00:00:32 10.11.2.1 xe4 0
10.0.1.22 1 Full/DR 00:00:35 10.22.2.1 xe10 0
10.0.1.44 1 Full/Backup 00:00:38 10.44.2.1 xe13 0
 
 
PE3#show ip ospf neighbor
 
Total number of full neighbors: 2
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
10.0.1.1 1 Full/DR 00:00:30 10.33.1.2 xe17 0
10.0.1.44 1 Full/DR 00:00:36 10.33.44.2 xe15 0
 
PE4#show ip ospf neighbor
 
Total number of full neighbors: 2
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
10.0.1.33 1 Full/Backup 00:00:40 10.33.44.1 xe15 0
10.0.1.2 1 Full/DR 00:00:32 10.44.2.2 xe13 0
Validation 2
Verify that segment routing is enabled and that prefix SIDs are announced to other routers.
Verify that prefix SIDs are installed as labels in the MPLS forwarding table. Verify the same in FTN and ILM tables.
PE1 and PE2 Segment Routing Domain
PE1#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
O> 10.0.1.1/32 2 5 0 Yes LSP_DEFAULT 18000 xe2 No 10.11.1.2
O> 10.0.1.2/32 3 6 0 Yes LSP_DEFAULT 19000 xe4 No 10.11.2.2
O> 10.0.1.22/32 1 1 0 Yes LSP_DEFAULT 17000 xe6 No 10.11.22.2
O> 10.0.1.33/32 5 8 0 Yes LSP_DEFAULT 20000 xe2 No 10.11.1.2
O> 10.0.1.44/32 4 7 0 Yes LSP_DEFAULT 21000 xe4 No
 
PE1#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop LSP-Type
O> 10.0.1.33/32 8 20000 20000 N/A xe2 10.11.1.2 LSP_DEFAULT
O> 10.0.1.22/32 2 17000 17000 N/A xe6 10.11.22.2 LSP_DEFAULT
O> 10.0.1.11/32 1 16000 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
O> 10.0.1.1/32 4 18000 18000 N/A xe2 10.11.1.2 LSP_DEFAULT
O> 10.0.1.2/32 6 19000 19000 N/A xe4 10.11.2.2 LSP_DEFAULT
O> 10.11.1.2/32 5 24961 3 N/A xe2 10.11.1.2 LSP_DEFAULT
O> 10.11.22.2/32 3 24960 3 N/A xe6 10.11.22.2 LSP_DEFAULT
O> 10.0.1.44/32 9 21000 21000 N/A xe4 10.11.2.2 LSP_DEFAULT
O> 10.11.2.2/32 7 24962 3 N/A xe4 10.11.2.2 LSP_DEFAULT
 
PE1#show mpls ftn-table
Primary FTN entry with FEC: 10.0.1.1/32, id: 2, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 3, in intf: - in label: 0 out-segment ix: 4
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 4, owner: OSPF-SR, Stale: NO, out intf: xe2, out label: 18000
Nexthop addr: 10.11.1.2 cross connect ix: 3, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.2/32, id: 3, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 5, in intf: - in label: 0 out-segment ix: 7
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 7, owner: OSPF-SR, Stale: NO, out intf: xe4, out label: 19000
Nexthop addr: 10.11.2.2 cross connect ix: 5, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.22/32, id: 1, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 1, in intf: - in label: 0 out-segment ix: 1
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 1, owner: OSPF-SR, Stale: NO, out intf: xe6, out label: 17000
Nexthop addr: 10.11.22.2 cross connect ix: 1, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.33/32, id: 4, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 7, in intf: - in label: 0 out-segment ix: 10
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 10, owner: OSPF-SR, Stale: NO, out intf: xe2, out label: 20000
Nexthop addr: 10.11.1.2 cross connect ix: 7, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.44/32, id: 5, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 8, in intf: - in label: 0 out-segment ix: 12
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 12, owner: OSPF-SR, Stale: NO, out intf: xe4, out label: 21000
Nexthop addr: 10.11.2.2 cross connect ix: 8, op code: Push
 
P1 and P2 Segment Routing Mapping Server Domain
PE2#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
O> 10.0.1.1/32 1 4 0 Yes LSP_DEFAULT 18000 xe7 No 10.22.1.2
O> 10.0.1.2/32 2 5 0 Yes LSP_DEFAULT 19000 xe10 No 10.22.2.2
O> 10.0.1.33/32 4 7 0 Yes LSP_DEFAULT 20000 xe7 No 10.22.1.2
O> 10.0.1.44/32 3 6 0 Yes LSP_DEFAULT 21000 xe10 No 10.22.2.2
 
 
PE2#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop LSP-Type
O> 10.0.1.33/32 9 20000 20000 N/A xe7 10.22.1.2 LSP_DEFAULT
O> 10.0.1.11/32 2 16000 16000 N/A xe6 10.11.22.1 LSP_DEFAULT
O> 10.0.1.1/32 5 18000 18000 N/A xe7 10.22.1.2 LSP_DEFAULT
O> 10.0.1.22/32 1 17000 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
O> 10.0.1.2/32 7 19000 19000 N/A xe10 10.22.2.2 LSP_DEFAULT
O> 10.22.1.2/32 6 24961 3 N/A xe7 10.22.1.2 LSP_DEFAULT
O> 10.11.22.1/32 4 24960 3 N/A xe6 10.11.22.1 LSP_DEFAULT
O> 10.0.1.44/32 10 21000 21000 N/A xe10 10.22.2.2 LSP_DEFAULT
O> 10.22.2.2/32 8 24962 3 N/A xe10 10.22.2.2 LSP_DEFAULT
 
PE2#show mpls ftn-table
Primary FTN entry with FEC: 10.0.1.1/32, id: 2, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 5, in intf: - in label: 0 out-segment ix: 6
Owner: OSPF-SR, Persistent: No, Admin Status: Down, Oper Status: Down
Out-segment with ix: 6, owner: OSPF-SR, Stale: NO, out intf: xe7, out label: 18000
Nexthop addr: 10.22.1.2 cross connect ix: 5, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.2/32, id: 3, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 7, in intf: - in label: 0 out-segment ix: 8
Owner: OSPF-SR, Persistent: No, Admin Status: Down, Oper Status: Down
Out-segment with ix: 8, owner: OSPF-SR, Stale: NO, out intf: xe10, out label: 19000
Nexthop addr: 10.22.2.2 cross connect ix: 7, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.11/32, id: 1, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 1, in intf: - in label: 0 out-segment ix: 1
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 1, owner: OSPF-SR, Stale: NO, out intf: xe6, out label: 16000
Nexthop addr: 10.11.22.1 cross connect ix: 1, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.33/32, id: 4, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 8, in intf: - in label: 0 out-segment ix: 11
Owner: OSPF-SR, Persistent: No, Admin Status: Down, Oper Status: Down
Out-segment with ix: 11, owner: OSPF-SR, Stale: NO, out intf: xe7, out label: 20000
Nexthop addr: 10.22.1.2 cross connect ix: 8, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.44/32, id: 5, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 9, in intf: - in label: 0 out-segment ix: 13
Owner: OSPF-SR, Persistent: No, Admin Status: Down, Oper Status: Down
Out-segment with ix: 13, owner: OSPF-SR, Stale: NO, out intf: xe10, out label: 21000
Nexthop addr: 10.22.2.2 cross connect ix: 9, op code: Push
 
P1#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
O> 10.0.1.2/32 1 1 0 Yes LSP_DEFAULT 19000 xe11 No 10.1.1.2
O> 10.0.1.22/32 2 2 0 Yes LSP_DEFAULT 17000 xe7 No 10.22.1.1
L> 10.0.1.33/32 4 7 - - LSP_DEFAULT 3 xe17 No 10.33.1.1
L> 10.0.1.44/32 5 8 - - LSP_DEFAULT 24326 xe17 No 10.33.1.1
O 10.0.1.44/32 3 6 0 Yes LSP_DEFAULT 21000 xe11 No 10.1.1.2
L> 10.33.44.0/30 6 7 - - LSP_DEFAULT 3 xe17 No 10.33.1.1
 
 
P1#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop LSP-Type
O> 10.1.1.2/32 7 24962 3 N/A xe11 10.1.1.2 LSP_DEFAULT
O> 10.0.1.1/32 1 18000 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
O> 10.0.1.11/32 2 16000 16000 N/A xe2 10.11.1.1 LSP_DEFAULT
O> 10.0.1.22/32 3 17000 17000 N/A xe7 10.22.1.1 LSP_DEFAULT
O> 10.11.1.1/32 4 24960 3 N/A xe2 10.11.1.1 LSP_DEFAULT
s O> 10.0.1.33/32 17 20000 3 N/A xe17 10.33.1.1 LSP_DEFAULT
O> 10.0.1.2/32 6 19000 19000 N/A xe11 10.1.1.2 LSP_DEFAULT
O> 10.0.1.44/32 18 21000 21000 N/A xe11 10.1.1.2 LSP_DEFAULT
O> 10.22.1.1/32 5 24961 3 N/A xe7 10.22.1.1 LSP_DEFAULT
s L> 10.0.1.22/32 11 25602 17000 N/A xe7 10.22.1.1 LSP_DEFAULT
s L> 10.0.1.2/32 9 25600 19000 N/A xe11 10.1.1.2 LSP_DEFAULT
O> 10.33.1.1/32 8 24963 3 N/A xe17 10.33.1.1 LSP_DEFAULT
s L> 10.0.1.11/32 10 25601 16000 N/A xe2 10.11.1.1 LSP_DEFAULT
L> 10.22.2.0/30 15 25606 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
L> 10.11.2.0/30 13 25604 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
L> 10.11.22.0/30 14 25605 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
L> 10.44.2.0/30 16 25607 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
 
P1#show mpls ftn-table
Primary FTN entry with FEC: 10.0.1.2/32, id: 3, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 5, in intf: - in label: 0 out-segment ix: 7
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 7, owner: OSPF-SR, Stale: NO, out intf: xe11, out label: 19000
Nexthop addr: 10.1.1.2 cross connect ix: 5, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.11/32, id: 1, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 1, in intf: - in label: 0 out-segment ix: 1
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 1, owner: OSPF-SR, Stale: NO, out intf: xe2, out label: 16000
Nexthop addr: 10.11.1.1 cross connect ix: 1, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.22/32, id: 2, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 4, in intf: - in label: 0 out-segment ix: 6
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 6, owner: OSPF-SR, Stale: NO, out intf: xe7, out label: 17000
Nexthop addr: 10.22.1.1 cross connect ix: 4, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.33/32, id: 4, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 7, in intf: - in label: 0 out-segment ix: 10
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 10, owner: N/A, Stale: NO, out intf: xe17, out label: 3
Nexthop addr: 10.33.1.1 cross connect ix: 7, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.44/32, id: 7, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 9, in intf: - in label: 0 out-segment ix: 13
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 13, owner: LDP, Stale: NO, out intf: xe17, out label: 25601
Nexthop addr: 10.33.1.1 cross connect ix: 9, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.44/32, id: 6, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 8, in intf: - in label: 0 out-segment ix: 11
Owner: OSPF-SR, Persistent: No, Admin Status: Down, Oper Status: Down
Out-segment with ix: 11, owner: OSPF-SR, Stale: NO, out intf: xe11, out label: 21000
Nexthop addr: 10.1.1.2 cross connect ix: 8, op code: Push
 
 
Primary FTN entry with FEC: 10.33.44.0/30, id: 5, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 7, in intf: - in label: 0 out-segment ix: 10
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 10, owner: N/A, Stale: NO, out intf: xe17, out label: 3
Nexthop addr: 10.33.1.1 cross connect ix: 7, op code: Push
 
P2#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
O> 10.0.1.1/32 1 2 0 Yes LSP_DEFAULT 18000 xe11 No 10.1.1.1
O> 10.0.1.22/32 2 3 0 Yes LSP_DEFAULT 17000 xe10 No 10.22.2.1
L> 10.0.1.33/32 6 8 - - LSP_DEFAULT 24326 xe13 No 10.44.2.1
O 10.0.1.33/32 5 7 0 Yes LSP_DEFAULT 20000 xe11 No 10.1.1.1
L> 10.0.1.44/32 3 6 - - LSP_DEFAULT 3 xe13 No 10.44.2.1
L> 10.33.44.0/30 4 6 - - LSP_DEFAULT 3 xe13 No 10.44.2.1
 
P2#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop LSP-Type
O> 10.11.2.1/32 7 24322 3 N/A xe4 10.11.2.1 LSP_DEFAULT
O> 10.0.1.2/32 1 19000 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
O> 10.0.1.22/32 4 17000 17000 N/A xe10 10.22.2.1 LSP_DEFAULT
O> 10.0.1.11/32 3 16000 16000 N/A xe4 10.11.2.1 LSP_DEFAULT
O> 10.0.1.1/32 2 18000 18000 N/A xe11 10.1.1.1 LSP_DEFAULT
O> 10.1.1.1/32 5 24320 3 N/A xe11 10.1.1.1 LSP_DEFAULT
s O> 10.0.1.44/32 32 21000 3 N/A xe13 10.44.2.1 LSP_DEFAULT
O> 10.0.1.33/32 31 20000 20000 N/A xe11 10.1.1.1 LSP_DEFAULT
O> 10.22.2.1/32 6 24321 3 N/A xe10 10.22.2.1 LSP_DEFAULT
s L> 10.0.1.22/32 22 25602 17000 N/A xe10 10.22.2.1 LSP_DEFAULT
s L> 10.0.1.1/32 17 25600 18000 N/A xe11 10.1.1.1 LSP_DEFAULT
O> 10.44.2.1/32 8 24323 3 N/A xe13 10.44.2.1 LSP_DEFAULT
s L> 10.0.1.11/32 19 25601 16000 N/A xe4 10.11.2.1 LSP_DEFAULT
L> 10.22.1.0/30 26 25606 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
L> 10.11.1.0/30 24 25604 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
L> 10.11.22.0/30 25 25605 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
L> 10.33.1.0/30 30 25607 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
 
P2#show mpls ftn-table
Primary FTN entry with FEC: 10.0.1.1/32, id: 1, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 1, in intf: - in label: 0 out-segment ix: 1
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 1, owner: OSPF-SR, Stale: NO, out intf: xe11, out label: 18000
Nexthop addr: 10.1.1.1 cross connect ix: 1, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.11/32, id: 2, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 6, in intf: - in label: 0 out-segment ix: 9
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 9, owner: OSPF-SR, Stale: NO, out intf: xe4, out label: 16000
Nexthop addr: 10.11.2.1 cross connect ix: 6, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.22/32, id: 3, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 5, in intf: - in label: 0 out-segment ix: 8
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 8, owner: OSPF-SR, Stale: NO, out intf: xe10, out label: 17000
Nexthop addr: 10.22.2.1 cross connect ix: 5, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.33/32, id: 7, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 9, in intf: - in label: 0 out-segment ix: 13
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 13, owner: LDP, Stale: NO, out intf: xe13, out label: 25600
Nexthop addr: 10.44.2.1 cross connect ix: 9, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.33/32, id: 6, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 8, in intf: - in label: 0 out-segment ix: 11
Owner: OSPF-SR, Persistent: No, Admin Status: Down, Oper Status: Down
Out-segment with ix: 11, owner: OSPF-SR, Stale: NO, out intf: xe11, out label: 20000
Nexthop addr: 10.1.1.1 cross connect ix: 8, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.44/32, id: 4, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 7, in intf: - in label: 0 out-segment ix: 10
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 10, owner: N/A, Stale: NO, out intf: xe13, out label: 3
Nexthop addr: 10.44.2.1 cross connect ix: 7, op code: Push
 
 
Primary FTN entry with FEC: 10.33.44.0/30, id: 5, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 7, in intf: - in label: 0 out-segment ix: 10
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 10, owner: N/A, Stale: NO, out intf: xe13, out label: 3
Nexthop addr: 10.44.2.1 cross connect ix: 7, op code: Push
PE3 and PE4 LDP Domain
PE3#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 10.0.1.1/32 4 3 - - LSP_DEFAULT 3 xe17 No 10.33.1.2
L> 10.0.1.2/32 3 2 - - LSP_DEFAULT 24320 xe15 No 10.33.44.2
- - LSP_DEFAULT 24960 xe17 No 10.33.1.2
L> 10.0.1.22/32 7 15 - - LSP_DEFAULT 24961 xe17 No 10.33.1.2
L> 10.0.1.44/32 1 1 - - LSP_DEFAULT 3 xe15 No 10.33.44.2
L> 10.1.1.0/30 8 3 - - LSP_DEFAULT 3 xe17 No 10.33.1.2
L> 10.11.1.0/30 9 3 - - LSP_DEFAULT 3 xe17 No 10.33.1.2
L> 10.11.2.0/30 5 4 - - LSP_DEFAULT 24322 xe15 No 10.33.44.2
- - LSP_DEFAULT 24962 xe17 No 10.33.1.2
L> 10.11.22.0/30 10 18 - - LSP_DEFAULT 24963 xe17 No 10.33.1.2
L> 10.22.1.0/30 11 3 - - LSP_DEFAULT 3 xe17 No 10.33.1.2
L> 10.22.2.0/30 6 5 - - LSP_DEFAULT 24323 xe15 No 10.33.44.2
- - LSP_DEFAULT 24964 xe17 No 10.33.1.2
L> 10.44.2.0/30 2 1 - - LSP_DEFAULT 3 xe15 No 10.33.44.2
PE3#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop LSP-Type
L> 10.1.1.0/30 8 25605 3 N/A xe17 10.33.1.2 LSP_DEFAULT
L> 10.0.1.11/32 4 25602 25601 N/A xe17 10.33.1.2 LSP_DEFAULT
L> 10.0.1.1/32 1 25600 3 N/A xe17 10.33.1.2 LSP_DEFAULT
L> 10.0.1.44/32 2 25601 3 N/A xe15 10.33.44.2 LSP_DEFAULT
L> 10.0.1.22/32 6 25603 25602 N/A xe17 10.33.1.2 LSP_DEFAULT
L> 10.11.22.0/30 11 25608 25605 N/A xe17 10.33.1.2 LSP_DEFAULT
L> 10.11.1.0/30 9 25606 3 N/A xe17 10.33.1.2 LSP_DEFAULT
L> 10.22.1.0/30 12 25609 3 N/A xe17 10.33.1.2 LSP_DEFAULT
 
 
PE3# show mpls ftn-table
Primary FTN entry with FEC: 10.0.1.1/32, id: 1, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 1, in intf: - in label: 0 out-segment ix: 1
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 1, owner: N/A, Stale: NO, out intf: xe17, out label: 3
Nexthop addr: 10.33.1.2 cross connect ix: 1, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.2/32, id: 3, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 2, in intf: - in label: 0 out-segment ix: 2
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 2, owner: LDP, Stale: NO, out intf: xe17, out label: 25600
Nexthop addr: 10.33.1.2 cross connect ix: 2, op code: Push
 
Cross connect ix: 2, in intf: - in label: 0 out-segment ix: 3
Owner: LDP, Persistent: No, Admin Status: Down, Oper Status: Not present
Out-segment with ix: 3, owner: LDP, Stale: NO, out intf: xe15, out label: 25601
Nexthop addr: 10.33.44.2 cross connect ix: 2, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.11/32, id: 4, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 4, in intf: - in label: 0 out-segment ix: 5
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 5, owner: LDP, Stale: NO, out intf: xe17, out label: 25601
Nexthop addr: 10.33.1.2 cross connect ix: 4, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.22/32, id: 5, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 6, in intf: - in label: 0 out-segment ix: 7
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 7, owner: LDP, Stale: NO, out intf: xe17, out label: 25602
Nexthop addr: 10.33.1.2 cross connect ix: 6, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.44/32, id: 6, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 7, in intf: - in label: 0 out-segment ix: 4
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 4, owner: N/A, Stale: NO, out intf: xe15, out label: 3
Nexthop addr: 10.33.44.2 cross connect ix: 7, op code: Push
 
 
Primary FTN entry with FEC: 10.1.1.0/30, id: 7, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 1, in intf: - in label: 0 out-segment ix: 1
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 1, owner: N/A, Stale: NO, out intf: xe17, out label: 3
Nexthop addr: 10.33.1.2 cross connect ix: 1, op code: Push
 
 
Primary FTN entry with FEC: 10.11.1.0/30, id: 8, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 1, in intf: - in label: 0 out-segment ix: 1
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 1, owner: N/A, Stale: NO, out intf: xe17, out label: 3
Nexthop addr: 10.33.1.2 cross connect ix: 1, op code: Push
 
 
Primary FTN entry with FEC: 10.11.2.0/30, id: 9, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 8, in intf: - in label: 0 out-segment ix: 9
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 9, owner: LDP, Stale: NO, out intf: xe17, out label: 25604
Nexthop addr: 10.33.1.2 cross connect ix: 8, op code: Push
 
Cross connect ix: 8, in intf: - in label: 0 out-segment ix: 6
Owner: LDP, Persistent: No, Admin Status: Down, Oper Status: Not present
Out-segment with ix: 6, owner: LDP, Stale: NO, out intf: xe15, out label: 25607
Nexthop addr: 10.33.44.2 cross connect ix: 8, op code: Push
 
 
Primary FTN entry with FEC: 10.11.22.0/30, id: 10, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 9, in intf: - in label: 0 out-segment ix: 10
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 10, owner: LDP, Stale: NO, out intf: xe17, out label: 25605
Nexthop addr: 10.33.1.2 cross connect ix: 9, op code: Push
 
 
Primary FTN entry with FEC: 10.22.1.0/30, id: 11, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 1, in intf: - in label: 0 out-segment ix: 1
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 1, owner: N/A, Stale: NO, out intf: xe17, out label: 3
Nexthop addr: 10.33.1.2 cross connect ix: 1, op code: Push
 
 
Primary FTN entry with FEC: 10.22.2.0/30, id: 12, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 10, in intf: - in label: 0 out-segment ix: 11
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 11, owner: LDP, Stale: NO, out intf: xe17, out label: 25606
Nexthop addr: 10.33.1.2 cross connect ix: 10, op code: Push
 
Cross connect ix: 10, in intf: - in label: 0 out-segment ix: 8
Owner: LDP, Persistent: No, Admin Status: Down, Oper Status: Not present
Out-segment with ix: 8, owner: LDP, Stale: NO, out intf: xe15, out label: 25610
Nexthop addr: 10.33.44.2 cross connect ix: 10, op code: Push
 
 
Primary FTN entry with FEC: 10.44.2.0/30, id: 13, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 7, in intf: - in label: 0 out-segment ix: 4
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 4, owner: N/A, Stale: NO, out intf: xe15, out label: 3
Nexthop addr: 10.33.44.2 cross connect ix: 7, op code: Push
 
PE4#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 10.0.1.1/32 3 2 - - LSP_DEFAULT 24320 xe13 No 10.33.44.1
- - LSP_DEFAULT 24320 xe15 No 10.44.2.2
L> 10.0.1.2/32 6 11 - - LSP_DEFAULT 3 xe15 No 10.44.2.2
L> 10.0.1.22/32 7 15 - - LSP_DEFAULT 24321 xe15 No 10.44.2.2
L> 10.0.1.33/32 1 1 - - LSP_DEFAULT 3 xe13 No 10.33.44.1
L> 10.1.1.0/30 8 11 - - LSP_DEFAULT 3 xe15 No 10.44.2.2
L> 10.11.1.0/30 4 3 - - LSP_DEFAULT 24323 xe13 No 10.33.44.1
- - LSP_DEFAULT 24322 xe15 No 10.44.2.2
L> 10.11.2.0/30 9 11 - - LSP_DEFAULT 3 xe15 No 10.44.2.2
L> 10.11.22.0/30 10 18 - - LSP_DEFAULT 24323 xe15 No 10.44.2.2
L> 10.22.1.0/30 5 4 - - LSP_DEFAULT 24325 xe13 No 10.33.44.1
- - LSP_DEFAULT 24324 xe15 No 10.44.2.2
L> 10.22.2.0/30 11 11 - - LSP_DEFAULT 3 xe15 No 10.44.2.2
L> 10.33.1.0/30 2 1 - - LSP_DEFAULT 3 xe13 No 10.33.44.1
 
PE4# show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop LSP-Type
L> 10.11.2.0/30 8 25607 3 N/A xe13 10.44.2.2 LSP_DEFAULT
L> 10.0.1.22/32 4 25603 25602 N/A xe13 10.44.2.2 LSP_DEFAULT
L> 10.0.1.2/32 2 25601 3 N/A xe13 10.44.2.2 LSP_DEFAULT
L> 10.0.1.33/32 1 25600 3 N/A xe15 10.33.44.1 LSP_DEFAULT
L> 10.0.1.11/32 3 25602 25601 N/A xe13 10.44.2.2 LSP_DEFAULT
L> 10.1.1.0/30 6 25605 3 N/A xe13 10.44.2.2 LSP_DEFAULT
L> 10.22.2.0/30 11 25610 3 N/A xe13 10.44.2.2 LSP_DEFAULT
L> 10.11.22.0/30 9 25608 25605 N/A xe13 10.44.2.2 LSP_DEFAULT
 
 
PE4#show mpls ftn-table
Primary FTN entry with FEC: 10.0.1.1/32, id: 1, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 1, in intf: - in label: 0 out-segment ix: 1
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 1, owner: LDP, Stale: NO, out intf: xe13, out label: 25600
Nexthop addr: 10.44.2.2 cross connect ix: 1, op code: Push
 
Cross connect ix: 1, in intf: - in label: 0 out-segment ix: 10
Owner: LDP, Persistent: No, Admin Status: Down, Oper Status: Not present
Out-segment with ix: 10, owner: LDP, Stale: NO, out intf: xe15, out label: 25600
Nexthop addr: 10.33.44.1 cross connect ix: 1, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.2/32, id: 2, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 2, in intf: - in label: 0 out-segment ix: 2
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 2, owner: N/A, Stale: NO, out intf: xe13, out label: 3
Nexthop addr: 10.44.2.2 cross connect ix: 2, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.11/32, id: 3, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 3, in intf: - in label: 0 out-segment ix: 3
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 3, owner: LDP, Stale: NO, out intf: xe13, out label: 25601
Nexthop addr: 10.44.2.2 cross connect ix: 3, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.22/32, id: 4, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 4, in intf: - in label: 0 out-segment ix: 4
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 4, owner: LDP, Stale: NO, out intf: xe13, out label: 25602
Nexthop addr: 10.44.2.2 cross connect ix: 4, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.33/32, id: 5, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 5, in intf: - in label: 0 out-segment ix: 11
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 11, owner: N/A, Stale: NO, out intf: xe15, out label: 3
Nexthop addr: 10.33.44.1 cross connect ix: 5, op code: Push
 
 
Primary FTN entry with FEC: 10.1.1.0/30, id: 6, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 2, in intf: - in label: 0 out-segment ix: 2
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 2, owner: N/A, Stale: NO, out intf: xe13, out label: 3
Nexthop addr: 10.44.2.2 cross connect ix: 2, op code: Push
 
 
Primary FTN entry with FEC: 10.11.1.0/30, id: 7, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 6, in intf: - in label: 0 out-segment ix: 6
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 6, owner: LDP, Stale: NO, out intf: xe13, out label: 25604
Nexthop addr: 10.44.2.2 cross connect ix: 6, op code: Push
 
Cross connect ix: 6, in intf: - in label: 0 out-segment ix: 5
Owner: LDP, Persistent: No, Admin Status: Down, Oper Status: Not present
Out-segment with ix: 5, owner: LDP, Stale: NO, out intf: xe15, out label: 25606
Nexthop addr: 10.33.44.1 cross connect ix: 6, op code: Push
 
 
Primary FTN entry with FEC: 10.11.2.0/30, id: 8, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 2, in intf: - in label: 0 out-segment ix: 2
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 2, owner: N/A, Stale: NO, out intf: xe13, out label: 3
Nexthop addr: 10.44.2.2 cross connect ix: 2, op code: Push
 
 
Primary FTN entry with FEC: 10.11.22.0/30, id: 9, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 7, in intf: - in label: 0 out-segment ix: 7
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 7, owner: LDP, Stale: NO, out intf: xe13, out label: 25605
Nexthop addr: 10.44.2.2 cross connect ix: 7, op code: Push
 
 
Primary FTN entry with FEC: 10.22.1.0/30, id: 10, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 8, in intf: - in label: 0 out-segment ix: 8
Owner: LDP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 8, owner: LDP, Stale: NO, out intf: xe13, out label: 25606
Nexthop addr: 10.44.2.2 cross connect ix: 8, op code: Push
 
Cross connect ix: 8, in intf: - in label: 0 out-segment ix: 12
Owner: LDP, Persistent: No, Admin Status: Down, Oper Status: Not present
Out-segment with ix: 12, owner: LDP, Stale: NO, out intf: xe15, out label: 25609
Nexthop addr: 10.33.44.1 cross connect ix: 8, op code: Push
 
 
Primary FTN entry with FEC: 10.22.2.0/30, id: 11, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 2, in intf: - in label: 0 out-segment ix: 2
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 2, owner: N/A, Stale: NO, out intf: xe13, out label: 3
Nexthop addr: 10.44.2.2 cross connect ix: 2, op code: Push
 
 
Primary FTN entry with FEC: 10.33.1.0/30, id: 12, row status: Active
Owner: LDP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A
Cross connect ix: 5, in intf: - in label: 0 out-segment ix: 11
Owner: N/A, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 11, owner: N/A, Stale: NO, out intf: xe15, out label: 3
Nexthop addr: 10.33.44.1 cross connect ix: 5, op code: Push
In the forwarding tables above, the configured prefix SIDs are in the Out-Label column which is expected and is global
across the topology. The swap happens in between nodes with this prefix SID and there is no local labelling
Validation 3
Show the routes details and OSPF database.
P1#show ip route
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
ia - IS-IS inter area, E - EVPN,
v - vrf leaked
* - candidate default
 
IP Route Table for VRF "default"
C 10.0.1.1/32 is directly connected, lo, 13:13:51
O 10.0.1.2/32 [110/2] via 10.1.1.2, xe11, 00:21:59
O 10.0.1.11/32 [110/2] via 10.11.1.1, xe2, 00:23:13
O 10.0.1.22/32 [110/2] via 10.22.1.1, xe7, 00:23:11
O 10.0.1.33/32 [110/2] via 10.33.1.1, xe17, 00:15:45
O 10.0.1.44/32 [110/3] via 10.1.1.2, xe11, 00:12:45
[110/3] via 10.33.1.1, xe17
C 10.1.1.0/30 is directly connected, xe11, 13:14:18
C 10.11.1.0/30 is directly connected, xe2, 13:15:21
O 10.11.2.0/30 [110/2] via 10.1.1.2, xe11, 00:23:13
[110/2] via 10.11.1.1, xe2
O 10.11.22.0/30 [110/2] via 10.22.1.1, xe7, 00:23:13
[110/2] via 10.11.1.1, xe2
C 10.22.1.0/30 is directly connected, xe7, 13:06:03
O 10.22.2.0/30 [110/2] via 10.22.1.1, xe7, 00:23:11
[110/2] via 10.1.1.2, xe11
C 10.33.1.0/30 is directly connected, xe17, 12:42:33
O 10.33.44.0/30 [110/2] via 10.33.1.1, xe17, 00:15:45
O 10.44.2.0/30 [110/2] via 10.1.1.2, xe11, 00:21:59
C 127.0.0.0/8 is directly connected, lo, 13:29:28
 
Gateway of last resort is not set
 
P1#show ip route ospf
IP Route Table for VRF "default"
O 10.0.1.2/32 [110/2] via 10.1.1.2, xe11, 00:23:02
O 10.0.1.11/32 [110/2] via 10.11.1.1, xe2, 00:24:16
O 10.0.1.22/32 [110/2] via 10.22.1.1, xe7, 00:24:14
O 10.0.1.33/32 [110/2] via 10.33.1.1, xe17, 00:16:48
O 10.0.1.44/32 [110/3] via 10.1.1.2, xe11, 00:13:48
[110/3] via 10.33.1.1, xe17
O 10.11.2.0/30 [110/2] via 10.1.1.2, xe11, 00:24:16
[110/2] via 10.11.1.1, xe2
O 10.11.22.0/30 [110/2] via 10.22.1.1, xe7, 00:24:16
[110/2] via 10.11.1.1, xe2
O 10.22.2.0/30 [110/2] via 10.22.1.1, xe7, 00:24:14
[110/2] via 10.1.1.2, xe11
O 10.33.44.0/30 [110/2] via 10.33.1.1, xe17, 00:16:48
O 10.44.2.0/30 [110/2] via 10.1.1.2, xe11, 00:23:02
 
Gateway of last resort is not set
 
P1# show ip ospf database
 
OSPF Router with ID (10.0.1.1) (Process ID 1 VRF default)
 
Router Link States (Area 0.0.0.0)
 
Link ID ADV Router Age Seq# CkSum Link count
10.0.1.1 10.0.1.1 1062 0x8000000b 0x9642 5
10.0.1.2 10.0.1.2 883 0x8000000b 0x4b6d 5
10.0.1.11 10.0.1.11 1404 0x8000000a 0x0bf4 4
10.0.1.22 10.0.1.22 1419 0x80000009 0xefc2 4
10.0.1.33 10.0.1.33 507 0x80000007 0x3347 3
10.0.1.44 10.0.1.44 512 0x80000007 0x3709 3
 
Net Link States (Area 0.0.0.0)
 
Link ID ADV Router Age Seq# CkSum
10.1.1.1 10.0.1.1 1435 0x80000001 0x7397
10.11.1.1 10.0.1.11 1514 0x80000001 0x15d8
10.11.2.1 10.0.1.11 1404 0x80000001 0x18d3
10.11.22.1 10.0.1.11 1612 0x80000001 0x546f
10.22.1.1 10.0.1.22 1506 0x80000001 0xbc10
10.22.2.1 10.0.1.22 1419 0x80000001 0xbf0b
10.33.1.2 10.0.1.1 1062 0x80000001 0x9b2f
10.33.44.2 10.0.1.44 512 0x80000001 0x6ddb
10.44.2.2 10.0.1.2 883 0x80000001 0xaa07
 
Area-Local Opaque-LSA (Area 0.0.0.0)
 
Link ID ADV Router Age Seq# CkSum Opaque ID
1.0.0.1 10.0.1.1 1503 0x80000003 0x1afa 1
1.0.0.1 10.0.1.2 1417 0x80000003 0x1ef4 1
1.0.0.1 10.0.1.11 1512 0x80000004 0x40bf 1
1.0.0.1 10.0.1.22 1505 0x80000003 0x6e7c 1
1.0.0.1 10.0.1.33 509 0x80000005 0x963c 1
1.0.0.1 10.0.1.44 510 0x80000005 0xc2f9 1
1.0.0.12 10.0.1.1 199 0x80000002 0xc26c 12
1.0.0.12 10.0.1.11 367 0x80000002 0x68bd 12
1.0.0.16 10.0.1.2 1402 0x80000001 0xc860 16
1.0.0.16 10.0.1.11 1402 0x80000001 0x74ac 16
1.0.0.20 10.0.1.11 1610 0x80000001 0x38bc 20
1.0.0.20 10.0.1.22 1611 0x80000001 0x14d4 20
1.0.0.22 10.0.1.1 209 0x80000002 0x709e 22
1.0.0.22 10.0.1.22 1505 0x80000001 0xd526 22
1.0.0.28 10.0.1.2 1417 0x80000001 0x62a4 28
1.0.0.28 10.0.1.22 1417 0x80000001 0xcb28 28
1.0.0.30 10.0.1.1 1433 0x80000001 0x1023 30
1.0.0.30 10.0.1.2 1434 0x80000001 0x2809 30
1.0.0.32 10.0.1.44 882 0x80000001 0x5953 32
1.0.0.34 10.0.1.2 881 0x80000001 0x6073 34
1.0.0.36 10.0.1.33 509 0x80000001 0x9dd7 36
1.0.0.36 10.0.1.44 510 0x80000001 0x79ef 36
1.0.0.40 10.0.1.33 1061 0x80000001 0x07c0 40
1.0.0.42 10.0.1.1 1060 0x80000001 0xd113 42
4.0.0.0 10.0.1.1 689 0x80000002 0x29c7 0
4.0.0.0 10.0.1.2 664 0x80000002 0xfa59 0
4.0.0.0 10.0.1.11 56 0x80000002 0x6e5c 0
4.0.0.0 10.0.1.22 315 0x80000002 0x2c93 0
7.0.0.0 10.0.1.1 1541 0x80000001 0x6ffe 0
7.0.0.0 10.0.1.2 1459 0x80000001 0x6917 0
7.0.0.0 10.0.1.11 1747 0x80000001 0x94d6 0
7.0.0.0 10.0.1.22 55 0x80000002 0x240b 0
7.0.0.1 10.0.1.1 689 0x80000001 0x4587 1
7.0.0.2 10.0.1.1 689 0x80000001 0xa331 2
8.0.39.20 10.0.1.1 1511 0x80000001 0xd567 10004
8.0.39.20 10.0.1.11 1512 0x80000001 0x0713 10004
8.0.39.22 10.0.1.2 1402 0x80000001 0x4d6b 10006
8.0.39.22 10.0.1.11 1402 0x80000001 0x50c3 10006
8.0.39.24 10.0.1.11 1610 0x80000001 0xae29 10008
8.0.39.24 10.0.1.22 1611 0x80000001 0xa752 10008
8.0.39.25 10.0.1.1 1503 0x80000001 0xf52b 10009
8.0.39.25 10.0.1.22 1505 0x80000001 0xc72c 10009
8.0.39.28 10.0.1.2 1417 0x80000001 0x2974 10012
8.0.39.28 10.0.1.22 25 0x80000002 0x05e6 10012
8.0.39.29 10.0.1.1 89 0x80000002 0x0d1f 10013
8.0.39.29 10.0.1.2 1434 0x80000001 0x9534 10013
8.0.39.31 10.0.1.2 881 0x80000001 0x2df9 10015
8.0.39.35 10.0.1.1 1060 0x80000001 0x3d87 10019
Validation 4
Show the details of routers configured with segment routing.
P1#show ip ospf segment-routing capability
 
OSPF process 1:
-----------------------------------------------------
Advertisement Router Capability :10.0.1.1
Algorithm :0
SRMS Preference :200
Total SID'S Supported :8000
SID Range List Count :1
SID's Range :16000 - 23999
-----------------------------------------------------
Advertisement Router Capability :10.0.1.2
Algorithm :0
SRMS Preference :100
Total SID'S Supported :8000
SID Range List Count :1
SID's Range :16000 - 23999
-----------------------------------------------------
Advertisement Router Capability :10.0.1.11
Algorithm :0
SRMS Preference :0
Total SID'S Supported :8000
SID Range List Count :1
SID's Range :16000 - 23999
-----------------------------------------------------
Advertisement Router Capability :10.0.1.22
Algorithm :0
SRMS Preference :0
Total SID'S Supported :8000
SID Range List Count :1
SID's Range :16000 - 23999
-----------------------------------------------------
 
P1#show ip ospf database opaque-area self-originate
 
OSPF Router with ID (10.0.1.1) (Process ID 1 VRF default)
 
Area-Local Opaque-LSA (Area 0.0.0.0)
 
LS age: 1738
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.1 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 1
Advertising Router: 10.0.1.1
LS Seq Number: 80000003
Checksum: 0x1afa
Length: 28
 
MPLS TE router ID : 10.0.1.1
 
Number of Links : 0
 
LS age: 433
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.12 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 12
Advertising Router: 10.0.1.1
LS Seq Number: 80000002
Checksum: 0xc26c
Length: 108
 
Link connected to Broadcast network
Link ID : 10.11.1.1
Interface Address : 10.11.1.2
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 443
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.22 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 22
Advertising Router: 10.0.1.1
LS Seq Number: 80000002
Checksum: 0x709e
Length: 108
 
Link connected to Broadcast network
Link ID : 10.22.1.1
Interface Address : 10.22.1.2
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 23
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.30 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 30
Advertising Router: 10.0.1.1
LS Seq Number: 80000002
Checksum: 0x0e24
Length: 108
 
Link connected to Broadcast network
Link ID : 10.1.1.1
Interface Address : 10.1.1.1
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 1294
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.42 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 42
Advertising Router: 10.0.1.1
LS Seq Number: 80000001
Checksum: 0xd113
Length: 108
 
Link connected to Broadcast network
Link ID : 10.33.1.2
Interface Address : 10.33.1.2
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 924
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 4
Opaque ID: 0
Advertising Router: 10.0.1.1
LS Seq Number: 80000002
Checksum: 0x29c7
Length: 52
 
Range Size: 8000
Base-SID: 16000
Algorithm: 0
Preference: 200
 
 
LS age: 1775
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 0
Advertising Router: 10.0.1.1
LS Seq Number: 80000001
Checksum: 0x6ffe
Length: 44
 
Prefix type : Extended Prefix TLV
Route Type: 1
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 10.0.1.1
Flags: 0x40 (-|NP|-|-|-|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 2000
 
LS age: 924
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.1 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 1
Advertising Router: 10.0.1.1
LS Seq Number: 80000001
Checksum: 0x4587
Length: 48
 
Prefix type : Extended Prefix Range TLV
Prefix Length: 32
AF: 0
Range: 1
Flags: 0x00 (-|-|-|-|-|-|-|-)
Address Prefix: 10.0.1.33
Flags: 0x20 (-|-|M|-|-|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 4000
 
LS age: 924
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.2 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 2
Advertising Router: 10.0.1.1
LS Seq Number: 80000001
Checksum: 0xa331
Length: 48
 
Prefix type : Extended Prefix Range TLV
Prefix Length: 32
AF: 0
Range: 1
Flags: 0x00 (-|-|-|-|-|-|-|-)
Address Prefix: 10.0.1.44
Flags: 0x20 (-|-|M|-|-|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 5000
 
LS age: 1746
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.20 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10004
Advertising Router: 10.0.1.1
LS Seq Number: 80000001
Checksum: 0xd567
Length: 48
 
Link Type: 2
Link ID: 10.11.1.1
Link Data: 10.11.1.2
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
SID: 24960
 
 
LS age: 43
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.25 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10009
Advertising Router: 10.0.1.1
LS Seq Number: 80000002
Checksum: 0xf32c
Length: 48
 
Link Type: 2
Link ID: 10.22.1.1
Link Data: 10.22.1.2
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
SID: 24961
 
 
LS age: 323
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.29 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10013
Advertising Router: 10.0.1.1
LS Seq Number: 80000002
Checksum: 0x0d1f
Length: 52
 
Link Type: 2
Link ID: 10.1.1.1
Link Data: 10.1.1.1
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
NBR ID: 10.0.1.2
SID: 24962
 
 
LS age: 1294
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.35 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10019
Advertising Router: 10.0.1.1
LS Seq Number: 80000001
Checksum: 0x3d87
Length: 52
 
Link Type: 2
Link ID: 10.33.1.2
Link Data: 10.33.1.2
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
NBR ID: 10.0.1.33
SID: 24963
 
P1#show ip ospf database opaque-area
 
OSPF Router with ID (10.0.1.1) (Process ID 1 VRF default)
 
Area-Local Opaque-LSA (Area 0.0.0.0)
 
LS age: 1744
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.1 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 1
Advertising Router: 10.0.1.1
LS Seq Number: 80000003
Checksum: 0x1afa
Length: 28
 
MPLS TE router ID : 10.0.1.1
 
Number of Links : 0
 
LS age: 1658
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.1 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 1
Advertising Router: 10.0.1.2
LS Seq Number: 80000003
Checksum: 0x1ef4
Length: 28
 
MPLS TE router ID : 10.0.1.2
 
Number of Links : 0
 
LS age: 8
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.1 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 1
Advertising Router: 10.0.1.11
LS Seq Number: 80000005
Checksum: 0x3ec0
Length: 28
 
MPLS TE router ID : 10.0.1.11
 
Number of Links : 0
 
LS age: 1747
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.1 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 1
Advertising Router: 10.0.1.22
LS Seq Number: 80000003
Checksum: 0x6e7c
Length: 28
 
MPLS TE router ID : 10.0.1.22
 
Number of Links : 0
 
LS age: 750
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.1 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 1
Advertising Router: 10.0.1.33
LS Seq Number: 80000005
Checksum: 0x963c
Length: 28
 
MPLS TE router ID : 10.0.1.33
 
Number of Links : 0
 
LS age: 751
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.1 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 1
Advertising Router: 10.0.1.44
LS Seq Number: 80000005
Checksum: 0xc2f9
Length: 28
 
MPLS TE router ID : 10.0.1.44
 
Number of Links : 0
 
LS age: 440
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.12 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 12
Advertising Router: 10.0.1.1
LS Seq Number: 80000002
Checksum: 0xc26c
Length: 108
 
Link connected to Broadcast network
Link ID : 10.11.1.1
Interface Address : 10.11.1.2
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 608
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.12 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 12
Advertising Router: 10.0.1.11
LS Seq Number: 80000002
Checksum: 0x68bd
Length: 108
 
Link connected to Broadcast network
Link ID : 10.11.1.1
Interface Address : 10.11.1.1
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 1643
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.16 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 16
Advertising Router: 10.0.1.2
LS Seq Number: 80000001
Checksum: 0xc860
Length: 108
 
Link connected to Broadcast network
Link ID : 10.11.2.1
Interface Address : 10.11.2.2
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 1643
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.16 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 16
Advertising Router: 10.0.1.11
LS Seq Number: 80000001
Checksum: 0x74ac
Length: 108
 
Link connected to Broadcast network
Link ID : 10.11.2.1
Interface Address : 10.11.2.1
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 1852
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.20 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 20
Advertising Router: 10.0.1.11
LS Seq Number: 80000001
Checksum: 0x38bc
Length: 108
 
Link connected to Broadcast network
Link ID : 10.11.22.1
Interface Address : 10.11.22.1
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 1853
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.20 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 20
Advertising Router: 10.0.1.22
LS Seq Number: 80000001
Checksum: 0x14d4
Length: 108
 
Link connected to Broadcast network
Link ID : 10.11.22.1
Interface Address : 10.11.22.2
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 450
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.22 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 22
Advertising Router: 10.0.1.1
LS Seq Number: 80000002
Checksum: 0x709e
Length: 108
 
Link connected to Broadcast network
Link ID : 10.22.1.1
Interface Address : 10.22.1.2
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 1747
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.22 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 22
Advertising Router: 10.0.1.22
LS Seq Number: 80000001
Checksum: 0xd526
Length: 108
 
Link connected to Broadcast network
Link ID : 10.22.1.1
Interface Address : 10.22.1.1
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 1658
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.28 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 28
Advertising Router: 10.0.1.2
LS Seq Number: 80000001
Checksum: 0x62a4
Length: 108
 
Link connected to Broadcast network
Link ID : 10.22.2.1
Interface Address : 10.22.2.2
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 1658
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.28 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 28
Advertising Router: 10.0.1.22
LS Seq Number: 80000001
Checksum: 0xcb28
Length: 108
 
Link connected to Broadcast network
Link ID : 10.22.2.1
Interface Address : 10.22.2.1
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 30
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.30 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 30
Advertising Router: 10.0.1.1
LS Seq Number: 80000002
Checksum: 0x0e24
Length: 108
 
Link connected to Broadcast network
Link ID : 10.1.1.1
Interface Address : 10.1.1.1
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 1676
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.30 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 30
Advertising Router: 10.0.1.2
LS Seq Number: 80000001
Checksum: 0x2809
Length: 108
 
Link connected to Broadcast network
Link ID : 10.1.1.1
Interface Address : 10.1.1.2
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 1124
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.32 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 32
Advertising Router: 10.0.1.44
LS Seq Number: 80000001
Checksum: 0x5953
Length: 108
 
Link connected to Broadcast network
Link ID : 10.44.2.2
Interface Address : 10.44.2.1
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 1123
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.34 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 34
Advertising Router: 10.0.1.2
LS Seq Number: 80000001
Checksum: 0x6073
Length: 108
 
Link connected to Broadcast network
Link ID : 10.44.2.2
Interface Address : 10.44.2.2
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 750
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.36 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 36
Advertising Router: 10.0.1.33
LS Seq Number: 80000001
Checksum: 0x9dd7
Length: 108
 
Link connected to Broadcast network
Link ID : 10.33.44.2
Interface Address : 10.33.44.1
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 751
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.36 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 36
Advertising Router: 10.0.1.44
LS Seq Number: 80000001
Checksum: 0x79ef
Length: 108
 
Link connected to Broadcast network
Link ID : 10.33.44.2
Interface Address : 10.33.44.2
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 130
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.40 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 40
Advertising Router: 10.0.1.33
LS Seq Number: 80000002
Checksum: 0x05c1
Length: 108
 
Link connected to Broadcast network
Link ID : 10.33.1.2
Interface Address : 10.33.1.1
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 1301
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.42 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 42
Advertising Router: 10.0.1.1
LS Seq Number: 80000001
Checksum: 0xd113
Length: 108
 
Link connected to Broadcast network
Link ID : 10.33.1.2
Interface Address : 10.33.1.2
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 931
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 4
Opaque ID: 0
Advertising Router: 10.0.1.1
LS Seq Number: 80000002
Checksum: 0x29c7
Length: 52
 
Range Size: 8000
Base-SID: 16000
Algorithm: 0
Preference: 200
 
 
LS age: 905
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 4
Opaque ID: 0
Advertising Router: 10.0.1.2
LS Seq Number: 80000002
Checksum: 0xfa59
Length: 52
 
Range Size: 8000
Base-SID: 16000
Algorithm: 0
Preference: 100
 
 
LS age: 298
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 4
Opaque ID: 0
Advertising Router: 10.0.1.11
LS Seq Number: 80000002
Checksum: 0x6e5c
Length: 44
 
Range Size: 8000
Base-SID: 16000
Algorithm: 0
 
 
LS age: 556
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 4
Opaque ID: 0
Advertising Router: 10.0.1.22
LS Seq Number: 80000002
Checksum: 0x2c93
Length: 44
 
Range Size: 8000
Base-SID: 16000
Algorithm: 0
 
 
LS age: 1782
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 0
Advertising Router: 10.0.1.1
LS Seq Number: 80000001
Checksum: 0x6ffe
Length: 44
 
Prefix type : Extended Prefix TLV
Route Type: 1
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 10.0.1.1
Flags: 0x40 (-|NP|-|-|-|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 2000
 
LS age: 1701
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 0
Advertising Router: 10.0.1.2
LS Seq Number: 80000001
Checksum: 0x6917
Length: 44
 
Prefix type : Extended Prefix TLV
Route Type: 1
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 10.0.1.2
Flags: 0x40 (-|NP|-|-|-|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 3000
 
LS age: 1989
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 0
Advertising Router: 10.0.1.11
LS Seq Number: 80000001
Checksum: 0x94d6
Length: 44
 
Prefix type : Extended Prefix TLV
Route Type: 1
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 10.0.1.11
Flags: 0x48 (-|NP|-|-|V|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 16000
 
LS age: 296
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 0
Advertising Router: 10.0.1.22
LS Seq Number: 80000002
Checksum: 0x240b
Length: 44
 
Prefix type : Extended Prefix TLV
Route Type: 1
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 10.0.1.22
Flags: 0x40 (-|NP|-|-|-|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 1000
 
LS age: 931
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.1 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 1
Advertising Router: 10.0.1.1
LS Seq Number: 80000001
Checksum: 0x4587
Length: 48
 
Prefix type : Extended Prefix Range TLV
Prefix Length: 32
AF: 0
Range: 1
Flags: 0x00 (-|-|-|-|-|-|-|-)
Address Prefix: 10.0.1.33
Flags: 0x20 (-|-|M|-|-|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 4000
 
LS age: 931
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.2 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 2
Advertising Router: 10.0.1.1
LS Seq Number: 80000001
Checksum: 0xa331
Length: 48
 
Prefix type : Extended Prefix Range TLV
Prefix Length: 32
AF: 0
Range: 1
Flags: 0x00 (-|-|-|-|-|-|-|-)
Address Prefix: 10.0.1.44
Flags: 0x20 (-|-|M|-|-|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 5000
 
LS age: 1753
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.20 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10004
Advertising Router: 10.0.1.1
LS Seq Number: 80000001
Checksum: 0xd567
Length: 48
 
Link Type: 2
Link ID: 10.11.1.1
Link Data: 10.11.1.2
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
SID: 24960
 
 
LS age: 1754
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.20 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10004
Advertising Router: 10.0.1.11
LS Seq Number: 80000001
Checksum: 0x0713
Length: 52
 
Link Type: 2
Link ID: 10.11.1.1
Link Data: 10.11.1.1
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
NBR ID: 10.0.1.1
SID: 24961
 
 
LS age: 1643
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.22 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10006
Advertising Router: 10.0.1.2
LS Seq Number: 80000001
Checksum: 0x4d6b
Length: 48
 
Link Type: 2
Link ID: 10.11.2.1
Link Data: 10.11.2.2
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
SID: 24322
 
 
LS age: 1643
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.22 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10006
Advertising Router: 10.0.1.11
LS Seq Number: 80000001
Checksum: 0x50c3
Length: 52
 
Link Type: 2
Link ID: 10.11.2.1
Link Data: 10.11.2.1
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
NBR ID: 10.0.1.2
SID: 24962
 
 
LS age: 1852
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.24 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10008
Advertising Router: 10.0.1.11
LS Seq Number: 80000001
Checksum: 0xae29
Length: 52
 
Link Type: 2
Link ID: 10.11.22.1
Link Data: 10.11.22.1
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
NBR ID: 10.0.1.22
SID: 24960
 
 
LS age: 1853
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.24 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10008
Advertising Router: 10.0.1.22
LS Seq Number: 80000001
Checksum: 0xa752
Length: 48
 
Link Type: 2
Link ID: 10.11.22.1
Link Data: 10.11.22.2
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
SID: 24960
 
 
LS age: 50
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.25 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10009
Advertising Router: 10.0.1.1
LS Seq Number: 80000002
Checksum: 0xf32c
Length: 48
 
Link Type: 2
Link ID: 10.22.1.1
Link Data: 10.22.1.2
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
SID: 24961
 
 
LS age: 1747
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.25 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10009
Advertising Router: 10.0.1.22
LS Seq Number: 80000001
Checksum: 0xc72c
Length: 52
 
Link Type: 2
Link ID: 10.22.1.1
Link Data: 10.22.1.1
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
NBR ID: 10.0.1.1
SID: 24961
 
 
LS age: 1658
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.28 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10012
Advertising Router: 10.0.1.2
LS Seq Number: 80000001
Checksum: 0x2974
Length: 48
 
Link Type: 2
Link ID: 10.22.2.1
Link Data: 10.22.2.2
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
SID: 24321
 
 
LS age: 266
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.28 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10012
Advertising Router: 10.0.1.22
LS Seq Number: 80000002
Checksum: 0x05e6
Length: 52
 
Link Type: 2
Link ID: 10.22.2.1
Link Data: 10.22.2.1
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
NBR ID: 10.0.1.2
SID: 24962
 
 
LS age: 330
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.29 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10013
Advertising Router: 10.0.1.1
LS Seq Number: 80000002
Checksum: 0x0d1f
Length: 52
 
Link Type: 2
Link ID: 10.1.1.1
Link Data: 10.1.1.1
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
NBR ID: 10.0.1.2
SID: 24962
 
 
LS age: 86
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.29 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10013
Advertising Router: 10.0.1.2
LS Seq Number: 80000002
Checksum: 0x9335
Length: 48
 
Link Type: 2
Link ID: 10.1.1.1
Link Data: 10.1.1.2
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
SID: 24320
 
 
LS age: 1123
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.31 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10015
Advertising Router: 10.0.1.2
LS Seq Number: 80000001
Checksum: 0x2df9
Length: 52
 
Link Type: 2
Link ID: 10.44.2.2
Link Data: 10.44.2.2
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
NBR ID: 10.0.1.44
SID: 24323
 
 
LS age: 1301
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.35 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10019
Advertising Router: 10.0.1.1
LS Seq Number: 80000001
Checksum: 0x3d87
Length: 52
 
Link Type: 2
Link ID: 10.33.1.2
Link Data: 10.33.1.2
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
NBR ID: 10.0.1.33
SID: 24963
 
P1#show ip ospf database opaque-area 7.0.0.0
 
OSPF Router with ID (10.0.1.1) (Process ID 1 VRF default)
 
Area-Local Opaque-LSA (Area 0.0.0.0)
 
LS age: 1793
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 0
Advertising Router: 10.0.1.1
LS Seq Number: 80000001
Checksum: 0x6ffe
Length: 44
 
Prefix type : Extended Prefix TLV
Route Type: 1
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 10.0.1.1
Flags: 0x40 (-|NP|-|-|-|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 2000
 
LS age: 1711
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 0
Advertising Router: 10.0.1.2
LS Seq Number: 80000001
Checksum: 0x6917
Length: 44
 
Prefix type : Extended Prefix TLV
Route Type: 1
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 10.0.1.2
Flags: 0x40 (-|NP|-|-|-|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 3000
 
LS age: 2000
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 0
Advertising Router: 10.0.1.11
LS Seq Number: 80000001
Checksum: 0x94d6
Length: 44
 
Prefix type : Extended Prefix TLV
Route Type: 1
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 10.0.1.11
Flags: 0x48 (-|NP|-|-|V|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 16000
 
LS age: 307
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 0
Advertising Router: 10.0.1.22
LS Seq Number: 80000002
Checksum: 0x240b
Length: 44
 
Prefix type : Extended Prefix TLV
Route Type: 1
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 10.0.1.22
Flags: 0x40 (-|NP|-|-|-|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 1000
 
P1#show ip ospf database opaque-area 8.0.39.20
 
OSPF Router with ID (10.0.1.1) (Process ID 1 VRF default)
 
Area-Local Opaque-LSA (Area 0.0.0.0)
 
LS age: 1777
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.20 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10004
Advertising Router: 10.0.1.1
LS Seq Number: 80000001
Checksum: 0xd567
Length: 48
 
Link Type: 2
Link ID: 10.11.1.1
Link Data: 10.11.1.2
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
SID: 24960
 
 
LS age: 1778
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.20 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10004
Advertising Router: 10.0.1.11
LS Seq Number: 80000001
Checksum: 0x0713
Length: 52
 
Link Type: 2
Link ID: 10.11.1.1
Link Data: 10.11.1.1
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
NBR ID: 10.0.1.1
SID: 24961
 
P1#show ip ospf database opaque-area 8.0.39.22
 
OSPF Router with ID (10.0.1.1) (Process ID 1 VRF default)
 
Area-Local Opaque-LSA (Area 0.0.0.0)
 
LS age: 1671
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.22 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10006
Advertising Router: 10.0.1.2
LS Seq Number: 80000001
Checksum: 0x4d6b
Length: 48
 
Link Type: 2
Link ID: 10.11.2.1
Link Data: 10.11.2.2
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
SID: 24322
 
 
LS age: 1671
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.22 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10006
Advertising Router: 10.0.1.11
LS Seq Number: 80000001
Checksum: 0x50c3
Length: 52
 
Link Type: 2
Link ID: 10.11.2.1
Link Data: 10.11.2.1
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
NBR ID: 10.0.1.2
SID: 24962
 
P1#show ip ospf database opaque-area 4.0.0.0
 
OSPF Router with ID (10.0.1.1) (Process ID 1 VRF default)
 
Area-Local Opaque-LSA (Area 0.0.0.0)
 
LS age: 1018
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 4
Opaque ID: 0
Advertising Router: 10.0.1.1
LS Seq Number: 80000002
Checksum: 0x29c7
Length: 52
 
Range Size: 8000
Base-SID: 16000
Algorithm: 0
Preference: 200
 
 
LS age: 990
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 4
Opaque ID: 0
Advertising Router: 10.0.1.2
LS Seq Number: 80000002
Checksum: 0xfa59
Length: 52
 
Range Size: 8000
Base-SID: 16000
Algorithm: 0
Preference: 100
 
 
LS age: 384
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 4
Opaque ID: 0
Advertising Router: 10.0.1.11
LS Seq Number: 80000002
Checksum: 0x6e5c
Length: 44
 
Range Size: 8000
Base-SID: 16000
Algorithm: 0
 
 
LS age: 642
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 4
Opaque ID: 0
Advertising Router: 10.0.1.22
LS Seq Number: 80000002
Checksum: 0x2c93
Length: 44
 
Range Size: 8000
Base-SID: 16000
Algorithm: 0
Validation 5
Displays the details of mapping server entries.
P2#show segment-routing mapping-server prefix-sid-map ipv4
Prefix SID Index Range Flags
10.0.1.33/32 6000 1
10.0.1.44/32 7000 1
 
Number of mapping entries: 2
 
P2#show ip ospf segment-routing mapping-table active
OSPF process ID: 1
Conflict Resolution Policy: Quarantine
 
Prefix SID Index Range Flags
10.0.1.1/32 2000 1
10.0.1.2/32 3000 1
10.0.1.11/32 0 1
10.0.1.22/32 1000 1
10.0.1.33/32 4000 1
10.0.1.44/32 5000 1
 
Number of mapping entries in Active Table: 6
 
P2#show ip ospf segment-routing mapping-table inactive
OSPF process ID: 1
Conflict Resolution Policy: Quarantine
 
Prefix SID Index Range Flags
10.0.1.33/32 6000 1
10.0.1.44/32 7000 1
 
Number of mapping entries in Inactive Table: 2
 
P2#show ip ospf segment-routing announce-list
------------------------
Area 0.0.0.0
Instance 0
--------------
Prefix:10.0.1.2/32
Origin Adv-Router:10.0.1.2
Route-Type:1
------------------------