OcNOS-SP : Segment Routing Guide : Segment Routing Configuration Guide : Configuring OSPF Intra-Area Segment Routing
Configuring OSPF Intra-Area Segment Routing
This chapter shows how to configure segment routing between routers in the same area.
The segment routing capabilities of a router are advertised to other routers through the Router Information opaque LSA.
Prefix SIDs are advertised through the Extended Prefix opaque LSA which supports multiple Extended Prefix TLVs containing subTLVs to carry the prefix and corresponding SID information.
Topology
Figure 4-4 shows the configuration required to enable OSPF segment routing at a global level and configure a prefix SID at the interface level.
You can configure a prefix SID on any router directly attached to that network prefix. In most cases configuring only one router is sufficient. If a prefix SID with the same prefix is configured on different routers, IP Infusion Inc. recommends that all SID values be the same.
 
OSPF Intra-Area Segment Routing Topology
Note: You must ensure that prefix SIDs are globally unique. Do not configure the same SID on different prefixes.
PE1
 
PE1#configure terminal
Enter configure mode.
PE1(config)#int xe2
Enter interface mode.
PE1(config-if)#ip address 10.11.1.1/30
Configure the IP address of the interface.
PE1(config-if)#label-switching
Enable label switching.
R2(config-if)#exit
Exit interface mode.
PE1(config)#int xe4
Enter interface mode.
PE1(config-if)#ip address 10.11.2.1/30
Configure the IP address of the interface.
PE1(config-if)#label-switching
Enable label switching.
PE1(config-if)#exit
Exit interface mode.
PE1(config)#int lo
Enter interface mode.
PE1(config-if)#ip address 10.0.1.11/32 secondary
Configure the IP address of the interface.
PE1(config-if)#prefix-sid absolute 16000 no-php
Assign the prefix sid values
PE1(config-if)#exit
Exit interface mode.
PE1(config)#router ospf 1
Enter OSPF router mode for process ID 1.
PE1(config-router)#router-id 10.0.1.11
Set the router-id
PE1(config-router)#network 10.0.1.11/32 area 0.0.0.0
Advertise the lo interface in OSPF area 0.
PE1(config-router)#network 10.11.1.0/30 area 0.0.0.0
Advertise the xe2 interface in OSPF area 0.
PE1(config-router)#network 10.11.2.0/30 area 0.0.0.0
Advertise the xe4 interface in OSPF area 0.
PE1(config-router)#ospf segment-routing global block 16000 23999
Enable SRGB range under OSPF process.
PE1(config-router)#segment-routing mpls
Enable segment routing for the OSPF process.
PE1(config-if)#exit
Exit interface mode.
PE1(config)#commit
Commit the candidate configuration to the running configuration.
P1
 
P1#configure terminal
Enter configure mode.
P1(config)#int lo
Enter interface mode.
P1(config-if)#ip address 10.0.1.1/32 secondary
Configure the IP address of the interface.
P1(config-if)#prefix-sid index 1000 no-php
Set the SID value.
P1(config-if)#exit
Exit interface mode.
P1(config)#int xe2
Enter interface mode.
P1(config-if)#ip address 10.11.1.2/30
Configure the IP address of the interface.
P1(config-if)#label-switching
Enable label switching.
P1(config-if)#exit
Exit interface mode.
P1(config)#int xe11
Enter interface mode.
P1(config-if)#ip address 10.1.1.1/30
Configure the IP address of the loopback interface.
P1(nfig-if)#label-switching
Enable label switching
P1(config-if)#exit
Exit interface mode.
P1(config)#int xe17
Enter interface mode.
P1(config-if)#ip address 10.33.1.2/30
Configure the IP address of the loopback interface.
P1(nfig-if)#label-switching
Enable label switching
P1(config-if)#exit
Exit interface mode.
P1(config)#router ospf 1
Enter OSPF router mode for process ID 1.
P1(config-router)#router-id 10.0.1.1
Set the router-id
P1(config-router)#network 10.0.1.1/32 area 0.0.0.0
Advertise the lo interface in OSPF area 0.
P1(config-router)#network 10.1.1.0/30 area 0.0.0.0
Advertise the xe2 interface in OSPF area 0.
P1(config-router)#network 10.11.1.0/30 area 0.0.0.0
Advertise the xe11 interface in OSPF area 0.
P1(config-router)#network 10.33.1.0/30 area 0.0.0.0
Advertise the xe17 interface in OSPF area 0.
P1(config)#ospf segment-routing global block 16000 23999
Enable SRGB range under OSPF process.
P1(config-router)#segment-routing mpls
Enable segment routing for the OSPF process.
P1(config-if)#exit
Exit interface mode.
P1(config)#commit
Commit the candidate configuration to the running configuration.
P2
 
P2#configure terminal
Enter configure mode.
P2(config)#int lo
Enter interface mode.
P2(config-if)#ip address 10.0.1.2/32 secondary
Configure the IP address of the interface.
P2(config-if)#prefix-sid index 2000 no-php
Enable label switching.
P2(config-if)#exit
Exit interface mode.
P2(config)#int xe4
Enter interface mode.
P2(config-if)#ip address 10.11.2.2/30
Configure the IP address of the interface.
P2(config-if)#label-switching
Enable label switching.
P2(config-if)#exit
Exit interface mode.
P2(config)#int xe11
Enter interface mode.
P2(config-if)#ip address 10.1.1.2/30
Configure the IP address of the loopback interface.
P2(config-if)#label-switching
Enable label switching.
P2(config-if)#exit
Exit interface mode.
P2(config)#int xe13
Enter interface mode.
P2(config-if)#ip address 10.44.2.2/30
Configure the IP address of the loopback interface.
P2(config-if)#label-switching
Enable label switching.
P2(config-if)#exit
Exit interface mode.
P2(config)#router ospf 1
Enter OSPF router mode for process ID 1.
P2(config-router)#router-id 10.0.1.2
Advertise the router-id.
P2(config-router)#network 10.0.1.2/32 area 0.0.0.0
Advertise the lo interface in OSPF area 0.
P2(config-router)#network 10.1.1.0/30 area 0.0.0.0
Advertise the xe11 interface in OSPF area 0.
P2(config-router)#network 10.11.2.0/30 area 0.0.0.0
Advertise the xe4 interface in OSPF area 0.
P2(config-router)#network 10.44.2.0/30 area 0.0.0.0
Advertise the xe13 interface in OSPF area 0.
P2(config)#ospf segment-routing global block 16000 23999
Enable SRGB range under OSPF process.
P2(config-router)#segment-routing mpls
Enable segment routing for the OSPF process.
P2(config-if)#exit
Exit interface mode.
P2(config)#commit
Commit the candidate configuration to the running configuration.
PE3
 
PE3#configure terminal
Enter configure mode.
PE3(config)#int lo
Enter interface mode.
PE3(config-if)#ip address 10.0.1.33/32 secondary
Configure the IP address of the interface.
PE3(config-if)#prefix-sid absolute 19000 no-php
Enable label switching.
PE3(config-if)#exit
Exit interface mode.
PE3(config)#int xe15
Enter interface mode.
PE3(config-if)#ip address 10.33.44.1/30
Configure the IP address of the loopback interface.
PE3(config-if)#label-switching
Enable Label switching
PE3(config-if)#exit
Exit interface mode.
PE3(config)#int xe17
Enter interface mode.
PE3(config-if)#ip address 10.33.1.1/30
Configure the IP address of the loopback interface.
PE3(config-if)#label-switching
Enable Label switching
PE3(config-if)#exit
Exit interface mode.
PE3(config)#router ospf 1
Enter OSPF router mode for process ID 1.
PE3(config-router)#router-id 10.0.1.33
Advertise the router-id..
PE3(config-router)#network 10.0.1.33/32 area 0.0.0.0
Advertise the lo interface in OSPF area 0.
PE3(config-router)#network 10.33.1.0/30 area 0.0.0.0
Advertise the xe15 interface in OSPF area 0.
PE3(config-router)#network 10.33.44.0/30 area 0.0.0.0
Advertise the xe17 interface in OSPF area 0.
PE3(config-router)#ospf segment-routing global block 16000 23999
Enable SRGB range under OSPF process.
PE3(config-router)#segment-routing mpls
Enable segment routing for OSPF process.
PE3(config-if)#exit
Exit interface mode.
PE3(config)#commit
Commit the candidate configuration to the running configuration.
PE4
 
PE4#configure terminal
Enter configure mode
PE4(config)#int lo
Enter interface mode.
PE4(config-if)#ip address 10.0.1.44/32 secondary
Configure the IP address of the interface.
PE4(config-if)#prefix-sid absolute 20000 no-php
Enable label switching.
PE4(config-if)#exit
Exit interface mode.
PE4(config)#int xe13
Enter interface mode.
PE4(config-if)#ip address 10.44.2.1/30
Configure the IP address of the loopback interface.
PE4(config-if)#label-switching
Enable Label switching
PE4(config-if)#exit
Exit interface mode.
PE4(config)#int xe15
Enter interface mode.
PE4(config-if)#ip address 10.33.44.2/30
Configure the IP address of the loopback interface.
PE4(config-if)#label-switching
Enable Label switching
PE4(config-if)#exit
Exit interface mode.
PE4(config)#router ospf 1
Enter OSPF router mode for process ID 1.
PE4(config-router)#router-id 10.0.1.44
Advertise the router-id..
PE4(config-router)#network 10.0.1.44/32 area 0.0.0.0
Advertise the lo interface in OSPF area 0.
PE4(config-router)#network 10.33.44.0/30 area 0.0.0.0
Advertise the xe13 interface in OSPF area 0.
PE4(config-router)#network 10.44.2.0/30 area 0.0.0.0
Advertise the xe15 interface in OSPF area 0.
PE4(config-router)#ospf segment-routing global block 16000 23999
Enable SRGB range under OSPF process.
PE4(config-router)#segment-routing mpls
Enable segment routing for OSPF process.
PE4(config-if)#exit
Exit interface mode.
PE4(config)#commit
Commit the candidate configuration to the running configuration.
Validation
Validation 1
Verify OSPF neighbor adjacency between all 5 routers.
PE1#show ip ospf neighbor
 
Total number of full neighbors: 2
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
10.0.1.1 1 Full/Backup 00:00:32 10.11.1.2 xe2 0
10.0.1.2 1 Full/Backup 00:00:37 10.11.2.2 xe4 0
 
P1#show ip ospf neighbor
 
Total number of full neighbors: 3
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
10.0.1.2 1 Full/Backup 00:00:29 10.1.1.2 xe11 0
10.0.1.11 1 Full/DR 00:00:37 10.11.1.1 xe2 0
10.0.1.33 1 Full/Backup 00:00:35 10.33.1.1 xe17 0
 
P2#show ip ospf neighbor
 
Total number of full neighbors: 3
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
10.0.1.1 1 Full/DR 00:00:28 10.1.1.1 xe11 0
10.0.1.11 1 Full/DR 00:00:34 10.11.2.1 xe4 0
10.0.1.44 1 Full/Backup 00:00:34 10.44.2.1 xe13 0
 
PE3#show ip ospf neighbor
 
Total number of full neighbors: 2
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
10.0.1.1 1 Full/DR 00:00:31 10.33.1.2 xe17 0
10.0.1.44 1 Full/Backup 00:00:29 10.33.44.2 xe15 0
 
PE4#show ip ospf neighbor
 
Total number of full neighbors: 2
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
10.0.1.33 1 Full/DR 00:00:38 10.33.44.1 xe15 0
10.0.1.2 1 Full/DR 00:00:37 10.44.2.2 xe13 0
Validation 2
Verify that segment routing is enabled and that prefix SIDs are announced to other routers via OSPF opaque LSAs.
Verify that labels are in the MPLS forwarding table and that prefix SIDs are installed. Verify the same in FTN and ILM tables.
PE1#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
O> 10.0.1.1/32 1 0 Yes LSP_DEFAULT 17000 xe2 No 10.11.1.2
O> 10.0.1.2/32 2 0 Yes LSP_DEFAULT 18000 xe4 No 10.11.2.2
O> 10.0.1.33/32 3 0 Yes LSP_DEFAULT 19000 xe2 No 10.11.1.2
O> 10.0.1.44/32 4 0 Yes LSP_DEFAULT 20000 xe4 No 10.11.2.2
 
P1#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
O> 10.0.1.2/32 2 0 Yes LSP_DEFAULT 18000 xe11 No 10.1.1.2
O> 10.0.1.11/32 1 0 Yes LSP_DEFAULT 16000 xe2 No 10.11.1.1
O> 10.0.1.33/32 3 0 Yes LSP_DEFAULT 19000 xe17 No 10.33.1.1
O> 10.0.1.44/32 4 0 Yes LSP_DEFAULT 20000 xe11 No 10.1.1.2
 
P2#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
O> 10.0.1.1/32 1 0 Yes LSP_DEFAULT 17000 xe11 No 10.1.1.1
O> 10.0.1.11/32 2 0 Yes LSP_DEFAULT 16000 xe4 No 10.11.2.1
O> 10.0.1.33/32 3 0 Yes LSP_DEFAULT 19000 xe13 No 10.44.2.1
O> 10.0.1.44/32 4 0 Yes LSP_DEFAULT 20000 xe13 No 10.44.2.1
 
PE3#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
O> 10.0.1.1/32 1 0 Yes LSP_DEFAULT 17000 xe17 No 10.33.1.2
O> 10.0.1.2/32 2 0 Yes LSP_DEFAULT 18000 xe17 No 10.33.1.2
O> 10.0.1.11/32 3 0 Yes LSP_DEFAULT 16000 xe17 No 10.33.1.2
O> 10.0.1.44/32 4 0 Yes LSP_DEFAULT 20000 xe15 No 10.33.44.2
 
PE4#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
O> 10.0.1.1/32 1 0 Yes LSP_DEFAULT 17000 xe13 No 10.44.2.2
O> 10.0.1.2/32 2 0 Yes LSP_DEFAULT 18000 xe13 No 10.44.2.2
O> 10.0.1.11/32 3 0 Yes LSP_DEFAULT 16000 xe13 No 10.44.2.2
O> 10.0.1.33/32 4 0 Yes LSP_DEFAULT 19000 xe15 No 10.33.44.1
 
In the forwarding tables above, the configured prefix SIDs are in the Out-Label column which is expected and is global across the topology. The swap happens in between nodes with this prefix SID and there is no local labelling.
Also verify the ILM and FTN tables.
PE1#show mpls ftn-table
Primary FTN entry with FEC: 10.0.1.1/32, id: 1, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 2, in intf: - in label: 0 out-segment ix: 2
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 2, owner: OSPF-SR, Stale: NO, out intf: xe2, out label: 17000
Nexthop addr: 10.11.1.2 cross connect ix: 2, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.2/32, id: 2, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 4, in intf: - in label: 0 out-segment ix: 5
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 5, owner: OSPF-SR, Stale: NO, out intf: xe4, out label: 18000
Nexthop addr: 10.11.2.2 cross connect ix: 4, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.33/32, id: 3, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 5, in intf: - in label: 0 out-segment ix: 7
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 7, owner: OSPF-SR, Stale: NO, out intf: xe2, out label: 19000
Nexthop addr: 10.11.1.2 cross connect ix: 5, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.44/32, id: 4, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 7, in intf: - in label: 0 out-segment ix: 11
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 11, owner: OSPF-SR, Stale: NO, out intf: xe4, out label: 20000
Nexthop addr: 10.11.2.2 cross connect ix: 7, op code: Push
 
PE1#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop LSP-Type
O> 10.0.1.2/32 5 18000 18000 N/A xe4 10.11.2.2 LSP_DEFAULT
O> 10.0.1.1/32 3 17000 17000 N/A xe2 10.11.1.2 LSP_DEFAULT
O> 10.0.1.11/32 1 16000 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
O> 10.11.1.2/32 2 24320 3 N/A xe2 10.11.1.2 LSP_DEFAULT
O> 10.0.1.33/32 6 19000 19000 N/A xe2 10.11.1.2 LSP_DEFAULT
O> 10.0.1.44/32 7 20000 20000 N/A xe4 10.11.2.2 LSP_DEFAULT
O> 10.11.2.2/32 4 24321 3 N/A xe4 10.11.2.2 LSP_DEFAULT
 
Here, the ILM Entry for In-Label 24320 is for the adjacency SID. The rest of the entries are for the prefix SID.
P1#show mpls ftn-table
Primary FTN entry with FEC: 10.0.1.2/32, id: 2, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 4, in intf: - in label: 0 out-segment ix: 5
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 5, owner: OSPF-SR, Stale: NO, out intf: xe11, out label: 18000
Nexthop addr: 10.1.1.2 cross connect ix: 4, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.11/32, id: 1, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 1, in intf: - in label: 0 out-segment ix: 1
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 1, owner: OSPF-SR, Stale: NO, out intf: xe2, out label: 16000
Nexthop addr: 10.11.1.1 cross connect ix: 1, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.33/32, id: 3, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 5, in intf: - in label: 0 out-segment ix: 7
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 7, owner: OSPF-SR, Stale: NO, out intf: xe17, out label: 19000
Nexthop addr: 10.33.1.1 cross connect ix: 5, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.44/32, id: 4, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 8, in intf: - in label: 0 out-segment ix: 12
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 12, owner: OSPF-SR, Stale: NO, out intf: xe11, out label: 20000
Nexthop addr: 10.1.1.2 cross connect ix: 8, op code: Push
 
P1#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop LSP-Type
O> 10.0.1.2/32 5 18000 18000 N/A xe11 10.1.1.2 LSP_DEFAULT
O> 10.0.1.1/32 3 17000 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
O> 10.0.1.11/32 1 16000 16000 N/A xe2 10.11.1.1 LSP_DEFAULT
O> 10.11.1.1/32 2 24320 3 N/A xe2 10.11.1.1 LSP_DEFAULT
O> 10.0.1.33/32 6 19000 19000 N/A xe17 10.33.1.1 LSP_DEFAULT
O> 10.0.1.44/32 8 20000 20000 N/A xe11 10.1.1.2 LSP_DEFAULT
O> 10.1.1.2/32 4 24321 3 N/A xe11 10.1.1.2 LSP_DEFAULT
O> 10.33.1.1/32 7 24322 3 N/A xe17 10.33.1.1 LSP_DEFAULT
 
P2#show mpls ftn-table
Primary FTN entry with FEC: 10.0.1.1/32, id: 1, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 1, in intf: - in label: 0 out-segment ix: 1
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 1, owner: OSPF-SR, Stale: NO, out intf: xe11, out label: 17000
Nexthop addr: 10.1.1.1 cross connect ix: 1, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.11/32, id: 2, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 4, in intf: - in label: 0 out-segment ix: 6
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 6, owner: OSPF-SR, Stale: NO, out intf: xe4, out label: 16000
Nexthop addr: 10.11.2.1 cross connect ix: 4, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.33/32, id: 3, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 7, in intf: - in label: 0 out-segment ix: 11
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 11, owner: OSPF-SR, Stale: NO, out intf: xe13, out label: 19000
Nexthop addr: 10.44.2.1 cross connect ix: 7, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.44/32, id: 4, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 5, in intf: - in label: 0 out-segment ix: 7
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 7, owner: OSPF-SR, Stale: NO, out intf: xe13, out label: 20000
Nexthop addr: 10.44.2.1 cross connect ix: 5, op code: Push
 
P2#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop LSP-Type
O> 10.0.1.2/32 5 18000 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
O> 10.0.1.1/32 1 17000 17000 N/A xe11 10.1.1.1 LSP_DEFAULT
O> 10.0.1.11/32 2 16000 16000 N/A xe4 10.11.2.1 LSP_DEFAULT
O> 10.1.1.1/32 3 24320 3 N/A xe11 10.1.1.1 LSP_DEFAULT
O> 10.0.1.33/32 6 19000 19000 N/A xe13 10.44.2.1 LSP_DEFAULT
O> 10.0.1.44/32 7 20000 20000 N/A xe13 10.44.2.1 LSP_DEFAULT
O> 10.11.2.1/32 4 24321 3 N/A xe4 10.11.2.1 LSP_DEFAULT
O> 10.44.2.1/32 8 24322 3 N/A xe13 10.44.2.1 LSP_DEFAULT
 
PE3#show mpls ftn-table
Primary FTN entry with FEC: 10.0.1.1/32, id: 1, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 1, in intf: - in label: 0 out-segment ix: 1
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 1, owner: OSPF-SR, Stale: NO, out intf: xe17, out label: 17000
Nexthop addr: 10.33.1.2 cross connect ix: 1, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.2/32, id: 2, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 2, in intf: - in label: 0 out-segment ix: 3
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 3, owner: OSPF-SR, Stale: NO, out intf: xe17, out label: 18000
Nexthop addr: 10.33.1.2 cross connect ix: 2, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.11/32, id: 3, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 3, in intf: - in label: 0 out-segment ix: 5
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 5, owner: OSPF-SR, Stale: NO, out intf: xe17, out label: 16000
Nexthop addr: 10.33.1.2 cross connect ix: 3, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.44/32, id: 4, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 5, in intf: - in label: 0 out-segment ix: 8
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 8, owner: OSPF-SR, Stale: NO, out intf: xe15, out label: 20000
Nexthop addr: 10.33.44.2 cross connect ix: 5, op code: Push
 
PE3#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop LSP-Type
O> 10.0.1.33/32 1 19000 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
O> 10.0.1.1/32 2 17000 17000 N/A xe17 10.33.1.2 LSP_DEFAULT
O> 10.0.1.11/32 4 16000 16000 N/A xe17 10.33.1.2 LSP_DEFAULT
O> 10.0.1.2/32 3 18000 18000 N/A xe17 10.33.1.2 LSP_DEFAULT
O> 10.33.1.2/32 5 24320 3 N/A xe17 10.33.1.2 LSP_DEFAULT
O> 10.0.1.44/32 6 20000 20000 N/A xe15 10.33.44.2 LSP_DEFAULT
O> 10.33.44.2/32 7 24321 3 N/A xe15 10.33.44.2 LSP_DEFAULT
 
 
PE4#show mpls ftn-table
Primary FTN entry with FEC: 10.0.1.1/32, id: 1, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 6, in intf: - in label: 0 out-segment ix: 10
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 10, owner: OSPF-SR, Stale: NO, out intf: xe13, out label: 17000
Nexthop addr: 10.44.2.2 cross connect ix: 6, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.2/32, id: 2, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 1, in intf: - in label: 0 out-segment ix: 1
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 1, owner: OSPF-SR, Stale: NO, out intf: xe13, out label: 18000
Nexthop addr: 10.44.2.2 cross connect ix: 1, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.11/32, id: 3, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 2, in intf: - in label: 0 out-segment ix: 3
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 3, owner: OSPF-SR, Stale: NO, out intf: xe13, out label: 16000
Nexthop addr: 10.44.2.2 cross connect ix: 2, op code: Push
 
 
Primary FTN entry with FEC: 10.0.1.33/32, id: 4, row status: Active
Owner: OSPF-SR, distance: 110, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Cross connect ix: 4, in intf: - in label: 0 out-segment ix: 7
Owner: OSPF-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 7, owner: OSPF-SR, Stale: NO, out intf: xe15, out label: 19000
Nexthop addr: 10.33.44.1 cross connect ix: 4, op code: Push
 
PE4#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
 
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop LSP-Type
O> 10.0.1.33/32 5 19000 19000 N/A xe15 10.33.44.1 LSP_DEFAULT
O> 10.0.1.1/32 2 17000 17000 N/A xe13 10.44.2.2 LSP_DEFAULT
O> 10.0.1.11/32 4 16000 16000 N/A xe13 10.44.2.2 LSP_DEFAULT
O> 10.0.1.2/32 3 18000 18000 N/A xe13 10.44.2.2 LSP_DEFAULT
O> 10.33.44.1/32 6 24320 3 N/A xe15 10.33.44.1 LSP_DEFAULT
O> 10.0.1.44/32 1 20000 Nolabel N/A N/A 127.0.0.1 LSP_DEFAULT
O> 10.44.2.2/32 7 24321 3 N/A xe13 10.44.2.2 LSP_DEFAULT
Validation 3
The command output below displays the details of routers configured with segment routing.
PE1#show ip ospf segment-routing capability
 
OSPF process 1:
-----------------------------------------------------
Advertisement Router Capability :10.0.1.1
Algorithm :0
SRMS Preference :0
Total SID'S Supported :8000
SID Range List Count :1
SID's Range :16000 - 23999
-----------------------------------------------------
Advertisement Router Capability :10.0.1.2
Algorithm :0
SRMS Preference :0
Total SID'S Supported :8000
SID Range List Count :1
SID's Range :16000 - 23999
-----------------------------------------------------
Advertisement Router Capability :10.0.1.11
Algorithm :0
SRMS Preference :0
Total SID'S Supported :8000
SID Range List Count :1
SID's Range :16000 - 23999
-----------------------------------------------------
Advertisement Router Capability :10.0.1.33
Algorithm :0
SRMS Preference :0
Total SID'S Supported :8000
SID Range List Count :1
SID's Range :16000 - 23999
-----------------------------------------------------
Advertisement Router Capability :10.0.1.44
Algorithm :0
SRMS Preference :0
Total SID'S Supported :8000
SID Range List Count :1
SID's Range :16000 - 23999
-----------------------------------------------------
The command below displays the database details where a prefix SID is advertised through opaque LSAs.
PE1#show ip ospf database opaque-area self-originate
 
OSPF Router with ID (10.0.1.11) (Process ID 1 VRF default)
 
Area-Local Opaque-LSA (Area 0.0.0.0)
 
LS age: 569
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.1 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 1
Advertising Router: 10.0.1.11
LS Seq Number: 80000004
Checksum: 0x40bf
Length: 28
 
MPLS TE router ID : 10.0.1.11
 
Number of Links : 0
 
LS age: 663
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.12 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 12
Advertising Router: 10.0.1.11
LS Seq Number: 80000001
Checksum: 0x6abc
Length: 108
 
Link connected to Broadcast network
Link ID : 10.11.1.1
Interface Address : 10.11.1.1
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 569
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.16 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 16
Advertising Router: 10.0.1.11
LS Seq Number: 80000001
Checksum: 0x74ac
Length: 108
 
Link connected to Broadcast network
Link ID : 10.11.2.1
Interface Address : 10.11.2.1
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 758
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 4
Opaque ID: 0
Advertising Router: 10.0.1.11
LS Seq Number: 80000001
Checksum: 0x705b
Length: 44
 
Range Size: 8000
Base-SID: 16000
Algorithm: 0
 
 
LS age: 758
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 0
Advertising Router: 10.0.1.11
LS Seq Number: 80000001
Checksum: 0x94d6
Length: 44
 
Prefix type : Extended Prefix TLV
Route Type: 1
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 10.0.1.11
Flags: 0x48 (-|NP|-|-|V|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 16000
 
LS age: 663
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.20 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10004
Advertising Router: 10.0.1.11
LS Seq Number: 80000001
Checksum: 0x1588
Length: 52
 
Link Type: 2
Link ID: 10.11.1.1
Link Data: 10.11.1.1
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
Weight: 0
NBR ID: 10.0.1.1
SID: 24320
 
 
LS age: 569
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.22 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10006
Advertising Router: 10.0.1.11
LS Seq Number: 80000001
Checksum: 0x5e39
Length: 52
 
Link Type: 2
Link ID: 10.11.2.1
Link Data: 10.11.2.1
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
Weight: 0
NBR ID: 10.0.1.2
SID: 24321
 
 
PE1#show ip ospf database opaque-area
 
OSPF Router with ID (10.0.1.11) (Process ID 1 VRF default)
 
Area-Local Opaque-LSA (Area 0.0.0.0)
 
LS age: 560
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.1 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 1
Advertising Router: 10.0.1.1
LS Seq Number: 80000004
Checksum: 0x18fb
Length: 28
 
MPLS TE router ID : 10.0.1.1
 
Number of Links : 0
 
LS age: 557
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.1 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 1
Advertising Router: 10.0.1.2
LS Seq Number: 80000003
Checksum: 0x1ef4
Length: 28
 
MPLS TE router ID : 10.0.1.2
 
Number of Links : 0
 
LS age: 556
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.1 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 1
Advertising Router: 10.0.1.11
LS Seq Number: 80000004
Checksum: 0x40bf
Length: 28
 
MPLS TE router ID : 10.0.1.11
 
Number of Links : 0
 
LS age: 385
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.1 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 1
Advertising Router: 10.0.1.33
LS Seq Number: 80000003
Checksum: 0x9a3a
Length: 28
 
MPLS TE router ID : 10.0.1.33
 
Number of Links : 0
 
LS age: 377
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.1 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 1
Advertising Router: 10.0.1.44
LS Seq Number: 80000003
Checksum: 0xc6f7
Length: 28
 
MPLS TE router ID : 10.0.1.44
 
Number of Links : 0
 
LS age: 652
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.12 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 12
Advertising Router: 10.0.1.1
LS Seq Number: 80000001
Checksum: 0xc46b
Length: 108
 
Link connected to Broadcast network
Link ID : 10.11.1.1
Interface Address : 10.11.1.2
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 651
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.12 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 12
Advertising Router: 10.0.1.11
LS Seq Number: 80000001
Checksum: 0x6abc
Length: 108
 
Link connected to Broadcast network
Link ID : 10.11.1.1
Interface Address : 10.11.1.1
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 557
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.16 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 16
Advertising Router: 10.0.1.2
LS Seq Number: 80000001
Checksum: 0xc860
Length: 108
 
Link connected to Broadcast network
Link ID : 10.11.2.1
Interface Address : 10.11.2.2
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 556
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.16 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 16
Advertising Router: 10.0.1.11
LS Seq Number: 80000001
Checksum: 0x74ac
Length: 108
 
Link connected to Broadcast network
Link ID : 10.11.2.1
Interface Address : 10.11.2.1
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 560
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.30 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 30
Advertising Router: 10.0.1.1
LS Seq Number: 80000001
Checksum: 0x1023
Length: 108
 
Link connected to Broadcast network
Link ID : 10.1.1.1
Interface Address : 10.1.1.1
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 561
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.30 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 30
Advertising Router: 10.0.1.2
LS Seq Number: 80000001
Checksum: 0x2809
Length: 108
 
Link connected to Broadcast network
Link ID : 10.1.1.1
Interface Address : 10.1.1.2
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 377
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.32 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 32
Advertising Router: 10.0.1.44
LS Seq Number: 80000001
Checksum: 0x5953
Length: 108
 
Link connected to Broadcast network
Link ID : 10.44.2.2
Interface Address : 10.44.2.1
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 376
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.34 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 34
Advertising Router: 10.0.1.2
LS Seq Number: 80000001
Checksum: 0x6073
Length: 108
 
Link connected to Broadcast network
Link ID : 10.44.2.2
Interface Address : 10.44.2.2
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 385
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.36 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 36
Advertising Router: 10.0.1.33
LS Seq Number: 80000001
Checksum: 0x87ee
Length: 108
 
Link connected to Broadcast network
Link ID : 10.33.44.1
Interface Address : 10.33.44.1
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 385
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.36 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 36
Advertising Router: 10.0.1.44
LS Seq Number: 80000001
Checksum: 0x6307
Length: 108
 
Link connected to Broadcast network
Link ID : 10.33.44.1
Interface Address : 10.33.44.2
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 490
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.40 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 40
Advertising Router: 10.0.1.33
LS Seq Number: 80000001
Checksum: 0x07c0
Length: 108
 
Link connected to Broadcast network
Link ID : 10.33.1.2
Interface Address : 10.33.1.1
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 489
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 1.0.0.42 (Area-Local Opaque-Type/ID)
Opaque Type: 1
Opaque ID: 42
Advertising Router: 10.0.1.1
LS Seq Number: 80000001
Checksum: 0xd113
Length: 108
 
Link connected to Broadcast network
Link ID : 10.33.1.2
Interface Address : 10.33.1.2
Admin Metric : 1
Maximum bandwidth : 10000000.00 Kbits/s
Maximum reservable bandwidth : 10000000.00 Kbits/s
Unreserved Bandwidth :
Number of Priority : 8
Priority 0 : 10000000.00 Kbits/s Priority 1 : 10000000.00 Kbits/s
Priority 2 : 10000000.00 Kbits/s Priority 3 : 10000000.00 Kbits/s
Priority 4 : 10000000.00 Kbits/s Priority 5 : 10000000.00 Kbits/s
Priority 6 : 10000000.00 Kbits/s Priority 7 : 10000000.00 Kbits/s
 
Number of Links : 1
 
LS age: 657
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 4
Opaque ID: 0
Advertising Router: 10.0.1.1
LS Seq Number: 80000001
Checksum: 0xac29
Length: 44
 
Range Size: 8000
Base-SID: 16000
Algorithm: 0
 
 
LS age: 570
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 4
Opaque ID: 0
Advertising Router: 10.0.1.2
LS Seq Number: 80000001
Checksum: 0xa62e
Length: 44
 
Range Size: 8000
Base-SID: 16000
Algorithm: 0
 
 
LS age: 746
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 4
Opaque ID: 0
Advertising Router: 10.0.1.11
LS Seq Number: 80000001
Checksum: 0x705b
Length: 44
 
Range Size: 8000
Base-SID: 16000
Algorithm: 0
 
 
LS age: 502
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 4
Opaque ID: 0
Advertising Router: 10.0.1.33
LS Seq Number: 80000001
Checksum: 0xebc9
Length: 44
 
Range Size: 8000
Base-SID: 16000
Algorithm: 0
 
 
LS age: 409
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 4
Opaque ID: 0
Advertising Router: 10.0.1.44
LS Seq Number: 80000001
Checksum: 0xa901
Length: 44
 
Range Size: 8000
Base-SID: 16000
Algorithm: 0
 
 
LS age: 622
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 0
Advertising Router: 10.0.1.1
LS Seq Number: 80000001
Checksum: 0x7ddc
Length: 44
 
Prefix type : Extended Prefix TLV
Route Type: 1
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 10.0.1.1
Flags: 0x40 (-|NP|-|-|-|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 1000
 
LS age: 552
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 0
Advertising Router: 10.0.1.2
LS Seq Number: 80000001
Checksum: 0x77f4
Length: 44
 
Prefix type : Extended Prefix TLV
Route Type: 1
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 10.0.1.2
Flags: 0x40 (-|NP|-|-|-|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 2000
 
LS age: 746
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 0
Advertising Router: 10.0.1.11
LS Seq Number: 80000001
Checksum: 0x94d6
Length: 44
 
Prefix type : Extended Prefix TLV
Route Type: 1
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 10.0.1.11
Flags: 0x48 (-|NP|-|-|V|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 16000
 
LS age: 502
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 0
Advertising Router: 10.0.1.33
LS Seq Number: 80000001
Checksum: 0x1b60
Length: 44
 
Prefix type : Extended Prefix TLV
Route Type: 1
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 10.0.1.33
Flags: 0x48 (-|NP|-|-|V|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 19000
 
LS age: 409
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 0
Advertising Router: 10.0.1.44
LS Seq Number: 80000001
Checksum: 0x6514
Length: 44
 
Prefix type : Extended Prefix TLV
Route Type: 1
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 10.0.1.44
Flags: 0x48 (-|NP|-|-|V|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 20000
 
LS age: 652
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.20 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10004
Advertising Router: 10.0.1.1
LS Seq Number: 80000001
Checksum: 0x0fb0
Length: 48
 
Link Type: 2
Link ID: 10.11.1.1
Link Data: 10.11.1.2
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
Weight: 0
SID: 24320
 
 
LS age: 651
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.20 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10004
Advertising Router: 10.0.1.11
LS Seq Number: 80000001
Checksum: 0x1588
Length: 52
 
Link Type: 2
Link ID: 10.11.1.1
Link Data: 10.11.1.1
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
Weight: 0
NBR ID: 10.0.1.1
SID: 24320
 
 
LS age: 557
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.22 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10006
Advertising Router: 10.0.1.2
LS Seq Number: 80000001
Checksum: 0x3089
Length: 48
 
Link Type: 2
Link ID: 10.11.2.1
Link Data: 10.11.2.2
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
Weight: 0
SID: 24321
 
 
LS age: 556
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.22 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10006
Advertising Router: 10.0.1.11
LS Seq Number: 80000001
Checksum: 0x5e39
Length: 52
 
Link Type: 2
Link ID: 10.11.2.1
Link Data: 10.11.2.1
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
Weight: 0
NBR ID: 10.0.1.2
SID: 24321
 
 
LS age: 560
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.29 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10013
Advertising Router: 10.0.1.1
LS Seq Number: 80000001
Checksum: 0x1d93
Length: 52
 
Link Type: 2
Link ID: 10.1.1.1
Link Data: 10.1.1.1
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
Weight: 0
NBR ID: 10.0.1.2
SID: 24321
 
 
LS age: 561
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.29 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10013
Advertising Router: 10.0.1.2
LS Seq Number: 80000001
Checksum: 0x9534
Length: 48
 
Link Type: 2
Link ID: 10.1.1.1
Link Data: 10.1.1.2
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
Weight: 0
SID: 24320
 
 
LS age: 377
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.30 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10014
Advertising Router: 10.0.1.44
LS Seq Number: 80000001
Checksum: 0x7ec6
Length: 48
 
Link Type: 2
Link ID: 10.44.2.2
Link Data: 10.44.2.1
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
Weight: 0
SID: 24321
 
 
LS age: 376
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.31 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10015
Advertising Router: 10.0.1.2
LS Seq Number: 80000001
Checksum: 0x0c1c
Length: 52
 
Link Type: 2
Link ID: 10.44.2.2
Link Data: 10.44.2.2
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
Weight: 0
NBR ID: 10.0.1.44
SID: 24322
 
 
LS age: 385
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.32 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10016
Advertising Router: 10.0.1.33
LS Seq Number: 80000001
Checksum: 0xc10b
Length: 52
 
Link Type: 2
Link ID: 10.33.44.1
Link Data: 10.33.44.1
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
Weight: 0
NBR ID: 10.0.1.44
SID: 24321
 
 
LS age: 385
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.32 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10016
Advertising Router: 10.0.1.44
LS Seq Number: 80000001
Checksum: 0x0df8
Length: 48
 
Link Type: 2
Link ID: 10.33.44.1
Link Data: 10.33.44.2
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
Weight: 0
SID: 24320
 
 
LS age: 490
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.34 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10018
Advertising Router: 10.0.1.33
LS Seq Number: 80000001
Checksum: 0x283d
Length: 48
 
Link Type: 2
Link ID: 10.33.1.2
Link Data: 10.33.1.1
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
Weight: 0
SID: 24320
 
 
LS age: 489
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.35 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10019
Advertising Router: 10.0.1.1
LS Seq Number: 80000001
Checksum: 0x4bfc
Length: 52
 
Link Type: 2
Link ID: 10.33.1.2
Link Data: 10.33.1.2
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
Weight: 0
NBR ID: 10.0.1.33
SID: 24322
 
PE1#show ip ospf database opaque-area 7.0.0.0
 
OSPF Router with ID (10.0.1.11) (Process ID 1 VRF default)
 
Area-Local Opaque-LSA (Area 0.0.0.0)
 
LS age: 685
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 0
Advertising Router: 10.0.1.1
LS Seq Number: 80000001
Checksum: 0x7ddc
Length: 44
 
Prefix type : Extended Prefix TLV
Route Type: 1
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 10.0.1.1
Flags: 0x40 (-|NP|-|-|-|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 1000
 
LS age: 615
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 0
Advertising Router: 10.0.1.2
LS Seq Number: 80000001
Checksum: 0x77f4
Length: 44
 
Prefix type : Extended Prefix TLV
Route Type: 1
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 10.0.1.2
Flags: 0x40 (-|NP|-|-|-|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 2000
 
LS age: 809
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 0
Advertising Router: 10.0.1.11
LS Seq Number: 80000001
Checksum: 0x94d6
Length: 44
 
Prefix type : Extended Prefix TLV
Route Type: 1
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 10.0.1.11
Flags: 0x48 (-|NP|-|-|V|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 16000
 
LS age: 565
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 0
Advertising Router: 10.0.1.33
LS Seq Number: 80000001
Checksum: 0x1b60
Length: 44
 
Prefix type : Extended Prefix TLV
Route Type: 1
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 10.0.1.33
Flags: 0x48 (-|NP|-|-|V|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 19000
 
LS age: 473
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 7.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 7
Opaque ID: 0
Advertising Router: 10.0.1.44
LS Seq Number: 80000001
Checksum: 0x6514
Length: 44
 
Prefix type : Extended Prefix TLV
Route Type: 1
Prefix Length: 32
AF: 0
Flags: 0x40 (-|N|-|-|-|-|-|-)
Address Prefix: 10.0.1.44
Flags: 0x48 (-|NP|-|-|V|-|-|-)
MT-ID: 0
Algorithm: 0
SID: 20000
The command below displays the database details where an adjacency SID is advertised through opaque LSAs.
PE1#show ip ospf database opaque-area 8.0.39.20
 
OSPF Router with ID (10.0.1.11) (Process ID 1 VRF default)
 
Area-Local Opaque-LSA (Area 0.0.0.0)
 
LS age: 766
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.20 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10004
Advertising Router: 10.0.1.1
LS Seq Number: 80000001
Checksum: 0x0fb0
Length: 48
 
Link Type: 2
Link ID: 10.11.1.1
Link Data: 10.11.1.2
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
Weight: 0
SID: 24320
 
 
LS age: 765
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.20 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10004
Advertising Router: 10.0.1.11
LS Seq Number: 80000001
Checksum: 0x1588
Length: 52
 
Link Type: 2
Link ID: 10.11.1.1
Link Data: 10.11.1.1
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
Weight: 0
NBR ID: 10.0.1.1
SID: 24320
 
PE1#show ip ospf database opaque-area 8.0.39.35
 
OSPF Router with ID (10.0.1.11) (Process ID 1 VRF default)
 
Area-Local Opaque-LSA (Area 0.0.0.0)
 
LS age: 649
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.35 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10019
Advertising Router: 10.0.1.1
LS Seq Number: 80000001
Checksum: 0x4bfc
Length: 52
 
Link Type: 2
Link ID: 10.33.1.2
Link Data: 10.33.1.2
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
Weight: 0
NBR ID: 10.0.1.33
SID: 24322
 
PE1#show ip ospf database opaque-area 8.0.39.22
 
OSPF Router with ID (10.0.1.11) (Process ID 1 VRF default)
 
Area-Local Opaque-LSA (Area 0.0.0.0)
 
LS age: 734
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.22 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10006
Advertising Router: 10.0.1.2
LS Seq Number: 80000001
Checksum: 0x3089
Length: 48
 
Link Type: 2
Link ID: 10.11.2.1
Link Data: 10.11.2.2
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
Weight: 0
SID: 24321
 
 
LS age: 733
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 8.0.39.22 (Area-Local Opaque-Type/ID)
Opaque Type: 8
Opaque ID: 10006
Advertising Router: 10.0.1.11
LS Seq Number: 80000001
Checksum: 0x5e39
Length: 52
 
Link Type: 2
Link ID: 10.11.2.1
Link Data: 10.11.2.1
Flags: 0x60 (-|V|L|-|-|-|-|-)
MT-ID: 0
Weight: 0
NBR ID: 10.0.1.2
SID: 24321
The command below on R1 displays who is advertising the prefix SID.
PE1#show ip ospf segment-routing announce-list
------------------------
Area 0.0.0.0
Instance 0
--------------
Prefix:10.0.1.11/32
Origin Adv-Router:10.0.1.11
Route-Type:1
------------------------
To verify the SID range through opaque LSAs, use the show ip ospf database opaque-area 4.0.0.0 command. The command displays the SID range and the base SID as well as the LSA details.
PE1#show ip ospf database opaque-area 4.0.0.0
 
OSPF Router with ID (10.0.1.11) (Process ID 1 VRF default)
 
Area-Local Opaque-LSA (Area 0.0.0.0)
 
LS age: 730
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 4
Opaque ID: 0
Advertising Router: 10.0.1.1
LS Seq Number: 80000001
Checksum: 0xac29
Length: 44
 
Range Size: 8000
Base-SID: 16000
Algorithm: 0
 
 
LS age: 643
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 4
Opaque ID: 0
Advertising Router: 10.0.1.2
LS Seq Number: 80000001
Checksum: 0xa62e
Length: 44
 
Range Size: 8000
Base-SID: 16000
Algorithm: 0
 
 
LS age: 819
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 4
Opaque ID: 0
Advertising Router: 10.0.1.11
LS Seq Number: 80000001
Checksum: 0x705b
Length: 44
 
Range Size: 8000
Base-SID: 16000
Algorithm: 0
 
 
LS age: 575
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 4
Opaque ID: 0
Advertising Router: 10.0.1.33
LS Seq Number: 80000001
Checksum: 0xebc9
Length: 44
 
Range Size: 8000
Base-SID: 16000
Algorithm: 0
 
 
LS age: 482
Options: 0x22 (-|-|DC|-|-|-|E|-)
LS Type: Area-Local Opaque-LSA
Link State ID: 4.0.0.0 (Area-Local Opaque-Type/ID)
Opaque Type: 4
Opaque ID: 0
Advertising Router: 10.0.1.44
LS Seq Number: 80000001
Checksum: 0xa901
Length: 44
 
Range Size: 8000
Base-SID: 16000
Algorithm: 0
 
 
 
PE1#show ip ospf database
 
OSPF Router with ID (10.0.1.11) (Process ID 1 VRF default)
 
Router Link States (Area 0.0.0.0)
 
Link ID ADV Router Age Seq# CkSum Link count
10.0.1.1 10.0.1.1 509 0x8000000b 0xf736 4
10.0.1.2 10.0.1.2 396 0x80000008 0xa56d 4
10.0.1.11 10.0.1.11 577 0x80000007 0x5a11 3
10.0.1.33 10.0.1.33 405 0x80000006 0x1f5d 3
10.0.1.44 10.0.1.44 395 0x80000004 0x3014 3
 
Net Link States (Area 0.0.0.0)
 
Link ID ADV Router Age Seq# CkSum
10.1.1.1 10.0.1.1 580 0x80000001 0x7397
10.11.1.1 10.0.1.11 671 0x80000001 0x15d8
10.11.2.1 10.0.1.11 577 0x80000001 0x18d3
10.33.1.2 10.0.1.1 509 0x80000001 0x9b2f
10.33.44.1 10.0.1.33 405 0x80000001 0xe56f
10.44.2.2 10.0.1.2 396 0x80000001 0xaa07
 
Area-Local Opaque-LSA (Area 0.0.0.0)
 
Link ID ADV Router Age Seq# CkSum Opaque ID
1.0.0.1 10.0.1.1 578 0x80000004 0x18fb 1
1.0.0.1 10.0.1.2 576 0x80000003 0x1ef4 1
1.0.0.1 10.0.1.11 575 0x80000004 0x40bf 1
1.0.0.1 10.0.1.33 403 0x80000003 0x9a3a 1
1.0.0.1 10.0.1.44 395 0x80000003 0xc6f7 1
1.0.0.12 10.0.1.1 670 0x80000001 0xc46b 12
1.0.0.12 10.0.1.11 669 0x80000001 0x6abc 12
1.0.0.16 10.0.1.2 576 0x80000001 0xc860 16
1.0.0.16 10.0.1.11 575 0x80000001 0x74ac 16
1.0.0.30 10.0.1.1 578 0x80000001 0x1023 30
1.0.0.30 10.0.1.2 579 0x80000001 0x2809 30
1.0.0.32 10.0.1.44 395 0x80000001 0x5953 32
1.0.0.34 10.0.1.2 394 0x80000001 0x6073 34
1.0.0.36 10.0.1.33 403 0x80000001 0x87ee 36
1.0.0.36 10.0.1.44 404 0x80000001 0x6307 36
1.0.0.40 10.0.1.33 508 0x80000001 0x07c0 40
1.0.0.42 10.0.1.1 507 0x80000001 0xd113 42
4.0.0.0 10.0.1.1 675 0x80000001 0xac29 0
4.0.0.0 10.0.1.2 588 0x80000001 0xa62e 0
4.0.0.0 10.0.1.11 764 0x80000001 0x705b 0
4.0.0.0 10.0.1.33 520 0x80000001 0xebc9 0
4.0.0.0 10.0.1.44 428 0x80000001 0xa901 0
7.0.0.0 10.0.1.1 640 0x80000001 0x7ddc 0
7.0.0.0 10.0.1.2 570 0x80000001 0x77f4 0
7.0.0.0 10.0.1.11 764 0x80000001 0x94d6 0
7.0.0.0 10.0.1.33 520 0x80000001 0x1b60 0
7.0.0.0 10.0.1.44 428 0x80000001 0x6514 0
8.0.39.20 10.0.1.1 670 0x80000001 0x0fb0 10004
8.0.39.20 10.0.1.11 669 0x80000001 0x1588 10004
8.0.39.22 10.0.1.2 576 0x80000001 0x3089 10006
8.0.39.22 10.0.1.11 575 0x80000001 0x5e39 10006
8.0.39.29 10.0.1.1 578 0x80000001 0x1d93 10013
8.0.39.29 10.0.1.2 579 0x80000001 0x9534 10013
8.0.39.30 10.0.1.44 395 0x80000001 0x7ec6 10014
8.0.39.31 10.0.1.2 394 0x80000001 0x0c1c 10015
8.0.39.32 10.0.1.33 403 0x80000001 0xc10b 10016
8.0.39.32 10.0.1.44 404 0x80000001 0x0df8 10016
8.0.39.34 10.0.1.33 508 0x80000001 0x283d 10018
8.0.39.35 10.0.1.1 507 0x80000001 0x4bfc 10019
Segment Routing MPLS OAM
Segment Routing Operations, Administration, and Maintenance (OAM) helps service providers to monitor label-switched paths (LSPs) and quickly isolate forwarding problems to assist with fault detection and troubleshooting in the network.
The Segment Routing OAM feature provides support for FEC (forwarding equivalence classes) LSP Ping and Traceroute, IGP prefix SID FEC type, and partially IGP adjacency-SID FEC.
The following are the main benefits of Segment Routing-OAM Support:
Operations: Network monitoring and fault management.
Administration: Network discovery and planning.
Maintenance: Corrective and preventive activities, minimize occurrences and impact of failures.
Segment Routing Ping
The MPLS LSP ping feature is used to check the connectivity between ingress and egress of LSP. MPLS LSP ping uses MPLS echo request and reply messages, similar to Internet Control Message Protocol (ICMP) echo request and reply messages, to validate an LSP.
Segment routing ping is an extension of the MPLS LSP ping to perform the connectivity verification on the segment routing control plane.
Segment Routing ping can use either generic FEC type or SR control-plane FEC type (ISIS-SR or OSPF-SR)
Segment Routing Traceroute
The MPLS LSP traceroute is used to isolate the failure point of an LSP. It is used for hop-by-hop fault localization and path tracing. The MPLS LSP traceroute feature relies on the expiration of the Time to Live (TTL) value of the packet that carries the echo request.
Similar to segment routing ping, you can initiate the segment routing traceroute operation only when Segment Routing control plane is available at the originator
Segment Routing traceroute can use either generic FEC type or SR control-plane FEC type (OSPF-SR or ISIS-SR).
Kindly refer Figure 4-4
Validation
These examples show how to use segment routing ping to test the connectivity of a segment routing control plane and segment routing trace to trace LSP of specified Prefix SID.
Ping with other options
PE1#ping mpls ospf-sr ipv4 10.0.1.33/32
Sending 5 MPLS Echos to 2.32.0.0, timeout is 5 seconds
 
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
 
Type 'Ctrl+C' to abort
 
!
!
!
!
!
 
Success Rate is 100.00 percent (5/5)
Detail
PE1#ping mpls ospf-sr ipv4 10.0.1.33/32 detail
Sending 5 MPLS Echos to 10.0.1.33, timeout is 5 seconds
 
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
 
Type 'Ctrl+C' to abort
 
! seq_num = 1 10.0.1.33 1.10 ms
! seq_num = 2 10.0.1.33 0.61 ms
! seq_num = 3 10.0.1.33 0.58 ms
! seq_num = 4 10.0.1.33 0.59 ms
! seq_num = 5 10.0.1.33 0.58 ms
 
Success Rate is 100.00 percent (5/5)
round-trip min/avg/max = 0.58/0.84/1.10
Destination
PE1#ping mpls ospf-sr ipv4 10.0.1.33/32 destination 127.1.0.1 detail
Sending 5 MPLS Echos to 10.0.1.33, timeout is 5 seconds
 
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
 
Type 'Ctrl+C' to abort
 
! seq_num = 1 10.0.1.33 0.69 ms
! seq_num = 2 10.0.1.33 0.61 ms
! seq_num = 3 10.0.1.33 0.45 ms
! seq_num = 4 10.0.1.33 0.56 ms
! seq_num = 5 10.0.1.33 0.52 ms
 
Success Rate is 100.00 percent (5/5)
round-trip min/avg/max = 0.45/0.57/0.69
Source
PE1#ping mpls ospf-sr ipv4 10.0.1.33/32 source 10.0.1.11
Sending 5 MPLS Echos to 2.32.0.0, timeout is 5 seconds
 
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
 
Type 'Ctrl+C' to abort
 
!
!
!
!
!
 
Success Rate is 100.00 percent (5/5)
Flags
PE1#ping mpls ospf-sr ipv4 10.0.1.33/32 destination 127.1.0.1 flags detail
Sending 5 MPLS Echos to 10.0.1.33, timeout is 5 seconds
 
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
 
Type 'Ctrl+C' to abort
 
! seq_num = 1 10.0.1.33 0.63 ms
! seq_num = 2 10.0.1.33 0.58 ms
! seq_num = 3 10.0.1.33 0.65 ms
! seq_num = 4 10.0.1.33 0.56 ms
! seq_num = 5 10.0.1.33 0.56 ms
 
Success Rate is 100.00 percent (5/5)
round-trip min/avg/max = 0.56/0.61/0.65
Timeout
PE1#ping mpls ospf-sr ipv4 10.0.1.33/32 timeout 500 detail
Sending 5 MPLS Echos to 10.0.1.33, timeout is 500 seconds
 
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
 
Type 'Ctrl+C' to abort
 
! seq_num = 1 10.0.1.33 0.89 ms
! seq_num = 2 10.0.1.33 0.61 ms
! seq_num = 3 10.0.1.33 0.59 ms
! seq_num = 4 10.0.1.33 0.62 ms
! seq_num = 5 10.0.1.33 0.63 ms
 
Success Rate is 100.00 percent (5/5)
round-trip min/avg/max = 0.59/0.74/0.89
Force-explicit-null
PE1#ping mpls ospf-sr ipv4 10.0.1.33/32 force-explicit-null detail
Sending 5 MPLS Echos to 10.0.1.33, timeout is 5 seconds
 
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
 
Type 'Ctrl+C' to abort
 
! seq_num = 1 10.0.1.33 0.81 ms
! seq_num = 2 10.0.1.33 0.54 ms
! seq_num = 3 10.0.1.33 0.51 ms
! seq_num = 4 10.0.1.33 0.57 ms
! seq_num = 5 10.0.1.33 0.74 ms
 
Success Rate is 100.00 percent (5/5)
round-trip min/avg/max = 0.51/0.66/0.81
Reply-mode
PE1#ping mpls ospf-sr ipv4 10.0.1.33/32 reply-mode 2 detail
Sending 5 MPLS Echos to 10.0.1.33, timeout is 5 seconds
 
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
 
Type 'Ctrl+C' to abort
 
! seq_num = 1 10.0.1.33 0.91 ms
! seq_num = 2 10.0.1.33 0.73 ms
! seq_num = 3 10.0.1.33 0.62 ms
! seq_num = 4 10.0.1.33 0.70 ms
! seq_num = 5 10.0.1.33 0.57 ms
 
Success Rate is 100.00 percent (5/5)
round-trip min/avg/max = 0.57/0.74/0.91
Repeat
PE1#ping mpls ospf-sr ipv4 10.0.1.33/32 repeat 5 detail
Sending 5 MPLS Echos to 10.0.1.33, timeout is 5 seconds
 
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
 
Type 'Ctrl+C' to abort
 
! seq_num = 1 10.0.1.33 0.80 ms
! seq_num = 2 10.0.1.33 0.71 ms
! seq_num = 3 10.0.1.33 0.58 ms
! seq_num = 4 10.0.1.33 0.56 ms
! seq_num = 5 10.0.1.33 0.54 ms
 
Success Rate is 100.00 percent (5/5)
round-trip min/avg/max = 0.54/0.67/0.80
Interval
PE1#ping mpls ospf-sr ipv4 10.0.1.33/32 interval 10 detail
Sending 5 MPLS Echos to 10.0.1.33, timeout is 5 seconds
 
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
 
Type 'Ctrl+C' to abort
 
! seq_num = 1 10.0.1.33 0.74 ms
! seq_num = 2 10.0.1.33 0.62 ms
! seq_num = 3 10.0.1.33 0.56 ms
! seq_num = 4 10.0.1.33 0.62 ms
! seq_num = 5 10.0.1.33 0.64 ms
 
Success Rate is 100.00 percent (5/5)
round-trip min/avg/max = 0.56/0.65/0.74
TTL
PE1#ping mpls ospf-sr ipv4 10.0.1.33/32 ttl 225 detail
Sending 5 MPLS Echos to 10.0.1.33, timeout is 5 seconds
 
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
 
Type 'Ctrl+C' to abort
 
! seq_num = 1 10.0.1.33 0.76 ms
! seq_num = 2 10.0.1.33 0.67 ms
! seq_num = 3 10.0.1.33 0.70 ms
! seq_num = 4 10.0.1.33 0.64 ms
! seq_num = 5 10.0.1.33 0.51 ms
 
Success Rate is 100.00 percent (5/5)
round-trip min/avg/max = 0.51/0.63/0.76
Trace with other options
Details
PE1#trace mpls ospf-sr ipv4 10.0.1.33/32 detail
Tracing MPLS Label Switched Path to 10.0.1.33, timeout is 5 seconds
 
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
 
Type 'Ctrl+C' to abort
 
0 10.11.1.1 [Labels: 4 16700]
R 1 10.0.1.1 [Labels: 16700] 0.94 ms
R 2 10.0.1.3 [Labels: 16700] 0.99 ms
! 3 10.0.1.33 0.77 ms
Destination
PE1#trace mpls ospf-sr ipv4 10.0.1.33/32 destination 127.1.0.1 detail
Tracing MPLS Label Switched Path to 10.0.1.33, timeout is 5 seconds
 
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
 
Type 'Ctrl+C' to abort
 
0 10.11.1.1 [Labels: 4 16700]
R 1 10.0.1.1 [Labels: 16700] 0.82 ms
R 2 10.0.1.3 [Labels: 16700] 0.84 ms
! 3 10.0.1.33 0.84 ms
Source
PE1#trace mpls ospf-sr ipv4 10.0.1.33/32 destination 127.1.0.1 source 10.0.1.11 detail
Tracing MPLS Label Switched Path to 10.0.1.33, timeout is 5 seconds
 
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
 
Type 'Ctrl+C' to abort
 
0 10.11.1.1 [Labels: 4 16700]
R 1 10.0.1.1 [Labels: 16700] 0.88 ms
R 2 10.0.1.3 [Labels: 16700] 0.91 ms
! 3 10.0.1.33 0.57 ms
Flags
PE1#trace mpls ospf-sr ipv4 10.0.1.33/32 flags detail
Tracing MPLS Label Switched Path to 10.0.1.33, timeout is 5 seconds
 
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
 
Type 'Ctrl+C' to abort
 
0 10.11.1.1 [Labels: 4 16700]
R 1 10.0.1.1 [Labels: 16700] 0.85 ms
R 2 10.0.1.3 [Labels: 16700] 0.90 ms
! 3 10.0.1.33 0.56 ms
Reply mode
PE1#trace mpls ospf-sr ipv4 10.0.1.33/32 reply-mode 2 detail
Tracing MPLS Label Switched Path to 10.0.1.33, timeout is 5 seconds
 
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
 
Type 'Ctrl+C' to abort
 
0 10.11.1.1 [Labels: 4 16700]
R 1 10.0.1.1 [Labels: 16700] 0.82 ms
R 2 10.0.1.3 [Labels: 16700] 0.91 ms
! 3 10.0.1.33 0.66 ms
Repeat
PE1#trace mpls ospf-sr ipv4 10.0.1.33/32 repeat 100 detail
Tracing MPLS Label Switched Path to 10.0.1.33, timeout is 5 seconds
 
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
 
Type 'Ctrl+C' to abort
 
0 10.11.1.1 [Labels: 4 16700]
R 1 10.0.1.1 [Labels: 16700] 0.76 ms
R 2 10.0.1.3 [Labels: 16700] 0.89 ms
! 3 10.0.1.33 0.72 ms
Interval
PE1#trace mpls ospf-sr ipv4 10.0.1.33/32 interval 100 detail
Tracing MPLS Label Switched Path to 10.0.1.33, timeout is 5 seconds
 
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
 
Type 'Ctrl+C' to abort
 
0 10.11.1.1 [Labels: 4 16700]
R 1 10.0.1.1 [Labels: 16700] 0.79 ms
R 2 10.0.1.3 [Labels: 16700] 0.98 ms
! 3 10.0.1.33 0.76 ms
Timeout
PE1#trace mpls ospf-sr ipv4 10.0.1.33/32 timeout 300 detail
Tracing MPLS Label Switched Path to 10.0.1.33, timeout is 300 seconds
 
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
 
Type 'Ctrl+C' to abort
 
0 10.11.1.1 [Labels: 4 16700]
R 1 10.0.1.1 [Labels: 16700] 0.94 ms
R 2 10.0.1.3 [Labels: 16700] 0.90 ms
! 3 10.0.1.33 0.70 ms