OcNOS-SP : Segment Routing Guide : Segment Routing Configuration Guide : TWAMP over L3VPN with SRv6
TWAMP over L3VPN with SRv6
Two-Way Active Measurement Protocol (TWAMP) is an open protocol designed for assessing network performance between any two devices. TWAMP over SRv6 transport is integrated to enable TWAMP functionality on routers, which assume the roles of MPLS routers, serving as both LERs and intermediate routers. OcNOS also provides end-to-end statistics calculation, supporting multi-path scenarios between the sender and reflector with multihop capabilities.
Users can use the link delay metrics, including average, minimum, maximum delay, and delay variance, to evaluate network latency. Leveraging these metrics is instrumental for latency troubleshooting and the implementation of Traffic Engineering (TE) solutions to meet Service Level Agreements (SLAs).
This feature enhances TWAMP functionality in OcNOS, focusing on accuracy and configurable advertisement of the measured data.
Regarding L3VPN scenarios based on SRv6, TWAMP over L3VPN is applicable to the following:
CE-CE: Overlay Only
CE-PE: Overlay Only
PE-PE: Both Underlay and Overlay.
Topology
SRv6 Configuration displays a sample TWAMP over L3VPN topology.
CE1 and CE2 are customer edge routers
PE1 and PE2 are IPv6 Provider Edge routers
P1 is the router at the core of the SRv6 network
 
TWAMP over EVPN-L3VPN Topology
SRv6 Configuration
PE1
SRv6 is configured on PE1 for IGP configs with ISIS v6 and OSPFv3 configuration.
 
PE1#configure terminal
Enter Configure mode.
PE1(config)#interface lo
Enter interface mode
PE1(config-if)# ip address 1.1.1.1/32 secondary
Assign IP address to interface lo
PE1(config-if)# ipv6 address 1001::1/128
Assign IPv6 address to interface lo
PE1(config-if)# ipv6 router ospf area 0.0.0.0 tag 1 instance-id 0
Make the interface part of the router ospf area 0.
PE1(config-if)# ipv6 router isis 1
Make the interface part of the router ISIS 1 instance.
PE1(config-if)#exit
Exit interface mode.
PE1(config-if)#interface ce3
Enter interface mode
PE1(config-if)# load-interval 30
Enable load interval
PE1(config-if)# ipv6 address 1112::1/64
Assign IPv6 address to interface
PE1(config-if)# ipv6 router ospf area 0.0.0.0 tag 1 instance-id 0
Make the interface part of the router ospf area 0.
PE1(config-if)# ipv6 router isis 1
Make the interface part of the router ISIS 1 instance.
PE1(config-if)#exit
Exit interface mode.
PE1(config)#segment-routing
Enable segment routing
PE1(config-sr)# srv6
Segment-Routing over IPv6 Data-Plane
PE1(config-srv6)# locators
Configure SRv6 locators
PE1(config-srv6-loc)# locator PE1_locator
Configure SRv6 locator name
PE1(config-srv6-loc-conf)# prefix 1001::/64
Configure prefix for locator
PE1(config-srv6-loc-conf)# exit-locator
Exit from locator
PE1(config-srv6-loc)# exit-locators
Exit from locators
PE1(config-srv6)# exit-srv6
Exit from srv6 mode
PE1(config-sr)#router ipv6 ospf 1
Entering router ospf.
PE1(config-router)# router-id 1.1.1.1
Configure OSPF router-id.
PE1(config-router)# segment-routing srv6
Enable segment routing srv6
PE1(config-router-srv6)# srv6-locator PE1_locator
Configure srv6 locator name
PE1(config-router-srv6)# exit-srv6
Exit from srv6
PE1(config-router)#!
Return to privilege mode
PE1(config-router)#router isis 1
Set the routing process ID as 1
PE1(config-router)# is-type level-2-only
Configure is-type as level-2
PE1(config-router)# metric-style wide
Configure wide metric-style
PE1(config-router)# net 49.0001.0000.0000.0001.00
Configure Network entity title (NET).
PE1(config-router)# address-family ipv6
Enter Address-family IPv6
PE1(config-router-af)# segment-routing srv6
Enable SRv6 under IPv6 address-family
PE1(config-router-af-srv6)# srv6-locator PE1_locator
Name to SRv6 locator
PE1(config-router-af-srv6)# exit-srv6
Exit SRv6 mode
PE1(config-router-af)# exit-address-family
Exit address-family IPv6
PE1(config-router)#commit
commit
P1
SRv6 is configured on P1 for IGP configs with ISIS v6 and OSPFv3 configuration.
 
P1#configure terminal
Enter Configure mode.
P1(config)#interface lo
Enter interface mode
P1(config-if)# ip address 2.2.2.2/32 secondary
Assign IP address to interface lo
P1(config-if)# ipv6 address 2001::1/128
Assign IPv6 address to interface lo
P1(config-if)# ipv6 router ospf area 0.0.0.0 tag 1 instance-id 0
Make the interface part of the router ospf area 0.
P1(config-if)# ipv6 router isis 1
Make the interface part of the router ISIS 1 instance.
P1(config-if)#exit
Exit interface mode.
P1(config-if)#interface ce3
Enter interface mode
P1(config-if)# load-interval 30
Enable load interval
P1(config-if)# ipv6 address 1112::2/64
Assign IPv6 address to interface
P1(config-if)# ipv6 router ospf area 0.0.0.0 tag 1 instance-id 0
Make the interface part of the router ospf area 0.
P1(config-if)# ipv6 router isis 1
Make the interface part of the router ISIS 1 instance.
P1(config-if)#exit
Exit interface mode.
P1(config-if)#interface ce16
Enter interface mode
P1(config-if)# load-interval 30
Enable load interval
P1(config-if)# ipv6 address 2221::1/64
Assign IPv6 address to interface
P1(config-if)# ipv6 router ospf area 0.0.0.0 tag 1 instance-id 0
Make the interface part of the router ospf area 0.
P1(config-if)# ipv6 router isis 1
Make the interface part of the router ISIS 1 instance.
P1(config-if)#exit
Exit interface mode.
P1(config-sr)#router ipv6 ospf 1
Entering router ospf.
P1(config-router)# router-id 2.2.2.2
Configure OSPF router-id.
P1(config-router)#!
Return to privilege mode
P1(config-router)#router isis 1
Set the routing process ID as 1
P1(config-router)# is-type level-2-only
Configure is-type as level-2
P1(config-router)# metric-style wide
Configure wide metric-style
P1(config-router)# net 49.0001.0000.0000.0002.00
Configure Network entity title (NET).
P1(config-router)# address-family ipv6
Enter Address-family IPv6
P1(config-router)#commit
commit
PE2
SRv6 is configured on PE2 for IGP configs with ISIS v6 and OSPFv3 configuration
 
PE2#configure terminal
Enter Configure mode.
PE2(config)#interface lo
Enter interface mode
PE2(config-if)# ip address 3.3.3.3/32 secondary
Assign IP address to interface lo
PE2(config-if)# ipv6 address 3001::1/128
Assign IPv6 address to interface lo
PE2(config-if)# ipv6 router ospf area 0.0.0.0 tag 1 instance-id 0
Make the interface part of the router ospf area 0.
PE2(config-if)# ipv6 router isis 1
Make the interface part of the router ISIS 1 instance.
PE2(config-if)#exit
Exit interface mode.
PE2(config-if)#interface ce1
Enter interface mode
PE2(config-if)# load-interval 30
Enable load interval
PE2(config-if)# ipv6 address 2221::2/64
Assign IPv6 address to interface
PE2(config-if)# ipv6 router ospf area 0.0.0.0 tag 1 instance-id 0
Make the interface part of the router ospf area 0.
PE2(config-if)# ipv6 router isis 1
Make the interface part of the router ISIS 1 instance.
PE2(config-if)#exit
Exit interface mode.
PE2(config)#segment-routing
Enable segment routing
PE2(config-sr)# srv6
Segment-Routing over IPv6 Data-Plane
PE2(config-srv6)# locators
Configure SRv6 locators
PE2(config-srv6-loc)# locator PE2_locator
Configure SRv6 locator name
PE2(config-srv6-loc-conf)# prefix 3001::/64
Configure prefix for locator
PE2(config-srv6-loc-conf)# exit-locator
Exit from locator
PE2(config-srv6-loc)# exit-locators
Exit from locators
PE2(config-srv6)# exit-srv6
Exit from srv6 mode
PE2(config-sr)#router ipv6 ospf 1
Entering router ospf.
PE2(config-router)# router-id 3.3.3.3
Configure OSPF router-id.
PE2(config-router)# segment-routing srv6
Enable segment routing srv6
PE2(config-router-srv6)# srv6-locator PE2_locator
Configure srv6 locator name
PE2(config-router-srv6)# exit-srv6
Exit from srv6
PE2(config-router)#!
Return to privilege mode
PE2(config-router)#router isis 1
Set the routing process ID as 1
PE2(config-router)# is-type level-2-only
Configure is-type as level-2
PE2(config-router)# metric-style wide
Configure wide metric-style
PE2(config-router)# net 49.0001.0000.0000.0003.00
Configure Network entity title (NET).
PE2(config-router)# address-family ipv6
Enter Address-family IPv6
PE2(config-router-af)# segment-routing srv6
Enable SRv6 under IPv6 address-family
PE2(config-router-af-srv6)# srv6-locator PE2_locator
Name to SRv6 locator
PE2(config-router-af-srv6)# exit-srv6
Exit SRv6 mode
PE2(config-router-af)# exit-address-family
Exit address-family IPv6
PE2(config-router)#commit
commit
Configure L3VPN
PE1
 
PE1#configure terminal
Enter Configure mode.
PE1(config)# ip vrf vrf111
Create a new VRF named vrf111
PE1(config-vrf)#rd 10:111
Assign the route distinguisher (RD) value as 10:111
PE1(config-vrf)#route-target both 10:111
Import routes between route target (RT) ext-communities 10 and 111
PE1(config-vrf)#exit
Exit VRF mode
PE1(config)#int xe9
Enter Interface mode
PE1(config-if)#mtu 9216
Set the mtu size
PE1(config-if)#exit
Exit Interface mode
PE1(config-if)#interface xe9.111
Enter Interface mode
PE1(config-if)#encapsulation dot1q 111
Configure encapsulation under a subinterface
PE1(config-if)#ip vrf forwarding vrf111
Bind the interface connected to the CE1 router with VRF 111
PE1(config-if)#ip address 100.1.1.1/24
Assign IP address to interface
PE1(config-if)#mtu 9216
Set the mtu size
PE1(config-if)#exit
Exit
PE1(config)#router bgp 65010
Enter BGP router mode
PE1(config-router)# bgp router-id 1.1.1.1
Configure BGP router-id
PE1(config-router)# neighbor 3001::1 remote-as 65010
Configure neighbor remote-as 65010
PE1(config-router)# neighbor 3001::1 update-source lo
Configure neighbor with update-source lo
PE1(config-router)# address-family vpnv4 unicast
address-family vpnv4 unicast
PE1(config-router-af)# segment-routing srv6
Enter SRv6 mode
PE1(config-router-vpnv4-srv6)# srv6-locator PE1_locator
Configure locator name under SRv6 mode
PE1(config-router-vpnv4-srv6)# exit-srv6
Exit SRv6 mode
PE1(config-router-af)# neighbor 3001::1 activate
Activate VPNv4 neighbor
PE1(config-router-af)# neighbor 3001::1 capability extended-nexthop-encode
Configure extended nexthop encode capability for VPNv4
neighbor
PE1(config-router-af)# exit-address-family
Exit from Address Family configuration mode
PE1(config-router)# address-family ipv4 vrf vrf111
Enter VRF address family
PE1(config-router-af)# redistribute connected
Redistribute connected routes
PE1(config-router-af)# segment-routing srv6
Enter SRv6 mode
PE1(config-router-vrfv4-srv6)# sid-alloc per-vrf
Allocate SID per VRF
PE1(config-router-vrfv4-srv6)# exit-srv6
Exit SRv6 mode
PE1(config-router-af)# neighbor 100.1.1.2 remote-as 100
Configure EBGP neighbor remote-as 100
PE1(config-router-af)# neighbor 100.1.1.2 activate
Configure EBGP neighbor activate
PE1(config-router-af)# exit-address-family
Exit from Address Family configuration mode
PE1(config-router-af)# commit
commit
PE2
 
PE2#configure terminal
Enter Configure mode.
PE2(config)# ip vrf vrf111
Create a new VRF named vrf111
PE2(config-vrf)#rd 10:111
Assign the route distinguisher (RD) value as 10:111
PE2(config-vrf)#route-target both 10:111
Import routes between route target (RT) ext-communities 10 and 111
PE2(config-vrf)#exit
Exit VRF mode
PE2(config)#int xe9
Enter Interface mode
PE2(config-if)#mtu 9216
Set the mtu size
PE2(config-if)#exit
Exit Interface mode
PE2(config-if)#interface xe4.111
Enter Interface mode
PE2(config-if)#encapsulation dot1q 111
Configure encapsulation under a subinterface
PE2(config-if)#ip vrf forwarding vrf111
Bind the interface connected to the CE1 router with VRF 111
PE2(config-if)#ip address 200.1.1.1/24
Assign IP address to interface
PE2(config-if)#mtu 9216
Set the mtu size
PE2(config-if)#exit
Exit
PE2(config)#router bgp 65010
Enter BGP router mode
PE2(config-router)# bgp router-id 3.3.3.3
Configure BGP router-id
PE2(config-router)# neighbor 1001::1 remote-as 65010
Configure neighbor remote-as 65010
PE2(config-router)# neighbor 1001::1 update-source lo
Configure neighbor with update-source lo
PE2(config-router)# address-family vpnv4 unicast
address-family vpnv4 unicast
PE2(config-router-af)# segment-routing srv6
Enter SRv6 mode
PE2(config-router-vpnv4-srv6)# srv6-locator PE2_locator
Configure locator name under SRv6 mode
PE2(config-router-vpnv4-srv6)# exit-srv6
Exit SRv6 mode
PE2(config-router-af)# neighbor 1001::1 activate
Activate VPNv4 neighbor
PE2(config-router-af)# neighbor 1001::1 capability extended-nexthop-encode
Configure extended nexthop encode capability for VPNv4
neighbor
PE2(config-router-af)# exit-address-family
Exit from Address Family configuration mode
PE2(config-router)# address-family ipv4 vrf vrf111
Enter VRF address family
PE2(config-router-af)# redistribute connected
Redistribute connected routes
PE2(config-router-af)# segment-routing srv6
Enter SRv6 mode
PE2(config-router-vrfv4-srv6)# sid-alloc per-vrf
Allocate SID per VRF
PE2(config-router-vrfv4-srv6)# exit-srv6
Exit SRv6 mode
PE2(config-router-af)# neighbor 200.1.1.2 remote-as 100
Configure EBGP neighbor remote-as 100
PE2(config-router-af)# neighbor 200.1.1.2 activate
Configure EBGP neighbor activate
PE2(config-router-af)# exit-address-family
Exit from Address Family configuration mode
PE2(config-router-af)# commit
commit
 
CE1
 
#configure terminal
Enter Configure mode.
(config)#int xe6
Enter Interface mode
(config-if)#mtu 9216
Set the mtu size
(config-if)#interface xe6.111
Enter Interface mode
(config-if)#encapsulation dot1q 111
Configure encapsulation under a subinterface
(config-if)#load-interval 30
Enable load interval
(config-if)#ip address 100.1.1.2/24
Assign IP address to interface
(config-if)#mtu 9216
Set the mtu size
(config-if)#interface lo
Configure lo interface
(config-if)#ip address 11.11.11.11/32 secondary
Assign IP address to interface
(config-if)#router bgp 100
Enter BGP router mode
(config-router)#neighbor 100.1.1.1 remote-as 65010
Configure BGP router-id
(config-router)#address-family ipv4 unicast
Enter address-family vpnv4 mode
(config-router-af)#neighbor 100.1.1.1 activate
mode Activate neighbor
(config-router-af)#redistribute connected
Redistribute connected routes
(config-router-af)#commit
Commit the configurations
(config-router-af)#end
Return to privilege mode
CE2
 
#configure terminal
Enter Configure mode.
(config)#int xe4
Enter Interface mode
(config)#mtu 9216
Set the mtu size
(config)#interface xe4.111
Enter Interface mode
(config)#encapsulation dot1q 111
Configure encapsulation under a subinterface
(config)#load-interval 30
Enable load interval
(config)#ip address 200.1.1.2/24
Assign IP address to interface
(config)#mtu 9216
Set the mtu size
(config-if)#interface lo
Configure lo interface
(config-if)#ip address 22.22.22.22/32 secondary
Assign IP address to interface
(config-if)#router bgp 200
Enter BGP router mode
config-router)#neighbor 200.1.1.1 remote-as 65010
Configure BGP router-id
config-router-af)#address-family ipv4 unicast
Enter address-family ipv4 mode
config-router-af)#neighbor 200.1.1.1 activate
mode Activate neighbor
config-router-af)#redistribute connected
Redistribute connected routes
(config)#commit
Commit the configurations
(config)#end
Return to privilege mode
TWAMP Between CE1 and CE2
TWAMP Configuration on Sender (CE1)
TWAMP sender is configured to measure the delay on interface Loopback on CE1
 
#configure terminal
Enter Configure mode.
(config)# hardware-profile filter twamp-ipv4 enable
Enable hardware filter for ipv4 to configure TWAMP meas- urement configs
(config)#commit
Commit the configuration
(config)# twamp-light control
Enable TWAMP light controller on CE1
(config-twamp-light-ctrl)# control-admin- state enable
Enable TWAMP Controller admin state
(config-twamp-light-ctrl)#delay-profile interfaces
Enter in to delay profile mode
(config-dp-intf)#mode two-way
Enter mode
(config-dp-intf)#burst-count 1
Enter burst count
(config-dp-intf)#burst-interval 1000
Configure burst interval value under delay profile mode
(config-dp-intf)#interval 30
Configure interval
(config-dp-intf)#advertisement periodic threshold 10
Configure advertisement periodic
(config-dp-intf)#advertisement periodic minimum-change 1000
Configure advertisement periodic minimum
(config-dp-intf)#advertisement accelerated
Configure advertisement accelerated
(config-dp-intf)#advertisement accelerated threshold 20
Configure advertisement accelerated threshold
(config-dp-intf)#advertisement accelerated minimum-change 2000
Configure advertisement accelerated minimum
(config-dp-intf)#int lo
Enter Interface Loopback mode
(config-if)#loss-measurement dynamic
Configure loss measurement
(config-if)#delay-measurement dynamic twamp reflector-ip 22.22.22.22 sender-ip 11.11.11.11
Enter in to delay profile mode
(config-if)#commit
Commit the configurations
(config-if)#end
Return to privilege mode
TWAMP Configuration on Reflector (CE2)
Configure TWAMP Reflector as interface xe4 on CE2 (Towards core)
 
#configure terminal
Enter Configure mode
(config)# hardware-profile filter twamp-ipv4 enable
Enable hardware filter for ipv4 to configure TWAMP measurement configuration
(config)#commit
Commit the configuration
(config)# twamp-light reflector
Enable TWAMP light Reflector on CE2
(config-twamp-light-ref)# reflec-tor-admin- state enable
Enable the TWAMP reflector admin state
(config-twamp-light-ref)# reflector-name CE2-CE1-lo reflector-ip ipv4 22.22.22.22
Configure TWAMP reflector IP as CE2 interface IP
(config-twamp-light-ref)#commit
Commit the configurations
(config-if)#end
Return to privilege mode
Validation
L3VPN over SRv6 Validation
Verify MP-BGP VPNv4 neighbourship
PE1#show ip bgp vpnv4 all summary
BGP router identifier 1.1.1.1, local AS number 65010
BGP table version is 3
3 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
3001::1 4 65010 282 281 3 0 0 01:58:45 2
 
Total number of neighbors 1
 
Total number of Established sessions 1
 
BGP VRF vrf111 Route Distinguisher: 10:111
BGP table version is 1
3 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
100.1.1.2 4 100 284 285 1 0 0 01:58:50 2
 
Total number of neighbors 1
 
Total number of Established sessions 1
PE1#
PE1#show ip bgp vpnv4 all
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal, l - labeled
S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 10:111 (Default for VRF vrf111)
*> 11.11.11.0/24 100.1.1.2 0 100 0 100 ?
*>i 22.22.22.22/32 3001::1 0 100 0 200 ?
*> 100.1.1.0/24 0.0.0.0 0 100 32768 ?
* 100.1.1.2 0 100 0 100 ?
*>i 200.1.1.0 3001::1 0 100 0 ?
Announced routes count = 3
Accepted routes count = 2
Route Distinguisher: 10:111
*>i 22.22.22.22/32 3001::1 0 100 0 200 ?
*>i 200.1.1.0 3001::1 0 100 0 ?
Announced routes count = 0
Accepted routes count = 2
PE1#show segment-routing srv6 sid
SRv6 Segment ID table:
SID Operation Nexthop Originator
+----------------------+------------+------------------------+----------
1001::801:0:0:0 END[usd] :: nsm
1001::1001:0:0:0 END[usp] :: nsm
1001::2001:0:0:0 END[psp] :: nsm
1001::6001:0:0:0 END.X[psp] fe80::eac5:7aff:feba:f18 isis
1001::8001:0:0:0 END.DT4 vrf vrf111 bgp:65010
Verify show SRv6 mpls services
PE1#show segment-routing srv6 services
Status codes: > - installed, * - selected, T - Uses service-mapped tunnel
L3VPN:
Service Flags vrf FEC SID Nexthop SRv6-Policy-Name
vpnv4 > vrf111 200.1.1.0/24 3001::8001:0:0:0 3001::1 None
vpnv4 > vrf111 22.22.22.22/32 3001::8001:0:0:0 3001::1 None
 
TWAMP CE1 to CE2 Validation
ping between CE1 lo to CE2 lo
CE1#ping 22.22.22.22
Press CTRL+C to exit
PING 22.22.22.22 (22.22.22.22) 56(84) bytes of data.
64 bytes from 22.22.22.22: icmp_seq=1 ttl=126 time=0.483 ms
64 bytes from 22.22.22.22: icmp_seq=2 ttl=126 time=0.449 ms
64 bytes from 22.22.22.22: icmp_seq=3 ttl=126 time=0.421 ms
 
--- 22.22.22.22 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 1000ms
rtt min/avg/max/mdev = 0.421/0.451/0.483/0.025 ms
 
Verify the TWAMP statistics on all the configured interfaces on CE1.In the below verification command, packets sent and received showing as equal. So all the TWAMP packets received reply for all the sent packets for the delay measurement. Showing all the Round Trip Delay and Reverse Delay timers.
CE1#show twamp-statistics
=========================================
TWAMP Test-Session Statistics
=========================================
Test-Session Name : __internal_interface_lo
Start Time : 2023 Oct 19 10:48:15
Elapsed time(milli sec) : 330207
Packets Sent : 330
Packets Received : 330
Packet Loss(%) : 0.00
Round Trip Delay(usec)
Minimum : 38
Maximum : 49
Average : 39
Forward Delay(usec)
Minimum : (*)
Maximum : (*)
Average : (*)
Reverse Delay(usec)
Minimum : (*)
Maximum : (*)
Average : (*)
Round Trip Delay Variation(usec)
Minimum : 15
Maximum : 39
Average : 15
Forward Delay Variation(usec)
Minimum : (*)
Maximum : (*)
Average : (*)
Reverse Delay Variation(usec)
Minimum : (*)
Maximum : (*)
Average : (*)
 
(*) - Time is not in sync between Sender and Reflector
 
show twamp-statistics interfaces
CE1#show twamp-statistics interfaces
Interface Last Advertisement Delay(us) Min(us) Max(us) Var(us) Loss(%)
lo 2023-10-19 10:54:02 20 20 23 0 0.00
Verify the Detailed list of TWAMP delay measurement information on CE lo interface
CE1#show twamp-statistics interfaces lo
Interface name : lo
Sender IP : 11.11.11.11
Reflector IP : 22.22.22.22
Reflector port : 862
DSCP value : 0
HW Status : HW rules installed
Last Advertised stats:
Time: 2023-10-19 10:54:02
Average delay : 20
Minimum delay : 20
Maximum delay : 23
Average delay variation: 0
Minimum delay variation: 0
Maximum delay variation: 0
Packets sent : 21
Packets received : 21
Packets timeout : 0
Packet Loss: 0.00
Last Calculated stats:
Time: 2023-10-19 10:54:02
Average delay : 20
Minimum delay : 20
Maximum delay : 23
Average delay variation: 0
Minimum delay variation: 0
Maximum delay variation: 0
Packets sent : 21
Packets received : 21
Packets timeout : 0
Packet Loss : 0.00