OcNOS-SP : System Management Guide : System Management Command Reference : Common Management Layer Commands
Common Management Layer Commands
This chapter is a reference for the Common Management Layer (CML) commands.
Transaction are enabled by default. You can disable the feature by using the cmlsh transaction command outside of configuration mode, but IP Infusion Inc. does not recommend this.
These are the steps to follow to use transactions:
When transactions are enabled, any changes done in configure mode are stored in a separate candidate configuration that you can view with the show transaction current command.
When a configuration is complete, apply the candidate configuration to the running configuration with the commit command.
If a commit fails, no configuration is applied as the entire transaction is considered failed. You can continue to change the candidate configuration and then retry the commit.
Discard the candidate configuration with the abort transaction command.
Check the last aborted transaction with the show transaction last-aborted command.
For the detailed description about Commit Rollback functionality, refer to the Commit Rollback section in the OcNOS Key Feature document, Release 6.4.1.
This chapter describes these commands:
commit
commit dry-run
abort transaction
Use this command to end a configuration session and discard all uncommitted changes.
Command Syntax
abort transaction
Parameters
None
Default
N/A
Mode
Configure mode
Applicability
This command was introduced in OcNOS version 5.0.
Example
(config)#
(config)#interface eth2
(config-if)#ip address 10.12.3.4/24
(config-if)#exit
(config)#abort transaction
(config)#exit
#show running-config interface eth2
!
interface eth2
!
#
cancel-commit
Use this command to revert configuration changes immediately before the timeout in a “confirmed commit” operation.
Note: This command does not support the <persist-id> parameter as specified in RFC 6241.
Command Syntax
cancel-commit
Parameters
None
Default
N/A
Mode
All configuration modes
Applicability
This command was introduced in OcNOS version 6.3.0.
Example
(config)#router ospf 1
(config-router)#router ospf 2
(config-router)#commit confirmed timeout 100 description This is a test for confirmed commit
(config-router)#
(config-router)#cancel-commit
cml force-unlock config-datastore
Use this command to release a configuration lock previously obtained with the cml lock config-datastore command by a different user.
This command is available only to users with the network-admin role.
A notification message is sent to the lock holder when forced out.
Command Syntax
cml force-unlock config-datastore (running|startup|candidate) (<0-600>|)
Parameters
<0-600>
Timeout interval to force out lock acquired by another user session. Zero (0) is immediate and is the default.
running
Release the lock on the running datastore.
startup
Release the lock on the startup datastore.
candidate
Release the lock on the candidate datastore.
Default
The default timeout is zero (0) which is immediate.
Mode
Exec mode
Applicability
This command was introduced in OcNOS version 5.1.
Example
#cml force-unlock config-datastore running
cml lock config-datastore
Use this command to lock the entire configuration datastore of a device. Such locks are intended to be short-lived and allow you to make a change without fear of interaction with other users.
When the lock is acquired, the server prevents any changes to the locked resource other than those requested by this session.
The duration of the lock is defined as beginning when the lock is acquired and lasting until either the lock is released or the user session closes. The session closure can be explicitly performed by the user, or implicitly performed by the server based on criteria such as failure of the underlying transport, simple inactivity timeout, or detection of abusive behavior on the part of the client.
A lock will not be granted if any of the following conditions is true:
A lock is already held by any user session or another entity.
The target configuration is candidate, it has already been modified, and these changes have not been committed or rolled back.
The target configuration is running, and another user session has an ongoing confirmed commit.
Command Syntax
cml lock config-datastore (running|startup|candidate)
Parameters
running
Lock on this datastore will not allow other sessions to perform operations with the target as running like commit, copy candidate to running and so on.
startup
Lock on this datastore will not allow other sessions to perform operations like copy-config and delete-config with the target startup
candidate
Lock on this datastore will not allow other sessions to perform operations with the target as candidate like edit-config, copy file candidate and so on. (Not supported in OcNOS version 5.1.)
Default
All three datastores are in the unlocked state.
Mode
Exec mode
Applicability
This command was introduced in OcNOS version 5.1.
Example
#cml lock config-datastore running
#
#show users
Current user : (*). Lock acquired by user : (#).
CLI user : [C]. Netconf users : [N].
Location : Applicable to CLI users.
Session : Applicable to NETCONF users.
 
Line User Idle Location/Session PID TYPE Role
 
(#)(*) 130 vty 0 [C]ocnos 0d00h00m pts/0 10732 Local network-admin
cml logging
Use this command to enable or disable CML logging. The logging level and debug cml should also be configured.
Command Syntax
cml logging (enable | disable)
Parameters
enable
Enable CML logging
disable
Disable CML logging
Default
By default CML Logging is enabled.
Mode
Configure mode
Applicability
This command was introduced in OcNOS version 5.0.
Example
(config)#cml logging disable
 
netconf translation openconfig
Use this command to enable or disable enable OpencConfig translation.
Use the no form of this command to Netconf translation.
Command Syntax
netconf translation openconfig
Parameters
openconfig
Translate NetConf to YANG
no
Disable OpencConfig translation
Default
By default NetConf-to-YANG translation is disabled.
Mode
Configuration mode
Applicability
This command was introduced before OcNOS version 6.4.
Example
OcNOS# configure terminal
OcNOS(config)# netconf translation openconfig
OcNOS(config)# commit
cml notification
Use this command to enable or disable notification for a given CML client.
Command Syntax:
cml notification (enable|disable) (netconf|snmp|cmlsh|all)
Parameters
disable
Disable notification subscription
enable
Enable notification subscription
all
All CML clients
cmlsh
CML client CMLSH
netconf
CML client NETCONF
snmp
CML client SNMP
Default
By default, notification is enabled for all CML clients.
Mode
Exec mode
Applicability
This command was introduced in OcNOS version 6.0.0.
Example
To enable notification for NETCONF client:
#cml notification enable netconf
To disable notification for NETCONF client:
#cml notification disable netconf
cml unlock config-datastore
Use this command to release a configuration lock previously obtained with the cml lock config-datastore command.
An unlock operation will not succeed if either of the following conditions is true:
The specified lock is not currently active.
The session calling tis command is not the same session that obtained the lock.
Command Syntax
cml unlock config-datastore (running|startup|candidate)
Parameters
running
Release the lock on the running datastore.
startup
Release the lock on the startup datastore.
candidate
Release the lock on the candidate datastore.
Default
N/A
Mode
Exec mode
Applicability
This command was introduced in OcNOS version 5.1.
Example
#cml unlock config-datastore running
#
#show users
Current user : (*). Lock acquired by user : (#).
CLI user : [C]. Netconf users : [N].
Location : Applicable to CLI users.
Session : Applicable to NETCONF users.
 
Line User Idle Location/Session PID TYPE Role
 
(*) 130 vty 0 [C]ocnos 0d00h00m pts/0 10732 Local network-admin
 
#
cmlsh cli-format
Use this command to display command strings in CLI error messages. By default, OcNOS displays error messages with Xpaths (path notation for navigating through the hierarchical structure of an XML document) which is not very clear for users.
Command Syntax
cmlsh cli-format (enable | disable)
Parameters
enable
Display command strings in CLI error messages.
disble
Display Xpaths in CLI error messages.
Default
Display Xpaths in CLI error messages
Mode
Exec mode
Applicability
This command was introduced in OcNOS version 6.3.0.
Example
This is the default behavior where an Xpath is displayed:
>en
#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
(config)#router ospf 10
(config-router)#area 3.3.3.3 interface xe1
(config-router)#commit
% Configuration " /ospfv2/processes/process[ospf-id='10']/areas/area[area-id='3.3.3.3']/interfaces/interface[name='xe1']/vrf-name" depends on "/ospfv2/global/config/area-interface-config-mode"
% Failed to commit .. As error(s) encountered during commit operation…
If you enable this feature, the Xpath is replaced with the respective command string:
>en
#cmlsh cli-format enable
#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
(config)#router ospf 10
(config-router)#area 3.3.3.3 interface xe1
(config-router)#commit
% Configuration " area <value-option> interface <value-option>" depends on " ospf area-interface-config-mode"
% Failed to commit .. As error(s) encountered during commit operation…
cmlsh multiple-config-session
Use this command to enable or disable multiple CLI sessions to enter into configuration mode simultaneously.
With this support, multiple CLI users can enter into configuration mode simultaneously and do configurations in parallel and commit into the running datastore. This is similar to NetConf multiple session support described in RFC 6241.
When multiple configuration mode sessions are disabled, only one user can enter configuration mode and it will lock the running datastore.
If any CLI session is already there in configuration mode, error will be given when user tries to enable this mode.
A datastore lock can be acquired using the cml lock config-datastore command if you want to do configuration without fear of interaction with other user sessions.
This command is available only to users with the network-admin role.
This configuration is retained across reboots.
Command Syntax
cmlsh multiple-config-session (enable|disable)
Parameters
enable
Enable multiple configuration mode sessions.
disable
Disable multiple configuration mode sessions.
Default
By default, multiple CLI sessions are disabled.
Mode
Exec mode
Applicability
This command was introduced in OcNOS version 5.1.
Example
#cmlsh multiple-config-session enable
#
#show cmlsh multiple-config-session status
CMLSh multiple configuration session mode : Enabled
#
Usage
Multiple users can enter into configuration mode simultaneously and do configurations in parallel and commit into the running datastore. Examples of when you need this feature are:
Migrating to replace an existing device. If an existing device has a large configuration and it is only done by one person, it will take more time to configure. If multiple users can configure at same time, it will take less time.
Troubleshooting and operating. Sometimes a single device has 2 or more links to troubleshoot. If only one user only can do configuration, it will take more time to resolve the problem.
When multiple sessions are doing parallel configurations, there is a chance that one user’s configuration might conflict with another user’s configuration.
If you do not lock the datastore before doing a configuration, a parallel candidate datastore can be created and will be allowed to commit to the datastore. So the datastore can change while the previous user is still having the configuration in its candidate. Now when the previous user tries to commit, if the configurations conflict, it will fail.
For example, if the previous user was adding a BGP neighbor and the BGP router itself is removed from the datastore via the parallel transaction, when this user tries to commit, it will fail. The reason is when commands are added to candidate, it only checks the running datastore at that point and allows them to be added to candidate configuration datastore. But later if the running datastore itself is changed, these configurations can be irrelevant and will cause an error on commit. So the user will have to abort the transaction.
cmlsh notification
Use this command to enable or disable notification for the current CMLSH session.
Command Syntax
cmlsh notification (enable|disable)
Parameters
disable
Disable notification subscription for current CMLSH session
enable
Enable notification subscription for current CMLSH session
Default
By default, notification is enabled for the CMLSH session.
Mode
Exec mode
Applicability
This command was introduced in OcNOS version 6.0.0.
Example
To enable notification for current CMLSH session:
#cmlsh notification enable
To disable notification for current CMLSH session:
#cmlsh notification disable
 
cmlsh transaction
Use this command to enable or disable the transaction-based command-line interface.
Note: IP Infusion Inc. recommends that you do not disable transactions.
Command Syntax
cmlsh transaction (enable | disable)
Parameters
enable
Enable transaction-based command-line interface
disable
Disable transaction-based command-line interface
Default
The transaction-based command-line interface is enabled by default.
Mode
Exec mode
Applicability
This command was introduced in OcNOS version 5.0.
Example
>en
#cmlsh transaction disable
% Deprecated CLI. Disabling transaction mode is not recommended
#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
(config)#router ipv6 ospf test
(config-router)#exit
(config)#show running-config router ipv6 ospf
!
router ipv6 ospf test
!
(config)#
cmlsh transaction limit
Use this command to set the maximum number of transactions.
To verify, give the show max-transaction limit command in exec mode.
Command Syntax
cml transaction limit <0-300000>
Parameters
<0-300000>
Maximum number of transactions with zero (0) indicating unlimited transactions.
Default
300,000 transactions
Mode
Configure mode
Applicability
This command was introduced in OcNOS version 5.0.
Example
(config)#cml transaction limit 1500
(config)#exit
#show max-transaction limit
Max-Transaction Limit is 1500
 
commit
Use this command to commit the candidate configuration to the running configuration.
Note: After a successful commit command, you must give the write command to save the running configuration to the startup configuration.
Note: Multiple configurations cannot be removed with a single commit. You must remove each configuration followed by a commit.
Optionally with “confirmed commit”, you can commit the configuration on a trial basis for a time specified in seconds. If you do not confirm within the specified time, the configuration will be reverted after the timeout.
To revert the configuration before timeout, then give the cancel-commit command.
To retain the configuration before timeout, then give the confirm-commit command.
See RFC 6241 “Confirmed Commit Capability”.
Note: A commit command without any parameters is treated as permanent and an explicit confirm-commit command is not required to confirm the commit.
Note: Multiple confirmed commits in the same session or different sessions are not supported. The commit command does not support the <persist-id> parameter as specified in RFC 6241.
Command Syntax
commit (confirmed (timeout <1-500>|)|) (description LINE|)
Parameters
confirmed
Commits the configuration on a trial basis.
<1-500>
Timeout in seconds after which configuration should be reverted if a confirmation is not given with confirm-commit. If not specified, the default timeout is 300 seconds.
LINE
Commit description up to 65 characters
Default
The default timeout is 300 seconds.
Mode
All configuration modes
Applicability
This command was introduced in OcNOS version 5.0 and the confirmed clause added in OcNOS version 6.3.0.
Example
(config)#router ospf 1
(config-router)#exit
(config)#router isis 3
(config-router)#commit
(config-router)#exit
(config)#show running-config ospf
!
router ospf 1
!
(config)#show running-config isis
!
router isis 3
!
(config)#
 
If you try to exit or end, you are prompted to commit or abort first:
(config)#router bgp 10
(config-router)#bgp as-local-count 34
(config-router)#exit
(config)#exit
% Un-committed transactions present. Please do commit or abort before exiting.
(config)#end
% Un-committed transactions present. Please do commit or abort before exiting.
(config)#commit
(config)#show running-config bgp
!
router bgp 10
bgp as-local-count 34
!
(config)#
This is an example of a “confirmed commit”:
(config)#router ospf 1
(config-router)#router ospf 2
(config-router)#commit confirmed timeout 100 description This is Test for confirmed commit
Usage
OcNOS validates dependencies when you commit. In this example, bridge 1 must exist before you can create a VLAN on it:
(config)#vlan database
(config-vlan)#vlan 10 bridge 1
(config-vlan)#exit
(config)commit
Because of the unmet dependency, you get an error when you try to commit.
If you also create the bridge, the commit succeeds:
(config)#bridge 1 protocol mstp
(config)#vlan database
(config-vlan)#vlan 10 bridge 1
(config-vlan)#exit
(config)commit
In a single transaction, dependent configurations can be given in any order. Using the same example as before, you can create the bridge after the VLAN:
(config)#vlan database
(config-vlan)#vlan 10 bridge 1
(config-vlan)#exit
(config)#bridge 1 protocol mstp
(config)commit
OcNOS supports “hitless merges” and does not write to the candidate configuration if you make the same configuration in separate transactions. In this example, subinterface xe1.1 is not created the second time because it already exists:
(config)#interface xe1.1
(config-if)#commit
(config)#interface xe1.1
(config-if)#commit
OcNOS does not write to the candidate configuration if you create and delete the same entity in the same transaction. You must create the entity and delete it with separate commits.
Mode changes, action items (such as clear interface counters), and show commands are not part of a transaction and are not displayed by the show transaction current command.
confirm-commit
Use this command to commit configuration changes before the timeout in a “confirmed commit” operation.
Note: This command does not support the <persist-id> parameter as specified in RFC 6241.
Command Syntax
confirm-commit
Parameters
None
Default
N/A
Mode
All configuration modes
Applicability
This command was introduced in OcNOS version 6.3.0.
Example
(config)#router ospf 1
(config-router)#router ospf 2
(config-router)#commit confirmed timeout 100 description This is a test for confirmed commit
(config-router)#
(config-router)#confirm-commit
commit dry-run
Use this command to validate the current candidate configuration without committing.
Command Syntax
commit dry-run
Parameters
None
Default
N/A
Mode
All configuration modes
Applicability
This command was introduced in OcNOS version 6.3.0.
Example
OcNOS(config)#commit dry-run
commit-rollback
Use this command to revert configurations to a previously committed stable state. This action will remove configurations made after the provided commit ID (Word).
Note: To use commit-rollback, cml commit-history must be enabled.
Command Syntax
commit-rollback to WORD (description LINE|)
Parameter
Word
Commit ID associated with recorded commit operations stored within the commit- history list.
description LINE
[Optional] Short description about commit-rollback, maximum 65 characters.
Command Mode
Exec mode
Applicability
This command is introduced in OcNOS 6.4.1.
Example
Example output for commit-rollback WORD:
#show commit list
 
S.No. ID User Client TimeStamp Commit Status Description
~~~~~ ~~~~~~~~~~~~~~~~~ ~~~~~ ~~~~~~ ~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~~~~
1 1684542445002144 ocnos cmlsh 20-05-2023 00:27:25 Confirmed NA
 
Example of a Commit Rollback to the Commit List ID 1684542445002144:
#commit-rollback to 1684542445002144 description commit-rollback Test
#show commit list
 
S.No. ID User Client TimeStamp Commit Status Description
~~~~~ ~~~~~~~~~~~~~~~~~ ~~~~~ ~~~~~~ ~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~~~~
1 1684542445002144 ocnos cmlsh 20-05-2023 00:27:25 Confirmed NA
2 1684542402123428 ocnos cmlsh 20-05-2023 00:28:45 Rollback to 20-05-2023 00:27:25 commit-rollback Test
Example of an automatic Commit Rollback
#show commit list
 
S.No. ID User Client TimeStamp Commit Status Description
~~~~~ ~~~~~~~~~~~~~~~~~ ~~~~~ ~~~~~~ ~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~~~~~
~~~~~
#show run router ospf
!
#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
(config)#router ospf 5
(config-router)#router ospf 6
(config-router)#commit confirmed timeout 20 description This is to test auto rollback of config
(config-router)#end
#show commit list
 
S.No. ID User Client TimeStamp Commit Status Description
~~~~~ ~~~~~~~~~~~~~~~~~ ~~~~~ ~~~~~~ ~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~~~~~
~~~~~
1 1698242643599569 root cmlsh 25-10-2023 14:04:03 Remaining Time: 17 This is to test auto rollback of config
 
#show run router ospf
!
router ospf 5
!
router ospf 6
!
#
Warning!!! Confirmed-commit timed out for commitid: 1698242643599569
#show commit list
 
S.No. ID User Client TimeStamp Commit Status Description
~~~~~ ~~~~~~~~~~~~~~~~~ ~~~~~ ~~~~~~ ~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~~~~~
~~~~~
1 1698242643599569 root cmlsh 25-10-2023 14:04:03 Timed-out (Reverted) This is to test auto rollback of config
 
#show run router ospf
!
#
clear cml commit-history (WORD|)
Use this command to delete any specific entry mentioned by commit ID or to delete entire list entries.
Note: To use the commit-rollback operation, the cml commit-history operation must be enabled, and note that commit-rollback cannot be used for deleted entries.
Command Syntax
clear cml commit-history (WORD|)
Parameter
Word
commit ID of the recorded commit operations into commit-history list
Default
When no parameter is provided, the commit history is deleted by default. If you specify the 'Word' parameter, it will delete the specific commit record.
Command Mode
Exec mode
Applicability
This command is introduced in OcNOS 6.4.1.
Example
Example for clear commit using Commit History ID:
#show commit list
 
S.No. ID User Client TimeStamp Commit Status Description
~~~~~ ~~~~~~~~~~~~~~~~~ ~~~~~ ~~~~~~ ~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~~~~
1 1684486018411866 ocnos cmlsh 19-05-2023 08:46:58 Confirmed NA
2 1684486037040268 ocnos cmlsh 19-05-2023 08:47:17 Confirmed
 
#clear cml commit-history 1684486018411866
#show commit list
 
S.No. ID User Client TimeStamp Commit Status Description
~~~~~ ~~~~~~~~~~~~~~~~~ ~~~~~ ~~~~~~ ~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~~~~
1 1684486037040268 ocnos cmlsh 19-05-2023 08:47:17 Confirmed NA
cml commit-history (enable | disable)
Use this command to enable or disable confirmed commit operation (commit-history operation). To verify the state of the operation, use the command show cml commit-history state.
Note:  
By default, cml commit-history operation is enabled.
After disabling the cml commit-history operation, confirmed commit CLIs cannot be used, rendering the commit confirmed, confirm-commit, and cancel-commit operations unavailable.
Command Syntax
cml commit-history (enable | disable)
Parameter
Enable
Enables commit confirmed and commit rollback operations
Disable
Disables commit confirmed and commit rollback operations
Default
By default, commit confirmed and commit rollback operations are enabled.
Command Mode
Exec mode
Applicability
This command is introduced in OcNOS 6.4.1.
Example
Example for enabling Commit History:
#cml commit-history enable
Warning!!! commit-history feature is enabled, confirmed commit and commit-rollback features are available for use.
 
Example for disabling Commit History:
#cml commit-history disable
Warning!!! commit-history feature is disabled, confirmed commit and commit-rollback features can not be used.
cml commit-id rollover (enable | disable)
Use this command to enable or disable commit entry rollover when the maximum count of 50 commit entries is reached. When enabled, older commit entries will be automatically deleted from the commit history list to record new entries.
To verify the state of the operation, use command show cml commit-id rollover state.
Note:  
By default, cml commit-id rollover operation is enabled.
The cml commit-history operation must be enabled to use this operation.
The commit-rollback operation can not be used for deleted entry.
When this operation is disabled and the number of commit entries reaches the maximum count, the addition of commit records to the commit history list will be stopped.
Command Syntax
cml commit-id rollover (enable | disable)
Parameter
Enable
Enables commit ID rollover
Disable
Disables commit ID rollover
Default
By default, commit ID rollover is enabled.
Command Mode
Exec mode
Applicability
This command is introduced in OcNOS 6.4.1.
Example
Example for verifying commit ID rollover state:
#show cml commit-id rollover state
cml commit-id rollover feature is enabled
 
debug cml
Use this command to enable or disable CML sub-module logging.
Command Syntax
debug cml (enable | disable) (events | engine | transaction | database | replace | smi | notification | all)
Parameters
enable
Enable debugging.
disable
Disable debugging.
events
Enable/disable events debugging
engine
Enable/disable engine debugging
transaction
Enable/disable transaction debugging
database
Enable/disable database debugging
replace
Enable/disable replace debugging
smi
Enable/disable SMI debugging
notification
Enable/disable notification debugging
all
Enable/disable all debugging
Default
By default, CML sub-module logging is disabled for all sub-modules.
Mode
Exec mode
Applicability
This command was introduced in OcNOS version 4.2 and the notification parameter added in OcNOS version 6.1.0.
Example
#debug cml enable transaction
module notification
Use this command to enable or disable notification for a given protocol at a given notification severity level.
Command Syntax
module PROTOCOL_NAME notification (enable|disable) (severity (all|info|warning|minor|major|critical)|)
Parameters
PROTOCOL_NAME
Protocol name. Specify all for all protocols.
enable
Enable notification subscription
disable
Disable notification subscription
severity
If notification is enabled, then all notifications having severity higher than or equal to this severity allowed. If notification disabled then all the notifications having severity lower than or equal to this severity not allowed.
all
Notification severity all
critical
Notification severity critical
info
Notification severity info
major
Notification severity major
minor
Notification severity minor
warning
notification severity warning
Mode
Configure mode
Applicability
This command was introduced in OcNOS version 6.0.0.
Example
To enable notification for NSM for all severity levels:
#module nsm notification enable
To disable notifications for NSM for all severity levels:
#module nsm notification disable
To enable notifications for NSM for severity levels higher than or equal to major (major and critical):
#module nsm notification enable severity major
To disable notifications for NSM for severity levels lower than or equal to minor (info, warning, and minor):
#module nsm notification disable severity minor
show cml config-datastore lock status
Use this command to display the configuration datastore lock state and its holder. The identifier of the process holding the lock is shown in parenthesis.
Command Syntax
show cml config-datastore lock status
Parameters
None
Default
N/A
Mode
Privileged exec mode
Applicability
This command was introduced in OcNOS version 6.0.0.
Example
#cml lock config-datastore candidate
#show cml config-datastore lock status
 
Running datastore is unlocked
Candidate datastore is locked by client cmlsh(2831)
Startup datastore is unlocked
#
 
show cml notification status
Use this command to display notification status (enabled or disabled) for all CML clients.
Command Syntax
show cml notification status
Parameters
None
Mode
Exec mode
Applicability
This command was introduced in OcNOS version 6.0.0.
Example
To show notification status for all clients:
#show cml notification status
NETCONF notification enabled
CMLSH notification enabled
SNMP notification enabled
show cmlsh multiple-config-session status
Use this command to display the multiple configuration mode session setting.
Command Syntax
show cmlsh multiple-config-session status
Parameters
None
Default
N/A
Mode
Privileged exec mode
Applicability
This command was introduced in OcNOS version 5.1.
Example
#cmlsh multiple-config-session enable
#
#show cmlsh multiple-config-session status
CMLSh multiple configuration session mode : Enabled
#
 
show cmlsh notification status
Use this command to display the notification status (enabled or disabled) for the current CMLSH session.
Command Syntax
show cmlsh notification status
Parameters
None
Mode
Exec mode
Applicability
This command was introduced in OcNOS version 6.0.0.
Example
To show notification status for the CMLSH session.
# OcNOS#show cmlsh notification status
CMLSH notification enabled.
show commit list
Use this command to display a record of commit operations stored in the commit history list.
Note: For commit records to be stored in the commit history list, enable cml commit-history (enable | disable). Otherwise, commit operations will not be stored.
Command Syntax
show commit list
Parameter
None
Command Mode
Exec mode
Applicability
This command is introduced in OcNOS 6.4.1.
Example
Example for show commit list:
#show commit list
S.No. ID User Client TimeStamp Commit Status Description
~~~~~ ~~~~~~~~~~~~~~~~~ ~~~~~ ~~~~~~ ~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~~~~
1 1684542224876712 ocnos cmlsh 20-05-2023 00:23:44 Confirmed NA
 
show max-transaction limit
Use this command to display the maximum number of transactions.
Command Syntax
show max-transaction limit
Parameters
None
Default
N/A
Mode
Exec mode
Applicability
This command was introduced in OcNOS version 5.0.
Example
#show max-transaction limit
Max-Transaction Limit is 30000
show module-info
Use this command to display module's config and state configuration for any top-level object in the data model. This command can be used to display module configuration in XML or JSON format. This command is equivalent to a NETCONF GET operation.
Command Syntax
show module-info OBJECT_NAME format (xml|json)
Parameters
OBJECT_NAME
Name of the object, such as ISIS or OSPF
xml
XML output format
json
JSON output format
Mode
All modes
Applicability
This command was introduced in OcNOS version 6.0.0.
Example
To display the user-session module's config and state configuration in XML format:
#show module-info user-session format xml
<user-session xmlns="http://www.ipinfusion.com/yang/ocnos/ipi-user-session-management">
<sessions>
<session>
<id>pts/0</id>
<state>
<id>pts/0</id>
<user-role>network-admin</user-role>
<type>Local</type>
<process-identifier>1099</process-identifier>
<idle-time>0d00h00m</idle-time>
<client-type>CLI</client-type>
<user-name>root</user-name>
<line>130 vty 0</line>
</state>
</session>
</sessions>
</user-session>
To display the user-session module's config and state configuration in JSON format:
#show module-info user-session format json
{
"user-session":{
"sessions":{
"session":[
{
"id":"pts/0",
"state":{
"id":"pts/0",
"user-role":"network-admin",
"type":"Local",
"process-identifier":"1099",
"idle-time":"0d00h00m",
"client-type":"CLI",
"user-name":"root",
"line":"130 vty 0"
}
}
]
}
}
}
 
show running-config notification
Use this command to display the notification status (enabled or disabled) and notification severity levels.
Command Syntax:
show running-config notification
Parameters
None
Mode
Exec mode
Applicability
This command was introduced in OcNOS version 6.0.0.
Example
To display the notification status and notification severity levels.
#show running-config notification
!
module nsm notification enable severity major
!
show system restore failures
Use this command to display configuration restoration status after save reload device.
Command Syntax
show system restore failures
Parameters
None
Mode
Exec mode
Applicability
This command was introduced in OcNOS version 5.1.
Example
Configuration restoration successful status information after save reload device:
#show system restore failures
Configuration restore from DB is completed.
Total no. of failed configuration objects = 0
Configuration restoration failure status information after save reload device:
#show system restore failures
Configuration restore from DB is completed.
Total no. of failed configuration objects = 1.
 
Failed Protocols information :
Protocol Name=ipi-interface, Protocol Id=3 :
Failed configuration object information :
Total no. of failed configuration objects = 1.
Object Name = config, DN = cmlAutoDummy3074=3074,name=eth0,cmlAutoDummy3073=3073 :
Error Information :
Total no. of configuration errors = 1.
ErrorCode = -16946, ErrorMessage = % No such VRF, ErrorXpath = /interfaces/interface[name='eth0']/config.
show transaction current
Use this command to display the current transaction.
Mode changes, action items (such as clear interface counters), and show commands are not part of a transaction and are not displayed by this command.
Command Syntax
show transaction current
Parameters
None
Default
N/A
Mode
Exec mode and configure mode
Applicability
This command was introduced in OcNOS version 5.0.
Example
(config)#interface eth3
(config-if)#description testing
(config-if)#mtu 664
(config-if)#exit
(config)#show transaction current
interface eth3
description testing
mtu 664
show transaction last-aborted
Use this command to display the last aborted transaction.
Command Syntax
show transaction last-aborted
Parameters
None
Default
N/A
Mode
Exec mode
Applicability
This command was introduced in OcNOS version 5.0.
Example
(config)#router isis 4
(config-router)#isis wait-timer 45
(config-router)#net 11.22.33
(config-router)#exit
(config)#commit
%% Invalid NET length - /isis/isis-instance[instance='4']/config
(config)#show running-config isis
!
!
(config)#abort transaction
(config)#exit
#show transaction last-aborted
router isis 4
isis wait-timer 45
net 11.22.33
#
show (xml|json) running-config|candidate-config
Use this command to display the running or candidate system configuration for any top-level object in the data model. This CLI can also be used for display full running or candidate system configuration for all protocol modules. This command can be used to display running or candidate system configuration in xml or json format. This command is equivalent to a NETCONF GET-CONFIG operation.
Command Syntax
show (xml|json) (running-config| candidate-config) OBJECT_NAME
Parameters
xml
XML output format
json
JSON output format
candidate-config
 
Candidate system configuration
running-config
Running system configuration
OBJECT_NAME
Name of the object, such as ISIS or OSPF
Mode
All modes
Applicability
This command was introduced before OcNOS version 4.2 and updated in OcNOS version 6.0.0.
Example
To display the top level objects:
#show xml running-config
arp bfd bgp dhcp evpn evpn-mpls
interfaces ip-global isis key-chains lacp layer2-global
ldp lldp logging mpls neighbor-discovery network-instances
ospfv2 pcep ping prefixes routemaps routing
rsvp-te segment-routing system-info tacacs time-ranges vlan-classifier
vpls vpws vxlan
To display the ISIS running configuration in XML format:
#show xml running-config isis
<isis xmlns="http://www.ipinfusion.com/yang/ocnos/ipi-isis">
<isis-instance xmlns="http://www.ipinfusion.com/yang/ocnos/ipi-isis">
<instance>1</instance>
<config xmlns="http://www.ipinfusion.com/yang/ocnos/ipi-isis">
<instance>1</instance>
<vrf-name>default</vrf-name>
</config>
</isis-instance>
</isis>
To display the logging running configuration in XML format:
#show xml running-config logging
<logging xmlns="http://www.ipinfusion.com/yang/ocnos/ipi-logging">
<rsyslog>
<vrf>default</vrf>
<config>
<vrf>default</vrf>
<enable-rsyslog>rsyslog</enable-rsyslog>
</config>
</rsyslog>
</logging>
To display the logging running configuration in JSON format:
#show json running-config logging
{
"logging":{
"rsyslog":[
{
"vrf":"default",
"config":{
"vrf":"default",
"enable-rsyslog":"rsyslog"
}
}
]
}
}
To display the OSPFv2 candidate configuration in XML format:
#show xml candidate-config ospfv2
<ospfv2 xmlns="http://www.ipinfusion.com/yang/ocnos/ipi-ospf">
<processes>
<process>
<ospf-id>1</ospf-id>
<config>
<ospf-id>1</ospf-id>
<vrf-name>default</vrf-name>
</config>
</process>
</processes>
</ospfv2>
To display the OSPFv2 candidate configuration in JSON format:
#show json candidate-config ospfv2
{
"ospfv2":{
"processes":{
"process":[
{
"ospf-id":"1",
"config":{
"ospf-id":"1",
"vrf-name":"default"
}
}
]
}
}
}