OcNOS-SP : Virtual Extensible LAN Guide : Virtual Extensible LAN Configuration Guide : VxLAN-EVPN Configuration
VxLAN-EVPN Configuration
This section contains basic VxLAN-EVPN configuration examples.
VxLAN (Virtual eXtended LAN) creates LAN segments using a MAC-in-IP encapsulation. The encapsulation carries the original L2 frame received from a host to the destination in another host using IP tunnels. The endpoints of the virtualized tunnel formed using VxLAN are called VTEPs (VxLAN Tunnel End Points). The VTEPs carry tenant data in L3 tunnels over the network which permits the network to support multiple tenants.The tenant data is not used in routing or switching. This aids in tenant machine movement and allows the tenants to have same IP/MAC addresses.
Information about the given VM to get to the VTEP is crucial in VxLAN protocol; therefore BGP-MP is used to carry this information across VTEPS.
Note: For port-channel/Static-channel interface, storm control will be applied on each member port. For Example: if Interface eth1 and interface eth2 is part of port-channel i.e. po1 and storm control 2mbps is applied for broadcast traffic, then the storm control settings will be applied on each member port and broadcast traffic on each member port will be rate limited to 2mbps each.
Topology
The procedures in this section use the topology in Figure 3-4.
VxLAN EVPN
VTEP1
Enable NVO access-if mode on a physical interface
 
#configure terminal
Enter configure mode
(config)#interface xe1
Enter interface mode
(config-if)#switchport
Configure the interface as a switch port.
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode
(config)#interface xe2
Enter interface mode
(config-if)#switchport
Configure the interface as switch port.
(config-if)#no shutdown
Bring the interface into operation.
(config-if)#exit
Exit interface mode.
(config)#interface xe22
Enter interface mode.
(config-if)#ip address 10.1.1.1/24
Set an IP address on the interface.
(config-if)#no shutdown
Bring the interface into operation.
(config-if)#exit
Exit interface mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 1.1.1.1/32 secondary
Set an IP address on the interface.
(config-if)#no shutdown
Bring the interface into operation.
(config-if)#exit
Exit interface mode.
(config)#router isis ABC
Create an IS-IS routing instance (ABC).
(config-router)#is-type level-1
Configure instance as level-1-only routing.
(config-router)#net 49.0001.1111.1111.1111.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#exit
Exit router mode.
(config)#interface xe22
Enter interface mode
(config-if)#ip router isis ABC
Enable IS-IS routing on an interface (ABC).
(config-if)#isis circuit-type level-1
Configure instance as level-1-only routing.
(config-if)#exit
Exit interface mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip router isis ABC
Enable IS-IS routing on an interface for area 49 (ABC).
(config-if)#isis circuit-type level-1
Configure instance as level-1-only routing.
(config-if)#exit
Exit interface mode.
(config)#mac vrf vrf_evpn_100
Configure a new VRF named vrf_evpn_100.
(config-vrf)#rd 1.1.1.1:1
Assign the Route Distinguisher value.
(config-vrf)#route-target both 100:1
Configure route target to import and export the routes.
(config-vrf)#exit
Exit VRF mode.
(config)#router bgp 1
Define the routing process. The number 1 specifies the AS number of VTEP1.
(config-router)#bgp router-id 1.1.1.1
Configure router-id for this BGP process.
(config-router)#neighbor 2.2.2.2 remote-as 1
Define BGP neighbor: 2.2.2.2 is the IP address of the neighbor (VTEP2), and 1 is the neighbor’s AS number.
(config-router)# neighbor 2.2.2.2 update-source 1.1.1.1
Define BGP neighbor: 1.1.1.1 is the peer interface.
(config-router)#address-family l2vpn evpn
Configure address-family L2VPN EVPN.
(config-router-af)#neighbor 2.2.2.2 activate
Activate the neighbor in the EVPN address family.
(config-router-af)#exit-address-family
Exit the address-family mode.
(config-router)#exit
Exit router mode.
(config)#hardware-profile filter vxlan enable
Enable hardware-profile filter for VxLAN.
(config)#nvo vxlan enable
Enable VxLAN globally on this VTEP.
(config)#nvo vxlan vtep-ip-global 1.1.1.1
Assign a global IP to the VTEP.
(config)#nvo vxlan id 100 ingress-replication
Configure a VNID on this VTEP and enter NVO mode.
(config-nvo)#vxlan host-reachability-protocol evpn-bgp vrf_evpn_100
Configure host-reachability-protocol as BGP-EVPN and associate the VNID with vrf_evpn_100.
(config-nvo)#exit
Exit NVO mode.
(config)#nvo vxlan access-if port-vlan xe1 2
Configure access-port xe1 and map vlan 2
(config-nvo-acc-if)#map vnid 100
Map VNID 100 to access-port xe1.
(config-nvo-acc-if)#exit
Exit NVO access-if mode.
(config)#nvo vxlan id 200 ingress-replication
Configure second VNID on this VTEP and enter NVO mode.
(config-nvo)#vxlan host-reachability-protocol evpn-bgp vrf_evpn_100
Configure host-reachability-protocol as BGP-EVPN and associate the VNID with vrf_evpn_100
(config-nvo)#exit
Exit NVO mode.
(config)#nvo vxlan access-if port-vlan xe2 3
Configure access-port xe2 and map vlan 3
(config-nvo-acc-if)#map vnid 200
Map VNID 200 to access-port xe2.
(config-nvo-acc-if)#exit
Exit NVO access-if mode.
(config)#commit
Commit the configurations
Activate access-if-evpn mode on an L2 sub-interface
 
(config)#interface xe1.1 switchport
Create L2 subinterface xe1.1
(config-if)#encapsulation dot1q 2
Configure encapsulation dot1q with vlan-id 2
(config-if)#access-if-evpn
Enter access-if-evpn mode
(config-acc-if-evpn)#map vpn-id 100
Map vnid 100 to access interface xe1.1
(config-acc-if-evpn)#exit
Exit access-if-evpn mode
(config)#interface xe2.1 switchport
Create L2 subinterface xe2.1
(config-if)#encapsulation dot1q 3
Configure encapsulation dot1q with vlan-id 3
(config-if)#access-if-evpn
Enter access-if-evpn mode
(config-acc-if-evpn)#map vpn-id 200
Map vnid 200 to access interface xe2.1
(config-acc-if-evpn)#exit
Exit access-if-evpn mode
(config-if)#commit
Commit the configurations
Spine-1
 
#configure terminal
Enter configure mode.
(config)#interface xe22
Enter interface mode.
(config-if)#ip address 10.1.1.2/24
Set an IP address on the interface.
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode.
(config)#interface xe11
Enter interface mode.
(config-if)#ip address 20.1.1.2/24
Set an IP address on the interface.
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode.
(config)#router isis ABC
Create an IS-IS routing instance (ABC).
(config-router)#is-type level-1
Configure instance as level-1-only routing.
(config-router)#net 49.0001.3333.3333.3333.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#exit
Exit router mode.
(config)#interface xe22
Enter interface mode.
(config-if)#ip router isis ABC
Enable IS-IS routing on an interface (ABC).
(config-if)#isis circuit-type level-1
Configure instance as level-1-only routing.
(config-if)#exit
Exit interface mode.
(config)#interface xe11
Enter interface mode.
(config-if)#ip router isis ABC
Enable IS-IS routing on an interface (ABC).
(config-if)#isis circuit-type level-1
Configure instance as level-1-only routing.
(config-if)#exit
Exit interface mode.
(config)#commit
Commit the configurations
VTEP2
Enable NVO access-if mode on a physical interface
 
#configure terminal
Enter configure mode.
(config)#interface xe1
Enter interface mode.
(config-if)#switchport
Configure the interface as switchport.
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#switchport
Configure the interface as switchport.
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode.
(config)#interface xe11
Enter interface mode.
(config-if)#ip address 20.1.1.1/24
Set an IP address on the interface.
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 2.2.2.2/32 secondary
Set an IP address on the interface.
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode.
(config)#router isis ABC
Create an IS-IS routing instance (ABC).
(config-router)#is-type level-1
Configure instance as level-1-only routing.
(config-router)#net 49.0001.2222.2222.2222.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#exit
Exit router mode.
(config)#interface xe11
Enter interface mode.
(config-if)#ip router isis ABC
Enable IS-IS routing on an interface (ABC).
(config-if)#isis circuit-type level-1
Configure instance as level-1-only routing.
(config-if)#exit
Exit interface mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip router isis ABC
Enable IS-IS routing on an interface for area 49 (ABC).
(config-if)#isis circuit-type level-1
Configure instance as level-1-only routing.
(config-if)#exit
Exit interface mode.
(config)#mac vrf vrf_evpn_100
Configure a new VRF named vrf_evpn_100.
(config-vrf)#rd 2.2.2.1:1
Assign the Route Distinguisher value.
(config-vrf)#route-target both 100:1
Configure route target to import and export the routes.
(config-vrf)#exit
Exit VRF mode.
(config)#router bgp 1
Define the routing process. The number 1 specifies the AS number of VTEP1.
(config-router)#neighbor 1.1.1.1 remote-as 1
Define BGP neighbor: 1.1.1.1 is the IP address of the neighbor (VTEP1), and 1 is the neighbor’s AS number.
(config-router)# neighbor 1.1.1.1 update-source 2.2.2.2
Define BGP neighbor: 2.2.2.2 is the peer interface.
(config-router)#address-family l2vpn evpn
Configure address-family L2VPN EVPN.
(config-router-af)#neighbor 1.1.1.1 activate
Activate the neighbor in the EVPN address family.
(config-router-af)#exit-address-family
Exit address-family mode.
(config-router)#exit
Exit router mode.
(config)#hardware-profile filter vxlan enable
Enable hardware-profile filter for VxLAN.
(config)#nvo vxlan enable
Enable VxLAN globally on this VTEP.
(config)#nvo vxlan vtep-ip-global 2.2.2.2
Assign a global IP to the VTEP.
(config)#nvo vxlan id 100 ingress-replication
Configure a VNID on this VTEP and enter NVO mode.
(config-nvo)#vxlan host-reachability-protocol evpn-bgp vrf_evpn_100
Configure host-reachability-protocol as BGP-EVPN and associate the VNID with vrf_evpn_100.
(config-nvo)#exit
Exit NVO mode.
(config)#nvo vxlan access-if port-vlan xe1 2
Configure access-port xe1 and map vlan 2
(config-nvo-acc-if)#map vnid 100
Map VNID 100 to access-port xe1.
(config-nvo-acc-if)#exit
Exit NVO access-if mode.
(config)#nvo vxlan id 200 ingress-replication
Configure second VNID on this VTEP and enter NVO mode.
(config-nvo)#vxlan host-reachability-protocol evpn-bgp vrf_evpn_100
Configure host-reachability-protocol as BGP-EVPN and associate the VNID with vrf_evpn_100
(config-nvo)#exit
Exit NVO mode.
(config)#nvo vxlan access-if port-vlan xe2 3
Configure access-port xe2 and map vlan 3
(config-nvo-acc-if)#map vnid 200
Map VNID 200 to access-port xe2.
(config-nvo-acc-if)#exit
Exit NVO access-if mode.
(config)#commit
Commit the configurations
Activate access-if-evpn mode on an L2 sub-interface
 
(config)#interface xe1.1 switchport
Create L2 subinterface xe1.1
(config-if)#encapsulation dot1q 2
Configure encapsulation dot1q with vlan-id 2
(config-if)#access-if-evpn
Enter access-if-evpn mode
(config-acc-if-evpn)#map vpn-id 100
Map vnid 100 to access interface xe1.1
(config-acc-if-evpn)#exit
Exit access-if-evpn mode
(config)#interface xe2.1 switchport
Create L2 subinterface xe2.1
(config-if)#encapsulation dot1q 3
Configure encapsulation dot1q with vlan-id 3
(config-if)#access-if-evpn
Enter access-if-evpn mode
(config-acc-if-evpn)#map vpn-id 200
Map vnid 200 to access interface xe2.1
(config-acc-if-evpn)#exit
Exit access-if-evpn mode
(config-if)#commit
Commit the configurations
 
Validation
CE1 and CE2 have hosts configured with MAC addresses, IP addresses, and VLAN identifiers as shown below.
 
 
VLAN
IP Address
Mac Address
VTEP1
CE-1
2
12.12.12.10
0000.0000.abab
VTEP2
CE-2
2
12.12.12.20
0000.0000.cdcd
VTEP1
CE-1
3
13.13.13.10
0000:0b60:25f2
VTEP2
CE-2
3
13.13.13.20
0000:0b60:25f3
Perform a tagged ping of VLAN 2 from CE1 to CE2 and vice-versa. Also perform a tagged ping of VLAN 3 from CE1 to CE2 and vice-versa.
VTEP Tunnel Status
VTEP-1#show nvo vxlan tunnel
VxLAN Network tunnel Entries
Source Destination Status Up/Down Update
================================================================================
1.1.1.1 2.2.2.2 Installed 00:05:53 00:05:53
Total number of entries are 1
 
 
VTEP-2#show nvo vxlan tunnel
VxLAN Network tunnel Entries
Source Destination Status Up/Down Update
================================================================================
2.2.2.2 1.1.1.1 Installed 00:05:46 00:05:46
Total number of entries are 1
 
VTEP ARP Cache
VTEP-1#sh nvo vxlan arp-cache
VxLAN ARP-CACHE Information
===========================
ARP Timeout : 300 sec Random-Jitter-Max : 640
VNID Ip-Addr Mac-Addr Type Age-Out Retries-Left
____________________________________________________________________________
200 13.13.13.10 0000.0b60.25f2 Dynamic Local 246 2
200 13.13.13.20 0000.0b60.25f3 Dynamic Remote ------
100 12.12.12.20 0000.0000.cdcd Dynamic Remote ------
100 12.12.12.10 0000.0000.abab Dynamic Local 246 2
Total number of entries are 4
 
VTEP-2#sh nvo vxlan arp-cache
VxLAN ARP-CACHE Information
===========================
ARP Timeout : 300 sec Random-Jitter-Max : 640
VNID Ip-Addr Mac-Addr Type Age-Out Retries-Left
____________________________________________________________________________
200 13.13.13.10 0000.0b60.25f2 Dynamic Remote -------
200 13.13.13.20 0000.0b60.25f3 Dynamic Local 257 2
100 12.12.12.10 0000.0000.abab Dynamic Remote -------
100 12.12.12.20 0000.0000.cdcd Dynamic Local 257 2
Total number of entries are 4
 
VTEP MAC Tables
VTEP-1#show nvo vxlan mac-table
================================================================================
VxLAN MAC Entries
================================================================================
VNID Interface VlanId Inner-VlanId Mac-Addr VTEP-Ip/ESI Type Status AccessPortDesc
________________________________________________________________________________
 
100 ---- ---- ---- 0000.0000.cdcd 2.2.2.2 Dynamic Remote ------- -------
100 xe1 2 ---- 0000.0000.abab 1.1.1.1 Dynamic Local ------- -------
200 xe2 3 ---- 0000.0b60.25f2 1.1.1.1 Dynamic Local ------- -------
200 ---- ---- ---- 0000.0b60.25f3 2.2.2.2 Dynamic Remote ------- -------
Total number of entries are : 4
 
 
VTEP-2#show nvo vxlan mac-table
================================================================================
VxLAN MAC Entries
================================================================================
VNID Interface VlanId Inner-VlanId Mac-Addr VTEP-Ip/ESI Type Status AccessPortDesc
________________________________________________________________________________
 
100 xe1 2 ---- 0000.0000.cdcd 2.2.2.2 Dynamic Local ------- -------
100 ---- ---- ---- 0000.0000.abab 1.1.1.1 Dynamic Remote ------- -------
200 ---- ---- ---- 0000.0b60.25f2 1.1.1.1 Dynamic Remote ------- -------
200 xe2 3 ---- 0000.0b60.25f3 2.2.2.2 Dynamic Local ------- -------
Total number of entries are : 4
 
VTEP MAC-IP BGP EVPN Entries
VTEP-1#show bgp l2vpn evpn mac-ip
RD[1.1.1.1:1] VRF[vrf_evpn_100]:
ESI Eth-Tag Mac-Address IP-Address VNID L3VNID Nexthop GW-Type
0 100 0000:0000:abab 12.12.12.10 100 0 1.1.1.1 --
0 200 0000:0b60:25f2 13.13.13.10 200 0 1.1.1.1 --
 
RD[2.2.2.2:1]
ESI Eth-Tag Mac-Address IP-Address VNID L3VNID Nexthop GW-Type
0 100 0000:0000:cdcd 12.12.12.20 100 0 2.2.2.2 --
0 200 0000:0b60:25f3 13.13.13.20 200 0 2.2.2.2 --
 
 
VTEP-2#show bgp l2vpn evpn mac-ip
RD[1.1.1.1:1]
ESI Eth-Tag Mac-Address IP-Address VNID L3VNID Nexthop GW-Type
0 100 0000:0000:abab 12.12.12.10 100 0 1.1.1.1 --
0 200 0000:0b60:25f2 13.13.13.10 200 0 1.1.1.1 --
 
RD[2.2.2.2:1] VRF[vrf_evpn_100]:
ESI Eth-Tag Mac-Address IP-Address VNID L3VNID Nexthop GW-Type
0 100 0000:0000:cdcd 12.12.12.20 100 0 2.2.2.2 --
0 100 0000:0b60:25f2 13.13.13.10 100 0 2.2.2.2 --
LAG as Access Port with ECMP on the Network Side
This section contains basic VxLAN EVPN configuration with LAG as an access port and ECMP on the network side.
Topology
The procedures in this section use the topology in Figure 3-5.
VxLAN EVPN with LAG and ECMP
SW-1
 
#configure terminal
Enter configure mode
(config)#bridge 1 protocol ieee vlan-bridge
Configure IEEE vlan bridge
(config)#vlan database
Enter into the vlan database
(config-vlan)#vlan 2 bridge 1 state enable
Configure vlan 2 and associate with bridge 1
(config-vlan)#vlan 3 bridge 1 state enable
Configure vlan 3 and associate with bridge 1
(config-vlan)#exit
Exit from the vlan database
(config)#in xe41
Enter interface mode
(config-if)#no shutdown
Make interface admin up
(config-if)#switchport
Set the interface as Layer2 port
(config-if)#bridge-group 1
Associate the Interface with bridge-group.
(config-if)#switchport mode trunk
Set the switching characteristics of this interface to trunk mode
(config-if)#switchport trunk allowed vlan add 2
Configure the VLANs that should be allowed through this interface
(config-if)#switchport trunk allowed vlan add 3
Configure the VLANs that should be allowed through this interface
(config-if)#exit
Exit interface mode.
(config)#interface po1
Enter interface mode
(config-if)#switchport
Set the interface as Layer2 port
(config-if)#exit
Exit interface mode.
(config)#in xe29
Enter interface mode
(config-if)#switchport
Set the interface as Layer2 port
(config-if)#channel-group 1 mode active
Configure the interface to be part of port channel 1
(config-if)#exit
Exit interface mode.
(config)#in xe30
Enter interface mode
(config-if)#switchport
Set the interface as Layer2 port
(config-if)#channel-group 1 mode active
Configure the interface to be part of port channel 1
(config-if)#exit
Exit interface mode.
(config)#in xe31
Enter interface mode
(config-if)#switchport
Set the interface as Layer2 port
(config-if)#channel-group 1 mode active
Configure the interface to be part of port channel 1
(config-if)#exit
Exit interface mode.
(config)#in xe32
Enter interface mode
(config-if)#switchport
Set the interface as Layer2 port
(config-if)#channel-group 1 mode active
Configure the interface to be part of port channel 1
(config-if)#exit
Exit interface mode.
(config-if)#inter po1
Enter interface mode
(config-if)#bridge-group 1
Associate the Interface with bridge-group.
(config-if)#switchport mode trunk
Set the switching characteristics of this interface to trunk mode
(config-if)#switchport trunk allowed vlan add 2
Configure the VLANs that should be allowed through this interface
(config-if)#switchport trunk allowed vlan add 3
Configure the VLANs that should be allowed through this interface
(config-if)#exit
Exit interface mode.
(config)#commit
Commit the configurations
VTEP-1
 
#configure terminal
Enter configure mode
(config)#interface po1
Create interface po1
(config-if)#switchport
Configure the interface as switchport.
(config-if)#exit
Exit interface mode
(config)#interface xe3
Enter interface mode.
(config-if)#switchport
Configure the interface as switchport.
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode
(config)#interface xe5
Enter interface mode
(config-if)#switchport
Configure the interface as switchport.
(config-if)#channel-group 1 mode active
Configure the interface to be part of port channel 1
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode
(config)#interface xe6
Enter interface mode
(config-if)#switchport
Configure the interface as switchport.
(config-if)#channel-group 1 mode active
Configure the interface to be part of port channel 1
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode
(config)#interface xe7
Enter interface mode
(config-if)#switchport
Configure the interface as switchport.
(config-if)#channel-group 1 mode active
Configure the interface to be part of port channel 1
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode
(config)#interface xe8
Enter interface mode
(config-if)#switchport
Configure the interface as switchport.
(config-if)#channel-group 1 mode active
Configure the interface to be part of port channel 1
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode.
(config)#interface xe1
Enter interface mode.
(config-if)#ip address 10.1.1.0/31
Configure IP address on the interface xe1.
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#ip address 10.1.1.2/31
Configure IP address on the interface xe2.
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 1.1.1.1/32 secondary
Configure IP address on the interface xe3.
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode.
(config)#router isis ABC
Create an IS-IS routing instance (ABC).
(config-router)#is-type level-1
Configure instance as level-1-only routing.
(config-router)#net
Set a Network Entity Title for this instance, specifying the
49.0001.1111.1111.1111.00
area address and the system ID.
(config-router)#exit
Exit router mode.
(config)#interface xe1
Enter interface mode.
(config-if)#ip router isis ABC
Enable IS-IS routing on an interface (ABC).
(config-if)#isis circuit-type level-1
Configure instance as level-1-only routing.
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#ip router isis ABC
Enable IS-IS routing on an interface (ABC).
(config-if)#isis circuit-type level-1
Configure instance as level-1-only routing.
(config-if)#exit
Exit interface mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip router isis ABC
Enable IS-IS routing on an interface for area 49 (ABC).
(config-if)#isis circuit-type level-1
Configure instance as level-1-only routing.
(config-if)#exit
Exit interface mode.
(config)#mac vrf vrf_evpn_100
Configure a new VRF named vrf_evpn_100.
(config-vrf)#rd 1.1.1.1:1
Assign the Route Distinguisher value.
(config-vrf)#route-target both 100:1
Configure route target to import and export the routes.
(config-vrf)#exit
Exit VRF mode.
(config)#router bgp 65535
Define the routing process. The number 65535 specifies the AS number of VTEP1.
(config-router)#bgp router-id 1.1.1.1
Configure router-id for this BGP process.
(config-router)#neighbor 2.2.2.2 remote-as 65535
Define BGP neighbor: 2.2.2.2 is the IP address of the neighbor (VTEP2), and 65535 is the neighbor’s AS number.
(config-router)# neighbor 2.2.2.2 update-source 1.1.1.1
Define BGP neighbor: 1.1.1.1 is the peer interface.
(config-router)#neighbor 3.3.3.3 remote-as 65535
Define BGP neighbor: 3.3.3.3 is the IP address of the neighbor (VTEP3), and 65535 is the neighbor’s AS number.
(config-router)# neighbor 3.3.3.3 update-source 1.1.1.1
Define BGP neighbor: 1.1.1.1 is the peer interface.
(config-router)#address-family l2vpn evpn
Configure address-family L2VPN EVPN.
(config-router-af)#neighbor 2.2.2.2 activate
Activate the neighbor at VTEP2 in the EVPN address family.
(config-router-af)#neighbor 3.3.3.3 activate
Activate the neighbor at VTEP3 in the EVPN address family.
(config-router-af)#exit-adress-family
Exit address-family mode.
(config-router)#exit
Exit router mode.
(config)#hardware-profile filter vxlan enable
Enable hardware-profile filter for VxLAN.
(config)#nvo vxlan enable
Enable VxLAN globally on this VTEP.
(config)#nvo vxlan vtep-ip-global 1.1.1.1
Assign a global IP to the VTEP.
(config)#nvo vxlan id 100001 ingress-replication
Configure a VNID on this VTEP and enter NVO mode.
(config-nvo)#vxlan host-reachability-protocol evpn-bgp vrf_evpn_100
Configure host-reachability-protocol as BGP-EVPN and associate the VNID with VRF vrf_evpn_100.
(config-nvo)#exit
Exit NVO mode.
(config)#nvo vxlan access-if port-vlan xe3 2
Configure access-port xe3 and map vlan 2
(config-nvo-acc-if)#map vnid 100001
Map VNID 100001 to access-port xe3.
(config-nvo-acc-if)#exit
Exit NVO access-if mode.
(config)#nvo vxlan access-if port-vlan po1 2
Configure access-port po1 and map vlan 2
(config-nvo-acc-if)#map vnid 100001
Map VNID 100001 to access-port po1.
(config-nvo-acc-if)#exit
Exit NVO access-if mode.
(config)#nvo vxlan id 200001 ingress-replication
Configure second VNID on this VTEP and enter NVO mode.
(config-nvo)#vxlan host-reachability-protocol evpn-bgp vrf_evpn_100
Configure host-reachability-protocol as BGP-EVPN and associate the VNID with VRF vrf_evpn_100.
(config-nvo)#exit
Exit NVO mode.
(config)#nvo vxlan access-if port-vlan xe3 3
Configure access-port xe3 and map vlan 3
(config-nvo-acc-if)#map vnid 200001
Map VNID 200001 to access-port xe3.
(config-nvo-acc-if)#exit
Exit NVO access-if mode.
(config)#nvo vxlan access-if port-vlan po1 3
Configure access-port po1 and map vlan 3
(config-nvo-acc-if)#map vnid 200001
Map VNID 200001 to access-port xe3.
(config-nvo-acc-if)#exit
Exit NVO access-if mode.
(config)#commit
Commit the configurations
Spine-1
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode
(config-if)#ip address 12.12.12.12/32 secondary
Set an IP address on the interface.
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode.
(config)#interface xe1
Enter interface mode.
(config-if)#ip address 10.1.1.1/31
Configure IP address on the interface xe1.
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#ip address 20.1.1.1/31
Configure IP address on the interface xe2.
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode.
(config)#interface xe3
Enter intereface mode.
(config-if)#ip address 30.1.1.1/31
Configure IP address on the interface xe3.
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode.
(config)#router isis ABC
Create an IS-IS routing instance (ABC).
(config-router)#is-type level-1
Configure instance as level-1-only routing.
(config-router)#net 49.0001.4444.4444.4444.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#exit
Exit router mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip router isis ABC
Enable IS-IS routing on an interface (ABC).
(config-if)#isis circuit-type level-1
Configure instance as level-1-only routing.
(config-if)#exit
Exit interface mode.
(config)#interface xe1
Enter interface mode.
(config-if)#ip router isis ABC
Enable IS-IS routing on an interface (ABC).
(config-if)#isis circuit-type level-1
Configure instance as level-1-only routing.
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#ip router isis ABC
Enable IS-IS routing on an interface (ABC).
(config-if)#isis circuit-type level-1
Configure instance as level-1-only routing.
(config-if)#exit
Exit interface mode.
(config)#interface xe3
Enter interface mode.
(config-if)#ip router isis ABC
Enable IS-IS routing on an interface (ABC).
(config-if)#isis circuit-type level-1
Configure instance as level-1-only routing.
(config-if)#exit
Exit interface mode.
(config)#commit
Commit the configurations
Spine-2
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 13.13.13.13/32 secondary
Set an IP address on the interface.
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode.
(config)#interface xe1
Enter interface mode.
(config-if)#ip address 10.1.1.3/31
Configure IP address on the interface xe1.
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#ip address 20.1.1.3/31
Configure IP address on the interface xe2.
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode.
(config)#interface xe3
Enter interface mode.
(config-if)#ip address 30.1.1.3/31
Configure IP address on the interface xe3.
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode.
(config)#router isis ABC
Create an IS-IS routing instance (ABC).
(config-router)#is-type level-1
Configure instance as level-1-only routing.
(config-router)#net 49.0001.5555.5555.5555.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#exit
Exit router mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip router isis ABC
Enable IS-IS routing on an interface (ABC).
(config-if)#isis circuit-type level-1
Configure instance as level-1-only routing.
(config-if)#exit
Exit interface mode.
(config)#interface xe1
Enter interface mode.
(config-if)#ip router isis ABC
Enable IS-IS routing on an interface (ABC).
(config-if)#isis circuit-type level-1
Configure instance as level-1-only routing.
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#ip router isis ABC
Enable IS-IS routing on an interface (ABC).
(config-if)#isis circuit-type level-1
Configure instance as level-1-only routing.
(config-if)#exit
Exit interface mode.
(config)#interface xe3
Enter interface mode.
(config-if)#ip router isis ABC
Enable IS-IS routing on an interface (ABC).
(config-if)#isis circuit-type level-1
Configure instance as level-1-only routing.
(config-if)#exit
Exit interface mode.
(config)#commit
Commit the configurations
VTEP-2
 
#configure terminal
Enter configure mode
(config)#interface po1
Enter interface mode
(config-if)#switchport
Configure the interface as switchport
(config-if)#exit
Exit interface mode
(config)#interface xe3
Enter interface mode
(config-if)#switchport
Configure the interface as switchport.
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode.
(config)#interface xe1
Enter interface mode.
(config-if)#ip address 20.1.1.0/31
Configure IP address on the interface xe1.
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#ip address 20.1.1.2/31
Configure IP address on the interface xe2.
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 2.2.2.2/32 secondary
Configure IP address on the interface xe3.
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode.
(config)#router isis ABC
Create an IS-IS routing instance (ABC).
(config-router)#is-type level-1
Configure instance as level-1-only routing.
(config-router)#net 49.0001.2222.2222.2222.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#exit
Exit router mode.
(config)#interface xe1
Enter interface mode.
(config-if)#ip router isis ABC
Enable IS-IS routing on an interface (ABC).
(config-if)#isis circuit-type level-1
Configure instance as level-1-only routing.
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#ip router isis ABC
Enable IS-IS routing on an interface (ABC).
(config-if)#isis circuit-type level-1
Configure instance as level-1-only routing.
(config-if)#exit
Exit interface mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip router isis ABC
Enable IS-IS routing on an interface for area 49 (ABC).
(config-if)#isis circuit-type level-1
Configure instance as level-1-only routing.
(config-if)#exit
Exit interface mode.
(config)#mac vrf vrf_evpn_100
Configure a new VRF named vrf_evpn_100.
(config-vrf)#rd 1.1.1.1:1
Assign the Route Distinguisher value.
(config-vrf)#route-target both 100:1
Configure route target to import and export the routes.
(config-vrf)#exit
Exit VRF mode.
(config)#router bgp 65535
Define the routing process. The number 65535 specifies the AS number of VTEP1.
(config-router)#neighbor 1.1.1.1 remote-as 65535
Define BGP neighbor: 1.1.1.1 is the IP address of the neighbor (VTEP1), and 65535 is the neighbor’s AS number.
(config-router)#neighbor 1.1.1.1 update-source 2.2.2.2
Define BGP neighbor: 2.2.2.2 is the peer interface.
(config-router)#neighbor 3.3.3.3 remote-as 65535
Define BGP neighbor: 3.3.3.3 is the IP address of the neighbor (VTEP3), and 65535 is the neighbor’s AS number.
(config-router)#neighbor 3.3.3.3 update-source 2.2.2.2
Define BGP neighbor: 2.2.2.2 is the peer interface.
(config-router)#address-family l2vpn evpn
Configure address-family L2VPN EVPN.
(config-router-af)#neighbor 1.1.1.1 activate
Activate the neighbor at VTEP1 in the EVPN address family.
(config-router-af)#neighbor 3.3.3.3 activate
Activate the neighbor at VTEP3 in the EVPN address family.
(config-router-af)#exit-adress-family
Exit address-family mode.
(config-router)#exit
Exit router mode.
(config)#hardware-profile filter vxlan enable
Enable hardware-profile filter for VxLAN.
(config)#nvo vxlan enable
Enable VxLAN globally on this VTEP.
(config)#nvo vxlan vtep-ip-global 2.2.2.2
Assign a global IP to the VTEP.
(config)#nvo vxlan id 100001 ingress-replication
Configure a VNID on this VTEP and enter NVO mode.
(config-nvo)#vxlan host-reachability-protocol evpn-bgp vrf_evpn_100
Configure host-reachability-protocol as BGP-EVPN and associate the VNID with VRF vrf_evpn_100.
(config-nvo)#exit
Exit NVO mode.
(config)#nvo vxlan access-if port-vlan xe3 2
Configure access-port xe3 and map vlan 2
(config-nvo-acc-if)#map vnid 100001
Map VNID 100001 to access-port xe3.
(config-nvo-acc-if)#exit
Exit NVO access-if mode.
(config)#nvo vxlan id 200001 ingress-replication
Configure second VNID on this VTEP and enter NVO mode.
(config-nvo)#vxlan host-reachability-protocol evpn-bgp vrf_evpn_100
Configure host-reachability-protocol as BGP-EVPN and associate the VNID with VRF vrf_evpn_100.
(config-nvo)#exit
Exit NVO mode.
(config)#nvo vxlan access-if port-vlan xe3 3
Configure access-port xe3 and map vlan 3
(config-nvo-acc-if)#map vnid 200001
Map VNID 200001 to access-port xe3.
(config-nvo-acc-if)#exit-adress-family
Exit NVO access-if mode.
(config)#commit
Commit the configurations
VTEP-3
 
#configure terminal
Enter configure mode.
(config)#interface xe3
Enter interface mode.
(config-if)#switchport
Configure the interface as switchport.
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode.
(config)#interface xe1
Enter interface mode.
(config-if)#ip address 30.1.1.0/31
Configure IP address on the interface xe1.
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#ip address 30.1.1.2/31
Configure IP address on the interface xe2.
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 3.3.3.3/32 secondary
Configure IP address on the loopback interface.
(config-if)#no shutdown
Bring the interface into operation
(config-if)#exit
Exit interface mode.
(config)#router isis ABC
Create an IS-IS routing instance (ABC).
(config-router)#is-type level-1
Configure instance as level-1-only routing.
(config-router)#net 49.0001.3333.3333.3333.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#exit
Exit router mode.
(config)#interface xe1
Enter interface mode.
(config-if)#ip router isis ABC
Enable IS-IS routing on an interface (ABC).
(config-if)#isis circuit-type level-1
Configure instance as level-1-only routing.
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#ip router isis ABC
Enable IS-IS routing on an interface (ABC).
(config-if)#isis circuit-type level-1
Configure instance as level-1-only routing.
(config-if)#exit
Exit interface mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip router isis ABC
Enable IS-IS routing on an interface for area 49 (ABC).
(config-if)#isis circuit-type level-1
Configure instance as level-1-only routing.
(config-if)#exit
Exit interface mode.
(config)#mac vrf vrf_evpn_100
Configure a new VRF named vrf_evpn_100.
(config-vrf)#rd 1.1.1.1:1
Assign the Route Distinguisher value.
(config-vrf)#route-target both 100:1
Configure route target to import and export the routes.
(config-vrf)#exit
Exit VRF mode.
(config)#router bgp 65535
Define the routing process. The number 65535 specifies the AS number of VTEP1.
(config-router)#neighbor 1.1.1.1 remote-as 65535
Define BGP neighbor: 1.1.1.1 is the IP address of the neighbor (VTEP1), and 65535 is the neighbor’s AS number.
(config-router)#neighbor 1.1.1.1 update-source 3.3.3.3
Define BGP neighbor: 3.3.3.3 is the peer interface.
(config-router)#neighbor 2.2.2.2 remote-as 65535
Define BGP neighbor: 2.2.2.2 is the IP address of the neighbor (VTEP3), and 65535 is the neighbor’s AS number.
(config-router)#neighbor 2.2.2.2 update-source 3.3.3.3
Define BGP neighbor: 3.3.3.3 is the peer interface.
(config-router)#address-family l2vpn evpn
Configure address-family L2VPN EVPN.
(config-router-af)#neighbor 1.1.1.1 activate
Activate the neighbor at VTEP1 in the EVPN address family.
(config-router-af)#neighbor 2.2.2.2 activate
Activate the neighbor at VTEP2 in the EVPN address family.
(config-router-af)#exit-adress-family
Exit address-family mode.
(config-router)#exit
Exit router mode.
(config)#hardware-profile filter vxlan enable
Enable hardware-profile filter for VxLAN.
(config)#nvo vxlan enable
Enable VxLAN globally on this VTEP.
(config)#nvo vxlan vtep-ip-global 3.3.3.3
Assign a global IP to the VTEP.
(config)#nvo vxlan id 100001 ingress-replication
Configure a VNID on this VTEP and enter NVO mode.
(config-nvo)#vxlan host-reachability-protocol evpn-bgp vrf_evpn_100
Configure host-reachability-protocol as BGP-EVPN and associate the VNID with VRF vrf_evpn_100.
(config-nvo)#exit
Exit NVO mode.
(config)#nvo vxlan access-if port-vlan xe3 2
Configure access-port xe3 and map vlan 2
(config-nvo-acc-if)#map vnid 100001
Map VNID 100001 to access-port xe3.
(config-nvo-acc-if)#exit-address-family
Exit NVO access-if mode.
(config)#nvo vxlan id 200001 ingress-replication
Configure second VNID on this VTEP and enter NVO mode.
(config-nvo)#vxlan host-reachability-protocol evpn-bgp vrf_evpn_100
Configure host-reachability-protocol as BGP-EVPN and associate the VNID with VRF vrf_evpn_100
(config-nvo)#exit
Exit NVO mode.
(config)#nvo vxlan access-if port-vlan xe3 3
Configure access-port xe3 and map vlan 3
(config-nvo-acc-if)#map vnid 200001
Map VNID 200001 to access-port xe3.
(config-nvo-acc-if)#exit
Exit NVO access-if mode.
(config)#commit
Commit the configurations
Validation
CE1, CE2, CE3, and CE4 have hosts configured with MAC addresses, IP addresses, and VLAN identifiers as shown below.
 
 
VLAN
IP Address
MAC Address
VTEP1
CE-1
2
12.12.12.10
0000.0000.aaaa
VTEP1
CE-2
2
12.12.12.20
0000.0000.bbbb
VTEP2
CE-3
2
12.12.12.30
0000.0000.cccc
VTEP3
CE-4
2
12.12.12.40
0000.0000.dddd
VTEP1
CE-1
3
14.14.14.10
0000.058e.2181
VTEP1
CE-2
3
14.14.14.20
0000.058e.2182
VTEP2
CE-3
3
14.14.14.30
0000.058e.2183
VTEP3
CE-4
3
14.14.14.40
0000.058e.2184
Perform a tagged ping of VLAN 2 from CE1 to CE2,CE3 and CE4 and vice-versa. Also perform a tagged ping of VLAN 3 from CE1 to CE2, CE3 and CE4 and vice-versa.
VTEP Tunnel Status
VTEP1#show nvo vxlan tunnel
VxLAN Network tunnel Entries
Source Destination Status Up/Down Update
====================================================================================
1.1.1.1 3.3.3.3 Installed 01:25:20 01:25:20
1.1.1.1 2.2.2.2 Installed 01:35:19 01:35:19
Total number of entries are 2
 
VTEP2#show nvo vxlan tunnel
VxLAN Network tunnel Entries
Source Destination Status Up/Down Update
====================================================================================
2.2.2.2 1.1.1.1 Installed 01:35:42 01:35:42
2.2.2.2 3.3.3.3 Installed 01:25:43 01:25:43
Total number of entries are 2
 
VTEP3#show nvo vxlan tunnel
VxLAN Network tunnel Entries
Source Destination Status Up/Down Update
====================================================================================
3.3.3.3 2.2.2.2 Installed 01:25:35 01:25:35
3.3.3.3 1.1.1.1 Installed 01:25:35 01:25:35
Total number of entries are 2
VTEP ARP Tables
VTEP-1#show nvo vxlan arp-cache
VxLAN ARP-CACHE Information
===========================
ARP Timeout : 300 sec Random-Jitter-Max : 640
VNID Ip-Addr Mac-Addr Type Age-Out Retries-Left
_______________________________________________________________________________________
200 13.13.13.10 0000.0b60.25f2 Dynamic Local 246 2
200 13.13.13.20 0000.0b60.25f3 Dynamic Remote ------
100 12.12.12.20 0000.0000.cdcd Dynamic Remote ------
100 12.12.12.10 0000.0000.abab Dynamic Local 246 2
Total number of entries are 4
 
 
VTEP-2#sh nvo vxlan arp-cache
VxLAN ARP-CACHE Information
===========================
ARP Timeout : 300 sec Random-Jitter-Max : 640
VNID Ip-Addr Mac-Addr Type Age-Out Retries-Left
______________________________________________________________________________________
200 13.13.13.10 0000.0b60.25f2 Dynamic Remote -------
200 13.13.13.20 0000.0b60.25f3 Dynamic Local 257 2
100 12.12.12.10 0000.0000.abab Dynamic Remote -------
100 12.12.12.20 0000.0000.cdcd Dynamic Local 257 2
Total number of entries are 4
 
 
VTEP3#show nvo vxlan arp-cache
VxLAN ARP-CACHE Information
===========================
VNID Ip-Addr Mac-Addr Type Age-Out Retries-Left
____________________________________________________________________________
100001 12.12.12.30 0000.0000.cccc Dynamic Remote ----
100001 12.12.12.10 0000.0000.aaaa Dynamic Remote ----
100001 12.12.12.20 0000.0000.bbbb Dynamic Remote ----
100001 12.12.12.40 0000.0000.dddd Dynamic Local ----
200001 14.14.14.20 0000.058e.2182 Dynamic Remote ----
200001 14.14.14.10 0000.058e.2181 Dynamic Remote ----
200001 14.14.14.40 0000.058e.2184 Dynamic Local ----
200001 14.14.14.30 0000.058e.2183 Dynamic Remote ----
Total number of entries are 8
VTEP3#
 
VTEP MAC Tables
VTEP1#show nvo vxlan mac-table
 
================================================================================
================================================================================
VxLAN MAC Entries
================================================================================
================================================================================
VNID Interface VlanId Inner-VlanId Mac-Addr VTEP-Ip/ESI
Type Status AccessPortDesc
________________________________________________________________________________
_____________________________________________________________________
 
1 xe1/1 1000 2000 0000.339a.9abb 33.33.33.0
Dynamic Local ------- -------
1 ---- ---- ---- 0000.339a.9397 34.34.34.0
Dynamic Remote ------- -------
 
Total number of entries are : 2
 
VTEP2#show nvo vxlan mac-table
================================================================================
================================================================================
VxLAN MAC Entries
================================================================================
================================================================================
VNID Interface VlanId Inner-VlanId Mac-Addr VTEP-Ip/ESI
Type Status AccessPortDesc
________________________________________________________________________________
_____________________________________________________________________
 
1 ---- ---- ---- 0000.339a.9abb 33.33.33.0
Dynamic Remote ------- -------
1 xe1/1 1000 2000 0000.339a.9397 34.34.34.0
Dynamic Local ------- -------
 
Total number of entries are : 2
 
 
VTEP MAC-IP BGP EVPN Entries
VTEP-1#show bgp l2vpn evpn mac-ip
RD[1.1.1.1:1] VRF[vrf_evpn_100]:
ESI Eth-Tag Mac-Address IP-Address VNID L3VNID Nexthop GW-Type
0 100 0000:0000:abab 12.12.12.10 100 0 1.1.1.1 --
0 200 0000:0b60:25f2 13.13.13.10 200 0 1.1.1.1 --
 
RD[2.2.2.2:1]
ESI Eth-Tag Mac-Address IP-Address VNID L3VNID Nexthop GW-Type
0 100 0000:0000:cdcd 12.12.12.20 100 0 2.2.2.2 --
0 200 0000:0b60:25f3 13.13.13.20 200 0 2.2.2.2 --
 
 
VTEP-2#show bgp l2vpn evpn mac-ip
RD[1.1.1.1:1]
ESI Eth-Tag Mac-Address IP-Address VNID L3VNID Nexthop GW-Type
0 100 0000:0000:abab 12.12.12.10 100 0 1.1.1.1 --
0 200 0000:0b60:25f2 13.13.13.10 200 0 1.1.1.1 --
 
RD[2.2.2.2:1] VRF[vrf_evpn_100]:
ESI Eth-Tag Mac-Address IP-Address VNID L3VNID Nexthop GW-Type
0 100 0000:0000:cdcd 12.12.12.20 100 0 2.2.2.2 --
0 100 0000:0b60:25f2 13.13.13.10 100 0 2.2.2.2 --
 
 
VTEP-3#show bgp l2vpn evpn mac-ip
 
RD[1.1.1.1:1] VRF[vrf_evpn_100]:
ESI Eth-Tag Mac-Address IP-Address VNID L3VNID Nexthop GW-Type
0 100001 0000:0000:dddd -- 100001 0 3.3.3.3 --
0 100001 0000:0000:dddd 12.12.12.40 100001 0 3.3.3.3 --
0 200001 0000:058e:2184 -- 200001 0 3.3.3.3 --
0 200001 0000:058e:2184 14.14.14.40 200001 0 3.3.3.3 --
 
RD[1.1.1.1:1]
ESI Eth-Tag Mac-Address IP-Address VNID L3VNID Nexthop GW-Type
0 100001 0000:0000:aaaa -- 100001 0 1.1.1.1 --
0 100001 0000:0000:aaaa 12.12.12.10 100001 0 1.1.1.1 --
0 100001 0000:0000:bbbb -- 100001 0 1.1.1.1 --
0 100001 0000:0000:bbbb 12.12.12.20 100001 0 1.1.1.1 --
0 100001 0000:0000:cccc -- 100001 0 2.2.2.2 --
0 100001 0000:0000:cccc 12.12.12.30 100001 0 2.2.2.2 --
0 200001 0000:058e:2181 -- 200001 0 1.1.1.1 --
0 200001 0000:058e:2181 14.14.14.10 200001 0 1.1.1.1 --
0 200001 0000:058e:2182 -- 200001 0 1.1.1.1 --
0 200001 0000:058e:2182 14.14.14.20 200001 0 1.1.1.1 --
0 200001 0000:058e:2183 -- 200001 0 2.2.2.2 --
0 200001 0000:058e:2183 14.14.14.30 200001 0 2.2.2.2 --