EVPN MPLS IRB Symmetric Distributed mode
Topology
Figure 26-3 depicts the EVPN MPLS IRB with LDP as underlay MPLS path.
Figure 26-3: EVPN MPLS IRB Distributed configuration
Configurations:
SH1
Enable EVPN MPLS and IRB:
#configure terminal | Enter configuration mode. |
(config)#evpn mpls enable | Enable EVPN MPLS globally |
(config)#evpn mpls irb | Enable EVPN MPLS IRB globally |
Loopback Interface:
(config-if)#interface lo | Enter the Interface mode for the loopback interface. |
(config-if)# ip address 5.5.5.5/32 secondary | Configure IP address on loopback interface. |
(config-if)#exit | Exit interface mode |
Configure MAC VRF:
(config)#mac vrf green | Create MAC VRF green. |
(config-vrf)# rd 5.5.5.5:200 | Configure route distinguisher |
(config-vrf)# route-target both evpn-auto-rt | Configure route target as evpn auto route target (we can configure as manual RT also) |
(config-vrf)#exit | Exit VRF mode |
Configure IP VRF:
(config)#ip vrf evpn | Configure IP VRF evpn. |
(config-vrf)# rd 30:200 | Configure route distinguisher |
(config-vrf)# route-target both 100:200 | Configure route target |
(config-vrf)# l3vni 20000 | Configure L3 VNID for routing |
(config-vrf)#exit | Exit VRF mode |
Configuring IRB interface:
(config)#interface irb200 | Create IRB interface irb100 |
(config-irb-if)# ip vrf forwarding evpn | Map L3 VRF to the IRB interface |
(config-irb-if)# ip address 70.70.1.1/24 | Assign IP address |
(config-irb-if)#exit | Exit interface mode |
Creating EVPN MPLS ID:
(config)#evpn mpls vtep-ip-global 5.5.5.5 | Configure VTEP global IP |
(config)#evpn mpls id 200 | Create EVPN MPLS ID |
(config-evpn-mpls)# host-reachability- protocol evpn-bgp green | Map the MAC VRF green |
(config-evpn-mpls)# evpn irb irb200 | Map the IRB interface |
(config-evpn-mpls)#exit | Exit the EVPN MPLS mode |
Global LDP:
(config)#router ldp | Enter the Router LDP mode. |
(config-router)#router-id 5.5.5.5 | Enter LDP router-id |
(config-router)# transport-address ipv4 5.5.5.5 | Configure LDP transport address |
(config-router)# targeted-peer ipv4 2.2.2.2 | Configure LDP target peer address (MH-1) |
(config-router-targeted-peer)#exit | Exit from LDP target peer mode |
(config-router)# targeted-peer ipv4 3.3.3.3 | Configure LDP target peer address (MH-2) |
(config-router-targeted-peer)#exit | Exit from LDP target peer mode |
(config-router)#exit | Exit from LDP mode |
Interface Configuration Network Side:
(config-if)#interface xe6 | Enter interface mode |
(config-if)# description connected to P1 | Configure interface description |
(config-if)# ip address 30.30.30.1/24 | Assign IP address |
(config-if)# mtu 9216 | Configure MTU |
(config-if)# label-switching | Enable label switching |
(config-if)# mpls ldp-igp sync ospf | Enable LDP IGP sync |
(config-if)# enable-ldp ipv4 | Enable LDP IPv4 |
(config-if)#exit | Exit interface mode |
OSPF Configuration:
(config)#router ospf 1 | Enter the Router OSPF mode. |
(config-router)#ospf router-id 5.5.5.5 | Configure OSPF router id |
(config-router)# network 5.5.5.5/32 area 0.0.0.0 | Advertise loopback address in OSPF. |
(config-router)# network 30.30.30.0/24 area 0.0.0.0 | Advertise network address in OSPF. |
(config-router)#exit | Exit OSPF mode |
BGP Configuration:
(config)#router bgp 65010 | Enter the Router BGP mode, ASN: 65010 |
(config-router)# neighbor 2.2.2.2 remote-as 65010 | Configuring MH-1 as I-BGP neighbor using it's loopback IP |
(config-router)# neighbor 2.2.2.2 update- source lo | Source of routing updates as loopback |
(config-router)# neighbor 3.3.3.3 remote-as 65010 | Configuring MH-2 as I-BGP neighbor using it's loopback IP |
(config-router)# neighbor 3.3.3.3 update- source lo | Source of routing updates as loopback |
(config-router-af)# exit-address-family | Exiting of Address family mode |
(config-router)# address-family l2vpn evpn | Entering into address family mode as EVPN |
(config-router-af)# neighbor 2.2.2.2 activate | Enabling EVPN Address family for neighbor |
(config-router-af)# neighbor 3.3.3.3 activate | Enabling EVPN Address family for neighbor |
(config-router-af)# exit-address-family | Exiting of Address family mode |
(config-router)# address-family ipv4 vrf evpn | Entering into VRF address family mode |
(config-router-af)# redistribute connected | Redistribute connected routes to the network |
(config-router-af)# exit-address-family | Exiting of Address family mode |
Access Port Configuration:
(config-if)#interface sa9000 | Creating Static LAG interface |
(config-if)#mtu 9216 | Configure MTU as 9216 |
(config-if)#exit | Exiting out of interface mode |
(config-if)#interface sa9000.200 switchport | Creating Static LAG L2 sub interface of physical interface xe12 |
(config-if)# encapsulation dot1q 200 | Setting Encapsulation to dot1q with VLAN ID 200 |
(config-if)#rewrite pop | Configure rewrite with action pop |
(config-if)#mtu 9216 | Configure MTU as 9216 |
(config-if)# access-if-evpn | Entering Access mode for EVPN MPLS ID configuration |
(config-acc-if-evpn)#map vpn-id 200 | Map VPN-ID 200 |
(config-acc-if-evpn)#exit | Exiting out of access interface mode |
(config-if)#interface xe12 | Enter the Interface mode |
(config-if)# static-channel-group 9000 | Map the physical interface xe12 as static LAG member |
(config-if)#exit | Exit interface mode |
P1:
Loopback Interface:
#configure terminal | Enter configuration mode. |
(config-if)#interface lo | Enter the Interface mode for the loopback interface. |
(config-if)# ip address 4.4.4.4/32 secondary | Configure IP address on loopback interface. |
(config-if)#exit | Exit interface mode |
Global LDP:
(config)#router ldp | Enter the Router LDP mode. |
(config-router)# router-id 4.4.4.4 | Configure router id |
(config-router)# transport-address ipv4 4.4.4.4 | Configure transport address |
(config-router)#exit | Exit from LDP mode |
(config-router)#exit | Exit from LDP mode |
Interface Configuration:
(config-if)#interface xe4 | Enter the Interface mode for xe4. |
(config-if)# mtu 9216 | Configure MTU. |
(config-if)#exit | Enable LDP on the physical interface |
(config)#interface xe4.1 | Create sub-interface xe4.1. |
(config-if)# description connected-to-MH-1 | Configure Interface description |
(config-if)# ip address 10.10.10.2/24 | Assign IP address |
(config-if)# mtu 9216 | Configure MTU to the sub-if |
(config-if)# encapsulation dot1q 20 | Configure encapsulation as dotq |
(config-if)# label-switching | Enable label switching |
(config-if)# mpls ldp-igp sync ospf | Enable LDP IGP sync |
(config-if)# enable-ldp ipv4 | Enable LDP IPv4 |
(config-if)#exit | Exit interface mode |
(config)#interface xe1 | Enter into Interface mode |
(config-if)# description connected to MH-2 | Configure Interface description |
(config-if)# ip address 20.20.20.2/24 | Cofigure IP address |
(config-if)# mtu 9216 | Configure MTU |
(config-if)# label-switching | Enable label switching |
(config-if)# mpls ldp-igp sync ospf | Enable LDP IGP sync |
(config-if)# enable-ldp ipv4 | Enable LDP IPv4 |
(config-if)#exit | Exit interface mode |
(config)#interface xe6 | Enter into Interface mode |
(config-if)# description connected to SH | Configure Interface description |
(config-if)# ip address 30.30.30.2/24 | Assign IP address |
(config-if)# mtu 9216 | Configure MTU |
(config-if)# label-switching | Enable label switching |
(config-if)# mpls ldp-igp sync ospf | Enable LDP IGP sync |
(config-if)# enable-ldp ipv4 | Enable LDP IPv4 |
(config-if)#exit | Exit interface mode |
OSPF Configuration:
(config)#router ospf 1 | Enter the Router OSPF mode. |
(config-router)# ospf router-id 4.4.4.4 | Setting the Router ID as Loopback IP |
(config-router)# network 4.4.4.4/32 area 0.0.0.0 | Advertise loopback address in OSPF. |
(config-router)# network 10.10.10.0/24 area 0.0.0.0 | Advertise network address in OSPF that comes under same subnet. |
(config-router)# network 20.20.20.0/24 area 0.0.0.0 | Advertise network address in OSPF that comes under same subnet. |
(config-router)# network 30.30.30.0/24 area 0.0.0.0 | Advertise network address in OSPF that comes under same subnet. |
(config-router)#exit | Exit Router OSPF mode and return to Configure mode. |
(config)#commit | Commit candidate configuration to be running configuration |
MH-1
Enable EVPN MPLS and IRB:
#configure terminal | Enter configuration mode. |
(config)#hardware-profile filter evpn-mpls-mh enable | Configure hardware profile to enable EVPN MPLS multi homing in hardware |
(config)#evpn mpls enable | Enable EVPN MPLS globally |
(config)#evpn mpls irb | Enable EVPN MPLS IRB globally |
(config)#evpn mpls multihoming enable | Enable EVPN MPLS multihoming globally |
Loopback Interface:
(config-if)#interface lo | Enter the Interface mode for the loopback interface. |
(config-if)#ip address 2.2.2.2/32 secondarysss | Configure IP address on loopback interface. |
(config-if)#exit | Exit interface mode |
Configure MAC VRF:
(config-vrf)#mac vrf green | Create MAC VRF green. |
(config-vrf)# rd 2.2.2.2:200 | Configure route distinguisher |
(config-vrf)# route-target both evpn-auto-rt | Configure route target as evpn auto-rt(we can configure as manual RT also) |
(config-vrf)#exit | Exit VRF mode |
Configure IP VRF:
(config)#ip vrf evpn | Configure IP VRF evpn. |
(config-vrf)# rd 10:200 | Configure route distinguisher |
(config-vrf)# route-target both 100:200 | Configure route target |
(config-vrf)# l3vni 20000 | Configure L3 VNID for routing |
(config-vrf)#exit | Exit VRF mode |
Configure Anycast Gateway MAC:
(config)#evpn irb-forwarding anycast-gateway- mac 0011.2233.4455 | Configure anycast gateway MAC globally |
(config)#interface irb100 | Create IRB interface irb100 |
(config-irb-if)# ip vrf forwarding evpn | Map L3 VRF to the IRB interface |
(config-irb-if)# ip address 80.80.1.1/24 | Assign IP address |
(config-irb-if)# evpn irb-if-forwarding anycast-gateway-mac | Map anycast gateway MAC |
(config-irb-if)#exit | Exit interface mode |
Creating EVPN MPLS ID:
(config)#evpn mpls vtep-ip-global 2.2.2.2 | Configure VTEP global IP |
(config)#evpn mpls id 100 | Create EVPN MPLS ID |
(config-evpn-mpls)# host- reachabilityprotocol evpn-bgp green | Map the MAC VRF green |
(config-evpn-mpls)# evpn irb irb100 | Map the IRB interface |
(config-evpn-mpls)#exit | Exit the EVPN MPLS mode |
Global LDP:
(config)#router ldp | Enter the Router LDP mode |
(config-router)#router-id 2.2.2.2 | Enter LDP router-id |
(config-router)# transport-address ipv4 2.2.2.2 | Configure LDP transport address |
(config-router)# targeted-peer ipv4 5.5.5.5 | Configure LDP target peer address (SH) |
(config-router-targeted-peer)#exit | Exit from LDP target peer mode |
(config-router)#exit | Exit from LDP mode |
Interface Configuration Network Side:
(config-if)#interface xe0 | Enter the Interface mode for xe0. |
(config-if)# mtu 9216 | Configure MTU. |
(config-if)#exit | Exit from interface xe0 |
(config)#interface xe0.1 | Create subinterface in xe10 |
(config-if)# encapsulation dot1q 20 | Configure encapsulation as dotq |
(config-if)# ip address 10.10.10.1/24 | Assign IP address |
(config-if)# mtu 9216 | Configure MTU to the sub-if |
(config-if)# label-switching | Enable label switching |
(config-if)# mpls ldp-igp sync ospf | Enable LDP IGP sync |
(config-if)# enable-ldp ipv4 | Enable LDP IPv4 |
OSPF Configuration:
(config)#router ospf 1 | Enter the Router OSPF mode. |
(config-router)# ospf router-id 2.2.2.2 | Router-ID configurations |
(config-router)# network 2.2.2.2/32 area 0.0.0.0 | Advertise loopback address in OSPF. |
(config-router)# network 10.10.10.0/24 area 0.0.0.0 | Advertise network address in OSPF. |
BGP Configuration:
(config-router)#router bgp 65010 | Enter the Router BGP mode, ASN: 100 |
(config-router)# neighbor 3.3.3.3 remote-as 65010 | Configuring PE2 as iBGP neighbor using it's loopback IP |
(config-router)# neighbor 3.3.3.3 update-source lo | Source of routing updates as loopback |
(config-router)# neighbor 5.5.5.5 remote-as 65010 | Configuring PE2 as iBGP neighbor using it's loopback IP |
(config-router)# neighbor 5.5.5.5 update-source lo | Source of routing updates as loopback |
(config-router)# address-family l2vpn evpn | Entering into address family mode as EVPN |
(config-router-af)# neighbor 3.3.3.3 activate | Enabling EVPN Address family for neighbor |
(config-router-af)# neighbor 5.5.5.5 activate | Enabling EVPN Address family for neighbor |
(config-router-af)# exit-address-family | Exiting of Address family mode |
(config-router)# address-family ipv4 vrf evpn | Entering into VRF address family mode |
(config-router-af)# redistribute connected | Redistribute connected routes to the network |
(config-router-af)# exit-address-family | Exiting of Address family mode |
Access Port Configuration:
(config)#interface xe9 | Enter configuration mode |
(config-if)# mtu 9216 | Configure MTU |
(config-if)# channel-group 10000 mode active | Configure physical interface xe9 as LAG member po10000 |
(config-if)#exit | Exit from interface xe9 |
(config)#interface po10000 | Create LAG interface po10000 |
(config-if)# mtu 9216 | Configure MTU |
(config-if)# description connected to Switch | Configure Interface description |
(config-if)# evpn multi-homed system-mac 0000.1111.aaaa | Configure system MAC for multi homing |
(config)#interface po10000.100 switchport | Creating L2 sub interface of physical interface xe9 |
(config-if)# encapsulation dot1q 100 | Setting Encapsulation to dot1q with VLAN ID 100 |
(config-if)#rewrite pop | Configure rewrite with action pop |
(config-if)#mtu 9216 | Configure MTU as 9216 |
(config-if)# access-if-evpn | Entering Access mode for EVPN MPLS ID configuration |
(config-acc-if-evpn)# map vpn-id 100 | Map VPN-ID 202 |
(config-acc-if-evpn)#exit | Exiting out of access interface mode |
MH-2
Enable EVPN MPLS and IRB:
#configure terminal | Enter configuration mode. |
(config)#hardware-profile filter evpn-mplsmh enable | Configure hardware profile to enable EVPN MPLS multi homing in hardware |
(config)#evpn mpls enable | Enable EVPN MPLS globally |
(config)#evpn mpls irb | Enable EVPN MPLS IRB globally |
(config)#evpn mpls multihoming enable | Enable EVPN MPLS multihoming globally |
Loopback Interface:
(config-if)#interface lo | Enter the Interface mode for the loopback interface |
(config-if)# ip address 3.3.3.3/32 secondary | Configure IP address on loopback interface. |
(config-if)#exit | Exit interface mode |
Configure MAC VRF:
(config-vrf)#mac vrf green | Create MAC VRF green. |
(config-vrf)# rd 3.3.3.3:200 | Configure route distinguisher |
(config-vrf)# route-target both evpn-auto-rt | Configure route target as evpn auto-rt (we can configure as manual RT also) |
(config-vrf)#exit | Exit VRF mode |
Configure IP VRF:
(config)#ip vrf evpn | Configure IP VRF evpn. |
(config-vrf)# rd 20:200 | Configure route distinguisher |
(config-vrf)# route-target both 100:200 | Configure route target |
(config-vrf)# l3vni 20000 | Configure L3 VNID for routing |
(config-vrf)#exit | Exit VRF mode |
Configure Anyc ast Gateway MAC:
(config)#evpn irb-forwarding anycastgateway- mac 0011.2233.4455 | Configure anycast gateway MAC globally |
Configuring IRB interface:
(config)#interface irb100 | Create IRB interface irb100 |
(config-irb-if)# ip vrf forwarding evpn | Map L3 VRF to the IRB interface |
(config-irb-if)# ip address 80.80.1.1/24 | Assign IP address |
(config-irb-if)# evpn irb-if-forwarding anycast-gateway-mac | Map anycast gateway MAC |
(config-irb-if)#exit | Exit interface mode |
Creating EVPN MPLS ID:
(config)#evpn mpls vtep-ip-global 3.3.3.3 | Configure VTEP global IP |
(config)#evpn mpls id 100 | Create EVPN MPLS ID |
(config-evpn-mpls)# host- reachabilityprotocol evpn-bgp green | Map the MAC VRF green |
(config-evpn-mpls)# evpn irb irb100 | Map the IRB interface |
(config-evpn-mpls)#exit | Exit the EVPN MPLS mode |
Global LDP:
(config)#router ldp | Enter the Router LDP mode. |
(config-router)# transport-address ipv4 3.3.3.3 | Configure LDP transport address |
(config-router)# targeted-peer ipv4 5.5.5.5 | Configure LDP target peer address (SH) |
(config-router-targeted-peer)#exit | Exit from LDP target peer mode |
(config-router)#exit | Exit from LDP mode |
Interface Configuration Network Side:
(config-if)#interface xe10 | Enter the configuration mode. |
(config-if)# description connected to P1 | Configure Interface description |
(config-if)# ip address 20.20.20.1/24 | Assign IP address |
(config-if)# mtu 9216 | Configure MTU to the sub-if |
(config-if)# label-switching | Enable label switching |
(config-if)# mpls ldp-igp sync ospf | Enable LDP IGP sync |
(config-if)# enable-ldp ipv4 | Enable LDP IPv4 |
(config-if)#exit | Exit interface mode |
OSPF Configuration:
(config)#router ospf 1 | Enter the Router OSPF mode. |
(config-router)# ospf router-id 3.3.3.3 | Router-ID configurations |
(config-router)# network 3.3.3.3/32 area 0.0.0.0 | Advertise loopback address in OSPF. |
(config-router)# network 20.20.20.0/24 area 0.0.0.0 | Advertise network address in OSPF. |
BGP Configuration:
(config-router)#router bgp 65010 | Enter the Router BGP mode, ASN: 100 |
(config-router)# neighbor 2.2.2.2 remote-as 65010 | Configuring PE3 as iBGP neighbor using it's loopback IP |
(config-router)# neighbor 2.2.2.2 update- source lo | Source of routing updates as loopback |
(config-router)# neighbor 5.5.5.5 remote-as 65010 | Configuring PE3 as iBGP neighbor using it's loopback IP |
(config-router)# neighbor 5.5.5.5 update-source lo | Source of routing updates as loopback |
(config-router)# address-family l2vpn evpn | Entering into address family mode as EVPN |
(config-router-af)# neighbor 2.2.2.2 activate | Enabling EVPN Address family for neighbor |
(config-router-af)# neighbor 5.5.5.5 activate | Enabling EVPN Address family for neighbor |
(config-router-af)# exit-address-family | Exiting of Address family mode |
(config-router)# address-family ipv4 vrf evpn | Entering into VRF address family mode |
(config-router-af)# redistribute connected | Redistribute connected routes to the network |
(config-router-af)# exit-address-family | Exiting of Address family mode |
Access Port Configuration:
(config)#interface xe21 | Enter configuration mode |
(config-if)# mtu 9216 | Configure MTU |
(config-if)# channel-group 10000 mode active | Configure physical interface xe21 as LAG member po10000 |
(config-if)#exit | Exit from interface xe21 |
(config)#interface po10000 | Create LAG interface po10000 |
(config-if)# mtu 9216 | Configure MTU |
(config-if)# description connected to Switch | Configure Interface description |
(config-if)# evpn multi-homed system-mac 0000.1111.aaaa | Configure system MAC for multi homing |
(config)#interface po10000.100 switchport | Creating L2 sub interface of physical interface xe21 |
(config-if)# encapsulation dot1q 100 | Setting Encapsulation to dot1q with VLAN ID 100 |
(config-if)#rewrite pop | Configure rewrite with action pop |
(config-if)#mtu 9216 | Configure MTU as 9216 |
(config-if)# access-if-evpn | Entering Access mode for EVPN MPLS ID configuration |
(config-acc-if-evpn)# map vpn-id 100 | Map VPN-ID 202 |
(config-acc-if-evpn)#exit | Exiting out of access interface mode |
Validation
Note: Remote entries cannot be fetched from through MAC table/ARP cache/ND cache. However they can be fetched from the BGP table.
MH-1:
MH-1#sh evpn mpls
EVPN-MPLS Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
VPN-ID EVI-Name EVI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
_______________________________________________________________________________________________________________________________
100 ---- L2 NW ---- ---- ---- ---- 2.2.2.2 3.3.3.3
100 ---- L2 NW ---- ---- ---- ---- 2.2.2.2 5.5.5.5
100 ---- -- AC po10000.100 00:00:00:11:11:aa:aa:00:00:00 ---- DF ---- ----
200 ---- L2 NW ---- ---- ---- ---- 2.2.2.2 3.3.3.3
200 ---- L2 NW ---- ---- ---- ---- 2.2.2.2 5.5.5.5
200 ---- -- AC po10000.200 00:00:00:11:11:aa:aa:00:00:00 ---- DF ---- ----
10000 ---- L3 NW ---- ---- ---- ---- 2.2.2.2 3.3.3.3
10000 ---- L3 NW ---- ---- ---- ---- 2.2.2.2 5.5.5.5
Total number of entries are 8
MH-1#
MH-1#sh evpn mpls tunnel
EVPN-MPLS Network tunnel Entries
Source Destination Status Up/Down Update evpn-id
===================================================================================
2.2.2.2 3.3.3.3 Installed 01:16:34 01:16:34 200
2.2.2.2 3.3.3.3 Installed 01:16:34 01:16:34 100
2.2.2.2 3.3.3.3 Installed 01:23:48 01:23:48 10000
2.2.2.2 5.5.5.5 Installed 01:14:59 01:14:59 200
2.2.2.2 5.5.5.5 Installed 01:14:59 01:14:59 100
2.2.2.2 5.5.5.5 Installed 01:23:48 01:23:48 10000
Total number of entries are 6
MH-1#
MH-1#sh evpn mpls mac-table
=========================================================================================================================================
EVPN MPLS MAC Entries
=========================================================================================================================================
VNID Interface VlanId In-VlanId Mac-Addr VTEP-Ip/ESI Type Status MAC move AccessPortDesc
_________________________________________________________________________________________________________________________________________
100 irb100 ---- ---- 0011.2233.4455 2.2.2.2 Static Local ------- 0 -------
100 ---- ---- ---- 9819.2c86.3e01 5.5.5.5 Static Remote ------- 0 -------
100 po10000.100 ---- ---- 0010.9400.0001 00:00:00:11:11:aa:aa:00:00:00 Dynamic Local ------- 0 -------
100 ---- ---- ---- 0010.9400.0004 5.5.5.5 Dynamic Remote ------- 0 -------
200 irb200 ---- ---- 0011.2233.4455 2.2.2.2 Static Local ------- 0 -------
200 ---- ---- ---- 9819.2c86.3e01 5.5.5.5 Static Remote ------- 0 -------
200 po10000.200 ---- ---- 0010.9400.0002 00:00:00:11:11:aa:aa:00:00:00 Dynamic Local ------- 0 -------
200 ---- ---- ---- 0010.9400.0005 5.5.5.5 Dynamic Remote ------- 0 -------
Total number of entries are : 8
MH-1#
MH-1#sh evpn mpls arp-cache
MPLS-EVPN ARP-CACHE Information
===============================
ARP Timeout : 300 sec Random-Jitter-Max : 200
EVPN-ID Ip-Addr Mac-Addr Type Age-Out Retries-Left
_____________________________________________________________________________
100 80.80.1.1 0011.2233.4455 Static Local ----
100 80.80.1.2 0010.9400.0001 Dynamic Local 244 2
100 80.80.1.3 9819.2c86.3e01 Static Remote ----
100 80.80.1.4 0010.9400.0004 Dynamic Remote ----
200 90.90.1.1 0011.2233.4455 Static Local ----
200 90.90.1.2 0010.9400.0002 Dynamic Local ----
200 90.90.1.3 9819.2c86.3e01 Static Remote ----
200 90.90.1.4 0010.9400.0005 Dynamic Remote ----
Total number of entries are 8
MH-1#
MH-1#show bgp l2vpn evpn multihoming ethernet-ad-per-es
RD[2.2.2.2:100] VRF[red]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 19 3.3.3.3 MPLS
RD[2.2.2.2:200] VRF[blue]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 19 3.3.3.3 MPLS
RD[2.2.2.2:64512] VRF[evpn-gvrf-1]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 19 2.2.2.2 MPLS
RD[3.3.3.3:64512]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 19 3.3.3.3 MPLS
MH-1#
MH-1#show bgp l2vpn evpn multihoming ethernet-ad-per-evi
RD[2.2.2.2:100] VRF[red]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 100 17 3.3.3.3 MPLS
00:00:00:11:11:aa:aa:00:00:00 100 17 2.2.2.2 MPLS
RD[2.2.2.2:200] VRF[blue]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 200 18 3.3.3.3 MPLS
00:00:00:11:11:aa:aa:00:00:00 200 18 2.2.2.2 MPLS
RD[3.3.3.3:100]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 100 17 3.3.3.3 MPLS
RD[3.3.3.3:200]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 200 18 3.3.3.3 MPLS
MH-1#
MH-1#sh evpn mpls label esi
S - Self
R - Remote
ESI PE-IP-ADDRESS ESI-LABEL
================================================================
00:00:00:11:11:aa:aa:00:00:00 2.2.2.2(S) 19
00:00:00:11:11:aa:aa:00:00:00 3.3.3.3(R) 19
MH-1#
MH-1#sh evpn mpls label alias
S - Self
R - Remote
ESI PE-IP-ADDRESS TENANT ALIAS-LABEL
=============================================================================================
00:00:00:11:11:aa:aa:00:00:00 2.2.2.2(S) 100 17
00:00:00:11:11:aa:aa:00:00:00 2.2.2.2(S) 200 18
00:00:00:11:11:aa:aa:00:00:00 3.3.3.3(R) 100 17
00:00:00:11:11:aa:aa:00:00:00 3.3.3.3(R) 200 18
MH-1#
MH-1#sh bgp l2vpn evpn
BGP table version is 10, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
[EVPN route type]:[ESI]:[VNID]:[relevent route informantion]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
Network Next Hop Metric LocPrf Weight Path Peer Encap
RD[20:200]
*>i [5]:[0]:[0]:[24]:[80.80.1.0]:[0.0.0.0]:[16]
3.3.3.3 0 100 0 ? 3.3.3.3 MPLS
*>i [5]:[0]:[0]:[24]:[90.90.1.0]:[0.0.0.0]:[16]
3.3.3.3 0 100 0 ? 3.3.3.3 MPLS
RD[30:200]
*>i [5]:[0]:[0]:[24]:[80.80.1.0]:[0.0.0.0]:[16]
5.5.5.5 0 100 0 ? 5.5.5.5 MPLS
*>i [5]:[0]:[0]:[24]:[90.90.1.0]:[0.0.0.0]:[16]
5.5.5.5 0 100 0 ? 5.5.5.5 MPLS
RD[2.2.2.2:100] VRF[red]:
* i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[17]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*> 2.2.2.2 0 100 32768 i ---------- MPLS
* i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[4294967295]:[0]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*> [2]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[48,0010:9400:0001]:[0]:[17]
2.2.2.2 0 100 32768 i ---------- MPLS
*> [2]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[48,0010:9400:0001]:[32,80.80.1.2]:[17]
2.2.2.2 0 100 32768 i ---------- MPLS
* i [2]:[0]:[100]:[48,0010:9400:0004]:[0]:[17]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
* i [2]:[0]:[100]:[48,0010:9400:0004]:[32,80.80.1.4]:[17]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
* i [2]:[0]:[100]:[48,0011:2233:4455]:[32,80.80.1.1]:[17]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*> 2.2.2.2 0 100 32768 i ---------- MPLS
* i [2]:[0]:[100]:[48,9819:2c86:3e01]:[32,80.80.1.3]:[17]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
*> [3]:[100]:[32,2.2.2.2]
2.2.2.2 0 100 32768 i ---------- MPLS
* i [3]:[100]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
* i [3]:[100]:[32,5.5.5.5]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
RD[2.2.2.2:200] VRF[blue]:
* i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[200]:[18]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*> 2.2.2.2 0 100 32768 i ---------- MPLS
* i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[4294967295]:[0]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*> [2]:[00:00:00:11:11:aa:aa:00:00:00]:[200]:[48,0010:9400:0002]:[0]:[18]
2.2.2.2 0 100 32768 i ---------- MPLS
*> [2]:[00:00:00:11:11:aa:aa:00:00:00]:[200]:[48,0010:9400:0002]:[32,90.90.1.2]:[18]
2.2.2.2 0 100 32768 i ---------- MPLS
* i [2]:[0]:[200]:[48,0010:9400:0005]:[0]:[18]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
* i [2]:[0]:[200]:[48,0010:9400:0005]:[32,90.90.1.4]:[18]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
* i [2]:[0]:[200]:[48,0011:2233:4455]:[32,90.90.1.1]:[18]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*> 2.2.2.2 0 100 32768 i ---------- MPLS
* i [2]:[0]:[200]:[48,9819:2c86:3e01]:[32,90.90.1.3]:[18]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
*> [3]:[200]:[32,2.2.2.2]
2.2.2.2 0 100 32768 i ---------- MPLS
* i [3]:[200]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
* i [3]:[200]:[32,5.5.5.5]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
RD[2.2.2.2:64512] VRF[evpn-gvrf-1]:
*> [1]:[00:00:00:11:11:aa:aa:00:00:00]:[4294967295]:[0]
2.2.2.2 0 100 32768 i ---------- MPLS
*> [4]:[00:00:00:11:11:aa:aa:00:00:00]:[32,2.2.2.2]
2.2.2.2 0 100 32768 i ---------- MPLS
* i [4]:[00:00:00:11:11:aa:aa:00:00:00]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
RD[3.3.3.3:100]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[17]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*>i [2]:[0]:[100]:[48,0011:2233:4455]:[32,80.80.1.1]:[17]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*>i [3]:[100]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
RD[3.3.3.3:200]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[200]:[18]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*>i [2]:[0]:[200]:[48,0011:2233:4455]:[32,90.90.1.1]:[18]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*>i [3]:[200]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
RD[3.3.3.3:64512]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[4294967295]:[0]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*>i [4]:[00:00:00:11:11:aa:aa:00:00:00]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
RD[5.5.5.5:100]
*>i [2]:[0]:[100]:[48,0010:9400:0004]:[0]:[17]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
*>i [2]:[0]:[100]:[48,0010:9400:0004]:[32,80.80.1.4]:[17]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
*>i [2]:[0]:[100]:[48,9819:2c86:3e01]:[32,80.80.1.3]:[17]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
*>i [3]:[100]:[32,5.5.5.5]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
RD[5.5.5.5:200]
*>i [2]:[0]:[200]:[48,0010:9400:0005]:[0]:[18]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
*>i [2]:[0]:[200]:[48,0010:9400:0005]:[32,90.90.1.4]:[18]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
*>i [2]:[0]:[200]:[48,9819:2c86:3e01]:[32,90.90.1.3]:[18]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
*>i [3]:[200]:[32,5.5.5.5]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
Total number of prefixes 45
MH-1#
MH-1#sh bgp l2vpn evpn prefix-route
RD[20:200]
ESI Eth-Tag Prefix-Length IP-Address GW-IPAddress L3VNID/LABEL Nexthop Encap Router-Mac
0 0 24 80.80.1.0 0.0.0.0 16 3.3.3.3 MPLS e8c5:7ad2:5d98
0 0 24 90.90.1.0 0.0.0.0 16 3.3.3.3 MPLS e8c5:7ad2:5d98
RD[30:200]
ESI Eth-Tag Prefix-Length IP-Address GW-IPAddress L3VNID/LABEL Nexthop Encap Router-Mac
0 0 24 80.80.1.0 0.0.0.0 16 5.5.5.5 MPLS 9819:2c86:3e01
0 0 24 90.90.1.0 0.0.0.0 16 5.5.5.5 MPLS 9819:2c86:3e01
MH-1#
MH-1#sh bgp l2vpn evpn summary
BGP router identifier 2.2.2.2, local AS number 65010
BGP table version is 10
1 BGP AS-PATH entries
0 BGP community entries
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd AD MACIP MCAST ESI PREFIX-ROUTE
3.3.3.3 4 65010 205 203 9 0 0 01:17:25 10 3 2 2 1 2
5.5.5.5 4 65010 187 197 9 0 0 01:15:01 10 0 6 2 0 2
Total number of neighbors 2
Total number of Established sessions 2
MH-1#
MH-1#sh ip bgp vrf evpn_anycast
BGP table version is 1, local router ID is 90.90.1.1
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 80.80.1.0/24 0.0.0.0 0 100 32768 ?
* i 5.5.5.5 0 100 0 ?
* i 3.3.3.3 0 100 0 ?
*> 90.90.1.0/24 0.0.0.0 0 100 32768 ?
* i 5.5.5.5 0 100 0 ?
* i 3.3.3.3 0 100 0 ?
Total number of prefixes 2
MH-1#
MH-1#sh mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN, ! - using backup
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
(m) - FTN mapped over multipath transport, (e) - FTN is ECMP
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 3.3.3.3/32 1 3
2 - Yes LSP_DEFAULT 25600 xe0.1 No 10.10.10.2
L> 4.4.4.4/32 2 6
5 - Yes LSP_DEFAULT 3 xe0.1 No 10.10.10.2
L> 5.5.5.5/32 5 8
7 - Yes LSP_DEFAULT 25603 xe0.1 No 10.10.10.2
L> 20.20.20.0/24 3 6
5 - Yes LSP_DEFAULT 3 xe0.1 No 10.10.10.2
L> 30.30.30.0/24 4 6
5 - Yes LSP_DEFAULT 3 xe0.1 No 10.10.10.2
MH-1#
MH-1#sh ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
5.5.5.5 xe0.1 Passive OPERATIONAL 30 01:14:50
4.4.4.4 xe0.1 Passive OPERATIONAL 30 01:16:35
MH-1#
MH-1#sh ip ospf neighbor
Total number of full neighbors: 1
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
4.4.4.4 1 Full/DR 00:00:39 10.10.10.2 xe0.1 0
MH-1#
MH-1#sh nvo vxlan l3vni-map
L3VNI L2VNI IRB-interface
===================================
10000 100 irb100
10000 200 irb200
MH-1#
MH-2:
MH-2#sh evpn mpls
EVPN-MPLS Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
VPN-ID EVI-Name EVI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
_______________________________________________________________________________________________________________________________
100 ---- L2 NW ---- ---- ---- ---- 3.3.3.3 5.5.5.5
100 ---- L2 NW ---- ---- ---- ---- 3.3.3.3 2.2.2.2
100 ---- -- AC po10000.100 00:00:00:11:11:aa:aa:00:00:00 ---- NON-DF ---- ----
200 ---- L2 NW ---- ---- ---- ---- 3.3.3.3 5.5.5.5
200 ---- L2 NW ---- ---- ---- ---- 3.3.3.3 2.2.2.2
200 ---- -- AC po10000.200 00:00:00:11:11:aa:aa:00:00:00 ---- NON-DF ---- ----
10000 ---- L3 NW ---- ---- ---- ---- 3.3.3.3 5.5.5.5
10000 ---- L3 NW ---- ---- ---- ---- 3.3.3.3 2.2.2.2
Total number of entries are 8
MH-2#
MH-2#sh evpn mpls tunnel
EVPN-MPLS Network tunnel Entries
Source Destination Status Up/Down Update evpn-id
===================================================================================
3.3.3.3 5.5.5.5 Installed 01:15:41 01:15:41 200
3.3.3.3 5.5.5.5 Installed 01:15:41 01:15:41 100
3.3.3.3 5.5.5.5 Installed 01:24:08 01:24:08 10000
3.3.3.3 2.2.2.2 Installed 01:17:15 01:17:15 200
3.3.3.3 2.2.2.2 Installed 01:17:15 01:17:15 100
3.3.3.3 2.2.2.2 Installed 01:24:08 01:24:08 10000
Total number of entries are 6
MH-2#
MH-2#sh evpn mpls mac-table
=========================================================================================================================================
EVPN MPLS MAC Entries
=========================================================================================================================================
VNID Interface VlanId In-VlanId Mac-Addr VTEP-Ip/ESI Type Status MAC move AccessPortDesc
_________________________________________________________________________________________________________________________________________
100 irb100 ---- ---- 0011.2233.4455 3.3.3.3 Static Local ------- 0 -------
100 ---- ---- ---- 9819.2c86.3e01 5.5.5.5 Static Remote ------- 0 -------
100 ---- ---- ---- 0010.9400.0001 00:00:00:11:11:aa:aa:00:00:00 Dynamic Remote ------- 0 -------
100 ---- ---- ---- 0010.9400.0004 5.5.5.5 Dynamic Remote ------- 0 -------
200 irb200 ---- ---- 0011.2233.4455 3.3.3.3 Static Local ------- 0 -------
200 ---- ---- ---- 9819.2c86.3e01 5.5.5.5 Static Remote ------- 0 -------
200 ---- ---- ---- 0010.9400.0002 00:00:00:11:11:aa:aa:00:00:00 Dynamic Remote ------- 0 -------
200 ---- ---- ---- 0010.9400.0005 5.5.5.5 Dynamic Remote ------- 0 -------
Total number of entries are : 8
MH-2#
MH-2#sh evpn mpls arp-cache
MPLS-EVPN ARP-CACHE Information
===============================
ARP Timeout : 300 sec Random-Jitter-Max : 200
EVPN-ID Ip-Addr Mac-Addr Type Age-Out Retries-Left
_____________________________________________________________________________
100 80.80.1.1 0011.2233.4455 Static Local ----
100 80.80.1.2 0010.9400.0001 Dynamic Remote ----
100 80.80.1.3 9819.2c86.3e01 Static Remote ----
100 80.80.1.4 0010.9400.0004 Dynamic Remote ----
200 90.90.1.1 0011.2233.4455 Static Local ----
200 90.90.1.2 0010.9400.0002 Dynamic Remote ----
200 90.90.1.3 9819.2c86.3e01 Static Remote ----
200 90.90.1.4 0010.9400.0005 Dynamic Remote ----
Total number of entries are 8
MH-2#
MH-2#show bgp l2vpn evpn multihoming ethernet-ad-per-es
RD[2.2.2.2:64512]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 19 2.2.2.2 MPLS
RD[3.3.3.3:100] VRF[red]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 19 2.2.2.2 MPLS
RD[3.3.3.3:200] VRF[blue]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 19 2.2.2.2 MPLS
RD[3.3.3.3:64512] VRF[evpn-gvrf-1]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 19 3.3.3.3 MPLS
MH-2#
MH-2#show bgp l2vpn evpn multihoming ethernet-ad-per-evi
RD[2.2.2.2:100]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 100 17 2.2.2.2 MPLS
RD[2.2.2.2:200]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 200 18 2.2.2.2 MPLS
RD[3.3.3.3:100] VRF[red]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 100 17 2.2.2.2 MPLS
00:00:00:11:11:aa:aa:00:00:00 100 17 3.3.3.3 MPLS
RD[3.3.3.3:200] VRF[blue]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 200 18 2.2.2.2 MPLS
00:00:00:11:11:aa:aa:00:00:00 200 18 3.3.3.3 MPLS
MH-2#
MH-2#sh evpn mpls label esi
S - Self
R - Remote
ESI PE-IP-ADDRESS ESI-LABEL
================================================================
00:00:00:11:11:aa:aa:00:00:00 2.2.2.2(R) 19
00:00:00:11:11:aa:aa:00:00:00 3.3.3.3(S) 19
MH-2#
MH-2#sh evpn mpls label alias
S - Self
R - Remote
ESI PE-IP-ADDRESS TENANT ALIAS-LABEL
=============================================================================================
00:00:00:11:11:aa:aa:00:00:00 2.2.2.2(R) 100 17
00:00:00:11:11:aa:aa:00:00:00 2.2.2.2(R) 200 18
00:00:00:11:11:aa:aa:00:00:00 3.3.3.3(S) 100 17
00:00:00:11:11:aa:aa:00:00:00 3.3.3.3(S) 200 18
MH-2#
MH-2#sh bgp l2vpn evpn
BGP table version is 16, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
[EVPN route type]:[ESI]:[VNID]:[relevent route informantion]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
Network Next Hop Metric LocPrf Weight Path Peer Encap
RD[10:200]
*>i [5]:[0]:[0]:[24]:[80.80.1.0]:[0.0.0.0]:[16]
2.2.2.2 0 100 0 ? 2.2.2.2 MPLS
*>i [5]:[0]:[0]:[24]:[90.90.1.0]:[0.0.0.0]:[16]
2.2.2.2 0 100 0 ? 2.2.2.2 MPLS
RD[30:200]
*>i [5]:[0]:[0]:[24]:[80.80.1.0]:[0.0.0.0]:[16]
5.5.5.5 0 100 0 ? 5.5.5.5 MPLS
*>i [5]:[0]:[0]:[24]:[90.90.1.0]:[0.0.0.0]:[16]
5.5.5.5 0 100 0 ? 5.5.5.5 MPLS
RD[2.2.2.2:100]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[17]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*>i [2]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[48,0010:9400:0001]:[0]:[17]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*>i [2]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[48,0010:9400:0001]:[32,80.80.1.2]:[17]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*>i [2]:[0]:[100]:[48,0011:2233:4455]:[32,80.80.1.1]:[17]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*>i [3]:[100]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
RD[2.2.2.2:200]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[200]:[18]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*>i [2]:[00:00:00:11:11:aa:aa:00:00:00]:[200]:[48,0010:9400:0002]:[0]:[18]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*>i [2]:[00:00:00:11:11:aa:aa:00:00:00]:[200]:[48,0010:9400:0002]:[32,90.90.1.2]:[18]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*>i [2]:[0]:[200]:[48,0011:2233:4455]:[32,90.90.1.1]:[18]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*>i [3]:[200]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
RD[2.2.2.2:64512]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[4294967295]:[0]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*>i [4]:[00:00:00:11:11:aa:aa:00:00:00]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
RD[3.3.3.3:100] VRF[red]:
* i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[17]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*> 3.3.3.3 0 100 32768 i ---------- MPLS
* i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[4294967295]:[0]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
* i [2]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[48,0010:9400:0001]:[0]:[17]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
* i [2]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[48,0010:9400:0001]:[32,80.80.1.2]:[17]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
* i [2]:[0]:[100]:[48,0010:9400:0004]:[0]:[17]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
* i [2]:[0]:[100]:[48,0010:9400:0004]:[32,80.80.1.4]:[17]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
* i [2]:[0]:[100]:[48,0011:2233:4455]:[32,80.80.1.1]:[17]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*> 3.3.3.3 0 100 32768 i ---------- MPLS
* i [2]:[0]:[100]:[48,9819:2c86:3e01]:[32,80.80.1.3]:[17]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
* i [3]:[100]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*> [3]:[100]:[32,3.3.3.3]
3.3.3.3 0 100 32768 i ---------- MPLS
* i [3]:[100]:[32,5.5.5.5]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
RD[3.3.3.3:200] VRF[blue]:
* i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[200]:[18]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*> 3.3.3.3 0 100 32768 i ---------- MPLS
* i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[4294967295]:[0]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
* i [2]:[00:00:00:11:11:aa:aa:00:00:00]:[200]:[48,0010:9400:0002]:[0]:[18]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*>i [2]:[00:00:00:11:11:aa:aa:00:00:00]:[200]:[48,0010:9400:0002]:[32,90.90.1.2]:[18]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
* i [2]:[0]:[200]:[48,0010:9400:0005]:[0]:[18]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
* i [2]:[0]:[200]:[48,0010:9400:0005]:[32,90.90.1.4]:[18]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
* i [2]:[0]:[200]:[48,0011:2233:4455]:[32,90.90.1.1]:[18]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*> 3.3.3.3 0 100 32768 i ---------- MPLS
* i [2]:[0]:[200]:[48,9819:2c86:3e01]:[32,90.90.1.3]:[18]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
* i [3]:[200]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*> [3]:[200]:[32,3.3.3.3]
3.3.3.3 0 100 32768 i ---------- MPLS
* i [3]:[200]:[32,5.5.5.5]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
RD[3.3.3.3:64512] VRF[evpn-gvrf-1]:
*> [1]:[00:00:00:11:11:aa:aa:00:00:00]:[4294967295]:[0]
3.3.3.3 0 100 32768 i ---------- MPLS
* i [4]:[00:00:00:11:11:aa:aa:00:00:00]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*> [4]:[00:00:00:11:11:aa:aa:00:00:00]:[32,3.3.3.3]
3.3.3.3 0 100 32768 i ---------- MPLS
RD[5.5.5.5:100]
*>i [2]:[0]:[100]:[48,0010:9400:0004]:[0]:[17]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
*>i [2]:[0]:[100]:[48,0010:9400:0004]:[32,80.80.1.4]:[17]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
*>i [2]:[0]:[100]:[48,9819:2c86:3e01]:[32,80.80.1.3]:[17]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
*>i [3]:[100]:[32,5.5.5.5]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
RD[5.5.5.5:200]
*>i [2]:[0]:[200]:[48,0010:9400:0005]:[0]:[18]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
*>i [2]:[0]:[200]:[48,0010:9400:0005]:[32,90.90.1.4]:[18]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
*>i [2]:[0]:[200]:[48,9819:2c86:3e01]:[32,90.90.1.3]:[18]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
*>i [3]:[200]:[32,5.5.5.5]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
Total number of prefixes 49
MH-2#
MH-2#sh bgp l2vpn evpn prefix-route
RD[10:200]
ESI Eth-Tag Prefix-Length IP-Address GW-IPAddress L3VNID/LABEL Nexthop Encap Router-Mac
0 0 24 80.80.1.0 0.0.0.0 16 2.2.2.2 MPLS e8c5:7a88:1738
0 0 24 90.90.1.0 0.0.0.0 16 2.2.2.2 MPLS e8c5:7a88:1738
RD[30:200]
ESI Eth-Tag Prefix-Length IP-Address GW-IPAddress L3VNID/LABEL Nexthop Encap Router-Mac
0 0 24 80.80.1.0 0.0.0.0 16 5.5.5.5 MPLS 9819:2c86:3e01
0 0 24 90.90.1.0 0.0.0.0 16 5.5.5.5 MPLS 9819:2c86:3e01
MH-2#
MH-2#sh bgp l2vpn evpn summary
BGP router identifier 3.3.3.3, local AS number 65010
BGP table version is 16
1 BGP AS-PATH entries
0 BGP community entries
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd AD MACIP MCAST ESI PREFIX-ROUTE
2.2.2.2 4 65010 203 207 16 0 0 01:18:08 14 3 6 2 1 2
5.5.5.5 4 65010 190 202 16 0 0 01:15:43 10 0 6 2 0 2
Total number of neighbors 2
Total number of Established sessions 2
MH-2#
MH-2#sh ip bgp vrf evpn_anycast
BGP table version is 1, local router ID is 90.90.1.1
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 80.80.1.0/24 0.0.0.0 0 100 32768 ?
* i 5.5.5.5 0 100 0 ?
* i 2.2.2.2 0 100 0 ?
*> 90.90.1.0/24 0.0.0.0 0 100 32768 ?
* i 5.5.5.5 0 100 0 ?
* i 2.2.2.2 0 100 0 ?
Total number of prefixes 2
MH-2#
MH-2#sh mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN, ! - using backup
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
(m) - FTN mapped over multipath transport, (e) - FTN is ECMP
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 2.2.2.2/32 1 3
2 - Yes LSP_DEFAULT 25601 xe10 No 20.20.20.2
L> 4.4.4.4/32 2 6
5 - Yes LSP_DEFAULT 3 xe10 No 20.20.20.2
L> 5.5.5.5/32 5 8
7 - Yes LSP_DEFAULT 25602 xe10 No 20.20.20.2
L> 10.10.10.0/24 3 6
5 - Yes LSP_DEFAULT 3 xe10 No 20.20.20.2
L> 30.30.30.0/24 4 6
5 - Yes LSP_DEFAULT 3 xe10 No 20.20.20.2
MH-2#
MH-2#sh ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
5.5.5.5 xe10 Passive OPERATIONAL 30 01:15:31
4.4.4.4 xe10 Passive OPERATIONAL 30 01:17:16
MH-2#
MH-2#sh ip ospf neighbor
Total number of full neighbors: 1
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
4.4.4.4 1 Full/DR 00:00:33 20.20.20.2 xe10 0
MH-2#
MH-2#sh nvo vxlan l3vni-map
L3VNI L2VNI IRB-interface
===================================
10000 100 irb100
10000 200 irb200
MH-2#
SH:
SH#sh evpn mpls
EVPN-MPLS Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
VPN-ID EVI-Name EVI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
_______________________________________________________________________________________________________________________________
100 ---- L2 NW ---- ---- ---- ---- 5.5.5.5 2.2.2.2
100 ---- L2 NW ---- ---- ---- ---- 5.5.5.5 3.3.3.3
100 ---- -- AC sa9000.100 --- Single Homed Port --- ---- ---- ---- ----
200 ---- L2 NW ---- ---- ---- ---- 5.5.5.5 2.2.2.2
200 ---- L2 NW ---- ---- ---- ---- 5.5.5.5 3.3.3.3
200 ---- -- AC sa9000.200 --- Single Homed Port --- ---- ---- ---- ----
10000 ---- L3 NW ---- ---- ---- ---- 5.5.5.5 2.2.2.2
10000 ---- L3 NW ---- ---- ---- ---- 5.5.5.5 3.3.3.3
Total number of entries are 8
SH#
SH#sh evpn mpls tunnel
EVPN-MPLS Network tunnel Entries
Source Destination Status Up/Down Update evpn-id
===================================================================================
5.5.5.5 2.2.2.2 Installed 01:15:49 01:15:49 200
5.5.5.5 2.2.2.2 Installed 01:15:49 01:15:49 100
5.5.5.5 2.2.2.2 Installed 01:25:33 01:25:33 10000
5.5.5.5 3.3.3.3 Installed 01:15:49 01:15:49 200
5.5.5.5 3.3.3.3 Installed 01:15:49 01:15:49 100
5.5.5.5 3.3.3.3 Installed 01:25:33 01:25:33 10000
Total number of entries are 6
SH#
SH#sh evpn mpls mac-table
=========================================================================================================================================
EVPN MPLS MAC Entries
=========================================================================================================================================
VNID Interface VlanId In-VlanId Mac-Addr VTEP-Ip/ESI Type Status MAC move AccessPortDesc
_________________________________________________________________________________________________________________________________________
100 ---- ---- ---- 0011.2233.4455 2.2.2.2 Static Remote ------- 0 -------
100 irb100 ---- ---- 9819.2c86.3e01 5.5.5.5 Static Local ------- 0 -------
100 ---- ---- ---- 0010.9400.0001 00:00:00:11:11:aa:aa:00:00:00 Dynamic Remote ------- 0 -------
100 sa9000.100 ---- ---- 0010.9400.0004 5.5.5.5 Dynamic Local ------- 0 -------
200 ---- ---- ---- 0011.2233.4455 2.2.2.2 Static Remote ------- 0 -------
200 irb200 ---- ---- 9819.2c86.3e01 5.5.5.5 Static Local ------- 0 -------
200 ---- ---- ---- 0010.9400.0002 00:00:00:11:11:aa:aa:00:00:00 Dynamic Remote ------- 0 -------
200 sa9000.200 ---- ---- 0010.9400.0005 5.5.5.5 Dynamic Local ------- 0 -------
Total number of entries are : 8
SH#
SH#sh evpn mpls arp-cache
MPLS-EVPN ARP-CACHE Information
===============================
EVPN-ID Ip-Addr Mac-Addr Type Age-Out Retries-Left
_____________________________________________________________________________
100 80.80.1.1 0011.2233.4455 Static Remote ----
100 80.80.1.2 0010.9400.0001 Dynamic Remote ----
100 80.80.1.3 9819.2c86.3e01 Static Local ----
100 80.80.1.4 0010.9400.0004 Dynamic Local ----
200 90.90.1.1 0011.2233.4455 Static Remote ----
200 90.90.1.2 0010.9400.0002 Dynamic Remote ----
200 90.90.1.3 9819.2c86.3e01 Static Local ----
200 90.90.1.4 0010.9400.0005 Dynamic Local ----
Total number of entries are 8
SH#
SH#show bgp l2vpn evpn multihoming ethernet-ad-per-es
RD[2.2.2.2:64512]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 19 2.2.2.2 MPLS
RD[3.3.3.3:64512]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 19 3.3.3.3 MPLS
RD[5.5.5.5:100] VRF[red]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 19 3.3.3.3 MPLS
00:00:00:11:11:aa:aa:00:00:00 4294967295 19 2.2.2.2 MPLS
RD[5.5.5.5:200] VRF[blue]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 19 3.3.3.3 MPLS
00:00:00:11:11:aa:aa:00:00:00 4294967295 19 2.2.2.2 MPLS
SH#
SH#show bgp l2vpn evpn multihoming ethernet-ad-per-evi
RD[2.2.2.2:100]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 100 17 2.2.2.2 MPLS
RD[2.2.2.2:200]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 200 18 2.2.2.2 MPLS
RD[3.3.3.3:100]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 100 17 3.3.3.3 MPLS
RD[3.3.3.3:200]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 200 18 3.3.3.3 MPLS
RD[5.5.5.5:100] VRF[red]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 100 17 3.3.3.3 MPLS
00:00:00:11:11:aa:aa:00:00:00 100 17 2.2.2.2 MPLS
RD[5.5.5.5:200] VRF[blue]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 200 18 3.3.3.3 MPLS
00:00:00:11:11:aa:aa:00:00:00 200 18 2.2.2.2 MPLS
SH#
SH#sh evpn mpls label esi
S - Self
R - Remote
ESI PE-IP-ADDRESS ESI-LABEL
================================================================
00:00:00:11:11:aa:aa:00:00:00 2.2.2.2(R) 19
00:00:00:11:11:aa:aa:00:00:00 3.3.3.3(R) 19
SH#
SH#sh evpn mpls label alias
S - Self
R - Remote
ESI PE-IP-ADDRESS TENANT ALIAS-LABEL
=============================================================================================
00:00:00:11:11:aa:aa:00:00:00 2.2.2.2(R) 100 17
00:00:00:11:11:aa:aa:00:00:00 2.2.2.2(R) 200 18
00:00:00:11:11:aa:aa:00:00:00 3.3.3.3(R) 100 17
00:00:00:11:11:aa:aa:00:00:00 3.3.3.3(R) 200 18
SH#
SH#sh bgp l2vpn evpn
BGP table version is 6, local router ID is 5.5.5.5
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
[EVPN route type]:[ESI]:[VNID]:[relevent route informantion]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
Network Next Hop Metric LocPrf Weight Path Peer Encap
RD[10:200]
*>i [5]:[0]:[0]:[24]:[80.80.1.0]:[0.0.0.0]:[16]
2.2.2.2 0 100 0 ? 2.2.2.2 MPLS
*>i [5]:[0]:[0]:[24]:[90.90.1.0]:[0.0.0.0]:[16]
2.2.2.2 0 100 0 ? 2.2.2.2 MPLS
RD[20:200]
*>i [5]:[0]:[0]:[24]:[80.80.1.0]:[0.0.0.0]:[16]
3.3.3.3 0 100 0 ? 3.3.3.3 MPLS
*>i [5]:[0]:[0]:[24]:[90.90.1.0]:[0.0.0.0]:[16]
3.3.3.3 0 100 0 ? 3.3.3.3 MPLS
RD[2.2.2.2:100]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[17]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*>i [2]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[48,0010:9400:0001]:[0]:[17]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*>i [2]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[48,0010:9400:0001]:[32,80.80.1.2]:[17]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*>i [2]:[0]:[100]:[48,0011:2233:4455]:[32,80.80.1.1]:[17]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*>i [3]:[100]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
RD[2.2.2.2:200]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[200]:[18]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*>i [2]:[00:00:00:11:11:aa:aa:00:00:00]:[200]:[48,0010:9400:0002]:[0]:[18]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*>i [2]:[00:00:00:11:11:aa:aa:00:00:00]:[200]:[48,0010:9400:0002]:[32,90.90.1.2]:[18]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*>i [2]:[0]:[200]:[48,0011:2233:4455]:[32,90.90.1.1]:[18]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*>i [3]:[200]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
RD[2.2.2.2:64512]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[4294967295]:[0]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*>i [4]:[00:00:00:11:11:aa:aa:00:00:00]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
RD[3.3.3.3:100]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[17]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*>i [2]:[0]:[100]:[48,0011:2233:4455]:[32,80.80.1.1]:[17]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*>i [3]:[100]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
RD[3.3.3.3:200]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[200]:[18]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*>i [2]:[0]:[200]:[48,0011:2233:4455]:[32,90.90.1.1]:[18]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*>i [3]:[200]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
RD[3.3.3.3:64512]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[4294967295]:[0]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*>i [4]:[00:00:00:11:11:aa:aa:00:00:00]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
RD[5.5.5.5:100] VRF[red]:
* i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[17]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
* i 2.2.2.2 0 100 0 i 2.2.2.2 MPLS
* i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[4294967295]:[0]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
* i 2.2.2.2 0 100 0 i 2.2.2.2 MPLS
* i [2]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[48,0010:9400:0001]:[0]:[17]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
* i [2]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[48,0010:9400:0001]:[32,80.80.1.2]:[17]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*> [2]:[0]:[100]:[48,0010:9400:0004]:[0]:[17]
5.5.5.5 0 100 32768 i ---------- MPLS
*> [2]:[0]:[100]:[48,0010:9400:0004]:[32,80.80.1.4]:[17]
5.5.5.5 0 100 32768 i ---------- MPLS
* i [2]:[0]:[100]:[48,0011:2233:4455]:[32,80.80.1.1]:[17]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
* i 2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*> [2]:[0]:[100]:[48,9819:2c86:3e01]:[32,80.80.1.3]:[17]
5.5.5.5 0 100 32768 i ---------- MPLS
* i [3]:[100]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
* i [3]:[100]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*> [3]:[100]:[32,5.5.5.5]
5.5.5.5 0 100 32768 i ---------- MPLS
RD[5.5.5.5:200] VRF[blue]:
* i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[200]:[18]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
* i 2.2.2.2 0 100 0 i 2.2.2.2 MPLS
* i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[4294967295]:[0]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
* i 2.2.2.2 0 100 0 i 2.2.2.2 MPLS
* i [2]:[00:00:00:11:11:aa:aa:00:00:00]:[200]:[48,0010:9400:0002]:[0]:[18]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
* i [2]:[00:00:00:11:11:aa:aa:00:00:00]:[200]:[48,0010:9400:0002]:[32,90.90.1.2]:[18]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*> [2]:[0]:[200]:[48,0010:9400:0005]:[0]:[18]
5.5.5.5 0 100 32768 i ---------- MPLS
*> [2]:[0]:[200]:[48,0010:9400:0005]:[32,90.90.1.4]:[18]
5.5.5.5 0 100 32768 i ---------- MPLS
* i [2]:[0]:[200]:[48,0011:2233:4455]:[32,90.90.1.1]:[18]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
* i 2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*> [2]:[0]:[200]:[48,9819:2c86:3e01]:[32,90.90.1.3]:[18]
5.5.5.5 0 100 32768 i ---------- MPLS
* i [3]:[200]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
* i [3]:[200]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*> [3]:[200]:[32,5.5.5.5]
5.5.5.5 0 100 32768 i ---------- MPLS
Total number of prefixes 46
SH#
SH#sh bgp l2vpn evpn prefix-route
RD[10:200]
ESI Eth-Tag Prefix-Length IP-Address GW-IPAddress L3VNID/LABEL Nexthop Encap Router-Mac
0 0 24 80.80.1.0 0.0.0.0 16 2.2.2.2 MPLS e8c5:7a88:1738
0 0 24 90.90.1.0 0.0.0.0 16 2.2.2.2 MPLS e8c5:7a88:1738
RD[20:200]
ESI Eth-Tag Prefix-Length IP-Address GW-IPAddress L3VNID/LABEL Nexthop Encap Router-Mac
0 0 24 80.80.1.0 0.0.0.0 16 3.3.3.3 MPLS e8c5:7ad2:5d98
0 0 24 90.90.1.0 0.0.0.0 16 3.3.3.3 MPLS e8c5:7ad2:5d98
SH#
SH#sh bgp l2vpn evpn summary
BGP router identifier 5.5.5.5, local AS number 65010
BGP table version is 6
1 BGP AS-PATH entries
0 BGP community entries
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd AD MACIP MCAST ESI PREFIX-ROUTE
2.2.2.2 4 65010 198 189 5 0 0 01:15:56 14 3 6 2 1 2
3.3.3.3 4 65010 203 191 5 0 0 01:15:55 10 3 2 2 1 2
Total number of neighbors 2
Total number of Established sessions 2
SH#
SH#sh ip bgp vrf evpn_anycast
BGP table version is 1, local router ID is 90.90.1.3
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 80.80.1.0/24 0.0.0.0 0 100 32768 ?
* i 3.3.3.3 0 100 0 ?
* i 2.2.2.2 0 100 0 ?
*> 90.90.1.0/24 0.0.0.0 0 100 32768 ?
* i 3.3.3.3 0 100 0 ?
* i 2.2.2.2 0 100 0 ?
Total number of prefixes 2
SH#
SH#sh mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN, ! - using backup
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
(m) - FTN mapped over multipath transport, (e) - FTN is ECMP
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 2.2.2.2/32 1 3
2 - Yes LSP_DEFAULT 25604 xe6 No 30.30.30.2
L> 3.3.3.3/32 2 6
5 - Yes LSP_DEFAULT 25605 xe6 No 30.30.30.2
L> 4.4.4.4/32 3 9
8 - Yes LSP_DEFAULT 3 xe6 No 30.30.30.2
L> 10.10.10.0/24 4 9
8 - Yes LSP_DEFAULT 3 xe6 No 30.30.30.2
L> 20.20.20.0/24 5 9
8 - Yes LSP_DEFAULT 3 xe6 No 30.30.30.2
SH#
SH#sh ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
2.2.2.2 xe6 Active OPERATIONAL 30 01:15:46
3.3.3.3 xe6 Active OPERATIONAL 30 01:15:44
4.4.4.4 xe6 Active OPERATIONAL 30 01:15:51
SH#
SH#sh ip ospf neighbor
Total number of full neighbors: 1
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
4.4.4.4 1 Full/DR 00:00:33 30.30.30.2 xe6 0
SH#
SH#sh nvo vxlan l3vni-map
L3VNI L2VNI IRB-interface
===================================
10000 100 irb100
10000 200 irb200
SH#
P1:
P1#sh ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
3.3.3.3 xe1 Active OPERATIONAL 30 01:21:33
2.2.2.2 xe4.1 Active OPERATIONAL 30 01:21:35
5.5.5.5 xe6 Passive OPERATIONAL 30 01:19:55
P1#
P1#sh ip ospf neighbor
Total number of full neighbors: 3
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
2.2.2.2 1 Full/Backup 00:00:37 10.10.10.1 xe4.1 0
3.3.3.3 1 Full/Backup 00:00:35 20.20.20.1 xe1 0
5.5.5.5 1 Full/Backup 00:00:35 30.30.30.1 xe6 0
P1#
P1#sh mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN, ! - using backup
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
(m) - FTN mapped over multipath transport, (e) - FTN is ECMP
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 2.2.2.2/32 1 2
1 - Yes LSP_DEFAULT 3 xe4.1 No 10.10.10.1
L> 3.3.3.3/32 2 4
3 - Yes LSP_DEFAULT 3 xe1 No 20.20.20.1
L> 5.5.5.5/32 3 8
7 - Yes LSP_DEFAULT 3 xe6 No 30.30.30.1
P1#