EVPN MPLS IRB Asymmetric Centralized mode
Topology
Figure 26-5 depicts the EVPN MPLS IRB Asymmetric centralized mode.
Figure 26-5: EVPN MPLS IRB Centralized Mode
Configurations:
SH-2:
Enable EVPN MPLS and IRB:
#configure terminal | Enter configuration mode. |
(config)#evpn mpls enable | Enable EVPN MPLS globally |
(config)#evpn mpls irb | Enable EVPN MPLS IRB globally |
Loopback Interface:
(config-if)#interface lo | Enter the Interface mode for the loopback interface. |
(config-if)# ip address 6.6.6.6/32 secondary | Configure IP address on loopback interface. |
(config-if)#exit | Exit interface mode |
Configure MAC VRF:
(config)#mac vrf red | Create MAC VRF red. |
(config-vrf)# rd 6.6.6.6:100 | Configure route distinguisher |
(config-vrf)# route-target both evpn-auto-rt | Configure route target as evpn auto route target (we can configure as manual RT also) |
(config-vrf)#exit | Exit VRF mode |
(config)#mac vrf blue | Create MAC VRF blue. |
(config-vrf)# rd 6.6.6.6:200 | Configure route distinguisher |
(config-vrf)# route-target both evpn-auto-rt | Configure route target as evpn auto route target (we can configure as manual RT also) |
(config-vrf)#exit | Exit VRF mode |
Configure IP VRF:
(config)#ip vrf evpn_anycast | Configure IP VRF evpn. |
(config-vrf)# rd 30:200 | Configure route distinguisher |
(config-vrf)# route-target both 100:200 | Configure route target |
(config-vrf)# l3vni 10000 | Configure L3 VNID for routing |
(config-vrf)#exit | Exit VRF mode |
Configuring IRB interface:
(config)#evpn irb-forwarding anycast-gateway- mac 0077.8899.5566 | Configure anycast gateway MAC globally |
(config)#interface irb100 | Create IRB interface irb100 |
(config-irb-if)# ip vrf forwarding evpn_anycast | Map L3 VRF to the IRB interface |
(config-irb-if)# evpn irb-if-forwarding anycast-gateway-mac | Map anycast gateway MAC |
(config-irb-if)# ip address 80.80.1.3/24 anycast | Assign IP address |
(config-irb-if)#exit | Exit interface mode |
(config)#interface irb200 | Create IRB interface irb100 |
(config-irb-if)# ip vrf forwarding evpn_anycast | Map L3 VRF to the IRB interface |
(config-irb-if)# evpn irb-if-forwarding anycast-gateway-mac | Map anycast gateway MAC |
(config-irb-if)# ip address 90.90.1.3/24 anycast | Assign IP address |
(config-irb-if)#exit | Exit interface mode |
Creating EVPN MPLS ID:
(config)#evpn mpls vtep-ip-global 6.6.6.6 | Configure VTEP global IP |
(config)#evpn mpls id 100 | Create EVPN MPLS ID |
(config-evpn-mpls)# host-reachability- protocol evpn-bgp red | Map the MAC VRF red |
(config-evpn-mpls)# evpn irb irb100 | Map the IRB interface |
(config-evpn-mpls)#exit | Exit the EVPN MPLS mode |
(config)#evpn mpls id 200 | Create EVPN MPLS ID |
(config-evpn-mpls)# host-reachability- protocol evpn-bgp blue | Map the MAC VRF blue |
(config-evpn-mpls)# evpn irb irb200 | Map the IRB interface |
(config-evpn-mpls)#exit | Exit the EVPN MPLS mode |
Global LDP:
(config)#router ldp | Enter the Router LDP mode. |
(config-router)#router-id 6.6.6.6 | Enter LDP router-id |
(config-router)# transport-address ipv4 6.6.6.6 | Configure LDP transport address |
(config-router)# targeted-peer ipv4 2.2.2.2 | Configure LDP target peer address (MH-1) |
(config-router-targeted-peer)#exit | Exit from LDP target peer mode |
(config-router)# targeted-peer ipv4 3.3.3.3 | Configure LDP target peer address (MH-2) |
(config-router-targeted-peer)#exit | Exit from LDP target peer mode |
(config-router)# targeted-peer ipv4 5.5.5.5 | Configure LDP target peer address (SH-1) |
(config-router-targeted-peer)#exit | Exit from LDP target peer mode |
(config-router)#exit | Exit from LDP mode |
Interface Configuration Network Side:
(config-if)#interface xe14 | Enter interface mode |
(config-if)# description connected to P1 | Configure interface description |
(config-if)# ip address 40.40.40.1/24 | Assign IP address |
(config-if)# mtu 9216 | Configure MTU |
(config-if)# label-switching | Enable label switching |
(config-if)# mpls ldp-igp sync ospf | Enable LDP IGP sync |
(config-if)# enable-ldp ipv4 | Enable LDP IPv4 |
(config-if)#exit | Exit interface mode |
OSPF Configuration:
(config)#router ospf 1 | Enter the Router OSPF mode. |
(config-router)#ospf router-id 6.6.6.6 | Configure OSPF router id |
(config-router)# network 6.6.6.6/32 area 0.0.0.0 | Advertise loopback address in OSPF. |
(config-router)# network 40.40.40.0/24 area 0.0.0.0 | Advertise network address in OSPF. |
(config-router)#exit | Exit OSPF mode |
BGP Configuration:
(config)#router bgp 65010 | Enter the Router BGP mode, ASN: 65010 |
(config-router)# neighbor 2.2.2.2 remote-as 65010 | Configuring MH-1 as I-BGP neighbor using it's loopback IP |
(config-router)# neighbor 2.2.2.2 update- source lo | Source of routing updates as loopback |
(config-router)# neighbor 3.3.3.3 remote-as 65010 | Configuring MH-2 as I-BGP neighbor using it's loopback IP |
(config-router)# neighbor 3.3.3.3 update- source lo | Source of routing updates as loopback |
(config-router)# neighbor 5.5.5.5 remote-as 65010 | Configuring MH-1 as I-BGP neighbor using it's loopback IP |
(config-router)# neighbor 5.5.5.5 update- source lo | Source of routing updates as loopback |
(config-router-af)# exit-address-family | Exiting of Address family mode |
(config-router)# address-family l2vpn evpn | Entering into address family mode as EVPN |
(config-router-af)# neighbor 2.2.2.2 activate | Enabling EVPN Address family for neighbor |
(config-router-af)# neighbor 3.3.3.3 activate | Enabling EVPN Address family for neighbor |
(config-router-af)# neighbor 5.5.5.5 activate | Enabling EVPN Address family for neighbor |
(config-router-af)# exit-address-family | Exiting of Address family mode |
(config-router)# address-family ipv4 vrf evpn_anycast | Entering into VRF address family mode |
(config-router-af)# redistribute connected | Redistribute connected routes to the network |
(config-router-af)# exit-address-family | Exiting of Address family mode |
SH-1:
Enable EVPN MPLS and IRB:
#configure terminal | Enter configuration mode. |
(config)#evpn mpls enable | Enable EVPN MPLS globally |
(config)#evpn mpls irb | Enable EVPN MPLS IRB globally |
Loopback Interface:
(config-if)#interface lo | Enter the Interface mode for the loopback interface. |
(config-if)# ip address 5.5.5.5/32 secondary | Configure IP address on loopback interface. |
(config-if)#exit | Exit interface mode |
Configure MAC VRF:
(config)#mac vrf red | Create MAC VRF red. |
(config-vrf)# rd 5.5.5.5:100 | Configure route distinguisher |
(config-vrf)# route-target both evpn-auto-rt | Configure route target as evpn auto route target (we can configure as manual RT also) |
(config-vrf)#exit | Exit VRF mode |
(config)#mac vrf blue | Create MAC VRF blue. |
(config-vrf)# rd 5.5.5.5:200 | Configure route distinguisher |
(config-vrf)# route-target both evpn-auto-rt | Configure route target as evpn auto route target (we can configure as manual RT also) |
(config-vrf)#exit | Exit VRF mode |
Creating EVPN MPLS ID:
(config)#evpn mpls vtep-ip-global 5.5.5.5 | Configure VTEP global IP |
(config)#evpn mpls id 100 | Create EVPN MPLS ID |
(config-evpn-mpls)# host-reachability- protocol evpn-bgp red | Map the MAC VRF red |
(config-evpn-mpls)# evpn irb irb100 | Map the IRB interface |
(config-evpn-mpls)#exit | Exit the EVPN MPLS mode |
(config)#evpn mpls id 200 | Create EVPN MPLS ID |
(config-evpn-mpls)# host-reachability- protocol evpn-bgp blue | Map the MAC VRF blue |
(config-evpn-mpls)# evpn irb irb200 | Map the IRB interface |
(config-evpn-mpls)#exit | Exit the EVPN MPLS mode |
Global LDP:
(config)#router ldp | Enter the Router LDP mode. |
(config-router)#router-id 5.5.5.5 | Enter LDP router-id |
(config-router)# transport-address ipv4 5.5.5.5 | Configure LDP transport address |
(config-router)# targeted-peer ipv4 2.2.2.2 | Configure LDP target peer address (MH-1) |
(config-router-targeted-peer)#exit | Exit from LDP target peer mode |
(config-router)# targeted-peer ipv4 3.3.3.3 | Configure LDP target peer address (MH-2) |
(config-router-targeted-peer)#exit | Exit from LDP target peer mode |
(config-router)# targeted-peer ipv4 6.6.6.6 | Configure LDP target peer address (SH-2) |
(config-router-targeted-peer)#exit | Exit from LDP target peer mode |
(config-router)#exit | Exit from LDP mode |
Interface Configuration Network Side:
(config-if)#interface xe6 | Enter interface mode |
(config-if)# description connected to P1 | Configure interface description |
(config-if)# ip address 30.30.30.1/24 | Assign IP address |
(config-if)# mtu 9216 | Configure MTU |
(config-if)# label-switching | Enable label switching |
(config-if)# mpls ldp-igp sync ospf | Enable LDP IGP sync |
(config-if)# enable-ldp ipv4 | Enable LDP IPv4 |
(config-if)#exit | Exit interface mode |
OSPF Configuration:
(config)#router ospf 1 | Enter the Router OSPF mode. |
(config-router)#ospf router-id 5.5.5.5 | Configure OSPF router id |
(config-router)# network 5.5.5.5/32 area 0.0.0.0 | Advertise loopback address in OSPF. |
(config-router)# network 30.30.30.0/24 area 0.0.0.0 | Advertise network address in OSPF. |
(config-router)#exit | Exit OSPF mode |
BGP Configuration:
(config)#router bgp 65010 | Enter the Router BGP mode, ASN: 65010 |
(config-router)# neighbor 2.2.2.2 remote-as 65010 | Configuring MH-1 as I-BGP neighbor using it's loopback IP |
(config-router)# neighbor 2.2.2.2 update- source lo | Source of routing updates as loopback |
(config-router)# neighbor 3.3.3.3 remote-as 65010 | Configuring MH-2 as I-BGP neighbor using it's loopback IP |
(config-router)# neighbor 3.3.3.3 update- source lo | Source of routing updates as loopback |
(config-router)# neighbor 6.6.6.6 remote-as 65010 | Configuring MH-2 as I-BGP neighbor using it's loopback IP |
(config-router)# neighbor 6.6.6.6 update- source lo | Source of routing updates as loopback |
(config-router-af)# exit-address-family | Exiting of Address family mode |
(config-router)# address-family l2vpn evpn | Entering into address family mode as EVPN |
(config-router-af)# neighbor 2.2.2.2 activate | Enabling EVPN Address family for neighbor |
(config-router-af)# neighbor 3.3.3.3 activate | Enabling EVPN Address family for neighbor |
(config-router-af)# neighbor 6.6.6.6 activate | Enabling EVPN Address family for neighbor |
(config-router-af)# exit-address-family | Exiting of Address family mode |
Access Port Configuration:
(config-if)#interface sa9000 | Creating Static LAG interface |
(config-if)#mtu 9216 | Configure MTU as 9216 |
(config-if)#exit | Exiting out of interface mode |
(config-if)#interface sa9000.100 switchport | Creating Static LAG L2 sub interface of physical interface xe12 |
(config-if)# encapsulation dot1q 100 | Setting Encapsulation to dot1q with VLAN ID 100 |
(config-if)#rewrite pop | Configure rewrite with action pop |
(config-if)#mtu 9216 | Configure MTU as 9216 |
(config-if)# access-if-evpn | Entering Access mode for EVPN MPLS ID configuration |
(config-acc-if-evpn)#map vpn-id 100 | Map VPN-ID 100 |
(config-acc-if-evpn)#exit | Exiting out of access interface mode |
(config-if)#interface sa9000.200 switchport | Creating Static LAG L2 sub interface of physical interface xe12 |
(config-if)# encapsulation dot1q 200 | Setting Encapsulation to dot1q with VLAN ID 200 |
(config-if)#rewrite pop | Configure rewrite with action pop |
(config-if)#mtu 9216 | Configure MTU as 9216 |
(config-if)# access-if-evpn | Entering Access mode for EVPN MPLS ID configuration |
(config-acc-if-evpn)#map vpn-id 200 | Map VPN-ID 200 |
(config-acc-if-evpn)#exit | Exiting out of access interface mode |
(config-if)#interface xe12 | Enter the Interface mode |
(config-if)# static-channel-group 9000 | Map the physical interface xe12 as static LAG member |
(config-if)#exit | Exit interface mode |
P1:
Loopback Interface:
#configure terminal | Enter configuration mode. |
(config-if)#interface lo | Enter the Interface mode for the loopback interface. |
(config-if)# ip address 4.4.4.4/32 secondary | Configure IP address on loopback interface. |
(config-if)#exit | Exit interface mode |
Global LDP:
(config)#router ldp | Enter the Router LDP mode. |
(config-router)# router-id 4.4.4.4 | Configure router id |
(config-router)# transport-address ipv4 4.4.4.4 | Configure transport address |
(config-router)#exit | Exit from LDP mode |
Interface Configuration:
(config-if)#interface xe4 | Enter the Interface mode for xe4. |
(config-if)# mtu 9216 | Configure MTU. |
(config-if)#exit | Enable LDP on the physical interface |
(config)#interface xe4.1 | Create sub-interface xe4.1. |
(config-if)# description connected-to-MH-1 | Configure Interface description |
(config-if)# ip address 10.10.10.2/24 | Assign IP address |
(config-if)# mtu 9216 | Configure MTU to the sub-if |
(config-if)# encapsulation dot1q 20 | Configure encapsulation as dotq |
(config-if)# label-switching | Enable label switching |
(config-if)# mpls ldp-igp sync ospf | Enable LDP IGP sync |
(config-if)# enable-ldp ipv4 | Enable LDP IPv4 |
(config-if)#exit | Exit interface mode |
(config)#interface xe1 | Enter into Interface mode |
(config-if)# description connected to MH-2 | Configure Interface description |
(config-if)# ip address 20.20.20.2/24 | Cofigure IP address |
(config-if)# mtu 9216 | Configure MTU |
(config-if)# label-switching | Enable label switching |
(config-if)# mpls ldp-igp sync ospf | Enable LDP IGP sync |
(config-if)# enable-ldp ipv4 | Enable LDP IPv4 |
(config-if)#exit | Exit interface mode |
(config)#interface xe6 | Enter into Interface mode |
(config-if)# description connected to SH-1 | Configure Interface description |
(config-if)# ip address 30.30.30.2/24 | Assign IP address |
(config-if)# mtu 9216 | Configure MTU |
(config-if)# label-switching | Enable label switching |
(config-if)# mpls ldp-igp sync ospf | Enable LDP IGP sync |
(config-if)# enable-ldp ipv4 | Enable LDP IPv4 |
(config-if)#exit | Exit interface mode |
(config)#interface xe10 | Enter into Interface mode |
(config-if)# description connected to SH-2 | Configure Interface description |
(config-if)# ip address 40.40.40.2/24 | Assign IP address |
(config-if)# mtu 9216 | Configure MTU |
(config-if)# label-switching | Enable label switching |
(config-if)# mpls ldp-igp sync ospf | Enable LDP IGP sync |
(config-if)# enable-ldp ipv4 | Enable LDP IPv4 |
(config-if)#exit | Exit interface mode |
OSFP Configuration
(config)#router ospf 1 | Enter the Router OSPF mode. |
(config-router)# ospf router-id 4.4.4.4 | Setting the Router ID as Loopback IP |
(config-router)# network 4.4.4.4/32 area 0.0.0.0 | Advertise loopback address in OSPF. |
(config-router)# network 10.10.10.0/24 area 0.0.0.0 | Advertise network address in OSPF that comes under same subnet. |
(config-router)# network 20.20.20.0/24 area 0.0.0.0 | Advertise network address in OSPF that comes under same subnet. |
(config-router)# network 30.30.30.0/24 area 0.0.0.0 | Advertise network address in OSPF that comes under same subnet. |
(config-router)# network 40.40.40.0/24 area 0.0.0.0 | Advertise network address in OSPF that comes under same subnet. |
(config-router)#exit | Exit Router OSPF mode and return to Configure mode. |
(config)#commit | Commit candidate configuration to be running configuration |
MH-1:
Enable EVPN MPLS and IRB:
#configure terminal | Enter configuration mode. |
(config)#hardware-profile filter evpn-mpls- mh enable | Configure hardware profile to enable EVPN MPLS multi homing in hardware |
(config)#evpn mpls enable | Enable EVPN MPLS globally |
(config)#evpn mpls irb | Enable EVPN MPLS IRB globally |
(config)#evpn mpls multihoming enable | Enable EVPN MPLS multihoming globally |
Loopback Interface:
(config-if)#interface lo | Enter the Interface mode for the loopback interface. |
(config-if)# ip address 2.2.2.2/32 secondarysss | Configure IP address on loopback interface. |
(config-if)#exit | Exit interface mode |
Configure MAC VRF:
(config)#mac vrf red | Create MAC VRF red. |
(config-vrf)# rd 2.2.2.2:100 | Configure route distinguisher |
(config-vrf)# route-target both evpn-auto-rt | Configure route target as evpn auto route target (we can configure as manual RT also) |
(config-vrf)#exit | Exit VRF mode |
(config)#mac vrf blue | Create MAC VRF blue. |
(config-vrf)# rd 2.2.2.2:200 | Configure route distinguisher |
(config-vrf)# route-target both evpn-auto-rt | Configure route target as evpn auto route target (we can configure as manual RT also) |
(config-vrf)#exit | Exit VRF mode |
Configure Anycast Gateway MAC:
(config)#evpn irb-forwarding anycast-gateway- mac 0011.2233.4455 | Configure anycast gateway MAC globally |
Creating EVPN MPLS ID:
(config)#evpn mpls vtep-ip-global 2.2.2.2 | Configure VTEP global IP |
(config)#evpn mpls id 100 | Create EVPN MPLS ID |
(config-evpn-mpls)# host- reachabilityprotocol evpn-bgp red | Map the MAC VRF red |
(config-evpn-mpls)# evpn irb irb100 | Map the IRB interface |
(config-evpn-mpls)#exit | Exit the EVPN MPLS mode |
(config)#evpn mpls id 200 | Create EVPN MPLS ID |
(config-evpn-mpls)# host- reachabilityprotocol evpn-bgp blue | Map the MAC VRF blue |
(config-evpn-mpls)# evpn irb irb200 | Map the IRB interface |
(config-evpn-mpls)#exit | Exit the EVPN MPLS mode |
Global LDP:
(config)#router ldp | Enter the Router LDP mode |
(config-router)#router-id 2.2.2.2 | Enter LDP router-id |
(config-router)# transport-address ipv4 2.2.2.2 | Configure LDP transport address |
(config-router)# targeted-peer ipv4 5.5.5.5 | Configure LDP target peer address (SH) |
(config-router-targeted-peer)#exit | Exit from LDP target peer mode |
(config-router)# targeted-peer ipv4 6.6.6.6 | Configure LDP target peer address (SH) |
(config-router-targeted-peer)#exit | Exit from LDP target peer mode |
(config-router)#exit | Exit from LDP mode |
Interface Configuration Network Side:
(config-if)#interface xe0 | Enter the Interface mode for xe0. |
(config-if)# mtu 9216 | Configure MTU. |
(config-if)#exit | Exit from interface xe0 |
(config)#interface xe0.1 | Create subinterface in xe10 |
(config-if)# encapsulation dot1q 20 | Configure encapsulation as dotq |
(config-if)# ip address 10.10.10.1/24 | Assign IP address |
(config-if)# mtu 9216 | Configure MTU to the sub-if |
(config-if)# label-switching | Enable label switching |
(config-if)# mpls ldp-igp sync ospf | Enable LDP IGP sync |
(config-if)# enable-ldp ipv4 | Enable LDP IPv4 |
OSPF Configuration:
(config)#router ospf 1 | Enter the Router OSPF mode. |
(config-router)# ospf router-id 2.2.2.2 | Router-ID configurations |
(config-router)# network 2.2.2.2/32 area 0.0.0.0 | Advertise loopback address in OSPF. |
(config-router)# network 10.10.10.0/24 area 0.0.0.0 | Advertise network address in OSPF. |
BGP Configuration:
(config-router)#router bgp 65010 | Enter the Router BGP mode, ASN: 100 |
(config-router)# neighbor 3.3.3.3 remote-as 65010 | Configuring MH-2 as iBGP neighbor using it's loopback IP |
(config-router)# neighbor 3.3.3.3 update-source lo | Source of routing updates as loopback |
(config-router)# neighbor 5.5.5.5 remote-as 65010 | Configuring SH-1 as iBGP neighbor using it's loopback IP |
(config-router)# neighbor 5.5.5.5 update-source lo | Source of routing updates as loopback |
(config-router)# neighbor 6.6.6.6 remote-as 65010 | Configuring SH-2 as iBGP neighbor using it's loopback IP |
(config-router)# neighbor 6.6.6.6 update-source lo | Source of routing updates as loopback |
(config-router)# address-family l2vpn evpn | Entering into address family mode as EVPN |
(config-router-af)# neighbor 3.3.3.3 activate | Enabling EVPN Address family for neighbor |
(config-router-af)# neighbor 5.5.5.5 activate | Enabling EVPN Address family for neighbor |
(config-router-af)# neighbor 6.6.6.6 activate | Enabling EVPN Address family for neighbor |
(config-router-af)# exit-address-family | Exiting of Address family mode |
(config-router)# address-family ipv4 vrf evpn | Entering into VRF address family mode |
(config-router-af)# redistribute connected | Redistribute connected routes to the network |
(config-router-af)# exit-address-family | Exiting of Address family mode |
Access Port Configuration:
(config)#interface xe9 | Enter configuration mode |
(config-if)# mtu 9216 | Configure MTU |
(config-if)# channel-group 10000 mode active | Configure physical interface xe9 as LAG member po10000 |
(config-if)#exit | Exit from interface xe9 |
(config)#interface po10000 | Create LAG interface po10000 |
(config-if)# mtu 9216 | Configure MTU |
(config-if)# description connected to Switch | Configure Interface description |
(config-if)# evpn multi-homed system-mac 0000.1111.aaaa | Configure system MAC for multi homing |
(config)#interface po10000.100 switchport | Creating L2 sub interface of physical interface xe9 |
(config-if)# encapsulation dot1q 100 | Setting Encapsulation to dot1q with VLAN ID 100 |
(config-if)#rewrite pop | Configure rewrite with action pop |
(config-if)#mtu 9216 | Configure MTU as 9216 |
(config-if)# access-if-evpn | Entering Access mode for EVPN MPLS ID configuration |
(config-acc-if-evpn)# map vpn-id 100 | Map VPN-ID 202 |
(config-acc-if-evpn)#exit | Exiting out of access interface mode |
(config)#interface po10000.200 switchport | Creating L2 sub interface of physical interface xe9 |
(config-if)# encapsulation dot1q 200 | Setting Encapsulation to dot1q with VLAN ID 200 |
(config-if)#rewrite pop | Configure rewrite with action pop |
(config-if)#mtu 9216 | Configure MTU as 9216 |
(config-if)# access-if-evpn | Entering Access mode for EVPN MPLS ID configuration |
(config-acc-if-evpn)# map vpn-id 200 | Map VPN-ID 202 |
(config-acc-if-evpn)#exit | Exiting out of access interface mode |
MH-2:
Enable EVPN MPLS and IRB:
#configure terminal | Enter configuration mode. |
(config)#hardware-profile filter evpn-mpls-mh enable | Configure hardware profile to enable EVPN MPLS multi homing in hardware |
(config)#evpn mpls enable | Enable EVPN MPLS globally |
(config)#evpn mpls irb | Enable EVPN MPLS IRB globally |
(config)#evpn mpls multihoming enable | Enable EVPN MPLS multihoming globally |
Loopback Interface:
(config-if)#interface lo | Enter the Interface mode for the loopback interface |
(config-if)# ip address 3.3.3.3/32 secondary | Configure IP address on loopback interface. |
(config-if)#exit | Exit interface mode |
Configure MAC VRF:
(config)#mac vrf red | Create MAC VRF red. |
(config-vrf)# rd 3.3.3.3:100 | Configure route distinguisher |
(config-vrf)# route-target both evpn-auto-rt | Configure route target as evpn auto route target (we can configure as manual RT also) |
(config-vrf)#exit | Exit VRF mode |
(config)#mac vrf blue | Create MAC VRF blue. |
(config-vrf)# rd 3.3.3.3:200 | Configure route distinguisher |
(config-vrf)# route-target both evpn-auto-rt | Configure route target as evpn auto route target (we can configure as manual RT also) |
(config-vrf)#exit | Exit VRF mode |
Configure Anycast Gateway MAC:
(config)#evpn irb-forwarding anycastgateway- mac 0011.2233.4455 | Configure anycast gateway MAC globally |
Creating EVPN MPLS ID:
(config)#evpn mpls vtep-ip-global 3.3.3.3 | Configure VTEP global IP |
(config)#evpn mpls id 100 | Create EVPN MPLS ID |
(config-evpn-mpls)# host- reachabilityprotocol evpn-bgp red | Map the MAC VRF red |
(config-evpn-mpls)# evpn irb irb100 | Map the IRB interface |
(config-evpn-mpls)#exit | Exit the EVPN MPLS mode |
(config)#evpn mpls id 200 | Create EVPN MPLS ID |
(config-evpn-mpls)# host- reachabilityprotocol evpn-bgp blue | Map the MAC VRF blue |
(config-evpn-mpls)# evpn irb irb200 | Map the IRB interface |
(config-evpn-mpls)#exit | Exit the EVPN MPLS mode |
Global LDP:
(config)#router ldp | Enter the Router LDP mode. |
(config-router)# transport-address ipv4 3.3.3.3 | Configure LDP transport address |
(config-router)# targeted-peer ipv4 5.5.5.5 | Configure LDP target peer address (SH) |
(config-router-targeted-peer)#exit | Exit from LDP target peer mode |
(config-router)# targeted-peer ipv4 6.6.6.6 | Configure LDP target peer address (SH) |
(config-router-targeted-peer)#exit | Exit from LDP target peer mode |
(config-router)#exit | Exit from LDP mode |
Interface Configuration Network Side:
(config-if)#interface xe10 | Enter the configuration mode. |
(config-if)# description connected to P1 | Configure Interface description |
(config-if)# ip address 20.20.20.1/24 | Assign IP address |
(config-if)# mtu 9216 | Configure MTU to the sub-if |
(config-if)# label-switching | Enable label switching |
(config-if)# mpls ldp-igp sync ospf | Enable LDP IGP sync |
(config-if)# enable-ldp ipv4 | Enable LDP IPv4 |
(config-if)#exit | Exit interface mode |
OSPF Configuration:
(config)#router ospf 1 | Enter the Router OSPF mode. |
(config-router)# ospf router-id 3.3.3.3 | Router-ID configurations |
(config-router)# network 3.3.3.3/32 area 0.0.0.0 | Advertise loopback address in OSPF. |
(config-router)# network 20.20.20.0/24 area 0.0.0.0 | Advertise network address in OSPF. |
BGP Configuration:
(config-router)#router bgp 65010 | Enter the Router BGP mode, ASN: 100 |
(config-router)# neighbor 2.2.2.2 remote-as 65010 | Configuring PE3 as iBGP neighbor using it's loopback IP |
(config-router)# neighbor 2.2.2.2 update- source lo | Source of routing updates as loopback |
(config-router)# neighbor 5.5.5.5 remote-as 65010 | Configuring PE3 as iBGP neighbor using it's loopback IP |
(config-router)# neighbor 5.5.5.5 update-source lo | Source of routing updates as loopback |
(config-router)# neighbor 6.6.6.6 remote-as 65010 | Configuring PE3 as iBGP neighbor using it's loopback IP |
(config-router)# neighbor 6.6.6.6 update-source lo | Source of routing updates as loopback |
(config-router)# address-family l2vpn evpn | Entering into address family mode as EVPN |
(config-router-af)# neighbor 2.2.2.2 activate | Enabling EVPN Address family for neighbor |
(config-router-af)# neighbor 5.5.5.5 activate | Enabling EVPN Address family for neighbor |
(config-router-af)# neighbor 6.6.6.6 activate | Enabling EVPN Address family for neighbor |
(config-router-af)# exit-address-family | Exiting of Address family mode |
(config-router)# address-family ipv4 vrf evpn_anycast | Entering into VRF address family mode |
(config-router-af)# redistribute connected | Redistribute connected routes to the network |
(config-router-af)# exit-address-family | Exiting of Address family mode |
Access Port Configuration:
(config)#interface xe21 | Enter configuration mode |
(config-if)# mtu 9216 | Configure MTU |
(config-if)# channel-group 10000 mode active | Configure physical interface xe21 as LAG member po10000 |
(config-if)#exit | Exit from interface xe21 |
(config)#interface po10000 | Create LAG interface po10000 |
(config-if)# mtu 9216 | Configure MTU |
(config-if)# description connected to Switch | Configure Interface description |
(config-if)# evpn multi-homed system-mac 0000.1111.aaaa | Configure system MAC for multi homing |
(config)#interface po10000.100 switchport | Creating L2 sub interface of physical interface xe21 |
(config-if)# encapsulation dot1q 100 | Setting Encapsulation to dot1q with VLAN ID 100 |
(config-if)#rewrite pop | Configure rewrite with action pop |
(config-if)#mtu 9216 | Configure MTU as 9216 |
(config-if)# access-if-evpn | Entering Access mode for EVPN MPLS ID configuration |
(config-acc-if-evpn)# map vpn-id 100 | Map VPN-ID 202 |
(config-acc-if-evpn)#exit | Exiting out of access interface mode |
(config)#interface po10000.200 switchport | Creating L2 sub interface of physical interface xe21 |
(config-if)# encapsulation dot1q 200 | Setting Encapsulation to dot1q with VLAN ID 200 |
(config-if)#rewrite pop | Configure rewrite with action pop |
(config-if)#mtu 9216 | Configure MTU as 9216 |
(config-if)# access-if-evpn | Entering Access mode for EVPN MPLS ID configuration |
(config-acc-if-evpn)# map vpn-id 200 | Map VPN-ID 202 |
(config-acc-if-evpn)#exit | Exiting out of access interface mode |
Validation
Note: Remote entries cannot be fetched from through MAC table/ARP cache/ND cache. However they can be fetched from the BGP table.
MH-1:
MH-1#sh evpn mpls
EVPN-MPLS Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
VPN-ID EVI-Name EVI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
_______________________________________________________________________________________________________________________________
100 ---- L2 NW ---- ---- ---- ---- 2.2.2.2 6.6.6.6
100 ---- L2 NW ---- ---- ---- ---- 2.2.2.2 3.3.3.3
100 ---- L2 NW ---- ---- ---- ---- 2.2.2.2 5.5.5.5
100 ---- -- AC po10000.100 00:00:00:11:11:aa:aa:00:00:00 ---- DF ---- ----
200 ---- L2 NW ---- ---- ---- ---- 2.2.2.2 6.6.6.6
200 ---- L2 NW ---- ---- ---- ---- 2.2.2.2 3.3.3.3
200 ---- L2 NW ---- ---- ---- ---- 2.2.2.2 5.5.5.5
200 ---- -- AC po10000.200 00:00:00:11:11:aa:aa:00:00:00 ---- DF ---- ----
Total number of entries are 8
MH-1#
MH-1#sh evpn mpls tunnel
EVPN-MPLS Network tunnel Entries
Source Destination Status Up/Down Update evpn-id
===================================================================================
2.2.2.2 6.6.6.6 Installed 01:38:59 01:38:59 200
2.2.2.2 6.6.6.6 Installed 01:38:59 01:38:59 100
2.2.2.2 3.3.3.3 Installed 01:38:59 01:38:59 200
2.2.2.2 3.3.3.3 Installed 01:38:59 01:38:59 100
2.2.2.2 5.5.5.5 Installed 01:38:59 01:38:59 200
2.2.2.2 5.5.5.5 Installed 01:38:59 01:38:59 100
Total number of entries are 6
MH-1#
MH-1#sh evpn mpls mac-table
=========================================================================================================================================
EVPN MPLS MAC Entries
=========================================================================================================================================
VNID Interface VlanId In-VlanId Mac-Addr VTEP-Ip/ESI Type Status MAC move AccessPortDesc
_________________________________________________________________________________________________________________________________________
100 ---- ---- ---- 0077.8899.5566 6.6.6.6 Static Remote ------- 0 -------
100 ---- ---- ---- 0010.9400.0001 00:00:00:11:11:aa:aa:00:00:00 Dynamic Remote ------- 0 -------
200 ---- ---- ---- 0077.8899.5566 6.6.6.6 Static Remote ------- 0 -------
200 ---- ---- ---- 0010.9400.0005 5.5.5.5 Dynamic Remote ------- 0 -------
Total number of entries are : 4
MH-1#
MH-1#sh evpn mpls arp-cache
MPLS-EVPN ARP-CACHE Information
===============================
ARP Timeout : 300 sec Random-Jitter-Max : 200
EVPN-ID Ip-Addr Mac-Addr Type Age-Out Retries-Left
_____________________________________________________________________________
100 80.80.1.2 0010.9400.0001 Dynamic Remote ----
100 80.80.1.3 0077.8899.5566 Static Remote ----
200 90.90.1.3 0077.8899.5566 Static Remote ----
200 90.90.1.4 0010.9400.0005 Dynamic Remote ----
Total number of entries are 4
MH-1#
MH-1#show bgp l2vpn evpn multihoming ethernet-ad-per-es
RD[2.2.2.2:100] VRF[red]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 16 3.3.3.3 MPLS
RD[2.2.2.2:200] VRF[blue]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 16 3.3.3.3 MPLS
RD[2.2.2.2:64512] VRF[evpn-gvrf-1]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 16 2.2.2.2 MPLS
RD[3.3.3.3:64512]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 16 3.3.3.3 MPLS
MH-1#
MH-1#show bgp l2vpn evpn multihoming ethernet-ad-per-evi
RD[2.2.2.2:100] VRF[red]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 100 17 2.2.2.2 MPLS
00:00:00:11:11:aa:aa:00:00:00 100 17 3.3.3.3 MPLS
RD[2.2.2.2:200] VRF[blue]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 200 18 2.2.2.2 MPLS
00:00:00:11:11:aa:aa:00:00:00 200 18 3.3.3.3 MPLS
RD[3.3.3.3:100]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 100 17 3.3.3.3 MPLS
RD[3.3.3.3:200]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 200 18 3.3.3.3 MPLS
MH-1#
MH-1#sh evpn mpls label esi
S - Self
R - Remote
ESI PE-IP-ADDRESS ESI-LABEL
================================================================
00:00:00:11:11:aa:aa:00:00:00 2.2.2.2(S) 16
00:00:00:11:11:aa:aa:00:00:00 3.3.3.3(R) 16
MH-1#
MH-1#sh evpn mpls label alias
S - Self
R - Remote
ESI PE-IP-ADDRESS TENANT ALIAS-LABEL
=============================================================================================
00:00:00:11:11:aa:aa:00:00:00 2.2.2.2(S) 100 17
00:00:00:11:11:aa:aa:00:00:00 2.2.2.2(S) 200 18
00:00:00:11:11:aa:aa:00:00:00 3.3.3.3(R) 100 17
00:00:00:11:11:aa:aa:00:00:00 3.3.3.3(R) 200 18
MH-1#
MH-1#sh bgp l2vpn evpn
BGP table version is 3, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
[EVPN route type]:[ESI]:[VNID]:[relevent route informantion]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
Network Next Hop Metric LocPrf Weight Path Peer Encap
RD[30:200]
*>i [5]:[0]:[0]:[24]:[80.80.1.0]:[0.0.0.0]:[16]
6.6.6.6 0 100 0 ? 6.6.6.6 MPLS
*>i [5]:[0]:[0]:[24]:[90.90.1.0]:[0.0.0.0]:[16]
6.6.6.6 0 100 0 ? 6.6.6.6 MPLS
RD[2.2.2.2:100] VRF[red]:
*> [1]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[17]
2.2.2.2 0 100 32768 i ---------- MPLS
* i 3.3.3.3 0 100 0 i 3.3.3.3 MPLS
* i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[4294967295]:[0]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
* i [2]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[48,0010:9400:0001]:[0]:[17]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
* i [2]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[48,0010:9400:0001]:[32,80.80.1.2]:[17]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
* i [2]:[0]:[100]:[48,0077:8899:5566]:[32,80.80.1.3]:[17]
6.6.6.6 0 100 0 i 6.6.6.6 MPLS
*> [3]:[100]:[32,2.2.2.2]
2.2.2.2 0 100 32768 i ---------- MPLS
* i [3]:[100]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
* i [3]:[100]:[32,5.5.5.5]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
* i [3]:[100]:[32,6.6.6.6]
6.6.6.6 0 100 0 i 6.6.6.6 MPLS
RD[2.2.2.2:200] VRF[blue]:
*> [1]:[00:00:00:11:11:aa:aa:00:00:00]:[200]:[18]
2.2.2.2 0 100 32768 i ---------- MPLS
* i 3.3.3.3 0 100 0 i 3.3.3.3 MPLS
* i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[4294967295]:[0]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
* i [2]:[0]:[200]:[48,0010:9400:0005]:[0]:[641]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
* i [2]:[0]:[200]:[48,0010:9400:0005]:[32,90.90.1.4]:[641]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
* i [2]:[0]:[200]:[48,0077:8899:5566]:[32,90.90.1.3]:[18]
6.6.6.6 0 100 0 i 6.6.6.6 MPLS
*> [3]:[200]:[32,2.2.2.2]
2.2.2.2 0 100 32768 i ---------- MPLS
* i [3]:[200]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
* i [3]:[200]:[32,5.5.5.5]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
* i [3]:[200]:[32,6.6.6.6]
6.6.6.6 0 100 0 i 6.6.6.6 MPLS
RD[2.2.2.2:64512] VRF[evpn-gvrf-1]:
*> [1]:[00:00:00:11:11:aa:aa:00:00:00]:[4294967295]:[0]
2.2.2.2 0 100 32768 i ---------- MPLS
*> [4]:[00:00:00:11:11:aa:aa:00:00:00]:[32,2.2.2.2]
2.2.2.2 0 100 32768 i ---------- MPLS
* i [4]:[00:00:00:11:11:aa:aa:00:00:00]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
RD[3.3.3.3:100]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[17]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*>i [2]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[48,0010:9400:0001]:[0]:[17]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*>i [2]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[48,0010:9400:0001]:[32,80.80.1.2]:[17]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*>i [3]:[100]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
RD[3.3.3.3:200]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[200]:[18]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*>i [3]:[200]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
RD[3.3.3.3:64512]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[4294967295]:[0]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*>i [4]:[00:00:00:11:11:aa:aa:00:00:00]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
RD[5.5.5.5:100]
*>i [3]:[100]:[32,5.5.5.5]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
RD[5.5.5.5:200]
*>i [2]:[0]:[200]:[48,0010:9400:0005]:[0]:[641]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
*>i [2]:[0]:[200]:[48,0010:9400:0005]:[32,90.90.1.4]:[641]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
*>i [3]:[200]:[32,5.5.5.5]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
RD[6.6.6.6:100]
*>i [2]:[0]:[100]:[48,0077:8899:5566]:[32,80.80.1.3]:[17]
6.6.6.6 0 100 0 i 6.6.6.6 MPLS
*>i [3]:[100]:[32,6.6.6.6]
6.6.6.6 0 100 0 i 6.6.6.6 MPLS
RD[6.6.6.6:200]
*>i [2]:[0]:[200]:[48,0077:8899:5566]:[32,90.90.1.3]:[18]
6.6.6.6 0 100 0 i 6.6.6.6 MPLS
*>i [3]:[200]:[32,6.6.6.6]
6.6.6.6 0 100 0 i 6.6.6.6 MPLS
Total number of prefixes 39
MH-1#
MH-1#sh bgp l2vpn evpn prefix-route
RD[30:200]
ESI Eth-Tag Prefix-Length IP-Address GW-IPAddress L3VNID/LABEL Nexthop Encap Router-Mac
0 0 24 80.80.1.0 0.0.0.0 16 6.6.6.6 MPLS e8c5:7aff:96de
0 0 24 90.90.1.0 0.0.0.0 16 6.6.6.6 MPLS e8c5:7aff:96de
MH-1#
MH-1#sh bgp l2vpn evpn summary
BGP router identifier 2.2.2.2, local AS number 65010
BGP table version is 3
1 BGP AS-PATH entries
0 BGP community entries
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd AD MACIP MCAST ESI PREFIX-ROUTE
3.3.3.3 4 65010 244 241 2 0 0 01:39:10 8 3 2 2 1 0
5.5.5.5 4 65010 237 238 2 0 0 01:39:10 4 0 2 2 0 0
6.6.6.6 4 65010 239 240 2 0 0 01:39:10 6 0 2 2 0 2
Total number of neighbors 3
Total number of Established sessions 3
MH-1#
MH-1#sh mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN, ! - using backup
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
(m) - FTN mapped over multipath transport, (e) - FTN is ECMP
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 3.3.3.3/32 1 2
1 - Yes LSP_DEFAULT 25605 xe0.1 No 10.10.10.2
L> 4.4.4.4/32 2 5
4 - Yes LSP_DEFAULT 3 xe0.1 No 10.10.10.2
L> 5.5.5.5/32 3 7
6 - Yes LSP_DEFAULT 25606 xe0.1 No 10.10.10.2
L> 6.6.6.6/32 4 10
9 - Yes LSP_DEFAULT 25609 xe0.1 No 10.10.10.2
L> 20.20.20.0/24 5 5
4 - Yes LSP_DEFAULT 3 xe0.1 No 10.10.10.2
L> 30.30.30.0/24 6 5
4 - Yes LSP_DEFAULT 3 xe0.1 No 10.10.10.2
L> 40.40.40.0/24 7 5
4 - Yes LSP_DEFAULT 3 xe0.1 No 10.10.10.2
MH-1#
MH-1#sh ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
5.5.5.5 xe0.1 Passive OPERATIONAL 30 01:39:03
6.6.6.6 xe0.1 Passive OPERATIONAL 30 01:39:03
4.4.4.4 xe0.1 Passive OPERATIONAL 30 01:39:01
MH-1#
MH-1#sh ip ospf neighbor
Total number of full neighbors: 1
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
4.4.4.4 1 Full/DR 00:00:35 10.10.10.2 xe0.1 0
MH-1#
MH-2:
MH-2#sh evpn mpls
EVPN-MPLS Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
VPN-ID EVI-Name EVI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
_______________________________________________________________________________________________________________________________
100 ---- L2 NW ---- ---- ---- ---- 3.3.3.3 5.5.5.5
100 ---- L2 NW ---- ---- ---- ---- 3.3.3.3 2.2.2.2
100 ---- L2 NW ---- ---- ---- ---- 3.3.3.3 6.6.6.6
100 ---- -- AC po10000.100 00:00:00:11:11:aa:aa:00:00:00 ---- NON-DF ---- ----
200 ---- L2 NW ---- ---- ---- ---- 3.3.3.3 5.5.5.5
200 ---- L2 NW ---- ---- ---- ---- 3.3.3.3 2.2.2.2
200 ---- L2 NW ---- ---- ---- ---- 3.3.3.3 6.6.6.6
200 ---- -- AC po10000.200 00:00:00:11:11:aa:aa:00:00:00 ---- NON-DF ---- ----
Total number of entries are 8
MH-2#
MH-2#sh evpn mpls tunnel
EVPN-MPLS Network tunnel Entries
Source Destination Status Up/Down Update evpn-id
===================================================================================
3.3.3.3 5.5.5.5 Installed 01:52:28 01:52:28 200
3.3.3.3 5.5.5.5 Installed 01:52:28 01:52:28 100
3.3.3.3 2.2.2.2 Installed 01:41:32 01:41:32 200
3.3.3.3 2.2.2.2 Installed 01:41:32 01:41:32 100
3.3.3.3 6.6.6.6 Installed 01:52:28 01:52:28 200
3.3.3.3 6.6.6.6 Installed 01:52:28 01:52:28 100
Total number of entries are 6
MH-2#
MH-2#sh evpn mpls mac-table
=========================================================================================================================================
EVPN MPLS MAC Entries
=========================================================================================================================================
VNID Interface VlanId In-VlanId Mac-Addr VTEP-Ip/ESI Type Status MAC move AccessPortDesc
_________________________________________________________________________________________________________________________________________
100 ---- ---- ---- 0077.8899.5566 6.6.6.6 Static Remote ------- 0 -------
100 po10000.100 ---- ---- 0010.9400.0001 00:00:00:11:11:aa:aa:00:00:00 Dynamic Local ------- 0 -------
200 ---- ---- ---- 0077.8899.5566 6.6.6.6 Static Remote ------- 0 -------
200 ---- ---- ---- 0010.9400.0005 5.5.5.5 Dynamic Remote ------- 0 -------
Total number of entries are : 4
MH-2#
MH-2#sh evpn mpls arp-cache
MPLS-EVPN ARP-CACHE Information
===============================
ARP Timeout : 300 sec Random-Jitter-Max : 200
EVPN-ID Ip-Addr Mac-Addr Type Age-Out Retries-Left
_____________________________________________________________________________
100 80.80.1.2 0010.9400.0001 Dynamic Local 249 2
100 80.80.1.3 0077.8899.5566 Static Remote ----
200 90.90.1.3 0077.8899.5566 Static Remote ----
200 90.90.1.4 0010.9400.0005 Dynamic Remote ----
Total number of entries are 4
MH-2#
MH-2#show bgp l2vpn evpn multihoming ethernet-ad-per-es
RD[2.2.2.2:64512]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 16 2.2.2.2 MPLS
RD[3.3.3.3:100] VRF[red]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 16 2.2.2.2 MPLS
RD[3.3.3.3:200] VRF[blue]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 16 2.2.2.2 MPLS
RD[3.3.3.3:64512] VRF[evpn-gvrf-1]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 16 3.3.3.3 MPLS
MH-2#
MH-2#show bgp l2vpn evpn multihoming ethernet-ad-per-evi
RD[2.2.2.2:100]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 100 17 2.2.2.2 MPLS
RD[2.2.2.2:200]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 200 18 2.2.2.2 MPLS
RD[3.3.3.3:100] VRF[red]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 100 17 2.2.2.2 MPLS
00:00:00:11:11:aa:aa:00:00:00 100 17 3.3.3.3 MPLS
RD[3.3.3.3:200] VRF[blue]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 200 18 2.2.2.2 MPLS
00:00:00:11:11:aa:aa:00:00:00 200 18 3.3.3.3 MPLS
MH-2#
MH-2#sh evpn mpls label esi
S - Self
R - Remote
ESI PE-IP-ADDRESS ESI-LABEL
================================================================
00:00:00:11:11:aa:aa:00:00:00 2.2.2.2(R) 16
00:00:00:11:11:aa:aa:00:00:00 3.3.3.3(S) 16
MH-2#
MH-2#sh evpn mpls label alias
S - Self
R - Remote
ESI PE-IP-ADDRESS TENANT ALIAS-LABEL
=============================================================================================
00:00:00:11:11:aa:aa:00:00:00 2.2.2.2(R) 100 17
00:00:00:11:11:aa:aa:00:00:00 2.2.2.2(R) 200 18
00:00:00:11:11:aa:aa:00:00:00 3.3.3.3(S) 100 17
00:00:00:11:11:aa:aa:00:00:00 3.3.3.3(S) 200 18
MH-2#
MH-2#sh bgp l2vpn evpn
BGP table version is 7, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
[EVPN route type]:[ESI]:[VNID]:[relevent route informantion]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
Network Next Hop Metric LocPrf Weight Path Peer Encap
RD[30:200]
*>i [5]:[0]:[0]:[24]:[80.80.1.0]:[0.0.0.0]:[16]
6.6.6.6 0 100 0 ? 6.6.6.6 MPLS
*>i [5]:[0]:[0]:[24]:[90.90.1.0]:[0.0.0.0]:[16]
6.6.6.6 0 100 0 ? 6.6.6.6 MPLS
RD[2.2.2.2:100]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[17]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*>i [3]:[100]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
RD[2.2.2.2:200]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[200]:[18]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*>i [3]:[200]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
RD[2.2.2.2:64512]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[4294967295]:[0]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*>i [4]:[00:00:00:11:11:aa:aa:00:00:00]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
RD[3.3.3.3:100] VRF[red]:
* i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[17]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*> 3.3.3.3 0 100 32768 i ---------- MPLS
* i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[4294967295]:[0]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*> [2]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[48,0010:9400:0001]:[0]:[17]
3.3.3.3 0 100 32768 i ---------- MPLS
*> [2]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[48,0010:9400:0001]:[32,80.80.1.2]:[17]
3.3.3.3 0 100 32768 i ---------- MPLS
* i [2]:[0]:[100]:[48,0077:8899:5566]:[32,80.80.1.3]:[17]
6.6.6.6 0 100 0 i 6.6.6.6 MPLS
* i [3]:[100]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*> [3]:[100]:[32,3.3.3.3]
3.3.3.3 0 100 32768 i ---------- MPLS
* i [3]:[100]:[32,5.5.5.5]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
* i [3]:[100]:[32,6.6.6.6]
6.6.6.6 0 100 0 i 6.6.6.6 MPLS
RD[3.3.3.3:200] VRF[blue]:
* i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[200]:[18]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*> 3.3.3.3 0 100 32768 i ---------- MPLS
* i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[4294967295]:[0]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
* i [2]:[0]:[200]:[48,0010:9400:0005]:[0]:[641]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
* i [2]:[0]:[200]:[48,0010:9400:0005]:[32,90.90.1.4]:[641]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
* i [2]:[0]:[200]:[48,0077:8899:5566]:[32,90.90.1.3]:[18]
6.6.6.6 0 100 0 i 6.6.6.6 MPLS
* i [3]:[200]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*> [3]:[200]:[32,3.3.3.3]
3.3.3.3 0 100 32768 i ---------- MPLS
* i [3]:[200]:[32,5.5.5.5]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
* i [3]:[200]:[32,6.6.6.6]
6.6.6.6 0 100 0 i 6.6.6.6 MPLS
RD[3.3.3.3:64512] VRF[evpn-gvrf-1]:
*> [1]:[00:00:00:11:11:aa:aa:00:00:00]:[4294967295]:[0]
3.3.3.3 0 100 32768 i ---------- MPLS
* i [4]:[00:00:00:11:11:aa:aa:00:00:00]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*> [4]:[00:00:00:11:11:aa:aa:00:00:00]:[32,3.3.3.3]
3.3.3.3 0 100 32768 i ---------- MPLS
RD[5.5.5.5:100]
*>i [3]:[100]:[32,5.5.5.5]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
RD[5.5.5.5:200]
*>i [2]:[0]:[200]:[48,0010:9400:0005]:[0]:[641]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
*>i [2]:[0]:[200]:[48,0010:9400:0005]:[32,90.90.1.4]:[641]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
*>i [3]:[200]:[32,5.5.5.5]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
RD[6.6.6.6:100]
*>i [2]:[0]:[100]:[48,0077:8899:5566]:[32,80.80.1.3]:[17]
6.6.6.6 0 100 0 i 6.6.6.6 MPLS
*>i [3]:[100]:[32,6.6.6.6]
6.6.6.6 0 100 0 i 6.6.6.6 MPLS
RD[6.6.6.6:200]
*>i [2]:[0]:[200]:[48,0077:8899:5566]:[32,90.90.1.3]:[18]
6.6.6.6 0 100 0 i 6.6.6.6 MPLS
*>i [3]:[200]:[32,6.6.6.6]
6.6.6.6 0 100 0 i 6.6.6.6 MPLS
Total number of prefixes 37
MH-2#
MH-2#sh bgp l2vpn evpn prefix-route
RD[30:200]
ESI Eth-Tag Prefix-Length IP-Address GW-IPAddress L3VNID/LABEL Nexthop Encap Router-Mac
0 0 24 80.80.1.0 0.0.0.0 16 6.6.6.6 MPLS e8c5:7aff:96de
0 0 24 90.90.1.0 0.0.0.0 16 6.6.6.6 MPLS e8c5:7aff:96de
MH-2#
MH-2#sh bgp l2vpn evpn summary
BGP router identifier 3.3.3.3, local AS number 65010
BGP table version is 7
1 BGP AS-PATH entries
0 BGP community entries
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd AD MACIP MCAST ESI PREFIX-ROUTE
2.2.2.2 4 65010 279 273 7 0 0 01:41:33 6 3 0 2 1 0
5.5.5.5 4 65010 270 276 7 0 0 01:52:30 4 0 2 2 0 0
6.6.6.6 4 65010 271 277 7 0 0 01:52:30 6 0 2 2 0 2
Total number of neighbors 3
Total number of Established sessions 3
MH-2#
MH-2#sh mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN, ! - using backup
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
(m) - FTN mapped over multipath transport, (e) - FTN is ECMP
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 2.2.2.2/32 5 13
12 - Yes LSP_DEFAULT 25600 xe10 No 20.20.20.2
L> 4.4.4.4/32 2 4
3 - Yes LSP_DEFAULT 3 xe10 No 20.20.20.2
L> 5.5.5.5/32 3 6
5 - Yes LSP_DEFAULT 25610 xe10 No 20.20.20.2
L> 6.6.6.6/32 4 8
7 - Yes LSP_DEFAULT 25611 xe10 No 20.20.20.2
L> 10.10.10.0/24 1 4
3 - Yes LSP_DEFAULT 3 xe10 No 20.20.20.2
L> 30.30.30.0/24 6 4
3 - Yes LSP_DEFAULT 3 xe10 No 20.20.20.2
L> 40.40.40.0/24 7 4
3 - Yes LSP_DEFAULT 3 xe10 No 20.20.20.2
MH-2#
MH-2#sh ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
4.4.4.4 xe10 Passive OPERATIONAL 30 01:52:33
5.5.5.5 xe10 Passive OPERATIONAL 30 01:52:10
6.6.6.6 xe10 Passive OPERATIONAL 30 01:52:10
MH-2#
MH-2#sh ip ospf neighbor
Total number of full neighbors: 1
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
4.4.4.4 1 Full/DR 00:00:31 20.20.20.2 xe10 0
MH-2#
SH-1:
SH-1#sh evpn mpls
EVPN-MPLS Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
VPN-ID EVI-Name EVI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
_______________________________________________________________________________________________________________________________
100 ---- L2 NW ---- ---- ---- ---- 5.5.5.5 6.6.6.6
100 ---- L2 NW ---- ---- ---- ---- 5.5.5.5 2.2.2.2
100 ---- L2 NW ---- ---- ---- ---- 5.5.5.5 3.3.3.3
100 ---- -- AC sa9000.100 --- Single Homed Port --- ---- ---- ---- ----
200 ---- L2 NW ---- ---- ---- ---- 5.5.5.5 6.6.6.6
200 ---- L2 NW ---- ---- ---- ---- 5.5.5.5 2.2.2.2
200 ---- L2 NW ---- ---- ---- ---- 5.5.5.5 3.3.3.3
200 ---- -- AC sa9000.200 --- Single Homed Port --- ---- ---- ---- ----
Total number of entries are 8
SH-1#
SH-1#sh evpn mpls tunnel
EVPN-MPLS Network tunnel Entries
Source Destination Status Up/Down Update evpn-id
===================================================================================
5.5.5.5 6.6.6.6 Installed 01:57:20 01:57:20 200
5.5.5.5 6.6.6.6 Installed 01:57:20 01:57:20 100
5.5.5.5 2.2.2.2 Installed 01:44:57 01:44:57 200
5.5.5.5 2.2.2.2 Installed 01:44:57 01:44:57 100
5.5.5.5 3.3.3.3 Installed 01:55:53 01:55:53 200
5.5.5.5 3.3.3.3 Installed 01:55:53 01:55:53 100
Total number of entries are 6
SH-1#
SH-1#sh evpn mpls mac-table
=========================================================================================================================================
EVPN MPLS MAC Entries
=========================================================================================================================================
VNID Interface VlanId In-VlanId Mac-Addr VTEP-Ip/ESI Type Status MAC move AccessPortDesc
_________________________________________________________________________________________________________________________________________
100 ---- ---- ---- 0077.8899.5566 6.6.6.6 Static Remote ------- 0 -------
100 ---- ---- ---- 0010.9400.0001 00:00:00:11:11:aa:aa:00:00:00 Dynamic Remote ------- 0 -------
200 ---- ---- ---- 0077.8899.5566 6.6.6.6 Static Remote ------- 0 -------
200 sa9000.200 ---- ---- 0010.9400.0005 5.5.5.5 Dynamic Local ------- 0 -------
Total number of entries are : 4
SH-1#
SH-1#sh evpn mpls arp-cache
MPLS-EVPN ARP-CACHE Information
===============================
ARP Timeout : 300 sec Random-Jitter-Max : 200
EVPN-ID Ip-Addr Mac-Addr Type Age-Out Retries-Left
_____________________________________________________________________________
100 80.80.1.2 0010.9400.0001 Dynamic Remote ----
100 80.80.1.3 0077.8899.5566 Static Remote ----
200 90.90.1.3 0077.8899.5566 Static Remote ----
200 90.90.1.4 0010.9400.0005 Dynamic Local 443 2
Total number of entries are 4
SH-1#
SH-1#show bgp l2vpn evpn multihoming ethernet-ad-per-es
RD[2.2.2.2:64512]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 16 2.2.2.2 MPLS
RD[3.3.3.3:64512]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 16 3.3.3.3 MPLS
RD[5.5.5.5:100] VRF[red]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 16 2.2.2.2 MPLS
00:00:00:11:11:aa:aa:00:00:00 4294967295 16 3.3.3.3 MPLS
RD[5.5.5.5:200] VRF[blue]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 16 2.2.2.2 MPLS
00:00:00:11:11:aa:aa:00:00:00 4294967295 16 3.3.3.3 MPLS
SH-1#
SH-1#show bgp l2vpn evpn multihoming ethernet-ad-per-evi
RD[2.2.2.2:100]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 100 17 2.2.2.2 MPLS
RD[2.2.2.2:200]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 200 18 2.2.2.2 MPLS
RD[3.3.3.3:100]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 100 17 3.3.3.3 MPLS
RD[3.3.3.3:200]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 200 18 3.3.3.3 MPLS
RD[5.5.5.5:100] VRF[red]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 100 17 2.2.2.2 MPLS
00:00:00:11:11:aa:aa:00:00:00 100 17 3.3.3.3 MPLS
RD[5.5.5.5:200] VRF[blue]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 200 18 2.2.2.2 MPLS
00:00:00:11:11:aa:aa:00:00:00 200 18 3.3.3.3 MPLS
SH-1#
SH-1#sh evpn mpls label esi
S - Self
R - Remote
ESI PE-IP-ADDRESS ESI-LABEL
================================================================
00:00:00:11:11:aa:aa:00:00:00 2.2.2.2(R) 16
00:00:00:11:11:aa:aa:00:00:00 3.3.3.3(R) 16
SH-1#
SH-1#sh evpn mpls label alias
S - Self
R - Remote
ESI PE-IP-ADDRESS TENANT ALIAS-LABEL
=============================================================================================
00:00:00:11:11:aa:aa:00:00:00 2.2.2.2(R) 100 17
00:00:00:11:11:aa:aa:00:00:00 2.2.2.2(R) 200 18
00:00:00:11:11:aa:aa:00:00:00 3.3.3.3(R) 100 17
00:00:00:11:11:aa:aa:00:00:00 3.3.3.3(R) 200 18
SH-1#
SH-1#sh bgp l2vpn evpn
BGP table version is 10, local router ID is 5.5.5.5
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
[EVPN route type]:[ESI]:[VNID]:[relevent route informantion]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
Network Next Hop Metric LocPrf Weight Path Peer Encap
RD[30:200]
*>i [5]:[0]:[0]:[24]:[80.80.1.0]:[0.0.0.0]:[16]
6.6.6.6 0 100 0 ? 6.6.6.6 MPLS
*>i [5]:[0]:[0]:[24]:[90.90.1.0]:[0.0.0.0]:[16]
6.6.6.6 0 100 0 ? 6.6.6.6 MPLS
RD[2.2.2.2:100]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[17]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*>i [3]:[100]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
RD[2.2.2.2:200]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[200]:[18]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*>i [3]:[200]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
RD[2.2.2.2:64512]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[4294967295]:[0]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*>i [4]:[00:00:00:11:11:aa:aa:00:00:00]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
RD[3.3.3.3:100]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[17]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*>i [2]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[48,0010:9400:0001]:[0]:[17]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*>i [2]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[48,0010:9400:0001]:[32,80.80.1.2]:[17]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*>i [3]:[100]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
RD[3.3.3.3:200]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[200]:[18]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*>i [3]:[200]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
RD[3.3.3.3:64512]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[4294967295]:[0]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*>i [4]:[00:00:00:11:11:aa:aa:00:00:00]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
RD[5.5.5.5:100] VRF[red]:
* i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[17]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
* i 3.3.3.3 0 100 0 i 3.3.3.3 MPLS
* i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[4294967295]:[0]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
* i 3.3.3.3 0 100 0 i 3.3.3.3 MPLS
* i [2]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[48,0010:9400:0001]:[0]:[17]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
* i [2]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[48,0010:9400:0001]:[32,80.80.1.2]:[17]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
* i [2]:[0]:[100]:[48,0077:8899:5566]:[32,80.80.1.3]:[17]
6.6.6.6 0 100 0 i 6.6.6.6 MPLS
* i [3]:[100]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
* i [3]:[100]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*> [3]:[100]:[32,5.5.5.5]
5.5.5.5 0 100 32768 i ---------- MPLS
* i [3]:[100]:[32,6.6.6.6]
6.6.6.6 0 100 0 i 6.6.6.6 MPLS
RD[5.5.5.5:200] VRF[blue]:
* i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[200]:[18]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
* i 3.3.3.3 0 100 0 i 3.3.3.3 MPLS
* i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[4294967295]:[0]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
* i 3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*> [2]:[0]:[200]:[48,0010:9400:0005]:[0]:[641]
5.5.5.5 0 100 32768 i ---------- MPLS
*> [2]:[0]:[200]:[48,0010:9400:0005]:[32,90.90.1.4]:[641]
5.5.5.5 0 100 32768 i ---------- MPLS
* i [2]:[0]:[200]:[48,0077:8899:5566]:[32,90.90.1.3]:[18]
6.6.6.6 0 100 0 i 6.6.6.6 MPLS
* i [3]:[200]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
* i [3]:[200]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*> [3]:[200]:[32,5.5.5.5]
5.5.5.5 0 100 32768 i ---------- MPLS
* i [3]:[200]:[32,6.6.6.6]
6.6.6.6 0 100 0 i 6.6.6.6 MPLS
RD[6.6.6.6:100]
*>i [2]:[0]:[100]:[48,0077:8899:5566]:[32,80.80.1.3]:[17]
6.6.6.6 0 100 0 i 6.6.6.6 MPLS
*>i [3]:[100]:[32,6.6.6.6]
6.6.6.6 0 100 0 i 6.6.6.6 MPLS
RD[6.6.6.6:200]
*>i [2]:[0]:[200]:[48,0077:8899:5566]:[32,90.90.1.3]:[18]
6.6.6.6 0 100 0 i 6.6.6.6 MPLS
*>i [3]:[200]:[32,6.6.6.6]
6.6.6.6 0 100 0 i 6.6.6.6 MPLS
Total number of prefixes 38
SH-1#
SH-1#sh bgp l2vpn evpn prefix-route
RD[30:200]
ESI Eth-Tag Prefix-Length IP-Address GW-IPAddress L3VNID/LABEL Nexthop Encap Router-Mac
0 0 24 80.80.1.0 0.0.0.0 16 6.6.6.6 MPLS e8c5:7aff:96de
0 0 24 90.90.1.0 0.0.0.0 16 6.6.6.6 MPLS e8c5:7aff:96de
SH-1#
SH-1#sh bgp l2vpn evpn summary
BGP router identifier 5.5.5.5, local AS number 65010
BGP table version is 10
1 BGP AS-PATH entries
0 BGP community entries
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd AD MACIP MCAST ESI PREFIX-ROUTE
2.2.2.2 4 65010 407 379 9 0 0 01:44:58 6 3 0 2 1 0
3.3.3.3 4 65010 416 390 8 0 0 01:55:55 8 3 2 2 1 0
6.6.6.6 4 65010 399 396 7 0 0 02:04:33 6 0 2 2 0 2
Total number of neighbors 3
Total number of Established sessions 3
SH-1#
SH-1#sh mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN, ! - using backup
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
(m) - FTN mapped over multipath transport, (e) - FTN is ECMP
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 2.2.2.2/32 4 2
1 - Yes LSP_DEFAULT 25601 xe6 No 30.30.30.2
L> 3.3.3.3/32 7 40
39 - Yes LSP_DEFAULT 25607 xe6 No 30.30.30.2
L> 4.4.4.4/32 2 35
7 - Yes LSP_DEFAULT 3 xe6 No 30.30.30.2
L> 6.6.6.6/32 3 37
36 - Yes LSP_DEFAULT 25603 xe6 No 30.30.30.2
L> 10.10.10.0/24 1 35
7 - Yes LSP_DEFAULT 3 xe6 No 30.30.30.2
L> 20.20.20.0/24 6 35
7 - Yes LSP_DEFAULT 3 xe6 No 30.30.30.2
L> 40.40.40.0/24 5 35
7 - Yes LSP_DEFAULT 3 xe6 No 30.30.30.2
SH-1#
SH-1#sh ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
2.2.2.2 xe6 Active OPERATIONAL 30 01:44:53
3.3.3.3 xe6 Active OPERATIONAL 30 01:55:35
6.6.6.6 xe6 Passive OPERATIONAL 30 01:57:21
4.4.4.4 xe6 Active OPERATIONAL 30 01:57:21
SH-1#
SH-1#sh ip ospf neighbor
Total number of full neighbors: 1
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
4.4.4.4 1 Full/Backup 00:00:31 30.30.30.2 xe6 0
SH-1#
SH-2:
SH-2#sh evpn mpls
EVPN-MPLS Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
VPN-ID EVI-Name EVI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
_______________________________________________________________________________________________________________________________
100 ---- L2 NW ---- ---- ---- ---- 6.6.6.6 3.3.3.3
100 ---- L2 NW ---- ---- ---- ---- 6.6.6.6 2.2.2.2
100 ---- L2 NW ---- ---- ---- ---- 6.6.6.6 5.5.5.5
200 ---- L2 NW ---- ---- ---- ---- 6.6.6.6 3.3.3.3
200 ---- L2 NW ---- ---- ---- ---- 6.6.6.6 2.2.2.2
200 ---- L2 NW ---- ---- ---- ---- 6.6.6.6 5.5.5.5
Total number of entries are 6
SH-2#
SH-2#sh evpn mpls tunnel
EVPN-MPLS Network tunnel Entries
Source Destination Status Up/Down Update evpn-id
===================================================================================
6.6.6.6 3.3.3.3 Installed 01:57:22 01:57:22 200
6.6.6.6 3.3.3.3 Installed 01:57:22 01:57:22 100
6.6.6.6 2.2.2.2 Installed 01:46:26 01:46:26 200
6.6.6.6 2.2.2.2 Installed 01:46:26 01:46:26 100
6.6.6.6 5.5.5.5 Installed 01:58:49 01:58:49 200
6.6.6.6 5.5.5.5 Installed 01:58:49 01:58:49 100
Total number of entries are 6
SH-2#
SH-2#sh evpn mpls mac-table
=========================================================================================================================================
EVPN MPLS MAC Entries
=========================================================================================================================================
VNID Interface VlanId In-VlanId Mac-Addr VTEP-Ip/ESI Type Status MAC move AccessPortDesc
_________________________________________________________________________________________________________________________________________
100 irb100 ---- ---- 0077.8899.5566 6.6.6.6 Static Local ------- 0 -------
100 ---- ---- ---- 0010.9400.0001 00:00:00:11:11:aa:aa:00:00:00 Dynamic Remote ------- 0 -------
200 irb200 ---- ---- 0077.8899.5566 6.6.6.6 Static Local ------- 0 -------
200 ---- ---- ---- 0010.9400.0005 5.5.5.5 Dynamic Remote ------- 0 -------
Total number of entries are : 4
SH-2#
SH-2#sh evpn mpls arp-cache
MPLS-EVPN ARP-CACHE Information
===============================
ARP Timeout : 300 sec Random-Jitter-Max : 200
EVPN-ID Ip-Addr Mac-Addr Type Age-Out Retries-Left
_____________________________________________________________________________
100 80.80.1.2 0010.9400.0001 Dynamic Remote ----
100 80.80.1.3 0077.8899.5566 Static Local ----
200 90.90.1.3 0077.8899.5566 Static Local ----
200 90.90.1.4 0010.9400.0005 Dynamic Remote ----
Total number of entries are 4
SH-2#
SH-2#show bgp l2vpn evpn multihoming ethernet-ad-per-es
RD[2.2.2.2:64512]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 16 2.2.2.2 MPLS
RD[3.3.3.3:64512]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 16 3.3.3.3 MPLS
RD[6.6.6.6:100] VRF[red]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 16 2.2.2.2 MPLS
00:00:00:11:11:aa:aa:00:00:00 4294967295 16 3.3.3.3 MPLS
RD[6.6.6.6:200] VRF[blue]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 16 2.2.2.2 MPLS
00:00:00:11:11:aa:aa:00:00:00 4294967295 16 3.3.3.3 MPLS
SH-2#
SH-2#show bgp l2vpn evpn multihoming ethernet-ad-per-evi
RD[2.2.2.2:100]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 100 17 2.2.2.2 MPLS
RD[2.2.2.2:200]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 200 18 2.2.2.2 MPLS
RD[3.3.3.3:100]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 100 17 3.3.3.3 MPLS
RD[3.3.3.3:200]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 200 18 3.3.3.3 MPLS
RD[6.6.6.6:100] VRF[red]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 100 17 2.2.2.2 MPLS
00:00:00:11:11:aa:aa:00:00:00 100 17 3.3.3.3 MPLS
RD[6.6.6.6:200] VRF[blue]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 200 18 2.2.2.2 MPLS
00:00:00:11:11:aa:aa:00:00:00 200 18 3.3.3.3 MPLS
SH-2#
SH-2#sh evpn mpls label esi
S - Self
R - Remote
ESI PE-IP-ADDRESS ESI-LABEL
================================================================
00:00:00:11:11:aa:aa:00:00:00 2.2.2.2(R) 16
00:00:00:11:11:aa:aa:00:00:00 3.3.3.3(R) 16
SH-2#
SH-2#sh evpn mpls label alias
S - Self
R - Remote
ESI PE-IP-ADDRESS TENANT ALIAS-LABEL
=============================================================================================
00:00:00:11:11:aa:aa:00:00:00 2.2.2.2(R) 100 17
00:00:00:11:11:aa:aa:00:00:00 2.2.2.2(R) 200 18
00:00:00:11:11:aa:aa:00:00:00 3.3.3.3(R) 100 17
00:00:00:11:11:aa:aa:00:00:00 3.3.3.3(R) 200 18
SH-2#
SH-2#sh bgp l2vpn evpn
BGP table version is 9, local router ID is 6.6.6.6
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
[EVPN route type]:[ESI]:[VNID]:[relevent route informantion]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
Network Next Hop Metric LocPrf Weight Path Peer Encap
RD[2.2.2.2:100]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[17]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*>i [3]:[100]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
RD[2.2.2.2:200]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[200]:[18]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*>i [3]:[200]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
RD[2.2.2.2:64512]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[4294967295]:[0]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
*>i [4]:[00:00:00:11:11:aa:aa:00:00:00]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
RD[3.3.3.3:100]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[17]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*>i [2]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[48,0010:9400:0001]:[0]:[17]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*>i [2]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[48,0010:9400:0001]:[32,80.80.1.2]:[17]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*>i [3]:[100]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
RD[3.3.3.3:200]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[200]:[18]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*>i [3]:[200]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
RD[3.3.3.3:64512]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[4294967295]:[0]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*>i [4]:[00:00:00:11:11:aa:aa:00:00:00]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
RD[5.5.5.5:100]
*>i [3]:[100]:[32,5.5.5.5]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
RD[5.5.5.5:200]
*>i [2]:[0]:[200]:[48,0010:9400:0005]:[0]:[641]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
*>i [2]:[0]:[200]:[48,0010:9400:0005]:[32,90.90.1.4]:[641]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
*>i [3]:[200]:[32,5.5.5.5]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
RD[6.6.6.6:100] VRF[red]:
* i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[17]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
* i 3.3.3.3 0 100 0 i 3.3.3.3 MPLS
* i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[4294967295]:[0]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
* i 3.3.3.3 0 100 0 i 3.3.3.3 MPLS
* i [2]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[48,0010:9400:0001]:[0]:[17]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
* i [2]:[00:00:00:11:11:aa:aa:00:00:00]:[100]:[48,0010:9400:0001]:[32,80.80.1.2]:[17]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
*> [2]:[0]:[100]:[48,0077:8899:5566]:[32,80.80.1.3]:[17]
6.6.6.6 0 100 32768 i ---------- MPLS
* i [3]:[100]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
* i [3]:[100]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
* i [3]:[100]:[32,5.5.5.5]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
*> [3]:[100]:[32,6.6.6.6]
6.6.6.6 0 100 32768 i ---------- MPLS
RD[6.6.6.6:200] VRF[blue]:
* i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[200]:[18]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
* i 3.3.3.3 0 100 0 i 3.3.3.3 MPLS
* i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[4294967295]:[0]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
* i 3.3.3.3 0 100 0 i 3.3.3.3 MPLS
* i [2]:[0]:[200]:[48,0010:9400:0005]:[0]:[641]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
* i [2]:[0]:[200]:[48,0010:9400:0005]:[32,90.90.1.4]:[641]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
*> [2]:[0]:[200]:[48,0077:8899:5566]:[32,90.90.1.3]:[18]
6.6.6.6 0 100 32768 i ---------- MPLS
* i [3]:[200]:[32,2.2.2.2]
2.2.2.2 0 100 0 i 2.2.2.2 MPLS
* i [3]:[200]:[32,3.3.3.3]
3.3.3.3 0 100 0 i 3.3.3.3 MPLS
* i [3]:[200]:[32,5.5.5.5]
5.5.5.5 0 100 0 i 5.5.5.5 MPLS
*> [3]:[200]:[32,6.6.6.6]
6.6.6.6 0 100 32768 i ---------- MPLS
Total number of prefixes 36
SH-2#
SH-2#sh bgp l2vpn evpn prefix-route
SH-2#
SH-2#sh bgp l2vpn evpn summary
BGP router identifier 6.6.6.6, local AS number 65010
BGP table version is 9
1 BGP AS-PATH entries
0 BGP community entries
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd AD MACIP MCAST ESI PREFIX-ROUTE
2.2.2.2 4 65010 410 398 8 0 0 01:46:28 6 3 0 2 1 0
3.3.3.3 4 65010 422 402 7 0 0 01:57:25 8 3 2 2 1 0
5.5.5.5 4 65010 391 406 5 0 0 02:06:03 4 0 2 2 0 0
Total number of neighbors 3
Total number of Established sessions 3
SH-2#
SH-2#sh ip bgp vrf evpn_anycast
BGP table version is 1, local router ID is 90.90.1.3
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 80.80.1.0/24 0.0.0.0 0 100 32768 ?
*> 90.90.1.0/24 0.0.0.0 0 100 32768 ?
Total number of prefixes 2
SH-2#
SH-2#sh mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN, ! - using backup
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
(m) - FTN mapped over multipath transport, (e) - FTN is ECMP
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 2.2.2.2/32 4 3
2 - Yes LSP_DEFAULT 25604 xe14 No 40.40.40.2
L> 3.3.3.3/32 7 41
40 - Yes LSP_DEFAULT 25608 xe14 No 40.40.40.2
L> 4.4.4.4/32 3 39
11 - Yes LSP_DEFAULT 3 xe14 No 40.40.40.2
L> 5.5.5.5/32 1 34
33 - Yes LSP_DEFAULT 25602 xe14 No 40.40.40.2
L> 10.10.10.0/24 2 39
11 - Yes LSP_DEFAULT 3 xe14 No 40.40.40.2
L> 20.20.20.0/24 6 39
11 - Yes LSP_DEFAULT 3 xe14 No 40.40.40.2
L> 30.30.30.0/24 5 39
11 - Yes LSP_DEFAULT 3 xe14 No 40.40.40.2
SH-2#
SH-2#sh ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
2.2.2.2 xe14 Active OPERATIONAL 30 01:46:21
3.3.3.3 xe14 Active OPERATIONAL 30 01:57:03
5.5.5.5 xe14 Active OPERATIONAL 30 01:58:50
4.4.4.4 xe14 Active OPERATIONAL 30 01:58:50
SH-2#
SH-2#sh ip ospf neighbor
Total number of full neighbors: 1
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
4.4.4.4 1 Full/Backup 00:00:30 40.40.40.2 xe14 0
SH-2#
SH-2#sh nvo vxlan l3vni-map
L3VNI L2VNI IRB-interface
===================================
10000 100 irb100
10000 200 irb200
SH-2#
P1:
P1#sh ip ospf neighbor
Total number of full neighbors: 4
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
2.2.2.2 1 Full/Backup 00:00:35 10.10.10.1 xe4.1 0
3.3.3.3 1 Full/Backup 00:00:37 20.20.20.1 xe1 0
5.5.5.5 1 Full/DR 00:00:38 30.30.30.1 xe6 0
6.6.6.6 1 Full/DR 00:00:36 40.40.40.1 xe10 0
P1#
P1#sh ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
3.3.3.3 xe1 Active OPERATIONAL 30 01:58:40
2.2.2.2 xe4.1 Active OPERATIONAL 30 01:47:32
5.5.5.5 xe6 Passive OPERATIONAL 30 02:00:03
6.6.6.6 xe10 Passive OPERATIONAL 30 02:00:03
P1#
P1#sh mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN, ! - using backup
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
(m) - FTN mapped over multipath transport, (e) - FTN is ECMP
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
L> 2.2.2.2/32 2 2
1 - Yes LSP_DEFAULT 3 xe4.1 No 10.10.10.1
L> 3.3.3.3/32 4 47
46 - Yes LSP_DEFAULT 3 xe1 No 20.20.20.1
L> 5.5.5.5/32 1 38
37 - Yes LSP_DEFAULT 3 xe6 No 30.30.30.1
L> 6.6.6.6/32 3 44
43 - Yes LSP_DEFAULT 3 xe10 No 40.40.40.1
P1#