OcNOS-SP : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : EVPN MPLS IRB Configuration : EVPN MPLS IRB Symmetric with Host Routes
EVPN MPLS IRB Symmetric with Host Routes
Overview
EVPN-IRB facilitates communication between two L2VNI’s with the help of Routing using IP-VRF. This features provides the Host (/32 or /128) based Symmetric IRB support which forwards the inter-subnet traffic directly towards the host (CEs) attached to VTEP (PEs).
Host based Symmetric IRB support is two modes: interface-full and interface-less.
Interface-full mode refers to configuring of IRB interface
Interface-less mode refers to configuring the access interface as L3 interface and using the IRB configuration. IRB interface is not used in this case.
Interface-full mode supports “evpn irb-advertise-host-route” CLI under evpn mpls id <id>.
Interface-less mode supports both “evpn irb-advertise-host-route” CLI under evpn mpls id <id> and “redistribute-connected-host-routes” under bgp vrf address family.
Host based Symmetric IRB support is achieved through one of the modes:
“evpn irb-advertise-host-route” in interface-full mode (with IRB interface“)
evpn irb-advertise-host-route” in interface-less mode (without IRB interface)
“redistribute-connected-host-routes” in interface-less mode (without IRB interface)
Topology
Figure 26-6 depicts the EVPN MPLS IRB with LDP as underlay MPLS path.
Figure 26-6: Host based symmetric IRB support
PE1
Enable EVPN MPLS and IRB
 
#configure terminal
Enter configuration mode.
(config)#evpn mpls enable
Enable EVPN MPLS globally.
(config)#evpn mpls irb
Enable EVPN MPLS IRB globally.
Loopback Interface
 
(config-if)#interface lo
Enter the Interface mode for the loopback interface.
(config-if)# ip address 20.20.20.20/32 secondary
Configure IP address on loopback interface.
(config-if)#exit
Exit interface mode.
Configure MAC VRF:
 
(config)#mac vrf green
Create MAC VRF mvrf4.
(config-vrf)# rd 20.20.20.20:400
Configure route distinguisher.
(config-vrf)# route-target both 65010:400
Configure route target as evpn auto route target (it can be configured as manual RT).
(config-vrf)#exit
Exit VRF mode.
Configure IP VRF:
 
(config)#ip vrf vrf400
Configure IP VRF vrf100.
(config-vrf)# rd 30:400
Configure route distinguisher
(config-vrf)# route-target both 100:400
Configure route target
(config-vrf)# l3vni 40000
Configure L3 VNID for routing
(config-vrf)#exit
Exit VRF mode
Configure anycast gateway MAC:
 
(config)#evpn irb-forwarding anycast-gateway-mac 0011.2233.5577
Configure anycast gateway MAC globally.
Configuring IRB interface:
 
(config)#interface irb400
Create IRB interface irb100.
(config-irb-if)# ip vrf forwarding vrf400
Map L3 VRF to the IRB interface.
(config-irb-if)# ip address 40.40.1.1/24
Assign IP address.
(config-irb-if)# ipv6 address 5001::1/48
Assign IPv6 address.
(config-irb-if)# evpn irb-if-forwarding anycast-gateway-mac
Map anycast gateway MAC.
(config-irb-if)#exit
Exit interface mode.
Creating EVPN MPLS ID:
 
(config)#evpn mpls vtep-ip-global 20.20.20.20
Configure VTEP global IP.
(config)#evpn mpls id 400
Create EVPN MPLS ID.
(config-evpn-mpls)# host-reachability-protocol evpn-bgp green
Map the MAC VRF mvrf4.
(config-evpn-mpls)# evpn irb irb400
Map the IRB interface.
(config-evpn-mpls)# evpn irb-advertise-host-route
Set host to route advertise.
(config-evpn-mpls)#exit
Exit the EVPN MPLS mode.
Global LDP
 
(config)#router ldp
Enter the Router LDP mode.
(config-router)# router-id 20.20.20.20
Set router ID of LDP.
(config-router)# targeted-peer ipv4 17.17.17.17
Configure targeted peer.
(config-router-targeted-peer)# exit
Exit from targeted-peer mode.
(config-router)# transport-address ipv4 20.20.20.20
Configure LDP transport address.
(config-router)#exit
Exit from LDP mode.
Interface Configuration Network Side
 
(config)#interface xe18
Configure physical interface.
(config-if)# mtu 9216
Configure MTU on the interface.
(config-if)# load-interval 30
Set load interval.
(config-if)# ip address 55.55.55.1/24
Assign IP address.
(config-if)# label-switching
Enable label switching.
(config-if)# isis network point-to-point
Configure isis as point-to-point network.
(config-if)# enable-ldp ipv4
Enable LDP IPv4.
(config-if)# ip router isis ISIS-IGP
Enable a routing process.
(config-if)#exit
Exit interface mode.
(config-if)# router isis ISIS-IGP
Enter the Router ISIS mode.
(config-router)# is-type level-1
IS Level for this routing process.
(config-router)# mpls traffic-eng router-id 20.20.20.20
Routing protocol commands for MPLS Traffic Engineering.
(config-router)# net 49.0001.0000.0000.0001.00
Configure net.
(config-router)#exit
Exit OSPF mode.
BGP Configuration
 
(config)#router bgp
Enter the Router BGP mode, ASN: 100
(config-router)# neighbor 11.11.11.11 remote-as 65010
Configuring PE3 as I-BGP neighbor using it's loopback IP
(config-router)# neighbor 11.11.11.11 update-source lo
Source of routing updates as loopback
(config-router)# neighbor 22.22.22.22 remote-as 65010
Configuring PE2 as I-BGP neighbor using it's loopback IP
(config-router)# neighbor 22.22.22.22 update-source lo
Source of routing updates as loopback
(config-router)# neighbor 17.17.17.17 remote-as 65010
Configuring PE3 as I-BGP neighbor using it's loopback IP
(config-router)# neighbor 22.22.22.22 update-source lo
Source of routing updates as loopback
(config-router)# address-family l2vpn evpn
Entering into address family mode as EVPN
(config-router-af)# neighbor 11.11.11.11 activate
Enabling EVPN Address family for neighbor
(config-router-af)# neighbor 22.22.22.22 activate
Enabling EVPN Address family for neighbor
(config-router-af)# neighbor 17.17.17.17 activate
Enabling EVPN Address family for neighbor
(config-router-af)# exit-address-family
Exiting of Address family mode
(config-router)# address-family ipv4 vrf vrf400
Entering into VRF address family mode
(config-router-af)# redistribute connected
Redistribute connected routes to the network
(config-router-af)# exit-address-family
Exiting of Address family mode
Access Port Configuration:
 
(config)# interface xe26
Configure physical interface
(config-if)# static-channel-group 10000
Create static channel group
(config-if)# exit
Exit interface mode
(config)# interface sa10000
Configure Static channel sa10000
(config-if)# switchport
Make it L2 interface
(config-if)# load-interval 30
Set load interval
(config-if)# mtu 9216
Configure MTU on the interface.
(config)# exit
Exit interface mode
(config)# interface sa10000.400 switchport
Configure static sub-interface
(config-if)# encapsulation dot1q 701
Configure encapsulation
(config-ig)# rewrite pop
Pop the outer VID
(config-if)# access-if-evpn
Entering Access mode for EVPN MPLS ID configuration
(config-acc-if-evpn)# map vpn-id 400
Map VPN-ID 400
(config-acc-if-evpn)# mac 0000.0000.aaaa ip 40.40.1.10
Configure static mac with IP
(config-acc-if-evpn)# mac 0000.0000.bbbb ipv6 5001:aaaa::1
Configure static mac with IPv6
(config-acc-if-evpn)#exit
Exiting out of access interface mode
PE2
Enable EVPN MPLS and IRB:
 
#configure terminal
Enter configuration mode.
(config)#evpn mpls enable
Enable EVPN MPLS globally
(config)#evpn mpls irb
Enable EVPN MPLS IRB globally
Loopback Interface
 
(config-if)#interface lo
Enter the Interface mode for the loopback interface.
(config-if)# ip address 22.22.22.22/32 secondary
Configure IP address on loopback interface.
(config-if)#exit
Exit interface mode
Configure MAC VRF
 
(config)#mac vrf green
Create MAC VRF mvrf4.
(config-vrf)# rd 22.22.22.22:400
Configure route distinguisher
(config-vrf)# route-target both 65010:400
Configure route target as evpn auto route target (we can configure as manual RT also)
(config-vrf)#exit
Exit VRF mode
Configure IP VRF
 
(config)#ip vrf vrf400
Configure IP VRF vrf100.
(config-vrf)# rd 40:400
Configure route distinguisher
(config-vrf)# route-target both 100:400
Configure route target
(config-vrf)# l3vni 40000
Configure L3 VNID for routing
(config-vrf)#exit
Exit VRF mode
Configure anycast gateway MAC
 
(config)#evpn irb-forwarding anycast-gateway-mac 0011.2233.5577
Configure anycast gateway MAC globally
Configuring IRB interface
 
(config)#interface irb400
Create IRB interface irb100
(config-irb-if)# ip vrf forwarding vrf400
Map L3 VRF to the IRB interface
(config-irb-if)# ip address 40.40.1.1/24
Assign IP address
(config-irb-if)# ipv6 address 5001::1/48
Assign IPv6 address
(config-irb-if)# evpn irb-if-forwarding anycast-gateway-mac
Map anycast gateway MAC
(config-irb-if)#exit
Exit interface mode
Creating EVPN MPLS ID:
 
(config)#evpn mpls vtep-ip-global 22.22.22.22
Configure VTEP global IP
(config)#evpn mpls id 400
Create EVPN MPLS ID
(config-evpn-mpls)# host-reachability-protocol evpn-bgp green
Map the MAC VRF mvrf4
(config-evpn-mpls)# evpn irb irb400
Map the IRB interface
(config-evpn-mpls)# evpn irb-advertise-host-route
Set host to route advertise
(config-evpn-mpls)#exit
Exit the EVPN MPLS mode
Global LDP
 
(config)#router ldp
Enter the Router LDP mode.
(config-router)# router-id 22.22.22.22
Set router ID of LDP
(config-router)# targeted-peer ipv4 17.17.17.17
Configure targeted peer
(config-router)# targeted-peer ipv4 11.11.11.11
Configure targeted peer
(config-router-targeted-peer)# exit
Exit from targeted-peer mode
(config-router)# transport-address ipv4 22.22.22.22
Configure LDP transport address
(config-router)#exit
Exit from LDP mode
Interface Configuration Network Side
 
(config)#interface xe19
Configure physical interface
(config-if)# mtu 9216
Configure MTU on the interface.
(config-if)# load-interval 30
Set load interval
(config-if)# ip address 30.30.30.1/24
Assign IP address
(config-if)# label-switching
Enable label switching
(config-if)# isis network point-to-point
Configure isis as point-to-point network
(config-if)# enable-ldp ipv4
Enable LDP IPv4
(config-if)# ip router isis ISIS-IGP
Enable a routing process
(config-if)#exit
Exit interface mode
(config-if)# router isis ISIS-IGP
Enter the Router ISIS mode.
(config-router)# is-type level-1
IS Level for this routing process
(config-router)# mpls traffic-eng router-id 22.22.22.22
routing protocol commands for MPLS Traffic Engineering
(config-router)# net 49.0001.0000.0000.0006.00
Configure net
(config-router)#exit
Exit OSPF mode
BGP Configuration
 
(config)#router bgp
Enter the Router BGP mode, ASN: 100
(config-router)# neighbor 11.11.11.11 remote-as 65010
Configuring PE3 as I-BGP neighbor using it's loopback IP
(config-router)# neighbor 11.11.11.11 update-source lo
Source of routing updates as loopback
(config-router)# neighbor 20.20.20.20 remote-as 65010
Configuring PE2 as I-BGP neighbor using it's loopback IP
(config-router)# neighbor 20.20.20.20 update-source lo
Source of routing updates as loopback
(config-router)# neighbor 17.17.17.17 remote-as 65010
Configuring PE3 as I-BGP neighbor using it's loopback IP
(config-router)# neighbor 17.17.17.17 update-source lo
Source of routing updates as loopback
(config-router)# address-family l2vpn evpn
Entering into address family mode as EVPN
(config-router-af)# neighbor 11.11.11.11 activate
Enabling EVPN Address family for neighbor
(config-router-af)# neighbor 22.22.22.22 activate
Enabling EVPN Address family for neighbor
(config-router-af)# neighbor 17.17.17.17 activate
Enabling EVPN Address family for neighbor
(config-router-af)# exit-address-family
Exiting of Address family mode
(config-router)# address-family ipv4 vrf vrf400
Entering into VRF address family mode
(config-router-af)# redistribute connected
Redistribute connected routes to the network
(config-router-af)# exit-address-family
Exiting of Address family mode
Access Port Configuration
 
(config)# interface xe12.400 switchport
Configure static sub-interface
(config-if)# encapsulation dot1q 400
Configure encapsulation
(config-ig)# rewrite pop
Pop the outer VID
(config-if)# access-if-evpn
Entering Access mode for EVPN MPLS ID configuration
(config-acc-if-evpn)# map vpn-id 400
Map VPN-ID 400
(config-acc-if-evpn)# mac 0000.0000.aabb ip 40.40.1.20
Configure static mac with IP
(config-acc-if-evpn)# mac 0000.0000.bbaa ipv6 5001::20
Configure static mac with IPv6
(config-acc-if-evpn)#exit
Exiting out of access interface mode
P1
Loopback Interface:
 
#configure terminal
Enter configuration mode.
(config-if)#interface lo
Enter the Interface mode for the loopback interface.
(config-if)# ip address 24.24.24.24/32 secondary
Configure IP address on loopback interface.
(config-if)#exit
Exit interface mode
Global LDP
 
(config)#router ldp
Enter the Router LDP mode.
(config-router)# router-id 24.24.24.24
Configure router id
(config-router)# transport-address ipv4 24.24.24.24
Configure transport address
Interface Configuration
 
(config)#interface xe2
Configure physical interface
(config-if)# mtu 9216
Configure MTU on the interface.
(config-if)# load-interval 30
Set load interval
(config-if)# ip address 30.30.30.2/24
Assign IP address
(config-if)# label-switching
Enable label switching
(config-if)# isis network point-to-point
Configure isis as point-to-point network
(config-if)# enable-ldp ipv4
Enable LDP IPv4
(config-if)#exit
Exit interface mode
(config)#interface xe18
Configure physical interface
(config-if)# mtu 9216
Configure MTU on the interface.
(config-if)# load-interval 30
Set load interval
(config-if)# ip address 55.55.55.2/24
Assign IP address
(config-if)# label-switching
Enable label switching
(config-if)# isis network point-to-point
Configure isis as point-to-point network
(config-if)# enable-ldp ipv4
Enable LDP IPv4
(config-if)#exit
Exit interface mode
(config)#interface xe40
Configure physical interface
(config-if)# mtu 9216
Configure MTU on the interface.
(config-if)# load-interval 30
Set load interval
(config-if)# ip address 76.76.76.2/24
Enter interface mode xe40
(config-if)# label-switching
Set label switching
(config-if)# isis network point-to-point
Set routing protocol isis
(config-if)# enable-ldp ipv4
Enable ldp
(config-if)#exit
Exit interface mode
(config-if)# mtu 1522
Configure MTU on the interface.
(config-if)#exit
Exit interface mode.
(config)# interface xe11
Create po subinterface
(config-if)# ip address 60.60.60.2/24
Assign IP address
(config-if)# mtu 9216
Configure MTU to the sub-if
(config-if)# label-switching
Enable label switching
(config-if)# enable-ldp ipv4
Enable LDP IPv4
(config-if)# isis network point-to-point
Set routing protocol isis
(config-if)#exit
Exit interface mode
ISIS Configuration
 
(config)#router isis ISIS-IGP
Enter the Router IsIs mode.
(config-router)# is-type level-1
IS Level for this routing process
(config-router)# mpls traffic-eng router-id 24.24.24.24
routing protocol commands for MPLS Traffic Engineering
(config-router)# net 49.0001.0000.0000.0003.00
Configure net
(config-router)#exit
Exit Router isis mode and return to Configure mode.
(config)#commit
Commit candidate configuration to be running configuration
PE3
Enable EVPN MPLS and IRB
 
#configure terminal
Enter configuration mode.
(config)#hardware-profile filter evpn-mpls-mh enable
Configure hardware profile to enable EVPN MPLS multi homing in hardware
(config)#evpn mpls enable
Enable EVPN MPLS globally
(config)#evpn mpls irb
Enable EVPN MPLS IRB globally
(config)#evpn mpls multihoming enable
Enable EVPN MPLS multihoming globally
Loopback Interface
 
(config-if)#interface lo
Enter the Interface mode for the loopback interface.
(config-if)# ip address 11.11.11.11/32 secondary
Configure IP address on loopback interface.
(config-if)#exit
Exit interface mode
Configure MAC VRF
 
(config-vrf)#mac vrf green
Create MAC VRF mvrf4.
(config-vrf)# rd 11.11.11.11:400
Configure route distinguisher
(config-vrf)# route-target both 65010:400
Configure route target as evpn auto-rt(we can configure as manual RT also)
(config-vrf)#exit
Exit VRF mode
Configure IP VRF
 
(config)#ip vrf vrf400
Configure IP VRF vrf100.
(config-vrf)# rd 20:400
Configure route distinguisher
(config-vrf)# route-target both 100:400
Configure route target
(config-vrf)# l3vni 40000
Configure L3 VNID for routing
(config-vrf)#exit
Exit VRF mode
Configure Anycast Gateway MAC
 
(config)#evpn irb-forwarding anycastgateway-
mac 0011.2233.4455
Configure anycast gateway MAC globally
(config)#interface irb500
Create IRB interface irb100
(config-irb-if)# ip vrf forwarding vrf400
Map L3 VRF to the IRB interface
(config-irb-if)# ip address 80.80.1.1/24
Assign IP address
(config-irb-if)# evpn irb-if-forwarding
anycast-gateway-mac
Map anycast gateway MAC
(config-irb-if)#exit
Exit interface mode
Creating EVPN MPLS ID
 
(config)#evpn mpls vtep-ip-global 11.11.11.11
Configure VTEP global IP
(config)#evpn mpls id 500
Create EVPN MPLS ID
(config-evpn-mpls)# host-reachability-protocol evpn-bgp green
Map the MAC VRF mvrf4
(config-evpn-mpls)# evpn irb irb500
Map the IRB interface
(config-evpn-mpls)#exit
Exit the EVPN MPLS mode
Global LDP
 
(config)#router ldp
Enter the Router LDP mode
(config-router)# transport-address ipv4
11.11.11.11
Configure LDP transport address
(config-router)#exit
Exit from LDP mode
Interface Configuration Network Side
 
(config-if)#interface xe27
Enter the Interface mode for eth10.
(config-if)# mtu 9216
Configure MTU.
(config-if)# enable-ldp ipv4
Enable LDP on the physical interface
(config-if)# ip address ip address 76.76.76.1/24
Assign IP address
(config-if)# mtu 1522
Configure MTU to the sub-if
(config-if)# label-switching
Enable label switching
(config-if)# isis network point-to-point
Configure isis as point-to-point network
(config-if)# router isis ISIS-IGP
Configure isis with ISIS-IGP area tag
(config-if)# exit
Exit interface mode
ISIS Configuration
 
(config)# router isis ISIS-IGP
Enter the Router ISIS mode.
(config-router)# is-type level-1
IS Level for this routing process
(config-router)# mpls traffic-eng router-id 11.11.11.11
Routing protocol commands for MPLS Traffic Engineering
(config-router)# net 49.0001.0000.0000.0005.00
Configure net
BGP Configuration
 
(config-router)# router bgp 65010
Enter the Router BGP mode, ASN: 65010
(config-router)# neighbor 20.20.20.20 remote-as 65010
Configuring PE1 as iBGP neighbor using it's loopback IP
(config-router)# neighbor 20.20.20.20 update-source
lo
Source of routing updates as loopback
(config-router)# neighbor 22.22.22.22 remote-as
65010
Configuring PE2 as iBGP neighbor using it's loopback IP
(config-router)# neighbor 22.22.22.22 update-source lo
lo
Source of routing updates as loopback
(config-router)# address-family l2vpn evpn
Entering into address family mode as EVPN
(config-router-af)# neighbor 20.20.20.20
activate
Enabling EVPN Address family for neighbor
(config-router-af)# neighbor 22.22.22.22
activate
Enabling EVPN Address family for neighbor
(config-router-af)# exit-address-family
Exiting of Address family mode
(config-router)# address-family ipv4 vrf
Vrf400
Entering into VRF address family mode
(config-router-af)# redistribute connected
Redistribute connected routes to the network
(config-router-af)# exit-address-family
Exiting of Address family mode
Access Port Configuration
 
(config)#interface po900
Create LAG interface po900
(config-if)# switchport
Configure as switchport
(config-if)# evpn multi-homed system-mac 0000.1111.aaaa
Configure system MAC for multi homing
(config)#interface po900.500 switchport
Creating L2 sub interface of physical interface xe28
(config-if)# encapsulation dot1q 500
Setting Encapsulation to dot1q with VLAN ID 500
(config-if)# access-if-evpn
Entering Access mode for EVPN MPLS ID configuration
(config-acc-if-evpn)# map vpn-id 500
Map VPN-ID 500
(config-acc-if-evpn)#exit
Exiting out of access interface mode
PE4
Enable EVPN MPLS and IRB
 
#configure terminal
Enter configuration mode.
(config)#hardware-profile filter evpn-mpls-mh enable
Configure hardware profile to enable EVPN MPLS multi
homing in hardware
(config)#evpn mpls enable
Enable EVPN MPLS globally
(config)#evpn mpls irb
Enable EVPN MPLS IRB globally
(config)#evpn mpls multihoming enable
Enable EVPN MPLS multihoming globally
Loopback Interface
 
(config-if)#interface lo
Enter the Interface mode for the loopback interface
(config-if)# ip address 17.17.17/32 secondary
Configure IP address on loopback interface.
(config-if)#exit
Exit interface mode
Configure MAC VRF
 
(config-vrf)#mac vrf green
Create MAC VRF mvrf4.
(config-vrf)# rd 17.17.17.17:400
Configure route distinguisher
(config-vrf)# route-target both 65010:400
Configure route target as evpn auto-rt (we can configure as
manual RT also)
(config-vrf)#exit
Exit VRF mode
Configure IP VRF
 
(config)#ip vrf vrf400
Configure IP VRF vrf100.
(config-vrf)# rd 10:400
Configure route distinguisher
(config-vrf)# route-target both 100:400
Configure route target
(config-vrf)# l3vni 40000
Configure L3 VNID for routing
(config-vrf)#exit
Exit VRF mode
Configure Anyc ast Gateway MAC
 
(config)#evpn irb-forwarding anycast-gateway-mac 0011.2233.5577
Configure anycast gateway MAC globally
Configuring IRB interface
 
(config)#interface irb500
Create IRB interface irb100
(config-irb-if)# ip vrf forwarding vrf400
Map L3 VRF to the IRB interface
(config-irb-if)# ip address 80.80.1.1/24
Assign IP address
(config-irb-if)# evpn irb-if-forwarding
anycast-gateway-mac
Map anycast gateway MAC
(config-irb-if)#exit
Exit interface mode
Creating EVPN MPLS ID
 
(config)#evpn mpls vtep-ip-global 17.17.17.17
Configure VTEP global IP
(config)#evpn mpls id 500
Create EVPN MPLS ID
(config-evpn-mpls)# host-reachability-protocol evpn-bgp green
Map the MAC VRF green
(config-evpn-mpls)# evpn irb irb500
Map the IRB interface
(config-evpn-mpls)#exit
Exit the EVPN MPLS mode
Global LDP
 
(config)#router ldp
Enter the Router LDP mode.
(config-router)#router-id 17.17.17.17
Configure lo under ldp
(config-router)#targeted-peer ipv4 20.20.20.20
Configure targeted peer
(config-router-targeted-peer)# exit-targeted-peer-mode
Exit target peer mode
(config-router)# targeted-peer ipv4 22.22.22.22
Configure targeted peer
(config-router-targeted-peer)# exit-targeted-peer-mode
Exit target peer mode
(config-router)# transport-address ipv4
17.17.17.17
Configure LDP transport address
(config-router)#exit
Exit from LDP mode
Interface Configuration Network Side
 
(config-if)#interface xe2
Configure physical interface
(config-if)# ip address 60.60.60.1/24
Assign IP address
(config-if)# mtu 9216
Configure MTU to the sub-if
(config-if)# label-switching
Enable label switching
(config-if)# isis network point-to-point
Configure ISIS as point-to-point network
(config-if)# ip router isis ISIS-IGP
Configure ISIS with area tag ISIS-IGP
(config-if)# enable-ldp ipv4
Enable LDP IPv4
(config-if)#exit
Exit interface mode
ISIS Configuration
 
(config)# router isis ISIS-IGP
Enter the Router OSPF mode.
(config-router)# is-type level-1
Configure routing ISIS level
(config-router)# mpls traffic-eng router-id 17.17.17.17
Routing protocol commands for MPLS Traffic Engineering.
(config-router)# net 49.0001.0000.0000.0004.00
Configure net
BGP Configuration
 
(config)#router bgp 65010
Enter the Router BGP mode, ASN: 100
(config-router)# bgp router-id 17.17.17.17
 
(config-router)# neighbor 20.20.20.20 remote-as 65010
Configuring PE3 as iBGP neighbor using it's loopback IP
(config-router)# neighbor 20.20.20.20 update-source lo
Source of routing updates as loopback
(config-router)# neighbor 22.22.22.22 remote-as 65010
Configuring PE3 as iBGP neighbor using it's loopback IP
(config-router)# neighbor 22.22.22.21 update-source lo
Source of routing updates as loopback
(config-router)# address-family l2vpn evpn
Entering into address family mode as EVPN
(config-router-af)# neighbor 20.20.20.20
activate
Enabling EVPN Address family for neighbor
(config-router-af)# neighbor 22.22.22.22
activate
Enabling EVPN Address family for neighbor
(config-router-af)# exit-address-family
Exiting of Address family mode
(config-router)# address-family ipv4 vrf
Vrf500
Entering into VRF address family mode
(config-router-af)# redistribute connected
Redistribute connected routes to the network
(config-router-af)# exit-address-family
Exiting of Address family mode
Access Port Configuration
 
(config)#interface po900
Create LAG interface po1
(config-if)# switchport
Configure as switchport
(config-if)# evpn multi-homed system-mac
0000.0000.1111
Configure system MAC for multi homing
(config)#interface po900.500 switchport
Creating L2 sub interface of physical interface xe9
(config-if)# encapsulation dot1q 500
Setting Encapsulation to dot1q with VLAN ID 500
(config-if)# access-if-evpn
Entering Access mode for EVPN MPLS ID configuration
(config-acc-if-evpn)# map vpn-id 500
Map VPN-ID 500
(config-acc-if-evpn)#exit
Exiting out of access interface mode
Validation
PE1
SH-1-7020#show evpn mpls tunnel
EVPN-MPLS Network tunnel Entries
Source Destination Status Up/Down Update evpn-id
===================================================================================
20.20.20.20 17.17.17.17 Installed 17:04:56 17:04:56 701
20.20.20.20 17.17.17.17 Installed 17:04:56 17:04:56 700
20.20.20.20 17.17.17.17 Installed 17:04:56 17:04:56 600
20.20.20.20 17.17.17.17 Installed 21:39:09 21:39:09 40000
20.20.20.20 22.22.22.22 Installed 21:39:09 21:39:09 40000
20.20.20.20 22.22.22.22 Installed 13:59:58 13:59:58 400
20.20.20.20 11.11.11.11 Installed 17:04:56 17:04:56 701
20.20.20.20 11.11.11.11 Installed 17:04:56 17:04:56 700
20.20.20.20 11.11.11.11 Installed 17:04:56 17:04:56 600
20.20.20.20 11.11.11.11 Installed 17:04:56 17:04:56 400
20.20.20.20 11.11.11.11 Installed 21:39:09 21:39:09 40000
 
Total number of entries are 11
SH-1-7020#show evpn mpls mac-table
=========================================================================================================================================
EVPN MPLS MAC Entries
=========================================================================================================================================
VNID Interface VlanId In-VlanId Mac-Addr VTEP-Ip/ESI Type Status MAC move AccessPortDesc
_________________________________________________________________________________________________________________________________________
 
400 irb400 ---- ---- 0011.2233.5577 20.20.20.20 Static Local ------- 0 -------
400 sa10000.400 ---- ---- 0000.0000.aaaa 20.20.20.20 Static Local ------- 0 -------
400 sa10000.400 ---- ---- 0000.0000.bbbb 20.20.20.20 Static Local ------- 0 -------
 
Total number of entries are: 3
SH-1-7020#show evpn mpls arp-cache
MPLS-EVPN ARP-CACHE Information
===============================
EVPN-ID Ip-Addr Mac-Addr Type Age-Out Retries-Left
_____________________________________________________________________________
400 40.40.1.1 0011.2233.5577 Static Local ----
400 40.40.1.10 0000.0000.aaaa Static Local ----
Total number of entries are 2
SH-1-7020#show evpn mpls nd-cache
MPLS-EVPN ND-CACHE Information
==============================
EVPN-ID Ip-Addr Mac-Addr Type Age-Out Retries-Left
_____________________________________________________________________________________________
400 5001::1 0011.2233.5577 Static Local ----
400 5001:aaaa::1 0000.0000.bbbb Static Local ----
Total number of entries are 2
SH-1-7020#show bgp l2vpn evpn multihoming ethernet-ad-per-es
 
RD[11.11.11.11:64512]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 38 11.11.11.11 MPLS
 
RD[17.17.17.17:64512]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 37 17.17.17.17 MPLS
PE2
SH2-7022#show evpn mpls tunnel
EVPN-MPLS Network tunnel Entries
Source Destination Status Up/Down Update evpn-id
===================================================================================
22.22.22.22 11.11.11.11 Installed 14:21:58 14:21:58 400
22.22.22.22 11.11.11.11 Installed 19:56:30 19:56:30 40000
22.22.22.22 17.17.17.17 Installed 19:56:30 19:56:30 40000
22.22.22.22 20.20.20.20 Installed 14:30:31 14:30:31 400
22.22.22.22 20.20.20.20 Installed 19:56:30 19:56:30 40000
 
Total number of entries are 5
SH2-7022#show evpn mpls mac-table
=========================================================================================================================================
EVPN MPLS MAC Entries
=========================================================================================================================================
VNID Interface VlanId In-VlanId Mac-Addr VTEP-Ip/ESI Type Status MAC move AccessPortDesc
_________________________________________________________________________________________________________________________________________
 
400 irb400 ---- ---- 0011.2233.5577 22.22.22.22 Static Local ------- 0 -------
400 ---- ---- ---- 0000.0000.aaaa 20.20.20.20 Static Remote ------- 0 -------
400 ---- ---- ---- 0000.0000.bbbb 20.20.20.20 Static Remote ------- 0 -------
 
Total number of entries are : 3
SH2-7022#sh evpn mpls arp-cache
MPLS-EVPN ARP-CACHE Information
===============================
EVPN-ID Ip-Addr Mac-Addr Type Age-Out Retries-Left
_____________________________________________________________________________
400 40.40.1.1 0011.2233.5577 Static Local ----
400 40.40.1.10 0000.0000.aaaa Static Remote ----
Total number of entries are 2
 
SH2-7022#sh evpn mpls nd-cache
MPLS-EVPN ND-CACHE Information
==============================
EVPN-ID Ip-Addr Mac-Addr Type Age-Out Retries-Left
_____________________________________________________________________________________________
400 5001::1 0011.2233.5577 Static Local ----
400 5001:aaaa::1 0000.0000.bbbb Static Remote ----
Total number of entries are 2
 
SH2-7022#show bgp l2vpn evpn multihoming ethernet-ad-per-es
 
RD[11.11.11.11:64512]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 38 11.11.11.11 MPLS
 
RD[17.17.17.17:64512]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 37 17.17.17.17 MPLS
 
SH2-7022#sh bgp l2vpn evpn
BGP table version is 11, local router ID is 22.22.22.22
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
[EVPN route type]:[ESI]:[VNID]:[relevent route informantion]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
 
Network Next Hop Metric LocPrf Weight Path Peer Encap
 
RD[10:400]
*>i [5]:[0]:[0]:[24]:[80.80.1.0]:[0.0.0.0]:[16]
17.17.17.17 0 100 0 ? 17.17.17.17 MPLS
 
RD[20:400]
*>i [5]:[0]:[0]:[24]:[80.80.1.0]:[0.0.0.0]:[16]
11.11.11.11 0 100 0 ? 11.11.11.11 MPLS
 
RD[30:400]
*>i [5]:[0]:[0]:[24]:[40.40.1.0]:[0.0.0.0]:[16]
20.20.20.20 0 100 0 ? 20.20.20.20 MPLS
 
RD[11.11.11.11:400]
*>i [2]:[0]:[500]:[48,0011:2233:5577]:[32,80.80.1.1]:[18]
11.11.11.11 0 100 0 i 11.11.11.11 MPLS
*>i [3]:[400]:[32,11.11.11.11]
11.11.11.11 0 100 0 i 11.11.11.11 MPLS
*>i [3]:[500]:[32,11.11.11.11]
11.11.11.11 0 100 0 i 11.11.11.11 MPLS
 
RD[17.17.17.17:400]
*>i [2]:[0]:[500]:[48,0011:2233:5577]:[32,80.80.1.1]:[17]
17.17.17.17 0 100 0 i 17.17.17.17 MPLS
*>i [3]:[500]:[32,17.17.17.17]
17.17.17.17 0 100 0 i 17.17.17.17 MPLS
 
RD[17.17.17.17:600]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[600]:[18]
17.17.17.17 0 100 0 i 17.17.17.17 MPLS
*>i [3]:[600]:[32,17.17.17.17]
17.17.17.17 0 100 0 i 17.17.17.17 MPLS
 
RD[20.20.20.20:400]
*>i [2]:[0]:[400]:[48,0000:0000:aaaa]:[32,40.40.1.10]:[17]:[16]
20.20.20.20 0 100 0 i 20.20.20.20 MPLS
*>i [2]:[0]:[400]:[48,0000:0000:bbbb]:[128,5001:aaaa::1]:[17]
20.20.20.20 0 100 0 i 20.20.20.20 MPLS
*>i [2]:[0]:[400]:[48,0011:2233:5577]:[32,40.40.1.1]:[17]
20.20.20.20 0 100 0 i 20.20.20.20 MPLS
*>i [2]:[0]:[400]:[48,0011:2233:5577]:[128,5001::1]:[17]
20.20.20.20 0 100 0 i 20.20.20.20 MPLS
*>i [3]:[400]:[32,20.20.20.20]
20.20.20.20 0 100 0 i 20.20.20.20 MPLS
 
RD[20.20.20.20:600]
*>i [3]:[600]:[32,20.20.20.20]
20.20.20.20 0 100 0 i 20.20.20.20 MPLS
 
RD[20.20.20.20:700]
*>i [3]:[0]:[32,20.20.20.20]
20.20.20.20 0 100 0 i 20.20.20.20 MPLS
 
RD[20.20.20.20:701]
*>i [2]:[0]:[701]:[48,0000:0000:2001]:[0]:[29]
20.20.20.20 0 100 0 i 20.20.20.20 MPLS
*>i [2]:[0]:[701]:[48,0000:0000:2002]:[32,20.20.20.1]:[29]
20.20.20.20 0 100 0 i 20.20.20.20 MPLS
*>i [2]:[0]:[701]:[48,0000:0000:2003]:[128,1204::1]:[29]
20.20.20.20 0 100 0 i 20.20.20.20 MPLS
*>i [3]:[701]:[32,20.20.20.20]
20.20.20.20 0 100 0 i 20.20.20.20 MPLS
 
RD[22.22.22.22:400] VRF[green]:
* i [2]:[0]:[400]:[48,0000:0000:aaaa]:[32,40.40.1.10]:[17]:[16]
20.20.20.20 0 100 0 i 20.20.20.20 MPLS
* i [2]:[0]:[400]:[48,0000:0000:bbbb]:[128,5001:aaaa::1]:[17]
20.20.20.20 0 100 0 i 20.20.20.20 MPLS
*> [2]:[0]:[400]:[48,0011:2233:5577]:[32,40.40.1.1]:[17]
22.22.22.22 0 100 32768 i ---------- MPLS
* i 20.20.20.20 0 100 0 i 20.20.20.20 MPLS
*> [2]:[0]:[400]:[48,0011:2233:5577]:[128,5001::1]:[17]
22.22.22.22 0 100 32768 i ---------- MPLS
* i 20.20.20.20 0 100 0 i 20.20.20.20 MPLS
* i [2]:[0]:[500]:[48,0011:2233:5577]:[32,80.80.1.1]:[18]
11.11.11.11 0 100 0 i 11.11.11.11 MPLS
* i 17.17.17.17 0 100 0 i 17.17.17.17 MPLS
* i [3]:[400]:[32,11.11.11.11]
11.11.11.11 0 100 0 i 11.11.11.11 MPLS
* i [3]:[400]:[32,20.20.20.20]
20.20.20.20 0 100 0 i 20.20.20.20 MPLS
*> [3]:[400]:[32,22.22.22.22]
22.22.22.22 0 100 32768 i ---------- MPLS
* i [3]:[500]:[32,11.11.11.11]
11.11.11.11 0 100 0 i 11.11.11.11 MPLS
* i [3]:[500]:[32,17.17.17.17]
17.17.17.17 0 100 0 i 17.17.17.17 MPLS
 
Total number of prefixes 50
PE3
MH-2-7011#show evpn mpls tunnel
EVPN-MPLS Network tunnel Entries
Source Destination Status Up/Down Update evpn-id
===================================================================================
11.11.11.11 22.22.22.22 Installed 15:23:05 15:23:05 400
11.11.11.11 22.22.22.22 Installed 23:11:42 23:11:42 40000
11.11.11.11 17.17.17.17 Installed 18:36:34 18:36:34 500
11.11.11.11 17.17.17.17 Installed 23:11:42 23:11:42 40000
11.11.11.11 20.20.20.20 Installed 18:36:34 18:36:34 400
11.11.11.11 20.20.20.20 Installed 23:11:42 23:11:42 40000
 
MH-2-7011#show evpn mpls mac-table
=========================================================================================================================================
EVPN MPLS MAC Entries
=========================================================================================================================================
VNID Interface VlanId In-VlanId Mac-Addr VTEP-Ip/ESI Type Status MAC move AccessPortDesc
_________________________________________________________________________________________________________________________________________
 
400 ---- ---- ---- 0011.2233.5577 20.20.20.20 Static Remote ------- 0 -------
400 ---- ---- ---- 0000.0000.aaaa 20.20.20.20 Static Remote ------- 0 -------
400 ---- ---- ---- 0000.0000.bbbb 20.20.20.20 Static Remote ------- 0 -------
500 irb500 ---- ---- 0011.2233.5577 11.11.11.11 Static Local ------- 0 -------
 
MH-2-7011#show evpn mpls arp-cache
MPLS-EVPN ARP-CACHE Information
===============================
EVPN-ID Ip-Addr Mac-Addr Type Age-Out Retries-Left
_____________________________________________________________________________
400 40.40.1.1 0011.2233.5577 Static Remote ----
400 40.40.1.10 0000.0000.aaaa Static Remote ----
500 80.80.1.1 0011.2233.5577 Static Local ----
Total number of entries are 3
MH-2-7011#show evpn mpls nd-cache
MPLS-EVPN ND-CACHE Information
==============================
EVPN-ID Ip-Addr Mac-Addr Type Age-Out Retries-Left
_____________________________________________________________________________________________
400 5001::1 0011.2233.5577 Static Remote ----
400 5001:aaaa::1 0000.0000.bbbb Static Remote ----
Total number of entries are 2
 
MH-2-7011#show bgp l2vpn evpn multihoming ethernet-ad-per-es
 
 
RD[11.11.11.11:64512] VRF[evpn-gvrf-1]:
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 38 11.11.11.11 MPLS
 
RD[17.17.17.17:64512]
ESI Eth-Tag VNID/LABEL Nexthop IP Encap
00:00:00:11:11:aa:aa:00:00:00 4294967295 37 17.17.17.17 MPLS
MH-2-7011#sh bgp l2vpn evpn
BGP table version is 8, local router ID is 11.11.11.11
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
[EVPN route type]:[ESI]:[VNID]:[relevent route informantion]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
 
Network Next Hop Metric LocPrf Weight Path Peer Encap
 
RD[10:400]
*>i [5]:[0]:[0]:[24]:[80.80.1.0]:[0.0.0.0]:[16]
17.17.17.17 0 100 0 ? 17.17.17.17 MPLS
 
RD[30:400]
*>i [5]:[0]:[0]:[24]:[40.40.1.0]:[0.0.0.0]:[16]
20.20.20.20 0 100 0 ? 20.20.20.20 MPLS
 
RD[40:400]
*>i [5]:[0]:[0]:[24]:[40.40.1.0]:[0.0.0.0]:[16]
22.22.22.22 0 100 0 ? 22.22.22.22 MPLS
 
RD[11.11.11.11:400] VRF[green]:
* i [2]:[0]:[400]:[48,0000:0000:aaaa]:[32,40.40.1.10]:[17]:[16]
20.20.20.20 0 100 0 i 20.20.20.20 MPLS
* i [2]:[0]:[400]:[48,0000:0000:bbbb]:[128,5001:aaaa::1]:[17]
20.20.20.20 0 100 0 i 20.20.20.20 MPLS
* i [2]:[0]:[400]:[48,0011:2233:5577]:[32,40.40.1.1]:[17]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
* i 20.20.20.20 0 100 0 i 20.20.20.20 MPLS
* i [2]:[0]:[400]:[48,0011:2233:5577]:[128,5001::1]:[17]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
* i 20.20.20.20 0 100 0 i 20.20.20.20 MPLS
* i [2]:[0]:[500]:[48,0011:2233:5577]:[32,80.80.1.1]:[17]
17.17.17.17 0 100 0 i 17.17.17.17 MPLS
*> 11.11.11.11 0 100 32768 i ---------- MPLS
*> [3]:[400]:[32,11.11.11.11]
11.11.11.11 0 100 32768 i ---------- MPLS
* i [3]:[400]:[32,20.20.20.20]
20.20.20.20 0 100 0 i 20.20.20.20 MPLS
* i [3]:[400]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
*> [3]:[500]:[32,11.11.11.11]
11.11.11.11 0 100 32768 i ---------- MPLS
* i [3]:[500]:[32,17.17.17.17]
17.17.17.17 0 100 0 i 17.17.17.17 MPLS
 
 
RD[11.11.11.11:64512] VRF[evpn-gvrf-1]:
*> [1]:[00:00:00:11:11:aa:aa:00:00:00]:[4294967295]:[0]
11.11.11.11 0 100 32768 i ---------- MPLS
*> [4]:[00:00:00:11:11:aa:aa:00:00:00]:[32,11.11.11.11]
11.11.11.11 0 100 32768 i ---------- MPLS
* i [4]:[00:00:00:11:11:aa:aa:00:00:00]:[32,17.17.17.17]
17.17.17.17 0 100 0 i 17.17.17.17 MPLS
 
RD[17.17.17.17:400]
*>i [2]:[0]:[500]:[48,0011:2233:5577]:[32,80.80.1.1]:[17]
17.17.17.17 0 100 0 i 17.17.17.17 MPLS
*>i [3]:[500]:[32,17.17.17.17]
17.17.17.17 0 100 0 i 17.17.17.17 MPLS
 
 
RD[17.17.17.17:64512]
*>i [1]:[00:00:00:11:11:aa:aa:00:00:00]:[4294967295]:[0]
17.17.17.17 0 100 0 i 17.17.17.17 MPLS
*>i [4]:[00:00:00:11:11:aa:aa:00:00:00]:[32,17.17.17.17]
17.17.17.17 0 100 0 i 17.17.17.17 MPLS
 
RD[20.20.20.20:400]
*>i [2]:[0]:[400]:[48,0000:0000:aaaa]:[32,40.40.1.10]:[17]:[16]
20.20.20.20 0 100 0 i 20.20.20.20 MPLS
*>i [2]:[0]:[400]:[48,0000:0000:bbbb]:[128,5001:aaaa::1]:[17]
20.20.20.20 0 100 0 i 20.20.20.20 MPLS
*>i [2]:[0]:[400]:[48,0011:2233:5577]:[32,40.40.1.1]:[17]
20.20.20.20 0 100 0 i 20.20.20.20 MPLS
*>i [2]:[0]:[400]:[48,0011:2233:5577]:[128,5001::1]:[17]
20.20.20.20 0 100 0 i 20.20.20.20 MPLS
*>i [3]:[400]:[32,20.20.20.20]
20.20.20.20 0 100 0 i 20.20.20.20 MPLS
 
RD[22.22.22.22:400]
*>i [2]:[0]:[400]:[48,0011:2233:5577]:[32,40.40.1.1]:[17]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
*>i [2]:[0]:[400]:[48,0011:2233:5577]:[128,5001::1]:[17]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
*>i [3]:[400]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
 
PE4
MH-1-7017#show evpn mpls tunnel
EVPN-MPLS Network tunnel Entries
Source Destination Status Up/Down Update evpn-id
===================================================================================
17.17.17.17 22.22.22.22 Installed 1d00h04m 1d00h04m 40000
17.17.17.17 11.11.11.11 Installed 00:20:45 00:20:45 500
17.17.17.17 11.11.11.11 Installed 1d00h04m 1d00h04m 40000
17.17.17.17 20.20.20.20 Installed 1d00h04m 1d00h04m 40000
 
MH-1-7017#show evpn mpls arp-cache
MPLS-EVPN ARP-CACHE Information
===============================
EVPN-ID Ip-Addr Mac-Addr Type Age-Out Retries-Left
_____________________________________________________________________________
500 80.80.1.1 0011.2233.5577 Static Local ----
Total number of entries are 1
 
Last modified date: 10/17/2023