#configure terminal | Enter configuration mode. |
(config)#interface lo | Enter the Interface mode for the loopback interface. |
(config-if)#ip address 10.143.73.1/32 secondary | Configure IP address on loopback interface. |
(config-if)#commit | Commit the transaction. |
(config-if)#exit | Exit interface mode |
#configure terminal | Enter configuration mode. |
(config)#evpn mpls enable | Enable EVPN MPLS |
(config-evpn-mpls)#evpn mpls vtep-ip-global 10.143.73.1 | Configuring VTEP global IP to loopback IP |
(config)#commit | Commit candidate configuration to be running configuration Note: Reload is required after Enabling/Disabling EVPN MPLS Feature. |
(config)#router ldp | Enter the Router LDP mode. |
(config-router)#router-id 10.143.73.1 | Set the router ID to IP address 10.143.73.1 |
(config-router)#transport-address ipv4 10.143.73.1 | Configure the transport address for IPV4 (for IPV6 use ipv6) to be used for a TCP session over which LDP will run. Note: It is preferable to use the loopback address as the transport address. |
(config-router)#targeted-peer ipv4 10.143.73.3 | Configure targeted peer. |
(config-router-targeted-peer)#exit | Exit-targeted-peer-mode |
(config-router)#exit | Exit from router target peer and LDP mode |
(config)#commit | Commit the transaction. |
(config)#interface xe3 | Enter the Interface mode for eth2. |
(config-if)#ip address 10.255.128.8/31 | Configure IP address on the interface. |
(config-if)#enable-ldp ipv4 | Enable LDP on the physical interface |
(config-if)#label-switching | Enable label switching on the interface. |
(config-if)#exit | Exit interface mode |
(config)#commit | Commit the transaction. |
(config)#router ospf 100 | Enter the Router OSPF mode. |
(config-router)#ospf router-id 10.143.73.1 | Router-ID configurations |
(config-router)#network 10.143.73.1/32 area 0.0.0.0 | Advertise loopback address in OSPF. |
(config-router)#network 10.255.128.8/31 area 0.0.0.0 | Advertise network address in OSPF. |
(config-router)#exit | Exit Router OSPF mode and return to Configure mode. |
(config)#commit | Commit the transaction. |
(config)#router bgp 65010 | Enter the Router BGP mode, ASN: 65010 |
(config-router)#neighbor 10.143.73.3 remote-as 65010 | Configuring PE3 as iBGP neighbor using it's loopback IP |
(config-router)#neighbor 10.143.73.3 update-source lo | Source of routing updates as loopback |
(config-router)#address-family l2vpn evpn | Entering into address family mode as EVPN |
(config-router-af)#neighbor 10.143.73.3 activate | Enabling EVPN Address family for neighbor |
(config-router-af)#exit | Exiting of Address family mode |
(config-router)#commit | Commit the transaction. |
(config)#mac vrf vrf2 | Enter VRF mode |
(config-vrf)#rd 10.143.73.1:2 | Configuring Route-Distinguisher value 10.143.73.1:2 |
(config-vrf)#route-target both 2:2 | Configuring import and export value as 2:2 |
(config-vrf)#exit | Exiting VRF Mode |
(config)#mac vrf vpls1001 | Enter VRF mode |
(config-vrf)#rd 10.143.73.1:1001 | Configuring Route-Distinguisher value 10.143.73.1:1001 |
(config-vrf)#route-target both evpn-auto-rt | Configuring import and export value as evpn-auto-rt. Route target will be derived automatically. Support: route-target export route-target import |
(config-vrf)#exit | Exiting VRF Mode |
(config)#commit | Commit the transaction. |
(config)#evpn mpls id 2 xconnect target-mpls-id 252 | Configure the EVPN-VPWS identifier with source identifier 2 and target identifier 252 |
(config)#host-reachability-protocol evpn-bgp vrf2 | Mapping vrf "vrf2" to EVPN-VPWS identifier |
(config)#evpn mpls id 1001 | Configure the EVPN-VPLS identifier with identifier 1001 |
(config)#host-reachability-protocol evpn-bgp vpls1001 | Mapping vrf "vpls1001" to EVPN-VPLS identifier |
(config)#commit | Commit the transaction. |
(config)#interface xe6 | Enter the Interface mode for xe6. |
(config-if)#interface xe6.2 switchport | Creating L2 sub interface of physical interface xe6 |
(config-if)#encapsulation dot1q 2 | Setting Encapsulation to dot1q with VLAN ID 2 Supported Encapsulation: dot1ad, dot1q, untagged, default |
(config-if)#access-if-evpn | Entering Access mode for EVPN MPLS ID configuration |
(config-access-if)#map vpn-id 2 | Map vpn-id 2 to interface xe6.2 (VPWS) |
(config-access-if)#exit | Exiting out of access interface mode |
(config-if)#interface xe6.1001 switchport | Creating L2 sub interface of physical interface xe6 |
(config-if)#encapsulation dot1q 1001 | Setting Encapsulation to dot1q with VLAN ID 1001 Supported Encapsulation: dot1ad, dot1q, untagged, default |
(config-if)#access-if-evpn | Entering Access mode for EVPN MPLS ID configuration |
(config-access-if)#map vpn-id 1001 | Map vpn-id 1001 to interface xe6.1001 (VPLS) |
OcNOS(config-access-if)#commit | Commit candidate configuration to be running configuration |
#configure terminal | Enter configuration mode. |
(config)#interface lo | Enter the Interface mode for the loopback interface. |
(config-if)#ip address 10.143.73.6/32 secondary | Configure IP address on loopback interface. |
(config-if)#exit | Exit interface mode |
(config)#commit | Commit the transaction. |
(config)#router ldp | Enter the Router LDP mode. |
(config-router)#router-id 10.255.128.25 | Set the router ID to IP address 10.255.128.25 |
(config-router)#transport-address ipv4 10.255.128.25 | Configure the transport address for IPV4 (for IPV6 use ipv6) to be used for a TCP session over which LDP will run. Note: It is preferable to use the loopback address as the transport address. |
(config-router)#exit | Exit from router target peer and LDP mode |
(config)#commit | Commit the transaction. |
(config)#interface xe3 | Enter the Interface mode for xe3. |
(config-if)#ip address 10.255.128.9/31 | Configure IP address on the interface. |
(config-if)#enable-ldp ipv4 | Enable LDP on the physical interface |
(config-if)#label-switching | Enable label switching on the interface. |
(config-if)#exit | Exit interface mode |
(config)#interface xe5 | Enter the Interface mode for xe5 |
(config-if)#ip address 10.255.128.25/31 | Configure IP address on the interface. |
(config-if)#enable-ldp ipv4 | Enable LDP on the physical interface |
(config-if)#label-switching | Enable label switching on the interface. |
(config-if)#exit | Exit interface mode |
(config)#commit | Commit the transaction. |
(config)#router ospf 100 | Enter the Router OSPF mode. |
(config-router)#ospf router-id 10.143.73.6 | Setting the Router ID as Loopback IP |
(config-router)#network 10.143.73.6/32 area 0.0.0.0 | Advertise loopback address in OSPF. |
(config-router)#network 10.255.128.8/31 area 0.0.0.0 | Advertise network address in OSPF that comes under same subnet. |
(config-router)#network 10.255.128.24/31 area 0.0.0.0 | Advertise xe5 network address in OSPF. |
(config-router)#exit | Exit Router OSPF mode and return to Configure mode. |
(config)#commit | Commit candidate configuration to be running configuration |
#configure terminal | Enter configuration mode. |
(config)#interface lo | Enter the Interface mode for the loopback interface. |
(config-if)#ip address 10.143.73.3/32 secondary | Configure IP address on loopback interface. |
(config-if)#exit | Exit interface mode |
(config)#commit | Commit the transaction. |
(config)#router ldp | Enter the Router LDP mode. |
(config-router)#router-id 10.143.73.3 | Set the router ID to IP address 10.143.73.3 |
(config-router)#transport-address ipv4 10.143.73.3 | Configure the transport address for IPV4 (for IPV6 use ipv6) to be used for a TCP session over which LDP will run. Note: It is preferable to use the loopback address as the transport address. |
(config-router)#targeted-peer ipv4 10.143.73.1 | Configure targeted peer. |
(config-router-targeted-peer)#exit | Exit router mode |
(config-router)#exit | Exit from router target peer and LDP mode |
(config)#commit | Commit the transaction. |
(config)#evpn mpls enable | Enable EVPN MPLS |
(config)#commit | Commit candidate configuration to be running configuration Note: Reload is required after Enabling/Disabling EVPN MPLS Feature |
(config-evpn-mpls)#evpn mpls vtep-ip-global 10.143.73.3 | Configuring VTEP global IP to loopback IP |
(config-evpn-mpls)#commit | Commit the transaction. |
(config)#interface xe3 | Enter the Interface mode for xe3. |
(config-if)#ip address 10.255.128.24/31 | Configure IP address on the interface. |
(config-if)#enable-ldp ipv4 | Enable LDP on the physical interface |
(config-if)#label-switching | Enable label switching on the interface. |
(config-if)#exit | Exit interface mode |
(config)#commit | Commit the transaction. |
(config)#router ospf 100 | Enter the Router OSPF mode. |
(config-router)#ospf router-id 10.143.73.3 | Router-ID configurations |
(config-router)#network 10.143.73.3/32 area 0.0.0.0 | Advertise loopback address in OSPF. |
(config-router)#network 10.255.128.24/31 area 0.0.0.0 | Advertise network address in OSPF. |
(config-router)#exit | Exit Router OSPF mode and return to Configure mode. |
(config)#commit | Commit the transaction. |
(config)#router bgp 65010 | Enter the Router BGP mode, ASN: 65010 |
(config-router)#neighbor 10.143.73.1 remote-as 65010 | Configuring PE1 as iBGP neighbor using it's loopback IP |
(config-router)#neighbor 10.143.73.1 update-source lo | Source of routing updates as loopback |
(config-router)#address-family l2vpn evpn | Entering into address family mode as EVPN |
(config-router-af)#neighbor 10.143.73.1 activate | Enabling EVPN Address family for neighbor |
(config-router-af)#exit | Exiting of Address family mode |
(config)#commit | Commit the transaction. |
(config)#mac vrf vrf2 | Enter VRF mode |
(config-vrf)#rd 10.143.73.3:2 | Configuring Route-Distinguisher value 10.143.73.3:2 |
(config-vrf)#route-target both 2:2 | Configuring import and export value as 2:2 Support: route-target export route-target import |
(config-vrf)#exit | Exiting VRF Mode |
(config)#mac vrf vpls1001 | Enter VRF mode |
(config-vrf)#rd 10.143.73.1:1001 | Configuring Route-Distinguisher value 10.143.73.1:1001 |
(config-vrf)#route-target both evpn-auto-rt | Configuring import and export value as evpn-auto-rt. Route target will be derived automatically. |
(config-vrf)#exit | Exiting VRF Mode |
(config)#commit | Commit the transaction. |
(config)#evpn mpls id 252 xconnect target-mpls-id 2 | Configure the EVPN-ELINE identifier with source identifier 252 and target identifier 2 |
(config-evpn-mpls)#host-reachability-protocol evpn-bgp vrf2 | Mapping vrf "vrf2" to EVPN-ELINE identifier |
(config-evpn-mpls)#evpn mpls id 1001 | Configure the EVPN-ELAN identifier with identifier 1001 |
(config-evpn-mpls)#host-reachability-protocol evpn-bgp vpls1001 | Mapping vrf "vpls1001" to EVPN-ELAN identifier |
(config-evpn-mpls)#commit | Commit the transaction. |
(config)#interface xe2 | Enter the Interface mode for xe2. |
(config-if)#description access-side-int | Giving Interface Description |
(config-if)#interface xe2.2 switchport | Creating L2 sub interface of physical interface xe2 |
(config-if)#encapsulation dot1q 2 | Setting Encapsulation to dot1q with VLAN ID 2 Supported Encapsulation: dot1ad, dot1q, untagged, default |
(config-if)#access-if-evpn | Entering Access mode for EVPN MPLS ID configuration |
(config-access-if)#map vpn-id 2 | Map vpn-id 252 to interface xe2.2 (VPWS) |
(config-access-if)#exit | Exiting out of access interface mode |
(config-if)#interface xe2.1001 switchport | Creating L2 sub interface of physical interface xe2 |
(config-if)#encapsulation dot1q 1001 | Setting Encapsulation to dot1q with VLAN ID 1001 Supported Encapsulation: dot1ad, dot1q, untagged, default |
(config-if)#access-if-evpn | Entering Access mode for EVPN MPLS ID configuration |
(config-access-if)#map vpn-id 1001 | Map vpn-id 1001 to interface xe2.1001 (VPLS) |
(config)#commit | Commit candidate configuration to be running configuration |