OcNOS-SP : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : EVPN MPLS E-TREE Configuration : Configuring MPLS EVPN over BGP-LU
Configuring MPLS EVPN over BGP-LU
Topology
Figure 25-2 shows the topology used to show how to configure MPLS EVPN over BGP-LU as underlay MPLS path.
Figure 25-2: MPLS EVPN configuration over BGP-LU
Configuration
PE1
 
#configure terminal
Enter configuration mode.
(config)#interface lo
Enter interface mode for loopback.
(config-if)#ip address 101.1.1.1/32 secondary
Configure IP address on loopback
(config-if)#exit
Exit interface mode
(config)#mac vrf vrfred
Configure MAC VRF
(config-vrf)#rd 101:1
Configure RD for the MAC VRF
(config-vrf)#route-target export 101:1
Configure export RT for the MAC VRF
(config-vrf)#route-target import 104:1
Configure import RT for the MAC VRF
(config-vrf)#route-target import 105:1
Configure import RT for the MAC VRF
(config-vrf)#exit
Exit VRF mode.
(config)#evpn mpls enable
Enable the evpn mpls.
(config)#evpn mpls vtep-ip-global 101.1.1.1
Configure VTEP-IP-global.
(config)#evpn mpls id 1000
Configure MPLS EVID.
(config-evpn-mpls)#host-reachability-protocol evpn-bgp vrfred
Configure host-reachability with VRF association.
(config-if)#interface xe6.2
Configure sub-interface to create access-circuit.
(config-if)#switchport
Make the sub-interface a Layer 2 interface
(config-if)#encapsulation dot1q 2
Configure the encapsulation required.
(config-if)#map vpn-id 1000
Map interface to Ethernet virtual network identifier.
(config-if)#exit
Exit interface mode.
(config)#router ldp
Enable LDP in the PE
(config-router)#router-id 101.1.1.1
Set the router ID to IP address 101.1.1.1
(config-router)#transport-address ipv4 101.1.1.1
Configure transport address
(config-router)#exit
Exit router mode
(config)#interface xe5
Enter interface mode for the network side interface.
(config-if)#ip address 10.1.1.1/24
Configure IP address on the network interface
(config-if)#label-switching
Enable label-switching.
(config-if)#enable-ldp ipv4
Enable ldp
(config-if)#exit
Exit interface mode
(config)#router ospf 1
Enter OSPF router mode
(config-router)#ospf router-id 101.1.1.1
Configure router-id.
(config-router)#network 101.1.1.1/32 area 0.0.0.0
Advertise the loopback address in area 0.
(config-router)#network 10.1.1.0/24 area 0.0.0.0
Advertise the network address in area 0
(config-router)#exit
Exit OSPF router mode.
(config)#router bgp 1
Enter BGP router mode
(config)#allocate-label all
Configure allocate all under router bgp
(config-router)#neighbor 102.1.1.1 remote-as 1
Advertise the neighbor in BGP process with the remote-as number
(config-router)#neighbor 102.1.1.1 update-source lo
Configure the update-source for the neighbor
(config-router)#neighbor 104.1.1.1 remote-as 1
Advertise the neighbor in BGP process with the remote-as number
(config-router)#neighbor 104.1.1.1 update-source lo
Configure the update-source for the neighbor
(config-router)#neighbor 105.1.1.1 remote-as 1
Advertise the neighbor in BGP process with the remote-as number
(config-router)#neighbor 105.1.1.1 update-source lo
Configure the update-source for the neighbor
(config-router)# address-family ipv4 unicast
Entering into address family ipv4 unicast
(config-router-af)# network 104.1.1.1/32
Advertise the network
(config-router-af)# exit-address-family
Exit from ipv4 address family
(config-router)# address-family ipv4 labeled-unicast
Entering into address family ipv4 labeled-unicast
(config-router-af)#neighbor 102.1.1.1 activate
Activate the ipv4 labeled-unicast neighbor
(config-router-af)#neighbor 102.1.1.1 next-hop-self
Configure next-hop-self for the ipv4 labeled-unicast neighbor
config-router-af)#neighbor 102.1.1.1 route-reflector-client
Configure neighbor as route reflector client
(config-router-af)# exit-address-family
Exit from ipv4 labeled-unicast address family
(config-router)#address-family l2vpn evpn
Enter EVPN address family mode
(config-router-af)#neighbor 104.1.1.1 activate
Activate the neighbor
(config-router-af)#neighbor 105.1.1.1 activate
Activate the neighbor
(config-router-af)#exit-address-family
Exit address family mode.
(config-router)#exit
Exit the router mode
(config)#commit
Commit the transaction.
(config)#exit
Exit the config mode.
ABR1: Loopback Interface
 
#configure terminal
Enter configuration mode.
(config)#interface lo
Enter the Interface mode for the loopback interface.
(config-if)#ip address 102.1.1.1/32 secondary
Configure IP address on loopback interface.
(config-if)#commit
Commit the transaction.
ABR1: Global LDP
 
(config)#router ldp
Enter the Router LDP mode.
(config-router)#router-id 102.1.1.1
Set the router ID to IP address 102.1.1.1
(config-router)#transport-address ipv4 102.1.1.1
Configure transport address
(config-router)#commit
Commit the transaction.
ABR1: Interface Configuration
 
(config)#interface xe6
Enter the Interface mode for xe3.
(config-if)#ip address 10.1.1.2/24
Configure IP address on the interface.
(config-if)#enable-ldp ipv4
Enable LDP on the physical interface
(config-if)#label-switching
Enable label switching on the interface.
(config-if)#exit
Exit interface mode
(config)#interface xe1
Enter the Interface mode for xe5
(config-if)#ip address 20.1.1.1/31
Configure IP address on the interface.
(config-if)#enable-ldp ipv4
Enable LDP on the physical interface
(config-if)#label-switching
Enable label switching on the interface.
(config-if)#commit
Commit the transaction.
ABR1: OSPF Configuration
 
(config)#enable ext-ospf-multi-inst
Enable multiple-instance capability
(config)#router ospf 1
Enter the Router OSPF mode.
(config-router)#ospf router-id 102.1.1.1
Setting the Router ID as Loopback IP
(config-router)#network 102.1.1.1/32 area 0.0.0.0 instance-id 2
Advertise loopback address in OSPF.
(config-router)#network 20.1.1.0/24 area 0.0.0.0
Advertise network address in OSPF.
(config)#router ospf 2
Enter the Router OSPF mode.
(config-router)#network 10.1.1.0/24 area 0.0.0.0 instance-id 1
Advertise the network address in area 0
(config-router)#exit
Exit Router OSPF mode and return to Configure mode.
(config)#commit
Commit candidate configuration to be running configuration
ABR1: BGP-LU Configuration
 
(config)#router bgp 1
Enter the Router BGP mode, ASN: 1
(config)#allocate-label all
Configure allocate all under router bgp
(config-router)#neighbor 101.1.1.1 remote-as 1
Advertise the neighbor in BGP process with the remote-as number
(config-router)#neighbor 101.1.1.1 update-source lo
Configure the update-source for the neighbor
(config-router)#neighbor 103.1.1.1 remote-as 1
Advertise the neighbor in BGP process with the remote-as number
(config-router)#neighbor 103.1.1.1 update-source lo
Configure the update-source for the neighbor
(config-router)# address-family ipv4 unicast
Entering into address family ipv4 unicast
(config-router-af)# network 102.1.1.1/32
Advertise the network
(config-router-af)# exit-address-family
Exit from ipv4 address family
(config-router)# address-family ipv4 labeled-unicast
Entering into address family ipv4 labeled-unicast
(config-router-af)#neighbor 101.1.1.1 activate
Activate the ipv4 labeled-unicast neighbor
(config-router-af)#neighbor 101.1.1.1 next-hop-self
Configure next-hop-self for the ipv4 labeled-unicast neighbor
config-router-af)#neighbor 101.1.1.1 route-reflector-client
Configure neighbor as route reflector client
(config-router-af)#neighbor 103.1.1.1 activate
Activate the ipv4 labeled-unicast neighbor
(config-router-af)#neighbor 103.1.1.1 next-hop-self
Configure next-hop-self for the ipv4 labeled-unicast neighbor
config-router-af)#neighbor 103.1.1.1 route-reflector-client
Configure neighbor as route reflector client
(config-router-af)# exit-address-family
Exit from ipv4 labeled-unicast address family
(config-router)#exit
Exit the config mode.
(config)#commit
Commit the transaction.
(config)#exit
Exit the config mode.
ABR2
 
#configure terminal
Enter configuration mode.
(config)#int lo
Enter interface mode for loopback.
(config-if)#ip address 103.1.1.1/32 secondary
Configure IP address on loopback
(config)#router ldp
Configure ldp.
(config-router)#router-id 103.1.1.1
Set the router ID to IP address 103.1.1.1
(config-router)#transport-address ipv4 103.1.1.1
Configure transport address
(config)#interface xe4
Enter interface mode for the network side interface.
(config-if)#ip address 30.1.1.1/24
Configure IP address on the network interface
(config-if)#label-switching
Enable label-switching.
(config-if)#enable-ldp
Enable RSVP.
(config)#interface xe1
Enter interface mode for the network side interface.
(config-if)#ip address 20.1.1.2/24
Configure IP address on the network interface
(config-if)#label-switching
Enable label-switching.
(config-if)#enable-ldp
Enable ldp
(config)#interface xe7
Enter interface mode for the network side interface.
(config-if)#ip address 40.1.1.1/24
Configure IP address on the network interface
(config-if)#label-switching
Enable label-switching.
(config-if)#enable-rsvp
Enable RSVP.
(config-if)#exit
Exit interface mode
(config)#enable ext-ospf-multi-inst
Enable multiple-instance capabilit
(config)#router ospf 2
Enter OSPF router mode
(config-router)#ospf router-id 103.1.1.1
Configure router-id.
(config-router)#network 103.1.1.1/32 area 0.0.0.0 instance-id 3
Advertise the loopback address in area 0.
(config-router)#network 20.1.1.0/24 area 0.0.0.0
Advertise the network address in area 0
(config)#router ospf 3
Enter the Router OSPF mode.
(config-router)#network 30.1.1.0/24 area 0.0.0.0 instance-id 2
Advertise the network address in area 0
(config-router)#network 40.1.1.0/24 area 0.0.0.0
Advertise the network address in area 0
(config-router)#exit
Exit the transaction
(config)#commit
Commit candidate configuration to be running configuration
(config)#exit
Exit the config mode
ABR2: BGP-LU Configuration
 
(config)#router bgp 1
Enter the Router BGP mode, ASN: 1
(config)#allocate-label all
Configure allocate all under router bgp
(config-router)#neighbor 102.1.1.1 remote-as 1
Advertise the neighbor in BGP process with the remote-as number
(config-router)#neighbor 102.1.1.1 update-source lo
Configure the update-source for the neighbor
(config-router)#neighbor 104.1.1.1 remote-as 1
Advertise the neighbor in BGP process with the remote-as number
(config-router)#neighbor 104.1.1.1 update-source lo
Configure the update-source for the neighbor
(config-router)#neighbor 105.1.1.1 remote-as 1
Advertise the neighbor in BGP process with the remote-as number
(config-router)#neighbor 105.1.1.1 update-source lo
Configure the update-source for the neighbor
(config-router)# address-family ipv4 unicast
Entering into address family ipv4 unicast
(config-router-af)# network 103.1.1.1/32
Advertise the network
(config-router-af)# exit-address-family
Exit from ipv4 address family
(config-router)# address-family ipv4 labeled-unicast
Entering into address family ipv4 labeled-unicast
(config-router-af)#neighbor 102.1.1.1 activate
Activate the ipv4 labeled-unicast neighbor
(config-router-af)#neighbor 102.1.1.1 next-hop-self
Configure next-hop-self for the ipv4 labeled-unicast neighbor
config-router-af)#neighbor 102.1.1.1 route-reflector-client
Configure neighbor as route reflector client
(config-router-af)#neighbor 104.1.1.1 activate
Activate the ipv4 labeled-unicast neighbor
(config-router-af)#neighbor 104.1.1.1 next-hop-self
Configure next-hop-self for the ipv4 labeled-unicast neighbor
config-router-af)#neighbor 104.1.1.1 route-reflector-client
Configure neighbor as route reflector client
(config-router-af)#neighbor 105.1.1.1 activate
Activate the ipv4 labeled-unicast neighbor
(config-router-af)#neighbor 105.1.1.1 next-hop-self
Configure next-hop-self for the ipv4 labeled-unicast neighbor
config-router-af)#neighbor 105.1.1.1 route-reflector-client
Configure neighbor as route reflector client
(config-router-af)# exit-address-family
Exit from ipv4 labeled-unicast address family
(config)#commit
Commit candidate configuration to be running configuration
(config)#exit
Exit the config mode
PE2
 
#configure terminal
Enter configuration mode.
(config)#int lo
Enter interface mode for loopback.
(config-if)#ip address 104.1.1.1/32 secondary
Configure IP address on loopback
(config-if)#exit
Exit interface mode
(config)#mac vrf vrfred
Configure MAC VRF
(config-vrf)#rd 104:1
Configure RD for the MAC VRF
(config-vrf)#route-target import 101:1
Configure import RT for the MAC VRF
(config-vrf)#route-target export 104:1
Configure export RT for the MAC VRF
(config-vrf)#exit
Exit VRF mode
(config)#evpn mpls enable
Enable evpn mpls.
(config)#evpn mpls vtep-ip-global 104.1.1.1
Configure VTEP-IP-global.
(config)#evpn mpls id 1000
Configure MPLS EVID.
(config-evpn-mpls)#host-reachability-protocol evpn-bgp vrfred
Configure host-reachability with VRF association.
(config-if)#int xe6.2
Configure sub-interface to create access-circuit.
(config-if)#switchport
Make the sub-interface a Layer 2 interface
(config-if)#encapsulation dot1q 2
Configure the encapsulation required.
(config-if)#map vpn-id 10000
Map interface to Ethernet virtual network identifier.
(config-if)#exit
Exit interface mode.
(config)#router ldp
Enable ldp in the PE
(config-router)#router-id 104.1.1.1
Set the router ID to IP address 104.1.1.1
(config-router)#transport-address ipv4 104.1.1.1
Configure transport address
(config)#interface xe5
Enter interface mode for the network side interface.
(config-if)#ip address 30.1.1.2/24
Configure IP address on the network interface
(config-if)#label-switching
Enable label-switching.
(config-if)#enable-ldp ipv4
Enable ldp
(config-if)#exit
Exit interface mode
(config)#router ospf 3
Enter OSPF router mode
(config-router)#ospf router-id 104.1.1.1
Configure router-id.
(config-router)#network 104.1.1.1/32 area 0.0.0.2
Advertise the loopback address in area 0.
(config-router)#network 30.1.1.0/24 area 0.0.0.2
Advertise the network address in area 0
(config-router)#exit
Exit OSPF router mode.
(config)#router bgp 1
Enter BGP router mode
(config-router)#neighbor 103.1.1.1 remote-as 1
Advertise the neighbor in BGP process with the remote-as number
(config-router)#neighbor 103.1.1.1 update-source lo
Configure the update-source for the neighbor
(config-router)#neighbor 101.1.1.1 remote-as 1
Advertise the neighbor in BGP process with the remote-as number
(config-router)#neighbor 101.1.1.1 update-source lo
Configure the update-source for the neighbor
(config-router)# address-family ipv4 unicast
Entering into address family ipv4 unicast
(config-router-af)# network 104.1.1.1/32
Advertise the network
(config-router-af)# exit-address-family
Exit from ipv4 address family
(config-router)# address-family ipv4 labeled-unicast
Entering into address family ipv4 labeled-unicast
(config-router-af)#neighbor 103.1.1.1 activate
Activate the ipv4 labeled-unicast neighbor
(config-router-af)# exit-address-family
Exit from ipv4 address family
(config-router)#address-family l2vpn evpn
Enter EVPN address family mode
(config-router-af)#neighbor 101.1.1.1 activate
Activate the neighbor
(config-router-af)#exit-address-family
Exit address family mode.
(config-router)#exit
Exit the router mode
(config)#commit
Commit candidate configuration to be running configuration
(config)#exit
Exit the config mode
PE3
 
#configure terminal
Enter configuration mode.
(config)#interface lo
Enter interface mode for loopback.
(config-if)#ip address 105.1.1.1/32 secondary
Configure IP address on loopback
(config-if)#exit
Exit interface mode
(config)#mac vrf vrfred
Configure MAC VRF
(config-vrf)#rd 105:1
Configure RD for the MAC VRF
(config-vrf)#route-target import 101:1
Configure import RT for the MAC VRF
(config-vrf)#route-target export 105:1
Configure export RT for the MAC VRF
(config-vrf)#exit
Exit VRF mode
(config)#evpn mpls enable
Enable evpn mpls.
(config)#evpn mpls vtep-ip-global 105.1.1.1
Configure VTEP-IP-global.
(config)#evpn mpls id 1000
Configure MPLS EVID.
(config-evpn-mpls)#host-reachability-protocol evpn-bgp vrfred
Configure host-reachability with VRF association.
(config-if)#interface xe3.2
Configure sub-interface to create access-circuit.
(config-if)#switchport
Make the sub-interface a Layer 2 interface
(config-if)#encapsulation dot1q 2
Configure the encapsulation required.
(config-if)#map vpn-id 1000
Map interface to Ethernet virtual network identifier.
(config-if)#exit
Exit interface mode.
(config)#router ldp
Enable RSVP in the PE
(config-router)#router-id 105.1.1.1
Set the router ID to IP address 105.1.1.1
(config-router)#transport-address ipv4 105.1.1.1
Configure transport address
(config)#interface xe4
Enter interface mode for the network side interface.
(config-if)#ip address 40.1.1.2/24
Configure IP address on the network interface
(config-if)#label-switching
Enable label-switching.
(config-if)#enable-ldp
Enable RSVP.
(config-if)#exit
Exit interface mode
(config)#router ospf 3
Enter OSPF router mode
(config-router)#ospf router-id 105.1.1.1
Configure router-id.
(config-router)#network 105.1.1.1/32 area 0.0.0.0
Advertise the loopback address in area 0.
(config-router)#network 40.1.1.0/24 area 0.0.0.0
Advertise the network address in area 0
(config-router)#exit
Exit OSPF router mode.
(config)#router bgp 1
Enter BGP router mode
(config-router)#neighbor 101.1.1.1 remote-as 1
Advertise the neighbor in BGP process with the remote-as number
(config-router)#neighbor 101.1.1.1 update-source lo
Configure the update-source for the neighbor
(config-router)#neighbor 103.1.1.1 remote-as 1
Advertise the neighbor in BGP process with the remote-as number
(config-router)#neighbor 103.1.1.1 update-source lo
Configure the update-source for the neighbor
(config-router)# address-family ipv4 unicast
Entering into address family ipv4 unicast
(config-router-af)# network 105.1.1.1/32
Advertise the network
(config-router-af)# exit-address-family
Exit from ipv4 address family
(config-router)# address-family ipv4 labeled-unicast
Entering into address family ipv4 labeled-unicast
(config-router-af)#neighbor 103.1.1.1 activate
Activate the ipv4 labeled-unicast neighbor
(config-router-af)# exit-address-family
Exit from ipv4 address family
(config-router)#address-family l2vpn evpn
Enter EVPN address family mode
(config-router-af)#neighbor 101.1.1.1 activate
Activate the neighbor
(config-router-af)#exit
Exit the transaction
(config-router)#exit
Exit the router mode
(config)#commit
Commit candidate configuration to be running configuration
(config)#exit
Exit the config mode
Validation
PE1
 
#show evpn mpls tunnel
EVPN-MPLS Network tunnel Entries
Source Destination Status Up/Down Update evpn-id
===================================================================================
101.1.1.1 105.1.1.1 Installed 02:08:11 02:08:11 1000
101.1.1.1 104.1.1.1 Installed 02:08:10 02:08:10 1000
 
Total number of entries are 2
 
pe1#show mpls forwarding-table | inc 105.1.1.1
B> 105.1.1.1/32 6 10 - - LSP_DEFAULT 24960 xe3 No 10.1.1.2
pe1#show mpls forwarding-table | inc 106.1.1.1
B> 106.1.1.1/32 6 10 - - LSP_DEFAULT 24960 xe3 No 10.1.1.2
 
pe1#show ip bgp labeled-unicast
 
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal, S - stale
Network Next Hop In Label Out Label
*> 102.1.1.1/32 0.0.0.0 24320 -
*>i 103.1.1.1/32 10.143.73.2 24322 24961
*>i 104.1.1.1/32 10.143.73.2 24323 24963
*>i 105.1.1.1/32 10.143.73.2 24321 24960
pe1#
 
#show evpn mpls nd-cache
MPLS-EVPN ND-CACHE Information
===========================
EVPN-ID Ip-Addr Mac-Addr Type
_____________________________________________________________________________
1 1001::1 0000.0000.1113 Static Local
Total number of entries are 1
 
#show evpn mpls arp-cache
MPLS-EVPN ARP-CACHE Information
===========================
EVPN-ID Ip-Addr Mac-Addr Type
______________________________________________________
1 11.11.11.1 0000.0000.1112 Static Local
PE2
 
#show bgp l2vpn evpn vrf vrfred
BGP table version is 1, local router ID is 0.0.0.0
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
[EVPN route type]:[ESI]:[VNID]:[relevent route information]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
 
Network Next Hop Metric LocPrf Weight Path Peer Encap
*> [2]:[0]:[1]:[48,0000.0000.2221]:[0]:[1]
101.1.1.1 0 100 32768 i ---------- MPLS
*> [2]:[0]:[1]:[48,0000.0000.2222]:[32,12.12.12.1]:[1]
102.1.1.1 0 100 32768 i ---------- MPLS
*> [2]:[0]:[1]:[48,0000.0000.2223]:[128,2001::1]:[1]
101.1.1.1 0 100 32768 i ---------- MPLS
*> [3]:[1]:[32,102.1.1.1]
102.1.1.1 0 100 32768 i ---------- MPLS
* i [3]:[1]:[32,101.1.1.1]
101.1.1.1 0 100 0 i 101.1.1.1 MPLS
 
Total number of prefixes 5
 
#show bgp l2vpn evpn
BGP table version is 5, local router ID is 102.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
[EVPN route type]:[ESI]:[VNID]:[relevent route information]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
 
Network Next Hop Metric LocPrf Weight Path Peer Encap
 
RD[101:1] VRF[vrfred]:
*> [2]:[0]:[1]:[48,0000.0000.2221]:[0]:[1]
101.1.1.1 0 100 32768 i ---------- MPLS
*> [2]:[0]:[1]:[48,0000.0000.2222]:[32,12.12.12.1]:[1]
101.1.1.1 0 100 32768 i ---------- MPLS
*> [2]:[0]:[1]:[48,0000.0000.2223]:[128,2001::1]:[1]
102.1.1.1 0 100 32768 i ---------- MPLS
*> [3]:[1]:[32,102.1.1.1]
102.1.1.1 0 100 32768 i ---------- MPLS
* i [3]:[1]:[32,101.1.1.1]
101.1.1.1 0 100 0 i 101.1.1.1 MPLS
 
RD[101:1]
*>i [3]:[1]:[32,101.1.1.1]
101.1.1.1 0 100 0 i 101.1.1.1 MPLS
 
#show evpn mpls nd-cache
MPLS-EVPN ND-CACHE Information
===========================
EVPN-ID Ip-Addr Mac-Addr Type
_____________________________________________________________________________
1 2001::1 0000.0000.2223 Static Local
Total number of entries are 1
 
#show evpn mpls arp-cache
MPLS-EVPN ARP-CACHE Information
===========================
EVPN-ID Ip-Addr Mac-Addr Type
______________________________________________________
1 12.12.12.1 0000.0000.2222 Static Local
PE3
 
PE3#show evpn mpls tunnel
EVPN-MPLS Network tunnel Entries
Source Destination Status Up/Down Update evpn-id
===================================================================================
103.1.1.1 101.1.1.1 Installed 21:28:14 21:28:14 1000
 
Total number of entries are 1
 
#show bgp l2vpn evpn vrf vrfred
BGP table version is 1, local router ID is 0.0.0.0
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
[EVPN route type]:[ESI]:[VNID]:[relevent route information]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
 
Network Next Hop Metric LocPrf Weight Path Peer Encap
*> [2]:[0]:[1]:[48,0000.0000.2221]:[0]:[1]
101.1.1.1 0 100 32768 i ---------- MPLS
*> [2]:[0]:[1]:[48,0000.0000.2222]:[32,12.12.12.1]:[1]
104.1.1.1 0 100 32768 i ---------- MPLS
*> [2]:[0]:[1]:[48,0000.0000.2223]:[128,2001::1]:[1]
101.1.1.1 0 100 32768 i ---------- MPLS
*> [3]:[1]:[32,103.1.1.1]
104.1.1.1 0 100 32768 i ---------- MPLS
* i [3]:[1]:[32,101.1.1.1]
101.1.1.1 0 100 0 i 101.1.1.1 MPLS
 
Total number of prefixes 5
 
PE3#show bgp l2vpn evpn
BGP table version is 15, local router ID is 105.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
[EVPN route type]:[ESI]:[VNID]:[relevent route informantion]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
 
Network Next Hop Metric LocPrf Weight Path Peer Encap
 
RD[101:1]
*>i [2]:[0]:[1000]:[48,0000:1111:2222]:[32,10.0.1.1]:[640]
101.1.1.1 0 100 0 i 101.1.1.1 MPLS
*>i [2]:[0]:[1000]:[48,0000:1111:3333]:[0]:[640]
101.1.1.1 0 100 0 i 101.1.1.1 MPLS
*>i [3]:[1000]:[32,101.1.1.1]
101.1.1.1 0 100 0 i 101.1.1.1 MPLS
 
RD[103:1] VRF[vrfred]:
[7m--More--[27m * i [2]:[0]:[1000]:[48,0000:1111:2222]:[32,10.0.1.1]:[640]
101.1.1.1 0 100 0 i 101.1.1.1 MPLS
* i [2]:[0]:[1000]:[48,0000:1111:3333]:[0]:[640]
101.1.1.1 0 100 0 i 101.1.1.1 MPLS
*> [2]:[0]:[1000]:[48,0000:3333:1111]:[0]:[640]
104.1.1.1 0 100 32768 i ---------- MPLS
* i [3]:[1000]:[32,101.1.1.1]
101.1.1.1 0 100 0 i 101.1.1.1 MPLS
*> [3]:[1000]:[32,103.1.1.1]
104.1.1.1 0 100 32768 i ---------- MPLS
 
Total number of prefixes 8
 
#show evpn mpls nd-cache
MPLS-EVPN ND-CACHE Information
===========================
EVPN-ID Ip-Addr Mac-Addr Type
_____________________________________________________________________________
1 2001::1 0000.0000.2223 Static Local
Total number of entries are 1
 
#show evpn mpls arp-cache
MPLS-EVPN ARP-CACHE Information
===========================
EVPN-ID Ip-Addr Mac-Addr Type
______________________________________________________
1 12.12.12.1 0000.0000.2222 Static Local
Last modified date: 10/17/2023