OcNOS-SP : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : EVPN MPLS E-TREE Configuration : Configuring Multi-Homing over BGP-LU
Configuring Multi-Homing over BGP-LU
Topology
Figure 25-4 shows the topology used to show how to configure multi-homing in MPLS EVPN.using BGP-LU as underlay MPLS path
Figure 25-4: MPLS EVPN Multi-homing over LU Configuration
Configuration
PE1
 
#configure terminal
Enter configuration mode.
(config)#interface lo
Enter interface mode for loopback.
(config-if)#ip address 101.1.1.1/32 secondary
Configure IP address on loopback
(config-if)#exit
Exit interface mode
(config)#mac vrf vrfred
Configure MAC VRF
(config-vrf)#rd 101:1
Configure RD for the MAC VRF
(config-vrf)#route-target export 101:1
Configure export RT for the MAC VRF
(config-vrf)#route-target import 104:1
Configure import RT for the MAC VRF
(config-vrf)#route-target import 105:1
Configure import RT for the MAC VRF
(config-vrf)#exit
Exit VRF mode.
(config)#evpn mpls enable
Enable the evpn mpls.
(config)#evpn mpls vtep-ip-global 101.1.1.1
Configure VTEP-IP-global.
(config)#evpn mpls id 1000
Configure MPLS EVID.
(config-evpn-mpls)#host-reachability-protocol evpn-bgp vrfred
Configure host-reachability with VRF association.
(config-if)#interface xe6.2
Configure sub-interface to create access-circuit.
(config-if)#switchport
Make the sub-interface a Layer 2 interface
(config-if)#encapsulation dot1q 2
Configure the encapsulation required.
(config-if)#map vpn-id 10000
Map interface to Ethernet virtual network identifier.
(config-if)#exit
Exit interface mode.
(config)#router ldp
Enable LDP in the PE
(config-router)#exit
Exit router mode
(config)#interface xe5
Enter interface mode for the network side interface.
(config-if)#ip address 10.1.1.1/24
Configure IP address on the network interface
(config-if)#label-switching
Enable label-switching.
(config-if)#enable-ldp ipv4
Enable ldp
(config-if)#exit
Exit interface mode
(config)#router ospf 1
Enter OSPF router mode
(config-router)#ospf router-id 101.1.1.1
Configure router-id.
(config-router)#network 101.1.1.1/32 area 0.0.0.0
Advertise the loopback address in area 0.
(config-router)#network 10.1.1.0/24 area 0.0.0.0
Advertise the network address in area 0
(config-router)#exit
Exit OSPF router mode.
(config)#router bgp 1
Enter BGP router mode
(config)#allocate-label all
Configure allocate all under router bgp
(config-router)#neighbor 102.1.1.1 remote-as 1
Advertise the neighbor in BGP process with the remote-as number
(config-router)#neighbor 102.1.1.1 update-source lo
Configure the update-source for the neighbor
(config-router)#neighbor 104.1.1.1 remote-as 1
Advertise the neighbor in BGP process with the remote-as number
(config-router)#neighbor 104.1.1.1 update-source lo
Configure the update-source for the neighbor
(config-router)#neighbor 105.1.1.1 remote-as 1
Advertise the neighbor in BGP process with the remote-as number
(config-router)#neighbor 105.1.1.1 update-source lo
Configure the update-source for the neighbor
(config-router)# address-family ipv4 unicast
Entering into address family ipv4 unicast
(config-router-af)# network 104.1.1.1/32
Advertise the network
(config-router-af)# exit-address-family
Exit from ipv4 address family
(config-router)# address-family ipv4 labeled-unicast
Entering into address family ipv4 labeled-unicast
(config-router-af)#neighbor 102.1.1.1 activate
Activate the ipv4 labeled-unicast neighbor
(config-router-af)#neighbor 102.1.1.1 next-hop-self
Configure next-hop-self for the ipv4 labeled-unicast neighbor
config-router-af)#neighbor 102.1.1.1 route-reflector-client
Configure neighbor as route reflector client
(config-router-af)# exit-address-family
Exit from ipv4 labeled-unicast address family
(config-router)#address-family l2vpn evpn
Enter EVPN address family mode
(config-router-af)#neighbor 104.1.1.1 activate
Activate the neighbor
(config-router-af)#neighbor 105.1.1.1 activate
Activate the neighbor
(config-router-af)#exit-address-family
Exit address family mode.
(config-router)#exit
Exit the router mode
(config)#commit
Commit the transaction.
(config)#exit
Exit the config mode.
ABR1: Loopback Interface
 
#configure terminal
Enter configuration mode.
(config)#interface lo
Enter the Interface mode for the loopback interface.
(config-if)#ip address 102.1.1.1/32 secondary
Configure IP address on loopback interface.
(config-if)#exit
Exit interface mode
(config)#commit
Commit candidate configuration to be running configuration
(config)#exit
Exit the config mode
ABR1: Global LDP
 
(config)#router ldp
Enter the Router LDP mode.
(config-router)#exit
Exit router mode.
(config)#commit
Commit candidate configuration to be running configuration
ABR1: Interface Configuration
 
(config)#interface xe6
Enter the Interface mode for xe3.
(config-if)#ip address 10.1.1.2/24
Configure IP address on the interface.
(config-if)#enable-ldp ipv4
Enable LDP on the physical interface
(config-if)#label-switching
Enable label switching on the interface.
(config-if)#exit
Exit interface mode
(config)#interface xe1
Enter the Interface mode for xe5
(config-if)#ip address 20.1.1.1/31
Configure IP address on the interface.
(config-if)#enable-ldp ipv4
Enable LDP on the physical interface
(config-if)#label-switching
Enable label switching on the interface.
(config-if)#exit
Exit interface mode
(config)#commit
Commit candidate configuration to be running configuration
(config)#exit
Exit the config mode
ABR1: OSPF Configuration
 
(config)# enable ext-ospf-multi-inst
Enable multiple-instance capability
(config)#router ospf 1
Enter the Router OSPF mode.
(config-router)#ospf router-id 102.1.1.1
Setting the Router ID as Loopback IP
(config-router)#network 102.1.1.1/32 area 0.0.0.0 instance-id 2
Advertise loopback address in OSPF.
(config-router)#network 20.1.1.0/24 area 0.0.0.0
Advertise network address in OSPF.
(config)#router ospf 2
Enter the Router OSPF mode.
(config-router)#network 10.1.1.0/24 area 0.0.0.0 instance-id 1
Advertise the network address in area 0
(config-router)#exit
Exit Router OSPF mode and return to Configure mode.
(config)#commit
Commit candidate configuration to be running configuration
ABR1: BGP-LU Configuration
 
(config)#router bgp 1
Enter the Router BGP mode, ASN: 1
(config)#allocate-label all
Configure allocate all under router bgp
(config-router)#neighbor 101.1.1.1 remote-as 1
Advertise the neighbor in BGP process with the remote-as number
(config-router)#neighbor 101.1.1.1 update-source lo
Configure the update-source for the neighbor
(config-router)#neighbor 103.1.1.1 remote-as 1
Advertise the neighbor in BGP process with the remote-as number
(config-router)#neighbor 103.1.1.1 update-source lo
Configure the update-source for the neighbor
(config-router)# address-family ipv4 unicast
Entering into address family ipv4 unicast
(config-router-af)# network 102.1.1.1/32
Advertise the network
(config-router-af)# exit-address-family
Exit from ipv4 address family
(config-router)# address-family ipv4 labeled-unicast
Entering into address family ipv4 labeled-unicast
(config-router-af)#neighbor 101.1.1.1 activate
Activate the ipv4 labeled-unicast neighbor
(config-router-af)#neighbor 101.1.1.1 next-hop-self
Configure next-hop-self for the ipv4 labeled-unicast neighbor
config-router-af)#neighbor 101.1.1.1 route-reflector-client
Configure neighbor as route reflector client
(config-router-af)#neighbor 103.1.1.1 activate
Activate the ipv4 labeled-unicast neighbor
(config-router-af)#neighbor 103.1.1.1 next-hop-self
Configure next-hop-self for the ipv4 labeled-unicast neighbor
config-router-af)#neighbor 103.1.1.1 route-reflector-client
Configure neighbor as route reflector client
(config-router-af)# exit-address-family
Exit from ipv4 labeled-unicast address family
(config-router)#exit
Exit router mode.
(config)#commit
Commit candidate configuration to be running configuration
ABR2
 
#configure terminal
Enter configuration mode.
(config)#int lo
Enter interface mode for loopback.
(config-if)#ip address 103.1.1.1/32 secondary
Configure IP address on loopback
(config)#router ldp
Configure ldp.
(config)#interface xe4
Enter interface mode for the network side interface.
(config-if)#ip address 30.1.1.1/24
Configure IP address on the network interface
(config-if)#label-switching
Enable label-switching.
(config-if)#enable-ldp
Enable RSVP.
(config)#interface xe1
Enter interface mode for the network side interface.
(config-if)#ip address 20.1.1.2/24
Configure IP address on the network interface
(config-if)#label-switching
Enable label-switching.
(config-if)#enable-ldp
Enable ldp
(config)#interface xe7
Enter interface mode for the network side interface.
(config-if)#ip address 40.1.1.1/24
Configure IP address on the network interface
(config-if)#label-switching
Enable label-switching.
(config-if)#enable-rsvp
Enable RSVP.
(config-if)#exit
Exit interface mode
(config)# enable ext-ospf-multi-inst
Enable multiple-instance capability
(config)#router ospf 2
Enter OSPF router mode
(config-router)#ospf router-id 103.1.1.1
Configure router-id.
(config-router)#network 103.1.1.1/32 area 0.0.0.0 instance-id 3
Advertise the loopback address in area 0.
(config-router)#network 20.1.1.0/24 area 0.0.0.0
Advertise the network address in area 0
(config)#router ospf 3
Enter the Router OSPF mode.
(config-router)#network 30.1.1.0/24 area 0.0.0.0 instance-id 2
Advertise the network address in area 0
(config-router)#network 40.1.1.0/24 area 0.0.0.0
Advertise the network address in area 0
(config-router)#exit
Exit the router mode
(config)#commit
Commit candidate configuration to be running configuration
(config)#exit
Exit the config mode
ABR2: BGP-LU Configuration
 
(config)#router bgp 1
Enter the Router BGP mode, ASN: 1
(config)#allocate-label all
Configure allocate all under router bgp
(config-router)#neighbor 102.1.1.1 remote-as 1
Advertise the neighbor in BGP process with the remote-as number
(config-router)#neighbor 102.1.1.1 update-source lo
Configure the update-source for the neighbor
(config-router)#neighbor 104.1.1.1 remote-as 1
Advertise the neighbor in BGP process with the remote-as number
(config-router)#neighbor 104.1.1.1 update-source lo
Configure the update-source for the neighbor
(config-router)#neighbor 105.1.1.1 remote-as 1
Advertise the neighbor in BGP process with the remote-as number
(config-router)#neighbor 105.1.1.1 update-source lo
Configure the update-source for the neighbor
(config-router)# address-family ipv4 unicast
Entering into address family ipv4 unicast
(config-router-af)# network 103.1.1.1/32
Advertise the network
(config-router-af)# exit-address-family
Exit from ipv4 address family
(config-router)# address-family ipv4 labeled-unicast
Entering into address family ipv4 labeled-unicast
(config-router-af)#neighbor 102.1.1.1 activate
Activate the ipv4 labeled-unicast neighbor
(config-router-af)#neighbor 102.1.1.1 next-hop-self
Configure next-hop-self for the ipv4 labeled-unicast neighbor
config-router-af)#neighbor 102.1.1.1 route-reflector-client
Configure neighbor as route reflector client
(config-router-af)#neighbor 104.1.1.1 activate
Activate the ipv4 labeled-unicast neighbor
(config-router-af)#neighbor 104.1.1.1 next-hop-self
Configure next-hop-self for the ipv4 labeled-unicast neighbor
config-router-af)#neighbor 104.1.1.1 route-reflector-client
Configure neighbor as route reflector client
(config-router-af)#neighbor 105.1.1.1 activate
Activate the ipv4 labeled-unicast neighbor
(config-router-af)#neighbor 105.1.1.1 next-hop-self
Configure next-hop-self for the ipv4 labeled-unicast neighbor
config-router-af)#neighbor 105.1.1.1 route-reflector-client
Configure neighbor as route reflector client
(config-router-af)# exit-address-family
Exit from ipv4 labeled-unicast address family
(config-router)#exit
Exit the router mode
(config)#commit
Commit candidate configuration to be running configuration
PE2
 
#configure terminal
Enter configuration mode.
(config)#int lo
Enter interface mode for loopback.
(config-if)#ip address 104.1.1.1/32 secondary
Configure IP address on loopback
(config-if)#exit
Exit interface mode
(config)#mac vrf vrfred
Configure MAC VRF
(config-vrf)#rd 104:1
Configure RD for the MAC VRF
(config-vrf)#route-target import 101:1
Configure import RT for the MAC VRF
(config-vrf)#route-target export 104:1
Configure export RT for the MAC VRF
(config-vrf)#exit
Exit VRF mode
(config)#evpn mpls enable
Enable evpn mpls.
(config)#evpn mpls vtep-ip-global 104.1.1.1
Configure VTEP-IP-global.
(config)#evpn mpls id 1000
Configure MPLS EVID.
(config-evpn-mpls)#host-reachability-protocol evpn-bgp vrfred
Configure host-reachability with VRF association.
(config)#router ldp
Enable ldp in the PE
(config)#interface xe5
Enter interface mode for the network side interface.
(config-if)#ip address 30.1.1.2/24
Configure IP address on the network interface
(config-if)#label-switching
Enable label-switching.
(config-if)#enable-ldp ipv4
Enable ldp
(config-if)#exit
Exit interface mode
(config)#router ospf 3
Enter OSPF router mode
(config-router)#ospf router-id 104.1.1.1
Configure router-id.
(config-router)#network 104.1.1.1/32 area 0.0.0.2
Advertise the loopback address in area 0.
(config-router)#network 30.1.1.0/24 area 0.0.0.2
Advertise the network address in area 0
(config-router)#exit
Exit OSPF router mode.
(config)#router bgp 1
Enter BGP router mode
(config-router)#neighbor 103.1.1.1 remote-as 1
Advertise the neighbor in BGP process with the remote-as number
(config-router)#neighbor 103.1.1.1 update-source lo
Configure the update-source for the neighbor
(config-router)#neighbor 101.1.1.1 remote-as 1
Advertise the neighbor in BGP process with the remote-as number
(config-router)#neighbor 101.1.1.1 update-source lo
Configure the update-source for the neighbor
(config-router)# address-family ipv4 unicast
Entering into address family ipv4 unicast
(config-router-af)# network 104.1.1.1/32
Advertise the network
(config-router-af)# exit-address-family
Exit from ipv4 address family
(config-router)# address-family ipv4 labeled-unicast
Entering into address family ipv4 labeled-unicast
(config-router-af)#neighbor 103.1.1.1 activate
Activate the ipv4 labeled-unicast neighbor
(config-router-af)# exit-address-family
Exit from ipv4 address family
(config-router)#address-family l2vpn evpn
Enter EVPN address family mode
(config-router-af)#neighbor 101.1.1.1 activate
Activate the neighbor
(config-router-af)#exit-address-family
Exit address family mode.
(config-router)#exit
Exit the router mode
(config)#commit
Commit candidate configuration to be running configuration
(config)#evpn multihoming enable
Enable EVPN multi-homing
(config)#int po1
Enter interface mode
(config-if)#evpn multi-homed system-mac 00:00:00:00:00:00:00:11:22
Make the interface multi-homed and set an Ethernet Segment Identifier (ESI)
(config-if)#exit
Exit interface mode.
(config)#int xe6
Enter interface mode
(config-if)#channel-group 1 mode active
Add member to the LAG interface
(config-if)#exit
Exit the interface mode.
(config)#commit
Commit candidate configuration to be running configuration
(config-if)#int po1.2
Configure sub-interface to create access-circuit.
(config-if)#switchport
Make the sub-interface a Layer 2 interface
(config-if)#encapsulation dot1q 2
Configure the encapsulation required.
(config-if)#map vpn-id 1000
Map interface to Ethernet virtual network identifier.
(config-if)#exit
Exit interface mode.
(config)#commit
Commit candidate configuration to be running configuration
PE3
 
#configure terminal
Enter configuration mode.
(config)#int lo
Enter interface mode for loopback.
(config-if)#ip address 105.1.1.1/32 secondary
Configure IP address on loopback
(config-if)#exit
Exit interface mode
(config)#mac vrf vrfred
Configure MAC VRF
(config-vrf)#rd 105:1
Configure RD for the MAC VRF
(config-vrf)#route-target import 101:1
Configure import RT for the MAC VRF
(config-vrf)#route-target export 105:1
Configure export RT for the MAC VRF
(config-vrf)#exit
Exit VRF mode
(config)#evpn mpls enable
Enable evpn mpls.
(config)#evpn mpls vtep-ip-global 105.1.1.1
Configure VTEP-IP-global.
(config)#evpn mpls id 1000
Configure MPLS EVID.
(config-evpn-mpls)#host-reachability-protocol evpn-bgp vrfred
Configure host-reachability with VRF association.
(config-if)#exit
Exit interface mode.
(config)#router ldp
Enable RSVP in the PE
(config)#interface xe4
Enter interface mode for the network side interface.
(config-if)#ip address 40.1.1.2/24
Configure IP address on the network interface
(config-if)#label-switching
Enable label-switching.
(config-if)#enable-ldp
Enable RSVP.
(config-if)#exit
Exit interface mode
(config)#router ospf 3
Enter OSPF router mode
(config-router)#ospf router-id 105.1.1.1
Configure router-id.
(config-router)#network 105.1.1.1/32 area 0.0.0.0
Advertise the loopback address in area 0.
(config-router)#network 40.1.1.0/24 area 0.0.0.0
Advertise the network address in area 0
(config-router)#exit
Exit OSPF router mode.
(config)#router bgp 1
Enter BGP router mode
(config-router)#neighbor 101.1.1.1 remote-as 1
Advertise the neighbor in BGP process with the remote-as number
(config-router)#neighbor 101.1.1.1 update-source lo
Configure the update-source for the neighbor
(config-router)#neighbor 103.1.1.1 remote-as 1
Advertise the neighbor in BGP process with the remote-as number
(config-router)#neighbor 103.1.1.1 update-source lo
Configure the update-source for the neighbor
(config-router)# address-family ipv4 unicast
Entering into address family ipv4 unicast
(config-router-af)# network 105.1.1.1/32
Advertise the network
(config-router-af)# exit-address-family
Exit from ipv4 address family
(config-router)# address-family ipv4 labeled-unicast
Entering into address family ipv4 labeled-unicast
(config-router-af)#neighbor 103.1.1.1 activate
Activate the ipv4 labeled-unicast neighbor
(config-router-af)# exit-address-family
Exit from ipv4 address family
(config-router)#address-family l2vpn evpn
Enter EVPN address family mode
(config-router-af)#neighbor 101.1.1.1 activate
Activate the neighbor
(config-router-af)#exit
Exit the transaction
(config-router)#exit
Exit the router mode
(config)#commit
Commit candidate configuration to be running configuration
(config)#evpn multihoming enable
Enable EVPN multi-homing
(config)#int po1
Enter interface mode
(config-if)#evpn multi-homed system-mac 00:00:00:00:00:00:00:11:22
Make the interface multi-homed and set an Ethernet Segment Identifier (ESI)
(config-if)#exit
Exit interface mode.
(config)#int xe3
Enter interface mode
(config-if)#channel-group 1 mode active
Add member to the LAG interface
(config-if)#exit
Exit the interface mode.
(config)#commit
Commit candidate configuration to be running configuration
(config-if)#int po1.2
Configure sub-interface to create access-circuit.
(config-if)#switchport
Make the sub-interface a Layer 2 interface
(config-if)#encapsulation dot1q 2
Configure the encapsulation required.
(config-if)#map vpn-id 10000
Map interface to Ethernet virtual network identifier.
(config-if)#commit
Commit candidate configuration to be running configuration
Validation
Note: Remote entries cannot be fetched from through MAC table/ARP cache/ND cache. However they can be fetched from the BGP table.
PE1
#show evpn mpls tunnel
EVPN-MPLS Network tunnel Entries
Source Destination Status Up/Down Update evpn-id
===================================================================================
101.1.1.1 105.1.1.1 Installed 01:25:18 01:25:18 1000
101.1.1.1 104.1.1.1 Installed 01:24:22 01:24:22 1000
 
#show evpn mpls tunnel label
EVPN-MPLS Network tunnel labels
Local Remote
Destination Status evpn-id Network-Intf Tunnel-Label MC-Label UC-Label MC-Label UC-Label
===================================================================================================================
103.1.1.1 Installed 1000 xe1 24320 16 640 16 640
104.1.1.1 Installed 1000 xe2 24324 16 640 16 640
 
Total number of entries are 2
 
#show evpn mpls mac-table
 
==========================================================================================================================================
EVPN MPLS MAC Entries
==========================================================================================================================================
VNID Interface VlanId Inner-VlanId Mac-Addr VTEP-Ip/ESI Type Status AccessPortDesc
__________________________________________________________________________________________________________________________________________
 
1000 po1.2 ---- ---- 0000.0000.0001 00:00:00:00:00:00:00:00:11:22 Dynamic Local ------- -------
1000 po1.2 ---- ---- 0000.0000.0003 00:00:00:00:00:00:00:00:11:22 Dynamic Local ------- -------
1000 po1.2 ---- ---- 0000.0000.0004 00:00:00:00:00:00:00:00:11:22 Dynamic Local ------- -------
1000 po1.2 ---- ---- 0000.0000.0005 00:00:00:00:00:00:00:00:11:22 Dynamic Local ------- -------
1000 po1.2 ---- ---- 0000.0000.0006 00:00:00:00:00:00:00:00:11:22 Dynamic Local ------- -------
1000 po1.2 ---- ---- 0000.0000.0007 00:00:00:00:00:00:00:00:11:22 Dynamic Local ------- -------
 
#show evpn mpls arp-cache
MPLS-EVPN ARP-CACHE Information
===========================
EVPN-ID Ip-Addr Mac-Addr Type
______________________________________________________
1000 11.11.11.1 0000.0000.1002 Static Local
Total number of entries are 1
 
#show evpn mpls nd-cache
MPLS-EVPN ND-CACHE Information
===========================
EVPN-ID Ip-Addr Mac-Addr Type
_____________________________________________________________________________
1000 1001::1 0000.0000.1003 Static Local
Total number of entries are 1
 
#show evpn mpls id 1000
EVPN-MPLS Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
 
VPN-ID EVI-Name EVI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
_______________________________________________________________________________________________________________________________
1000 ---- L2 NW ---- ---- ---- ---- 101.1.1.1 105.1.1.1
1000 ---- L2 NW ---- ---- ---- ---- 101.1.1.1 104.1.1.1
1000 ---- -- AC po1.2 00:00:00:00:00:00:00:00:11:22 ---- DF ---- ----
 
#show evpn mpls tunnel summary
 
Total number of entries: 2 [Installed: 2, Resolved: 0, Unresolved: 0]
 
#show evpn mpls mac-table summary
==========================================================
Evpn mpls MAC Summary
==========================================================
 
Total number of entries are : 6
 
 
#show bgp l2vpn evpn
BGP table version is 6, local router ID is 10.12.4.242
Status codes: s suppressed, d damped, h his]tory, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
[EVPN route type]:[ESI]:[VNID]:[relevent route information]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
Network Next Hop Metric LocPrf Weight Path Peer Encap
RD[101:1] VRF[vrfred]:
* i [1]:[00:00:00:00:00:00:00:00:11:22]:[1]:[18]
103.1.1.1 0 100 0 i 102.1.1.1 MPLS
*> 101.1.1.1 0 100 32768 i ---------- MPLS
* i [1]:[00:00:00:00:00:00:00:00:11:22]:[4294967295]:[0]
103.1.1.1 0 100 0 i 102.1.1.1 MPLS
* i [2]:[00:00:00:00:00:00:00:00:11:22]:[1]:[48,0000.0000.1001]:[0]:[1]
103.1.1.1 0 100 0 i 102.1.1.1 MPLS
*> 101.1.1.1 0 100 32768 i ---------- MPLS
* i [2]:[00:00:00:00:00:00:00:00:11:22]:[1]:[48,0000.0000.1002]:[32,12.12.12.1]:[1]
103.1.1.1 0 100 0 i 102.1.1.1 MPLS
*> 101.1.1.1 0 100 32768 i ---------- MPLS
* i [2]:[00:00:00:00:00:00:00:00:11:22]:[1]:[48,0000.0000.1003]:[128,2001::1]:[1]
103.1.1.1 0 100 0 i 102.1.1.1 MPLS
*> 101.1.1.1 0 100 32768 i ---------- MPLS
*> [3]:[1]:[32,101.1.1.1]
101.1.1.1 0 100 32768 i ---------- MPLS
* i [3]:[1]:[32,102.1.1.1]
103.1.1.1 0 100 0 i 102.1.1.1 MPLS
* i [3]:[1]:[32,103.1.1.1]
104.1.1.1 0 100 0 i 103.1.1.1 MPLS
 
RD[102:1]
*>i [1]:[00:00:00:00:00:00:00:00:11:22]:[1]:[18]
103.1.1.1 0 100 0 i 102.1.1.1 MPLS
*>i [2]:[00:00:00:00:00:00:00:00:11:22]:[1]:[48,0000.0000.1001]:[0]:[1]
103.1.1.1 0 100 0 i 102.1.1.1 MPLS
*>i [2]:[00:00:00:00:00:00:00:00:11:22]:[1]:[48,0000.0000.1002]:[32,12.12.12.1]:[1]
103.1.1.1 0 100 0 i 102.1.1.1 MPLS
*>i [2]:[00:00:00:00:00:00:00:00:11:22]:[1]:[48,0000.0000.1003]:[128,2001::1]:[1]
103.1.1.1 0 100 0 i 102.1.1.1 MPLS
*>i [3]:[1]:[32,102.1.1.1]
103.1.1.1 0 100 0 i 102.1.1.1 MPLS
RD[102:1]
*>i [1]:[00:00:00:00:00:00:00:00:11:22]:[4294967295]:[0]
102.1.1.1 0 100 0 i 102.1.1.1 MPLS
RD[103:1]
*>i [3]:[1]:[32,103.1.1.1]
103.1.1.1 0 100 0 i 103.1.1.1 MPLS
Total number of prefixes 16
PE3
 
#show evpn mpls tunnel
EVPN-MPLS Network tunnel Entries
Source Destination Status Up/Down Update evpn-id ILM
=========================================================================================================
104.1.1.1 101.1.1.1 Installed 02:08:55 02:08:55 1000 0
104.1.1.1 105.1.1.1 Installed 02:08:52 02:08:52 1000 0
Total number of entries are 2
 
#show evpn mpls tunnel label
EVPN-MPLS Network tunnel labels
Local Remote
Destination Status evpn-id Network-Intf Tunnel-Label MC-Label UC-Label MC-Label UC-Label
===================================================================================================================
104.1.1.1 Installed 1000 xe5 24320 16 640 16 640
104.1.1.1 Installed 1000 xe5 24324 16 640 16 640
 
 
Total number of entries are 3
 
#show evpn mpls id 1000
EVPN-MPLS Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
 
VPN-ID EVI-Name EVI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
____________________________________________________________________________________________________________________________
1000 ---- L2 NW ---- ---- ---- ---- 104.1.1.1 101.1.1.1
1000 ---- L2 NW ---- ---- ---- ---- 104.1.1.1 105.1.1.1
1000 ---- -- AC po1.2 00:00:00:00:00:00:00:00:11:22 ---- DF ---- ----
 
 
#show evpn mpls tunnel summary
 
Total number of entries: 2 [Installed: 2, Resolved: 0, Unresolved: 0]
 
#show evpn mpls mac-table summary
==========================================================
Evpn mpls MAC Summary
==========================================================
 
Total number of entries are : 6
 
PE1#show evpn mpls route-count
EVPN-MPLS Active route count information
====================================
Max route count : 32768
Active route count: 6
 
---------------------------------------------
VNID Total MACONLY MACIPv4 MACIPv6
---------------------------------------------
1000 6 6 0 0
 
Total number of entries are 1
 
#show bgp l2vpn evpn multihoming ethernet-ad-per-es
 
RD[101:1]
ESI Eth-Tag VNID Nexthop IP
00:00:00:00:00:00:00:00:11:22 4294967295 0 101.1.1.1
#
#show bgp l2vpn evpn multihoming ethernet-ad-per-evi
 
RD[101:1]
ESI Eth-Tag VNID Nexthop IP
00:00:00:00:00:00:00:00:11:22 100 19 101.1.1.1
#
PE4
 
#show evpn mpls tunnel
EVPN-MPLS Network tunnel Entries
Source Destination Status Up/Down Update evpn-id ILM
=========================================================================================================
105.1.1.1 101.1.1.1 Installed 02:02:55 02:02:55 1000 0
105.1.1.1 104.1.1.1 Installed 02:02:55 02:02:55 1000 16
Total number of entries are 2
 
#show evpn mpls tunnel label
EVPN-MPLS Network tunnel labels
Local Remote
Destination Status evpn-id Network-Intf Tunnel-Label MC-Label UC-Label MC-Label UC-Label
===================================================================================================================
101.1.1.1 Installed 1000 xe1 24320 16 640 16 640
104.1.1.1 Installed 1000 xe2 24325 16 640 16 640
 
Total number of entries are 2
 
#show evpn mpls id 1000
EVPN-MPLS Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
 
VPN-ID EVI-Name EVI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
_______________________________________________________________________________________________________________________________
1000 ---- L2 NW ---- ---- ---- ---- 104.1.1.1 101.1.1.1
1000 ---- L2 NW ---- ---- ---- ---- 104.1.1.1 105.1.1.1
1000 ---- -- AC po1.2 00:00:00:00:00:00:00:00:11:22 ---- DF ---- ----
 
#show evpn mpls tunnel summary
 
Total number of entries: 2 [Installed: 2, Resolved: 0, Unresolved: 0]
 
#show evpn mpls mac-table summary
==========================================================
Evpn mpls MAC Summary
==========================================================
 
Total number of entries are : 6
 
Last modified date: 10/17/2023