OcNOS-SP : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : RSVP-TE Configuration : Fast Reroute Configuration (one-to-one method)
Fast Reroute Configuration (one-to-one method)
The Fast Reroute (FRR) configuration is a MPLS resiliency technology that provides fast traffic recovery when there is a link or router failure on mission critical services. These mechanisms enable the re-direction of traffic onto backup LSP tunnels in tens of milliseconds, in the event of a failure. The one-to-one backup method creates detour LSPs for each protected LSP at each potential point of local repair. This method is used to protect links and nodes during network failure.
In the below configurations each FRR trunk is mapped to VPWS,VPLS, and L3 VPN services.So it includes configurations of VPWS,VPLS and L3 VPN also.
Figure 6-13 is a simple topology example for FRR:
Figure 6-13: Topology Example for Fast Reroute
RTR-29
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 29.29.29.29/32 secondary
Set a secondary IP address of the interface
(config-if)#no shutdown
Administratively bring the interface up.
(config-if)#exit
Exit interface mode.
(config)#router-id 29.29.29.29
Configure the router ID.
(config)#router rsvp
Enter to router rsvp mode.
(config-router)#exit
Exit the router mode
(config)#router ldp
Enter to router LDP mode.
(config-router)#targeted-peer ipv4 30.30.30.30
Configure targeted peer.
(config-router-targeted-peer)#exit-targeted-peer-mode
Exit-targeted-peer-mode
(config-router)#exit
Exit router mode
(config)#interface xe21
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface.
(config-if)#ip address 21.21.21.29/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#enable-ldp ipv4
Enable LDP on this interface
(config-if)#exit
Exit interface mode.
(config)#interface xe22
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface
(config-if)#enable-ldp ipv4
Enable LDP on this interface
(config-if)#ip address 22.22.22.29/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf
Enter the router configure mode for OSPF.
(config-router)#router-id 29.29.29.29
Configure OSPF router-ID same as loopback interface IP address
(config-router)#network 21.21.21.0/24 area 0
(config-router)#network 22.22.22.0/24 area 0
(config-router)#network 29.29.29.29/32 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#exit
Exit the router configure mode.
(config)#rsvp-path p21
Enter the path mode for RSVP pt1.
(config-path)#21.21.21.43 strict
Configure this explicit route path as a strict hop.
(config-path)#38.38.38.42 strict
Configure this explicit route path as a strict hop.
(config-path)#69.69.69.30 strict
Configure this explicit route path as a strict hop.
(config)#exit
Exit the path mode.
(config)#rsvp-trunk to_30 ipv4
Enter the trunk mode for RSVP.
(config-trunk)#primary fast-reroute protection one-to-one
Configure primary fast-reroute protection facility for a trunk.
(config-trunk)#primary fast-reroute node-protection
Configure primary fast-reroute node protection for the trunk
(config-trunk)#primary path p21
Configure trunk to 30 to use the defined path.
(config-trunk)#to 30.30.30.30
Specify the IPv4 egress (destination point) for the LSP.
(config-trunk)#exit
Exit from trunk mode.
(config)#ip vrf vrf1
Configure VRF instance
(config-vrf)#rd 100:1
Configure Router Distinguisher value
(config-vrf)#route-target both 100:1
Configure route-target as both
(config-vrf)#exit
Exit the path mode.
(config)#interface xe43
Enter to the interface mode
(config-if)#ip vrf forwarding vrf1
Bind the VRF instance to the interface
(config-if)#ip address 43.43.43.29/24
Configure IP address
(config-if)#exit
Exit interface mode.
(config)#router bgp 100
Configure BGP router instance
(config-router)#neighbor 30.30.30.30 remote-as 100
Configure neighbor with remote-as
(config-router)#neighbor 30.30.30.30 update-source 29.29.29.29
Configure update source as loopback address
(config-router)#address-family vpnv4 unicast
Configure VPNv4 address family
(config-router-af)#neighbor 30.30.30.30 activate
Activate the VPN neighbor
(config-router-af)#exit-address-family
Exit the VPN address family
(config-router)#address-family ipv4 vrf vrf1
Configure VRF address family
(config-router-af)redistribute connected
Redistribute connected route
(config-router-af)exit-address-family
Exit VRF address family
(config-router)#exit
Exit router mode
(config)#mpls l2-circuit vlan10 10 30.30.30.30
Configure Virtual circuit.
(config-pseudowire)#exit
Exit pseudowire config mode.
(config)#service-template st1
Template configuration
(config-svc)#match outer-vlan 10
Match criteria under template configuration
(config-svc)#exit
Exit service template mode
(config)#service-template st2
Template configuration
(config-svc)#match outer-vlan 30
Match criteria under template configuration
(config-svc)#exit
Exit service template mode
(config)#interface xe44
Enter interface configuration mode
(config-if)#switchport
Configure interface as switch port
(config-if)#mpls-l2-circuit t1 service-template st1
Bind the interface to the VC with service template
(config-if)#exit
Exit interface configuration mode
(config)#mpls vpls vpls30 30
Configure VPLS instance
(config-vpls)#signaling ldp
Configure VPLS signaling as LDP
(config-vpls-sig)#vpls-type vlan
Configure VPLS type as VLAN encapsulation
(config-vpls-sig)#vpls-peer 30.30.30.30
Configure VPLS peer
(config-vpls-sig)#exit-signaling
Exit VPLS configuration mode
(config)#interface xe45
Enter interface configuration mode
(config-if)#switchport
Configure interface as switch port
(config-if)#mpls-vpls vpls30 service-template st2
Bind the VPLS instance to the interface
(config-if-vpls)#split-horizon group access1
Configure split-horizon group on VPLS
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#commit
Commit the transaction.
RTR-43
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 43.43.43.43/32 secondary
Set a secondary IP address of the interface
(config-if)#no shutdown
Administratively shutdown the interface.
(config-if)#exit
Exit interface mode.
(config)#router-id 43.43.43.43
Configure the router ID.
(config)#router rsvp
Enter to router RSVP mode.
(config-router)#exit
Exit the router mode
(config)#interface xe5/1
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface.
(config-if)#ip address 11.11.11.43/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe9/1
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface
(config-if)#ip address 21.21.21.43/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe9/2
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface.
(config-if)#ip address 22.22.22.43/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe13/2
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface
(config-if)#ip address 38.38.38.43/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf
Enter the router configure mode for OSPF.
(config-router)#router-id 43.43.43.43
Configure OSPF router-ID same as loopback interface IP address
(config-router)#network 11.11.11.0/24 area 0
(config-router)#network 22.22.22.0/24 area 0
(config-router)#network 21.21.21.0/24 area 0
(config-router)#network 38.38.38.0/24 area 0
(config-router)#network 43.43.43.43/32 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#commit
Commit the transaction.
RTR-42
 
(config)#interface lo
Enter interface mode.
(config-if)#ip address 42.42.42.42/32 secondary
Set a secondary IP address of the interface
(config-if)#no shutdown
Administratively shutdown the interface.
(config-if)#exit
Exit interface mode.
(config)#router-id 42.42.42.42
Configure the router ID.
(config)#router rsvp
Enter to router RSVP mode.
(config-router)#exit
Exit the router mode
(config)#interface xe2
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface.
(config-if)#ip address 5.5.5.42/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe10/1
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface
(config-if)#ip address 25.25.25.42/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe3
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface.
(config-if)#ip address 38.38.38.42/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe4
Enter interface mode
(config-if)#label-switching
Enable label switching on interface
(config-if)#ip address 69.69.69.42/24
Specify an IP address for the interface
(config-if)#no shutdown
Administratively no shutdown the interface
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface
(config-if)#exit
Exit interface mode
(config)#router ospf
Enter the router configure mode for OSPF.
(config-router)#router-id 42.42.42.42
Configure OSPF router-ID same as loopback interface IP address
(config-router)#network 5.5.5.0/24 area 0
(config-router)#network 25.25.25.0/24 area 0
(config-router)#network 69.69.69.0/24 area 0
(config-router)#network 38.38.38.0/24 area 0
(config-router)#network 42.42.42.42/32 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#commit
Commit the transaction
RTR-41
 
(config)#interface lo
Enter interface mode.
(config-if)#ip address 44.44.44.44/32 secondary
Set a secondary IP address of the interface
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#exit
Exit interface mode.
(config)#router-id 44.44.44.44
Configure the router ID.
(config)#router rsvp
Enter to router RSVP mode.
(config-router)#exit
Exit the router mode
(config)#interface xe1/1
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface.
(config-if)#ip address 1.1.1.41/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface
(config-if)#ip address 5.5.5.41/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe5/1
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface.
(config-if)#ip address 11.11.11.41/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf
Enter the router configure mode for OSPF.
(config-router)#router-id 44.44.44.44
Configure OSPF router-ID same as loopback interface IP address
(config-router)#network 5.5.5.0/24 area 0
(config-router)#network 1.1.1.0/24 area 0
(config-router)#network 11.11.11.0/24 area 0
(config-router)#network 44.44.44.44/32 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#commit
Commit the transaction.
RTR-31
 
(config)#interface lo
Enter interface mode.
(config-if)#ip address 31.31.31.31/32 secondary
Set a secondary IP address of the interface
(config-if)#no shutdown
Administratively shutdown the interface.
(config-if)#exit
Exit interface mode.
(config)#router-id 31.31.31.31
Configure the router ID.
(config)#router rsvp
Enter to router RSVP mode.
(config-router)#exit
Exit the router mode
(config)#interface xe1
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface.
(config-if)#ip address 1.1.1.31/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe25
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface
(config-if)#ip address 25.25.25.31/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#interface xe41
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface.
(config-if)#ip address 41.41.41.31/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf
Enter the router configure mode for OSPF.
(config-router)#router-id 31.31.31.31
Configure OSPF router-ID same as loopback interface IP address
(config-router)#network 1.1.1.0/24 area 0
(config-router)#network 25.25.25.0/24 area 0
(config-router)#network 41.41.41.0/24 area 0
(config-router)#network 31.31.31.31/32 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#commit
Commit the transaction.
RTR-30
 
(config)#interface lo
Enter interface mode.
(config-if)#ip address 30.30.30.30/32 secondary
Set a secondary IP address of the interface
(config-if)#no shutdown
Administratively shutdown the interface.
(config-if)#exit
Exit interface mode.
(config)#router-id 30.30.30.30
Configure the router ID.
(config)#router rsvp
Enter to router RSVP mode.
(config-router)#exit
Exit the router mode
(config)#router ldp
Enter to router LDP mode.
(config-router)#targeted-peer ipv4 29.29.29.29
Configure targeted peer.
(config-router-targeted-peer)#exit-targeted-peer-mode
Exit-targeted-peer-mode
(config-router)#exit
Exit router mode
(config)#interface xe41
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface.
(config-if)#ip address 41.41.41.30/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#enable-ldp ipv4
Enable LDP on this interface
(config-if)#exit
Exit interface mode.
(config)#interface xe54/1
Enter interface mode.
(config-if)#label-switching
Enable label switching on interface
(config-if)#enable-ldp ipv4
Enable LDP on this interface
(config-if)#ip address 69.69.69.30/24
Set an IP address of the interface.
(config-if)#no shutdown
Administratively no shutdown the interface.
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf
Enter the router configure mode for OSPF.
(config-router)#router-id 30.30.30.30
Configure OSPF router-ID same as loopback interface IP address
(config-router)#network 41.41.41.0/24 area 0
(config-router)#network 69.69.69.0/24 area 0
(config-router)#network 30.30.30.30/32 area 0
Define the network on which OSPF runs and associate the area ID
(config-router)#commit
Commit the transaction.
(config)#rsvp-path p41
Enter the path mode for RSVP pt1.
(config-path)#41.41.41.31 strict
Configure this explicit route path as a strict hop.
(config-path)#1.1.1.41 strict
Configure this explicit route path as a strict hop.
(config-path)#11.11.11.43 strict
Configure this explicit route path as a strict hop.
(config)#exit
Exit the path mode.
(config)#rsvp-trunk to_29 ipv4
Enter the trunk mode for rsvp.
(config-trunk)#primary fast-reroute protection one-to-one
Configure primary fast-reroute protection facility for a trunk.
(config-trunk)#primary fast-reroute node-protection
Configure primary fast-reroute node protection for the trunk
(config-trunk)#primary path p41
Configure trunk to_29 to use the defined path.
(config-trunk)#to 29.29.29.29
Specify the IPv4 egress (destination point) for the LSP.
(config-trunk)#exit
Exit from trunk mode.
(config)#ip vrf vrf1
Configure VRF instance
(config-vrf)#rd 100:1
Configure Router Distinguisher value
(config-vrf)#route-target both 100:1
Configure route-target as both
(config-vrf)#exit
Exit the path mode.
(config)#interface xe23
Enter to the interface mode
(config-if)#ip vrf forwarding vrf1
Bind the VRF instance to the interface
(config-if)#ip address 23.23.23.29/24
Configure IP address
(config-if)#exit
Exit interface mode.
(config)#router bgp 100
Configure BGP router instance
(config-router)#neighbor 29.29.29.29 remote-as 100
Configure neighbor with remote-as
(config-router)#neighbor 29.29.29.29 update-source 30.30.30.30
Configure update source as loopback address
(config-router)#address-family vpnv4 unicast
Configure VPNv4 address family
(config-router-af)#neighbor 29.29.29.29 activate
Activate the VPN neighbor
(config-router-af)#exit-address-family
Exit the VPN address family
(config-router)#address-family ipv4 vrf vrf1
Configure VRF address family
(config-router-af)redistribute connected
Redistribute connected route
(config-router-af)exit-address-family
Exit VRF address family
(config-router)#exit
Exit router mode
(config)#mpls l2-circuit vlan10 10 29.29.29.29
Configure Virtual circuit.
(config-pseudowire)#exit
Exit pseudowire config mode.
(config)#service-template st1
Template configuration
(config-svc)#match outer-vlan 10
Match criteria under template configuration
(config-svc)#exit
Exit service template mode
(config)#service-template st2
Template configuration
(config-svc)#match outer-vlan 30
Match criteria under template configuration
(config-svc)#exit
Exit service template mode
(config)#interface xe24
Enter interface configuration mode
(config-if)#switchport
Configure interface as switch port
(config-if)#mpls-l2-circuit vlan10 service-template st1
Bind the interface to the VC with service template
(config-if)#exit
Exit interface configuration mode
(config)#mpls vpls vpls30 30
Configure VPLS instance
(config-vpls)#signaling ldp
Configure VPLS signaling as LDP
(config-vpls-sig)#vpls-type vlan
Configure VPLS type as VLAN encapsulation
(config-vpls-sig)#vpls-peer 29.29.29.29
Configure VPLS peer
(config-vpls-sig)#exit-signaling
Exit VPLS configuration mode
(config)#interface xe25
Enter interface configuration mode
(config-if)#switchport
Configure interface as switch port
(config-if)#mpls-vpls vpls30 service-template st2
Bind the VPLS instance to the interface
(config-if-vpls)#split-horizon group access1
Configure split-horizon group on VPLS
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#commit
Commit the transaction.
Validation
RTR-30#show rsvp session
Ingress RSVP:
To From State Pri Rt Style Labelin Labelout LSPName Uptime Est.time D
SType
29.29.29.29 30.30.30.30 Up Yes 1 1 SE - 24322 to_29-Primary 00:07:53 0s 118ms D
EFAULT
29.29.29.29 69.69.69.30 Up No 1 1 SE - 24322 to_29-Detour 00:07:53 0s 4ms DEF
AULT
Total 2 displayed, Up 2, Down 0.
 
Egress RSVP:
To From State Pri Rt Style Labelin Labelout LSPName Uptime Est.time D
SType
30.30.30.30 29.29.29.29 Up Yes 1 1 SE 24960 - to_30-Primary 00:07:57 N/A ELSP
_CON
30.30.30.30 25.25.25.42 Up Yes 1 1 SE 24961 - to_30-Detour 00:07:57 N/A ELSP
_CON
Total 2 displayed, Up 2, Down 0.
 
 
RTR-30#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf Nexthop
R(t)> 29.29.29.29/32 1 5001 Yes LSP_DEFAULT 24322 xe2 41.41.41.31
R(t)> 29.29.29.29/32 2 5001 No LSP_DEFAULT 24322 xe1 69.69.69.42
RTR-30#
 
RTR-30#show mpls vrf-table
Output for IPv4 VRF table with id: 2
Primary FTN entry with FEC: 43.43.43.0/24, id: 1, row status: Active
Owner: BGP, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 5001, Protected LSP id: 0, QoS Resource id: 0, Description: N/A
Matched bytes:0, pkts:0, TX bytes:0, Pushed pkts:0
Cross connect ix: 7, in intf: - in label: 0 out-segment ix: 6
Owner: BGP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 6, owner: BGP, out intf: xe1, out label: 25602
Nexthop addr: 29.29.29.29 cross connect ix: 7, op code: Push and Lookup
 
 
Link 41.41.41.0/24 Goes down. Interface xe41 on router 30 is admistratively disabled with the "shutdown command".
 
RTR-30#
 
RTR-30#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
RTR-30(config)#int xe41
RTR-30(config-if)#shutdown
RTR-30(config-if)#
 
 
RTR-30#show rsvp session
Ingress RSVP:
To From State Pri Rt Style Labelin Labelout LSPName Uptime Est.time D
SType
29.29.29.29 30.30.30.30 Using Backup Yes 0 0 SE - - to_29-Primary N/A DEFAULT
29.29.29.29 30.30.30.30 Dn Yes 0 0 SE - - to_29-Primary N/A DEFAULT
29.29.29.29 69.69.69.30 Up No 1 1 SE - 24322 to_29-Detour 00:10:53 0s 4ms DEF
AULT
Total 3 displayed, Up 1, Down 2.
 
Egress RSVP:
To From State Pri Rt Style Labelin Labelout LSPName Uptime Est.time D
SType
30.30.30.30 29.29.29.29 Up Yes 1 1 SE 24960 - to_30-Primary 00:10:57 N/A ELSP
_CON
Total 1 displayed, Up 1, Down 0.
 
 
RTR-30#show mpls vc-table
VC-ID Vlan-ID Inner-Vlan-ID Access-Intf Network-Intf Out Label Tunnel-Label Nexthop Status
10 N/A N/A xe4 xe1 24321 24322 29.29.29.29 Active
RTR-30#
 
 
RTR-30#show mpls vpls mesh
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status
30 29.29.29.29 24322 24320 xe41 24320 2/Up 2 LDP Active
 
 
 
Link 41.41.41.0/24 is reestablished. Interfce xe41 is administrativly re-enabled.
 
 
RTR-30#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
RTR-30(config)#int xe41
RTR-30(config-if)#no shutdown
RTR-30(config-if)#
RTR-30#
 
 
RTR-30#show rsvp session
Ingress RSVP:
To From State Pri Rt Style Labelin Labelout LSPName Uptime Est.time D
SType
29.29.29.29 30.30.30.30 Up Yes 1 1 SE - 24322 to_29-Primary 00:00:01 0s 8ms DEF
AULT
29.29.29.29 69.69.69.30 Up No 1 1 SE - 24322 to_29-Detour 00:00:01 0s 8ms DEF
AULT
Total 2 displayed, Up 2, Down 0.
 
Egress RSVP:
To From State Pri Rt Style Labelin Labelout LSPName Uptime Est.time D
SType
30.30.30.30 29.29.29.29 Up Yes 1 1 SE 24960 - to_30-Primary 00:13:22 N/A ELSP
_CON
30.30.30.30 25.25.25.42 Up Yes 1 1 SE 24961 - to_30-Detour 00:00:08 N/A ELSP
_CON
Total 2 displayed, Up 2, Down 0.
 
 
RTR-30#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
 
Code FEC FTN-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf Nexthop
R(t)> 29.29.29.29/32 1 5001 Yes LSP_DEFAULT 24322 xe41 41.41.41.31
R(t)> 29.29.29.29/32 2 5001 No LSP_DEFAULT 24322 xe54/1 69.69.69.42
 
Note: The primary LSP, which is in using backup state shall continue to use backup path in case where secondary is provisioned after the LSP state is changed to switch to backup.
Last modified date: 10/17/2023