RSVP Detour Over Ring Topology
Overview
In OcNOS, this feature allows the detour formation in the ring topology to enhance the routing experience. The detour formation is a local protection mechanism to reroute the data traffic when a failure or congestion occurs in the primary Label Switched Path (LSP). In Multiprotocol Label Switching (MPLS), the primary LSP is the default path through which the data travels from the source to the destination node.
Feature Characteristics
This feature allows detour to take the upstream path of protected LSP, allowing a detour based protection in a ring topology. The upstream path of the protected LSP is the section of the network that precedes the PLR node in the network. This feature works for both path and sender-template method of detour formation. For the inter-op solutions that do not support the sender-template method, use the path method of detour formation.
In the below diagram, the data traffic path highlighted in green dots is the primary LSP. The link shown with the red cross is locally protected at the Point of Local Repair (PLR) node. A PLR node is a network device that reacts and takes action when a link fails. For continued data traffic flow, detour occurs through the red dotted line. Detour in MPLS is an alternate path used when the primary LSP encounters disruption or congestion.
RSVP-TE FRR failover ring topology Feature Characteristics
Benefits
This feature helps detour the data traffic when there is a link or node failure, keeping the data traffic loss to a minimum (less than 50ms when BFD negotiated for fastest detection).
Prerequisite
Before the detour configuration in a ring topology, configure the RSVP tunnel with fast reroute protection of the one-to-one method.
For more information, refer to the
Fast Reroute Configuration (one-to-one method) section of the
RSVP-TE Configuration chapter in the
OcNOS Multi-Protocol Label Switching Guide.
Configuration
This section shows the configuration procedure to create a detour in the ring topology.
Topology
Configure the primary LSP in the below ring topology from the head end to the tail end.
For example, consider PE1 as the head end and PE2 as the tail end, and the primary LSP is via R1, R2, and R3. In this case, first configure the
Fast Reroute Configuration (one-to-one method) on the PE1 and PE2 and then configure the
detour-allow-primary-upstream-path command in all the nodes. For example, if the link between R3 and PE2 is down, the detour follows via primary LSP to reach PE2.
RSVP-TE FRR failover ring topology - 1:1 Detour
PE1 - OSPF Configurations
This section shows how to configure the Open Shortest Path First (OSPF) as Interior Gateway Protocol (IGP).
PE1#configure terminal | Enter configure mode. |
PE1(config)#interface xe3 | Enter interface mode xe3. |
PE1(config-if)#ip address 61.61.61.3/24 | Configure IPv4 address 61.61.61.3.24. |
PE1(config-if)#label-switching | Configure label switching on xe3. |
PE1(config-if)#enable-rsvp | Enable RSVP on xe3. |
PE1(config-if)#exit | Exit interface mode. |
PE1(config)#interface xe12 | Enter interface mode xe12. |
PE1(config-if)#ip address 58.58.58.2/24 | Configure IPv4 address 58.58.58.2/24. |
PE1(config-if)#label-switching | Configure label switching on xe12. |
PE1(config-if)#enable-rsvp | Enable RSVP on xe12. |
PE1(config-if)#exit | Exit interface mode. |
PE1(config)#interface lo | Enter loopback interface mode. |
PE1(config-if)#ip address 26.26.26.26/32 secondary | Configure IPv4 address 26.26.26.26/32. |
PE1(config-if)#exit | Exit interface mode. |
PE1(config)#router ospf 100 | Enter OSPF router mode. |
PE1(config-router)#ospf router-id 26.26.26.26 | Assign router ID 26.26.26.26 for OSPF. |
PE1(config-router)#network 26.26.26.26/32 area 0.0.0.0 | Define network 26.26.26.26/32 under router OSPF. |
PE1(config-router)#network 58.58.58.0/24 area 0.0.0.0 | Define network 58.58.58.0/24 under router OSPF. |
PE1(config-router)#network 61.61.61.0/24 area 0.0.0.0 | Define network 61.61.61.0/24 under router OSPF. |
PE1(config-router)#exit | Exit router OSPF mode. |
PE1(config)#commit | Commit the transaction. |
PE1(config)#exit | Exit the configure mode. |
PE1 - RSVP Configurations
This section shows:
1. The configuration of detour to take the upstream path of protected LSP.
2. The configuration of the primary LSP and attaching it to the RSVP trunk.
3. The configuration of the FRR.
PE1#configure terminal | Enter configure mode. |
PE1(config)#router rsvp | Enable RSVP globally. |
PE1(config-router)#detour-allow-primary-upstream-path | Configure this CLI to allow detour to take primary upstream path. |
PE1(config-router)#exit | Exit router RSVP mode. |
PE1(config)#rsvp-path PE1-PE2-01 mpls | Configure RSVP path PE1-PE2-01 and enter path mode. |
PE1(config-path)#61.61.61.2 strict | Configure this explicit route path as a strict hop. |
PE1(config-path)#23.23.23.3 strict | Configure this explicit route path as a strict hop. |
PE1(config-path)#41.41.41.3 strict | Configure this explicit route path as a strict hop. |
PE1(config-path)#56.56.56.3 strict | Configure this explicit route path as a strict hop. |
PE1(config-path)#rsvp-trunk TR-PE1-PE2-MP-01 ipv4 | Create an RSVP trunk TR-PE1-PE2-MP-01 and enter the trunk mode. |
PE1(config-trunk)#primary fast-reroute protection one-to-one | Configure primary fast reroute protection. |
PE1(config-trunk)#primary fast-reroute node-protection | Configure node protection. |
PE1(config-trunk)#primary path PE1-PE2-01 | Configure trunk PE1-PE2-01 to use as the primary LSP. |
PE1(config-trunk)#from 26.26.26.26 | Assign the source loopback address 26.26.26.26 to the RSVP trunk. |
PE1(config-trunk)#to 22.22.22.22 | Assign the destination loopback address 22.22.22.22 to the RSVP trunk. |
PE1(config-trunk)#exit | Exit router RSVP trunk mode. |
PE1(config)#commit | Commit the transaction. |
PE1(config)#exit | Exit the configure mode. |
R1 - OSPF Configurations
This section shows how to configure the Open Shortest Path First (OSPF) as Interior Gateway Protocol (IGP).
R1#configure terminal | Enter configure mode. |
R1(config)#interface xe3 | Enter interface mode xe3. |
R1(config-if)#ip address 61.61.61.2/24 | Configure IPv4 address 61.61.61.2/24. |
R1(config-if)#label-switching | Configure label switching on xe3. |
R1(config-if)#enable-rsvp | Enable RSVP on interface xe3. |
R1(config-if)#exit | Exit interface mode. |
R1(config)#interface xe47 | Enter interface mode xe47. |
R1(config-if)#ip address 23.23.23.2/24 | Configure IPv4 address 23.23.23.2/24. |
R1(config-if)#label-switching | Configure label switching on xe47. |
R1(config-if)#enable-rsvp | Enable RSVP on interface xe47. |
R1(config-if)#exit | Exit interface mode. |
R1(config)#interface lo | Enter loopback interface mode. |
R1(config-if)#ip address 24.24.24.24/32 secondary | Configure IPv4 address 24.24.24.24/32. |
R1(config-if)#exit | Exit interface mode. |
R1(config)#router ospf 100 | Enter OSPF router mode. |
R1(config-router)#ospf router-id 24.24.24.24 | Assign router-id for OSPF. |
R1(config-router)#network 23.23.23.0/24 area 0.0.0.0 | Define network 23.23.23.0/24 under router OSPF. |
R1(config-router)#network 24.24.24.24/32 area 0.0.0.0 | Define network 24.24.24.24/32 under router OSPF. |
R1(config-router)#network 61.61.61.0/24 area 0.0.0.0 | Define network 61.61.61.0/24 under router OSPF. |
R1(config-router)#exit | Exit router OSPF mode. |
R1(config)#commit | Commit the transaction. |
R1(config)#exit | Exit the configure mode. |
R1 - RSVP Configurations
This section shows how to configure the detour to take the upstream path of protected LSP.
R1#configure terminal | Enter configure mode. |
R1(config)#router rsvp | Enable RSVP globally. |
R1(config-router)#detour-allow-primary-upstream-path | Configure this CLI to allow detour to take primary upstream path. |
R1(config-router)#exit | Exit router RSVP mode. |
R1(config)#commit | Commit the transaction. |
R1(config)#exit | Exit the configure mode. |
R2 - OSPF Configurations
This section shows how to configure the Open Shortest Path First (OSPF) as Interior Gateway Protocol (IGP).
R2#configure terminal | Enter configure mode. |
R2(config)#interface xe1 | Enter interface mode xe1. |
R2(config-if)#ip address 41.41.41.2/24 | Configure IPv4 address 41.41.41.2/24. |
R2(config-if)#label-switching | Configure label switching on xe1. |
R2(config-if)#enable-rsvp | Enable RSVP on xe1. |
R2(config-if)#exit | Exit interface mode. |
R2(config)#interface xe47 | Enter interface mode xe47. |
R2(config-if)#ip address 23.23.23.3/24 | Configure IPv4 address 23.23.23.3/24. |
R2(config-if)#label-switching | Configure label switching on xe47. |
R2(config-if)#enable-rsvp | Enable RSVP on xe47. |
R2(config-if)#exit | Exit interface mode. |
R2(config)#interface lo | Enter loopback interface mode. |
R2(config-if)#ip address 88.88.88.88/32 secondary | Configure IPv4 address 88.88.88.88/32. |
R2(config-if)#exit | Exit interface mode. |
R2(config)#router ospf 100 | Enter OSPF router mode. |
R2(config-router)#ospf router-id 88.88.88.88 | Assign router-id 88.88.88.88 for OSPF. |
R2(config-router)#network 23.23.23.0/24 area 0.0.0.0 | Define network 23.23.23.0/24 under router OSPF. |
R2(config-router)#network 41.41.41.0/24 area 0.0.0.0 | Define network 41.41.41.0/24 under router OSPF. |
R2(config-router)#network 88.88.88.88/32 area 0.0.0.0 | Define network 88.88.88.88/32 under router OSPF. |
R2(config-router)#exit | Exit router OSPF mode. |
R2(config)#commit | Commit the transaction. |
R2(config)#exit | Exit the configure mode. |
R2 - RSVP Configurations
This section shows how to configure the detour to take the upstream path of protected LSP.
R2#configure terminal | Enter configure mode. |
R2(config)#router rsvp | Enable RSVP globally. |
R2(config-router)#detour-allow-primary-upstream-path | Configure this CLI to allow detour to take primary upstream path. |
R2(config-router)#exit | Exit router RSVP mode. |
R2(config)#commit | Commit the transaction. |
R2(config)#exit | Exit the configure mode. |
R3 - OSPF Configurations
This section shows how to configure the Open Shortest Path First (OSPF) as Interior Gateway Protocol (IGP).
R3#configure terminal | Enter configure mode. |
R3(config)#interface xe1 | Enter interface mode xe1. |
R3(config-if)#ip address 41.41.41.3/24 | Configure IPv4 address 41.41.41.3/24. |
R3(config-if)#label-switching | Configure label switching on xe1. |
R3(config-if)#enable-rsvp | Enable RSVP on xe1. |
R3(config-if)#exit | Exit interface mode. |
R3(config)#interface xe5 | Enter interface mode xe5. |
R3(config-if)#ip address 56.56.56.2/24 | Configure IPv4 address 56.56.56.2/24. |
R3(config-if)#label-switching | Configure label switching on xe5. |
R3(config-if)#enable-rsvp | Enable RSVP on xe5. |
R3(config-if)#exit | Exit interface mode. |
R3(config)#interface lo | Enter loopback interface mode. |
R3(config-if)#ip address 99.99.99.99/32 secondary | Configure IPv4 address 99.99.99.99/32. |
R3(config-if)#exit | Exit interface mode. |
R3(config)#router ospf 100 | Enter OSPF router mode. |
R3(config-router)#ospf router-id 99.99.99.99 | Assign router-id for OSPF. |
R3(config-router)#network 41.41.41.0/24 area 0.0.0.0 | Define network 41.41.41.0/24 under router OSPF. |
R3(config-router)#network 56.56.56.0/24 area 0.0.0.0 | Define network 56.56.56.0/24 under router OSPF. |
R3(config-router)#network 99.99.99.99/32 area 0.0.0.0 | Define network 99.99.99.99/32 under router OSPF. |
R3(config-router)#exit | Exit router OSPF mode. |
R3(config)#commit | Commit the transaction. |
R3(config)#exit | Exit the configure mode. |
R3 - RSVP Configurations
This section shows how to configure the detour to take the upstream path of protected LSP.
R3#configure terminal | Enter configure mode. |
R3(config)#router rsvp | Enable RSVP globally. |
R3(config-router)#detour-allow-primary-upstream-path | Configure this CLI to allow detour to take primary upstream path. |
R3(config-router)#exit | Exit router RSVP mode. |
R3(config)#commit | Commit the transaction. |
R3(config)#exit | Exit the configure mode. |
R5 - OSPF Configurations
This section shows how to configure the Open Shortest Path First (OSPF) as Interior Gateway Protocol (IGP).
R5#configure terminal | Enter configure mode. |
R5(config)#interface xe1 | Enter interface mode 58.58.58.3/24. |
R5(config-if)#ip address 58.58.58.3/24 | Configure IPv4 address. |
R5(config-if)#label-switching | Configure label switching on xe1. |
R5(config-if)#enable-rsvp | Enable RSVP on xe1. |
R5(config-if)#exit | Exit interface mode. |
R5(config)#interface xe13 | Enter interface mode xe13. |
R5(config-if)#ip address 54.54.54.4/24 | Configure IPv4 address 54.54.54.4/24. |
R5(config-if)#label-switching | Configure label switching on xe13. |
R5(config-if)#enable-rsvp | Enable RSVP on xe13. |
R5(config-if)#exit | Exit interface mode. |
R5(config)#interface lo | Enter loopback interface mode. |
R5(config-if)#ip address 17.17.17.17/32 secondary | Configure IPv4 address 17.17.17.17/32. |
R5(config-if)#exit | Exit interface mode. |
R5(config)#router ospf 100 | Enter OSPF router mode. |
R5(config-router)#ospf router-id 17.17.17.17 | Assign router-id for OSPF. |
R5(config-router)#network 17.17.17.17/32 area 0.0.0.0 | Define network 17.17.17.17/32 under router OSPF. |
R5(config-router)#network 54.54.54.0/24 area 0.0.0.0 | Define network 54.54.54.0/24 under router OSPF. |
R5(config-router)#network 58.58.58.0/24 area 0.0.0.0 | Define network 58.58.58.0/24 under router OSPF. |
R5(config-router)#exit | Exit router OSPF mode. |
R5(config)#commit | Commit the transaction. |
R5(config)#exit | Exit the configure mode. |
R5 - RSVP Configurations
This section shows how to configure the detour to take the upstream path of protected LSP.
R5#configure terminal | Enter configure mode. |
R5(config)#router rsvp | Enable RSVP globally. |
R5(config-router)#detour-allow-primary-upstream-path | Configure this CLI to allow detour to take primary upstream path |
R5(config-router)#exit | Exit router RSVP mode |
R5(config)#commit | Commit the transaction. |
R5(config)#exit | Exit the configure mode. |
R4 - OSPF Configurations
This section shows how to configure the Open Shortest Path First (OSPF) as Interior Gateway Protocol (IGP).
R4#configure terminal | Enter configure mode. |
R4(config)#interface xe13 | Enter interface mode xe13. |
R4(config-if)#ip address 54.54.54.3/24 | Configure IPv4 address 54.54.54.3/24. |
R4(config-if)#label-switching | Configure label switching on xe13. |
R4(config-if)#enable-rsvp | Enable RSVP on interface xe13. |
R4(config-if)#exit | Exit interface mode. |
R4(config)#interface xe8 | Enter interface mode xe8. |
R4(config-if)#ip address 62.62.62.3/24 | Configure IPv4 address 62.62.62.3/24. |
R4(config-if)#label-switching | Configure label switching on xe8. |
R4(config-if)#enable-rsvp | Enable RSVP on xe8. |
R4(config-if)#exit | Exit interface mode. |
R4(config)#interface lo | Enter loopback interface mode. |
R4(config-if)#ip address 48.48.48.48/32 secondary | Configure IPv4 address 48.48.48.48/32. |
R4(config-if)#exit | Exit interface mode. |
R4(config)#router ospf 100 | Enter OSPF router mode. |
R4(config-router)#ospf router-id 48.48.48.48 | Assign router-id for OSPF. |
R4(config-router)#network 48.48.48.48/32 area 0.0.0.0 | Define network 48.48.48.48/32 under router OSPF. |
R4(config-router)#network 54.54.54.0/24 area 0.0.0.0 | Define network 54.54.54.0/24 under router OSPF. |
R4(config-router)#network 62.62.62.0/24 area 0.0.0.0 | Define network 62.62.62.0/24 under router OSPF. |
R4(config-router)#exit | Exit router OSPF mode. |
R4(config)#commit | Commit the transaction. |
R4(config)#exit | Exit the configure mode. |
R4 - RSVP Configurations
This section shows how to configure the detour to take the upstream path of protected LSP.
R4#configure terminal | Enter configure mode. |
R4(config)#router rsvp | Enable RSVP globally. |
R4(config-router)#detour-allow-primary-upstream-path | Configure this CLI to allow detour to take primary upstream path. |
R4(config-router)#exit | Exit router RSVP mode. |
R4(config)#commit | Commit the transaction. |
R4(config)#exit | Exit the configure mode. |
PE2 - OSPF Configurations
This section shows how to configure the Open Shortest Path First (OSPF) as Interior Gateway Protocol (IGP).
PE2#configure terminal | Enter configure mode. |
PE2(config)#interface xe5 | Enter interface mode xe5. |
PE2(config-if)#ip address 56.56.56.3/24 | Configure IPv4 address 56.56.56.3/24. |
PE2(config-if)#label-switching | Configure label switching on xe5. |
PE2(config-if)#enable-rsvp | Enable RSVP on xe5. |
PE2(config-if)#exit | Exit interface mode. |
PE2(config)#interface ge8 | Enter interface mode ge8. |
PE2(config-if)#ip address 62.62.62.2/24 | Configure IPv4 address 62.62.62.2/24. |
PE2(config-if)#label-switching | Configure label switching on ge8. |
PE2(config-if)#enable-rsvp | Enable RSVP on ge8. |
PE2(config-if)#exit | Exit interface mode. |
PE2(config)#interface lo | Enter loopback interface mode. |
PE2(config-if)#ip address 22.22.22.22/32 secondary | Configure IPv4 address 22.22.22.22/32. |
PE2(config-if)#exit | Exit interface mode. |
PE2(config)#router ospf 100 | Enter OSPF router mode. |
PE2(config-router)#ospf router-id 22.22.22.22 | Assign router-id for OSPF. |
PE2(config-router)#network 22.22.22.22/32 area 0.0.0.0 | Define network 22.22.22.22/32 under router OSPF. |
PE2(config-router)#network 56.56.56.0/24 area 0.0.0.0 | Define network 56.56.56.0/24 under router OSPF. |
PE2(config-router)#network 62.62.62.0/24 area 0.0.0.0 | Define network 62.62.62.0/24 under router OSPF. |
PE2(config-router)#exit | Exit router OSPF mode. |
PE2(config)#commit | Commit the transaction. |
PE2(config)#exit | Exit the configure mode. |
PE2 - RSVP Configurations
This section shows:
1. The configuration of detour to take the upstream path of protected LSP.
2. The configuration of the primary LSP and attaching it to the RSVP trunk.
3. The configuration of the FRR.
PE2#configure terminal | Enter configure mode. |
PE2(config)#router rsvp | Enable RSVP globally. |
PE2(config-router)#detour-allow-primary-upstream-path | Configure this CLI to allow detour to take primary upstream path. |
PE2(config-router)#exit | Exit router RSVP mode. |
PE2(config)#rsvp-path PE2-PE1-01 mpls | Configure RSVP path PE2-PE1-01 and enter path mode. |
PE2(config-path)#56.56.56.2 strict | Configure this explicit route path as a strict hop. |
PE2(config-path)#41.41.41.2 strict | Configure this explicit route path as a strict hop. |
PE2(config-path)#23.23.23.2 strict | Configure this explicit route path as a strict hop. |
PE2(config-path)#61.61.61.3 strict | Configure this explicit route path as a strict hop. |
PE2(config-router)#exit | Exit path mode. |
PE2(config-path)#rsvp-trunk TR-PE2-PE1-MP-01 ipv4 | Create an RSVP trunk TR-PE2-PE1-MP-01 and enter the Trunk mode. |
PE2(config-trunk)#primary fast-reroute protection one-to-one | Configure primary fast-reroute protection. |
PE2(config-trunk)#primary fast-reroute node-protection | Configure node protection. |
PE2(config-trunk)#primary path PE2-PE1-01 | Configure trunk PE2-PE1-01 to use as the primary LSP. |
PE2(config-trunk)#from 22.22.22.22 | Assign the source loopback address 22.22.22.22 to the RSVP trunk. |
PE2(config-trunk)#to 26.26.26.26 | Assign the destination loopback address 26.26.26.26 to the RSVP trunk. |
PE2(config-trunk)#exit | Exit router RSVP trunk mode. |
PE2(config)#commit | Commit the transaction. |
PE2(config)#exit | Exit the configure mode. |
Validation
PE1
Below is the validation output of RSVP LSPs from PE1 to PE2 via R1>R2>R3:
#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
Ingress RSVP:
To From Tun-ID LSP-ID Type LSPName State Uptime Rt Style Labelin Labelout
22.22.22.22 26.26.26.26 5001 2205 PRI TR-PE1-PE2-MP-01-Primary UP 02:12:32 1 1 SE - 52480
22.22.22.22 58.58.58.2 5001 2205 DTR TR-PE1-PE2-MP-01-Detour UP 00:34:04 1 2 SE - 25600
Total 2 displayed, Up 2, Down 0.
Transit RSVP:
To From Tun-ID LSP-ID Type LSPName State Uptime Rt Style Labelin Labelout
22.22.22.22 61.61.61.2 5001 2205 PRI TR-PE1-PE2-MP-01-Detour UP 00:33:19 1 2 SE 25602 25600
Total 1 displayed, Up 1, Down 0.
Egress RSVP:
To From Tun-ID LSP-ID Type LSPName State Uptime Rt Style Labelin Labelout
26.26.26.26 22.22.22.22 5001 2205 PRI TR-PE2-PE1-MP-01-Primary UP 02:12:27 1 1 SE 25601 -
26.26.26.26 62.62.62.2 5001 2205 PRI TR-PE2-PE1-MP-01-Detour UP 02:09:08 1 1 SE 25600 -
Total 2 displayed, Up 2, Down 0.
Below is the validation output of RSVP ping and trace from PE1 to PE2:
#ping mpls rsvp egress 22.22.22.22 detail
Sending 5 MPLS Echos to 22.22.22.22, timeout is 5 seconds
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
Type 'Ctrl+C' to abort
! seq_num = 1 56.56.56.3 0.91 ms
! seq_num = 2 56.56.56.3 0.54 ms
! seq_num = 3 56.56.56.3 0.48 ms
! seq_num = 4 56.56.56.3 0.47 ms
! seq_num = 5 56.56.56.3 0.50 ms
Success Rate is 100.00 percent (5/5)
round-trip min/avg/max = 0.47/0.69/0.91
PE1#
#trace mpls rsvp egress 22.22.22.22 detail
Tracing MPLS Label Switched Path to 22.22.22.22, timeout is 5 seconds
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
Type 'Ctrl+C' to abort
0 61.61.61.3 [Labels: 52480]
R 1 61.61.61.2 [Labels: 25600] 0.71 ms
R 2 23.23.23.3 [Labels: 25600] 0.83 ms
R 3 41.41.41.3 [Labels: 25600] 0.88 ms
! 4 56.56.56.3 0.69 ms
Below are the outputs from transit nodes R1, R2 and R3 for primary LSP configured:
R1
#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
Ingress RSVP:
To From Tun-ID LSP-ID Type LSPName State Uptime Rt Style Labelin Labelout
22.22.22.22 61.61.61.2 5001 2205 DTR TR-PE1-PE2-MP-01-Detour UP 00:38:43 1 2 SE - 25602
26.26.26.26 23.23.23.2 5001 2205 DTR TR-PE2-PE1-MP-01-Detour UP 00:38:44 1 1 SE - 25603
Total 2 displayed, Up 2, Down 0.
Transit RSVP:
To From Tun-ID LSP-ID Type LSPName State Uptime Rt Style Labelin Labelout
22.22.22.22 26.26.26.26 5001 2205 PRI TR-PE1-PE2-MP-01-Primary UP 02:17:55 1 1 SE 52480 25600
22.22.22.22 23.23.23.3 5001 2205 PRI TR-PE1-PE2-MP-01-Detour UP 00:37:58 1 2 SE 52482 25602
26.26.26.26 22.22.22.22 5001 2205 PRI TR-PE2-PE1-MP-01-Primary UP 02:17:50 1 1 SE 52481 25601
Total 3 displayed, Up 3, Down 0.
R2
#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
Ingress RSVP:
To From Tun-ID LSP-ID Type LSPName State Uptime Rt Style Labelin Labelout
22.22.22.22 23.23.23.3 5001 2205 DTR TR-PE1-PE2-MP-01-Detour UP 00:38:07 1 2 SE - 52482
26.26.26.26 41.41.41.2 5001 2205 DTR TR-PE2-PE1-MP-01-Detour UP 00:39:00 1 2 SE - 25602
Total 2 displayed, Up 2, Down 0.
Transit RSVP:
To From Tun-ID LSP-ID Type LSPName State Uptime Rt Style Labelin Labelout
22.22.22.22 26.26.26.26 5001 2205 PRI TR-PE1-PE2-MP-01-Primary UP 02:18:05 1 1 SE 25600 25600
22.22.22.22 41.41.41.3 5001 2205 PRI TR-PE1-PE2-MP-01-Detour UP 00:37:28 1 2 SE 25602 52482
26.26.26.26 22.22.22.22 5001 2205 PRI TR-PE2-PE1-MP-01-Primary UP 02:18:00 1 1 SE 25601 52481
26.26.26.26 23.23.23.2 5001 2205 PRI TR-PE2-PE1-MP-01-Detour UP 00:38:53 1 2 SE 25603 25602
Total 4 displayed, Up 4, Down 0.
R3
#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
Ingress RSVP:
To From Tun-ID LSP-ID Type LSPName State Uptime Rt Style Labelin Labelout
22.22.22.22 41.41.41.3 5001 2205 DTR TR-PE1-PE2-MP-01-Detour UP 00:37:31 1 1 SE - 25602
26.26.26.26 56.56.56.2 5001 2205 DTR TR-PE2-PE1-MP-01-Detour UP 00:39:23 1 2 SE - 25602
Total 2 displayed, Up 2, Down 0.
Transit RSVP:
To From Tun-ID LSP-ID Type LSPName State Uptime Rt Style Labelin Labelout
22.22.22.22 26.26.26.26 5001 2205 PRI TR-PE1-PE2-MP-01-Primary UP 02:18:08 1 1 SE 25600 25600
26.26.26.26 22.22.22.22 5001 2205 PRI TR-PE2-PE1-MP-01-Primary UP 02:18:02 1 1 SE 25601 25601
26.26.26.26 41.41.41.2 5001 2205 PRI TR-PE2-PE1-MP-01-Detour UP 00:39:03 1 2 SE 25602 25602
Total 3 displayed, Up 3, Down 0.
Below are the outputs from transit nodes R4 and R5 for Detour LSPs formation:
From R4
#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
Transit RSVP:
To From Tun-ID LSP-ID Type LSPName State Uptime Rt Style Labelin Labelout
22.22.22.22 58.58.58.2 5001 2205 PRI TR-PE1-PE2-MP-01-Detour UP 02:14:52 1 1 SE 25600 25601
26.26.26.26 62.62.62.2 5001 2205 PRI TR-PE2-PE1-MP-01-Detour UP 00:39:49 1 1 SE 25601 25601
Total 2 displayed, Up 2, Down 0.
From R5
#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
Transit RSVP:
To From Tun-ID LSP-ID Type LSPName State Uptime Rt Style Labelin Labelout
22.22.22.22 58.58.58.2 5001 2205 PRI TR-PE1-PE2-MP-01-Detour UP 00:39:45 1 1 SE 25600 25600
26.26.26.26 62.62.62.2 5001 2205 PRI TR-PE2-PE1-MP-01-Detour UP 02:14:48 1 1 SE 25601 25600
Total 2 displayed, Up 2, Down 0.
Now, shutting down one of the interfaces on Primary LSP path and check RSVP tunnel outputs on PE1 and PE2
Shutdown interface xe47 connected between R1 and R2:
#configure terminal | Enter Configure mode. |
(config)#interface xe47 | Enter interface mode. |
(config-router)#shutdown | Administratively bring the interface down. |
(config-router)#exit | Exit router RSVP mode |
Below is the validation output of RSVP LSPs from PE1 to PE2 after admin shutting one of the interfaces on primary LSP path:
#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
Ingress RSVP:
To From Tun-ID LSP-ID Type LSPName State Uptime Rt Style Labelin Labelout
22.22.22.22 26.26.26.26 5001 2205 PRI TR-PE1-PE2-MP-01-Primary UP* 02:32:40 1 1 SE - 52480
22.22.22.22 26.26.26.26 5001 2201 PRI TR-PE1-PE2-MP-01-Primary DN N/A 0 0 SE - -
22.22.22.22 58.58.58.2 5001 2205 DTR TR-PE1-PE2-MP-01-Detour UP 00:54:12 1 2 SE - 25600
Total 3 displayed, Up 2, Down 1.
Transit RSVP:
To From Tun-ID LSP-ID Type LSPName State Uptime Rt Style Labelin Labelout
22.22.22.22 61.61.61.2 5001 2205 PRI TR-PE1-PE2-MP-01-Detour UP 00:53:27 1 2 SE 25602 25600
Total 1 displayed, Up 1, Down 0.
Below is the validation output of RSVP ping and trace from PE1 to PE2 after shutting one of the interfaces on primary LSP path:
Egress RSVP:
To From Tun-ID LSP-ID Type LSPName State Uptime Rt Style Labelin Labelout
26.26.26.26 62.62.62.2 5001 2205 PRI TR-PE2-PE1-MP-01-Detour UP 02:29:16 1 1 SE 25600 -
Total 1 displayed, Up 1, Down 0.
#ping mpls rsvp egress 22.22.22.22 detail
Sending 5 MPLS Echos to 22.22.22.22, timeout is 5 seconds
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
Type 'Ctrl+C' to abort
! seq_num = 1 62.62.62.2 0.69 ms
! seq_num = 2 62.62.62.2 0.54 ms
! seq_num = 3 62.62.62.2 0.56 ms
! seq_num = 4 62.62.62.2 0.49 ms
! seq_num = 5 62.62.62.2 0.51 ms
Success Rate is 100.00 percent (5/5)
round-trip min/avg/max = 0.49/0.59/0.69
#trace mpls rsvp egress 22.22.22.22 detail
Tracing MPLS Label Switched Path to 22.22.22.22, timeout is 5 seconds
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
Type 'Ctrl+C' to abort
0 61.61.61.3 [Labels: 52480]
R 1 61.61.61.2 [Labels: 25602] 0.72 ms
R 2 61.61.61.3 [Labels: 25600] 0.67 ms
R 3 58.58.58.3 [Labels: 25600] 0.80 ms
R 4 54.54.54.3 [Labels: 25601] 0.80 ms
! 5 62.62.62.2 0.50 ms
Below is the validation output of RSVP LSPs from PE2 to PE1 after admin shutting one of the interfaces on primary LSP path:
#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
Ingress RSVP:
To From Tun-ID LSP-ID Type LSPName State Uptime Rt Style Labelin Labelout
26.26.26.26 22.22.22.22 5001 2205 PRI TR-PE2-PE1-MP-01-Primary UP* 02:36:19 1 1 SE - 25601
26.26.26.26 22.22.22.22 5001 2201 PRI TR-PE2-PE1-MP-01-Primary DN N/A 0 0 SE - -
26.26.26.26 62.62.62.2 5001 2205 DTR TR-PE2-PE1-MP-01-Detour UP 00:57:57 1 2 SE - 25601
Total 3 displayed, Up 2, Down 1.
Transit RSVP:
To From Tun-ID LSP-ID Type LSPName State Uptime Rt Style Labelin Labelout
26.26.26.26 56.56.56.2 5001 2205 PRI TR-PE2-PE1-MP-01-Detour UP 00:57:40 1 2 SE 25602 25601
Total 1 displayed, Up 1, Down 0.
Egress RSVP:
To From Tun-ID LSP-ID Type LSPName State Uptime Rt Style Labelin Labelout
22.22.22.22 58.58.58.2 5001 2205 PRI TR-PE1-PE2-MP-01-Detour UP 02:33:00 1 1 SE 25601 -
Total 1 displayed, Up 1, Down 0.
Below is the validation output of RSVP ping and trace from PE2 to PE1 after shutting one of the interfaces on primary LSP path:
#ping mpls rsvp egress 26.26.26.26 detail
Sending 5 MPLS Echos to 26.26.26.26, timeout is 5 seconds
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
Type 'Ctrl+C' to abort
! seq_num = 1 58.58.58.2 0.80 ms
! seq_num = 2 58.58.58.2 0.59 ms
! seq_num = 3 58.58.58.2 0.47 ms
! seq_num = 4 58.58.58.2 0.49 ms
! seq_num = 5 58.58.58.2 0.54 ms
Success Rate is 100.00 percent (5/5)
round-trip min/avg/max = 0.47/0.63/0.80
#trace mpls rsvp egress 26.26.26.26 detail
Tracing MPLS Label Switched Path to 26.26.26.26, timeout is 5 seconds
Codes:
'!' - Success, 'Q' - request not sent, '.' - timeout,
'x' - Retcode 0, 'M' - Malformed Request, 'm' - Errored TLV,
'N' - LBL Mapping Err, 'D' - DS Mismatch,
'U' - Unknown Interface, 'R' - Transit (LBL Switched),
'B' - IP Forwarded, 'F' No FEC Found, 'f' - FEC Mismatch,
'P' - Protocol Error, 'X' - Unknown code,
'Z' - Reverse FEC Validation Failed
Type 'Ctrl+C' to abort
0 56.56.56.3 [Labels: 25601]
R 1 56.56.56.2 [Labels: 25601] 1.01 ms
R 2 41.41.41.2 [Labels: 25602] 0.95 ms
R 3 41.41.41.3 [Labels: 25602] 0.62 ms
R 4 56.56.56.3 [Labels: 25601] 0.79 ms
R 5 62.62.62.3 [Labels: 25601] 0.67 ms
R 6 54.54.54.4 [Labels: 25600] 0.57 ms
! 7 58.58.58.2 0.50 ms
Implementation Examples
To implement detour based protection in a ring topology, use the command
detour-allow-primary-upstream-path that allows the detour formation to consider the upstream path of protected LSP. This is only applicable in ring topology.
New CLI Commands
detour-allow-primary-upstream-path
Use this command to ensure detour formation to consider the upstream path of protected LSPs. This is a deviation to RFC 4090 section 6.2 recommendation (https://datatracker.ietf.org/doc/html/rfc4090). This command is intended to be used in special cases where detour protection is required on ring topology if no alternate path is available.
Use the no parameter with this command to bypass the upstream path to the protected LSP when choosing a detour path.
Note: This command is intended to be used in ring topology if detour support is required at the cost of resource and link bandwidth. This command is not recommended to be configured otherwise.
Command Syntax
detour-allow-primary-upstream-path
no detour-allow-primary-upstream-path
Parameters
None
Default
By default, detour formation excludes the protected LSP upstream path as per RFC 4090 section 6.2 recommendations.
Command Mode
Router mode
Applicability
This command was introduced in OcNOS version 6.4.1.
Examples
#configure terminal
(config)#router rsvp
(config-router)#detour-allow-primary-upstream-path
(config-router)#commit
(config-router)#no detour-allow-primary-upstream-path
(config-router)#commit
Abbreviations
The following are some key abbreviations and their meanings relevant to this document:
Acronym | Description |
FRR | Fast Reroute |
LSP | Label Switched Path |
OSPF | Open Shortest Path First |
PLR | Point of Local Repair |
Glossary
The following provides definitions for key terms used throughout this document:
Detour formation in the ring topology | The detour formation in the ring topology is a mechanism to reroute the data traffic over the backup path when a failure or congestion occurs in the primary Label Switched Path (LSP). |
PLR node | A PLR node is a network device that reacts and takes action when a link fails. |
Primary LSP | The primary LSP is the default path of the forwarding data packets from the source device to the destination device. |
Protected LSP | A protected LSP is a primary LSP with a backup path in an MPLS network. When there is an issue or a failure in the primary LSP, the traffic is rerouted through the backup path, protecting the primary LSP. |
RSVP Tunnel | RSVP tunnels are logical paths through which data traffic traverses in an IP network. |
Upstream path of the protected LSP | The upstream path of the protected LSP is the section of the network that precedes the PLR node in the network. |