Backup Router | The VRRP router that is backing up an IP address. It assumes forwarding responsibility for the virtual IP address if the Master fails. |
Critical IP | The IP address that a VRRP router sends/receives messages on for a particular session. |
IP Address Owner | The VRRP Router that has the virtual router's IP address(es) as real interface address(es). This is the router that, when up, will respond to packets addressed to one of these IP addresses for ICMP pings, TCP connections, and so on |
Master Router | The VRRP router that owns the IP address (i.e., is being backed up), and which is the default router for forwarding for that IP address. |
Virtual IP | The IP address that is being backed up by a VRRP session. |
Virtual Router | A router managed by VRRP that acts as a default router for hosts on a shared LAN. It consists of a Virtual Router Identifier and a set of associated IP addresses across a common LAN. A VRRP Router might backup one or more virtual routers. |
VRRPv2 Router | A router running the Virtual Router Redundancy Protocol version 2. It might participate in one or more virtual routers. |
VRRPv3 Router | A router running the Virtual Router Redundancy Protocol version 3. It might participate in one or more virtual routers. |
#configure terminal | Enter the Configure mode. |
(config)#router vrrp 1 eth2 | Create a VRRP instance for interface eth2. |
(config-router)#virtual-ip 10.10.10.50 owner | Set the virtual IP address for the VRRP session. Define the default state (owner) of the VRRP router within the virtual router. |
(config-router)#preempt-mode true | Set the preempt mode to specify that the highest priority will function as a backup to master when master is unavailable. |
(config-router)#advertisement-interval 100 | Configure the advertisement interval to 100 centi seconds (value must be a multiple of 5). |
(config-router)# v2-compatible | Enable the v2-compatible |
(config-router)#authentication text abcd | Configure the authentication text to specify that as simple text for vrrpv2 packets, accept only 8 characters |
(config-router)#enable | Enable the VRRP session on the router. |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
(config-router)#exit | Exit Router mode. |
#configure terminal | Enter the Configure mode. |
(config)#router vrrp 1 eth2 | Create a VRRP instance for interface eth2. |
(config-router)#virtual-ip 10.10.10.50 | Set the virtual IP address for the VRRP session. |
(config-router)#priority 200 | Configure the priority to 200 (less than 255), because R2 is the Backup router. |
(config-router)#preempt-mode true | Set the preempt mode to specify that the highest priority will function as a backup to master when master is unavailable. |
(config-router)#advertisement-interval 100 | Configure the advertisement interval to 100 centi seconds (value must be a multiple of 5). |
(config-router)# v2-compatible | Enable the v2-compatible |
(config-router)#authentication text abcd | Configure the authentication text to specify that as simple text for vrrpv2 packets, accept only 8 characters |
(config-router)#enable | Enable the VRRP session on the router. |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
(config-router)#exit | Exit Router mode. |
#configure terminal | Enter the Configure mode. |
(config)#router vrrp 1 xe1 | Create a VRRP instance for interface xe1. |
(config-router)#virtual-ip 10.10.10.81 owner | Set the virtual IP address for the VRRP session. Define the default state (owner) of the VRRP router within the virtual router. |
(config-router)#preempt-mode true | Set the preempt mode to specify that the highest priority will function as a backup to master when master is unavailable. |
(config-router)#advertisement-interval 100 | Configure the advertisement interval to 100 centi seconds (value must be a multiple of 5). |
(config-router)# v2-compatible | Enable the v2-compatible |
(config-router)#authentication text abcd | Configure the authentication text to specify that as simple text for vrrpv2 packets, accept only 8 characters |
(config-router)#enable | Enable the VRRP session 1 on the router. |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
(config-router)#exit | Exit Router mode and enter the Configure mode. |
(config)#router vrrp 2 xe1 | Create a VRRP instance for interface xe1. |
(config-router)#virtual-ip 10.10.10.82 | Set the virtual IP address for the VRRP session. |
(config-router)#priority 200 | Configure the priority to 200 (less than 255), because R2 is the Backup router. |
(config-router)#preempt-mode true | Set the preempt mode to specify that the highest priority will function as a backup to master when master is unavailable. |
(config-router)#advertisement-interval 100 | Configure the advertisement interval to 100 centi seconds (value must be a multiple of 5). |
(config-router)# v2-compatible | Enable the v2-compatible |
(config-router)#authentication text abcd | Configure the authentication text to specify that as simple text for vrrpv2 packets, accept only 8 characters |
(config-router)#enable | Enable the VRRP session two on the router. |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
(config-router)#exit | Exit Router mode. |
#configure terminal | Enter the Configure mode. |
(config)#router vrrp 1 xe1 | Create a VRRP instance for interface xe1. |
(config-router)#virtual-ip 10.10.10.81 | Set the virtual IP address for the VRRP session. |
(config-router)#priority 200 | Configure the priority to 200 (less than 255), because R2 is the Backup router. |
(config-router)#preempt-mode true | Set the preempt mode to specify that the highest priority will function as a backup to master when master is unavailable. |
(config-router)#advertisement-interval 100 | Configure the advertisement interval to 100 centi seconds (value must be a multiple of 5). |
(config-router)# v2-compatible | Enable the v2-compatible |
(config-router)#authentication text abcd | Configure the authentication text to specify that as simple text for vrrpv2 packets, accept only 8 characters |
(config-router)#enable | Enable the VRRP session 1 on the router. |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
(config-router)#exit | Exit the Router mode and enter the Configure mode. |
(config)#router vrrp 2 xe1 | Create a VRRP instance for interface xe1 |
(config-router)#virtual-ip 10.10.10.82 owner | Set the virtual IP address for the VRRP session. Define the default state (owner) of the VRRP router within the virtual router. |
(config-router)#preempt-mode true | Set the preempt mode to specify that the highest priority will function as a backup to master when master is unavailable. |
(config-router)#advertisement-interval 100 | Configure the advertisement interval to 100 centi seconds (value must be a multiple of 5). |
(config-router)# v2-compatible | Enable the v2-compatible |
(config-router)#authentication text abcd | Configure the authentication text to specify that as simple text for vrrpv2 packets, accept only 8 characters |
(config-router)#enable | Enable the VRRP session two on the router. |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
(config-router)#exit | Exit Router mode. |
#configure terminal | Enter the Configure mode. |
(config)#interface eth2 | Enter interface mode for eth2. |
(config-if)#ip address 2.2.2.1/24 | Configure the IP address for interface eth2 to be in network 0. |
(config-if)#commit | Commit the candidate configuration to the running configuration. |
(config-if)#exit | Exit interface mode. |
(config)#interface eth1 | Enter interface mode for eth1. |
(config-if)#ip address 1.1.1.1/24 | Configure the IP address for interface eth1 to be in network 1. |
(config-if)#commit | Commit the candidate configuration to the running configuration. |
(config-if)#exit | Exit interface mode. |
(config)#router vrrp 1 eth2 | Create a VRRP instance for interface eth2. |
(config-router)#virtual-ip 2.2.2.1 owner | Configure R1 as the owner. |
(config-router)#advertisement-interval 100 | Configure the default value for the advertisement interval. The configurable range is 5 to 4095 centi seconds (value must be a multiple of 5). |
(config-router)#preempt-mode true | Set true as the default value for the field. |
(config-router)# v2-compatible | Enable the v2-compatible |
(config-router)#authentication text abcd | Configure the authentication text to specify that as simple text for vrrpv2 packets, accept only 8 characters |
(config-router)#enable | Enable the VRRP session on the router. |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
(config-router)#exit | Exit Router mode. |
#configure terminal | Enter the Configure mode. |
(config)#interface eth2 | Enter interface mode for eth2. |
(config-if)#ip address 2.2.2.2/24 | Configure the IP address for interface eth2 to be in network 0. |
(config-if)#commit | Commit the candidate configuration to the running configuration. |
(config-if)#exit | Exit interface mode. |
(config)#interface eth1 | Enter interface mode for eth1. |
(config-if)#ip address 1.1.1.2/24 | Configure the IP address for interface eth1 to be in network 1. |
(config-if)#commit | Commit the candidate configuration to the running configuration. |
(config-if)#exit | Exit interface mode. |
(config)#router vrrp 1 eth2 | Create a VRRP instance for interface eth2. |
(config-router)#virtual-ip 2.2.2.1 | Configure R2 as the backup. |
(config-router)#advertisement-interval 100 | Configure the default value for the advertisement interval. The configurable range is 5 to 4095 centi seconds (value must be a multiple of 5). |
(config-router)#priority 100 | Set the default value for the backup router. |
(config-router)#preempt-mode true | Set true as the default value for the field. |
(config-router)# v2-compatible | Enable the v2-compatible |
(config-router)#authentication text abcd | Configure the authentication text to specify that as simple text for vrrpv2 packets, accept only 8 characters |
(config-router)#enable | Enable the VRRP session on the router. |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
(config-router)#exit | Exit Router mode. |
#configure terminal | Enter the Configure mode. |
(config)#interface eth2 | Enter interface mode for eth2. |
(config-if)#ip address 2.2.2.3/24 | Configure the IP address for interface eth2 to be in network 0. |
(config-if)#commit | Commit the candidate configuration to the running configuration. |
(config-if)#exit | Exit interface mode. |
(config)#interface eth1 | Enter interface mode for eth1. |
(config-if)#ip address 1.1.1.3/24 | Configure the IP address for interface eth1 to be in network 1. |
(config-if)#commit | Commit the candidate configuration to the running configuration. |
(config-if)#exit | Exit interface mode. |
(config)#router vrrp 1 eth2 | Create a VRRP instance for interface eth2. |
(config-router)#virtual-ip 2.2.2.1 | Configure R3 as the backup. |
(config-router)#advertisement-interval 100 | Configure the default value for the advertisement interval. The configurable range is 5 to 4095 centi seconds (value must be a multiple of 5). |
(config-router)#priority 254 | Configure the priority for R3. The configurable range is 1-255. |
(config-router)#preempt-mode true | Set true as the default value for the field. |
(config-router)# v2-compatible | Enable the v2-compatible |
(config-router)#authentication text abcd | Configure the authentication text to specify that as simple text for vrrpv2 packets, accept only 8 characters |
(config-router)#enable | Enable the VRRP session on the router. |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
(config-router)#exit | Exit Router mode. |
#configure terminal | Enter the Configure mode. |
(config)#router vrrp 1 eth2 | Create a VRRP instance for interface eth2. |
(config-router)#disable | Disable the VRRP session. |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
(config-router)#exit | Exit Router mode. |
(config)#configure terminal | Enter the Configure mode. |
(config)#bridge 1 protocol rstp vlan-bridge | Create a RSTP VLAN aware bridge. |
(config)#vlan 1001-1002 bridge 1 | Create VLAN 1001,1002 and map it to bridge 1. |
(config)#interface xe29 | Enter interface mode. |
(config-if)#switchport | Configure switch port. |
(config-if)#bridge-group 1 spanning-tree disable | Configure bridge group to l2 interface with spanning-tree Disable. |
(config-if)#switchport mode trunk | Configure switch port mode as trunk. |
(config-if)#switchport trunk allowed vlan add 1001,1002 | Allow vlan 1001 ,1002 on the interface. |
(config-if)#interface vlan1.1001 | Enter the vlan interface |
(config-if)#ip address 10.1.1.2/24 | Configure ipv4 address |
(config-if)#ipv6 address 1000:1::2/32 | Configure ipv6 address |
(config-if)#ipv6 router ospf area 0.0.0.0 | Tag ospfv3 instance on interface with area 0 |
(config-if)#exit | Exit the interface mode |
(config)#router vrrp 1 vlan1.1001 | Create a new ipv4 VRRP instance for interface vlan1.1001 |
(config-router)#virtual-ip 10.1.1.1 | Set the virtual IP address for the VRRP session |
(config-router)#priority 150 | Configure the priority to 150 |
(config-router)#circuit-failover xe41 70 | Configure the priority-delta value to be 70. In case of failover, this priority-delta value is subtracted from the current VR Master. |
(config-router)#circuit-failover xe50/1 10 | Configure the priority-delta value to be 10. In case of failover, this priority-delta value is subtracted from the current VR Master. |
(config-router)#circuit-failover xe50/2 30 | Configure the priority-delta value to be 10. In case of failover, this priority-delta value is subtracted from the current VR Master. |
(config-router)#v2-compatible | Enable the v2-compatible |
(config-router)#authentication text abcd | Configure the authentication text to specify that as simple text for vrrpv2 packets, accept only 8 characters. |
(config-router)#enable | Enable the VRRP session on the router. |
(config-router)#commit | Commit the configuration on the node |
(config-router)#exit | Exit the router mode. |
(config)#router ipv6 vrrp 1 vlan1.1001 | Create a new ipv6 VRRP instance for interface vlan1.1001. |
(config-router)#virtual-ipv6 fe80::1 | Set the virtual IPv6 address for the VRRP session. |
(config-router)#priority 150 | Configure the priority to 150 |
(config-router)#circuit-failover xe41 70 | Configure the priority-delta value to be 70. In case of failover, this priority-delta value is subtracted from the current VR Master. |
(config-router)#circuit-failover xe50/1 10 | Configure the priority-delta value to be 10. In case of failover, this priority-delta value is subtracted from the current VR Master. |
(config-router)#circuit-failover xe50/2 30 | Configure the priority-delta value to be 10. In case of failover, this priority-delta value is subtracted from the current VR Master. |
(config-router)#enable | Enable the VRRP session on the router. |
(config-router)#commit | Commit the configuration on the node |
(config-router)#exit | Exit the router mode |
(config)#interface xe50/1 | Enter interface mode |
(config-if)#ip address 20.1.1.1/24 | Configure ipv4 address |
(config-if)#ipv6 address 2000::1/64 | Configure ipv6 address |
(config-if)#ipv6 router ospf area 0.0.0.0 | Tag ospfv3 instance on interface with area 0 |
(config-if)#interface xe50/2 | Enter interface mode |
(config-if)#ip address 30.1.1.1/24 | Configure ipv4 address |
(config-if)#ipv6 address 3000::1/64 | Configure ipv6 address |
(config-if)#ipv6 router ospf area 0.0.0.0 | Tag ospfv3 instance on interface with area 0 |
(config-if)#interface xe41 | Enter interface mode |
(config-if)#ip address 60.1.1.1/24 | Configure ipv4 address |
(config-if)#ipv6 address 6000::1/64 | Configure ipv6 address |
(config-if)#ipv6 router ospf area 0.0.0.0 | Tag ospfv3 instance on interface with area 0 |
(config-if)#commit | Commit the configuration on the node |
(config-if)#exit | Exit interface and configure mode |
(config)#bridge 1 protocol rstp vlan-bridge | Create a RSTP VLAN aware bridge with bridge-id. |
(config)#vlan 1001-1002 bridge 1 | Create VLAN 1001,1002 and map it to bridge 1 |
(config)#interface xe31 | Enter interface mode |
(config-if)#switchport | Configure switch port |
(config-if)#bridge-group 1 spanning-tree disable | Configure bridge group to l2 interface with spanning-tree Disable |
(config-if)#switchport mode trunk | Configure switch port mode as trunk |
(config-if)#switchport trunk allowed vlan add 1001,1002 | Allow vlan 1001 ,1002 on the interface |
(config-if)#interface vlan1.1001 | Enter the vlan interface |
(config-if)#ip address 10.1.1.3/24 | Configure ipv4 address |
(config-if)#ipv6 address 1000:1::3/32 | Configure ipv6 address |
(config-if)#ipv6 router ospf area 0.0.0.0 | Tag ospfv3 instance on interface with area 0 |
(config-if)#commit | Commit the configuration on the node |
(config-if)#exit | Exit interface mode |
(config)#router vrrp 1 vlan1.1001 | Create a router ipv4 VRRP instance for interface vlan1.1001. |
(config-router)#virtual-ip 10.1.1.1 | Set the virtual IP address for the VRRP session. |
(config-router)#priority 50 | Configure the priority to 50 (less than 150), because R2 is the VR Backup router. |
(config-router)#v2-compatible | Enable the v2-compatible |
(config-router)#authentication text abcd | Configure the authentication text to specify that as simple text for vrrpv2 packets, accept only 8 characters. |
(config-router)#enable | Enable the VRRP session |
(config-router)#commit | Commit the configuration on the node |
(config-router)#exit | Exit the router mode |
(config)#router ipv6 vrrp 1 vlan1.1001 | Create a router ipv6 VRRP ipv6 instance for interface vlan1.1001. |
(config-router)#virtual-ipv6 fe80::1 | Set the virtual IPv6 address for the VRRP session. |
(config-router)#priority 50 | Configure the priority to 50 (less than 150), because R2 is the VR Backup router. |
(config-router)#commit | Commit the configuration on the node |
(config-router)#exit | Exit the router mode |
(config)#interface xe41 | Enter interface mode |
(config-if)#ip address 80.1.1.1/24 | Configure ipv4 address |
(config-if)#ipv6 address 8000::1/64 | Configure ipv6 address |
(config-if)#ipv6 router ospf area 0.0.0.0 | Tag ospfv3 instance on interface with area 0 |
(config-if)#interface xe42 | Enter interface mode |
(config-if)#ip address 90.1.1.1/24 | Enter the tracked interface |
(config-if)#ipv6 address 9000::1/64 | Configure ipv6 address |
(config-if)#ipv6 router ospf area 0.0.0.0 | Tag ospfv3 instance on interface with area 0 |
(config-if)#commit | Commit the configuration on the node |
(config-if)#exit | Exit interface and configure mode |
#configure terminal | Enter the Configure mode. |
(config)#interface xe1 | Enter Interface configuration mode. |
(config-if)#ip address 5.5.5.90/24 | Configure IP address on the interface. |
(config-if)#commit | Commit the candidate configuration to the running configuration. |
(config-if)#exit | Exit Router mode. |
(config)#router vrrp 1 xe1 | Configure VRRP on DUT with Virtual router Identifier as 1 on the interface xe1. |
(config-router)#virtual-ip 5.5.5.190 | Configure Virtual-IP address as the interface IP address of Owner which is not actually present in the LAN. |
(config-router)#v2-compatible | Enable the v2-compatible |
(config-router)#authentication text abcd | Configure the authentication text to specify that as simple text for vrrpv2 packets, accept only 8 characters |
(config-router)#enable | Enable VRRP session on DUT. |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
(config-router)#exit | Exit Router mode. |
(config)#vrrp compatible-v2 enable | Enable VRRP-Backward compatibility feature on a VRRPv3 running router. |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
(config-router)#exit | Exit Router mode. |
#configure terminal | Enter the Configure mode. |
(config)# interface xe1 | Enter Interface configuration mode. |
(config-if)#ip address 5.5.5.100/24 | Configure IP address on the interface. |
(config-if)#commit | Commit the candidate configuration to the running configuration. |
(config-if)#exit | Exit Router mode. |
(config)#router vrrp 1 xe1 | Configure VRRP on DUT with Virtual router Identifier as 1 on the interface xe1. |
(config-router)#virtual-ip 5.5.5.190 | Configure Virtual-IP address as the interface IP address of Owner which is not actually present in the LAN. |
(config-router)#v2-compatible | Enable the v2-compatible |
(config-router)#authentication text abcd | Configure the authentication text to specify that as simple text for vrrpv2 packets, accept only 8 characters |
(config-router)#enable | Enable VRRP session on DUT. |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
(config-router)#exit | Exit Router mode. |
#configure terminal | Enter the Configure mode. |
(config)#router ospf 1 | Configure the routing process and specify the process ID (1). The process ID should be a unique integer. |
(config-router)#ospf router-id 10.10.10.181 | Specify the OSPF router ID. |
(config-router)#timers spf exp 0 0 | Set timers to minimum time for quick convergence. |
(config-router)#network 10.10.10.0/24 area 0 | Define one interface (10.10.10.0/24) on which OSPF runs and associate the area ID (0). |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
(config-router)#exit | Exit router VRRP mode. |
#configure terminal | Enter the Configure mode. |
(config)#router ospf 1 | Configure the routing process and specify the process ID (1). The process ID should be a unique integer. |
(config-router)#ospf router-id 10.10.12.6 | Specify the OSPF router ID. |
(config-router)#area 1 stub | Define area 1 as a stub network. |
(config-router)#network 10.10.10.0/24 area 0 | Define one interface (10.10.10.0/24) on which OSPF runs and associate the area ID (0). |
(config-router)#network 10.10.12.0/24 area 1 | Define the other interface (10.10.12.0/24) on which OSPF runs and associate the area ID (1) |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
(config-router)#exit | Exit router VRRP mode. |
#configure terminal | Enter the Configure mode. |
(config)#router ospf 1 | Configure the routing process, and specify the process ID (1). The process ID should be a unique integer |
(config-router)#ospf router-id 10.10.12.251 | Specify the OSPF router ID. |
(config-router)#area 1 stub | Define area 1 as a stub network. |
(config-router)#network 10.10.10.0/24 area 0 | Define one interface (10.10.10.0/24) on which OSPF runs and associate the area ID (0). |
(config-router)#network 10.10.12.0/24 area 1 | Define the other interface (10.12.10.0/24) on which OSPF runs and associate the area ID (1) |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
(config-router)#exit | Exit router VRRP mode. |
#config terminal | Enter the Configure mode. |
(config)#hostname SW1 | Assign the hostname for the router. |
SW1(config)# bridge 1 protocol rstp vlan-bridge | Create bridge |
SW1(config)#vlan database | Enter to VLAN database |
SW1(config-vlan)#vlan 2-1002 bridge 1 state enable | Create VLANs |
SW1(config-vlan)#exit | Exit the VLAN database mode |
SW1(config)# int po1 | Enter the interface mode |
SW1(config-if)#switchport | Configure the interface as Layer 2 |
SW1(config-if)# bridge-group 1 | Assign the bridge to the interface. |
SW1(config-if)#switchport mode trunk | Configure the interface as trunk mode |
SW1(config-if)#switchport trunk allowed vlan all | Configure the interface to allow all VLAN IDs |
(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW1(config-if)#exit | Exit the interface mode |
SW1(config)# int xe15 | Enter the interface mode |
SW1(config-if)# channel-group 1 mode active | Add the interface as member of LAG interface |
SW1(config-if)# int xe31 | Enter the interface mode |
SW1(config-if)# channel-group 1 mode active | Add the interface as member of LAG interface |
SW1(config-if)# int xe36 | Enter the interface mode |
SW1(config-if)#switchport | Configure the interface as Layer 2 |
SW1(config-if)# bridge-group 1 | Assign the bridge to the interface. |
SW1(config-if)#switchport mode trunk | Configure the interface as trunk mode |
SW1(config-if)#switchport trunk allowed vlan all | Configure the interface to allow all VLAN IDs |
SW1(config-if)#exit | Exit the interface mode |
SW1(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW1(config-if)#exit | Exit the interface mode. |
#config terminal | Enter the Config terminal |
(config)#hostname TOR1 | Assign the hostname to the router |
TOR1(config)# bridge 1 protocol rstp vlan-bridge | Configure the bridge |
TOR1(config)#vlan database | Enter the VLAN database |
TOR1(config-vlan)#vlan 2-1002 bridge 1 state enable | Configure VLANs |
TOR1(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
TOR1(config-vlan)#exit | Exit the VLAN database |
TOR1(config)# int po1 | Enter the interface mode |
TOR1(config-if)#switchport | Configure the interface as L2 |
TOR1(config-if)# bridge-group 1 | Assign the bridge to the interface |
TOR1(config-if)#switchport mode trunk | Configure the interface as trunk mode |
TOR1(config-if)#switchport trunk allowed vlan all | Configure to allow all the VLANs |
TOR1(config-if)#commit | Commit the candidate configuration to the running configuration. |
TOR1(config-if)#exit | Exit the interface mode |
TOR1(config)# int xe15 | Enter the interface mode |
TOR1(config-if)# channel-group 1 mode active | Assign the interface as member of LAG interface |
TOR1(config-if)#exit | Exit the interface mode |
TOR1(config)#interface xe7 | Enter interface mode. |
TOR1(config)#switchport | Configure as switchport L2 interface. |
TOR1(config)#mcec domain configuration | Enter the MCEC mode |
TOR1(config-mcec-domain)#domain-system-number 1 | Assign the domain system number for MLAG interface. |
TOR1(config-mcec-domain)#domain-address 1111.2222.3333 | Assign the domain address |
TOR1(config-mcec-domain)#domain-hello-timeout short | Assign the domain hello timeout |
TOR1(config-mcec-domain)#intra-domain-link xe7 | Assign the interface as IDL |
TOR1(config-mcec-domain)#commit | Commit the candidate configuration to the running configuration. |
TOR1(config-mcec-domain)#exit | Exit the MCEC domain |
TOR1(config)#interface lo | Enter the interface mode |
TOR1(config-if)#ip add 1.1.1.1/32 secondary | Assign IP address to the interface |
TOR1(config-if)#int xe11 | Enter the interface mode |
TOR1(config-if)#ip add 20.20.20.1/24 | Assign IP address to the interface |
TOR1(config-if)#commit | Commit the candidate configuration to the running configuration. |
TOR1(config-if)#exit | Exit the interface mode |
TOR1(config)#router ospf 100 | Configure the routing process and specify the process ID (100). The process ID should be a unique integer. |
TOR1(config-router)#network 20.20.20.1/24 area 0 | Add the network to the OSPF process |
TOR1(config-router)#network 1.1.1.1/32 area 0 | Define one interface (1.1.1.1/32) on which OSPF runs and associate the area ID (0). |
TOR1(config-router)#redistribute connected | Redistribute the connected routes |
TOR1(config-router)#commit | Commit the candidate configuration to the running configuration |
TOR1(config-router)#exit | Exit the OSPF process |
TOR1(config)#interface mlag1 | Enter mlag1 interface |
TOR1(config)#switchport | Configure as switchport L2 interface |
TOR1(config)#bridge-group 1 | Assign the bridge to the interface |
TOR1(config)#switchport mode trunk | Make the interface trunk mode |
TOR1(config)#switchport trunk allowed vlan all | Configure to allow all vlans |
TOR1(config)#int po1 | Enter the interface mode |
TOR1(config-if)#mlag 1 | Redistribute the connected routes |
TOR1(config-if)#exit | Exit the interface mode |
TOR1(config)#int vlan1.2 | Enter interface mode |
TOR1(config-if)#ip address 10.10.10.1/24 | Assign IP address |
TOR1(config-if)#exit | Exit the interface mode |
TOR1(config)#router vrrp 1 vlan1.2 | Create the VRRP process |
TOR1(config-router)# virtual-ip 10.10.10.1 owner | Assign the virtual IP address to VRRP |
TOR1(config-router)#enable | Enable the VRRP process |
TOR1(config-router)#commit | Commit the candidate configuration to the running configuration. |
TOR1(config-router)#exit | Exit the VRRP mode |
#config terminal | Enter the Config terminal |
(config)#hostname TOR2 | Assign the hostname to the router |
TOR2(config)# bridge 1 protocol rstp vlan-bridge | Configure the bridge |
TOR2(config)#vlan database | Enter the VLAN database |
TOR2(config-vlan)#vlan 2-1002 bridge 1 state enable | Configure VLANs |
TOR2(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
TOR2(config-vlan)#exit | Exit the VLAN database |
TOR2(config)# int po1 | Enter the interface mode |
TOR2(config-if)#switchport | Configure the interface as L2 |
TOR2(config-if)# bridge-group 1 | Assign the bridge to the interface |
TOR2(config-if)#switchport mode trunk | Configure the interface as trunk mode |
TOR2(config-if)#switchport trunk allowed vlan add 2 | Configure to add the VLAN 2 to the receiving packet. |
TOR2(config-if)#commit | Commit the candidate configuration to the running configuration. |
TOR2(config-if)#exit | Exit the interface mode |
TOR2(config)# int xe32 | Enter the interface mode |
TOR2(config-if)# channel-group 1 mode active | Assign the interface as member of LAG interface |
TOR2(config-if)#exit | Exit the interface mode |
TOR2(config)#interface xe7 | Enter interface mode |
TOR2(config)#switchport | Configure as switchport L2 interface |
TOR2(config)#mcec domain configuration | Enter the MCEC mode |
TOR2(config-mcec-domain)#domain-system-number 2 | Assign the domain system number for MLAG interface. |
TOR2(config-mcec-domain)#domain-address 1111.2222.3333 | Assign the domain address |
TOR2(config-mcec-domain)#domain-hello-timeout short | Assign the domain hello timeout |
TOR2(config-mcec-domain)#intra-domain-link xe7 | Assign the interface as IDL |
TOR2(config-mcec-domain)#commit | Commit the candidate configuration to the running configuration. |
TOR2(config-mcec-domain)#exit | Exit the MCEC domain |
TOR2(config)#interface mlag1 | Enter mlag1 interface |
TOR2(config)#switchport | Configure as switchport L2 interface |
TOR2(config)#bridge-group 1 | Assign the bridge to the interface |
TOR2(config)#switchport mode trunk | Make the interface trunk mode |
TOR2(config)#switchport trunk allowed vlan all | Configure to allow all vlans |
TOR2(config)# int po1 | Enter the interface mode |
TOR2(config-if)# mlag 1 | Create the MLAG interface. |
TOR2(config-if)#commit | Commit the candidate configuration to the running configuration. |
TOR2(config-if)#exit | Exit the interface mode |
TOR2(config)#interface lo | Enter the interface mode |
TOR2(config-if)#ip add 2.2.2.2/32 secondary | Assign IP address to the interface |
TOR2(config-if)#int xe5 | Enter the interface mode |
TOR2(config-if)#ip add 30.30.30.1/24 | Assign IP address to the interface |
TOR2(config-if)#commit | Commit the candidate configuration to the running configuration. |
TOR2(config-if)#exit | Exit the interface mode |
TOR2(config)#router ospf 100 | Enter the OSPF router mode |
TOR2(config-router)#network 30.30.30.1/24 area 0 | Add the network to the OSPF process |
TOR2(config-router)#network 2.2.2.2/32 area 0 | Add the network to the OSPF process |
TOR2(config-router)#redistribute connected | Redistribute the connected routes |
TOR2(config-router)#commit | Commit the candidate configuration to the running configuration. |
TOR2(config-router)#exit | Exit the OSPF process |
TOR2(config)#int vlan1.2 | Enter interface mode |
TOR2(config-if)#ip address 10.10.10.2/24 | Assign IP address |
TOR2(config-if)#exit | Exit the interface mode |
TOR2(config)#router vrrp 1 vlan1.2 | Create the VRRP process |
TOR2(config-router)# virtual-ip 10.10.10.1 | Assign the virtual IP address to VRRP |
TOR2(config-router)#enable | Enable the VRRP process |
TOR2(config-router)#commit | Commit the candidate configuration to the running configuration. |
TOR2(config-router)#exit | Exit the VRRP mode |
#config terminal | Enter the Config terminal |
(config)#hostname SW2 | Assign the hostname to the router |
SW2(config)# bridge 1 protocol rstp vlan-bridge | Configure the bridge |
SW2(config)#vlan database | Enter the VLAN database |
SW2(config-vlan)#vlan 2-1002 bridge 1 state enable | Configure VLANs |
SW2(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-vlan)#exit | Exit the VLAN database |
SW2(config)# int xe11 | Enter the interface mode |
SW2(config-if)#ip address 20.20.20.2/24 | Assign IP address to the interface |
SW2(config-if)# int xe5 | Enter the interface mode |
SW2(config-if)#ip address 30.30.30.2/24 | Assign IP address to the interface |
SW2(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-if)# int xe46 | Enter the interface mode |
SW2(config-if)#ip address 40.40.40.1/24 | Assign IP address to the interface |
SW2(config-if)#int lo | Enter the interface mode |
SW2(config-if)#ip add 3.3.3.3/32 secondary | Assign IP address to the interface |
SW2(config-if)#int xe32 | Enter the interface mode |
SW2(config-if)#ip add 50.50.50.2/24 | Assign IP address to the interface |
SW2(config-if)#exit | Exit interface mode |
SW2(config)# router ospf 100 | Enter OSPF router |
SW2(config-router)# network 3.3.3.3/32 area 0 | Add the IP address to the OSPF process |
SW2(config-router)# network 20.20.20.0/24 area 0 | Add the IP address to the OSPF process |
SW2(config-router)# network 30.30.30.0/24 area 0 | Add the IP address to the OSPF process |
SW2(config-router)#network 50.50.50.2/24 area 0 | Add the IP address to the OSPF process |
SW2(config-router)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-router)#exit | Exit the OSPF mode |
TOR1#config terminal | Enter the config terminal. |
TOR1(config)#ip vrf vrf1 | Configure VRF1. |
TOR1(config-vrf)#rd 1:1 | Configure rd 1:1. |
TOR1(config-vrf)#route-target both 1:1 | Configure the route target. |
TOR1(config-vrf)#commit | Commit the candidate configuration to the running configuration. |
TOR1(config-vrf)#end | Returns to privilege mode. |
TOR2#config terminal | Enter the config terminal. |
TOR2(config)#ip vrf vrf1 | Configure VRF1. |
TOR2(config-vrf)#rd 1:1 | Configure rd 1:1. |
TOR2(config-vrf)#route-target both 1:1 | Configure the route target. |
TOR2(config-vrf)#commit | Commit the candidate configuration to the running configuration. |
TOR2(config-vrf)#end | Returns to privilege mode. |